PowerLanguage

PowerLanguage.NET Help

PowerLanguage Namespace

Namespace Hierarchy

Classes

Class | Description
AllowSendOrdersAlwaysAttribute | The class that defines AllowSendOrdersAlwaysAttribute.
Array2DSeries<T> | 2D array series class with behavior similar to PowerLanguage version.
Array2DSimple<T> | 2D array simple class with behavior similar to PowerLanguage version.
ArraySeries<T> | Array series class with behavior similar to PowerLanguage version.
ArraySimple<T> | Array simple class with behavior similar to PowerLanguage version.
ArrowObjectException | The exception that is displayed when a "create drawings" error occurs.
CalcAtOpenNextBarAttribute | The class that defines CalcOnNextBarOpenAttribute.
ConstantObject<T> | ISeries implementation that emulates behavior of the simple property with a constant value.
CStudyAbstract | Base class for studies.
CStudyControl | Base class for studies.
CustomInstrument | Allows to access data series of another symbol without adding it as an additional data series. Note: after using CustomInstrument you need to call the Dispose() method for proper operation of MultiCharts application.
CustomInstrumentBase | Base class of custom instrument.
CustomInstrumentBase.InstrumentSettingsImpl |
CustomInstrumentBase.SeriesImpl<T> |
DrawContext | Structure containing information necessary for drawing on the chart.
DrawingObjectException | The exception that is displayed when working with drawings.
ExitFromOneEntryOnceAttribute | The class that defines ExitFromOneEntryOnceAttribute.
FunctionObject<T> | Class that describes a function object.
InputAttribute | Class that contains information about the input attribute.
InputInfo |
IOGModeAttribute | The class that defines IOGModeAttribute.
Lambda<T> | The lambda implementation of ISeries.
LambdaRef<T> | The lambda implementation of IVar.
MouseEventsAttribute | The class that defines MouseEventsAttribute.
Order | Class that contains information about the order.
OrderCreator | Allows order generation.
OrderExit | Class that contains information about the exit order.
Pair<T> | Specialization of generic Pair class
Pair<T1,T2> | Generic class for pair values
Price |
PriceCtx | Utility class for prices.
PublicFunctions | A set of public functions for common use.
RecoverDrawingsAttribute | The class that defines RecoverDrawingsAttribute.
ResourceUtils | Resource Utils class
SameAsSymbolAttribute | Setting that defines whether the indicator is marked "Same As Symbol" or not.
SessionNotFoundException | The exception displayed when a session is not found.
SessionObject | The class that defines a session object.
SessionsParser | Sessions parser class
SkipIdenticalTicksAttribute | The class that defines SkipIdenticalTicksAttribute.
StrategyOnlyKeywordException | The exception that is displayed when a strategy keyword is used outside of a strategy.
StudyRuntimeException | The exception that is displayed when a study runtime error occurs.
SymbolNotFoundException | The exception displayed when a symbol is not found.
TextObjectException | The exception that is displayed when working with text objects.
TrendLineObjectException | The exception that is displayed when working with trend line objects.
UpdateOnEveryTickAttribute | The class that defines UpdateOnEveryTickAttribute.
VariableObject<T> | Class for simple variables, provides access to the value of the variable in the current context of study execution.
VariableSeries<T> | Class that allows access to and preserves historical variable values (for a series of variables).
WrongContextException | The exception that is displayed when a context is wrong.

Interfaces

Interface | Description
IAlert | An interface for working with alerts.
IApplicationInfo | Environment access interface.
IArray<T> | The array access interface.
IArray2D<T> | The 2D array access interface.
IArraySeries<T> | The array series access interface.
IArraySeries2D<T> | The 2D array series access interface.
IArrowContainer | Container for a collection of specific IArrowObject.
IArrowObject | Arrow Drawings access interface.
ICalculationControl | An interface for controlling study calculations.
ICalculationInfo | An interface for accessing current execution context.
IChartCommands | Charting commands access interface.
IChartCustomDrawer | Interface for custom drawing. This interface realizes a class that can add drawings to the chart at different stages.
IChartCustomDrawRegistrator | Interface for adding/deleting custom drawers.
ICustomToolBar | Interface for accessing custom toolbar.
IDataLoader | Data loading.
IDataLoaderResult | The result of data loading.
IDOMData | Interface for DOM data access.
IDrawDataEnviroment | An interface for accessing "Draw" data environment.
IDrawObject | A base interface for accessing drawing objects.
IDrawSymbolBars | An interface for accessing "Draw" symbol bars.
IExpertCommentary | Expert commentary.
IFunctionObject<T> | An interface that describes a function object.
IIndicatorInfo |
IInstrument | Interface for series data access.
IInstrumentSettings | An interface for accessing symbol information.
IInstrumentSettingsTZI |
IInstrumentTPO | Interface for TPO series data access.
IMarketPosition | An interface that provides information about the position.
IOrderCreator | An interface for order creation.
IOrderMarket | An interface describing Market Order.
IOrderObject | Base interface for orders.
IOrderPriced | An interface describing Price Order.
IOrderStopLimit | An interface describing StopLimit Order.
IOutput | An interface for accessing the Output Window.
IPlotAttributesArray<T> | Interface to access the plot attributes array.
IPlotObject | An interface providing access to plot manipulations.
IPlotObjectBase<T> | Common base interface for plot object.
IPlotObjectStr | An interface providing access to string plot manipulations.
IPortfolioPerformance | An interface providing access to portfolio performance.
IRectangleContainer | Container for IRectangleObject collection.
IRectangleObject | Rectangle drawing access interface.
IROList<T> | Base interface for the read-only list.
IROListObjectEx<T> | An interface describing enumerable read-only list.
ISeries<T> | Base interface for functions, series variables, and price series. Provides access to historical values of inherited objects.
ISeriesSymbolData | Interface for access to symbol's price and time data.
ISeriesSymbolDataRand | Interface for access to symbol's price and time data of any bar (no Max Number of Bar Reference limits).
ISignalInfo |
IStatusLine | Interface for an information reflected in Status Line.
IStrategy | An interface describing the strategy.
IStrategyPerformance | An interface for accessing strategy information.
IStudy | Common base interface for data access.
IStudyInfo |
ISymbolsStorage | An interface for accessing symbol storage.
ITextContainer | Container for ITextObject.
ITextObject | An interface for accessing Text Drawings.
ITPOData | Interface for TPO data access.
ITPODataRand | Interface for access to symbol's TPO data of any bar (no Max Number of Bar Reference limits).
ITPODynamicSettings | Interface for accessing the dynamically retrievable settings of the TPO charts.
ITPOSettings | Interface for TPO settings access.
ITrade | An interface for accessing trade’s information.
ITradeOrder | An entry-point interface to information on trade’s orders (access to entry and exit of the trade).
ITrendLineContainer | Container for ITrendLineObject collection.
ITrendLineObject | TrendLine Drawing access interface.
IVar<T> | The base interface for variables.

Structures

Structure | Description
Bar | The structure that defines Bar data.
BarPriceLevels | Structure describes volume data by showing at specific prices for a bar (Bar's Volume Profile).
ChartPoint | The structure that defines a point on the chart.
Contracts | Class that contains information about contracts.
DataRequest | Class that describes data requests.
DOMPrice | The structure that defines a DOM price.
InstrumentDataRequest | The structure that defines instrument data request.
MouseClickArgs | The structure that defines mouse-click arguments.
PlotAttributes | A structure for plots initialization.
PriceLevel | Structure that describes a price level for Volume Profile. BarPriceLevels
Resolution | The structure that defines a resolution.
SOrderParameters | A structure containing information for order creation.
StatusLineData |
StringPlotAttributes | A structure for string plot initialization.
TPOBar | TODO:
TPOBlock | TODO:
TPOBlocks | TODO:
TPOProfile | Structure describes volume data by showing at specific prices for a bar (Bar's Volume Profile).

Delegates

Delegate | Description
CustomInstrumentBase.TBarFldGetter<T> |
GetLambda<T> | Delegate GetLambda
LoadDataCallback | LoadDataCallback delegate.
SetLambda<T> | Delegate SetLambda
ToolBarAction | Defines signature of the callback function, which will be called when access to chart's toolbar is requested. Contains the toolbar as a parameter to be sent.

Enumerations

Enumeration | Description
BoxSizeType | Enumeration represents the boxsize value type for Renko or Point and Figure, or reversal type for Kagi
BreakdownType | Enumeration represents possible values for Breakdown type.
BuildVolumeOn | Enumeration that describes Instrument's "build volume on" setting.
CalculationReason | Enumeration that describes the reason for the calculation (i.e. calculation was triggered by a new bar/tick or initialized after left-click on the chart).
ChartType | Enumeration that describes chart types of instruments.
ChartTypeCommonOptions | Enumeration represents common options for not regular chart types.
Contracts.EContractsType | Enumeration describing types of contracts.
CumulativeDeltaAttributes | Enumeration represents options for Cumulative Delta and Volume Delta chart types.
CumulativeDeltaChartType | Enumeration represents Breakdown type for Cumulative Delta and Volume Delta chart types.
DataLoadedEvent | Enumeration the describes reasons for making the LoadDataCallback callback.
DataRequestType | Enumeration that describes Data Range types in data request objects DataRequest
DeltaAttributes | Enumeration represents possible delta attributes.
DeltaType | Enumeration represents possible values for Delta type.
EAlertType | Enumeration describing alert types.
EApplicationCode | The code of the application that executes the study.
EArrowForms | Enumeration describing arrow forms.
EBarState | Enumeration describing bar state.
EDrawingSource | Enumeration describing drawing’s origin.
EDrawPhases | Enumeration describing chart drawing phases.
EMarketPositionSide | Enumeration describing market position side.
EOrderAction | Enumeration describing order action.
EPlotShapes | Enumeration describing plot shapes.
EPlotStyle | Enumeration describing plot shapes.
ERectPattern | Enumeration describing rectangle patterns.
EResolution | Enumeration describing resolution type.
ESpecOrdersMode | Enumeration describing special orders mode.
ESymbolCategory | Enumeration describing Symbol Category.
ESymbolSettingsType | Enumeration describing settings types.
ETextStyleH | Enumeration describing horizontal text alignment style.
ETextStyleV | Enumeration describing vertical text alignment style.
ETickTradedSide | Enumeration represents the trade side of the tick, i.e. ask or bid.
ETickTradedSideEx | Enumeration represents the extended trade side of the tick
ETLStyle | Enumeration describing trend line style. Applicable to rectangle drawings also.
ExitFromOneEntryOnce | Describes mode for processing exit orders.
FootPrintAttributes | Enumeration represents options for Volume Delta chart type.
FootPrintChartType | Enumeration represents the base elements type for Volume Delta chart type.
IOGMode | Enumeration describing IntrabarOrderGeneration (IOG) mode.
KagiOptions | Enumeration represents options for Kagi chart type.
KagiReversalType | Enumeration represents the reversal type of Kagi chart.
LineBreakOptions | Enumeration represents options for LineBreak chart type.
OptionType | Enumeration that describes option type.
OrderCategory | Enumeration describing order category.
OrderExit.EExitType | Enumeration describing exit type.
PlotAlignment | Output value alignment in Scanner's cell.
PlotFormat | Plots data format in Scanner's cell.
PointAndFigureBasis | Enumeration represents whether on Close or High/Low "Point And Figure" chart will be based on.
PointAndFigureOptions | Enumeration represents options for Point And Figure chart type.
RenkoBasis | Enumeration represents whether on Close or OHLC "Renko" chart will be based on.
RenkoOptions | Enumeration represents options for Renko chart type.
RequestQuoteField | Enumeration that describes quote field for the request.
RequestTimeZone | Enumeration that describes time zone for the request.
SubscribeStatusLineMode |
TPOAttributes | Enumeration represents possible TPO attributes.
TPOBase | Enumeration describing TPO base.


AllowSendOrdersAlwaysAttribute Class

The class that defines AllowSendOrdersAlwaysAttribute.

For a list of all members of this type, see AllowSendOrdersAlwaysAttribute Members .

System.Object
Attribute
AllowSendOrdersAlwaysAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class AllowSendOrdersAlwaysAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

AllowSendOrdersAlwaysAttribute Members | PowerLanguage Namespace


AllowSendOrdersAlwaysAttribute Members

AllowSendOrdersAlwaysAttribute overview

Public Instance Constructors

AllowSendOrdersAlwaysAttribute Overloaded. Initializes a new instance of the AllowSendOrdersAlwaysAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. AllowSendOrdersAlwaysAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

AllowSendOrdersAlwaysAttribute Class | PowerLanguage Namespace


AllowSendOrdersAlwaysAttribute Constructor

Initializes a new instance of the AllowSendOrdersAlwaysAttribute class.

Overload List

Initializes a new instance of the AllowSendOrdersAlwaysAttribute class.

public AllowSendOrdersAlwaysAttribute()

Initializes a new instance of the AllowSendOrdersAlwaysAttribute class.

public AllowSendOrdersAlwaysAttribute(bool)

See Also

AllowSendOrdersAlwaysAttribute Class | PowerLanguage Namespace


AllowSendOrdersAlwaysAttribute Constructor

Initializes a new instance of the AllowSendOrdersAlwaysAttribute class.

AllowSendOrdersAlwaysAttribute(
bool value
);

Parameters

value
AllowSendOrdersAlwaysAttribute value.

See Also

AllowSendOrdersAlwaysAttribute Class | PowerLanguage Namespace | AllowSendOrdersAlwaysAttribute Constructor Overload List


AllowSendOrdersAlwaysAttribute Constructor

Initializes a new instance of the AllowSendOrdersAlwaysAttribute class.

AllowSendOrdersAlwaysAttribute();

See Also

AllowSendOrdersAlwaysAttribute Class | PowerLanguage Namespace | AllowSendOrdersAlwaysAttribute Constructor Overload List


AllowSendOrdersAlwaysAttribute Properties

The properties of the AllowSendOrdersAlwaysAttribute class are listed below. For a complete list of AllowSendOrdersAlwaysAttribute class members, see the AllowSendOrdersAlwaysAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. AllowSendOrdersAlwaysAttribute value.

See Also

AllowSendOrdersAlwaysAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

AllowSendOrdersAlwaysAttribute.Value Property

Read-write property. AllowSendOrdersAlwaysAttribute value.

public bool Value { public get; public set; }

See Also

AllowSendOrdersAlwaysAttribute Class | PowerLanguage Namespace


Array2DSeries<T> Class

2D array series class with behavior similar to PowerLanguage version.

For a list of all members of this type, see Array2DSeries<T> Members .

System.Object
ArraySeriesAbstract<T>
Array2DSeries<T>

[DefaultMember(MemberName="Item")]
public sealed class Array2DSeries<T> : ArraySeriesAbstract<T>, IArray2D<T>, IArraySeries2D<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Array2DSeries<T> Members | PowerLanguage Namespace


Array2DSeries<T> Members

Array2DSeries<T> overview

Public Instance Constructors

Array2DSeries<T> Overloaded. Initializes a new instance of the Array2DSeries<T> class.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySeriesAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
Length1 | Read-only property. Returns the first dimension of 2D array series.
Length2 | Read-only property. Returns the second dimension of 2D array series.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Array2DSeries<T> Class | PowerLanguage Namespace


Array2DSeries`1 Constructor

Initializes a new instance of the Array2DSeries.

Overload List

Initializes a new instance of the Array2DSeries.

public Array2DSeries`1(IStudyControl,int,int)

Initializes a new instance of the Array2DSeries.

public Array2DSeries`1(IStudyControl,int,int,int)

See Also

Array2DSeries<T> Class | PowerLanguage Namespace


Array2DSeries<T> Constructor

Initializes a new instance of the Array2DSeries.

Array2DSeries<T>(
IStudyControl master,
int length1,
int length2
);

Parameters

master
The master object of 2D array series.
length1
The first dimension of 2D array series.
length2
The second dimension of 2D array series.

See Also

Array2DSeries<T> Class | PowerLanguage Namespace | Array2DSeries<T> Constructor Overload List


Array2DSeries<T> Constructor

Initializes a new instance of the Array2DSeries.

Array2DSeries<T>(
IStudyControl master,
int dataStream,
int length1,
int length2
);

Parameters

master
The master object of 2D array series.
dataStream
The data stream number.
length1
The first dimension of 2D array series.
length2
The second dimension of 2D array series.

See Also

Array2DSeries<T> Class | PowerLanguage Namespace | Array2DSeries<T> Constructor Overload List


Array2DSeries<T> Properties

The properties of the Array2DSeries<T> class are listed below. For a complete list of Array2DSeries<T> class members, see the Array2DSeries<T> Members topic.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySeriesAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
Length1 | Read-only property. Returns the first dimension of 2D array series.
Length2 | Read-only property. Returns the second dimension of 2D array series.

See Also

Array2DSeries<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

Array2DSeries`1.Item Property

Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.

new public T[,] this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression specifying the number of bars back.

Implements

IArraySeries2D<T>.Item

See Also

Array2DSeries<T> Class | PowerLanguage Namespace


Length1 Property

PowerLanguage.NET Help

Array2DSeries`1.Length1 Property

Read-only property. Returns the first dimension of 2D array series.

public int Length1 { public get; }

Implements

IArraySeries2D<T>.Length1

See Also

Array2DSeries<T> Class | PowerLanguage Namespace


Length2 Property

PowerLanguage.NET Help

Array2DSeries`1.Length2 Property

Read-only property. Returns the second dimension of 2D array series.

public int Length2 { public get; }

Implements

IArraySeries2D<T>.Length2

See Also

Array2DSeries<T> Class | PowerLanguage Namespace


Array2DSimple<T> Class

2D array simple class with behavior similar to PowerLanguage version.

For a list of all members of this type, see Array2DSimple<T> Members .

System.Object
ArraySimpleAbstract<T>
Array2DSimple<T>

[DefaultMember(MemberName="Item")]
public sealed class Array2DSimple<T> : ArraySimpleAbstract<T>, IArray2D<T>, IArraySeries2D<T>

Generic template parameters

T
Any type - double, int, string, etc

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Array2DSimple<T> Members | PowerLanguage Namespace


Array2DSimple<T> Members

Array2DSimple<T> overview

Public Instance Constructors

Array2DSimple<T> Overloaded. Initializes a new instance of the Array2DSimple<T> class.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySimpleAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
Length1 | Read-only property. Returns the first dimension of 2D array simple.
Length2 | Read-only property. Returns the second dimension of 2D array simple.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Array2DSimple<T> Class | PowerLanguage Namespace


Array2DSimple`1 Constructor

Initializes a new instance of the Array2DSimple.

Overload List

Initializes a new instance of the Array2DSimple.

public Array2DSimple`1(IStudyControl,int,int)

Initializes a new instance of Array2DSimple.

public Array2DSimple`1(IStudyControl,int,int,int)

See Also

Array2DSimple<T> Class | PowerLanguage Namespace


Array2DSimple<T> Constructor

Initializes a new instance of the Array2DSimple.

Array2DSimple<T>(
IStudyControl master,
int length1,
int length2
);

Parameters

master
The master object of 2D array simple.
length1
The first dimension of 2D array simple.
length2
The second dimension of 2D array simple.

See Also

Array2DSimple<T> Class | PowerLanguage Namespace | Array2DSimple<T> Constructor Overload List


Array2DSimple<T> Constructor

Initializes a new instance of Array2DSimple.

Array2DSimple<T>(
IStudyControl master,
int dataStream,
int length1,
int length2
);

Parameters

master
The master object of 2D array simple.
dataStream
The data stream number.
length1
The first dimension of 2D array simple.
length2
The second dimension of 2D array simple.

See Also

Array2DSimple<T> Class | PowerLanguage Namespace | Array2DSimple<T> Constructor Overload List


Array2DSimple<T> Properties

The properties of the Array2DSimple<T> class are listed below. For a complete list of Array2DSimple<T> class members, see the Array2DSimple<T> Members topic.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySimpleAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
Length1 | Read-only property. Returns the first dimension of 2D array simple.
Length2 | Read-only property. Returns the second dimension of 2D array simple.

See Also

Array2DSimple<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

Array2DSimple`1.Item Property

Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.

new public T[,] this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression specifying the number of bars back.

Implements

IArraySeries2D<T>.Item

See Also

Array2DSimple<T> Class | PowerLanguage Namespace


Length1 Property

PowerLanguage.NET Help

Array2DSimple`1.Length1 Property

Read-only property. Returns the first dimension of 2D array simple.

public int Length1 { public get; }

Implements

IArraySeries2D<T>.Length1

See Also

Array2DSimple<T> Class | PowerLanguage Namespace


Length2 Property

PowerLanguage.NET Help

Array2DSimple`1.Length2 Property

Read-only property. Returns the second dimension of 2D array simple.

public int Length2 { public get; }

Implements

IArraySeries2D<T>.Length2

See Also

Array2DSimple<T> Class | PowerLanguage Namespace


ArraySeries<T> Class

Array series class with behavior similar to PowerLanguage version.

For a list of all members of this type, see ArraySeries<T> Members .

System.Object
ArraySeriesAbstract<T>
ArraySeries<T>

[DefaultMember(MemberName="Item")]
public sealed class ArraySeries<T> : ArraySeriesAbstract<T>, IArray<T>, IArraySeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ArraySeries<T> Members | PowerLanguage Namespace


ArraySeries<T> Members

ArraySeries<T> overview

Public Instance Constructors

ArraySeries<T> Overloaded. Initializes a new instance of the ArraySeries<T> class.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySeriesAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing the bar located a specified number of bars back from the current bar.
Length | Read-only property. Returns the array series length.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ArraySeries<T> Class | PowerLanguage Namespace


ArraySeries`1 Constructor

Initializes a new instance of the ArraySeries.

Overload List

Initializes a new instance of the ArraySeries.

public ArraySeries`1(IStudyControl,int)

Initializes a new instance of the ArraySeries.

public ArraySeries`1(IStudyControl,int,int)

See Also

ArraySeries<T> Class | PowerLanguage Namespace


ArraySeries<T> Constructor

Initializes a new instance of the ArraySeries.

ArraySeries<T>(
IStudyControl master,
int length
);

Parameters

master
The master object of array simple.
length
The array series length.

See Also

ArraySeries<T> Class | PowerLanguage Namespace | ArraySeries<T> Constructor Overload List


ArraySeries<T> Constructor

Initializes a new instance of the ArraySeries.

ArraySeries<T>(
IStudyControl master,
int dataStream,
int length
);

Parameters

master
The master object of array simple.
dataStream
The data stream number.
length
The array series length.

See Also

ArraySeries<T> Class | PowerLanguage Namespace | ArraySeries<T> Constructor Overload List


ArraySeries<T> Properties

The properties of the ArraySeries<T> class are listed below. For a complete list of ArraySeries<T> class members, see the ArraySeries<T> Members topic.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySeriesAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing the bar located a specified number of bars back from the current bar.
Length | Read-only property. Returns the array series length.

See Also

ArraySeries<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

ArraySeries`1.Item Property

Read-only property. Returns information referencing the bar located a specified number of bars back from the current bar.

new public T[] this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression specifying the number of bars back.

Implements

IArraySeries<T>.Item

See Also

ArraySeries<T> Class | PowerLanguage Namespace


Length Property

PowerLanguage.NET Help

ArraySeries`1.Length Property

Read-only property. Returns the array series length.

public int Length { public get; }

Implements

IArraySeries<T>.Length

See Also

ArraySeries<T> Class | PowerLanguage Namespace


ArraySimple<T> Class

Array simple class with behavior similar to PowerLanguage version.

For a list of all members of this type, see ArraySimple<T> Members .

System.Object
ArraySimpleAbstract<T>
ArraySimple<T>

[DefaultMember(MemberName="Item")]
public sealed class ArraySimple<T> : ArraySimpleAbstract<T>, IArray<T>, IArraySeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ArraySimple<T> Members | PowerLanguage Namespace


ArraySimple<T> Members

ArraySimple<T> overview

Public Instance Constructors

ArraySimple<T> Overloaded. Initializes a new instance of the ArraySimple<T> class.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySimpleAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
Length | Read-only property. Returns the array series length.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ArraySimple<T> Class | PowerLanguage Namespace


ArraySimple`1 Constructor

Initializes a new instance of the ArraySimple.

Overload List

Initializes a new instance of the ArraySimple.

public ArraySimple`1(IStudyControl,int)

Initializes a new instance of the ArraySimple.

public ArraySimple`1(IStudyControl,int,int)

See Also

ArraySimple<T> Class | PowerLanguage Namespace


ArraySimple<T> Constructor

Initializes a new instance of the ArraySimple.

ArraySimple<T>(
IStudyControl master,
int length
);

Parameters

master
The master object of array simple.
length
The array simple length.

See Also

ArraySimple<T> Class | PowerLanguage Namespace | ArraySimple<T> Constructor Overload List


ArraySimple<T> Constructor

Initializes a new instance of the ArraySimple.

ArraySimple<T>(
IStudyControl master,
int dataStream,
int length
);

Parameters

master
The master object of array simple.
dataStream
The data stream number.
length
The array simple length.

See Also

ArraySimple<T> Class | PowerLanguage Namespace | ArraySimple<T> Constructor Overload List


ArraySimple<T> Properties

The properties of the ArraySimple<T> class are listed below. For a complete list of ArraySimple<T> class members, see the ArraySimple<T> Members topic.

Public Instance Properties

DefaultValue (inherited from PowerLanguage.ArraySimpleAbstract`1) |
Item | Overloaded. Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
Length | Read-only property. Returns the array series length.

See Also

ArraySimple<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

ArraySimple`1.Item Property

Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.

new public T[] this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression, specifying the number of bars back.

Implements

IArraySeries<T>.Item

See Also

ArraySimple<T> Class | PowerLanguage Namespace


Length Property

PowerLanguage.NET Help

ArraySimple`1.Length Property

Read-only property. Returns the array series length.

public int Length { public get; }

Implements

IArraySeries<T>.Length

See Also

ArraySimple<T> Class | PowerLanguage Namespace


ArrowObjectException Class

The exception that is displayed when a "create drawings" error occurs.

For a list of all members of this type, see ArrowObjectException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
DrawingObjectException
ArrowObjectException

[Serializable]
public class ArrowObjectException : DrawingObjectException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ArrowObjectException Members | PowerLanguage Namespace


ArrowObjectException Members

ArrowObjectException overview

Public Instance Constructors

ArrowObjectException Overloaded. Initializes a new instance of the ArrowObjectException class.

Public Instance Properties

Data (inherited from Exception) |
Error (inherited from DrawingObjectException) | Returns error code.
HelpLink (inherited from Exception) |
HResult (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object) |
GetBaseException (inherited from Exception) |
GetHashCode (inherited from Object) |
GetObjectData (inherited from DrawingObjectException) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) |
ToString (inherited from Exception) |

Protected Instance Constructors

ArrowObjectException Overloaded. Initializes a new instance of the ArrowObjectException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

ArrowObjectException Class | PowerLanguage Namespace


ArrowObjectException Constructor

Initializes a new instance of the ArrowObjectException class.

Overload List

Initializes a new instance of the ArrowObjectException class.

public ArrowObjectException(int)

Initializes a new instance of the ArrowObjectException class.

protected ArrowObjectException(SerializationInfo,StreamingContext)

See Also

ArrowObjectException Class | PowerLanguage Namespace


ArrowObjectException Constructor

Initializes a new instance of the ArrowObjectException class.

ArrowObjectException(
int errCode
);

Parameters

errCode
A code that describes the error.

See Also

ArrowObjectException Class | PowerLanguage Namespace | ArrowObjectException Constructor Overload List


ArrowObjectException Constructor

Initializes a new instance of the ArrowObjectException class.

ArrowObjectException(
SerializationInfo info,
StreamingContext context
);

See Also

ArrowObjectException Class | PowerLanguage Namespace | ArrowObjectException Constructor Overload List


Bar Structure

The structure that defines Bar data.

For a list of all members of this type, see Bar Members .

System.Object
Bar

public struct Bar : IEquatable<T>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Bar Members | PowerLanguage Namespace


Bar Members

Bar overview

Public Static Operators

Equality Operator | Indicates whether this instance and a specified object are equal.
Inequality Operator | Indicates whether this instance and a specified object are not equal.

Public Instance Properties

Close | Read-write property. Bar "Close" price value.
DownVolume | Read-write property. Bar "DownVolume" value.
EndOfSession | Read-write Property. Indicates that bar is the end of session bar.
High | Read-write property. Bar "High" price value.
Low | Read-write property. Bar "Low" price value.
Open | Read-write property. Bar "Open" price value.
OpenInterest | Read-write property. Bar "OpenInterest" value.
State | Read-write property. Bar "State" value.
TickID | Read-write property. TickID for tick-based resolution. Can be used for time measurement within one second.
TickTradedSide | Read-write property. Current tick traded side, i.e. ask or bid. ETickTradedSide.
TickTradedSideEx | Read-write property. Current extended tick traded side.
Time | Read-write property. Bar time.
TotalResolution | Read-write property. Bar "TotalResolution" value.
TotalVolume | Read-write property. Bar "TotalVolume" value.
UnchangedVolume | Read-write property. Bar "UnchangedVolume" value.
UpVolume | Read-write property. Bar "UpVolume" value.

Public Instance Methods

Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Bar Class | PowerLanguage Namespace


Bar Properties

The properties of the Bar structure are listed below. For a complete list of Bar structure members, see the Bar Members topic.

Public Instance Properties

Close | Read-write property. Bar "Close" price value.
DownVolume | Read-write property. Bar "DownVolume" value.
EndOfSession | Read-write Property. Indicates that bar is the end of session bar.
High | Read-write property. Bar "High" price value.
Low | Read-write property. Bar "Low" price value.
Open | Read-write property. Bar "Open" price value.
OpenInterest | Read-write property. Bar "OpenInterest" value.
State | Read-write property. Bar "State" value.
TickID | Read-write property. TickID for tick-based resolution. Can be used for time measurement within one second.
TickTradedSide | Read-write property. Current tick traded side, i.e. ask or bid. ETickTradedSide.
TickTradedSideEx | Read-write property. Current extended tick traded side.
Time | Read-write property. Bar time.
TotalResolution | Read-write property. Bar "TotalResolution" value.
TotalVolume | Read-write property. Bar "TotalVolume" value.
UnchangedVolume | Read-write property. Bar "UnchangedVolume" value.
UpVolume | Read-write property. Bar "UpVolume" value.

See Also

Bar Class | PowerLanguage Namespace


Close Property

PowerLanguage.NET Help

Bar.Close Property

Read-write property. Bar "Close" price value.

public double Close { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


DownVolume Property

PowerLanguage.NET Help

Bar.DownVolume Property

Read-write property. Bar "DownVolume" value.

public float DownVolume { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


EndOfSession Property

PowerLanguage.NET Help

Bar.EndOfSession Property

Read-write Property. Indicates that bar is the end of session bar.

public bool EndOfSession { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


High Property

PowerLanguage.NET Help

Bar.High Property

Read-write property. Bar "High" price value.

public double High { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


Low Property

PowerLanguage.NET Help

Bar.Low Property

Read-write property. Bar "Low" price value.

public double Low { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


Open Property

PowerLanguage.NET Help

Bar.Open Property

Read-write property. Bar "Open" price value.

public double Open { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


OpenInterest Property

PowerLanguage.NET Help

Bar.OpenInterest Property

Read-write property. Bar "OpenInterest" value.

public float OpenInterest { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


State Property

PowerLanguage.NET Help

Bar.State Property

Read-write property. Bar "State" value.

public EBarState State { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


TickID Property

PowerLanguage.NET Help

Bar.TickID Property

Read-write property. TickID for tick-based resolution. Can be used for time measurement within one second.

public uint TickID { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


TickTradedSide Property

PowerLanguage.NET Help

Bar.TickTradedSide Property

Read-write property. Current tick traded side, i.e. ask or bid. ETickTradedSide.

public ETickTradedSide TickTradedSide { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


TickTradedSideEx Property

PowerLanguage.NET Help

Bar.TickTradedSideEx Property

Read-write property. Current extended tick traded side.

public ETickTradedSideEx TickTradedSideEx { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

Bar.Time Property

Read-write property. Bar time.

public DateTime Time { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


TotalResolution Property

PowerLanguage.NET Help

Bar.TotalResolution Property

Read-write property. Bar "TotalResolution" value.

public uint TotalResolution { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


TotalVolume Property

PowerLanguage.NET Help

Bar.TotalVolume Property

Read-write property. Bar "TotalVolume" value.

public float TotalVolume { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


UnchangedVolume Property

PowerLanguage.NET Help

Bar.UnchangedVolume Property

Read-write property. Bar "UnchangedVolume" value.

public float UnchangedVolume { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


UpVolume Property

PowerLanguage.NET Help

Bar.UpVolume Property

Read-write property. Bar "UpVolume" value.

public float UpVolume { public get; public set; }

See Also

Bar Class | PowerLanguage Namespace


Bar Methods

The methods of the Bar structure are listed below. For a complete list of Bar structure members, see the Bar Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Bar Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

Bar.Equals Method

Indicates whether the current object is equal to another object of the same type.

Overload List

Indicates whether the current object is equal to another object of the same type.

public bool Equals(Bar)

Indicates whether this instance and a specified object are equal.

public override bool Equals(object)

See Also

Bar Class | PowerLanguage Namespace


Bar.Equals(Bar) Method

Indicates whether the current object is equal to another object of the same type.

public bool Equals(
Bar other
);

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable< Bar>.Equals

See Also

Bar Class | PowerLanguage Namespace | Bar.Equals Overload List


Bar.Equals(Object) Method

Indicates whether this instance and a specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

True if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

Bar Class | PowerLanguage Namespace | Bar.Equals Overload List


Bar.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

Bar Class | PowerLanguage Namespace


Bar.ToString Method

public override string ToString();

See Also

Bar Class | PowerLanguage Namespace


Bar Operators

The operators of the Bar structure are listed below. For a complete list of Bar structure members, see the Bar Members topic.

Public Static Operators

Equality Operator | Indicates whether this instance and a specified object are equal.
Inequality Operator | Indicates whether this instance and a specified object are not equal.

See Also

Bar Class | Bar Members | PowerLanguage Namespace


Bar Equality Operator

Indicates whether this instance and a specified object are equal.

public static bool operator ==(
Bar left,
Bar right
);

Parameters

left
right

Return Value

See Also

Bar Class | PowerLanguage Namespace


Bar Inequality Operator

Indicates whether this instance and a specified object are not equal.

public static bool operator !=(
Bar left,
Bar right
);

Parameters

left
right

Return Value

See Also

Bar Class | PowerLanguage Namespace


BarPriceLevels Structure

Structure describes volume data by showing at specific prices for a bar (Bar's Volume Profile).

For a list of all members of this type, see BarPriceLevels Members .

System.Object
BarPriceLevels

public struct BarPriceLevels

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

BarPriceLevels Members | PowerLanguage Namespace


BarPriceLevels Members

BarPriceLevels overview

Public Static Operators

Equality Operator | Indicates whether two instances of BarPriceLevels are equal.
Inequality Operator | Indicates whether two instances of BarPriceLevels are not equal.

Public Instance Constructors

BarPriceLevels Constructor Initializes a new instance of the BarPriceLevels structure to the specified value.

Public Instance Properties

Bar | Read-write property. Bar object.
Index | Read-write property. Bar's index.
Levels | Read-write property. Bar's price levels. Volume profile of the bar. PriceLevel
TickID | Read-write property. Bar's tick ID.
Time | Read-write property. Bar's time.
TotalRes |

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and other instance of BarPriceLevels are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels Constructor

Initializes a new instance of the BarPriceLevels structure to the specified value.

BarPriceLevels(
Bar bar,
PriceLevel[] levels,
int index
);

Parameters

bar
Bar object.
levels
Price levels. PriceLevel
index
Bar index.

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels Properties

The properties of the BarPriceLevels structure are listed below. For a complete list of BarPriceLevels structure members, see the BarPriceLevels Members topic.

Public Instance Properties

Bar | Read-write property. Bar object.
Index | Read-write property. Bar's index.
Levels | Read-write property. Bar's price levels. Volume profile of the bar. PriceLevel
TickID | Read-write property. Bar's tick ID.
Time | Read-write property. Bar's time.
TotalRes |

See Also

BarPriceLevels Class | PowerLanguage Namespace


Bar Property

PowerLanguage.NET Help

BarPriceLevels.Bar Property

Read-write property. Bar object.

public Bar Bar { public get; public set; }

See Also

BarPriceLevels Class | PowerLanguage Namespace


Index Property

PowerLanguage.NET Help

BarPriceLevels.Index Property

Read-write property. Bar's index.

public int Index { public get; public set; }

See Also

BarPriceLevels Class | PowerLanguage Namespace


Levels Property

PowerLanguage.NET Help

BarPriceLevels.Levels Property

Read-write property. Bar's price levels. Volume profile of the bar. PriceLevel

public PriceLevel[] Levels { public get; public set; }

See Also

BarPriceLevels Class | PowerLanguage Namespace


TickID Property

PowerLanguage.NET Help

BarPriceLevels.TickID Property

Read-write property. Bar's tick ID.

public uint TickID { public get; public set; }

See Also

BarPriceLevels Class | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

BarPriceLevels.Time Property

Read-write property. Bar's time.

public DateTime Time { public get; public set; }

See Also

BarPriceLevels Class | PowerLanguage Namespace


TotalRes Property

PowerLanguage.NET Help

BarPriceLevels.TotalRes Property

public uint TotalRes { public get; public set; }

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels Methods

The methods of the BarPriceLevels structure are listed below. For a complete list of BarPriceLevels structure members, see the BarPriceLevels Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and other instance of BarPriceLevels are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

BarPriceLevels Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

BarPriceLevels.Equals Method

Indicates whether this instance and other instance of BarPriceLevels are equal.

Overload List

Indicates whether this instance and other instance of BarPriceLevels are equal.

public bool Equals(BarPriceLevels)

Indicates whether this instance and a specified object are equal.

public override bool Equals(object)

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels.Equals(BarPriceLevels) Method

Indicates whether this instance and other instance of BarPriceLevels are equal.

public bool Equals(
BarPriceLevels other
);

Parameters

other
Instance of BarPriceLevels object for comparison.

Return Value

true if the other parameter is equal to the current BarPriceLevels object; otherwise, false.

See Also

BarPriceLevels Class | PowerLanguage Namespace | BarPriceLevels.Equals Overload List


BarPriceLevels.Equals(Object) Method

Indicates whether this instance and a specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

BarPriceLevels Class | PowerLanguage Namespace | BarPriceLevels.Equals Overload List


BarPriceLevels.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels.ToString Method

public override string ToString();

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels Operators

The operators of the BarPriceLevels structure are listed below. For a complete list of BarPriceLevels structure members, see the BarPriceLevels Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances of BarPriceLevels are equal.
Inequality Operator | Indicates whether two instances of BarPriceLevels are not equal.

See Also

BarPriceLevels Class | BarPriceLevels Members | PowerLanguage Namespace


BarPriceLevels Equality Operator

Indicates whether two instances of BarPriceLevels are equal.

public static bool operator ==(
BarPriceLevels left,
BarPriceLevels right
);

Parameters

left
First instance of BarPriceLevels object for comparison.
right
Second instance of BarPriceLevels object for comparison.

Return Value

true if first instance is equal to the second; otherwise, false.

See Also

BarPriceLevels Class | PowerLanguage Namespace


BarPriceLevels Inequality Operator

Indicates whether two instances of BarPriceLevels are not equal.

public static bool operator !=(
BarPriceLevels left,
BarPriceLevels right
);

Parameters

left
First instance of BarPriceLevels object for comparison.
right
Second instance of BarPriceLevels object for comparison.

Return Value

true if first instance is not equal to the second; otherwise, false.

See Also

BarPriceLevels Class | PowerLanguage Namespace


BoxSizeType Enumeration

Enumeration represents the boxsize value type for Renko or Point and Figure, or reversal type for Kagi

public enum BoxSizeType

Members

Member Name | Description
FIXEDPRICE | Box size is the fixed value.
PERCENT | Box size in percents.
POINTS | Box size in points.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


BreakdownType Enumeration

Enumeration represents possible values for Breakdown type.

public enum BreakdownType

Members

Member Name | Description
AskBid | Breakdown by Ask Traded vs Bid Traded.
UpDown | Breakdown by Up tick vs Down Tick.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


BuildVolumeOn Enumeration

Enumeration that describes Instrument's "build volume on" setting.

public enum BuildVolumeOn

Members

Member Name | Description
TickCount | Build on tick count.
Volume | Build on volume.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


CalcAtOpenNextBarAttribute Class

The class that defines CalcOnNextBarOpenAttribute.

For a list of all members of this type, see CalcAtOpenNextBarAttribute Members .

System.Object
Attribute
CalcAtOpenNextBarAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class CalcAtOpenNextBarAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

CalcAtOpenNextBarAttribute Members | PowerLanguage Namespace


CalcAtOpenNextBarAttribute Members

CalcAtOpenNextBarAttribute overview

Public Instance Constructors

CalcAtOpenNextBarAttribute Overloaded. Initializes a new instance of the CalcAtOpenNextBarAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. SkipIdenticalTicksAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CalcAtOpenNextBarAttribute Class | PowerLanguage Namespace


CalcAtOpenNextBarAttribute Constructor

Initializes a new instance of the CalcOnNextBarOpenAttribute class.

Overload List

Initializes a new instance of the CalcOnNextBarOpenAttribute class.

public CalcAtOpenNextBarAttribute()

Initializes a new instance of the CalcOnNextBarOpenAttribute class.

public CalcAtOpenNextBarAttribute(bool)

See Also

CalcAtOpenNextBarAttribute Class | PowerLanguage Namespace


CalcAtOpenNextBarAttribute Constructor

Initializes a new instance of the CalcOnNextBarOpenAttribute class.

CalcAtOpenNextBarAttribute(
bool value
);

Parameters

value
CalcOnNextBarOpenAttribute value.

See Also

CalcAtOpenNextBarAttribute Class | PowerLanguage Namespace | CalcAtOpenNextBarAttribute Constructor Overload List


CalcAtOpenNextBarAttribute Constructor

Initializes a new instance of the CalcOnNextBarOpenAttribute class.

CalcAtOpenNextBarAttribute();

See Also

CalcAtOpenNextBarAttribute Class | PowerLanguage Namespace | CalcAtOpenNextBarAttribute Constructor Overload List


CalcAtOpenNextBarAttribute Properties

The properties of the CalcAtOpenNextBarAttribute class are listed below. For a complete list of CalcAtOpenNextBarAttribute class members, see the CalcAtOpenNextBarAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. SkipIdenticalTicksAttribute value.

See Also

CalcAtOpenNextBarAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

CalcAtOpenNextBarAttribute.Value Property

Read-write property. SkipIdenticalTicksAttribute value.

public bool Value { public get; public set; }

See Also

CalcAtOpenNextBarAttribute Class | PowerLanguage Namespace


CalculationReason Enumeration

Enumeration that describes the reason for the calculation (i.e. calculation was triggered by a new bar/tick or initialized after left-click on the chart).

public enum CalculationReason

Members

Member Name | Description
Default | Calculation is to be initialized when the new bar/tick appeared.
LeftMouseClick | Calculation is to be initialized after left-click on the chart.
RightMouseClick | Calculation is to be initialized after right-click on the chart.
Timer | Calculation is to be initialized after expiration of RecalcLastBarAfter timeout.
MarketPositionChange | Calculation is to be initialized after market position for the instrument has been changed. For SignalObject only.
OrderFilled | Calculation is to be initialized after order filled event. For SignalObject only.
OrderRejected | Calculation is to be initialized after order reject event. For SignalObject only.
UserClickClosePositionButtonInPortfolio | calculation is to be initialized after the Close Position button is pressed in Portfolio Trader.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace | CalcReason


ChartPoint Structure

The structure that defines a point on the chart.

For a list of all members of this type, see ChartPoint Members .

System.Object
ChartPoint

public struct ChartPoint

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ChartPoint Members | PowerLanguage Namespace


ChartPoint Members

ChartPoint overview

Public Static Properties

Empty Read-only property. Returns an empty coordinate.

Public Static Operators

Equality Operator | Returns "true" if left and right coordinates are equal.
Inequality Operator | Returns "true" if left and right coordinates are not equal.

Public Instance Constructors

ChartPoint Overloaded. Initializes a new instance of the ChartPoint class.

Public Instance Properties

BarNumber | Read-write property. Bar number (first coordinate).
Price | Read-write property. Price (second coordinate).
Time | Read-write property. System time (first coordinate).

Public Instance Methods

Equals | Overloaded. Returns "true" if coordinates are equal.
GetHashCode |
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint Constructor

Initializes a new instance of ChartPoint.

Overload List

Initializes a new instance of ChartPoint.

public ChartPoint(DateTime,double)

Initializes a new instance of ChartPoint.

public ChartPoint(double)

Initializes a new instance of ChartPoint.

public ChartPoint(int,double)

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint Constructor

Initializes a new instance of ChartPoint.

ChartPoint(
DateTime time,
double price
);

Parameters

time
System time (first coordinate)
price
Price (second coordinate)

See Also

ChartPoint Class | PowerLanguage Namespace | ChartPoint Constructor Overload List


ChartPoint Constructor

Initializes a new instance of ChartPoint.

ChartPoint(
int barNumber,
double price
);

Parameters

barNumber
Bar number (first coordinate)
price
Price (second coordinate)

See Also

ChartPoint Class | PowerLanguage Namespace | ChartPoint Constructor Overload List


ChartPoint Constructor

Initializes a new instance of ChartPoint.

ChartPoint(
double price
);

Parameters

price
Price (second coordinate)

See Also

ChartPoint Class | PowerLanguage Namespace | ChartPoint Constructor Overload List


ChartPoint Properties

The properties of the ChartPoint structure are listed below. For a complete list of ChartPoint structure members, see the ChartPoint Members topic.

Public Static Properties

Empty Read-only property. Returns an empty coordinate.

Public Instance Properties

BarNumber | Read-write property. Bar number (first coordinate).
Price | Read-write property. Price (second coordinate).
Time | Read-write property. System time (first coordinate).

See Also

ChartPoint Class | PowerLanguage Namespace


BarNumber Property

PowerLanguage.NET Help

ChartPoint.BarNumber Property

Read-write property. Bar number (first coordinate).

public int? BarNumber { public get; public set; }

See Also

ChartPoint Class | PowerLanguage Namespace


Empty Property

PowerLanguage.NET Help

ChartPoint.Empty Property

Read-only property. Returns an empty coordinate.

public static ChartPoint Empty { public get; }

See Also

ChartPoint Class | PowerLanguage Namespace


Price Property

PowerLanguage.NET Help

ChartPoint.Price Property

Read-write property. Price (second coordinate).

public double Price { public get; public set; }

See Also

ChartPoint Class | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

ChartPoint.Time Property

Read-write property. System time (first coordinate).

public DateTime Time { public get; public set; }

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint Methods

The methods of the ChartPoint structure are listed below. For a complete list of ChartPoint structure members, see the ChartPoint Members topic.

Public Instance Methods

Equals | Overloaded. Returns "true" if coordinates are equal.
GetHashCode |
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ChartPoint Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

ChartPoint.Equals Method

Returns "true" if coordinates are equal.

Overload List

Returns "true" if coordinates are equal.

public bool Equals(ChartPoint)

public override bool Equals(object)

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint.Equals(ChartPoint) Method

Returns "true" if coordinates are equal.

public bool Equals(
ChartPoint other
);

Parameters

other

Return Value

See Also

ChartPoint Class | PowerLanguage Namespace | ChartPoint.Equals Overload List


ChartPoint.Equals(Object) Method

public override bool Equals(
object obj
);

See Also

ChartPoint Class | PowerLanguage Namespace | ChartPoint.Equals Overload List


ChartPoint.GetHashCode Method

public override int GetHashCode();

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint.ToString Method

public override string ToString();

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint Operators

The operators of the ChartPoint structure are listed below. For a complete list of ChartPoint structure members, see the ChartPoint Members topic.

Public Static Operators

Equality Operator | Returns "true" if left and right coordinates are equal.
Inequality Operator | Returns "true" if left and right coordinates are not equal.

See Also

ChartPoint Class | ChartPoint Members | PowerLanguage Namespace


ChartPoint Equality Operator

Returns "true" if left and right coordinates are equal.

public static bool operator ==(
ChartPoint left,
ChartPoint right
);

Parameters

left
right

Return Value

See Also

ChartPoint Class | PowerLanguage Namespace


ChartPoint Inequality Operator

Returns "true" if left and right coordinates are not equal.

public static bool operator !=(
ChartPoint left,
ChartPoint right
);

Parameters

left
right

Return Value

See Also

ChartPoint Class | PowerLanguage Namespace


ChartType Enumeration

Enumeration that describes chart types of instruments.

public enum ChartType

Members

Member Name | Description
Regular | Regular chart type
PointAndFigure | PointAndFigure chart type.
Kagi | Kagi chart type.
Renko | Renko chart type.
LineBreak | LineBreak chart type.
HeikinAshi | HeikinAshi chart type.
FootPrint | FootPrint chart type. Obsolete. Use DeltaType instead.
CumulativeDelta | CumulativeDelta chart type. Obsolete. Use DeltaType instead.
TPO | TPO chart type.
CustomResolution | Custom resolution type.
FlexRenko | FlexRenko chart type.
ReversalBar | Reversal Bar chart type.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ChartTypeCommonOptions Enumeration

Enumeration represents common options for not regular chart types.

public enum ChartTypeCommonOptions

Members

Member Name | Description
BREAK_ON_SESSION | Break on session.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ConstantObject<T> Class

ISeries implementation that emulates behavior of the simple property with a constant value.

For a list of all members of this type, see ConstantObject<T> Members .

System.Object
ConstantObject<T>

[DefaultMember(MemberName="Item")]
public sealed class ConstantObject<T> : ISeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ConstantObject<T> Members | PowerLanguage Namespace


ConstantObject<T> Members

ConstantObject<T> overview

Public Instance Constructors

ConstantObject<T> Constructor Initializes a new instance of the ConstantObject class.

Public Instance Properties

Item | Read-only property. Returns Value property.
Value | Read-only property. Returns constant value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ConstantObject<T> Class | PowerLanguage Namespace


ConstantObject<T> Constructor

Initializes a new instance of the ConstantObject class.

ConstantObject<T>(
T value
);

Parameters

value
The value that ConstantObject always returns.

See Also

ConstantObject<T> Class | PowerLanguage Namespace


ConstantObject<T> Properties

The properties of the ConstantObject<T> class are listed below. For a complete list of ConstantObject<T> class members, see the ConstantObject<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns Value property.
Value | Read-only property. Returns constant value.

See Also

ConstantObject<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

ConstantObject`1.Item Property

Read-only property. Returns Value property.

public T this[
int barsAgo
] { public get; }

Parameters

barsAgo
Not used.

Implements

ISeries<T>.Item

See Also

ConstantObject<T> Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

ConstantObject`1.Value Property

Read-only property. Returns constant value.

public T Value { public get; }

Implements

ISeries<T>.Value

See Also

ConstantObject<T> Class | PowerLanguage Namespace


Contracts Structure

Class that contains information about contracts.

For a list of all members of this type, see Contracts Members .

System.Object
Contracts

public struct Contracts

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Contracts Members | PowerLanguage Namespace


Contracts Members

Contracts overview

Public Static Properties

Default | Read-only property. Returns a new instance of Contracts with default contracts type.
UserSpecified | Read-only property. Returns a new instance of Contracts with user-specified contracts type.

Public Static Methods

CreateUserSpecified Creating the user-specified Contracts with a specified number of contracts.

Public Instance Fields

Contract | Number of Contracts.
Type | Contracts type.

Public Instance Properties

IsDefault | Read-only property. Returns an indication whether the contracts type is the default.
IsUserSpecified | Read-only property. Returns an indication whether the type is specified by user.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Contracts Class | PowerLanguage Namespace


Contracts Fields

The fields of the Contracts structure are listed below. For a complete list of Contracts structure members, see the Contracts Members topic.

Public Instance Fields

Contract | Number of Contracts.
Type | Contracts type.

See Also

Contracts Class | PowerLanguage Namespace


Contracts.Contract Field

Number of Contracts.

public readonly int Contract;

See Also

Contracts Class | PowerLanguage Namespace


Contracts.Type Field

Contracts type.

public readonly EContractsType Type;

See Also

Contracts Class | PowerLanguage Namespace


Contracts Properties

The properties of the Contracts structure are listed below. For a complete list of Contracts structure members, see the Contracts Members topic.

Public Static Properties

Default | Read-only property. Returns a new instance of Contracts with default contracts type.
UserSpecified | Read-only property. Returns a new instance of Contracts with user-specified contracts type.

Public Instance Properties

IsDefault | Read-only property. Returns an indication whether the contracts type is the default.
IsUserSpecified | Read-only property. Returns an indication whether the type is specified by user.

See Also

Contracts Class | PowerLanguage Namespace


Default Property

PowerLanguage.NET Help

Contracts.Default Property

Read-only property. Returns a new instance of Contracts with default contracts type.

public static Contracts Default { public get; }

See Also

Contracts Class | PowerLanguage Namespace


IsDefault Property

PowerLanguage.NET Help

Contracts.IsDefault Property

Read-only property. Returns an indication whether the contracts type is the default.

public bool IsDefault { public get; }

See Also

Contracts Class | PowerLanguage Namespace


IsUserSpecified Property

PowerLanguage.NET Help

Contracts.IsUserSpecified Property

Read-only property. Returns an indication whether the type is specified by user.

public bool IsUserSpecified { public get; }

See Also

Contracts Class | PowerLanguage Namespace


UserSpecified Property

PowerLanguage.NET Help

Contracts.UserSpecified Property

Read-only property. Returns a new instance of Contracts with user-specified contracts type.

public static Contracts UserSpecified { public get; }

See Also

Contracts Class | PowerLanguage Namespace


Contracts Methods

The methods of the Contracts structure are listed below. For a complete list of Contracts structure members, see the Contracts Members topic.

Public Static Methods

CreateUserSpecified Creating the user-specified Contracts with a specified number of contracts.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Contracts Class | PowerLanguage Namespace


Contracts.CreateUserSpecified Method

Creating the user-specified Contracts with a specified number of contracts.

public static Contracts CreateUserSpecified(
int num
);

Parameters

num
The number of contracts.

Return Value

New instance of the user-specified Contracts with a specified number of contracts.

See Also

Contracts Class | PowerLanguage Namespace


Contracts.EContractsType Enumeration

Enumeration describing types of contracts.

public enum EContractsType

Members

Member Name | Description
Default | If the number of Contracts is not explicitly specified, the number of contracts specified in the Strategy Properties dialog is used.
UserSpecified | Number of Contracts is always taken from order’s Contracts property (0, by default).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


CStudyAbstract Class

Base class for studies.

For a list of all members of this type, see CStudyAbstract Members .

System.Object
CStudyControl
CStudyAbstract
IndicatorObject
SignalObject

public abstract class CStudyAbstract : CStudyControl, IStudyInfo

Requirements

Namespace: PowerLanguage

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

CStudyAbstract Members | PowerLanguage Namespace


CStudyAbstract Members

CStudyAbstract overview

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetDataStream |
GetHashCode (inherited from Object) |
GetInputs |
GetInputValue |
GetMouseEvents |
GetRecoverDrawings |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
AddIndicator | Overloaded.
CalcBar | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy | This method is called once when the study is removed from the chart(scanner).
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
OnBrokerPositionChange | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent | Allows control of mouse-click events on the chart.
OnOrderRejected | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent | Event that happens after the Close Position button is pressed in Portfolio Trader
StartCalc | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract Methods

The methods of the CStudyAbstract class are listed below. For a complete list of CStudyAbstract class members, see the CStudyAbstract Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetDataStream |
GetHashCode (inherited from Object) |
GetInputs |
GetInputValue |
GetMouseEvents |
GetRecoverDrawings |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
AddIndicator | Overloaded.
CalcBar | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy | This method is called once when the study is removed from the chart(scanner).
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
OnBrokerPositionChange | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent | Allows control of mouse-click events on the chart.
OnOrderRejected | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent | Event that happens after the Close Position button is pressed in Portfolio Trader
StartCalc | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

CStudyAbstract Class | PowerLanguage Namespace


AddIndicator Method

PowerLanguage.NET Help

CStudyAbstract.AddIndicator Method

This method allows to add any indicator and use it later. The indicator will be calculated every time before this study calculation. The goal is to use the indicator's algorithm in signals or other indicators.

Overload List

This method allows to add any indicator and use it later. The indicator will be calculated every time before this study calculation. The goal is to use the indicator's algorithm in signals or other indicators.

protected object AddIndicator(string)

protected object AddIndicator(string,int)

protected object AddIndicator(Type)

protected object AddIndicator(Type,int)

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.AddIndicator(String) Method

This method allows to add any indicator and use it later. The indicator will be calculated every time before this study calculation. The goal is to use the indicator's algorithm in signals or other indicators.

protected object AddIndicator(
string name
);

See Also

CStudyAbstract Class | PowerLanguage Namespace | CStudyAbstract.AddIndicator Overload List


CStudyAbstract.AddIndicator(String, Int32) Method

protected object AddIndicator(
string name,
int data_stream
);

See Also

CStudyAbstract Class | PowerLanguage Namespace | CStudyAbstract.AddIndicator Overload List


CStudyAbstract.AddIndicator(Type) Method

protected object AddIndicator(
Type type_of_indicator
);

See Also

CStudyAbstract Class | PowerLanguage Namespace | CStudyAbstract.AddIndicator Overload List


CStudyAbstract.AddIndicator(Type, Int32) Method

protected object AddIndicator(
Type type_of_indicator,
int data_stream
);

See Also

CStudyAbstract Class | PowerLanguage Namespace | CStudyAbstract.AddIndicator Overload List


CStudyAbstract.CalcBar Method

This method is called every tick from the calculation's beginning bar until the last historical bar.

Every real-time tick (or bar close, optionally) after the historical calculation.

protected abstract void CalcBar();

Example

CalcBar method in the MomentumLE signal.

private PowerLanguage.Function.Momentum m_momentum1;
private PowerLanguage.Function.Momentum m_momentum2;
private IOrderPriced m_Order0;

protected override void CalcBar() {
    const double momentum1 = m_momentum1[0];
    const double momentum2 = m_momentum2[0];
    if ( momentum1 > 0 && momentum2 > 0 ) {
        m_Order0.Send(Bars.High[0] + Bars.Point);
    }
}

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.Create Method

Method which is called once when the study object is created. Here, and only here, access the following:

1) add plot objects (for indicator objects only) ,

2) create order objects OrderCreator (for signal objects only) ,

3) create function objects,

4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>

protected virtual void Create();

Example

Create method in the MomentumLE signal.

private PowerLanguage.Function.Momentum m_momentum1;
private PowerLanguage.Function.Momentum m_momentum2;
private VariableSeries<double> m_mom;
private IOrderPriced m_Order0;

protected override void Create() {
    m_momentum1 = new PowerLanguage.Function.Momentum(this);
    m_momentum2 = new PowerLanguage.Function.Momentum(this);
    m_mom = new VariableSeries<double>(this);
    m_Order0 = OrderCreator.Stop(new SOrderParameters(Contracts.Default, "MomLE", EOrderAction.Buy));
}

See Also

CStudyAbstract Class | PowerLanguage Namespace | PowerLanguage::Indicator::IndicatorObject | PowerLanguage::Strategy::SignalObject


CStudyAbstract.Destroy Method

This method is called once when the study is removed from the chart(scanner).

protected virtual void Destroy();

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.Dispose Method

[HandleProcessCorruptedStateExceptions]
protected override void Dispose(
bool A_0
);

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.GetDataStream Method

public UInt32** GetDataStream();

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.GetInputs Method

public override InputInfo[] GetInputs();

Implements

IStudyInfo.GetInputs

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.GetInputValue Method

public override object GetInputValue(
string name
);

Implements

IStudyInfo.GetInputValue

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.GetMouseEvents Method

public override bool? GetMouseEvents();

Implements

IStudyInfo.GetMouseEvents

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.GetRecoverDrawings Method

public override bool? GetRecoverDrawings();

Implements

IStudyInfo.GetRecoverDrawings

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.OnBrokerPositionChange Method

Event that occurs after MarketPosition and/or average Entry Price changed at broker.

protected virtual void OnBrokerPositionChange();

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.OnBrokerStategyOrderFilled Method

Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.

protected virtual void OnBrokerStategyOrderFilled(
bool is_buy,
int quantity,
double avg_fill_price
);

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.OnMouseEvent Method

Allows control of mouse-click events on the chart.

protected virtual void OnMouseEvent(
MouseClickArgs arg
);

Parameters

arg
Specifies the mouse-click parameters. Keyboard button code, mouse button code, chart point, bar number and data stream number parameters are passed.

Example

This example shows how to recalculate script on Shift + MouseLeftButton pressed event.

protected override void CalcBar() {
    if (Bars.CurrentBar >= start_calc_bar_number) {
        // execute script from the specified bar
    }
}

private static int start_calc_bar_number = 1;

protected override void OnMouseEvent(MouseClickArgs args) {
    if (Keys.ShiftKey == args.keys && MouseButtons.Left == args.buttons) {
        start_calc_bar_number = args.bar_number;
        ExecControl.Recalculate();
    }
}

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.OnOrderRejected Method

Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.

protected virtual void OnOrderRejected(
EOrderAction RejectedOrderAction,
OrderCategory RejectedOrderCategory,
int RejectedOrderQuantity,
double RejectedOrderStopPrice,
double RejectedOrderLimitPrice
);

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.OnRecalcLastBarAfterEvent Method

Event that happens after timeout in RecalcLastBarAfter function occurs.

protected virtual void OnRecalcLastBarAfterEvent();

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.OnUserClickClosePositionButtonEvent Method

Event that happens after the Close Position button is pressed in Portfolio Trader

protected virtual void OnUserClickClosePositionButtonEvent();

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.SetInputValue Method

public override void SetInputValue(
string name,
object value
);

Implements

IStudyInfo.SetInputValue

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.StartCalc Method

Method which is called once at the start of the calculation process.

Here you can initialize study variables.

protected virtual void StartCalc();

Example

StartCalc method in the MomentumLE signal.

private PowerLanguage.Function.Momentum m_momentum1;
private PowerLanguage.Function.Momentum m_momentum2;
private VariableSeries<double> m_mom;
private IOrderPriced m_Order0;

private ISeries<double> m_price;

private ISeries<double> price {
    get { return m_price; }
}

private int m_length = 12;

[Input]
public int length {
    get { return m_length; }
    set { m_length = value; }
}

protected override void StartCalc() {
    m_price = Bars.Close;
    m_momentum1.price = price;
    m_momentum1.length = new Lambda<int>(delegate { return length; });
    m_momentum2.price = m_mom;
    m_momentum2.length = new ConstantObject<int>(1);
    m_mom.DefaultValue = 0;
}

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyAbstract.StopCalc Method

Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

protected virtual void StopCalc();

See Also

CStudyAbstract Class | PowerLanguage Namespace


CStudyControl Class

Base class for studies.

For a list of all members of this type, see CStudyControl Members .

System.Object
CStudyControl
CStudyAbstract
FunctionObject<T>

public class CStudyControl : IStudy, IChartCommands, IDisposable

Requirements

Namespace: PowerLanguage

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

CStudyControl Members | PowerLanguage Namespace


CStudyControl Members

CStudyControl overview

Public Instance Properties

Alerts | Read-only property. Returns an interface for working with Alerts.
Bars | Read-only property. Returns base instrument.
ChartCommands |
ChartCustomDraw | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader | Read-only property. Returns an interface for data loading.
DrwArrow | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle | Read-only property. Returns a container for IRectangleObject collection.
DrwText | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine | Read-only property. Returns a container for ITrendLineObject collection.
Environment | Read-only property. Returns environment access interface.
ExecControl | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary | Read-only property. Returns an interface for controlling expert commentary.
MaxDataStream | Read-only property. Returns max data stream.
Name | Read-only property. Returns name.
Output | Read-only property. Returns an interface to access Output Window.
PersistData | This string is saved to workspace and loaded from workspace.
StrategyInfo | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage | Read-only property. Returns an interface for accessing symbol storage.
TPOBars | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager | Returns interface for accessing trading functionality.
VolumeProfile | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed |
CreateSeriesVar<T> | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl Properties

The properties of the CStudyControl class are listed below. For a complete list of CStudyControl class members, see the CStudyControl Members topic.

Public Instance Properties

Alerts | Read-only property. Returns an interface for working with Alerts.
Bars | Read-only property. Returns base instrument.
ChartCommands |
ChartCustomDraw | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader | Read-only property. Returns an interface for data loading.
DrwArrow | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle | Read-only property. Returns a container for IRectangleObject collection.
DrwText | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine | Read-only property. Returns a container for ITrendLineObject collection.
Environment | Read-only property. Returns environment access interface.
ExecControl | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary | Read-only property. Returns an interface for controlling expert commentary.
MaxDataStream | Read-only property. Returns max data stream.
Name | Read-only property. Returns name.
Output | Read-only property. Returns an interface to access Output Window.
PersistData | This string is saved to workspace and loaded from workspace.
StrategyInfo | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage | Read-only property. Returns an interface for accessing symbol storage.
TPOBars | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager | Returns interface for accessing trading functionality.
VolumeProfile | Returns interface for accessing volume profile.

See Also

CStudyControl Class | PowerLanguage Namespace


Alerts Property

PowerLanguage.NET Help

CStudyControl.Alerts Property

Read-only property. Returns an interface for working with Alerts.

public IAlert Alerts { public get; }

Implements

IStudy.Alerts

See Also

CStudyControl Class | PowerLanguage Namespace


Bars Property

PowerLanguage.NET Help

CStudyControl.Bars Property

Read-only property. Returns base instrument.

public IInstrument Bars { public get; }

Implements

IStudy.Bars

See Also

CStudyControl Class | PowerLanguage Namespace


ChartCommands Property

PowerLanguage.NET Help

CStudyControl.ChartCommands Property

public IChartCommands ChartCommands { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


ChartCustomDraw Property

PowerLanguage.NET Help

CStudyControl.ChartCustomDraw Property

Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).

public IChartCustomDrawRegistrator ChartCustomDraw { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


ChartToolBar Property

PowerLanguage.NET Help

CStudyControl.ChartToolBar Property

Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.

public ICustomToolBar ChartToolBar { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


DataLoader Property

PowerLanguage.NET Help

CStudyControl.DataLoader Property

Read-only property. Returns an interface for data loading.

public IDataLoader DataLoader { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


DrwArrow Property

PowerLanguage.NET Help

CStudyControl.DrwArrow Property

Read-only property. Returns a container for collection of specific IArrowObject.

public IArrowContainer DrwArrow { public get; }

Implements

IStudy.DrwArrow

See Also

CStudyControl Class | PowerLanguage Namespace


DrwRectangle Property

PowerLanguage.NET Help

CStudyControl.DrwRectangle Property

Read-only property. Returns a container for IRectangleObject collection.

public IRectangleContainer DrwRectangle { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


DrwText Property

PowerLanguage.NET Help

CStudyControl.DrwText Property

Read-only property. Returns a container for ITextObject collection.

public ITextContainer DrwText { public get; }

Implements

IStudy.DrwText

See Also

CStudyControl Class | PowerLanguage Namespace


DrwTrendLine Property

PowerLanguage.NET Help

CStudyControl.DrwTrendLine Property

Read-only property. Returns a container for ITrendLineObject collection.

public ITrendLineContainer DrwTrendLine { public get; }

Implements

IStudy.DrwTrendLine

See Also

CStudyControl Class | PowerLanguage Namespace


Environment Property

PowerLanguage.NET Help

CStudyControl.Environment Property

Read-only property. Returns environment access interface.

public IApplicationInfo Environment { public get; }

Implements

IStudy.Environment

See Also

CStudyControl Class | PowerLanguage Namespace


ExecControl Property

PowerLanguage.NET Help

CStudyControl.ExecControl Property

Read-only property. Returns an interface for controlling strategy calculation.

public ICalculationControl ExecControl { public get; }

Implements

IStudy.ExecControl

See Also

CStudyControl Class | PowerLanguage Namespace


ExecInfo Property

PowerLanguage.NET Help

CStudyControl.ExecInfo Property

Read-only property. Returns an interface for accessing current execution context.

public ICalculationInfo ExecInfo { public get; }

Implements

IStudy.ExecInfo

See Also

CStudyControl Class | PowerLanguage Namespace


ExpertCommentary Property

PowerLanguage.NET Help

CStudyControl.ExpertCommentary Property

Read-only property. Returns an interface for controlling expert commentary.

public IExpertCommentary ExpertCommentary { public get; }

Implements

IStudy.ExpertCommentary

See Also

CStudyControl Class | PowerLanguage Namespace


MaxDataStream Property

PowerLanguage.NET Help

CStudyControl.MaxDataStream Property

Read-only property. Returns max data stream.

public int MaxDataStream { public get; }

Implements

IStudy.MaxDataStream

See Also

CStudyControl Class | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

CStudyControl.Name Property

Read-only property. Returns name.

public string Name { public get; }

Implements

IStudy.Name

See Also

CStudyControl Class | PowerLanguage Namespace


Output Property

PowerLanguage.NET Help

CStudyControl.Output Property

Read-only property. Returns an interface to access Output Window.

public IOutput Output { public get; }

Implements

IStudy.Output

See Also

CStudyControl Class | PowerLanguage Namespace


PersistData Property

PowerLanguage.NET Help

CStudyControl.PersistData Property

This string is saved to workspace and loaded from workspace.

public string PersistData { public get; public set; }

See Also

CStudyControl Class | PowerLanguage Namespace


StrategyInfo Property

PowerLanguage.NET Help

CStudyControl.StrategyInfo Property

Read-only property. Returns an interface for accessing strategy information.

public IStrategyPerformance StrategyInfo { public get; }

Implements

IStudy.StrategyInfo

See Also

CStudyControl Class | PowerLanguage Namespace


SymbolStorage Property

PowerLanguage.NET Help

CStudyControl.SymbolStorage Property

Read-only property. Returns an interface for accessing symbol storage.

public ISymbolsStorage SymbolStorage { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


TPOBars Property

PowerLanguage.NET Help

CStudyControl.TPOBars Property

Read-only property. Provides an interface for accessing current series' TPO data.

public IInstrumentTPO TPOBars { public get; }

Implements

IStudy.TPOBars

See Also

CStudyControl Class | PowerLanguage Namespace


TradeManager Property

PowerLanguage.NET Help

CStudyControl.TradeManager Property

Returns interface for accessing trading functionality.

public ITradeManager TradeManager { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


VolumeProfile Property

PowerLanguage.NET Help

CStudyControl.VolumeProfile Property

Returns interface for accessing volume profile.

public IProfilesCollection VolumeProfile { public get; }

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl Methods

The methods of the CStudyControl class are listed below. For a complete list of CStudyControl class members, see the CStudyControl Members topic.

Public Instance Methods

BarsOfData | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed |
CreateSeriesVar<T> | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl._check_for_disposed Method

protected void _check_for_disposed();

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.BarsOfData Method

Returns instrument for specified data stream number.

public IInstrument BarsOfData(
int data_stream
);

Implements

IStudy.BarsOfData

See Also

CStudyControl Class | PowerLanguage Namespace


CreateSeriesVar<T> Method

PowerLanguage.NET Help

CStudyControl.CreateSeriesVar<T> Method

Overload List

protected IVar<T> CreateSeriesVar<T>()

protected IVar<T> CreateSeriesVar<T>(T)

Creates VariableSeries object.

protected IVar<T> CreateSeriesVar<T>(T,int)

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.CreateSeriesVar<T>() Method

protected IVar<T> CreateSeriesVar<T>();

See Also

CStudyControl Class | PowerLanguage Namespace | CStudyControl.CreateSeriesVar<T> Overload List


CStudyControl.CreateSeriesVar<T>(T) Method

protected IVar<T> CreateSeriesVar<T>(
T defaultVal
);

See Also

CStudyControl Class | PowerLanguage Namespace | CStudyControl.CreateSeriesVar<T> Overload List


CStudyControl.CreateSeriesVar<T>(T, Int32) Method

Creates VariableSeries object.

protected IVar<T> CreateSeriesVar<T>(
T defaultVal,
int dataStream
);

Parameters

defaultVal
Series variable default value.
dataStream
Series variable base datastream number.

See Also

CStudyControl Class | PowerLanguage Namespace | CStudyControl.CreateSeriesVar<T> Overload List


CreateSimpleVar<T> Method

PowerLanguage.NET Help

CStudyControl.CreateSimpleVar<T> Method

Creates VariableObject object.

Overload List

Creates VariableObject object.

protected IVar<T> CreateSimpleVar<T>()

Creates VariableObject object.

protected IVar<T> CreateSimpleVar<T>(T)

Creates VariableObject object.

protected IVar<T> CreateSimpleVar<T>(T,int)

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.CreateSimpleVar<T>() Method

Creates VariableObject object.

protected IVar<T> CreateSimpleVar<T>();

See Also

CStudyControl Class | PowerLanguage Namespace | CStudyControl.CreateSimpleVar<T> Overload List


CStudyControl.CreateSimpleVar<T>(T) Method

Creates VariableObject object.

protected IVar<T> CreateSimpleVar<T>(
T defaultVal
);

See Also

CStudyControl Class | PowerLanguage Namespace | CStudyControl.CreateSimpleVar<T> Overload List


CStudyControl.CreateSimpleVar<T>(T, Int32) Method

Creates VariableObject object.

protected IVar<T> CreateSimpleVar<T>(
T defaultVal,
int dataStream
);

Parameters

defaultVal
Simple variable default value.
dataStream
Simple variable base datastream number.

See Also

CStudyControl Class | PowerLanguage Namespace | CStudyControl.CreateSimpleVar<T> Overload List


CStudyControl.Dispose Method

protected virtual void Dispose(
bool A_0
);

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.IsExist Method

Returns whether there is data at a specified data stream number.

[return : MarshalAs(SafeArraySubType=VarEnum.VT_EMPTY, SafeArrayUserDefinedSubType=null, IidParameterIndex=0, ArraySubType=UnmanagedType.0, SizeParamIndex=0, SizeConst=0, MarshalType="null", MarshalTypeRef=null, MarshalCookie="null", Value=UnmanagedType.U1)]
public bool IsExist(
int data_stream
);

Implements

IStudy.IsExist

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.TPOBarsOfData Method

Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.

public IInstrumentTPO TPOBarsOfData(
int data_stream
);

Implements

IStudy.TPOBarsOfData

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.VerifyLicense Method

Allows study developers to use MultiCharts .NET Special Edition authorization services.

public void VerifyLicense(
string sName,
string sDevID
);

See Also

CStudyControl Class | PowerLanguage Namespace


CStudyControl.VolumeProfileByDataStream Method

Returns interface for accessing volume profile for specified instrument.

public IProfilesCollection VolumeProfileByDataStream(
int data_stream
);

See Also

CStudyControl Class | PowerLanguage Namespace


CumulativeDeltaAttributes Enumeration

Enumeration represents options for Cumulative Delta and Volume Delta chart types.

public enum CumulativeDeltaAttributes

Members

Member Name | Description
CHART_TYPE | Breakdown type for Cumulative Delta.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


CumulativeDeltaChartType Enumeration

Enumeration represents Breakdown type for Cumulative Delta and Volume Delta chart types.

public enum CumulativeDeltaChartType

Members

Member Name | Description
NOTHING |
ASK_TRADE_BID_TRADE | Breakdown by Ask Traded vs Bid Traded.
DELTA_UP_TICK_DOWN_TICK | Breakdown by Up tick vs Down Tick.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


CustomInstrument Class

Allows to access data series of another symbol without adding it as an additional data series. Note: after using CustomInstrument you need to call the Dispose() method for proper operation of MultiCharts application.

For a list of all members of this type, see CustomInstrument Members .

System.Object
CustomInstrumentBase
CustomInstrument

[DefaultMember(MemberName="Item")]
public sealed class CustomInstrument : CustomInstrumentBase

Requirements

Namespace: PowerLanguage

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CustomInstrument Members | PowerLanguage Namespace


CustomInstrument Members

CustomInstrument overview

Public Instance Constructors

CustomInstrument Overloaded. Initializes a new instance of the CustomInstrument class.

Public Instance Properties

BarUpdateTime (inherited from CustomInstrumentBase) |
Close (inherited from CustomInstrumentBase) |
CloseValue (inherited from CustomInstrumentBase) |
Count (inherited from CustomInstrumentBase) |
Current (inherited from CustomInstrumentBase) |
CurrentBar (inherited from CustomInstrumentBase) |
DOM (inherited from CustomInstrumentBase) |
DownTicks (inherited from CustomInstrumentBase) |
DownTicksValue (inherited from CustomInstrumentBase) |
FullSymbolData (inherited from CustomInstrumentBase) |
High (inherited from CustomInstrumentBase) |
HighValue (inherited from CustomInstrumentBase) |
Info (inherited from CustomInstrumentBase) |
Item (inherited from CustomInstrumentBase) |
LastBarInSession (inherited from CustomInstrumentBase) |
LastBarOnChart (inherited from CustomInstrumentBase) |
LastBarTime (inherited from CustomInstrumentBase) |
Low (inherited from CustomInstrumentBase) |
LowValue (inherited from CustomInstrumentBase) |
Open (inherited from CustomInstrumentBase) |
OpenInt (inherited from CustomInstrumentBase) |
OpenIntValue (inherited from CustomInstrumentBase) |
OpenValue (inherited from CustomInstrumentBase) |
Point (inherited from CustomInstrumentBase) |
Request (inherited from CustomInstrumentBase) |
Sessions (inherited from CustomInstrumentBase) |
Status (inherited from CustomInstrumentBase) |
StatusLine (inherited from CustomInstrumentBase) |
TickIDValue (inherited from CustomInstrumentBase) |
Ticks (inherited from CustomInstrumentBase) |
TicksValue (inherited from CustomInstrumentBase) |
Time (inherited from CustomInstrumentBase) |
TimeValue (inherited from CustomInstrumentBase) |
UpTicks (inherited from CustomInstrumentBase) |
UpTicksValue (inherited from CustomInstrumentBase) |
Volume (inherited from CustomInstrumentBase) |
VolumeValue (inherited from CustomInstrumentBase) |
WaitLoadTimeout | Time to wait for data when loading it upon accessing bars. If the time is out and data is not loading, the System.TimeoutException is generated.

Public Instance Methods

Dispose
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Fields

disposed (inherited from CustomInstrumentBase)
m_cur_index_driver (inherited from CustomInstrumentBase)
m_data (inherited from CustomInstrumentBase)

Protected Instance Methods

check_for_data_loaded
Finalize (inherited from Object)
make_request (inherited from CustomInstrumentBase)
MemberwiseClone (inherited from Object)

See Also

CustomInstrument Class | PowerLanguage Namespace


CustomInstrument Constructor

Constructor.

Overload List

Constructor.

public CustomInstrument(CStudyControl,Resolution)

Constructor.

public CustomInstrument(IInstrument,Resolution)

Constructor.

public CustomInstrument(IInstrument,string,MTPA_MCSymbolInfo2,Resolution,bool)

Constructor.

public CustomInstrument(IInstrument,string,MTPA_MCSymbolInfo2,Resolution,bool,RequestQuoteField)

Constructor.

public CustomInstrument(IInstrument,string,Resolution)

Constructor.

public CustomInstrument(IInstrument,string,Resolution,bool)

See Also

CustomInstrument Class | PowerLanguage Namespace


CustomInstrument Constructor

Constructor.

CustomInstrument(
CStudyControl _this,
Resolution resolution
);

Parameters

_this
The new series time scale is bound to time scale of data series the indicator is based on.
resolution
The data resolution of the new symbol.

See Also

CustomInstrument Class | PowerLanguage Namespace | CustomInstrument Constructor Overload List


CustomInstrument Constructor

Constructor.

CustomInstrument(
IInstrument _base,
Resolution resolution
);

Parameters

_base
The new series time scale is bound to time scale of specified data series on chart.
resolution
The data resolution of the new symbol.

See Also

CustomInstrument Class | PowerLanguage Namespace | CustomInstrument Constructor Overload List


CustomInstrument Constructor

Constructor.

CustomInstrument(
IInstrument _base,
string instrumentName,
Resolution resolution
);

Parameters

_base
The new series time scale is bound to time scale of specified data series.
instrumentName
The name of the symbol.
resolution
The data resolution of the new symbol.

See Also

CustomInstrument Class | PowerLanguage Namespace | CustomInstrument Constructor Overload List


CustomInstrument Constructor

Constructor.

CustomInstrument(
IInstrument _base,
string instrumentName,
Resolution resolution,
bool needRT
);

Parameters

_base
The new series time scale is bound to time scale of specified data series.
instrumentName
The name of the symbol.
resolution
The data resolution of the new symbol.
needRT
Real-time data subcription mode. If only historical data is required, set the pearamterto "false".

See Also

CustomInstrument Class | PowerLanguage Namespace | CustomInstrument Constructor Overload List


CustomInstrument Constructor

Constructor.

CustomInstrument(
IInstrument _base,
string datafeed,
MTPA_MCSymbolInfo2 instrument,
Resolution resolution,
bool needRT
);

Parameters

_base
The new series time scale is bound to time scale of specified data series.
datafeed
The name of the data provider.
instrument
Attributes of the symbol.
resolution
The data resolution of the new symbol.
needRT
Real-time data subcription mode. If only historical data is required, set the pearamterto "false".

See Also

CustomInstrument Class | PowerLanguage Namespace | CustomInstrument Constructor Overload List


CustomInstrument Constructor

Constructor.

CustomInstrument(
IInstrument _base,
string datafeed,
MTPA_MCSymbolInfo2 instrument,
Resolution resolution,
bool needRT,
RequestQuoteField field
);

Parameters

_base
The new series time scale is bound to time scale of specified data series.
datafeed
The name of the data provider.
instrument
Attributes of the symbol.
resolution
The data resolution of the new symbol.
needRT
Real-time data subcription mode. If only historical data is required, set the pearamterto "false".
field
Quote field of the symbol. Possible values: Ask, Bid or Trade.

See Also

CustomInstrument Class | PowerLanguage Namespace | CustomInstrument Constructor Overload List


CustomInstrument Properties

The properties of the CustomInstrument class are listed below. For a complete list of CustomInstrument class members, see the CustomInstrument Members topic.

Public Instance Properties

BarUpdateTime (inherited from CustomInstrumentBase) |
Close (inherited from CustomInstrumentBase) |
CloseValue (inherited from CustomInstrumentBase) |
Count (inherited from CustomInstrumentBase) |
Current (inherited from CustomInstrumentBase) |
CurrentBar (inherited from CustomInstrumentBase) |
DOM (inherited from CustomInstrumentBase) |
DownTicks (inherited from CustomInstrumentBase) |
DownTicksValue (inherited from CustomInstrumentBase) |
FullSymbolData (inherited from CustomInstrumentBase) |
High (inherited from CustomInstrumentBase) |
HighValue (inherited from CustomInstrumentBase) |
Info (inherited from CustomInstrumentBase) |
Item (inherited from CustomInstrumentBase) |
LastBarInSession (inherited from CustomInstrumentBase) |
LastBarOnChart (inherited from CustomInstrumentBase) |
LastBarTime (inherited from CustomInstrumentBase) |
Low (inherited from CustomInstrumentBase) |
LowValue (inherited from CustomInstrumentBase) |
Open (inherited from CustomInstrumentBase) |
OpenInt (inherited from CustomInstrumentBase) |
OpenIntValue (inherited from CustomInstrumentBase) |
OpenValue (inherited from CustomInstrumentBase) |
Point (inherited from CustomInstrumentBase) |
Request (inherited from CustomInstrumentBase) |
Sessions (inherited from CustomInstrumentBase) |
Status (inherited from CustomInstrumentBase) |
StatusLine (inherited from CustomInstrumentBase) |
TickIDValue (inherited from CustomInstrumentBase) |
Ticks (inherited from CustomInstrumentBase) |
TicksValue (inherited from CustomInstrumentBase) |
Time (inherited from CustomInstrumentBase) |
TimeValue (inherited from CustomInstrumentBase) |
UpTicks (inherited from CustomInstrumentBase) |
UpTicksValue (inherited from CustomInstrumentBase) |
Volume (inherited from CustomInstrumentBase) |
VolumeValue (inherited from CustomInstrumentBase) |
WaitLoadTimeout | Time to wait for data when loading it upon accessing bars. If the time is out and data is not loading, the System.TimeoutException is generated.

See Also

CustomInstrument Class | PowerLanguage Namespace


WaitLoadTimeout Property

PowerLanguage.NET Help

CustomInstrument.WaitLoadTimeout Property

Time to wait for data when loading it upon accessing bars. If the time is out and data is not loading, the System.TimeoutException is generated.

public TimeSpan WaitLoadTimeout { public get; public set; }

See Also

CustomInstrument Class | PowerLanguage Namespace


CustomInstrument Methods

The methods of the CustomInstrument class are listed below. For a complete list of CustomInstrument class members, see the CustomInstrument Members topic.

Public Instance Methods

Dispose
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

check_for_data_loaded
Finalize (inherited from Object)
make_request (inherited from CustomInstrumentBase)
MemberwiseClone (inherited from Object)

See Also

CustomInstrument Class | PowerLanguage Namespace


CustomInstrument.check_for_data_loaded Method

protected override void check_for_data_loaded();

See Also

CustomInstrument Class | PowerLanguage Namespace


CustomInstrument.Dispose Method

public override void Dispose();

Implements

IDisposable.Dispose

See Also

CustomInstrument Class | PowerLanguage Namespace


CustomInstrumentBase Class

Base class of custom instrument.

For a list of all members of this type, see CustomInstrumentBase Members .

System.Object
CustomInstrumentBase
CustomInstrument

[DefaultMember(MemberName="Item")]
public class CustomInstrumentBase : IInstrument, ISeriesSymbolData, IDisposable, ISeriesSymbolDataRand

Requirements

Namespace: PowerLanguage

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CustomInstrumentBase Members | PowerLanguage Namespace


CustomInstrumentBase Members

CustomInstrumentBase overview

Public Instance Properties

BarUpdateTime
Close
CloseValue
Count
Current
CurrentBar
DOM
DownTicks
DownTicksValue
FullSymbolData
High
HighValue
Info
Item
LastBarInSession
LastBarOnChart
LastBarTime
Low
LowValue
Open
OpenInt
OpenIntValue
OpenValue
Point
Request
Sessions
Status
StatusLine
TickIDValue
Ticks
TicksValue
Time
TimeValue
UpTicks
UpTicksValue
Volume
VolumeValue

Public Instance Methods

Dispose
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

CustomInstrumentBase Constructor

Protected Instance Fields

disposed
m_cur_index_driver
m_data

Protected Instance Methods

check_for_data_loaded
Finalize (inherited from Object)
make_request
MemberwiseClone (inherited from Object)

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase Constructor

CustomInstrumentBase(
IInstrument _cur_index_driver,
Resolution resolution,
MTPA_MCSymbolInfo2 instrument,
string datafeed,
RequestQuoteField _field
);

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase Fields

The fields of the CustomInstrumentBase class are listed below. For a complete list of CustomInstrumentBase class members, see the CustomInstrumentBase Members topic.

Protected Instance Fields

disposed
m_cur_index_driver
m_data

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.disposed Field

protected bool disposed;

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.m_cur_index_driver Field

protected IInstrument m_cur_index_driver;

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.m_data Field

protected readonly List<Bar> m_data;

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase Properties

The properties of the CustomInstrumentBase class are listed below. For a complete list of CustomInstrumentBase class members, see the CustomInstrumentBase Members topic.

Public Instance Properties

BarUpdateTime
Close
CloseValue
Count
Current
CurrentBar
DOM
DownTicks
DownTicksValue
FullSymbolData
High
HighValue
Info
Item
LastBarInSession
LastBarOnChart
LastBarTime
Low
LowValue
Open
OpenInt
OpenIntValue
OpenValue
Point
Request
Sessions
Status
StatusLine
TickIDValue
Ticks
TicksValue
Time
TimeValue
UpTicks
UpTicksValue
Volume
VolumeValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


BarUpdateTime Property

PowerLanguage.NET Help

CustomInstrumentBase.BarUpdateTime Property

public DateTime BarUpdateTime { public get; }

Implements

IInstrument.BarUpdateTime

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Close Property

PowerLanguage.NET Help

CustomInstrumentBase.Close Property

public ISeries<double> Close { public get; private set; }

Implements

ISeriesSymbolData.Close

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CloseValue Property

PowerLanguage.NET Help

CustomInstrumentBase.CloseValue Property

public double CloseValue { public get; }

Implements

IInstrument.CloseValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Count Property

PowerLanguage.NET Help

CustomInstrumentBase.Count Property

public int Count { public get; }

Implements

ISeriesSymbolDataRand.Count

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Current Property

PowerLanguage.NET Help

CustomInstrumentBase.Current Property

public int Current { public get; }

Implements

ISeriesSymbolDataRand.Current

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CurrentBar Property

PowerLanguage.NET Help

CustomInstrumentBase.CurrentBar Property

public int CurrentBar { public get; }

Implements

IInstrument.CurrentBar

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


DOM Property

PowerLanguage.NET Help

CustomInstrumentBase.DOM Property

public IDOMData DOM { public get; }

Implements

IInstrument.DOM

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


DownTicks Property

PowerLanguage.NET Help

CustomInstrumentBase.DownTicks Property

public ISeries<double> DownTicks { public get; private set; }

Implements

ISeriesSymbolData.DownTicks

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


DownTicksValue Property

PowerLanguage.NET Help

CustomInstrumentBase.DownTicksValue Property

public double DownTicksValue { public get; }

Implements

IInstrument.DownTicksValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


FullSymbolData Property

PowerLanguage.NET Help

CustomInstrumentBase.FullSymbolData Property

public ISeriesSymbolDataRand FullSymbolData { public get; }

Implements

IInstrument.FullSymbolData

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


High Property

PowerLanguage.NET Help

CustomInstrumentBase.High Property

public ISeries<double> High { public get; private set; }

Implements

ISeriesSymbolData.High

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


HighValue Property

PowerLanguage.NET Help

CustomInstrumentBase.HighValue Property

public double HighValue { public get; }

Implements

IInstrument.HighValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Info Property

PowerLanguage.NET Help

CustomInstrumentBase.Info Property

public IInstrumentSettings Info { public get; }

Implements

IInstrument.Info

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

CustomInstrumentBase.Item Property

public Bar this[
int barsAgo
] { public get; }

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


LastBarInSession Property

PowerLanguage.NET Help

CustomInstrumentBase.LastBarInSession Property

public bool LastBarInSession { public get; }

Implements

IInstrument.LastBarInSession

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


LastBarOnChart Property

PowerLanguage.NET Help

CustomInstrumentBase.LastBarOnChart Property

public bool LastBarOnChart { public get; }

Implements

IInstrument.LastBarOnChart

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


LastBarTime Property

PowerLanguage.NET Help

CustomInstrumentBase.LastBarTime Property

public DateTime LastBarTime { public get; }

Implements

IInstrument.LastBarTime

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Low Property

PowerLanguage.NET Help

CustomInstrumentBase.Low Property

public ISeries<double> Low { public get; private set; }

Implements

ISeriesSymbolData.Low

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


LowValue Property

PowerLanguage.NET Help

CustomInstrumentBase.LowValue Property

public double LowValue { public get; }

Implements

IInstrument.LowValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Open Property

PowerLanguage.NET Help

CustomInstrumentBase.Open Property

public ISeries<double> Open { public get; private set; }

Implements

ISeriesSymbolData.Open

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


OpenInt Property

PowerLanguage.NET Help

CustomInstrumentBase.OpenInt Property

public ISeries<double> OpenInt { public get; private set; }

Implements

ISeriesSymbolData.OpenInt

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


OpenIntValue Property

PowerLanguage.NET Help

CustomInstrumentBase.OpenIntValue Property

public double OpenIntValue { public get; }

Implements

IInstrument.OpenIntValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


OpenValue Property

PowerLanguage.NET Help

CustomInstrumentBase.OpenValue Property

public double OpenValue { public get; }

Implements

IInstrument.OpenValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Point Property

PowerLanguage.NET Help

CustomInstrumentBase.Point Property

public double Point { public get; }

Implements

IInstrument.Point

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Request Property

PowerLanguage.NET Help

CustomInstrumentBase.Request Property

public virtual InstrumentDataRequest Request { public get; protected set; }

Implements

IInstrument.Request

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Sessions Property

PowerLanguage.NET Help

CustomInstrumentBase.Sessions Property

public IROList<SessionObject> Sessions { public get; }

Implements

IInstrument.Sessions

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Status Property

PowerLanguage.NET Help

CustomInstrumentBase.Status Property

public EBarState Status { public get; }

Implements

IInstrument.Status

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


StatusLine Property

PowerLanguage.NET Help

CustomInstrumentBase.StatusLine Property

public IStatusLine StatusLine { public get; }

Implements

IInstrument.StatusLine

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


TickIDValue Property

PowerLanguage.NET Help

CustomInstrumentBase.TickIDValue Property

public uint TickIDValue { public get; }

Implements

IInstrument.TickIDValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Ticks Property

PowerLanguage.NET Help

CustomInstrumentBase.Ticks Property

public ISeries<double> Ticks { public get; private set; }

Implements

ISeriesSymbolData.Ticks

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


TicksValue Property

PowerLanguage.NET Help

CustomInstrumentBase.TicksValue Property

public double TicksValue { public get; }

Implements

IInstrument.TicksValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

CustomInstrumentBase.Time Property

public ISeries<DateTime> Time { public get; private set; }

Implements

ISeriesSymbolData.Time

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


TimeValue Property

PowerLanguage.NET Help

CustomInstrumentBase.TimeValue Property

public DateTime TimeValue { public get; }

Implements

IInstrument.TimeValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


UpTicks Property

PowerLanguage.NET Help

CustomInstrumentBase.UpTicks Property

public ISeries<double> UpTicks { public get; private set; }

Implements

ISeriesSymbolData.UpTicks

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


UpTicksValue Property

PowerLanguage.NET Help

CustomInstrumentBase.UpTicksValue Property

public double UpTicksValue { public get; }

Implements

IInstrument.UpTicksValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


Volume Property

PowerLanguage.NET Help

CustomInstrumentBase.Volume Property

public ISeries<double> Volume { public get; private set; }

Implements

ISeriesSymbolData.Volume

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


VolumeValue Property

PowerLanguage.NET Help

CustomInstrumentBase.VolumeValue Property

public double VolumeValue { public get; }

Implements

IInstrument.VolumeValue

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase Methods

The methods of the CustomInstrumentBase class are listed below. For a complete list of CustomInstrumentBase class members, see the CustomInstrumentBase Members topic.

Public Instance Methods

Dispose
Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

check_for_data_loaded
Finalize (inherited from Object)
make_request
MemberwiseClone (inherited from Object)

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.check_for_data_loaded Method

protected virtual void check_for_data_loaded();

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.Dispose Method

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.make_request Method

protected InstrumentDataRequest make_request();

See Also

CustomInstrumentBase Class | PowerLanguage Namespace


CustomInstrumentBase.InstrumentSettingsImpl Class

For a list of all members of this type, see CustomInstrumentBase.InstrumentSettingsImpl Members .

System.Object
CustomInstrumentBase.InstrumentSettingsImpl

protected sealed class InstrumentSettingsImpl : IInstrumentSettings

Requirements

Namespace: PowerLanguage

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CustomInstrumentBase.InstrumentSettingsImpl Members | PowerLanguage Namespace


CustomInstrumentBase.InstrumentSettingsImpl Members

CustomInstrumentBase.InstrumentSettingsImpl overview

Public Instance Constructors

CustomInstrumentBase.InstrumentSettingsImpl Constructor

Public Instance Properties

ASymbolInfo2
BigPointValue
BVO
Category
CurrencyCode
DailyLimit
DataFeed
Description
Exchange
Expiration
ExpirationFromVendor
Margin
MinMove
Name
OptionType
PointValue
PriceScale
QuoteField
Request
Resolution
RTDataFeed
RTExchange
RTSymbolName
SessionName
StrikePrice
TimeZone

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


CustomInstrumentBase.InstrumentSettingsImpl Constructor

InstrumentSettingsImpl(
IInstrumentSettings mImpl,
CustomInstrumentBase mOwner
);

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


CustomInstrumentBase.InstrumentSettingsImpl Properties

The properties of the CustomInstrumentBase.InstrumentSettingsImpl class are listed below. For a complete list of CustomInstrumentBase.InstrumentSettingsImpl class members, see the CustomInstrumentBase.InstrumentSettingsImpl Members topic.

Public Instance Properties

ASymbolInfo2
BigPointValue
BVO
Category
CurrencyCode
DailyLimit
DataFeed
Description
Exchange
Expiration
ExpirationFromVendor
Margin
MinMove
Name
OptionType
PointValue
PriceScale
QuoteField
Request
Resolution
RTDataFeed
RTExchange
RTSymbolName
SessionName
StrikePrice
TimeZone

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


ASymbolInfo2 Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.ASymbolInfo2 Property

public MTPA_MCSymbolInfo2 ASymbolInfo2 { public get; }

Implements

IInstrumentSettings.ASymbolInfo2

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


BigPointValue Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.BigPointValue Property

public double BigPointValue { public get; }

Implements

IInstrumentSettings.BigPointValue

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


BVO Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.BVO Property

public BuildVolumeOn BVO { public get; }

Implements

IInstrumentSettings.BVO

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Category Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Category Property

public ESymbolCategory Category { public get; }

Implements

IInstrumentSettings.Category

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


CurrencyCode Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.CurrencyCode Property

public MTPA_MCSymbolCurrency CurrencyCode { public get; }

Implements

IInstrumentSettings.CurrencyCode

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


DailyLimit Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.DailyLimit Property

public double DailyLimit { public get; }

Implements

IInstrumentSettings.DailyLimit

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


DataFeed Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.DataFeed Property

public string DataFeed { public get; }

Implements

IInstrumentSettings.DataFeed

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Description Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Description Property

public string Description { public get; }

Implements

IInstrumentSettings.Description

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Exchange Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Exchange Property

public string Exchange { public get; }

Implements

IInstrumentSettings.Exchange

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Expiration Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Expiration Property

public DateTime Expiration { public get; }

Implements

IInstrumentSettings.Expiration

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


ExpirationFromVendor Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.ExpirationFromVendor Property

public DateTime ExpirationFromVendor { public get; }

Implements

IInstrumentSettings.ExpirationFromVendor

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Margin Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Margin Property

public double Margin { public get; }

Implements

IInstrumentSettings.Margin

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


MinMove Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.MinMove Property

public double MinMove { public get; }

Implements

IInstrumentSettings.MinMove

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Name Property

public string Name { public get; }

Implements

IInstrumentSettings.Name

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


OptionType Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.OptionType Property

public OptionType OptionType { public get; }

Implements

IInstrumentSettings.OptionType

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


PointValue Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.PointValue Property

public double PointValue { public get; }

Implements

IInstrumentSettings.PointValue

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


PriceScale Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.PriceScale Property

public double PriceScale { public get; }

Implements

IInstrumentSettings.PriceScale

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


QuoteField Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.QuoteField Property

public RequestQuoteField QuoteField { public get; }

Implements

IInstrumentSettings.QuoteField

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Request Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Request Property

public DataRequest Request { public get; }

Implements

IInstrumentSettings.Request

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


Resolution Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.Resolution Property

public Resolution Resolution { public get; }

Implements

IInstrumentSettings.Resolution

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


RTDataFeed Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.RTDataFeed Property

public string RTDataFeed { public get; }

Implements

IInstrumentSettings.RTDataFeed

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


RTExchange Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.RTExchange Property

public string RTExchange { public get; }

Implements

IInstrumentSettings.RTExchange

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


RTSymbolName Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.RTSymbolName Property

public string RTSymbolName { public get; }

Implements

IInstrumentSettings.RTSymbolName

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


SessionName Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.SessionName Property

public string SessionName { public get; }

Implements

IInstrumentSettings.SessionName

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


StrikePrice Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.StrikePrice Property

public double StrikePrice { public get; }

Implements

IInstrumentSettings.StrikePrice

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


TimeZone Property

PowerLanguage.NET Help

CustomInstrumentBase.InstrumentSettingsImpl.TimeZone Property

public RequestTimeZone TimeZone { public get; }

Implements

IInstrumentSettings.TimeZone

See Also

InstrumentSettingsImpl Class | PowerLanguage Namespace


CustomInstrumentBase.SeriesImpl<T> Class

For a list of all members of this type, see CustomInstrumentBase.SeriesImpl<T> Members .

System.Object
CustomInstrumentBase.SeriesImpl<T>

[DefaultMember(MemberName="Item")]
protected sealed class SeriesImpl<T> : ISeries<T>

Requirements

Namespace: PowerLanguage

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CustomInstrumentBase.SeriesImpl<T> Members | PowerLanguage Namespace


CustomInstrumentBase.SeriesImpl<T> Members

CustomInstrumentBase.SeriesImpl<T> overview

Public Instance Constructors

CustomInstrumentBase.SeriesImpl<T> Constructor

Public Instance Properties

Item
Value

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SeriesImpl<T> Class | PowerLanguage Namespace


CustomInstrumentBase.SeriesImpl<T> Constructor

SeriesImpl<T>(
CustomInstrumentBase mOwner,
TBarFldGetter<T> mGetter
);

See Also

SeriesImpl<T> Class | PowerLanguage Namespace


CustomInstrumentBase.SeriesImpl<T> Properties

The properties of the CustomInstrumentBase.SeriesImpl<T> class are listed below. For a complete list of CustomInstrumentBase.SeriesImpl<T> class members, see the CustomInstrumentBase.SeriesImpl<T> Members topic.

Public Instance Properties

Item
Value

See Also

SeriesImpl<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

CustomInstrumentBase.SeriesImpl`1.Item Property

public T this[
int barsAgo
] { public get; }

Implements

ISeries<T>.Item

See Also

SeriesImpl<T> Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

CustomInstrumentBase.SeriesImpl`1.Value Property

public T Value { public get; }

Implements

ISeries<T>.Value

See Also

SeriesImpl<T> Class | PowerLanguage Namespace


CustomInstrumentBase.TBarFldGetter<T> Delegate

protected delegate T TBarFldGetter<T>(
Bar _bar
);

Requirements

Namespace: PowerLanguage

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PowerLanguage Namespace


DataLoadedEvent Enumeration

Enumeration the describes reasons for making the LoadDataCallback callback.

public enum DataLoadedEvent

Members

Member Name | Description
None | None.
History | LoadDataCallback was made because historical data arrived.
RTUpdateLastBar | LoadDataCallback was made because last bar was updated.
RTNewBar | LoadDataCallback was made because new bar was formed.
StatusLine |

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


DataRequest Structure

Class that describes data requests.

For a list of all members of this type, see DataRequest Members .

System.Object
DataRequest

public struct DataRequest : IEquatable<T>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

DataRequest Members | PowerLanguage Namespace


DataRequest Members

DataRequest overview

Public Static Methods

CreateBarsBack | Creates Bars Back data request.
CreateDaysBack | Creates Days Back data request.
CreateFromTo | Creates From/To data request.

Public Static Operators

Equality Operator | Indicates whether two instances are equal.
Inequality Operator | Indicates whether two instances are not equal.

Public Instance Constructors

DataRequest Constructor Initializes a new instance of the DataRequest class.

Public Instance Fields

Count | Member represents number of bars or days in BarsBack or DaysBack requests respectively.
From | Member represents the start point of the request.
RequestType | Member represents data request type.
To | Member represents the end point of the request.
ToAlwaysIsNow | Member shows if the 'To' point value is fixed or floating and is always equal to the current time. false - the value is fixed, true - the value is equal to the current time.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and a specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest Constructor

Initializes a new instance of the DataRequest class.

DataRequest(
DateTime to,
int count,
DataRequestType requestType,
DateTime from
);

Parameters

to
Specifies end point for data request.
count
Specifies number of bars or days back from end point for data request.
requestType
Specifies data request type.
from
Specifies start point for data request.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest Fields

The fields of the DataRequest structure are listed below. For a complete list of DataRequest structure members, see the DataRequest Members topic.

Public Instance Fields

Count | Member represents number of bars or days in BarsBack or DaysBack requests respectively.
From | Member represents the start point of the request.
RequestType | Member represents data request type.
To | Member represents the end point of the request.
ToAlwaysIsNow | Member shows if the 'To' point value is fixed or floating and is always equal to the current time. false - the value is fixed, true - the value is equal to the current time.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.Count Field

Member represents number of bars or days in BarsBack or DaysBack requests respectively.

public int Count;

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.From Field

Member represents the start point of the request.

public DateTime From;

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.RequestType Field

Member represents data request type.

public DataRequestType RequestType;

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.To Field

Member represents the end point of the request.

public DateTime To;

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.ToAlwaysIsNow Field

Member shows if the 'To' point value is fixed or floating and is always equal to the current time. false - the value is fixed, true - the value is equal to the current time.

public bool ToAlwaysIsNow;

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest Methods

The methods of the DataRequest structure are listed below. For a complete list of DataRequest structure members, see the DataRequest Members topic.

Public Static Methods

CreateBarsBack | Creates Bars Back data request.
CreateDaysBack | Creates Days Back data request.
CreateFromTo | Creates From/To data request.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and a specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.CreateBarsBack Method

Creates Bars Back data request.

public static DataRequest CreateBarsBack(
DateTime _to,
int _bars
);

Parameters

_to
Specifies end point for data request.
_bars
Specifies number of bars back from end point for the request.

Return Value

New DataRequest object.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.CreateDaysBack Method

Creates Days Back data request.

public static DataRequest CreateDaysBack(
DateTime _to,
int _days
);

Parameters

_to
Specifies end point for data request.
_days
Specifies number of days back from end point for the request.

Return Value

New DataRequest object.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.CreateFromTo Method

Creates From/To data request.

public static DataRequest CreateFromTo(
DateTime _from,
DateTime _to
);

Parameters

_from
Cpecifier for start point of the request.
_to
Cpecifier for end point of the request.

Return Value

New DataRequest object.

See Also

DataRequest Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

DataRequest.Equals Method

Indicates whether this instance and a specified object are equal.

Overload List

Indicates whether this instance and a specified object are equal.

public bool Equals(DataRequest)

Indicates whether this instance and a specified object are equal.

public override bool Equals(object)

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest.Equals(DataRequest) Method

Indicates whether this instance and a specified object are equal.

public bool Equals(
DataRequest other
);

Parameters

other
Another object to compare to.

Return Value

true if other and this instance are represent the same value; otherwise, false.

Implements

IEquatable< DataRequest>.Equals

See Also

DataRequest Class | PowerLanguage Namespace | DataRequest.Equals Overload List


DataRequest.Equals(Object) Method

Indicates whether this instance and a specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

DataRequest Class | PowerLanguage Namespace | DataRequest.Equals Overload List


DataRequest.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest Operators

The operators of the DataRequest structure are listed below. For a complete list of DataRequest structure members, see the DataRequest Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances are equal.
Inequality Operator | Indicates whether two instances are not equal.

See Also

DataRequest Class | DataRequest Members | PowerLanguage Namespace


DataRequest Equality Operator

Indicates whether two instances are equal.

public static bool operator ==(
DataRequest left,
DataRequest right
);

Parameters

left
One DataRequest object.
right
Another DataRequest object.

Return Value

true if both objects are represent the same value; otherwise, false.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequest Inequality Operator

Indicates whether two instances are not equal.

public static bool operator !=(
DataRequest left,
DataRequest right
);

Parameters

left
One DataRequest object.
right
Another DataRequest object.

Return Value

true if one object is not equal another one; otherwise, false.

See Also

DataRequest Class | PowerLanguage Namespace


DataRequestType Enumeration

Enumeration that describes Data Range types in data request objects DataRequest

public enum DataRequestType

Members

Member Name | Description
FromTo | From/To requests.
DaysBack | Days Back requests.
BarsBack | Bars Back Requests.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


DeltaAttributes Enumeration

Enumeration represents possible delta attributes.

public enum DeltaAttributes

Members

Member Name | Description
SHOW_DELTA | Attribute value, allowing to enable/disable mode of volume request for the resolution.
DELTA_TYPE | Attribute value, specifying delta type.
BREAKDOWN_TYPE | Attribute value, specifying the type of Breakdown.
DELTA_RESOLUTION | Attribute value, specifying build from resolution

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


DeltaType Enumeration

Enumeration represents possible values for Delta type.

public enum DeltaType

Members

Member Name | Description
None | Show Delta is disabled.
Volume | Volume Delta type.
Cumulative | Cumulative Delta type.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


DOMPrice Structure

The structure that defines a DOM price.

For a list of all members of this type, see DOMPrice Members .

System.Object
DOMPrice

public struct DOMPrice

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

DOMPrice Members | PowerLanguage Namespace


DOMPrice Members

DOMPrice overview

Public Static Operators

Equality Operator | Returns "true" if left and right are equal.
Inequality Operator | Returns "true" if left and right are not equal.

Public Instance Constructors

DOMPrice Constructor Initializes a new instance of the DOMPrice.

Public Instance Fields

Price | Price value.
Size | Size value.

Public Instance Methods

Equals | Overloaded. Returns "true" if this object is equal to the other object.
GetHashCode |
GetType (inherited from Object) |
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice Constructor

Initializes a new instance of the DOMPrice.

DOMPrice(
double price,
double size
);

Parameters

price
Price value.
size
Size value.

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice Fields

The fields of the DOMPrice structure are listed below. For a complete list of DOMPrice structure members, see the DOMPrice Members topic.

Public Instance Fields

Price | Price value.
Size | Size value.

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice.Price Field

Price value.

public readonly double Price;

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice.Size Field

Size value.

public readonly double Size;

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice Methods

The methods of the DOMPrice structure are listed below. For a complete list of DOMPrice structure members, see the DOMPrice Members topic.

Public Instance Methods

Equals | Overloaded. Returns "true" if this object is equal to the other object.
GetHashCode |
GetType (inherited from Object) |
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DOMPrice Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

DOMPrice.Equals Method

Returns "true" if this object is equal to the other object.

Overload List

Returns "true" if this object is equal to the other object.

public bool Equals(DOMPrice)

public override bool Equals(object)

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice.Equals(DOMPrice) Method

Returns "true" if this object is equal to the other object.

public bool Equals(
DOMPrice other
);

Parameters

other

Return Value

See Also

DOMPrice Class | PowerLanguage Namespace | DOMPrice.Equals Overload List


DOMPrice.Equals(Object) Method

public override bool Equals(
object obj
);

See Also

DOMPrice Class | PowerLanguage Namespace | DOMPrice.Equals Overload List


DOMPrice.GetHashCode Method

public override int GetHashCode();

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice Operators

The operators of the DOMPrice structure are listed below. For a complete list of DOMPrice structure members, see the DOMPrice Members topic.

Public Static Operators

Equality Operator | Returns "true" if left and right are equal.
Inequality Operator | Returns "true" if left and right are not equal.

See Also

DOMPrice Class | DOMPrice Members | PowerLanguage Namespace


DOMPrice Equality Operator

Returns "true" if left and right are equal.

public static bool operator ==(
DOMPrice left,
DOMPrice right
);

Parameters

left
right

Return Value

See Also

DOMPrice Class | PowerLanguage Namespace


DOMPrice Inequality Operator

Returns "true" if left and right are not equal.

public static bool operator !=(
DOMPrice left,
DOMPrice right
);

Parameters

left
right

Return Value

See Also

DOMPrice Class | PowerLanguage Namespace


DrawContext Class

Structure containing information necessary for drawing on the chart.

For a list of all members of this type, see DrawContext Members .

System.Object
DrawContext

public sealed class DrawContext

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

DrawContext Members | PowerLanguage Namespace


DrawContext Members

DrawContext overview

Public Instance Fields

BackGround | Returns chart background color.
DirtyRect | Chart area that needs to be re-drawn, i.e. which you modified.
DrawRect | Chart area that will be drawn in.
Environment | Provides methods for converting ChartPoint into PointF and back. Gives access to information about drawings on bars. IDrawSymbolBars.
FinalDraw | Returns "true" if this is the final redraw. I.e. there won't be any more redrawings due to changes in DirtyRect.
FullRect | Entire chart area.
graphics | Handle for drawing.
ReDraw | Set to "true" if full chart redraw needed.
StatusLineFont | Returns chart status line font.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext Fields

The fields of the DrawContext class are listed below. For a complete list of DrawContext class members, see the DrawContext Members topic.

Public Instance Fields

BackGround | Returns chart background color.
DirtyRect | Chart area that needs to be re-drawn, i.e. which you modified.
DrawRect | Chart area that will be drawn in.
Environment | Provides methods for converting ChartPoint into PointF and back. Gives access to information about drawings on bars. IDrawSymbolBars.
FinalDraw | Returns "true" if this is the final redraw. I.e. there won't be any more redrawings due to changes in DirtyRect.
FullRect | Entire chart area.
graphics | Handle for drawing.
ReDraw | Set to "true" if full chart redraw needed.
StatusLineFont | Returns chart status line font.

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.BackGround Field

Returns chart background color.

public readonly Color BackGround;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.DirtyRect Field

Chart area that needs to be re-drawn, i.e. which you modified.

public RectangleF DirtyRect;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.DrawRect Field

Chart area that will be drawn in.

public readonly RectangleF DrawRect;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.Environment Field

Provides methods for converting ChartPoint into PointF and back. Gives access to information about drawings on bars. IDrawSymbolBars.

public readonly IDrawDataEnviroment Environment;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.FinalDraw Field

Returns "true" if this is the final redraw. I.e. there won't be any more redrawings due to changes in DirtyRect.

public readonly bool FinalDraw;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.FullRect Field

Entire chart area.

public readonly RectangleF FullRect;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.graphics Field

Handle for drawing.

public readonly Graphics graphics;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.ReDraw Field

Set to "true" if full chart redraw needed.

public bool ReDraw;

See Also

DrawContext Class | PowerLanguage Namespace


DrawContext.StatusLineFont Field

Returns chart status line font.

public readonly Font StatusLineFont;

See Also

DrawContext Class | PowerLanguage Namespace


DrawingObjectException Class

The exception that is displayed when working with drawings.

For a list of all members of this type, see DrawingObjectException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
DrawingObjectException
ArrowObjectException
TextObjectException
TrendLineObjectException

[Serializable]
public class DrawingObjectException : ExecuteStudyException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

DrawingObjectException Members | PowerLanguage Namespace


DrawingObjectException Members

DrawingObjectException overview

Public Instance Properties

Data (inherited from Exception) |
Error | Returns error code.
HelpLink (inherited from Exception) |
HResult (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object) |
GetBaseException (inherited from Exception) |
GetHashCode (inherited from Object) |
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) |
ToString (inherited from Exception) |

Protected Instance Constructors

DrawingObjectException Overloaded. Initializes a new instance of the DrawingObjectException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

DrawingObjectException Class | PowerLanguage Namespace


DrawingObjectException Constructor

Initializes a new instance of the DrawingObjectException class.

Overload List

Initializes a new instance of the DrawingObjectException class.

protected DrawingObjectException(int)

protected DrawingObjectException(SerializationInfo,StreamingContext)

See Also

DrawingObjectException Class | PowerLanguage Namespace


DrawingObjectException Constructor

Initializes a new instance of the DrawingObjectException class.

DrawingObjectException(
int errCode
);

Parameters

errCode
A code that describes the error

See Also

DrawingObjectException Class | PowerLanguage Namespace | DrawingObjectException Constructor Overload List


DrawingObjectException Constructor

DrawingObjectException(
SerializationInfo info,
StreamingContext context
);

See Also

DrawingObjectException Class | PowerLanguage Namespace | DrawingObjectException Constructor Overload List


DrawingObjectException Properties

The properties of the DrawingObjectException class are listed below. For a complete list of DrawingObjectException class members, see the DrawingObjectException Members topic.

Public Instance Properties

Data (inherited from Exception) |
Error | Returns error code.
HelpLink (inherited from Exception) |
HResult (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

See Also

DrawingObjectException Class | PowerLanguage Namespace


Error Property

PowerLanguage.NET Help

DrawingObjectException.Error Property

Returns error code.

public int Error { public get; private set; }

See Also

DrawingObjectException Class | PowerLanguage Namespace


DrawingObjectException Methods

The methods of the DrawingObjectException class are listed below. For a complete list of DrawingObjectException class members, see the DrawingObjectException Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetBaseException (inherited from Exception) |
GetHashCode (inherited from Object) |
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) |
ToString (inherited from Exception) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawingObjectException Class | PowerLanguage Namespace


DrawingObjectException.GetObjectData Method

When overridden in a derived class, sets the SerializationInfo with information about the exception.

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being displayed.
context
The StreamingContext that contains contextual information about the source or destination.

Implements

ISerializable.GetObjectData

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is a null reference (Nothing in Visual Basic).

See Also

DrawingObjectException Class | PowerLanguage Namespace


EAlertType Enumeration

Enumeration describing alert types.

public enum EAlertType

Members

Member Name | Description
Disabled | Alerts are disabled.
BreakoutIntrabar | Alerts can be triggered intrabar.
BreakoutOnClose | Alerts can be triggered on close of bar.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EApplicationCode Enumeration

The code of the application that executes the study.

public enum EApplicationCode

Members

Member Name | Description
Unknown | Unknown application code.
Charting | 'Charting' application code.
Scanner | 'Scanner' application code.
Portfolio | 'Portfolio' application code.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace | ApplicationCode


EArrowForms Enumeration

Enumeration describing arrow forms.

public enum EArrowForms

Members

Member Name | Description
ArrowForm0 | Arrow form 0.
ArrowForm1 | Arrow form 1.
ArrowForm2 | Arrow form 2.
ArrowForm3 | Arrow form 3.
ArrowForm4 | Arrow form 4.
ArrowForm5 | Arrow form 5.
ArrowForm6 | Arrow form 6.
ArrowForm7 | Arrow form 7.
ArrowForm8 | Arrow form 8.
ArrowForm9 | Arrow form 9.
ArrowForm10 | Arrow form 10.
ArrowForm11 | Arrow form 11.
ArrowForm12 | Arrow form 12.
ArrowForm13 | Arrow form 13.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EBarState Enumeration

Enumeration describing bar state.

public enum EBarState

Members

Member Name | Description
None | 'None' bar state.
Open | Open bar.
Inside | Inside bar.
Close | Close bar.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EDrawingSource Enumeration

Enumeration describing drawing’s origin.

public enum EDrawingSource

Members

Member Name | Description
CurrentTech | Drawing was created by current study.
NotCurrentTechOrManual | Drawing was not created by the current study or manually.
AnyTechOrManual | Drawing was created by any study or manually.
CurrentTechOrManual | Drawing was created by current study or manually.
NotCurrentTech | Drawing was not created by current study.
AnyTech | Drawing was not created by any study.
Manual | Drawing was created manually.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EDrawPhases Enumeration

Enumeration describing chart drawing phases.

public enum EDrawPhases

Members

Member Name | Description
AfterBGFill | Phase after background filled.
BeforeBGShapes | Phase after grid is drawn, but before background figures are drawn (circles, ellipses, etc.)
BeforeSeries | Phase after background figures are drawn, but before data series (bars) are drawn, and before indicators (plots) are drawn.
BeforeFGShapes | Phase after series and plots are drawn, but before foreground figures (trendlines, text, etc.)are drawn.
Final | Phase after everything is drawn.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EMarketPositionSide Enumeration

Enumeration describing market position side.

public enum EMarketPositionSide

Members

Member Name | Description
Flat | Flat position.
Long | Long position.
Short | Short position.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EOrderAction Enumeration

Enumeration describing order action.

public enum EOrderAction

Members

Member Name | Description
Buy | Buy order action (closes current short position AND buys indicated amount of contracts).
Sell | Sell order action (sells indicated amount of contracts).
SellShort | Sell short order action (closes current long position AND sells indicated amount of contracts).
BuyToCover | Buy to cover order action (buys indicated number of contracts).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EPlotShapes Enumeration

Enumeration describing plot shapes.

public enum EPlotShapes

Members

Member Name | Description
Line | Line plot shape.
Histogram | Histogram plot shape.
Point | Point plot shape.
Cross | Cross plot shape.
BarHigh | BarHigh plot shape.
BarLow | BarLow plot shape.
LeftTick | LeftTick plot shape.
RightTick | RightTick plot shape.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EPlotStyle Enumeration

Enumeration describing plot shapes.

public enum EPlotStyle

Members

Member Name | Description
Solid | Solid plot line.
Dash | Dash plot line.
Dot | Dot plot line.
DashDot | Dash-Dot-Dash-Dot plot line.
DashDotDot | Dash-Dot-Dot-Dash plot line.
Invisible | Invisible plot line.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ERectPattern Enumeration

Enumeration describing rectangle patterns.

public enum ERectPattern

Members

Member Name | Description
Solid | Solid pattern.
Hollow | Hollow pattern.
Horizontal | Horizontal pattern. -----
Vertical | Vertical pattern. |||||
FDiagonal | FDiagonal pattern. \\\\\
BDiagonal | BDiagonal pattern. /////
Cross | Crosses pattern. +++++
DiagCross | Diagonal crosses pattern. xxxxx

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


EResolution Enumeration

Enumeration describing resolution type.

public enum EResolution

Members

Member Name | Description
Tick | Tick resolution type.
Volume | Volume resolution type.
Second | Second resolution type.
Minute | Minute resolution type.
Hour | Hour resolution type.
Day | Day resolution type.
Week | Week resolution type.
Month | Month resolution type.
Year | Year resolution type.
Quarter | Quarter resolution type.
Points | Points resolution type.
Change | Change resolution type.
OrigPoints | OrigPoints resolution type.
CustomTick | Tick based custom resolution type.
CustomVolume | Volume based custom resolution type.
CustomSecond | Second based custom resolution type.
CustomMinute | Minute based custom resolution type.
CustomHour | Hour based custom resolution type.
CustomDay | Day based custom resolution type.
CustomWeek | Week based custom resolution type.
CustomMonth | Month based custom resolution type.
CustomYear | Year based custom resolution type.
CustomQuarter | Quarter based custom resolution type.
CustomPoints | Points based custom resolution type.
CustomChange | Change based custom resolution type.
CustomOrigPoints | OrigPoints based custom resolution type.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ESpecOrdersMode Enumeration

Enumeration describing special orders mode.

public enum ESpecOrdersMode

Members

Member Name | Description
PerContract | Per contract mode.
PerPosition | Per position mode.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ESymbolCategory Enumeration

Enumeration describing Symbol Category.

public enum ESymbolCategory

Members

Member Name | Description
None | "None" symbol category.
Future | "Futures" symbol category.
FutureOption | "Futures Option" symbol category.
Stock | "Stock" symbol category.
StockOption | "Stock Option" symbol category.
Index | "Index" symbol category.
CurrOption | "Currency Option" symbol category.
MutualFund | "Mutual Fund" symbol category.
MoneyMarketFund | "Money Market Fund" symbol category.
IndexOption | "Index Option" symbol category.
Cash | "Cash Option" symbol category.
Bond | "Bond" symbol category.
Spread | "Spread" symbol category.
Forex | "Forex" symbol category.
CPCSymbol | "CPCSymbol" symbol category.
Composites | "Composites" symbol category.
FutureRoot | "FutureRoot" symbol category.
FutureOptionRoot | "FutureOptionRoot" symbol category.
StockOptionRoot | "StockOptionRoot" symbol category.
FutureRolover | "Futures Rollover" symbol category.
Commodity | "Commodity" symbol category.
Crypto | "Crypto" symbol category.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ESymbolSettingsType Enumeration

Enumeration describing settings types.

public enum ESymbolSettingsType

Members

Member Name | Description
Custom | Custom settings
Exchange | exchange settings
Dictionary | Symbol Dictionary settings (for futures)

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ETextStyleH Enumeration

Enumeration describing horizontal text alignment style.

public enum ETextStyleH

Members

Member Name | Description
Right | Align text to the right.
Left | Align text to the left.
Center | Center the text.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ETextStyleV Enumeration

Enumeration describing vertical text alignment style.

public enum ETextStyleV

Members

Member Name | Description
Below | Below text.
Above | Above text.
Center | Center the text.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ETickTradedSide Enumeration

Enumeration represents the trade side of the tick, i.e. ask or bid.

public enum ETickTradedSide

Members

Member Name | Description
Undefined | Undefined.
AskTraded | Traded Ask.
BidTraded | Traded Bid.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ETickTradedSideEx Enumeration

Enumeration represents the extended trade side of the tick

public enum ETickTradedSideEx

Members

Member Name | Description
Undefined | Undefined.
AboveAsk | Above Ask.
Ask | Ask.
Bid | Bid.
BellowBid | Bellow Bid.
BetweenAskBid | Between Ask Bid.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ETLStyle Enumeration

Enumeration describing trend line style. Applicable to rectangle drawings also.

public enum ETLStyle

Members

Member Name | Description
ToolSolid | Solid line style.
ToolDashed | Dashed line style.
ToolDotted | Dotted line style.
ToolDashed2 | Dashed2 line style.
ToolDashed3 | Dashed3 line style.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ExitFromOneEntryOnce Enumeration

Describes mode for processing exit orders.

public enum ExitFromOneEntryOnce

Members

Member Name | Description
FillAndKillExitOrder | Any one exit order can be applied an unlimited number of times to one entry. After this exit filled it cannot be applied again until the script recalculates and generates again.
StandardCalculation | Default. Any one exit order cannot be applied to one entry more than once. Exit order that was filled can be generated again and applied to a different entry.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


ExitFromOneEntryOnceAttribute Class

The class that defines ExitFromOneEntryOnceAttribute.

For a list of all members of this type, see ExitFromOneEntryOnceAttribute Members .

System.Object
Attribute
ExitFromOneEntryOnceAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class ExitFromOneEntryOnceAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ExitFromOneEntryOnceAttribute Members | PowerLanguage Namespace


ExitFromOneEntryOnceAttribute Members

ExitFromOneEntryOnceAttribute overview

Public Instance Constructors

ExitFromOneEntryOnceAttribute Overloaded. Initializes a new instance of the ExitFromOneEntryOnceAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. ExitFromOneEntryOnceAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ExitFromOneEntryOnceAttribute Class | PowerLanguage Namespace


ExitFromOneEntryOnceAttribute Constructor

Initializes a new instance of the ExitFromOneEntryOnceAttribute class.

Overload List

Initializes a new instance of the ExitFromOneEntryOnceAttribute class.

public ExitFromOneEntryOnceAttribute()

Initializes a new instance of the ExitFromOneEntryOnceAttribute class.

public ExitFromOneEntryOnceAttribute(ExitFromOneEntryOnce)

See Also

ExitFromOneEntryOnceAttribute Class | PowerLanguage Namespace


ExitFromOneEntryOnceAttribute Constructor

Initializes a new instance of the ExitFromOneEntryOnceAttribute class.

ExitFromOneEntryOnceAttribute(
ExitFromOneEntryOnce value
);

Parameters

value
ExitFromOneEntryOnceAttribute value.

See Also

ExitFromOneEntryOnceAttribute Class | PowerLanguage Namespace | ExitFromOneEntryOnceAttribute Constructor Overload List


ExitFromOneEntryOnceAttribute Constructor

Initializes a new instance of the ExitFromOneEntryOnceAttribute class.

ExitFromOneEntryOnceAttribute();

See Also

ExitFromOneEntryOnceAttribute Class | PowerLanguage Namespace | ExitFromOneEntryOnceAttribute Constructor Overload List


ExitFromOneEntryOnceAttribute Properties

The properties of the ExitFromOneEntryOnceAttribute class are listed below. For a complete list of ExitFromOneEntryOnceAttribute class members, see the ExitFromOneEntryOnceAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. ExitFromOneEntryOnceAttribute value.

See Also

ExitFromOneEntryOnceAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

ExitFromOneEntryOnceAttribute.Value Property

Read-write property. ExitFromOneEntryOnceAttribute value.

public ExitFromOneEntryOnce Value { public get; public set; }

See Also

ExitFromOneEntryOnceAttribute Class | PowerLanguage Namespace


FootPrintAttributes Enumeration

Enumeration represents options for Volume Delta chart type.

public enum FootPrintAttributes

Members

Member Name | Description
CHART_TYPE | Base element for Volume Delta.
PRINT_SHOW_PERCENT | Displayed as a percentage.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


FootPrintChartType Enumeration

Enumeration represents the base elements type for Volume Delta chart type.

public enum FootPrintChartType

Members

Member Name | Description
BID_ASK_VOL | Volume Delta is constructed by Bid x Ask volume.
TOTAL_VOL | Volume Delta is constructed by Total volume.
DELTA_ASK_BID_VOL | Volume Delta is constructed by Delta (Ask volume - Bid volume).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


FunctionObject<T> Class

Class that describes a function object.

For a list of all members of this type, see FunctionObject<T> Members .

System.Object
CStudyControl
FunctionObject<T>
FunctionSeries<T>
FunctionSimple<T>

[DefaultMember(MemberName="Item")]
public abstract class FunctionObject<T> : CStudyControl, IFunctionObject<T>, ISeries<T>

Requirements

Namespace: PowerLanguage

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

FunctionObject<T> Members | PowerLanguage Namespace


FunctionObject<T> Members

FunctionObject<T> overview

Public Instance Constructors

FunctionObject<T> Constructor Initializes a new instance of the FunctionObject class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call | Overloaded. Returns a reference to the curent bar.
DoDestroy |
DoInitializeVars |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FunctionObject<T> Class | PowerLanguage Namespace


FunctionObject<T> Constructor

Initializes a new instance of the FunctionObject class.

FunctionObject<T>(
CStudyControl _master,
bool _is_series,
int _ds
);

See Also

FunctionObject<T> Class | PowerLanguage Namespace


FunctionObject<T> Properties

The properties of the FunctionObject<T> class are listed below. For a complete list of FunctionObject<T> class members, see the FunctionObject<T> Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy Read-only property. Returns a reference to the current strategy.

See Also

FunctionObject<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

FunctionObject`1.Item Property

public abstract T this[
int bars_ago
] { public get; }

Implements

ISeries<T>.Item

See Also

FunctionObject<T> Class | PowerLanguage Namespace


MyStrategy Property

PowerLanguage.NET Help

FunctionObject`1.MyStrategy Property

Read-only property. Returns a reference to the current strategy.

protected IStrategy MyStrategy { protected get; }

See Also

FunctionObject<T> Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

FunctionObject`1.Value Property

Read-only property. Returns a reference to the curent bar.

public virtual T Value { public get; }

Implements

ISeries<T>.Value

See Also

FunctionObject<T> Class | PowerLanguage Namespace


FunctionObject<T> Methods

The methods of the FunctionObject<T> class are listed below. For a complete list of FunctionObject<T> class members, see the FunctionObject<T> Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call | Overloaded. Returns a reference to the curent bar.
DoDestroy |
DoInitializeVars |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FunctionObject<T> Class | PowerLanguage Namespace


Call Method

PowerLanguage.NET Help

FunctionObject`1.Call Method

Returns a reference to the curent bar.

Overload List

Returns a reference to the curent bar.

public T Call()

Returns a reference to a bar located a specified number of bars back from the current bar.

public T Call(int)

See Also

FunctionObject<T> Class | PowerLanguage Namespace


FunctionObject<T>.Call() Method

Returns a reference to the curent bar.

public T FunctionObject();

See Also

FunctionObject<T> Class | PowerLanguage Namespace | FunctionObject<T>.Call Overload List


FunctionObject<T>.Call(Int32) Method

Returns a reference to a bar located a specified number of bars back from the current bar.

public T FunctionObject(
int bars_ago
);

See Also

FunctionObject<T> Class | PowerLanguage Namespace | FunctionObject<T>.Call Overload List


FunctionObject<T>.Dispose Method

protected override void FunctionObject(
bool A_0
);

See Also

FunctionObject<T> Class | PowerLanguage Namespace


FunctionObject<T>.DoDestroy Method

public void FunctionObject();

See Also

FunctionObject<T> Class | PowerLanguage Namespace


FunctionObject<T>.DoInitializeVars Method

public void FunctionObject(
IInitIndexes* _indexes
);

See Also

FunctionObject<T> Class | PowerLanguage Namespace


GetLambda<T> Delegate

Delegate GetLambda

public delegate T GetLambda<T>(
int barsBack
);

Parameters

barsBack
The bars back number.

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


IAlert Interface

An interface for working with alerts.

For a list of all members of this type, see IAlert Members .

public interface IAlert

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IAlert Members | PowerLanguage Namespace


IAlert Members

IAlert overview

Public Instance Properties

CheckAlertLastBar | Read-only property. Indicates whether an alert can be generated on the last bar. For all but the last bar returns 'false'.
Enabled | Read-only property. Indicates whether a study’s alert is in enabled state.

Public Instance Methods

Alert | Overloaded. A method that displays an alert.
Cancel | A method for cancelling an alert generated on a current bar.

See Also

IAlert Interface | PowerLanguage Namespace


IAlert Properties

The properties of the IAlert interface are listed below. For a complete list of IAlert interface members, see the IAlert Members topic.

Public Instance Properties

CheckAlertLastBar | Read-only property. Indicates whether an alert can be generated on the last bar. For all but the last bar returns 'false'.
Enabled | Read-only property. Indicates whether a study’s alert is in enabled state.

See Also

IAlert Interface | PowerLanguage Namespace


CheckAlertLastBar Property

PowerLanguage.NET Help

IAlert.CheckAlertLastBar Property

Read-only property. Indicates whether an alert can be generated on the last bar. For all but the last bar returns 'false'.

public bool CheckAlertLastBar { public get; }

See Also

IAlert Interface | PowerLanguage Namespace


Enabled Property

PowerLanguage.NET Help

IAlert.Enabled Property

Read-only property. Indicates whether a study’s alert is in enabled state.

public bool Enabled { public get; }

See Also

IAlert Interface | PowerLanguage Namespace


IAlert Methods

The methods of the IAlert interface are listed below. For a complete list of IAlert interface members, see the IAlert Members topic.

Public Instance Methods

Alert | Overloaded. A method that displays an alert.
Cancel | A method for cancelling an alert generated on a current bar.

See Also

IAlert Interface | PowerLanguage Namespace


Alert Method

PowerLanguage.NET Help

IAlert.Alert Method

A method that displays an alert.

Overload List

A method that displays an alert.

void Alert()

A method that displays an alert with a resulting string of '_args' arguments application to '_format' formatting string and specific backround/text colors.

void Alert(Color,Color,string,params object[])

A method that displays an alert with a resulting string of '_args' arguments application to '_format' formatting string and specific backround color.

void Alert(Color,string,params object[])

A method that displays an alert with a resulting string of '_args' arguments application to '_format' formatting string.

void Alert(string,params object[])

See Also

IAlert Interface | PowerLanguage Namespace


IAlert.Alert() Method

A method that displays an alert.

void Alert();

See Also

IAlert Interface | PowerLanguage Namespace | IAlert.Alert Overload List


IAlert.Alert(Color, Color, String, Object) Method

A method that displays an alert with a resulting string of '_args' arguments application to '_format' formatting string and specific backround/text colors.

void Alert(
Color bgColor,
Color txtColor,
string format,
params object[] _args
);

Parameters

bgColor
txtColor
format
_args

See Also

IAlert Interface | PowerLanguage Namespace | IAlert.Alert Overload List


IAlert.Alert(Color, String, Object) Method

A method that displays an alert with a resulting string of '_args' arguments application to '_format' formatting string and specific backround color.

void Alert(
Color bgColor,
string format,
params object[] _args
);

Parameters

bgColor
format
_args

See Also

IAlert Interface | PowerLanguage Namespace | IAlert.Alert Overload List


IAlert.Alert(String, Object) Method

A method that displays an alert with a resulting string of '_args' arguments application to '_format' formatting string.

void Alert(
string format,
params object[] _args
);

Parameters

format
_args

See Also

IAlert Interface | PowerLanguage Namespace | IAlert.Alert Overload List


IAlert.Cancel Method

A method for cancelling an alert generated on a current bar.

void Cancel();

See Also

IAlert Interface | PowerLanguage Namespace


IApplicationInfo Interface

Environment access interface.

For a list of all members of this type, see IApplicationInfo Members .

public interface IApplicationInfo

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IApplicationInfo Members | PowerLanguage Namespace


IApplicationInfo Members

IApplicationInfo overview

Public Instance Properties

ApplicationCode | Read-only property. Returns the code of the application that executed the study.
BarSpacing | Read-only property. Returns a distance between bars in pixels.
BGColor | Read-only property. Returns the Background Color of the chart.
CalcReason | Read-only property. Returns the reason for the calculation. CalculationReason.
ChartShiftBars | Read-only property. Returns a distance from the last bar to the right border of the chart’s screen area, measured in bars.
ChartShiftPcnt | Read-only property. Returns a distance from the last bar to the right border of the chart’s screen area, measured in percent.
ChartWindowHWND | Read-only property. Returns HWND of window where study was applied.
HighestScaleValue | Read-only property. Returns the highest bar price on the visible part of the chart.
IOGEnabled | Read-only property. Indicates if Intrabar Order Generation (IOG) mode is on.
IsAutoTradingMode | Read-only property. Indicates if auto-trading is on.
IsRealTimeCalc | Read-only property. Indicates if there‘s an ongoing real-time calculation.
LeftScreenTime | Read-only property. Returns the first bar’s time on the visible part of the chart.
LowestScaleValue | Read-only property. Returns the lowest bar price on the visible part of the chart.
Optimizing | Read-only property. Indicates if optimization is running.
OrderConfirmationRequired | Read-only property. Indicates if auto-trading is on with order confirmation.
RightScreenTime | Read-only property. Returns the last bar’s time on the visible part of the chart.
ScannerRow | Read-only property. Identifies the symbol's row number in Scanner; returns a positive non-zero value from a Scanner application else returns 0.
UserID | Read-only property. Returns the UserID of a user (can be seen in MC->Help->About).
UserName | Read-only property. Returns the MultiCharts user's authorization login, i.e. the license name provided after purchase.

See Also

IApplicationInfo Interface | PowerLanguage Namespace


IApplicationInfo Properties

The properties of the IApplicationInfo interface are listed below. For a complete list of IApplicationInfo interface members, see the IApplicationInfo Members topic.

Public Instance Properties

ApplicationCode | Read-only property. Returns the code of the application that executed the study.
BarSpacing | Read-only property. Returns a distance between bars in pixels.
BGColor | Read-only property. Returns the Background Color of the chart.
CalcReason | Read-only property. Returns the reason for the calculation. CalculationReason.
ChartShiftBars | Read-only property. Returns a distance from the last bar to the right border of the chart’s screen area, measured in bars.
ChartShiftPcnt | Read-only property. Returns a distance from the last bar to the right border of the chart’s screen area, measured in percent.
ChartWindowHWND | Read-only property. Returns HWND of window where study was applied.
HighestScaleValue | Read-only property. Returns the highest bar price on the visible part of the chart.
IOGEnabled | Read-only property. Indicates if Intrabar Order Generation (IOG) mode is on.
IsAutoTradingMode | Read-only property. Indicates if auto-trading is on.
IsRealTimeCalc | Read-only property. Indicates if there‘s an ongoing real-time calculation.
LeftScreenTime | Read-only property. Returns the first bar’s time on the visible part of the chart.
LowestScaleValue | Read-only property. Returns the lowest bar price on the visible part of the chart.
Optimizing | Read-only property. Indicates if optimization is running.
OrderConfirmationRequired | Read-only property. Indicates if auto-trading is on with order confirmation.
RightScreenTime | Read-only property. Returns the last bar’s time on the visible part of the chart.
ScannerRow | Read-only property. Identifies the symbol's row number in Scanner; returns a positive non-zero value from a Scanner application else returns 0.
UserID | Read-only property. Returns the UserID of a user (can be seen in MC->Help->About).
UserName | Read-only property. Returns the MultiCharts user's authorization login, i.e. the license name provided after purchase.

See Also

IApplicationInfo Interface | PowerLanguage Namespace


ApplicationCode Property

PowerLanguage.NET Help

IApplicationInfo.ApplicationCode Property

Read-only property. Returns the code of the application that executed the study.

public EApplicationCode ApplicationCode { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


BarSpacing Property

PowerLanguage.NET Help

IApplicationInfo.BarSpacing Property

Read-only property. Returns a distance between bars in pixels.

public double BarSpacing { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


BGColor Property

PowerLanguage.NET Help

IApplicationInfo.BGColor Property

Read-only property. Returns the Background Color of the chart.

public Color BGColor { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


CalcReason Property

PowerLanguage.NET Help

IApplicationInfo.CalcReason Property

Read-only property. Returns the reason for the calculation. CalculationReason.

public CalculationReason CalcReason { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


ChartShiftBars Property

PowerLanguage.NET Help

IApplicationInfo.ChartShiftBars Property

Read-only property. Returns a distance from the last bar to the right border of the chart’s screen area, measured in bars.

public int ChartShiftBars { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


ChartShiftPcnt Property

PowerLanguage.NET Help

IApplicationInfo.ChartShiftPcnt Property

Read-only property. Returns a distance from the last bar to the right border of the chart’s screen area, measured in percent.

public int ChartShiftPcnt { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


ChartWindowHWND Property

PowerLanguage.NET Help

IApplicationInfo.ChartWindowHWND Property

Read-only property. Returns HWND of window where study was applied.

public IntPtr ChartWindowHWND { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


HighestScaleValue Property

PowerLanguage.NET Help

IApplicationInfo.HighestScaleValue Property

Read-only property. Returns the highest bar price on the visible part of the chart.

public double HighestScaleValue { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


IOGEnabled Property

PowerLanguage.NET Help

IApplicationInfo.IOGEnabled Property

Read-only property. Indicates if Intrabar Order Generation (IOG) mode is on.

public bool IOGEnabled { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


IsAutoTradingMode Property

PowerLanguage.NET Help

IApplicationInfo.IsAutoTradingMode Property

Read-only property. Indicates if auto-trading is on.

public bool IsAutoTradingMode { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


IsRealTimeCalc Property

PowerLanguage.NET Help

IApplicationInfo.IsRealTimeCalc Property

Read-only property. Indicates if there‘s an ongoing real-time calculation.

public bool IsRealTimeCalc { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


LeftScreenTime Property

PowerLanguage.NET Help

IApplicationInfo.LeftScreenTime Property

Read-only property. Returns the first bar’s time on the visible part of the chart.

public DateTime LeftScreenTime { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


LowestScaleValue Property

PowerLanguage.NET Help

IApplicationInfo.LowestScaleValue Property

Read-only property. Returns the lowest bar price on the visible part of the chart.

public double LowestScaleValue { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


Optimizing Property

PowerLanguage.NET Help

IApplicationInfo.Optimizing Property

Read-only property. Indicates if optimization is running.

public bool Optimizing { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


OrderConfirmationRequired Property

PowerLanguage.NET Help

IApplicationInfo.OrderConfirmationRequired Property

Read-only property. Indicates if auto-trading is on with order confirmation.

public bool OrderConfirmationRequired { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


RightScreenTime Property

PowerLanguage.NET Help

IApplicationInfo.RightScreenTime Property

Read-only property. Returns the last bar’s time on the visible part of the chart.

public DateTime RightScreenTime { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


ScannerRow Property

PowerLanguage.NET Help

IApplicationInfo.ScannerRow Property

Read-only property. Identifies the symbol's row number in Scanner; returns a positive non-zero value from a Scanner application else returns 0.

public int ScannerRow { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


UserID Property

PowerLanguage.NET Help

IApplicationInfo.UserID Property

Read-only property. Returns the UserID of a user (can be seen in MC->Help->About).

public long UserID { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


UserName Property

PowerLanguage.NET Help

IApplicationInfo.UserName Property

Read-only property. Returns the MultiCharts user's authorization login, i.e. the license name provided after purchase.

public string UserName { public get; }

See Also

IApplicationInfo Interface | PowerLanguage Namespace


IArray<T> Interface

The array access interface.

For a list of all members of this type, see IArray<T> Members .

public interface IArray<T> : IArraySeries<T>

Types that implement IArray<T>

Type | Description
ArraySeries<T> | Array series class with behavior similar to PowerLanguage version.
ArraySimple<T> | Array simple class with behavior similar to PowerLanguage version.

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IArray<T> Members | PowerLanguage Namespace


IArray<T> Members

IArray<T> overview

Public Instance Properties

DefaultValue Read-only properties. Returns the default value.

See Also

IArray<T> Interface | PowerLanguage Namespace


IArray<T> Properties

The properties of the IArray<T> interface are listed below. For a complete list of IArray<T> interface members, see the IArray<T> Members topic.

Public Instance Properties

DefaultValue Read-only properties. Returns the default value.

See Also

IArray<T> Interface | PowerLanguage Namespace


DefaultValue Property

PowerLanguage.NET Help

IArray`1.DefaultValue Property

Read-only properties. Returns the default value.

public T DefaultValue { public set; }

See Also

IArray<T> Interface | PowerLanguage Namespace


IArray2D<T> Interface

The 2D array access interface.

For a list of all members of this type, see IArray2D<T> Members .

public interface IArray2D<T> : IArraySeries2D<T>

Types that implement IArray2D<T>

Type | Description
Array2DSeries<T> | 2D array series class with behavior similar to PowerLanguage version.
Array2DSimple<T> | 2D array simple class with behavior similar to PowerLanguage version.

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IArray2D<T> Members | PowerLanguage Namespace


IArray2D<T> Members

IArray2D<T> overview

Public Instance Properties

DefaultValue Read-only properties. Returns the default value.

See Also

IArray2D<T> Interface | PowerLanguage Namespace


IArray2D<T> Properties

The properties of the IArray2D<T> interface are listed below. For a complete list of IArray2D<T> interface members, see the IArray2D<T> Members topic.

Public Instance Properties

DefaultValue Read-only properties. Returns the default value.

See Also

IArray2D<T> Interface | PowerLanguage Namespace


DefaultValue Property

PowerLanguage.NET Help

IArray2D`1.DefaultValue Property

Read-only properties. Returns the default value.

public T DefaultValue { public set; }

See Also

IArray2D<T> Interface | PowerLanguage Namespace


IArraySeries<T> Interface

The array series access interface.

For a list of all members of this type, see IArraySeries<T> Members .

PowerLanguage.IArraySeries<T>
PowerLanguage.IArray`1

[DefaultMember(MemberName="Item")]
public interface IArraySeries<T>

Types that implement IArraySeries<T>

Type | Description
ArraySeries<T> | Array series class with behavior similar to PowerLanguage version.
ArraySimple<T> | Array simple class with behavior similar to PowerLanguage version.

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IArraySeries<T> Members | PowerLanguage Namespace


IArraySeries<T> Members

IArraySeries<T> overview

Public Instance Properties

Item | Read-only property. Returns to reference the bar located a specified number of bars back from the current bar.
Length | Read-only property. Returns the array series length.

See Also

IArraySeries<T> Interface | PowerLanguage Namespace


IArraySeries<T> Properties

The properties of the IArraySeries<T> interface are listed below. For a complete list of IArraySeries<T> interface members, see the IArraySeries<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns to reference the bar located a specified number of bars back from the current bar.
Length | Read-only property. Returns the array series length.

See Also

IArraySeries<T> Interface | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

IArraySeries`1.Item Property

Read-only property. Returns to reference the bar located a specified number of bars back from the current bar.

public T[] this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression, specifying the number of bars back.

See Also

IArraySeries<T> Interface | PowerLanguage Namespace


Length Property

PowerLanguage.NET Help

IArraySeries`1.Length Property

Read-only property. Returns the array series length.

public int Length { public get; }

See Also

IArraySeries<T> Interface | PowerLanguage Namespace


IArraySeries2D<T> Interface

The 2D array series access interface.

For a list of all members of this type, see IArraySeries2D<T> Members .

PowerLanguage.IArraySeries2D<T>
PowerLanguage.IArray2D`1

[DefaultMember(MemberName="Item")]
public interface IArraySeries2D<T>

Types that implement IArraySeries2D<T>

Type | Description
Array2DSeries<T> | 2D array series class with behavior similar to PowerLanguage version.
Array2DSimple<T> | 2D array simple class with behavior similar to PowerLanguage version.

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IArraySeries2D<T> Members | PowerLanguage Namespace


IArraySeries2D<T> Members

IArraySeries2D<T> overview

Public Instance Properties

Item | Read-only property. Returns to reference the bar located a specified number of bars back from the current bar.
Length1 | Read-only property. Returns the first dimension of 2D array series.
Length2 | Read-only property. Returns the second dimension of 2D array series.

See Also

IArraySeries2D<T> Interface | PowerLanguage Namespace


IArraySeries2D<T> Properties

The properties of the IArraySeries2D<T> interface are listed below. For a complete list of IArraySeries2D<T> interface members, see the IArraySeries2D<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns to reference the bar located a specified number of bars back from the current bar.
Length1 | Read-only property. Returns the first dimension of 2D array series.
Length2 | Read-only property. Returns the second dimension of 2D array series.

See Also

IArraySeries2D<T> Interface | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

IArraySeries2D`1.Item Property

Read-only property. Returns to reference the bar located a specified number of bars back from the current bar.

public T[,] this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression, specifying the number of bars back.

See Also

IArraySeries2D<T> Interface | PowerLanguage Namespace


Length1 Property

PowerLanguage.NET Help

IArraySeries2D`1.Length1 Property

Read-only property. Returns the first dimension of 2D array series.

public int Length1 { public get; }

See Also

IArraySeries2D<T> Interface | PowerLanguage Namespace


Length2 Property

PowerLanguage.NET Help

IArraySeries2D`1.Length2 Property

Read-only property. Returns the second dimension of 2D array series.

public int Length2 { public get; }

See Also

IArraySeries2D<T> Interface | PowerLanguage Namespace


IArrowContainer Interface

Container for a collection of specific IArrowObject.

For a list of all members of this type, see IArrowContainer Members .

public interface IArrowContainer

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IArrowContainer Members | PowerLanguage Namespace


IArrowContainer Members

IArrowContainer overview

Public Instance Properties

Active Read-only property. Returns an interface to the active IArrowObject, if any; nullptr otherwise.

Public Instance Methods

Create | Overloaded. Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.
GetArrowObjects | A method for accessing collection’s elements using foreach.

See Also

IArrowContainer Interface | PowerLanguage Namespace


IArrowContainer Properties

The properties of the IArrowContainer interface are listed below. For a complete list of IArrowContainer interface members, see the IArrowContainer Members topic.

Public Instance Properties

Active Read-only property. Returns an interface to the active IArrowObject, if any; nullptr otherwise.

See Also

IArrowContainer Interface | PowerLanguage Namespace


Active Property

PowerLanguage.NET Help

IArrowContainer.Active Property

Read-only property. Returns an interface to the active IArrowObject, if any; nullptr otherwise.

public IArrowObject Active { public get; }

See Also

IArrowContainer Interface | PowerLanguage Namespace


IArrowContainer Methods

The methods of the IArrowContainer interface are listed below. For a complete list of IArrowContainer interface members, see the IArrowContainer Members topic.

Public Instance Methods

Create | Overloaded. Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.
GetArrowObjects | A method for accessing collection’s elements using foreach.

See Also

IArrowContainer Interface | PowerLanguage Namespace


Create Method

PowerLanguage.NET Help

IArrowContainer.Create Method

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

Overload List

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

IArrowObject Create(ChartPoint,bool)

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

IArrowObject Create(ChartPoint,bool,bool)

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

IArrowObject Create(ChartPoint,bool,int)

See Also

IArrowContainer Interface | PowerLanguage Namespace


IArrowContainer.Create(ChartPoint, Boolean) Method

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

IArrowObject Create(
ChartPoint point,
bool direction
);

Parameters

point
The point on the chart to create an arrow.
direction
Arrow direction.

Return Value

See Also

IArrowContainer Interface | PowerLanguage Namespace | IArrowContainer.Create Overload List


IArrowContainer.Create(ChartPoint, Boolean, Boolean) Method

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

IArrowObject Create(
ChartPoint point,
bool direction,
bool onSameSubchart
);

Parameters

point
The point on the chart to create an arrow.
direction
Arrow direction.
onSameSubchart
By default: false.

Return Value

See Also

IArrowContainer Interface | PowerLanguage Namespace | IArrowContainer.Create Overload List


IArrowContainer.Create(ChartPoint, Boolean, Int32) Method

Create Arrow Drawing with '_start' coordinates, '_direction' direction, '_data_stream' number data stream, and '_on_same_subchart' flag.

IArrowObject Create(
ChartPoint point,
bool direction,
int dataStream
);

Parameters

point
The point on the chart to create an arrow.
direction
Arrow direction.
dataStream
The data stream number. By default: 0

Return Value

See Also

IArrowContainer Interface | PowerLanguage Namespace | IArrowContainer.Create Overload List


IArrowContainer.GetArrowObjects Method

A method for accessing collection’s elements using foreach.

IEnumerable<IArrowObject> GetArrowObjects(
EDrawingSource drawingSource
);

Parameters

drawingSource
By default: AnyTechOrManual

Return Value

See Also

IArrowContainer Interface | PowerLanguage Namespace


IArrowObject Interface

Arrow Drawings access interface.

For a list of all members of this type, see IArrowObject Members .

public interface IArrowObject : IDrawObject, IEquatable<IDrawObject>, IEquatable<IArrowObject>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IArrowObject Members | PowerLanguage Namespace


IArrowObject Members

IArrowObject overview

Public Instance Properties

Color | A property to get/set drawing’s color.
Direction | A property to get drawing’s direction.
FontName | A get/set property for drawing's font name.
Location | Drawing coordinates get/set property.
Size | A property to get/set drawing’s size.
Style | Drawing style get/set property. Overall there are 14 styles available (EArrowForms – enumeration from ArrowForm0 to Style13).
Text | A property to get/set drawing’s text.
TextBGColor | A property to get/set drawing’s background color.
TextColor | A property to get/set drawing text’s color.
TextSize | A property to get/set drawing's text size.

Public Instance Methods

HaveFont | Returns 'false' for regular font style, 'true' for any other, defined, style.
SetFont | A method for setting drawing text’s font system style.

See Also

IArrowObject Interface | PowerLanguage Namespace


IArrowObject Properties

The properties of the IArrowObject interface are listed below. For a complete list of IArrowObject interface members, see the IArrowObject Members topic.

Public Instance Properties

Color | A property to get/set drawing’s color.
Direction | A property to get drawing’s direction.
FontName | A get/set property for drawing's font name.
Location | Drawing coordinates get/set property.
Size | A property to get/set drawing’s size.
Style | Drawing style get/set property. Overall there are 14 styles available (EArrowForms – enumeration from ArrowForm0 to Style13).
Text | A property to get/set drawing’s text.
TextBGColor | A property to get/set drawing’s background color.
TextColor | A property to get/set drawing text’s color.
TextSize | A property to get/set drawing's text size.

See Also

IArrowObject Interface | PowerLanguage Namespace


Color Property

PowerLanguage.NET Help

IArrowObject.Color Property

A property to get/set drawing’s color.

public Color Color { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


Direction Property

PowerLanguage.NET Help

IArrowObject.Direction Property

A property to get drawing’s direction.

public bool Direction { public get; }

See Also

IArrowObject Interface | PowerLanguage Namespace


FontName Property

PowerLanguage.NET Help

IArrowObject.FontName Property

A get/set property for drawing's font name.

public string FontName { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


Location Property

PowerLanguage.NET Help

IArrowObject.Location Property

Drawing coordinates get/set property.

public ChartPoint Location { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


Size Property

PowerLanguage.NET Help

IArrowObject.Size Property

A property to get/set drawing’s size.

public int Size { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


Style Property

PowerLanguage.NET Help

IArrowObject.Style Property

Drawing style get/set property. Overall there are 14 styles available (EArrowForms – enumeration from ArrowForm0 to Style13).

public EArrowForms Style { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


Text Property

PowerLanguage.NET Help

IArrowObject.Text Property

A property to get/set drawing’s text.

public string Text { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


TextBGColor Property

PowerLanguage.NET Help

IArrowObject.TextBGColor Property

A property to get/set drawing’s background color.

public Color TextBGColor { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


TextColor Property

PowerLanguage.NET Help

IArrowObject.TextColor Property

A property to get/set drawing text’s color.

public Color TextColor { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


TextSize Property

PowerLanguage.NET Help

IArrowObject.TextSize Property

A property to get/set drawing's text size.

public int TextSize { public get; public set; }

See Also

IArrowObject Interface | PowerLanguage Namespace


IArrowObject Methods

The methods of the IArrowObject interface are listed below. For a complete list of IArrowObject interface members, see the IArrowObject Members topic.

Public Instance Methods

HaveFont | Returns 'false' for regular font style, 'true' for any other, defined, style.
SetFont | A method for setting drawing text’s font system style.

See Also

IArrowObject Interface | PowerLanguage Namespace


IArrowObject.HaveFont Method

Returns 'false' for regular font style, 'true' for any other, defined, style.

bool HaveFont(
FontStyle style
);

Parameters

style

Return Value

See Also

IArrowObject Interface | PowerLanguage Namespace


IArrowObject.SetFont Method

A method for setting drawing text’s font system style.

void SetFont(
FontStyle style,
bool val
);

Parameters

style
val

See Also

IArrowObject Interface | PowerLanguage Namespace


ICalculationControl Interface

An interface for controlling study calculations.

For a list of all members of this type, see ICalculationControl Members .

public interface ICalculationControl

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ICalculationControl Members | PowerLanguage Namespace


ICalculationControl Members

ICalculationControl overview

Public Instance Methods

Abort | Overloaded. Method for terminating execution of a study.
RecalcLastBarAfter | A method carrying out study's recalculation after a time interval. Note: The maximum recalculation frequency is 100 milliseconds (0.1 sec).
Recalculate | A method carrying out study's recalculation.

See Also

ICalculationControl Interface | PowerLanguage Namespace


ICalculationControl Methods

The methods of the ICalculationControl interface are listed below. For a complete list of ICalculationControl interface members, see the ICalculationControl Members topic.

Public Instance Methods

Abort | Overloaded. Method for terminating execution of a study.
RecalcLastBarAfter | A method carrying out study's recalculation after a time interval. Note: The maximum recalculation frequency is 100 milliseconds (0.1 sec).
Recalculate | A method carrying out study's recalculation.

See Also

ICalculationControl Interface | PowerLanguage Namespace


Abort Method

PowerLanguage.NET Help

ICalculationControl.Abort Method

Method for terminating execution of a study.

Overload List

Method for terminating execution of a study.

void Abort()

A method that terminates a study's execution and displays an alert-type error message with a string which is a result of '_args' arguments application to '_format_str' format string.

void Abort(string,params object[])

See Also

ICalculationControl Interface | PowerLanguage Namespace


ICalculationControl.Abort() Method

Method for terminating execution of a study.

void Abort();

See Also

ICalculationControl Interface | PowerLanguage Namespace | ICalculationControl.Abort Overload List


ICalculationControl.Abort(String, Object) Method

A method that terminates a study's execution and displays an alert-type error message with a string which is a result of '_args' arguments application to '_format_str' format string.

void Abort(
string formatStr,
params object[] _args
);

Parameters

formatStr
_args

See Also

ICalculationControl Interface | PowerLanguage Namespace | ICalculationControl.Abort Overload List


ICalculationControl.RecalcLastBarAfter Method

A method carrying out study's recalculation after a time interval. Note: The maximum recalculation frequency is 100 milliseconds (0.1 sec).

void RecalcLastBarAfter(
TimeSpan interval
);

Parameters

interval
The time interval after which study should be recalculated.

See Also

ICalculationControl Interface | PowerLanguage Namespace


ICalculationControl.Recalculate Method

A method carrying out study's recalculation.

void Recalculate();

See Also

ICalculationControl Interface | PowerLanguage Namespace


ICalculationInfo Interface

An interface for accessing current execution context.

For a list of all members of this type, see ICalculationInfo Members .

public interface ICalculationInfo

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ICalculationInfo Members | PowerLanguage Namespace


ICalculationInfo Members

ICalculationInfo overview

Public Instance Properties

BaseDataNumber | Read-only property. Returns the number of base data stream.
CurrentDataNumber | Read-only property. Returns the number of current data stream.
ExecOffset | Read-only property. Returns the offset of the bars for execution.
MaxBarsBack | Property. Maximum number of bars "backward".
MaxBarsForward | Read-only property. Returns maximum number of bars "forward".

See Also

ICalculationInfo Interface | PowerLanguage Namespace


ICalculationInfo Properties

The properties of the ICalculationInfo interface are listed below. For a complete list of ICalculationInfo interface members, see the ICalculationInfo Members topic.

Public Instance Properties

BaseDataNumber | Read-only property. Returns the number of base data stream.
CurrentDataNumber | Read-only property. Returns the number of current data stream.
ExecOffset | Read-only property. Returns the offset of the bars for execution.
MaxBarsBack | Property. Maximum number of bars "backward".
MaxBarsForward | Read-only property. Returns maximum number of bars "forward".

See Also

ICalculationInfo Interface | PowerLanguage Namespace


BaseDataNumber Property

PowerLanguage.NET Help

ICalculationInfo.BaseDataNumber Property

Read-only property. Returns the number of base data stream.

public int BaseDataNumber { public get; }

See Also

ICalculationInfo Interface | PowerLanguage Namespace


CurrentDataNumber Property

PowerLanguage.NET Help

ICalculationInfo.CurrentDataNumber Property

Read-only property. Returns the number of current data stream.

public int CurrentDataNumber { public get; }

See Also

ICalculationInfo Interface | PowerLanguage Namespace


ExecOffset Property

PowerLanguage.NET Help

ICalculationInfo.ExecOffset Property

Read-only property. Returns the offset of the bars for execution.

public int ExecOffset { public get; }

See Also

ICalculationInfo Interface | PowerLanguage Namespace


MaxBarsBack Property

PowerLanguage.NET Help

ICalculationInfo.MaxBarsBack Property

Property. Maximum number of bars "backward".

public int MaxBarsBack { public get; public set; }

See Also

ICalculationInfo Interface | PowerLanguage Namespace


MaxBarsForward Property

PowerLanguage.NET Help

ICalculationInfo.MaxBarsForward Property

Read-only property. Returns maximum number of bars "forward".

public int MaxBarsForward { public get; }

See Also

ICalculationInfo Interface | PowerLanguage Namespace


IChartCommands Interface

Charting commands access interface.

For a list of all members of this type, see IChartCommands Members .

public interface IChartCommands

Types that implement IChartCommands

Type | Description
CStudyAbstract | Base class for studies.
CStudyControl | Base class for studies.
AccumSwingIndex |
AccumulationDistribution |
AdaptiveMovAvg |
AdvanceDeclineDiff |
ADX |
ADXCustom |
ADXR |
ADXRCustom |
AverageFC |
BarNumber |
C_3WhSolds_3BlkCrows |
C_BullEng_BearEng |
C_BullHar_BearHar |
C_Hammer_HangingMan |
C_MornDoji_EveDoji |
C_MornStar_EveStar |
C_PierceLine_DkCloud |
C_ShootingStar |
ChaikinOsc |
CloseD |
CloseS |
CSI |
Cum |
DirMovement |
draw_DOM_level |
ExtremesFC |
FastK |
FastKCustom |
FunctionSeries<T> | A series function’s base class. Feature of a series function is that its body is always calculated in the current context of execution (at the currently calculating bar), and the function always keeps its previous values.
FunctionSimple<T> | Simple function’s base class. Its peculiarity is that it doesn’t keep the history of its values, but rather calculates them each time in the context of calling an execution (on the bar, shifted relative to the current one for a specified number of bars).
HighD |
HighestFC |
HighS |
HPI |
HullMovAvg |
LinearReg |
LinearRegValue |
LowD |
LowestFC |
LowS |
LWAccDis |
MACD |
MassIndex |
McClellanOsc |
NormGradientColor |
OBV |
OHLCPeriodsAgo |
OpenD |
OpenS |
ParabolicSAR |
Pennant |
PivotHighVS |
PivotHighVSBar |
PivotLowVS |
PivotLowVSBar |
PivotReversalGen |
PriceOscillator |
PriceVolTrend |
RS_Average |
RS_BarsPerDay |
RS_DailyDataArray |
RS_Extremes |
RS_PriceExtension |
RS_ReversalPatterns |
RS_TrueExtremes |
RSI |
SharpeRatio |
SlowKCustom |
StdError |
Stochastic |
StochasticExp |
SummationFC |
SwingHigh |
SwingHighBar |
SwingLow |
SwingLowBar |
TimeSeriesForecast |
TriAverage |
TRIX |
UltimateOscillator |
Volatility |
VolatilityStdDev |
VolumeOsc |
vwapResettable |
XAverage |
XAverageOrig |
FunctionObject<T> | Class that describes a function object.
IndicatorObject | Indicator’s base class (inherit from this class to create an indicator).
PortfolioSignalObject |
SignalObject | Base class for strategies (inherit from SignalObject to create this kind of study).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IChartCommands Members | PowerLanguage Namespace


IChartCommands Members

IChartCommands overview

Public Instance Methods

CommandLine | Execute the command for the chart (command line)
ScrollToBar | Scrolls the chart to the specified bar (barN) of the data series with the dataN number

See Also

IChartCommands Interface | PowerLanguage Namespace


IChartCommands Methods

The methods of the IChartCommands interface are listed below. For a complete list of IChartCommands interface members, see the IChartCommands Members topic.

Public Instance Methods

CommandLine | Execute the command for the chart (command line)
ScrollToBar | Scrolls the chart to the specified bar (barN) of the data series with the dataN number

See Also

IChartCommands Interface | PowerLanguage Namespace


IChartCommands.CommandLine Method

Execute the command for the chart (command line)

void CommandLine(
string command
);

Parameters

command

See Also

IChartCommands Interface | PowerLanguage Namespace


IChartCommands.ScrollToBar Method

Scrolls the chart to the specified bar (barN) of the data series with the dataN number

void ScrollToBar(
int dataN,
int barN
);

Parameters

dataN
Data series number starting from 1
barN
Bar number starting from 1. Absolute value regardless of the bars back settings

See Also

IChartCommands Interface | PowerLanguage Namespace


IChartCustomDrawer Interface

Interface for custom drawing. This interface realizes a class that can add drawings to the chart at different stages.

For a list of all members of this type, see IChartCustomDrawer Members .

public interface IChartCustomDrawer

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IChartCustomDrawer Members | PowerLanguage Namespace


IChartCustomDrawer Members

IChartCustomDrawer overview

Public Instance Methods

Draw !IMPORTANT! This interface is called from the main thread, while indicators and signals calculate in work threads. If implementing class for this interface needs data generated during calculation of studies, you need to guarantee thread-safe access to that data.

See Also

IChartCustomDrawer Interface | PowerLanguage Namespace


IChartCustomDrawer Methods

The methods of the IChartCustomDrawer interface are listed below. For a complete list of IChartCustomDrawer interface members, see the IChartCustomDrawer Members topic.

Public Instance Methods

Draw !IMPORTANT! This interface is called from the main thread, while indicators and signals calculate in work threads. If implementing class for this interface needs data generated during calculation of studies, you need to guarantee thread-safe access to that data.

See Also

IChartCustomDrawer Interface | PowerLanguage Namespace


IChartCustomDrawer.Draw Method

!IMPORTANT! This interface is called from the main thread, while indicators and signals calculate in work threads. If implementing class for this interface needs data generated during calculation of studies, you need to guarantee thread-safe access to that data.

void Draw(
DrawContext context,
EDrawPhases phase
);

Parameters

context
Contains information for drawing. !IMPORANT! Context exists only until exiting the method. DO NOT SAVE!
phase
Current drawing phase.

See Also

IChartCustomDrawer Interface | PowerLanguage Namespace


IChartCustomDrawRegistrator Interface

Interface for adding/deleting custom drawers.

For a list of all members of this type, see IChartCustomDrawRegistrator Members .

public interface IChartCustomDrawRegistrator

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IChartCustomDrawRegistrator Members | PowerLanguage Namespace


IChartCustomDrawRegistrator Members

IChartCustomDrawRegistrator overview

Public Instance Properties

Environment Return interface for access to drawing environment.

Public Instance Methods

ReDraw | Redraws custom drawings.
Register | Adds drawers. Registers the interface for drawing on chart. Each Register call must have an associated Unregister call when finishing working with drawings.
Unregister | Deletes drawers. Unregisters the interface for drawing on chart. Each Register call must have an associated Unregister call when finishing working with drawings.

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


IChartCustomDrawRegistrator Properties

The properties of the IChartCustomDrawRegistrator interface are listed below. For a complete list of IChartCustomDrawRegistrator interface members, see the IChartCustomDrawRegistrator Members topic.

Public Instance Properties

Environment Return interface for access to drawing environment.

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


Environment Property

PowerLanguage.NET Help

IChartCustomDrawRegistrator.Environment Property

Return interface for access to drawing environment.

public IDrawDataEnviroment Environment { public get; }

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


IChartCustomDrawRegistrator Methods

The methods of the IChartCustomDrawRegistrator interface are listed below. For a complete list of IChartCustomDrawRegistrator interface members, see the IChartCustomDrawRegistrator Members topic.

Public Instance Methods

ReDraw | Redraws custom drawings.
Register | Adds drawers. Registers the interface for drawing on chart. Each Register call must have an associated Unregister call when finishing working with drawings.
Unregister | Deletes drawers. Unregisters the interface for drawing on chart. Each Register call must have an associated Unregister call when finishing working with drawings.

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


IChartCustomDrawRegistrator.ReDraw Method

Redraws custom drawings.

void ReDraw();

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


IChartCustomDrawRegistrator.Register Method

Adds drawers. Registers the interface for drawing on chart. Each Register call must have an associated Unregister call when finishing working with drawings.

void Register(
IChartCustomDrawer drawer
);

Parameters

drawer
Drawing interface.

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


IChartCustomDrawRegistrator.Unregister Method

Deletes drawers. Unregisters the interface for drawing on chart. Each Register call must have an associated Unregister call when finishing working with drawings.

void Unregister(
IChartCustomDrawer drawer
);

Parameters

drawer

See Also

IChartCustomDrawRegistrator Interface | PowerLanguage Namespace


ICustomToolBar Interface

Interface for accessing custom toolbar.

For a list of all members of this type, see ICustomToolBar Members .

public interface ICustomToolBar

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ICustomToolBar Members | PowerLanguage Namespace


ICustomToolBar Members

ICustomToolBar overview

Public Instance Properties

Visible Write-only property. Sets the visibility of the toolbar.

Public Instance Methods

AccessToolBar | Method for accessing the toolbar.
AccessToolBarAsync | Method for asynchronous access to the toolbar.

See Also

ICustomToolBar Interface | PowerLanguage Namespace


ICustomToolBar Properties

The properties of the ICustomToolBar interface are listed below. For a complete list of ICustomToolBar interface members, see the ICustomToolBar Members topic.

Public Instance Properties

Visible Write-only property. Sets the visibility of the toolbar.

See Also

ICustomToolBar Interface | PowerLanguage Namespace


Visible Property

PowerLanguage.NET Help

ICustomToolBar.Visible Property

Write-only property. Sets the visibility of the toolbar.

public bool Visible { public set; }

See Also

ICustomToolBar Interface | PowerLanguage Namespace


ICustomToolBar Methods

The methods of the ICustomToolBar interface are listed below. For a complete list of ICustomToolBar interface members, see the ICustomToolBar Members topic.

Public Instance Methods

AccessToolBar | Method for accessing the toolbar.
AccessToolBarAsync | Method for asynchronous access to the toolbar.

See Also

ICustomToolBar Interface | PowerLanguage Namespace


ICustomToolBar.AccessToolBar Method

Method for accessing the toolbar.

void AccessToolBar(
ToolBarAction action
);

Parameters

action

See Also

ICustomToolBar Interface | PowerLanguage Namespace


ICustomToolBar.AccessToolBarAsync Method

Method for asynchronous access to the toolbar.

void AccessToolBarAsync(
ToolBarAction action
);

Parameters

action

See Also

ICustomToolBar Interface | PowerLanguage Namespace


IDataLoader Interface

Data loading.

For a list of all members of this type, see IDataLoader Members .

public interface IDataLoader : IDisposable

Types that implement IDataLoader

Type | Description
DataLoaderCache | DataLoader singleton service. Caches LoadData requests, what allows to avoid same data over-requesting. It increases the speed of script calculation.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IDataLoader Members | PowerLanguage Namespace


IDataLoader Members

IDataLoader overview

Public Instance Methods

BeginLoadData | Initializes the data loading.
EndLoadData | Cancel data loading.

See Also

IDataLoader Interface | PowerLanguage Namespace


IDataLoader Methods

The methods of the IDataLoader interface are listed below. For a complete list of IDataLoader interface members, see the IDataLoader Members topic.

Public Instance Methods

BeginLoadData | Initializes the data loading.
EndLoadData | Cancel data loading.

See Also

IDataLoader Interface | PowerLanguage Namespace


IDataLoader.BeginLoadData Method

Initializes the data loading.

IDataLoaderResult BeginLoadData(
InstrumentDataRequest Request,
LoadDataCallback Sink,
object State
);

Parameters

Request
Data loading request.
Sink
Result Callback.
State

Return Value

See Also

IDataLoader Interface | PowerLanguage Namespace


IDataLoader.EndLoadData Method

Cancel data loading.

void EndLoadData(
IDataLoaderResult Result
);

Parameters

Result
Result of data loading.

See Also

IDataLoader Interface | PowerLanguage Namespace


IDataLoaderResult Interface

The result of data loading.

For a list of all members of this type, see IDataLoaderResult Members .

public interface IDataLoaderResult

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IDataLoaderResult Members | PowerLanguage Namespace


IDataLoaderResult Members

IDataLoaderResult overview

Public Instance Properties

Data | Read-only property. Returns loaded data.
Data2 | Read-only property. Describes volume profile data. BarPriceLevels.
Event | LoadDataCallback event's call reason. DataLoadedEvent.
IsCompleted | Read-only property. Returns whether data loading is completed.
Request | Read-only property. Returns request.
RTData | Nullable property represents real-time data. Bar.
RTData2 | Nullable property represents real-time volume profile data. BarPriceLevels.
RTTPOData | Nullable property represents real-time TPO data. TPOProfile.
SLData | Nullable property represents status line data.
State | Read-only property. Returns current state of the object.
TPOData | Read-only property. Describes TPO data. TPOProfile.

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


IDataLoaderResult Properties

The properties of the IDataLoaderResult interface are listed below. For a complete list of IDataLoaderResult interface members, see the IDataLoaderResult Members topic.

Public Instance Properties

Data | Read-only property. Returns loaded data.
Data2 | Read-only property. Describes volume profile data. BarPriceLevels.
Event | LoadDataCallback event's call reason. DataLoadedEvent.
IsCompleted | Read-only property. Returns whether data loading is completed.
Request | Read-only property. Returns request.
RTData | Nullable property represents real-time data. Bar.
RTData2 | Nullable property represents real-time volume profile data. BarPriceLevels.
RTTPOData | Nullable property represents real-time TPO data. TPOProfile.
SLData | Nullable property represents status line data.
State | Read-only property. Returns current state of the object.
TPOData | Read-only property. Describes TPO data. TPOProfile.

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


Data Property

PowerLanguage.NET Help

IDataLoaderResult.Data Property

Read-only property. Returns loaded data.

public Bar[] Data { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


Data2 Property

PowerLanguage.NET Help

IDataLoaderResult.Data2 Property

Read-only property. Describes volume profile data. BarPriceLevels.

public BarPriceLevels[] Data2 { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


Event Property

PowerLanguage.NET Help

IDataLoaderResult.Event Property

LoadDataCallback event's call reason. DataLoadedEvent.

public DataLoadedEvent Event { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


IsCompleted Property

PowerLanguage.NET Help

IDataLoaderResult.IsCompleted Property

Read-only property. Returns whether data loading is completed.

public bool IsCompleted { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


Request Property

PowerLanguage.NET Help

IDataLoaderResult.Request Property

Read-only property. Returns request.

public InstrumentDataRequest Request { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


RTData Property

PowerLanguage.NET Help

IDataLoaderResult.RTData Property

Nullable property represents real-time data. Bar.

public Bar? RTData { public get; public set; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


RTData2 Property

PowerLanguage.NET Help

IDataLoaderResult.RTData2 Property

Nullable property represents real-time volume profile data. BarPriceLevels.

public BarPriceLevels? RTData2 { public get; public set; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


RTTPOData Property

PowerLanguage.NET Help

IDataLoaderResult.RTTPOData Property

Nullable property represents real-time TPO data. TPOProfile.

public TPOProfile? RTTPOData { public get; public set; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


SLData Property

PowerLanguage.NET Help

IDataLoaderResult.SLData Property

Nullable property represents status line data.

public StatusLineData? SLData { public get; public set; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


State Property

PowerLanguage.NET Help

IDataLoaderResult.State Property

Read-only property. Returns current state of the object.

public object State { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


TPOData Property

PowerLanguage.NET Help

IDataLoaderResult.TPOData Property

Read-only property. Describes TPO data. TPOProfile.

public TPOProfile[] TPOData { public get; }

See Also

IDataLoaderResult Interface | PowerLanguage Namespace


IDOMData Interface

Interface for DOM data access.

For a list of all members of this type, see IDOMData Members .

public interface IDOMData

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IDOMData Members | PowerLanguage Namespace


IDOMData Members

IDOMData overview

Public Instance Properties

Ask | Read-only property. Returns ask price.
Bid | Read-only property. Returns bid price.
Connected | Read-only property. Returns "is connected" if DOM connected.

See Also

IDOMData Interface | PowerLanguage Namespace


IDOMData Properties

The properties of the IDOMData interface are listed below. For a complete list of IDOMData interface members, see the IDOMData Members topic.

Public Instance Properties

Ask | Read-only property. Returns ask price.
Bid | Read-only property. Returns bid price.
Connected | Read-only property. Returns "is connected" if DOM connected.

See Also

IDOMData Interface | PowerLanguage Namespace


Ask Property

PowerLanguage.NET Help

IDOMData.Ask Property

Read-only property. Returns ask price.

public DOMPrice[] Ask { public get; }

See Also

IDOMData Interface | PowerLanguage Namespace


Bid Property

PowerLanguage.NET Help

IDOMData.Bid Property

Read-only property. Returns bid price.

public DOMPrice[] Bid { public get; }

See Also

IDOMData Interface | PowerLanguage Namespace


Connected Property

PowerLanguage.NET Help

IDOMData.Connected Property

Read-only property. Returns "is connected" if DOM connected.

public bool Connected { public get; }

See Also

IDOMData Interface | PowerLanguage Namespace


IDrawDataEnviroment Interface

An interface for accessing "Draw" data environment.

For a list of all members of this type, see IDrawDataEnviroment Members .

public interface IDrawDataEnviroment

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IDrawDataEnviroment Members | PowerLanguage Namespace


IDrawDataEnviroment Members

IDrawDataEnviroment overview

Public Instance Properties

Bars | Read-only property. Returns "Draw" symbol bars.
ChartBarCloseDistance |
StatusLine | Read-only property. Returns symbol's status line.

Public Instance Methods

BarIndex2PointX | Return "System.Point.X" for bar by "index"
ChartPoint2Point | Convert "Chart Point" to "System Point".
Point2ChartPoint | Convert "System Point" to "Chart Point".
PointX2BarIndex | Return nearest bar "index" for "System.Point.X"

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawDataEnviroment Properties

The properties of the IDrawDataEnviroment interface are listed below. For a complete list of IDrawDataEnviroment interface members, see the IDrawDataEnviroment Members topic.

Public Instance Properties

Bars | Read-only property. Returns "Draw" symbol bars.
ChartBarCloseDistance |
StatusLine | Read-only property. Returns symbol's status line.

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


Bars Property

PowerLanguage.NET Help

IDrawDataEnviroment.Bars Property

Read-only property. Returns "Draw" symbol bars.

public IDrawSymbolBars Bars { public get; }

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


ChartBarCloseDistance Property

PowerLanguage.NET Help

IDrawDataEnviroment.ChartBarCloseDistance Property

public int ChartBarCloseDistance { public get; }

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


StatusLine Property

PowerLanguage.NET Help

IDrawDataEnviroment.StatusLine Property

Read-only property. Returns symbol's status line.

public IStatusLine StatusLine { public get; }

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawDataEnviroment Methods

The methods of the IDrawDataEnviroment interface are listed below. For a complete list of IDrawDataEnviroment interface members, see the IDrawDataEnviroment Members topic.

Public Instance Methods

BarIndex2PointX | Return "System.Point.X" for bar by "index"
ChartPoint2Point | Convert "Chart Point" to "System Point".
Point2ChartPoint | Convert "System Point" to "Chart Point".
PointX2BarIndex | Return nearest bar "index" for "System.Point.X"

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawDataEnviroment.BarIndex2PointX Method

Return "System.Point.X" for bar by "index"

int BarIndex2PointX(
uint index
);

Parameters

index

Return Value

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawDataEnviroment.ChartPoint2Point Method

Convert "Chart Point" to "System Point".

PointF ChartPoint2Point(
ChartPoint p
);

Parameters

p
Chart point value.

Return Value

System Point value.

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawDataEnviroment.Point2ChartPoint Method

Convert "System Point" to "Chart Point".

ChartPoint Point2ChartPoint(
PointF p
);

Parameters

p
System Point value.

Return Value

Chart Point value.

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawDataEnviroment.PointX2BarIndex Method

Return nearest bar "index" for "System.Point.X"

uint PointX2BarIndex(
int X
);

Parameters

X

Return Value

See Also

IDrawDataEnviroment Interface | PowerLanguage Namespace


IDrawObject Interface

A base interface for accessing drawing objects.

For a list of all members of this type, see IDrawObject Members .

PowerLanguage.IDrawObject
PowerLanguage.IArrowObject
PowerLanguage.IRectangleObject
PowerLanguage.ITextObject
PowerLanguage.ITrendLineObject

public interface IDrawObject : IEquatable<IDrawObject>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IDrawObject Members | PowerLanguage Namespace


IDrawObject Members

IDrawObject overview

Public Instance Properties

AnchorToBars | Anchors drawing to the visible bar index.
Exist | Read-only property. Returns an indication whether the drawing exists.
ID | Read-only property. Returns drawing ID.
Locked | Lock drawing on the chart get/set property. Lock for drawings prevents it from unnecessary user changes.

Public Instance Methods

Delete Delete current drawing object.

See Also

IDrawObject Interface | PowerLanguage Namespace


IDrawObject Properties

The properties of the IDrawObject interface are listed below. For a complete list of IDrawObject interface members, see the IDrawObject Members topic.

Public Instance Properties

AnchorToBars | Anchors drawing to the visible bar index.
Exist | Read-only property. Returns an indication whether the drawing exists.
ID | Read-only property. Returns drawing ID.
Locked | Lock drawing on the chart get/set property. Lock for drawings prevents it from unnecessary user changes.

See Also

IDrawObject Interface | PowerLanguage Namespace


AnchorToBars Property

PowerLanguage.NET Help

IDrawObject.AnchorToBars Property

Anchors drawing to the visible bar index.

public bool AnchorToBars { public get; public set; }

See Also

IDrawObject Interface | PowerLanguage Namespace


Exist Property

PowerLanguage.NET Help

IDrawObject.Exist Property

Read-only property. Returns an indication whether the drawing exists.

public bool Exist { public get; }

See Also

IDrawObject Interface | PowerLanguage Namespace


ID Property

PowerLanguage.NET Help

IDrawObject.ID Property

Read-only property. Returns drawing ID.

public int ID { public get; }

See Also

IDrawObject Interface | PowerLanguage Namespace


Locked Property

PowerLanguage.NET Help

IDrawObject.Locked Property

Lock drawing on the chart get/set property. Lock for drawings prevents it from unnecessary user changes.

public bool Locked { public get; public set; }

See Also

IDrawObject Interface | PowerLanguage Namespace


IDrawObject Methods

The methods of the IDrawObject interface are listed below. For a complete list of IDrawObject interface members, see the IDrawObject Members topic.

Public Instance Methods

Delete Delete current drawing object.

See Also

IDrawObject Interface | PowerLanguage Namespace


IDrawObject.Delete Method

Delete current drawing object.

bool Delete();

Return Value

Returns an indication whether the drawing object was deleted.

See Also

IDrawObject Interface | PowerLanguage Namespace


IDrawSymbolBars Interface

An interface for accessing "Draw" symbol bars.

For a list of all members of this type, see IDrawSymbolBars Members .

[DefaultMember(MemberName="Item")]
public interface IDrawSymbolBars

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IDrawSymbolBars Members | PowerLanguage Namespace


IDrawSymbolBars Members

IDrawSymbolBars overview

Public Instance Properties

All | Read-only property. Returns all bars.
Count | Read-only property. Returns "Draw" symbol bars count.
Item | Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
PureCount | Read-only property. Returns "Draw" pure symbol bars count. If playback is turned on, Count returns current series size based on start playback point. PureCount returns original series size independent from start playback point.

Public Instance Methods

Get | Overloaded. Get bar array for specified DateTime range.
GetIndexByTime | Returns index of the bar with the specified time. If there is no bar with specified time, GetIndexByTime will return the closest index to the left of the specified time. If there is no index to the left of the specified time, then the closest index from the right will be returned.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


IDrawSymbolBars Properties

The properties of the IDrawSymbolBars interface are listed below. For a complete list of IDrawSymbolBars interface members, see the IDrawSymbolBars Members topic.

Public Instance Properties

All | Read-only property. Returns all bars.
Count | Read-only property. Returns "Draw" symbol bars count.
Item | Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.
PureCount | Read-only property. Returns "Draw" pure symbol bars count. If playback is turned on, Count returns current series size based on start playback point. PureCount returns original series size independent from start playback point.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


All Property

PowerLanguage.NET Help

IDrawSymbolBars.All Property

Read-only property. Returns all bars.

public Bar[] All { public get; }

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


Count Property

PowerLanguage.NET Help

IDrawSymbolBars.Count Property

Read-only property. Returns "Draw" symbol bars count.

public uint Count { public get; }

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

IDrawSymbolBars.Item Property

Read-only property. Returns information referencing a bar that is located a specified number of bars back from the current bar.

public Bar this[
uint i
] { public get; }

Parameters

i

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


PureCount Property

PowerLanguage.NET Help

IDrawSymbolBars.PureCount Property

Read-only property. Returns "Draw" pure symbol bars count. If playback is turned on, Count returns current series size based on start playback point. PureCount returns original series size independent from start playback point.

public uint PureCount { public get; }

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


IDrawSymbolBars Methods

The methods of the IDrawSymbolBars interface are listed below. For a complete list of IDrawSymbolBars interface members, see the IDrawSymbolBars Members topic.

Public Instance Methods

Get | Overloaded. Get bar array for specified DateTime range.
GetIndexByTime | Returns index of the bar with the specified time. If there is no bar with specified time, GetIndexByTime will return the closest index to the left of the specified time. If there is no index to the left of the specified time, then the closest index from the right will be returned.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


Get Method

PowerLanguage.NET Help

IDrawSymbolBars.Get Method

Get bar array for specified DateTime range.

Overload List

Get bar array for specified DateTime range.

void Get(DateTime,DateTime,out Bar[])

Get bar array.

void Get(uint,out Bar[])

Get bar array.

void Get(uint,uint,out Bar[])

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


IDrawSymbolBars.Get(DateTime, DateTime, Bar) Method

Get bar array for specified DateTime range.

void Get(
DateTime from,
DateTime to,
out Bar[] bars
);

Parameters

from
"From" date.
to
"To" date.
bars
The resulting bar array.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace | IDrawSymbolBars.Get Overload List


IDrawSymbolBars.Get(UInt32, Bar) Method

Get bar array.

void Get(
uint from,
out Bar[] bars
);

Parameters

from
"From" value.
bars
The resulting bar array.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace | IDrawSymbolBars.Get Overload List


IDrawSymbolBars.Get(UInt32, UInt32, Bar) Method

Get bar array.

void Get(
uint from,
uint to,
out Bar[] bars
);

Parameters

from
"From" value.
to
"To" value.
bars
The resulting bar array.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace | IDrawSymbolBars.Get Overload List


IDrawSymbolBars.GetIndexByTime Method

Returns index of the bar with the specified time. If there is no bar with specified time, GetIndexByTime will return the closest index to the left of the specified time. If there is no index to the left of the specified time, then the closest index from the right will be returned.

uint GetIndexByTime(
DateTime dt
);

Parameters

dt
DateTime value.

Return Value

Index of the bar with the specified time.

See Also

IDrawSymbolBars Interface | PowerLanguage Namespace


IExpertCommentary Interface

Expert commentary.

For a list of all members of this type, see IExpertCommentary Members .

public interface IExpertCommentary

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IExpertCommentary Members | PowerLanguage Namespace


IExpertCommentary Members

IExpertCommentary overview

Public Instance Properties

AtCommentaryBar | Return 'true' if this bar was selected by user in expert commentary mode.
Enabled | Return true if expert commentary mode is active.

Public Instance Methods

Write | Write commentary text for current bar.
WriteLine | Write commentary text for current bar with line terminator.

See Also

IExpertCommentary Interface | PowerLanguage Namespace


IExpertCommentary Properties

The properties of the IExpertCommentary interface are listed below. For a complete list of IExpertCommentary interface members, see the IExpertCommentary Members topic.

Public Instance Properties

AtCommentaryBar | Return 'true' if this bar was selected by user in expert commentary mode.
Enabled | Return true if expert commentary mode is active.

See Also

IExpertCommentary Interface | PowerLanguage Namespace


AtCommentaryBar Property

PowerLanguage.NET Help

IExpertCommentary.AtCommentaryBar Property

Return 'true' if this bar was selected by user in expert commentary mode.

public bool AtCommentaryBar { public get; }

See Also

IExpertCommentary Interface | PowerLanguage Namespace


Enabled Property

PowerLanguage.NET Help

IExpertCommentary.Enabled Property

Return true if expert commentary mode is active.

public bool Enabled { public get; }

See Also

IExpertCommentary Interface | PowerLanguage Namespace


IExpertCommentary Methods

The methods of the IExpertCommentary interface are listed below. For a complete list of IExpertCommentary interface members, see the IExpertCommentary Members topic.

Public Instance Methods

Write | Write commentary text for current bar.
WriteLine | Write commentary text for current bar with line terminator.

See Also

IExpertCommentary Interface | PowerLanguage Namespace


IExpertCommentary.Write Method

Write commentary text for current bar.

void Write(
string format,
params object[] _args
);

Parameters

format
Format string.
_args
Arguments for format string.

See Also

IExpertCommentary Interface | PowerLanguage Namespace


IExpertCommentary.WriteLine Method

Write commentary text for current bar with line terminator.

void WriteLine(
string format,
params object[] _args
);

Parameters

format
Format string.
_args
Arguments for format string.

See Also

IExpertCommentary Interface | PowerLanguage Namespace


IFunctionObject<T> Interface

An interface that describes a function object.

For a list of all members of this type, see IFunctionObject<T> Members .

public interface IFunctionObject<T> : ISeries<T>

Types that implement IFunctionObject<T>

Type | Description
AccumSwingIndex |
AccumulationDistribution |
AdaptiveMovAvg |
AdvanceDeclineDiff |
ADX |
ADXCustom |
ADXR |
ADXRCustom |
AverageFC |
BarNumber |
C_3WhSolds_3BlkCrows |
C_BullEng_BearEng |
C_BullHar_BearHar |
C_Hammer_HangingMan |
C_MornDoji_EveDoji |
C_MornStar_EveStar |
C_PierceLine_DkCloud |
C_ShootingStar |
ChaikinOsc |
CloseD |
CloseS |
CSI |
Cum |
DirMovement |
draw_DOM_level |
ExtremesFC |
FastK |
FastKCustom |
FunctionSeries<T> | A series function’s base class. Feature of a series function is that its body is always calculated in the current context of execution (at the currently calculating bar), and the function always keeps its previous values.
FunctionSimple<T> | Simple function’s base class. Its peculiarity is that it doesn’t keep the history of its values, but rather calculates them each time in the context of calling an execution (on the bar, shifted relative to the current one for a specified number of bars).
HighD |
HighestFC |
HighS |
HPI |
HullMovAvg |
LinearReg |
LinearRegValue |
LowD |
LowestFC |
LowS |
LWAccDis |
MACD |
MassIndex |
McClellanOsc |
NormGradientColor |
OBV |
OHLCPeriodsAgo |
OpenD |
OpenS |
ParabolicSAR |
Pennant |
PivotHighVS |
PivotHighVSBar |
PivotLowVS |
PivotLowVSBar |
PivotReversalGen |
PriceOscillator |
PriceVolTrend |
RS_Average |
RS_BarsPerDay |
RS_DailyDataArray |
RS_Extremes |
RS_PriceExtension |
RS_ReversalPatterns |
RS_TrueExtremes |
RSI |
SharpeRatio |
SlowKCustom |
StdError |
Stochastic |
StochasticExp |
SummationFC |
SwingHigh |
SwingHighBar |
SwingLow |
SwingLowBar |
TimeSeriesForecast |
TriAverage |
TRIX |
UltimateOscillator |
Volatility |
VolatilityStdDev |
VolumeOsc |
vwapResettable |
XAverage |
XAverageOrig |
FunctionObject<T> | Class that describes a function object.

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IFunctionObject<T> Members | PowerLanguage Namespace


IFunctionObject<T> Members

IFunctionObject<T> overview

Public Instance Properties

Value Read-only property, returns value of the function.

See Also

IFunctionObject<T> Interface | PowerLanguage Namespace


IFunctionObject<T> Properties

The properties of the IFunctionObject<T> interface are listed below. For a complete list of IFunctionObject<T> interface members, see the IFunctionObject<T> Members topic.

Public Instance Properties

Value Read-only property, returns value of the function.

See Also

IFunctionObject<T> Interface | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

IFunctionObject`1.Value Property

Read-only property, returns value of the function.

public T Value { public get; }

See Also

IFunctionObject<T> Interface | PowerLanguage Namespace


IIndicatorInfo Interface

For a list of all members of this type, see IIndicatorInfo Members .

public interface IIndicatorInfo

Types that implement IIndicatorInfo

Type | Description
IndicatorObject | Indicator’s base class (inherit from this class to create an indicator).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IIndicatorInfo Members | PowerLanguage Namespace


IIndicatorInfo Members

IIndicatorInfo overview

Public Instance Methods

GetSameAsSymbol
GetSkipIdenticalTicks
GetUpdateOnEveryTick

See Also

IIndicatorInfo Interface | PowerLanguage Namespace


IIndicatorInfo Methods

The methods of the IIndicatorInfo interface are listed below. For a complete list of IIndicatorInfo interface members, see the IIndicatorInfo Members topic.

Public Instance Methods

GetSameAsSymbol
GetSkipIdenticalTicks
GetUpdateOnEveryTick

See Also

IIndicatorInfo Interface | PowerLanguage Namespace


IIndicatorInfo.GetSameAsSymbol Method

bool? GetSameAsSymbol();

See Also

IIndicatorInfo Interface | PowerLanguage Namespace


IIndicatorInfo.GetSkipIdenticalTicks Method

bool? GetSkipIdenticalTicks();

See Also

IIndicatorInfo Interface | PowerLanguage Namespace


IIndicatorInfo.GetUpdateOnEveryTick Method

bool? GetUpdateOnEveryTick();

See Also

IIndicatorInfo Interface | PowerLanguage Namespace


IInstrument Interface

Interface for series data access.

For a list of all members of this type, see IInstrument Members .

public interface IInstrument : ISeriesSymbolData

Types that implement IInstrument

Type | Description
CustomInstrument | Allows to access data series of another symbol without adding it as an additional data series. Note: after using CustomInstrument you need to call the Dispose() method for proper operation of MultiCharts application.
CustomInstrumentBase | Base class of custom instrument.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IInstrument Members | PowerLanguage Namespace


IInstrument Members

IInstrument overview

Public Instance Properties

BarUpdateTime | Read-only property. Returns time of the last update of the current bar if Bar Magnifier mode is on. If Bar Magnifier mode is off, returns the time of the current bar (as the Time property).
CloseValue | Read-only property.Returns series current bar’s Close value.
CurrentBar | Read-only property. Returns current bar number.
DOM | Read-only property. Provides an interface for accessing Depth Of Market data.
DownTicksValue | Read-only property. Returns series current bar’s Down Ticks value.
FullSymbolData | Read-only property. Provides an interface for accessing any bar in the series.
HighValue | Read-only property. Returns series current bar's High value.
Info | Read-only property. Provides an interface for accessing symbol information.
LastBarInSession | Read-only property. Indicates whether current bar is the last bar in the SessionObject.
LastBarOnChart | Read-only property. Indicates whether current bar is the last bar on the chart.
LastBarTime | Read-only property. Returns the last bar’s time.
LowValue | Read-only property.Returns series current bar’s Low value.
OpenIntValue | Read-only property. Returns series current bar’s Open Interest value.
OpenValue | Read-only property.Returns series current bar’s Open value.
Point | Read-only property. Returns value of a point(pip).
Request | Read-only property. Returns the request for data describing the instrument.
Sessions | Read-only property. Provides an interface for accessing Sessions information.
Status | Read-only property. Returns current bar’s status: None = -1, Open = 0, Inside = 1, Close = 2.
StatusLine | Read-only property. Provides an interface for accessing information reflected in Status Line.
TickIDValue | Read-only property. This keyword can be used to distinguish between the bars with the same date and time stamps.For tick and volume-based charts: Returns the tick index within a second. For resolutions higher than 1 Tick returns the index of the last tick within the bar. For time-based charts with resolutions of 1 sec or more: Not supported. Returns 0.Real-time ticks stored in the data base are being assigned the last 31 bit - the identifier of realtime affiliation. In order to get the TickID value without real-time identifier one needs to calculate the remainder from TickID value division by 0x80000000, or execute an operation of bitwise "AND" with 0x7FFFFFFF value.uint _TrueTickID = Bars.TickIDValue % 0x80000000; or uint _TrueTickID = Bars.TickIDValue & 0x7FFFFFFF;TickIDValue value can be obtained for the current bar only.
TicksValue | Read-only property. Returns series current bar’s Ticks value.
TimeValue | Read-only property. Returns current bar’s time.
UpTicksValue | Read-only property. Returns series current bar’s Up Ticks value.
VolumeValue | Read-only property. Returns series current bar’s Volume value.

See Also

IInstrument Interface | PowerLanguage Namespace


IInstrument Properties

The properties of the IInstrument interface are listed below. For a complete list of IInstrument interface members, see the IInstrument Members topic.

Public Instance Properties

BarUpdateTime | Read-only property. Returns time of the last update of the current bar if Bar Magnifier mode is on. If Bar Magnifier mode is off, returns the time of the current bar (as the Time property).
CloseValue | Read-only property.Returns series current bar’s Close value.
CurrentBar | Read-only property. Returns current bar number.
DOM | Read-only property. Provides an interface for accessing Depth Of Market data.
DownTicksValue | Read-only property. Returns series current bar’s Down Ticks value.
FullSymbolData | Read-only property. Provides an interface for accessing any bar in the series.
HighValue | Read-only property. Returns series current bar's High value.
Info | Read-only property. Provides an interface for accessing symbol information.
LastBarInSession | Read-only property. Indicates whether current bar is the last bar in the SessionObject.
LastBarOnChart | Read-only property. Indicates whether current bar is the last bar on the chart.
LastBarTime | Read-only property. Returns the last bar’s time.
LowValue | Read-only property.Returns series current bar’s Low value.
OpenIntValue | Read-only property. Returns series current bar’s Open Interest value.
OpenValue | Read-only property.Returns series current bar’s Open value.
Point | Read-only property. Returns value of a point(pip).
Request | Read-only property. Returns the request for data describing the instrument.
Sessions | Read-only property. Provides an interface for accessing Sessions information.
Status | Read-only property. Returns current bar’s status: None = -1, Open = 0, Inside = 1, Close = 2.
StatusLine | Read-only property. Provides an interface for accessing information reflected in Status Line.
TickIDValue | Read-only property. This keyword can be used to distinguish between the bars with the same date and time stamps.For tick and volume-based charts: Returns the tick index within a second. For resolutions higher than 1 Tick returns the index of the last tick within the bar. For time-based charts with resolutions of 1 sec or more: Not supported. Returns 0.Real-time ticks stored in the data base are being assigned the last 31 bit - the identifier of realtime affiliation. In order to get the TickID value without real-time identifier one needs to calculate the remainder from TickID value division by 0x80000000, or execute an operation of bitwise "AND" with 0x7FFFFFFF value.uint _TrueTickID = Bars.TickIDValue % 0x80000000; or uint _TrueTickID = Bars.TickIDValue & 0x7FFFFFFF;TickIDValue value can be obtained for the current bar only.
TicksValue | Read-only property. Returns series current bar’s Ticks value.
TimeValue | Read-only property. Returns current bar’s time.
UpTicksValue | Read-only property. Returns series current bar’s Up Ticks value.
VolumeValue | Read-only property. Returns series current bar’s Volume value.

See Also

IInstrument Interface | PowerLanguage Namespace


BarUpdateTime Property

PowerLanguage.NET Help

IInstrument.BarUpdateTime Property

Read-only property. Returns time of the last update of the current bar if Bar Magnifier mode is on. If Bar Magnifier mode is off, returns the time of the current bar (as the Time property).

public DateTime BarUpdateTime { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


CloseValue Property

PowerLanguage.NET Help

IInstrument.CloseValue Property

Read-only property.Returns series current bar’s Close value.

public double CloseValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


CurrentBar Property

PowerLanguage.NET Help

IInstrument.CurrentBar Property

Read-only property. Returns current bar number.

public int CurrentBar { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


DOM Property

PowerLanguage.NET Help

IInstrument.DOM Property

Read-only property. Provides an interface for accessing Depth Of Market data.

public IDOMData DOM { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


DownTicksValue Property

PowerLanguage.NET Help

IInstrument.DownTicksValue Property

Read-only property. Returns series current bar’s Down Ticks value.

public double DownTicksValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


FullSymbolData Property

PowerLanguage.NET Help

IInstrument.FullSymbolData Property

Read-only property. Provides an interface for accessing any bar in the series.

public ISeriesSymbolDataRand FullSymbolData { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


HighValue Property

PowerLanguage.NET Help

IInstrument.HighValue Property

Read-only property. Returns series current bar's High value.

public double HighValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


Info Property

PowerLanguage.NET Help

IInstrument.Info Property

Read-only property. Provides an interface for accessing symbol information.

public IInstrumentSettings Info { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


LastBarInSession Property

PowerLanguage.NET Help

IInstrument.LastBarInSession Property

Read-only property. Indicates whether current bar is the last bar in the SessionObject.

public bool LastBarInSession { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


LastBarOnChart Property

PowerLanguage.NET Help

IInstrument.LastBarOnChart Property

Read-only property. Indicates whether current bar is the last bar on the chart.

public bool LastBarOnChart { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


LastBarTime Property

PowerLanguage.NET Help

IInstrument.LastBarTime Property

Read-only property. Returns the last bar’s time.

public DateTime LastBarTime { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


LowValue Property

PowerLanguage.NET Help

IInstrument.LowValue Property

Read-only property.Returns series current bar’s Low value.

public double LowValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


OpenIntValue Property

PowerLanguage.NET Help

IInstrument.OpenIntValue Property

Read-only property. Returns series current bar’s Open Interest value.

public double OpenIntValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


OpenValue Property

PowerLanguage.NET Help

IInstrument.OpenValue Property

Read-only property.Returns series current bar’s Open value.

public double OpenValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


Point Property

PowerLanguage.NET Help

IInstrument.Point Property

Read-only property. Returns value of a point(pip).

public double Point { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


Request Property

PowerLanguage.NET Help

IInstrument.Request Property

Read-only property. Returns the request for data describing the instrument.

public InstrumentDataRequest Request { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


Sessions Property

PowerLanguage.NET Help

IInstrument.Sessions Property

Read-only property. Provides an interface for accessing Sessions information.

public IROList<SessionObject> Sessions { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


Status Property

PowerLanguage.NET Help

IInstrument.Status Property

Read-only property. Returns current bar’s status: None = -1, Open = 0, Inside = 1, Close = 2.

public EBarState Status { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


StatusLine Property

PowerLanguage.NET Help

IInstrument.StatusLine Property

Read-only property. Provides an interface for accessing information reflected in Status Line.

public IStatusLine StatusLine { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


TickIDValue Property

PowerLanguage.NET Help

IInstrument.TickIDValue Property

Read-only property.

This keyword can be used to distinguish between the bars with the same date and time stamps.

For tick and volume-based charts: Returns the tick index within a second. For resolutions higher than 1 Tick returns the index of the last tick within the bar. For time-based charts with resolutions of 1 sec or more: Not supported. Returns 0.

Real-time ticks stored in the data base are being assigned the last 31 bit - the identifier of realtime affiliation. In order to get the TickID value without real-time identifier one needs to calculate the remainder from TickID value division by 0x80000000, or execute an operation of bitwise "AND" with 0x7FFFFFFF value.

uint _TrueTickID = Bars.TickIDValue % 0x80000000; or uint _TrueTickID = Bars.TickIDValue & 0x7FFFFFFF;

TickIDValue value can be obtained for the current bar only.

public uint TickIDValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


TicksValue Property

PowerLanguage.NET Help

IInstrument.TicksValue Property

Read-only property. Returns series current bar’s Ticks value.

public double TicksValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


TimeValue Property

PowerLanguage.NET Help

IInstrument.TimeValue Property

Read-only property. Returns current bar’s time.

public DateTime TimeValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


UpTicksValue Property

PowerLanguage.NET Help

IInstrument.UpTicksValue Property

Read-only property. Returns series current bar’s Up Ticks value.

public double UpTicksValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


VolumeValue Property

PowerLanguage.NET Help

IInstrument.VolumeValue Property

Read-only property. Returns series current bar’s Volume value.

public double VolumeValue { public get; }

See Also

IInstrument Interface | PowerLanguage Namespace


IInstrumentSettings Interface

An interface for accessing symbol information.

For a list of all members of this type, see IInstrumentSettings Members .

public interface IInstrumentSettings

Types that implement IInstrumentSettings

Type | Description
CustomInstrumentBase.InstrumentSettingsImpl |

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IInstrumentSettings Members | PowerLanguage Namespace


IInstrumentSettings Members

IInstrumentSettings overview

Public Instance Properties

ASymbolInfo2 | Read-only property. Returns symbol information as MTPA_MCSymbolInfo2 structure (all fields that are included in this structure).
BigPointValue | Read-only property. Returns symbol’s Big Point Value.
BVO | Read-only property. Returns built volume on tick-count or volume.
Category | Read-only property. Returns category of the symbol.
CurrencyCode | Read-only property. Returns currency code for symbol.
DailyLimit | Read-only property. Returns symbol's Daily Limit value.
DataFeed | Read-only property. Returns datafeed name for the symbol.
Description | Read-only property. Returns description for the symbol.
Exchange | Read-only property. Returns name of the exchange.
Expiration | Read-only property. Returns symbol expiration date (useful for futures).
ExpirationFromVendor | Read-only property. Returns symbol original expiration date (useful for futures).
Margin | Read-only property. Returns margin value for symbol.
MinMove | Read-only property. Returns symbol’s Min Movement value.
Name | Read-only property. Returns name of the symbol.
OptionType | Read-only property. Returns option's type.
PointValue | Read-only property. Returns symbol’s Point Value.
PriceScale | Read-only property. Returns symbol’s Price Scale value.
QuoteField | Read-only property. Returns current quote for symbol (Ask, Bid or Trade).
Request | Read-only property. Returns data request settings for symbol.
Resolution | Read-only property. Returns symbol’s resolution.
RTDataFeed | Read-only property. Returns the datafeed of the real-time symbol in case the merging option is enabled. If the merging option is disabled returns the same value as the DataFeed property. In case of a custom futures instrument the name of the last contract is returned.
RTExchange | Read-only property. Returns name of the exchange for realtime symbol.
RTSymbolName | Read-only property. Returns the name of the real-time symbol in case the merging option is enabled. If the merging option is disabled returns the same value as the Name property. In case of a custom futures instrument the name of the last contract is returned.
SessionName | Read-only property. Returns current session name for symbol.
StrikePrice | Read-only property. Returns strike price for options.
TimeZone | Read-only property. Returns current time zone for symbol.

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


IInstrumentSettings Properties

The properties of the IInstrumentSettings interface are listed below. For a complete list of IInstrumentSettings interface members, see the IInstrumentSettings Members topic.

Public Instance Properties

ASymbolInfo2 | Read-only property. Returns symbol information as MTPA_MCSymbolInfo2 structure (all fields that are included in this structure).
BigPointValue | Read-only property. Returns symbol’s Big Point Value.
BVO | Read-only property. Returns built volume on tick-count or volume.
Category | Read-only property. Returns category of the symbol.
CurrencyCode | Read-only property. Returns currency code for symbol.
DailyLimit | Read-only property. Returns symbol's Daily Limit value.
DataFeed | Read-only property. Returns datafeed name for the symbol.
Description | Read-only property. Returns description for the symbol.
Exchange | Read-only property. Returns name of the exchange.
Expiration | Read-only property. Returns symbol expiration date (useful for futures).
ExpirationFromVendor | Read-only property. Returns symbol original expiration date (useful for futures).
Margin | Read-only property. Returns margin value for symbol.
MinMove | Read-only property. Returns symbol’s Min Movement value.
Name | Read-only property. Returns name of the symbol.
OptionType | Read-only property. Returns option's type.
PointValue | Read-only property. Returns symbol’s Point Value.
PriceScale | Read-only property. Returns symbol’s Price Scale value.
QuoteField | Read-only property. Returns current quote for symbol (Ask, Bid or Trade).
Request | Read-only property. Returns data request settings for symbol.
Resolution | Read-only property. Returns symbol’s resolution.
RTDataFeed | Read-only property. Returns the datafeed of the real-time symbol in case the merging option is enabled. If the merging option is disabled returns the same value as the DataFeed property. In case of a custom futures instrument the name of the last contract is returned.
RTExchange | Read-only property. Returns name of the exchange for realtime symbol.
RTSymbolName | Read-only property. Returns the name of the real-time symbol in case the merging option is enabled. If the merging option is disabled returns the same value as the Name property. In case of a custom futures instrument the name of the last contract is returned.
SessionName | Read-only property. Returns current session name for symbol.
StrikePrice | Read-only property. Returns strike price for options.
TimeZone | Read-only property. Returns current time zone for symbol.

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


ASymbolInfo2 Property

PowerLanguage.NET Help

IInstrumentSettings.ASymbolInfo2 Property

Read-only property. Returns symbol information as MTPA_MCSymbolInfo2 structure (all fields that are included in this structure).

public MTPA_MCSymbolInfo2 ASymbolInfo2 { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


BigPointValue Property

PowerLanguage.NET Help

IInstrumentSettings.BigPointValue Property

Read-only property. Returns symbol’s Big Point Value.

public double BigPointValue { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


BVO Property

PowerLanguage.NET Help

IInstrumentSettings.BVO Property

Read-only property. Returns built volume on tick-count or volume.

public BuildVolumeOn BVO { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Category Property

PowerLanguage.NET Help

IInstrumentSettings.Category Property

Read-only property. Returns category of the symbol.

public ESymbolCategory Category { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


CurrencyCode Property

PowerLanguage.NET Help

IInstrumentSettings.CurrencyCode Property

Read-only property. Returns currency code for symbol.

public MTPA_MCSymbolCurrency CurrencyCode { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


DailyLimit Property

PowerLanguage.NET Help

IInstrumentSettings.DailyLimit Property

Read-only property. Returns symbol's Daily Limit value.

public double DailyLimit { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


DataFeed Property

PowerLanguage.NET Help

IInstrumentSettings.DataFeed Property

Read-only property. Returns datafeed name for the symbol.

public string DataFeed { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Description Property

PowerLanguage.NET Help

IInstrumentSettings.Description Property

Read-only property. Returns description for the symbol.

public string Description { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Exchange Property

PowerLanguage.NET Help

IInstrumentSettings.Exchange Property

Read-only property. Returns name of the exchange.

public string Exchange { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Expiration Property

PowerLanguage.NET Help

IInstrumentSettings.Expiration Property

Read-only property. Returns symbol expiration date (useful for futures).

public DateTime Expiration { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


ExpirationFromVendor Property

PowerLanguage.NET Help

IInstrumentSettings.ExpirationFromVendor Property

Read-only property. Returns symbol original expiration date (useful for futures).

public DateTime ExpirationFromVendor { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Margin Property

PowerLanguage.NET Help

IInstrumentSettings.Margin Property

Read-only property. Returns margin value for symbol.

public double Margin { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


MinMove Property

PowerLanguage.NET Help

IInstrumentSettings.MinMove Property

Read-only property. Returns symbol’s Min Movement value.

public double MinMove { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

IInstrumentSettings.Name Property

Read-only property. Returns name of the symbol.

public string Name { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


OptionType Property

PowerLanguage.NET Help

IInstrumentSettings.OptionType Property

Read-only property. Returns option's type.

public OptionType OptionType { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


PointValue Property

PowerLanguage.NET Help

IInstrumentSettings.PointValue Property

Read-only property. Returns symbol’s Point Value.

public double PointValue { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


PriceScale Property

PowerLanguage.NET Help

IInstrumentSettings.PriceScale Property

Read-only property. Returns symbol’s Price Scale value.

public double PriceScale { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


QuoteField Property

PowerLanguage.NET Help

IInstrumentSettings.QuoteField Property

Read-only property. Returns current quote for symbol (Ask, Bid or Trade).

public RequestQuoteField QuoteField { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Request Property

PowerLanguage.NET Help

IInstrumentSettings.Request Property

Read-only property. Returns data request settings for symbol.

public DataRequest Request { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


Resolution Property

PowerLanguage.NET Help

IInstrumentSettings.Resolution Property

Read-only property. Returns symbol’s resolution.

public Resolution Resolution { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


RTDataFeed Property

PowerLanguage.NET Help

IInstrumentSettings.RTDataFeed Property

Read-only property. Returns the datafeed of the real-time symbol in case the merging option is enabled. If the merging option is disabled returns the same value as the DataFeed property. In case of a custom futures instrument the name of the last contract is returned.

public string RTDataFeed { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


RTExchange Property

PowerLanguage.NET Help

IInstrumentSettings.RTExchange Property

Read-only property. Returns name of the exchange for realtime symbol.

public string RTExchange { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


RTSymbolName Property

PowerLanguage.NET Help

IInstrumentSettings.RTSymbolName Property

Read-only property. Returns the name of the real-time symbol in case the merging option is enabled. If the merging option is disabled returns the same value as the Name property. In case of a custom futures instrument the name of the last contract is returned.

public string RTSymbolName { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


SessionName Property

PowerLanguage.NET Help

IInstrumentSettings.SessionName Property

Read-only property. Returns current session name for symbol.

public string SessionName { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


StrikePrice Property

PowerLanguage.NET Help

IInstrumentSettings.StrikePrice Property

Read-only property. Returns strike price for options.

public double StrikePrice { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


TimeZone Property

PowerLanguage.NET Help

IInstrumentSettings.TimeZone Property

Read-only property. Returns current time zone for symbol.

public RequestTimeZone TimeZone { public get; }

See Also

IInstrumentSettings Interface | PowerLanguage Namespace


IInstrumentSettingsTZI Interface

For a list of all members of this type, see IInstrumentSettingsTZI Members .

public interface IInstrumentSettingsTZI

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IInstrumentSettingsTZI Members | PowerLanguage Namespace


IInstrumentSettingsTZI Members

IInstrumentSettingsTZI overview

Public Instance Properties

TimeZoneInstrument Read-only property. Returns margin value for symbol.

See Also

IInstrumentSettingsTZI Interface | PowerLanguage Namespace


IInstrumentSettingsTZI Properties

The properties of the IInstrumentSettingsTZI interface are listed below. For a complete list of IInstrumentSettingsTZI interface members, see the IInstrumentSettingsTZI Members topic.

Public Instance Properties

TimeZoneInstrument Read-only property. Returns margin value for symbol.

See Also

IInstrumentSettingsTZI Interface | PowerLanguage Namespace


TimeZoneInstrument Property

PowerLanguage.NET Help

IInstrumentSettingsTZI.TimeZoneInstrument Property

Read-only property. Returns margin value for symbol.

public string TimeZoneInstrument { public get; }

See Also

IInstrumentSettingsTZI Interface | PowerLanguage Namespace


IInstrumentTPO Interface

Interface for TPO series data access.

For a list of all members of this type, see IInstrumentTPO Members .

public interface IInstrumentTPO : ITPOData

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IInstrumentTPO Members | PowerLanguage Namespace


IInstrumentTPO Members

IInstrumentTPO overview

Public Instance Properties

DynamicSettings | Read-only property. Provides an interface for accessing TPO specific instrument dynamically changed settings.
FullTPOData | Read-only property. Provides an interface for accessing TPO data of any bar in the series.
LevelHighValue | Read-only property. Returns series current bar's TPO high price.
LevelLowValue | Read-only property. Returns series current bar's TPO low price.
LevelsCountValue | Read-only property. Returns series current bar's TPO levels count.
POCBlocksValue | Read-only property. Returns series current bar's TPO POC value.
POCPriceValue | Read-only property. Returns series current bar's TPO POC price.
Settings | Read-only property. Provides an interface for accessing TPO specific instrument settings.

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


IInstrumentTPO Properties

The properties of the IInstrumentTPO interface are listed below. For a complete list of IInstrumentTPO interface members, see the IInstrumentTPO Members topic.

Public Instance Properties

DynamicSettings | Read-only property. Provides an interface for accessing TPO specific instrument dynamically changed settings.
FullTPOData | Read-only property. Provides an interface for accessing TPO data of any bar in the series.
LevelHighValue | Read-only property. Returns series current bar's TPO high price.
LevelLowValue | Read-only property. Returns series current bar's TPO low price.
LevelsCountValue | Read-only property. Returns series current bar's TPO levels count.
POCBlocksValue | Read-only property. Returns series current bar's TPO POC value.
POCPriceValue | Read-only property. Returns series current bar's TPO POC price.
Settings | Read-only property. Provides an interface for accessing TPO specific instrument settings.

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


DynamicSettings Property

PowerLanguage.NET Help

IInstrumentTPO.DynamicSettings Property

Read-only property. Provides an interface for accessing TPO specific instrument dynamically changed settings.

public ITPODynamicSettings DynamicSettings { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


FullTPOData Property

PowerLanguage.NET Help

IInstrumentTPO.FullTPOData Property

Read-only property. Provides an interface for accessing TPO data of any bar in the series.

public ITPODataRand FullTPOData { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


LevelHighValue Property

PowerLanguage.NET Help

IInstrumentTPO.LevelHighValue Property

Read-only property. Returns series current bar's TPO high price.

public double LevelHighValue { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


LevelLowValue Property

PowerLanguage.NET Help

IInstrumentTPO.LevelLowValue Property

Read-only property. Returns series current bar's TPO low price.

public double LevelLowValue { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


LevelsCountValue Property

PowerLanguage.NET Help

IInstrumentTPO.LevelsCountValue Property

Read-only property. Returns series current bar's TPO levels count.

public int LevelsCountValue { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


POCBlocksValue Property

PowerLanguage.NET Help

IInstrumentTPO.POCBlocksValue Property

Read-only property. Returns series current bar's TPO POC value.

public int POCBlocksValue { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


POCPriceValue Property

PowerLanguage.NET Help

IInstrumentTPO.POCPriceValue Property

Read-only property. Returns series current bar's TPO POC price.

public double POCPriceValue { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


Settings Property

PowerLanguage.NET Help

IInstrumentTPO.Settings Property

Read-only property. Provides an interface for accessing TPO specific instrument settings.

public ITPOSettings Settings { public get; }

See Also

IInstrumentTPO Interface | PowerLanguage Namespace


IMarketPosition Interface

An interface that provides information about the position.

For a list of all members of this type, see IMarketPosition Members .

public interface IMarketPosition

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IMarketPosition Members | PowerLanguage Namespace


IMarketPosition Members

IMarketPosition overview

Public Instance Properties

ClosedTrades | A collection of closed orders for given position.
MaxDrawDown | Read-only property. Returns position’s maximum potential loss (drawdown).
MaxRunUp | Read-only property. Returns position’s maximum potential profit.
OpenLots | Read-only property. Returns position’s open lots.
OpenProfit | Read-only property. Returns position’s non-fixed profit.
OpenTrades | Open trades for given position (a collection will be empty for closed positions).
Profit | Read-only property. Returns position profit.
ProfitPerContract | Read-only property. Returns profit per single contract.
Side | Read-only property. Returns position type. Flat, Long, Short.
Value | Read-only property. Returns position’s value.

See Also

IMarketPosition Interface | PowerLanguage Namespace


IMarketPosition Properties

The properties of the IMarketPosition interface are listed below. For a complete list of IMarketPosition interface members, see the IMarketPosition Members topic.

Public Instance Properties

ClosedTrades | A collection of closed orders for given position.
MaxDrawDown | Read-only property. Returns position’s maximum potential loss (drawdown).
MaxRunUp | Read-only property. Returns position’s maximum potential profit.
OpenLots | Read-only property. Returns position’s open lots.
OpenProfit | Read-only property. Returns position’s non-fixed profit.
OpenTrades | Open trades for given position (a collection will be empty for closed positions).
Profit | Read-only property. Returns position profit.
ProfitPerContract | Read-only property. Returns profit per single contract.
Side | Read-only property. Returns position type. Flat, Long, Short.
Value | Read-only property. Returns position’s value.

See Also

IMarketPosition Interface | PowerLanguage Namespace


ClosedTrades Property

PowerLanguage.NET Help

IMarketPosition.ClosedTrades Property

A collection of closed orders for given position.

public IROList<ITrade> ClosedTrades { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


MaxDrawDown Property

PowerLanguage.NET Help

IMarketPosition.MaxDrawDown Property

Read-only property. Returns position’s maximum potential loss (drawdown).

public double MaxDrawDown { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


MaxRunUp Property

PowerLanguage.NET Help

IMarketPosition.MaxRunUp Property

Read-only property. Returns position’s maximum potential profit.

public double MaxRunUp { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


OpenLots Property

PowerLanguage.NET Help

IMarketPosition.OpenLots Property

Read-only property. Returns position’s open lots.

public int OpenLots { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


OpenProfit Property

PowerLanguage.NET Help

IMarketPosition.OpenProfit Property

Read-only property. Returns position’s non-fixed profit.

public double OpenProfit { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


OpenTrades Property

PowerLanguage.NET Help

IMarketPosition.OpenTrades Property

Open trades for given position (a collection will be empty for closed positions).

public IROList<ITrade> OpenTrades { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


Profit Property

PowerLanguage.NET Help

IMarketPosition.Profit Property

Read-only property. Returns position profit.

public double Profit { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


ProfitPerContract Property

PowerLanguage.NET Help

IMarketPosition.ProfitPerContract Property

Read-only property. Returns profit per single contract.

public double ProfitPerContract { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


Side Property

PowerLanguage.NET Help

IMarketPosition.Side Property

Read-only property. Returns position type. Flat, Long, Short.

public EMarketPositionSide Side { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

IMarketPosition.Value Property

Read-only property. Returns position’s value.

public int Value { public get; }

See Also

IMarketPosition Interface | PowerLanguage Namespace


InputAttribute Class

Class that contains information about the input attribute.

For a list of all members of this type, see InputAttribute Members .

System.Object
Attribute
InputAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Property, AllowMultiple=False, Inherited=True)]
public class InputAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

InputAttribute Members | PowerLanguage Namespace


InputAttribute Members

InputAttribute overview

Public Instance Constructors

InputAttribute Overloaded. Initializes a new instance of the InputAttribute class.

Public Instance Properties

TypeId (inherited from Attribute)

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InputAttribute Class | PowerLanguage Namespace


InputAttribute Constructor

Initializes a new instance of the InputAttribute class with list of values.

Overload List

Initializes a new instance of the InputAttribute class.

public InputAttribute()

Initializes a new instance of the InputAttribute class with list of values.

public InputAttribute(params string[])

See Also

InputAttribute Class | PowerLanguage Namespace


InputAttribute Constructor

Initializes a new instance of the InputAttribute class with list of values.

InputAttribute(
params string[] _enumeration
);

Parameters

_enumeration

See Also

InputAttribute Class | PowerLanguage Namespace | InputAttribute Constructor Overload List


InputAttribute Constructor

Initializes a new instance of the InputAttribute class.

InputAttribute();

See Also

InputAttribute Class | PowerLanguage Namespace | InputAttribute Constructor Overload List


InputInfo Class

For a list of all members of this type, see InputInfo Members .

System.Object
InputInfo

public class InputInfo

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

InputInfo Members | PowerLanguage Namespace


InputInfo Members

InputInfo overview

Public Instance Constructors

InputInfo Constructor

Public Instance Properties

InputEnumeration
InputName
InputType

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InputInfo Class | PowerLanguage Namespace


InputInfo Constructor

InputInfo(
string inputName,
Type inputType,
params string[] inputEnumeration
);

See Also

InputInfo Class | PowerLanguage Namespace


InputInfo Properties

The properties of the InputInfo class are listed below. For a complete list of InputInfo class members, see the InputInfo Members topic.

Public Instance Properties

InputEnumeration
InputName
InputType

See Also

InputInfo Class | PowerLanguage Namespace


InputEnumeration Property

PowerLanguage.NET Help

InputInfo.InputEnumeration Property

public string[] InputEnumeration { public get; private set; }

See Also

InputInfo Class | PowerLanguage Namespace


InputName Property

PowerLanguage.NET Help

InputInfo.InputName Property

public string InputName { public get; private set; }

See Also

InputInfo Class | PowerLanguage Namespace


InputType Property

PowerLanguage.NET Help

InputInfo.InputType Property

public Type InputType { public get; private set; }

See Also

InputInfo Class | PowerLanguage Namespace


InstrumentDataRequest Structure

The structure that defines instrument data request.

For a list of all members of this type, see InstrumentDataRequest Members .

System.Object
InstrumentDataRequest

public struct InstrumentDataRequest : IEquatable<T>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

InstrumentDataRequest Members | PowerLanguage Namespace


InstrumentDataRequest Members

InstrumentDataRequest overview

Public Instance Constructors

InstrumentDataRequest Overloaded. Initializes a new instance of the InstrumentDataRequest class.

Public Instance Fields

BuildResultVolumeOn |
BuildVolumeOn | Instrument's "build volume on" setting. BuildVolumeOn
Category | Symbol category ESymbolCategory.
DataFeed | Data feed name.
Exchange | Exchange name.
FilterOutOfRangeData | Indicates whether to filter result data based on start/end point of the request.
QuoteField | Field of the QuoteField. RequestQuoteField. Default value is Trade.
Range | Represents data request's range. DataRequest
RequestStatusDetails |
Resolution | Resolution info Resolution.
RTDataFeed | Realtime Data feed name.
RTExchange | Realtime Exchange name.
RTSymbol | Realtime Symbol name.
SessionName | Field of the Session Name.
StatusLineMode |
Subscribe2RT | Defines whether request is realtime or historical.
Symbol | Symbol name.
TimeZone | Time zone field. RequestTimeZone. Default value is Local.

Public Instance Properties

From | Obsolete. Use Range.
To | Obsolete. Use Range.

Public Instance Methods

GetType (inherited from Object) |
ToString (inherited from ValueType) |
Verify | Checks for correctness.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest Constructor

Initializes a new instance of InstrumentDataRequest.

Overload List

Initializes a new instance of InstrumentDataRequest.

public InstrumentDataRequest(MTPA_MCSymbolInfo2)

Initializes a new instance of InstrumentDataRequest.

public InstrumentDataRequest(IInstrumentSettings)

Initializes a new instance of InstrumentDataRequest.

public InstrumentDataRequest(IInstrumentSettings,Resolution,DataRequest)

Initialize a new instance of InstrumentDataRequest.

public InstrumentDataRequest(IInstrumentSettings,Resolution,DateTime,DateTime)

Initializes a new instance of InstrumentDataRequest.

public InstrumentDataRequest(string,MTPA_MCSymbolInfo2,Resolution,DateTime,DateTime)

Initializes a new instance of InstrumentDataRequest.

public InstrumentDataRequest(string,string,string,ESymbolCategory,Resolution,DateTime,DateTime)

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest Constructor

Initializes a new instance of InstrumentDataRequest.

InstrumentDataRequest(
string symbol,
string dataFeed,
string exchange,
ESymbolCategory category,
Resolution resolution,
DateTime from,
DateTime to
);

Parameters

symbol
Symbol name.
dataFeed
Data feed name.
exchange
Exchange name.
category
Symbol category.
resolution
Resolution info.
from
"From" DateTime.
to
"To" DateTime.

See Also

InstrumentDataRequest Class | PowerLanguage Namespace | InstrumentDataRequest Constructor Overload List


InstrumentDataRequest Constructor

Initialize a new instance of InstrumentDataRequest.

InstrumentDataRequest(
IInstrumentSettings Settings,
Resolution resolution,
DateTime from,
DateTime to
);

Parameters

Settings
Instrument settings. IInstrumentSettings
resolution
Resolution info.
from
"From" DateTime.
to
"To" DateTime.

See Also

InstrumentDataRequest Class | PowerLanguage Namespace | InstrumentDataRequest Constructor Overload List


InstrumentDataRequest Constructor

Initializes a new instance of InstrumentDataRequest.

InstrumentDataRequest(
IInstrumentSettings Settings
);

Parameters

Settings
Instrument settings. IInstrumentSettings

See Also

InstrumentDataRequest Class | PowerLanguage Namespace | InstrumentDataRequest Constructor Overload List


InstrumentDataRequest Constructor

Initializes a new instance of InstrumentDataRequest.

InstrumentDataRequest(
string dataFeed,
MTPA_MCSymbolInfo2 symbol,
Resolution resolution,
DateTime from,
DateTime to
);

Parameters

dataFeed
Data feed name.
symbol
Symbol name.
resolution
Resolution info.
from
"From" DateTime.
to
"To" DateTime.

See Also

InstrumentDataRequest Class | PowerLanguage Namespace | InstrumentDataRequest Constructor Overload List


InstrumentDataRequest Constructor

Initializes a new instance of InstrumentDataRequest.

InstrumentDataRequest(
MTPA_MCSymbolInfo2 symbol
);

Parameters

symbol
Symbol info.

See Also

InstrumentDataRequest Class | PowerLanguage Namespace | InstrumentDataRequest Constructor Overload List


InstrumentDataRequest Constructor

Initializes a new instance of InstrumentDataRequest.

InstrumentDataRequest(
IInstrumentSettings settings,
Resolution res,
DataRequest request
);

Parameters

settings
Instrument's settings. IInstrumentSettings
res
Instrument's resolution. Resolution
request
Instrument's data range. DataRequest

See Also

InstrumentDataRequest Class | PowerLanguage Namespace | InstrumentDataRequest Constructor Overload List


InstrumentDataRequest Fields

The fields of the InstrumentDataRequest structure are listed below. For a complete list of InstrumentDataRequest structure members, see the InstrumentDataRequest Members topic.

Public Instance Fields

BuildResultVolumeOn |
BuildVolumeOn | Instrument's "build volume on" setting. BuildVolumeOn
Category | Symbol category ESymbolCategory.
DataFeed | Data feed name.
Exchange | Exchange name.
FilterOutOfRangeData | Indicates whether to filter result data based on start/end point of the request.
QuoteField | Field of the QuoteField. RequestQuoteField. Default value is Trade.
Range | Represents data request's range. DataRequest
RequestStatusDetails |
Resolution | Resolution info Resolution.
RTDataFeed | Realtime Data feed name.
RTExchange | Realtime Exchange name.
RTSymbol | Realtime Symbol name.
SessionName | Field of the Session Name.
StatusLineMode |
Subscribe2RT | Defines whether request is realtime or historical.
Symbol | Symbol name.
TimeZone | Time zone field. RequestTimeZone. Default value is Local.

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.BuildResultVolumeOn Field

public BuildVolumeOn BuildResultVolumeOn;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.BuildVolumeOn Field

Instrument's "build volume on" setting. BuildVolumeOn

public BuildVolumeOn BuildVolumeOn;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Category Field

Symbol category ESymbolCategory.

public ESymbolCategory Category;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.DataFeed Field

Data feed name.

public string DataFeed;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Exchange Field

Exchange name.

public string Exchange;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.FilterOutOfRangeData Field

Indicates whether to filter result data based on start/end point of the request.

public bool FilterOutOfRangeData;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.QuoteField Field

Field of the QuoteField. RequestQuoteField. Default value is Trade.

public RequestQuoteField QuoteField;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Range Field

Represents data request's range. DataRequest

public DataRequest Range;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.RequestStatusDetails Field

public bool RequestStatusDetails;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Resolution Field

Resolution info Resolution.

public Resolution Resolution;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.RTDataFeed Field

Realtime Data feed name.

public string RTDataFeed;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.RTExchange Field

Realtime Exchange name.

public string RTExchange;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.RTSymbol Field

Realtime Symbol name.

public string RTSymbol;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.SessionName Field

Field of the Session Name.

public string SessionName;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.StatusLineMode Field

public SubscribeStatusLineMode StatusLineMode;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Subscribe2RT Field

Defines whether request is realtime or historical.

public bool Subscribe2RT;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Symbol Field

Symbol name.

public string Symbol;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.TimeZone Field

Time zone field. RequestTimeZone. Default value is Local.

public RequestTimeZone TimeZone;

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest Properties

The properties of the InstrumentDataRequest structure are listed below. For a complete list of InstrumentDataRequest structure members, see the InstrumentDataRequest Members topic.

Public Instance Properties

From | Obsolete. Use Range.
To | Obsolete. Use Range.

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


From Property

PowerLanguage.NET Help

InstrumentDataRequest.From Property

Obsolete. Use Range.

public DateTime From { public get; public set; }

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


To Property

PowerLanguage.NET Help

InstrumentDataRequest.To Property

Obsolete. Use Range.

public DateTime To { public get; public set; }

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest Methods

The methods of the InstrumentDataRequest structure are listed below. For a complete list of InstrumentDataRequest structure members, see the InstrumentDataRequest Members topic.

Public Instance Methods

GetType (inherited from Object) |
ToString (inherited from ValueType) |
Verify | Checks for correctness.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


InstrumentDataRequest.Verify Method

Checks for correctness.

public void Verify();

See Also

InstrumentDataRequest Class | PowerLanguage Namespace


IOGMode Enumeration

Enumeration describing IntrabarOrderGeneration (IOG) mode.

public enum IOGMode

Members

Member Name | Description
Disabled | IOG mode is disabled.
Enabled | IOG mode is enabled.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


IOGModeAttribute Class

The class that defines IOGModeAttribute.

For a list of all members of this type, see IOGModeAttribute Members .

System.Object
Attribute
IOGModeAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class IOGModeAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOGModeAttribute Members | PowerLanguage Namespace


IOGModeAttribute Members

IOGModeAttribute overview

Public Instance Constructors

IOGModeAttribute Overloaded. Initializes a new instance of the IOGModeAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. IOGModeAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

IOGModeAttribute Class | PowerLanguage Namespace


IOGModeAttribute Constructor

Initializes a new instance of the IOGModeAttribute class.

Overload List

Initializes a new instance of the IOGModeAttribute class.

public IOGModeAttribute()

Initializes a new instance of the IOGModeAttribute class.

public IOGModeAttribute(IOGMode)

See Also

IOGModeAttribute Class | PowerLanguage Namespace


IOGModeAttribute Constructor

Initializes a new instance of the IOGModeAttribute class.

IOGModeAttribute(
IOGMode value
);

Parameters

value
IOGModeAttribute value.

See Also

IOGModeAttribute Class | PowerLanguage Namespace | IOGModeAttribute Constructor Overload List


IOGModeAttribute Constructor

Initializes a new instance of the IOGModeAttribute class.

IOGModeAttribute();

See Also

IOGModeAttribute Class | PowerLanguage Namespace | IOGModeAttribute Constructor Overload List


IOGModeAttribute Properties

The properties of the IOGModeAttribute class are listed below. For a complete list of IOGModeAttribute class members, see the IOGModeAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. IOGModeAttribute value.

See Also

IOGModeAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

IOGModeAttribute.Value Property

Read-write property. IOGModeAttribute value.

public IOGMode? Value { public get; public set; }

See Also

IOGModeAttribute Class | PowerLanguage Namespace


IOrderCreator Interface

An interface for order creation.

For a list of all members of this type, see IOrderCreator Members .

public interface IOrderCreator

Types that implement IOrderCreator

Type | Description
OrderCreator | Allows order generation.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOrderCreator Members | PowerLanguage Namespace


IOrderCreator Members

IOrderCreator overview

Public Instance Methods

Limit | Function for Limit-order creation.
MarketNextBar | Function for market order creation on the next bar.
MarketThisBar | Function for market order creation on the current bar.
Stop | Function for Stop-order creation.
StopLimit | Function for StopLimit-order creation.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderCreator Methods

The methods of the IOrderCreator interface are listed below. For a complete list of IOrderCreator interface members, see the IOrderCreator Members topic.

Public Instance Methods

Limit | Function for Limit-order creation.
MarketNextBar | Function for market order creation on the next bar.
MarketThisBar | Function for market order creation on the current bar.
Stop | Function for Stop-order creation.
StopLimit | Function for StopLimit-order creation.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderCreator.Limit Method

Function for Limit-order creation.

IOrderPriced Limit(
SOrderParameters orderParams
);

Parameters

orderParams
Parameters for creating limit order.

Return Value

An instance of the interface describing limit order.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderCreator.MarketNextBar Method

Function for market order creation on the next bar.

IOrderMarket MarketNextBar(
SOrderParameters orderParams
);

Parameters

orderParams
Parameters for creating market order.

Return Value

An instance of the interface describing market order.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderCreator.MarketThisBar Method

Function for market order creation on the current bar.

IOrderMarket MarketThisBar(
SOrderParameters orderParams
);

Parameters

orderParams
Parameters for creating market order.

Return Value

An instance of the interface describing market order.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderCreator.Stop Method

Function for Stop-order creation.

IOrderPriced Stop(
SOrderParameters orderParams
);

Parameters

orderParams
Parameters for creating stop order.

Return Value

An instance of the interface describing stop order.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderCreator.StopLimit Method

Function for StopLimit-order creation.

IOrderStopLimit StopLimit(
SOrderParameters orderParams
);

Parameters

orderParams
Parameters for creating stop-limit order.

Return Value

An instance of the interface describing stop-limit order.

See Also

IOrderCreator Interface | PowerLanguage Namespace


IOrderMarket Interface

An interface describing Market Order.

For a list of all members of this type, see IOrderMarket Members .

public interface IOrderMarket : IOrderObject

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOrderMarket Members | PowerLanguage Namespace


IOrderMarket Members

IOrderMarket overview

Public Instance Methods

Send | Overloaded. Generation of an order.
SendFromEntry | Overloaded. Generation of an exit order from entry name.

See Also

IOrderMarket Interface | PowerLanguage Namespace


IOrderMarket Methods

The methods of the IOrderMarket interface are listed below. For a complete list of IOrderMarket interface members, see the IOrderMarket Members topic.

Public Instance Methods

Send | Overloaded. Generation of an order.
SendFromEntry | Overloaded. Generation of an exit order from entry name.

See Also

IOrderMarket Interface | PowerLanguage Namespace


Send Method

PowerLanguage.NET Help

IOrderMarket.Send Method

Generation of an order.

Overload List

Generation of an order.

void Send()

Generation of an order with 'num_lots' number of lots.

void Send(int)

Generation of an order with new order name.

void Send(string)

Generation of an order with 'num_lots' number of lots.

void Send(string,int)

See Also

IOrderMarket Interface | PowerLanguage Namespace


IOrderMarket.Send() Method

Generation of an order.

void Send();

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.Send Overload List


IOrderMarket.Send(Int32) Method

Generation of an order with 'num_lots' number of lots.

void Send(
int numLots
);

Parameters

numLots
Number of lots. By default: 0

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.Send Overload List


IOrderMarket.Send(String) Method

Generation of an order with new order name.

void Send(
string new_name
);

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.Send Overload List


IOrderMarket.Send(String, Int32) Method

Generation of an order with 'num_lots' number of lots.

void Send(
string new_name,
int numLots
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
numLots
Number of lots. By default: 0

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.Send Overload List


SendFromEntry Method

PowerLanguage.NET Help

IOrderMarket.SendFromEntry Method

Generation of an exit order from entry with 'num_lots' number of lots.

Overload List

Generation of an exit order from entry with 'num_lots' number of lots.

void SendFromEntry(int,string)

Generation of an exit order from entry name.

void SendFromEntry(string)

Generation of an exit order from entry with 'num_lots' number of lots.

void SendFromEntry(string,int,string)

Generation of an exit order from entry with new order name.

void SendFromEntry(string,string)

See Also

IOrderMarket Interface | PowerLanguage Namespace


IOrderMarket.SendFromEntry(Int32, String) Method

Generation of an exit order from entry with 'num_lots' number of lots.

void SendFromEntry(
int numLots,
string fromName
);

Parameters

numLots
Number of lots. By default: 0
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.SendFromEntry Overload List


IOrderMarket.SendFromEntry(String) Method

Generation of an exit order from entry name.

void SendFromEntry(
string fromName
);

Parameters

fromName
name of the entry order, of which needs to be closed

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.SendFromEntry Overload List


IOrderMarket.SendFromEntry(String, Int32, String) Method

Generation of an exit order from entry with 'num_lots' number of lots.

void SendFromEntry(
string new_name,
int numLots,
string fromName
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
numLots
Number of lots. By default: 0
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.SendFromEntry Overload List


IOrderMarket.SendFromEntry(String, String) Method

Generation of an exit order from entry with new order name.

void SendFromEntry(
string new_name,
string fromName
);

Parameters

new_name
New name for this order
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderMarket Interface | PowerLanguage Namespace | IOrderMarket.SendFromEntry Overload List


IOrderObject Interface

Base interface for orders.

For a list of all members of this type, see IOrderObject Members .

PowerLanguage.IOrderObject
PowerLanguage.IOrderMarket
PowerLanguage.IOrderPriced
PowerLanguage.IOrderStopLimit

public interface IOrderObject

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOrderObject Members | PowerLanguage Namespace


IOrderObject Members

IOrderObject overview

Public Instance Properties

ID | Read-only property. Returns order ID.
Info | Read-only property. Returns order information (Order).

See Also

IOrderObject Interface | PowerLanguage Namespace


IOrderObject Properties

The properties of the IOrderObject interface are listed below. For a complete list of IOrderObject interface members, see the IOrderObject Members topic.

Public Instance Properties

ID | Read-only property. Returns order ID.
Info | Read-only property. Returns order information (Order).

See Also

IOrderObject Interface | PowerLanguage Namespace


ID Property

PowerLanguage.NET Help

IOrderObject.ID Property

Read-only property. Returns order ID.

public int ID { public get; }

See Also

IOrderObject Interface | PowerLanguage Namespace


Info Property

PowerLanguage.NET Help

IOrderObject.Info Property

Read-only property. Returns order information (Order).

public Order Info { public get; }

See Also

IOrderObject Interface | PowerLanguage Namespace


IOrderPriced Interface

An interface describing Price Order.

For a list of all members of this type, see IOrderPriced Members .

public interface IOrderPriced : IOrderObject

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOrderPriced Members | PowerLanguage Namespace


IOrderPriced Members

IOrderPriced overview

Public Instance Methods

Send | Overloaded. Generation of Price order with 'price' price.
SendFromEntry | Overloaded. Generation of Price exit from entry order with 'price' price.

See Also

IOrderPriced Interface | PowerLanguage Namespace


IOrderPriced Methods

The methods of the IOrderPriced interface are listed below. For a complete list of IOrderPriced interface members, see the IOrderPriced Members topic.

Public Instance Methods

Send | Overloaded. Generation of Price order with 'price' price.
SendFromEntry | Overloaded. Generation of Price exit from entry order with 'price' price.

See Also

IOrderPriced Interface | PowerLanguage Namespace


Send Method

PowerLanguage.NET Help

IOrderPriced.Send Method

Generation of Price order with 'price' price.

Overload List

Generation of Price order with 'price' price.

void Send(double)

Generation of Price order with 'price' price and 'num_lots' number of contracts.

void Send(double,int)

Generation of Price order with 'price' price.

void Send(string,double)

Generation of Price order with 'price' price and 'num_lots' number of contracts.

void Send(string,double,int)

See Also

IOrderPriced Interface | PowerLanguage Namespace


IOrderPriced.Send(Double) Method

Generation of Price order with 'price' price.

void Send(
double price
);

Parameters

price
Order price.

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.Send Overload List


IOrderPriced.Send(Double, Int32) Method

Generation of Price order with 'price' price and 'num_lots' number of contracts.

void Send(
double price,
int numLots
);

Parameters

price
Order price.
numLots
Number of Lots. By default: 0

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.Send Overload List


IOrderPriced.Send(String, Double) Method

Generation of Price order with 'price' price.

void Send(
string new_name,
double price
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
price
Order price.

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.Send Overload List


IOrderPriced.Send(String, Double, Int32) Method

Generation of Price order with 'price' price and 'num_lots' number of contracts.

void Send(
string new_name,
double price,
int numLots
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
price
Order price.
numLots
Number of Lots. By default: 0

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.Send Overload List


SendFromEntry Method

PowerLanguage.NET Help

IOrderPriced.SendFromEntry Method

Generation of Price exit from entry order with 'price' price and 'num_lots' number of contracts.

Overload List

Generation of Price exit from entry order with 'price' price and 'num_lots' number of contracts.

void SendFromEntry(double,int,string)

Generation of Price exit from entry order with 'price' price.

void SendFromEntry(double,string)

Generation of Price exit from entry order with 'price' price and 'num_lots' number of contracts.

void SendFromEntry(string,double,int,string)

Generation of Price exit from entry order with 'price' price.

void SendFromEntry(string,double,string)

See Also

IOrderPriced Interface | PowerLanguage Namespace


IOrderPriced.SendFromEntry(Double, Int32, String) Method

Generation of Price exit from entry order with 'price' price and 'num_lots' number of contracts.

void SendFromEntry(
double price,
int numLots,
string fromName
);

Parameters

price
Order price.
numLots
Number of Lots. By default: 0
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.SendFromEntry Overload List


IOrderPriced.SendFromEntry(Double, String) Method

Generation of Price exit from entry order with 'price' price.

void SendFromEntry(
double price,
string fromName
);

Parameters

price
Order price.
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.SendFromEntry Overload List


IOrderPriced.SendFromEntry(String, Double, Int32, String) Method

Generation of Price exit from entry order with 'price' price and 'num_lots' number of contracts.

void SendFromEntry(
string new_name,
double price,
int numLots,
string fromName
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
price
Order price.
numLots
Number of Lots. By default: 0
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.SendFromEntry Overload List


IOrderPriced.SendFromEntry(String, Double, String) Method

Generation of Price exit from entry order with 'price' price.

void SendFromEntry(
string new_name,
double price,
string fromName
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
price
Order price.
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderPriced Interface | PowerLanguage Namespace | IOrderPriced.SendFromEntry Overload List


IOrderStopLimit Interface

An interface describing StopLimit Order.

For a list of all members of this type, see IOrderStopLimit Members .

public interface IOrderStopLimit : IOrderObject

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOrderStopLimit Members | PowerLanguage Namespace


IOrderStopLimit Members

IOrderStopLimit overview

Public Instance Methods

Send | Overloaded. Generation of StopLimit order with 'stop_price' and 'limit_price' prices.
SendFromEntry | Overloaded. Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices.

See Also

IOrderStopLimit Interface | PowerLanguage Namespace


IOrderStopLimit Methods

The methods of the IOrderStopLimit interface are listed below. For a complete list of IOrderStopLimit interface members, see the IOrderStopLimit Members topic.

Public Instance Methods

Send | Overloaded. Generation of StopLimit order with 'stop_price' and 'limit_price' prices.
SendFromEntry | Overloaded. Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices.

See Also

IOrderStopLimit Interface | PowerLanguage Namespace


Send Method

PowerLanguage.NET Help

IOrderStopLimit.Send Method

Generation of StopLimit order with 'stop_price' and 'limit_price' prices.

Overload List

Generation of StopLimit order with 'stop_price' and 'limit_price' prices.

void Send(double,double)

Generation of Price order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void Send(double,double,int)

Generation of StopLimit order with 'stop_price' and 'limit_price' prices.

void Send(string,double,double)

Generation of Price order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void Send(string,double,double,int)

See Also

IOrderStopLimit Interface | PowerLanguage Namespace


IOrderStopLimit.Send(Double, Double) Method

Generation of StopLimit order with 'stop_price' and 'limit_price' prices.

void Send(
double stopPrice,
double limitPrice
);

Parameters

stopPrice
Order stop condition price.
limitPrice
Order Limit price.

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.Send Overload List


IOrderStopLimit.Send(Double, Double, Int32) Method

Generation of Price order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void Send(
double stopPrice,
double limitPrice,
int numLots
);

Parameters

stopPrice
Order stop condition price.
limitPrice
Order Limit price.
numLots
Number of Lots. By default: 0

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.Send Overload List


IOrderStopLimit.Send(String, Double, Double) Method

Generation of StopLimit order with 'stop_price' and 'limit_price' prices.

void Send(
string new_name,
double stopPrice,
double limitPrice
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
stopPrice
Order stop condition price.
limitPrice
Order Limit price.

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.Send Overload List


IOrderStopLimit.Send(String, Double, Double, Int32) Method

Generation of Price order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void Send(
string new_name,
double stopPrice,
double limitPrice,
int numLots
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
stopPrice
Order stop condition price.
limitPrice
Order Limit price.
numLots
Number of Lots. By default: 0

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.Send Overload List


SendFromEntry Method

PowerLanguage.NET Help

IOrderStopLimit.SendFromEntry Method

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

Overload List

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void SendFromEntry(double,double,int,string)

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices.

void SendFromEntry(double,double,string)

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void SendFromEntry(string,double,double,int,string)

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices.

void SendFromEntry(string,double,double,string)

See Also

IOrderStopLimit Interface | PowerLanguage Namespace


IOrderStopLimit.SendFromEntry(Double, Double, Int32, String) Method

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void SendFromEntry(
double stopPrice,
double limitPrice,
int numLots,
string fromName
);

Parameters

stopPrice
Order stop condition price.
limitPrice
Order Limit price.
numLots
Number of Lots. By default: 0
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.SendFromEntry Overload List


IOrderStopLimit.SendFromEntry(Double, Double, String) Method

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices.

void SendFromEntry(
double stopPrice,
double limitPrice,
string fromName
);

Parameters

stopPrice
Order stop condition price.
limitPrice
Order Limit price.
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.SendFromEntry Overload List


IOrderStopLimit.SendFromEntry(String, Double, Double, Int32, String) Method

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices and 'num_lots' number of contracts.

void SendFromEntry(
string new_name,
double stopPrice,
double limitPrice,
int numLots,
string fromName
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
stopPrice
Order stop condition price.
limitPrice
Order Limit price.
numLots
Number of Lots. By default: 0
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.SendFromEntry Overload List


IOrderStopLimit.SendFromEntry(String, Double, Double, String) Method

Generation of StopLimit exit from entry order with 'stop_price' and 'limit_price' prices.

void SendFromEntry(
string new_name,
double stopPrice,
double limitPrice,
string fromName
);

Parameters

new_name
New order name. Will be used old name if new_name is null or empty
stopPrice
Order stop condition price.
limitPrice
Order Limit price.
fromName
Name of the entry order, of which needs to be closed

See Also

IOrderStopLimit Interface | PowerLanguage Namespace | IOrderStopLimit.SendFromEntry Overload List


IOutput Interface

An interface for accessing the Output Window.

For a list of all members of this type, see IOutput Members .

public interface IOutput

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IOutput Members | PowerLanguage Namespace


IOutput Members

IOutput overview

Public Instance Methods

Clear | A method for cleaning the Output Window.
Write | A method that outputs to Output Window the resulting string of '_args' arguments application to '_format' formatting string.
WriteLine | A method that outputs to Output Window the resulting string of the '_args' arguments application to the '_format' formatting string and then positions the cursor on a new line.

See Also

IOutput Interface | PowerLanguage Namespace


IOutput Methods

The methods of the IOutput interface are listed below. For a complete list of IOutput interface members, see the IOutput Members topic.

Public Instance Methods

Clear | A method for cleaning the Output Window.
Write | A method that outputs to Output Window the resulting string of '_args' arguments application to '_format' formatting string.
WriteLine | A method that outputs to Output Window the resulting string of the '_args' arguments application to the '_format' formatting string and then positions the cursor on a new line.

See Also

IOutput Interface | PowerLanguage Namespace


IOutput.Clear Method

A method for cleaning the Output Window.

void Clear();

See Also

IOutput Interface | PowerLanguage Namespace


IOutput.Write Method

A method that outputs to Output Window the resulting string of '_args' arguments application to '_format' formatting string.

void Write(
string format,
params object[] args
);

Parameters

format
Format string.
args
Arguments.

See Also

IOutput Interface | PowerLanguage Namespace


IOutput.WriteLine Method

A method that outputs to Output Window the resulting string of the '_args' arguments application to the '_format' formatting string and then positions the cursor on a new line.

void WriteLine(
string format,
params object[] args
);

Parameters

format
Format string.
args
Arguments.

See Also

IOutput Interface | PowerLanguage Namespace


IPlotAttributesArray<T> Interface

Interface to access the plot attributes array.

For a list of all members of this type, see IPlotAttributesArray<T> Members .

[DefaultMember(MemberName="Item")]
public interface IPlotAttributesArray<T> : ISeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IPlotAttributesArray<T> Members | PowerLanguage Namespace


IPlotAttributesArray<T> Members

IPlotAttributesArray<T> overview

Public Instance Properties

Item Read-write property. Returns a reference to the plot attributes located a specified number of bars back from the current.

See Also

IPlotAttributesArray<T> Interface | PowerLanguage Namespace


IPlotAttributesArray<T> Properties

The properties of the IPlotAttributesArray<T> interface are listed below. For a complete list of IPlotAttributesArray<T> interface members, see the IPlotAttributesArray<T> Members topic.

Public Instance Properties

Item Read-write property. Returns a reference to the plot attributes located a specified number of bars back from the current.

See Also

IPlotAttributesArray<T> Interface | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

IPlotAttributesArray`1.Item Property

Read-write property. Returns a reference to the plot attributes located a specified number of bars back from the current.

public T this[
int barsAgo
] { public get; public set; }

Parameters

barsAgo
The numerical expression specifying the number of bars back.

See Also

IPlotAttributesArray<T> Interface | PowerLanguage Namespace


IPlotObject Interface

An interface providing access to plot manipulations.

For a list of all members of this type, see IPlotObject Members .

public interface IPlotObject : IPlotObjectBase<double>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IPlotObject Members | PowerLanguage Namespace


IPlotObject Members

IPlotObject overview

Public Instance Properties

Colors | Read-only property. Provides an array for accessing Colors (plot color) of the bars previous to the current one. The array index is number of bars back (Bars ago).
Styles | Read-only property. Provides an array for accessing Styles (plot styles) of the bars previous to the current one. The array index is number of bars back (Bars ago)
Values | Read-only property. Provides an array for accessing Values (plot values) of the bars previous to the current one. The array index is number of bars back (Bars ago).
Widths | Read-only property. Provides an array for accessing Widths (plot width) of the bars previous to the current one. The array index is number of bars back (Bars ago)

Public Instance Methods

Reset | Do not draw plot on the specified bar (analog to EL’s NoPlot function). Bars back number.
Set | Overloaded. Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

See Also

IPlotObject Interface | PowerLanguage Namespace


IPlotObject Properties

The properties of the IPlotObject interface are listed below. For a complete list of IPlotObject interface members, see the IPlotObject Members topic.

Public Instance Properties

Colors | Read-only property. Provides an array for accessing Colors (plot color) of the bars previous to the current one. The array index is number of bars back (Bars ago).
Styles | Read-only property. Provides an array for accessing Styles (plot styles) of the bars previous to the current one. The array index is number of bars back (Bars ago)
Values | Read-only property. Provides an array for accessing Values (plot values) of the bars previous to the current one. The array index is number of bars back (Bars ago).
Widths | Read-only property. Provides an array for accessing Widths (plot width) of the bars previous to the current one. The array index is number of bars back (Bars ago)

See Also

IPlotObject Interface | PowerLanguage Namespace


Colors Property

PowerLanguage.NET Help

IPlotObject.Colors Property

Read-only property. Provides an array for accessing Colors (plot color) of the bars previous to the current one. The array index is number of bars back (Bars ago).

public IPlotAttributesArray<Color> Colors { public get; }

See Also

IPlotObject Interface | PowerLanguage Namespace


Styles Property

PowerLanguage.NET Help

IPlotObject.Styles Property

Read-only property. Provides an array for accessing Styles (plot styles) of the bars previous to the current one. The array index is number of bars back (Bars ago)

public IPlotAttributesArray<EPlotStyle> Styles { public get; }

See Also

IPlotObject Interface | PowerLanguage Namespace


Values Property

PowerLanguage.NET Help

IPlotObject.Values Property

Read-only property. Provides an array for accessing Values (plot values) of the bars previous to the current one. The array index is number of bars back (Bars ago).

public IPlotAttributesArray<double> Values { public get; }

See Also

IPlotObject Interface | PowerLanguage Namespace


Widths Property

PowerLanguage.NET Help

IPlotObject.Widths Property

Read-only property. Provides an array for accessing Widths (plot width) of the bars previous to the current one. The array index is number of bars back (Bars ago)

public IPlotAttributesArray<int> Widths { public get; }

See Also

IPlotObject Interface | PowerLanguage Namespace


IPlotObject Methods

The methods of the IPlotObject interface are listed below. For a complete list of IPlotObject interface members, see the IPlotObject Members topic.

Public Instance Methods

Reset | Do not draw plot on the specified bar (analog to EL’s NoPlot function). Bars back number.
Set | Overloaded. Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

See Also

IPlotObject Interface | PowerLanguage Namespace


IPlotObject.Reset Method

Do not draw plot on the specified bar (analog to EL’s NoPlot function). Bars back number.

void Reset(
int barsAgo
);

See Also

IPlotObject Interface | PowerLanguage Namespace


Set Method

PowerLanguage.NET Help

IPlotObject.Set Method

Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

Overload List

Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

void Set(double,Color,int)

Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

void Set(double,KnownColor,int)

Setting plot to a 'val' price on a bar ‘bars_ago’ bars back.

void Set(int,double)

Setting plot to a 'val' price with 'color' color on a bar 'bars_ago' bars back.

void Set(int,double,Color)

Setting plot to a 'val' price with 'color' color on a bar 'bars_ago' bars back and 'width' width on current bar.

void Set(int,double,Color,int)

Setting plot to a 'val' price and 'color' color on a bar ‘bars_ago’ bars back.

void Set(int,double,KnownColor)

Setting plot to a 'val' price with 'color' color on a bar 'bars_ago' bars back and 'width' width on current bar.

void Set(int,double,KnownColor,int)

See Also

IPlotObject Interface | PowerLanguage Namespace


IPlotObject.Set(Double, Color, Int32) Method

Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

void Set(
double val,
Color color,
int width
);

Parameters

val
Plot price value.
color
Plot color. By default: Color.Default
width
Plot width. By default: -1

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObject.Set(Double, KnownColor, Int32) Method

Setting plot to a 'val' price with 'color' color and 'width' width on current bar.

void Set(
double val,
KnownColor color,
int width
);

Parameters

val
Plot price value.
color
Plot color.
width
Plot width.

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObject.Set(Int32, Double) Method

Setting plot to a 'val' price on a bar ‘bars_ago’ bars back.

void Set(
int barsAgo,
double val
);

Parameters

barsAgo
Bars back number.
val
Plot price value.

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObject.Set(Int32, Double, Color) Method

Setting plot to a 'val' price with 'color' color on a bar 'bars_ago' bars back.

void Set(
int barsAgo,
double val,
Color color
);

Parameters

barsAgo
Bars back number.
val
Plot price value.
color
Plot color. By default: Color.Default

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObject.Set(Int32, Double, Color, Int32) Method

Setting plot to a 'val' price with 'color' color on a bar 'bars_ago' bars back and 'width' width on current bar.

void Set(
int barsAgo,
double val,
Color color,
int width
);

Parameters

barsAgo
Bars back number.
val
Plot price value.
color
Plot color. By default: Color.Default
width
Plot width. By default: -1

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObject.Set(Int32, Double, KnownColor) Method

Setting plot to a 'val' price and 'color' color on a bar ‘bars_ago’ bars back.

void Set(
int barsAgo,
double val,
KnownColor color
);

Parameters

barsAgo
Bars back number.
val
Plot price value.
color
Plot color.

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObject.Set(Int32, Double, KnownColor, Int32) Method

Setting plot to a 'val' price with 'color' color on a bar 'bars_ago' bars back and 'width' width on current bar.

void Set(
int barsAgo,
double val,
KnownColor color,
int width
);

Parameters

barsAgo
Bars back number.
val
Plot price value.
color
Plot color.
width
Plot width.

See Also

IPlotObject Interface | PowerLanguage Namespace | IPlotObject.Set Overload List


IPlotObjectBase<T> Interface

Common base interface for plot object.

For a list of all members of this type, see IPlotObjectBase<T> Members .

PowerLanguage.IPlotObjectBase<T>
PowerLanguage.IPlotObject
PowerLanguage.IPlotObjectStr

public interface IPlotObjectBase<T>

Generic template parameters

T

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IPlotObjectBase<T> Members | PowerLanguage Namespace


IPlotObjectBase<T> Members

IPlotObjectBase<T> overview

Public Instance Properties

BGColor | Read-write property. Sets/gets plot's background color.
Name | Read-only property. Return plot name.

Public Instance Methods

Reset | Do not draw plot on this bar (analog to EL’s NoPlot function).
Set | Overloaded. Setting plot to a 'val' value.

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


IPlotObjectBase<T> Properties

The properties of the IPlotObjectBase<T> interface are listed below. For a complete list of IPlotObjectBase<T> interface members, see the IPlotObjectBase<T> Members topic.

Public Instance Properties

BGColor | Read-write property. Sets/gets plot's background color.
Name | Read-only property. Return plot name.

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


BGColor Property

PowerLanguage.NET Help

IPlotObjectBase`1.BGColor Property

Read-write property. Sets/gets plot's background color.

public Color BGColor { public get; public set; }

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

IPlotObjectBase`1.Name Property

Read-only property. Return plot name.

public string Name { public get; }

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


IPlotObjectBase<T> Methods

The methods of the IPlotObjectBase<T> interface are listed below. For a complete list of IPlotObjectBase<T> interface members, see the IPlotObjectBase<T> Members topic.

Public Instance Methods

Reset | Do not draw plot on this bar (analog to EL’s NoPlot function).
Set | Overloaded. Setting plot to a 'val' value.

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


IPlotObjectBase<T>.Reset Method

Do not draw plot on this bar (analog to EL’s NoPlot function).

void IPlotObjectBase();

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


Set Method

PowerLanguage.NET Help

IPlotObjectBase`1.Set Method

Setting plot to a 'val' value.

Overload List

Setting plot to a 'val' value.

void Set(T)

Setting plot to a 'val' value with 'color' color.

void Set(T,Color)

Setting plot to a 'val' value with a known 'color' color.

void Set(T,KnownColor)

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace


IPlotObjectBase<T>.Set(T) Method

Setting plot to a 'val' value.

void IPlotObjectBase(
T val
);

Parameters

val
The place in which a plot will be set.

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace | IPlotObjectBase<T>.Set Overload List


IPlotObjectBase<T>.Set(T, Color) Method

Setting plot to a 'val' value with 'color' color.

void IPlotObjectBase(
T val,
Color color
);

Parameters

val
The place in which a plot will be set.
color
Plot color.

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace | IPlotObjectBase<T>.Set Overload List


IPlotObjectBase<T>.Set(T, KnownColor) Method

Setting plot to a 'val' value with a known 'color' color.

void IPlotObjectBase(
T val,
KnownColor color
);

Parameters

val
The place in which a plot will be set.
color
Plot color.

See Also

IPlotObjectBase<T> Interface | PowerLanguage Namespace | IPlotObjectBase<T>.Set Overload List


IPlotObjectStr Interface

An interface providing access to string plot manipulations.

public interface IPlotObjectStr : IPlotObjectBase<string>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


IPortfolioPerformance Interface

An interface providing access to portfolio performance.

For a list of all members of this type, see IPortfolioPerformance Members .

public interface IPortfolioPerformance

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IPortfolioPerformance Members | PowerLanguage Namespace


IPortfolioPerformance Members

IPortfolioPerformance overview

Public Instance Properties

CurrentEntries Read-only property. Returns a numerical value, indicating the combined number of entries currently open within a portfolio. Example:

Assign a value, indicating the combined number of entries currently open within a portfolio, to "var0" variable.

int var0 = Portfolio.CurrentEntries;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
GrossLoss Read-only property. Returns a negative numerical value indicating the total currency value of all completed losing trades for a portfolio. Example:

GrossLoss will return a value of -50 if there were a total of four losing trades, at 10, 5, 20, and 15.

GrossLoss will return a value of 0 if no losing trades were completed during the entire trading period.

double grossLoss = Portfolio.GrossLoss;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
GrossProfit Read-only property. Returns a numerical value, indicating the total currency value of all completed winning trades for a portfolio. Example:

GrossProfit will return a value of 50 if there were a total of four winning trades, at 10, 5, 20, and 15.

GrossProfit will return a value of 0 if no winning trades were completed during the entire trading period.

double grossProfit = Portfolio.GrossProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
InterestRate | Read-only property. Returns 'Interest Rate' from the Financial Settings tab of the Portfolio Settings dialog box.
InvestedCapital Read-only property. Returns an absolute value in US dollars, indicating the amount of cash assets invested in portfolio securities on the moment of strategy calculation. Example:

InvestedCapital will return a value of 100 000 if the amount of cash assets invested in portfolio securities on the moment of strategy calculation is 100 000 dollars (e.g. there are three open positions: 50 000 long, 20 000 long and 30 000 short).

double investedCapital = Portfolio.InvestedCapital;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
LossTradesNumber Read-only property. Returns a numerical value, indicating the number of all completed losing trades for a portfolio. Example:

LossTradesNumber will return a value of 5 if there were a total of five completed losing trades.

LossTradesNumber will return a value of 0 if no losing trades were completed during the entire trading period.

int lossTradesNumber = Portfolio.LossTradesNumber;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MarginPerContract | Read-only property. Returns: a numerical value indicated in the % of contract cost box multiplied by -1, if the Margin value option is selected;or:the same value as a reserved word Margin, if the Absolute Margin Value option is selected.Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxIDDrawdown Read-only property. Returns a negative numerical value, indicating the largest decline in equity for the entire portfolio during the trading period. Example:

MaxIDDrawdown will return a value of -500 if the largest decline in equity during the entire trading period was $500.

double maxIdDrawdown = Portfolio.MaxIDDrawdown;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxOpenPositionPotentialLoss Read-only property. Returns a dollar value indicating the combined potential loss (not including margin, commission or slippage) for the traded symbols' open position within the portfolio. Example:

MaxOpenPositionPotentialLoss will return a value of 0 if there are currently no open positions within a portfolio.

MaxOpenPositionPotentialLoss will return a value of 100 if the combined potential loss for all open positions within a portfolio is $100 since the positions were entered.

double maxPotentialLoss = Portfolio.MaxOpenPositionPotentialLoss;
if ( maxPotentialLoss != 0 ) {
    CurSpecOrdersMode = ESpecOrdersMode.PerPosition;
    GenerateStopLoss(maxPotentialLoss);
}
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxPotentialLossPerContract Read-only property. Returns: a numerical value indicated in the % box multiplied by -1, if the Max Potential Loss option is selected in the Format Settings dialog window under the Portfolio Settings tab;or:a numerical value indicated in the $ box, if the Absolute Max Potential Loss option is selected in the Format Settings dialog window under the Portfolio Settings tab.Example:

MaxPotentialLossPerContract will return -5 if the Max Potential Loss option is selected and % box value is 5 under the Portfolio Settings tab in the Format Settings dialog window.

MaxPotentialLossPerContract will return 0.001 if the Absolute Max Potential Loss option is selected and $ box value is 0.001 under the Portfolio Settings tab in the Format Settings dialog window.

double lossPerContract = Portfolio.MaxPotentialLossPerContract;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxRiskEquityPerPosPercent Read-only property. Returns the Max % of Equity at Risk per Position numerical value set by the user in the Portfolio Settings tab of the Portfolio Trader Format Settings window. Example:

MaxRiskEquityPerPosPercent will return the Max % of Equity at Risk per Position numerical value set by the user.

double maxRiskEquityPerPosPercent = Portfolio.MaxRiskEquityPerPosPercent;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MinAcceptableRate | Read-only property. Returns 'Minimum acceptable rate of return' from the Financial Settings tab of the Portfolio Settings dialog box.
NetProfit Read-only property. Returns a numerical value, indicating the total currency value of all completed trades for a portfolio. Example:

NetProfit will return a value of 20 if there were winning trades at 25 and 10, and losing trades at 5 and 10.

NetProfit will return a value of -15 if there were winning trades at 10 and 5, and losing trades at 20 and 10.

NetProfit will return a value of 0 no trades were completed during the entire trading period.

double netProfit = Portfolio.NetProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
OpenPositionProfit Read-only property. Returns a numerical value, indicating the current combined profit or loss for all open positions within a portfolio. Example:

OpenPositionProfit will return a value of 0 if there are currently no open positions within a portfolio.

OpenPositionProfit will return a value of 100 if the combined value of all open positions within a portfolio has increased by $100 since the positions were entered.

OpenPositionProfit will return a value of -50 if the combined value of all open positions within a portfolio has decreased by $50 since the positions were entered.

double openPositionPL = Portfolio.OpenPositionProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
PercentProfit Read-only property. Returns a numerical value, indicating the percentage of winning trades in all trades completed for a portfolio. Example:

PercentProfit will return a value of 70 if seven out of the total of 10 completed trades were winning trades.

double percentProfit = Portfolio.PercentProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
PortfolioEntriesPriority Write-only property. Assigns a priority to each entry order within a portfolio. If execution of all entries generated for a portfolio would cause the capital limits to be exceeded, the entries with the highest priority will receive preference, while the entries with the lowest priority will not be executed. If PortfolioEntriesPriority is not specified, the entries will be executed according to the order the symbols are listed in the symbol grid of the Portfolio Trader. Example:

Assign higher execution priority to entry orders for symbols with lower share prices.

Lambda<double> PriorityExpr = new Lambda<double>(delegate { return -Bars.CloseValue; });

Portfolio.PortfolioEntriesPriority = PriorityExpr;

Notes:This property can only be used in signals that will be used in the Portfolio Trader.
ProfitTradesNumber Read-only property. Returns a numerical value, indicating the number of all completed winning trades for a portfolio. Example:

ProfitTradesNumber will return a value of 5 if there were a total of five completed winning trades.

ProfitTradesNumber will return a value of 0 if no winning trades were completed during the entire trading period.

int profitTradesNumber = Portfolio.ProfitTradesNumber;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
StrategyDrawdown Read-only property. Returns a negative numerical value, indicating the current decline in equity for the entire portfolio from the peak value for the entire trading period. Example:

StrategyDrawdown will return a value of -100 if the current decline in equity from the peak value is $100.

double drawdown = Portfolio.StrategyDrawdown;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
TotalMaxRiskEquityPercent | Read-only property. Returns the equity Exposure % numerical value set by the user in the Portfolio Settings tab of the Portfolio Trader Format Settings window.
TotalTrades Read-only property. Returns a numerical value, indicating the total number of all completed trades for a portfolio. Example:

TotalTrades will return a value of 5 if there were a total of 5 completed trades.

TotalTrades will return a value of 0 if no trades were completed during the entire trading period.

int tradesNum = Portfolio.TotalTrades;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.

Public Instance Methods

CalcMaxPotentialLossForEntry | Overloaded. Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell), number of Contracts and Price. Notes:This property can only be used in signals that will be used in the Portfolio Trader.
SetMaxPotentialLossPerContract | Provides method to redefine the values for the indicated symbol. The values in the $ box, if the Absolute Max Potential Loss option is selected, or the values in the % box, if the Max Potential Loss is selected. The newly set value is valid during the strategy calculation or until the SetMaxPotentialLossPerContract is requested again assigning a new value.

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


IPortfolioPerformance Properties

The properties of the IPortfolioPerformance interface are listed below. For a complete list of IPortfolioPerformance interface members, see the IPortfolioPerformance Members topic.

Public Instance Properties

CurrentEntries Read-only property. Returns a numerical value, indicating the combined number of entries currently open within a portfolio. Example:

Assign a value, indicating the combined number of entries currently open within a portfolio, to "var0" variable.

int var0 = Portfolio.CurrentEntries;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
GrossLoss Read-only property. Returns a negative numerical value indicating the total currency value of all completed losing trades for a portfolio. Example:

GrossLoss will return a value of -50 if there were a total of four losing trades, at 10, 5, 20, and 15.

GrossLoss will return a value of 0 if no losing trades were completed during the entire trading period.

double grossLoss = Portfolio.GrossLoss;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
GrossProfit Read-only property. Returns a numerical value, indicating the total currency value of all completed winning trades for a portfolio. Example:

GrossProfit will return a value of 50 if there were a total of four winning trades, at 10, 5, 20, and 15.

GrossProfit will return a value of 0 if no winning trades were completed during the entire trading period.

double grossProfit = Portfolio.GrossProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
InterestRate | Read-only property. Returns 'Interest Rate' from the Financial Settings tab of the Portfolio Settings dialog box.
InvestedCapital Read-only property. Returns an absolute value in US dollars, indicating the amount of cash assets invested in portfolio securities on the moment of strategy calculation. Example:

InvestedCapital will return a value of 100 000 if the amount of cash assets invested in portfolio securities on the moment of strategy calculation is 100 000 dollars (e.g. there are three open positions: 50 000 long, 20 000 long and 30 000 short).

double investedCapital = Portfolio.InvestedCapital;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
LossTradesNumber Read-only property. Returns a numerical value, indicating the number of all completed losing trades for a portfolio. Example:

LossTradesNumber will return a value of 5 if there were a total of five completed losing trades.

LossTradesNumber will return a value of 0 if no losing trades were completed during the entire trading period.

int lossTradesNumber = Portfolio.LossTradesNumber;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MarginPerContract | Read-only property. Returns: a numerical value indicated in the % of contract cost box multiplied by -1, if the Margin value option is selected;or:the same value as a reserved word Margin, if the Absolute Margin Value option is selected.Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxIDDrawdown Read-only property. Returns a negative numerical value, indicating the largest decline in equity for the entire portfolio during the trading period. Example:

MaxIDDrawdown will return a value of -500 if the largest decline in equity during the entire trading period was $500.

double maxIdDrawdown = Portfolio.MaxIDDrawdown;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxOpenPositionPotentialLoss Read-only property. Returns a dollar value indicating the combined potential loss (not including margin, commission or slippage) for the traded symbols' open position within the portfolio. Example:

MaxOpenPositionPotentialLoss will return a value of 0 if there are currently no open positions within a portfolio.

MaxOpenPositionPotentialLoss will return a value of 100 if the combined potential loss for all open positions within a portfolio is $100 since the positions were entered.

double maxPotentialLoss = Portfolio.MaxOpenPositionPotentialLoss;
if ( maxPotentialLoss != 0 ) {
    CurSpecOrdersMode = ESpecOrdersMode.PerPosition;
    GenerateStopLoss(maxPotentialLoss);
}
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxPotentialLossPerContract Read-only property. Returns: a numerical value indicated in the % box multiplied by -1, if the Max Potential Loss option is selected in the Format Settings dialog window under the Portfolio Settings tab;or:a numerical value indicated in the $ box, if the Absolute Max Potential Loss option is selected in the Format Settings dialog window under the Portfolio Settings tab.Example:

MaxPotentialLossPerContract will return -5 if the Max Potential Loss option is selected and % box value is 5 under the Portfolio Settings tab in the Format Settings dialog window.

MaxPotentialLossPerContract will return 0.001 if the Absolute Max Potential Loss option is selected and $ box value is 0.001 under the Portfolio Settings tab in the Format Settings dialog window.

double lossPerContract = Portfolio.MaxPotentialLossPerContract;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MaxRiskEquityPerPosPercent Read-only property. Returns the Max % of Equity at Risk per Position numerical value set by the user in the Portfolio Settings tab of the Portfolio Trader Format Settings window. Example:

MaxRiskEquityPerPosPercent will return the Max % of Equity at Risk per Position numerical value set by the user.

double maxRiskEquityPerPosPercent = Portfolio.MaxRiskEquityPerPosPercent;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
MinAcceptableRate | Read-only property. Returns 'Minimum acceptable rate of return' from the Financial Settings tab of the Portfolio Settings dialog box.
NetProfit Read-only property. Returns a numerical value, indicating the total currency value of all completed trades for a portfolio. Example:

NetProfit will return a value of 20 if there were winning trades at 25 and 10, and losing trades at 5 and 10.

NetProfit will return a value of -15 if there were winning trades at 10 and 5, and losing trades at 20 and 10.

NetProfit will return a value of 0 no trades were completed during the entire trading period.

double netProfit = Portfolio.NetProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
OpenPositionProfit Read-only property. Returns a numerical value, indicating the current combined profit or loss for all open positions within a portfolio. Example:

OpenPositionProfit will return a value of 0 if there are currently no open positions within a portfolio.

OpenPositionProfit will return a value of 100 if the combined value of all open positions within a portfolio has increased by $100 since the positions were entered.

OpenPositionProfit will return a value of -50 if the combined value of all open positions within a portfolio has decreased by $50 since the positions were entered.

double openPositionPL = Portfolio.OpenPositionProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
PercentProfit Read-only property. Returns a numerical value, indicating the percentage of winning trades in all trades completed for a portfolio. Example:

PercentProfit will return a value of 70 if seven out of the total of 10 completed trades were winning trades.

double percentProfit = Portfolio.PercentProfit;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
PortfolioEntriesPriority Write-only property. Assigns a priority to each entry order within a portfolio. If execution of all entries generated for a portfolio would cause the capital limits to be exceeded, the entries with the highest priority will receive preference, while the entries with the lowest priority will not be executed. If PortfolioEntriesPriority is not specified, the entries will be executed according to the order the symbols are listed in the symbol grid of the Portfolio Trader. Example:

Assign higher execution priority to entry orders for symbols with lower share prices.

Lambda<double> PriorityExpr = new Lambda<double>(delegate { return -Bars.CloseValue; });

Portfolio.PortfolioEntriesPriority = PriorityExpr;

Notes:This property can only be used in signals that will be used in the Portfolio Trader.
ProfitTradesNumber Read-only property. Returns a numerical value, indicating the number of all completed winning trades for a portfolio. Example:

ProfitTradesNumber will return a value of 5 if there were a total of five completed winning trades.

ProfitTradesNumber will return a value of 0 if no winning trades were completed during the entire trading period.

int profitTradesNumber = Portfolio.ProfitTradesNumber;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
StrategyDrawdown Read-only property. Returns a negative numerical value, indicating the current decline in equity for the entire portfolio from the peak value for the entire trading period. Example:

StrategyDrawdown will return a value of -100 if the current decline in equity from the peak value is $100.

double drawdown = Portfolio.StrategyDrawdown;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.
TotalMaxRiskEquityPercent | Read-only property. Returns the equity Exposure % numerical value set by the user in the Portfolio Settings tab of the Portfolio Trader Format Settings window.
TotalTrades Read-only property. Returns a numerical value, indicating the total number of all completed trades for a portfolio. Example:

TotalTrades will return a value of 5 if there were a total of 5 completed trades.

TotalTrades will return a value of 0 if no trades were completed during the entire trading period.

int tradesNum = Portfolio.TotalTrades;
Notes:This property can only be used in signals that will be used in the Portfolio Trader.

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


CurrentEntries Property

PowerLanguage.NET Help

IPortfolioPerformance.CurrentEntries Property

Read-only property. Returns a numerical value, indicating the combined number of entries currently open within a portfolio.

Example:

Assign a value, indicating the combined number of entries currently open within a portfolio, to "var0" variable.

int var0 = Portfolio.CurrentEntries;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public int CurrentEntries { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


GrossLoss Property

PowerLanguage.NET Help

IPortfolioPerformance.GrossLoss Property

Read-only property. Returns a negative numerical value indicating the total currency value of all completed losing trades for a portfolio.

Example:

GrossLoss will return a value of -50 if there were a total of four losing trades, at 10, 5, 20, and 15.

GrossLoss will return a value of 0 if no losing trades were completed during the entire trading period.

double grossLoss = Portfolio.GrossLoss;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double GrossLoss { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


GrossProfit Property

PowerLanguage.NET Help

IPortfolioPerformance.GrossProfit Property

Read-only property. Returns a numerical value, indicating the total currency value of all completed winning trades for a portfolio.

Example:

GrossProfit will return a value of 50 if there were a total of four winning trades, at 10, 5, 20, and 15.

GrossProfit will return a value of 0 if no winning trades were completed during the entire trading period.

double grossProfit = Portfolio.GrossProfit;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double GrossProfit { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


InterestRate Property

PowerLanguage.NET Help

IPortfolioPerformance.InterestRate Property

Read-only property. Returns 'Interest Rate' from the Financial Settings tab of the Portfolio Settings dialog box.

public double InterestRate { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


InvestedCapital Property

PowerLanguage.NET Help

IPortfolioPerformance.InvestedCapital Property

Read-only property. Returns an absolute value in US dollars, indicating the amount of cash assets invested in portfolio securities on the moment of strategy calculation.

Example:

InvestedCapital will return a value of 100 000 if the amount of cash assets invested in portfolio securities on the moment of strategy calculation is 100 000 dollars (e.g. there are three open positions: 50 000 long, 20 000 long and 30 000 short).

double investedCapital = Portfolio.InvestedCapital;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double InvestedCapital { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


LossTradesNumber Property

PowerLanguage.NET Help

IPortfolioPerformance.LossTradesNumber Property

Read-only property. Returns a numerical value, indicating the number of all completed losing trades for a portfolio.

Example:

LossTradesNumber will return a value of 5 if there were a total of five completed losing trades.

LossTradesNumber will return a value of 0 if no losing trades were completed during the entire trading period.

int lossTradesNumber = Portfolio.LossTradesNumber;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public int LossTradesNumber { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


MarginPerContract Property

PowerLanguage.NET Help

IPortfolioPerformance.MarginPerContract Property

Read-only property. Returns:

a numerical value indicated in the % of contract cost box multiplied by -1, if the Margin value option is selected;

or:

the same value as a reserved word Margin, if the Absolute Margin Value option is selected.

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double MarginPerContract { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


MaxIDDrawdown Property

PowerLanguage.NET Help

IPortfolioPerformance.MaxIDDrawdown Property

Read-only property. Returns a negative numerical value, indicating the largest decline in equity for the entire portfolio during the trading period.

Example:

MaxIDDrawdown will return a value of -500 if the largest decline in equity during the entire trading period was $500.

double maxIdDrawdown = Portfolio.MaxIDDrawdown;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double MaxIDDrawdown { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


MaxOpenPositionPotentialLoss Property

PowerLanguage.NET Help

IPortfolioPerformance.MaxOpenPositionPotentialLoss Property

Read-only property. Returns a dollar value indicating the combined potential loss (not including margin, commission or slippage) for the traded symbols' open position within the portfolio.

Example:

MaxOpenPositionPotentialLoss will return a value of 0 if there are currently no open positions within a portfolio.

MaxOpenPositionPotentialLoss will return a value of 100 if the combined potential loss for all open positions within a portfolio is $100 since the positions were entered.

double maxPotentialLoss = Portfolio.MaxOpenPositionPotentialLoss;
if ( maxPotentialLoss != 0 ) {
    CurSpecOrdersMode = ESpecOrdersMode.PerPosition;
    GenerateStopLoss(maxPotentialLoss);
}

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double MaxOpenPositionPotentialLoss { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


MaxPotentialLossPerContract Property

PowerLanguage.NET Help

IPortfolioPerformance.MaxPotentialLossPerContract Property

Read-only property. Returns:

a numerical value indicated in the % box multiplied by -1, if the Max Potential Loss option is selected in the Format Settings dialog window under the Portfolio Settings tab;

or:

a numerical value indicated in the $ box, if the Absolute Max Potential Loss option is selected in the Format Settings dialog window under the Portfolio Settings tab.

Example:

MaxPotentialLossPerContract will return -5 if the Max Potential Loss option is selected and % box value is 5 under the Portfolio Settings tab in the Format Settings dialog window.

MaxPotentialLossPerContract will return 0.001 if the Absolute Max Potential Loss option is selected and $ box value is 0.001 under the Portfolio Settings tab in the Format Settings dialog window.

double lossPerContract = Portfolio.MaxPotentialLossPerContract;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double MaxPotentialLossPerContract { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


MaxRiskEquityPerPosPercent Property

PowerLanguage.NET Help

IPortfolioPerformance.MaxRiskEquityPerPosPercent Property

Read-only property. Returns the Max % of Equity at Risk per Position numerical value set by the user in the Portfolio Settings tab of the Portfolio Trader Format Settings window.

Example:

MaxRiskEquityPerPosPercent will return the Max % of Equity at Risk per Position numerical value set by the user.

double maxRiskEquityPerPosPercent = Portfolio.MaxRiskEquityPerPosPercent;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double MaxRiskEquityPerPosPercent { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


MinAcceptableRate Property

PowerLanguage.NET Help

IPortfolioPerformance.MinAcceptableRate Property

Read-only property. Returns 'Minimum acceptable rate of return' from the Financial Settings tab of the Portfolio Settings dialog box.

public double MinAcceptableRate { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


NetProfit Property

PowerLanguage.NET Help

IPortfolioPerformance.NetProfit Property

Read-only property. Returns a numerical value, indicating the total currency value of all completed trades for a portfolio.

Example:

NetProfit will return a value of 20 if there were winning trades at 25 and 10, and losing trades at 5 and 10.

NetProfit will return a value of -15 if there were winning trades at 10 and 5, and losing trades at 20 and 10.

NetProfit will return a value of 0 no trades were completed during the entire trading period.

double netProfit = Portfolio.NetProfit;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double NetProfit { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


OpenPositionProfit Property

PowerLanguage.NET Help

IPortfolioPerformance.OpenPositionProfit Property

Read-only property. Returns a numerical value, indicating the current combined profit or loss for all open positions within a portfolio.

Example:

OpenPositionProfit will return a value of 0 if there are currently no open positions within a portfolio.

OpenPositionProfit will return a value of 100 if the combined value of all open positions within a portfolio has increased by $100 since the positions were entered.

OpenPositionProfit will return a value of -50 if the combined value of all open positions within a portfolio has decreased by $50 since the positions were entered.

double openPositionPL = Portfolio.OpenPositionProfit;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double OpenPositionProfit { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


PercentProfit Property

PowerLanguage.NET Help

IPortfolioPerformance.PercentProfit Property

Read-only property. Returns a numerical value, indicating the percentage of winning trades in all trades completed for a portfolio.

Example:

PercentProfit will return a value of 70 if seven out of the total of 10 completed trades were winning trades.

double percentProfit = Portfolio.PercentProfit;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double PercentProfit { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


PortfolioEntriesPriority Property

PowerLanguage.NET Help

IPortfolioPerformance.PortfolioEntriesPriority Property

Write-only property. Assigns a priority to each entry order within a portfolio. If execution of all entries generated for a portfolio would cause the capital limits to be exceeded, the entries with the highest priority will receive preference, while the entries with the lowest priority will not be executed. If PortfolioEntriesPriority is not specified, the entries will be executed according to the order the symbols are listed in the symbol grid of the Portfolio Trader.

Example:

Assign higher execution priority to entry orders for symbols with lower share prices.

Lambda<double> PriorityExpr = new Lambda<double>(delegate { return -Bars.CloseValue; });

Portfolio.PortfolioEntriesPriority = PriorityExpr;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public Lambda<double> PortfolioEntriesPriority { public set; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


ProfitTradesNumber Property

PowerLanguage.NET Help

IPortfolioPerformance.ProfitTradesNumber Property

Read-only property. Returns a numerical value, indicating the number of all completed winning trades for a portfolio.

Example:

ProfitTradesNumber will return a value of 5 if there were a total of five completed winning trades.

ProfitTradesNumber will return a value of 0 if no winning trades were completed during the entire trading period.

int profitTradesNumber = Portfolio.ProfitTradesNumber;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public int ProfitTradesNumber { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


StrategyDrawdown Property

PowerLanguage.NET Help

IPortfolioPerformance.StrategyDrawdown Property

Read-only property. Returns a negative numerical value, indicating the current decline in equity for the entire portfolio from the peak value for the entire trading period.

Example:

StrategyDrawdown will return a value of -100 if the current decline in equity from the peak value is $100.

double drawdown = Portfolio.StrategyDrawdown;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public double StrategyDrawdown { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


TotalMaxRiskEquityPercent Property

PowerLanguage.NET Help

IPortfolioPerformance.TotalMaxRiskEquityPercent Property

Read-only property. Returns the equity Exposure % numerical value set by the user in the Portfolio Settings tab of the Portfolio Trader Format Settings window.

public double TotalMaxRiskEquityPercent { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


TotalTrades Property

PowerLanguage.NET Help

IPortfolioPerformance.TotalTrades Property

Read-only property. Returns a numerical value, indicating the total number of all completed trades for a portfolio.

Example:

TotalTrades will return a value of 5 if there were a total of 5 completed trades.

TotalTrades will return a value of 0 if no trades were completed during the entire trading period.

int tradesNum = Portfolio.TotalTrades;

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

public int TotalTrades { public get; }

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


IPortfolioPerformance Methods

The methods of the IPortfolioPerformance interface are listed below. For a complete list of IPortfolioPerformance interface members, see the IPortfolioPerformance Members topic.

Public Instance Methods

CalcMaxPotentialLossForEntry | Overloaded. Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell), number of Contracts and Price. Notes:This property can only be used in signals that will be used in the Portfolio Trader.
SetMaxPotentialLossPerContract | Provides method to redefine the values for the indicated symbol. The values in the $ box, if the Absolute Max Potential Loss option is selected, or the values in the % box, if the Max Potential Loss is selected. The newly set value is valid during the strategy calculation or until the SetMaxPotentialLossPerContract is requested again assigning a new value.

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


CalcMaxPotentialLossForEntry Method

PowerLanguage.NET Help

IPortfolioPerformance.CalcMaxPotentialLossForEntry Method

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell) for a number of contracts indicated in the Format Settings dialog window under the Properties tab at Close price.

Overload List

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell) for a number of contracts indicated in the Format Settings dialog window under the Properties tab at Close price.

double CalcMaxPotentialLossForEntry(int)

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell) and number of Contracts at the Close price.

double CalcMaxPotentialLossForEntry(int,int)

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell), number of Contracts and Price. Notes:This property can only be used in signals that will be used in the Portfolio Trader.

double CalcMaxPotentialLossForEntry(int,int,double)

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


IPortfolioPerformance.CalcMaxPotentialLossForEntry(Int32) Method

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell) for a number of contracts indicated in the Format Settings dialog window under the Properties tab at Close price.

double CalcMaxPotentialLossForEntry(
int side
);

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace | IPortfolioPerformance.CalcMaxPotentialLossForEntry Overload List


IPortfolioPerformance.CalcMaxPotentialLossForEntry(Int32, Int32) Method

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell) and number of Contracts at the Close price.

double CalcMaxPotentialLossForEntry(
int side,
int contracts
);

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace | IPortfolioPerformance.CalcMaxPotentialLossForEntry Overload List


IPortfolioPerformance.CalcMaxPotentialLossForEntry(Int32, Int32, Double) Method

Provides method to calculate maximum potential loss (not including margin, commission or slippage) if user entered the position with the specified Side(buy, sell), number of Contracts and Price.

Notes:

This property can only be used in signals that will be used in the Portfolio Trader.

double CalcMaxPotentialLossForEntry(
int side,
int contracts,
double price
);

Parameters

side
Specifies the entry type (e.g. 1 Long entry or -1 Short entry).
contracts
Specifies the number of contracts.
price
Specifies the price value. This parameter may be rounded down if entered a Short position or rounded up if entered a Long position.

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace | IPortfolioPerformance.CalcMaxPotentialLossForEntry Overload List


IPortfolioPerformance.SetMaxPotentialLossPerContract Method

Provides method to redefine the values for the indicated symbol. The values in the $ box, if the Absolute Max Potential Loss option is selected, or the values in the % box, if the Max Potential Loss is selected. The newly set value is valid during the strategy calculation or until the SetMaxPotentialLossPerContract is requested again assigning a new value.

bool SetMaxPotentialLossPerContract(
double newValue
);

See Also

IPortfolioPerformance Interface | PowerLanguage Namespace


IRectangleContainer Interface

Container for IRectangleObject collection.

For a list of all members of this type, see IRectangleContainer Members .

public interface IRectangleContainer

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IRectangleContainer Members | PowerLanguage Namespace


IRectangleContainer Members

IRectangleContainer overview

Public Instance Properties

Active Read-only property. Active rectangle object interface, if any; nullptr otherwise.

Public Instance Methods

Create | Overloaded. Creates a Rectangle with '_start','_end' coordinates and '_data_stream' number data stream.
GetRectangleObjects | A method for accessing collection’s elements using foreach.

See Also

IRectangleContainer Interface | PowerLanguage Namespace


IRectangleContainer Properties

The properties of the IRectangleContainer interface are listed below. For a complete list of IRectangleContainer interface members, see the IRectangleContainer Members topic.

Public Instance Properties

Active Read-only property. Active rectangle object interface, if any; nullptr otherwise.

See Also

IRectangleContainer Interface | PowerLanguage Namespace


Active Property

PowerLanguage.NET Help

IRectangleContainer.Active Property

Read-only property. Active rectangle object interface, if any; nullptr otherwise.

public IRectangleObject Active { public get; }

See Also

IRectangleContainer Interface | PowerLanguage Namespace


IRectangleContainer Methods

The methods of the IRectangleContainer interface are listed below. For a complete list of IRectangleContainer interface members, see the IRectangleContainer Members topic.

Public Instance Methods

Create | Overloaded. Creates a Rectangle with '_start','_end' coordinates and '_data_stream' number data stream.
GetRectangleObjects | A method for accessing collection’s elements using foreach.

See Also

IRectangleContainer Interface | PowerLanguage Namespace


Create Method

PowerLanguage.NET Help

IRectangleContainer.Create Method

Creates a Rectangle with '_start','_end' coordinates.

Overload List

Creates a Rectangle with '_start','_end' coordinates.

IRectangleObject Create(ChartPoint,ChartPoint)

Creates a Rectangle with '_start','_end' coordinates and '_on_same_subchart' flag.

IRectangleObject Create(ChartPoint,ChartPoint,bool)

Creates a Rectangle with '_start','_end' coordinates and '_data_stream' number data stream.

IRectangleObject Create(ChartPoint,ChartPoint,int)

See Also

IRectangleContainer Interface | PowerLanguage Namespace


IRectangleContainer.Create(ChartPoint, ChartPoint) Method

Creates a Rectangle with '_start','_end' coordinates.

IRectangleObject Create(
ChartPoint start,
ChartPoint end
);

Parameters

start
Rectangle's diagonal start point.
end
Rectangle's diagonal end point.

Return Value

An instance of the interface describing Rectangle object.

See Also

IRectangleContainer Interface | PowerLanguage Namespace | IRectangleContainer.Create Overload List


IRectangleContainer.Create(ChartPoint, ChartPoint, Boolean) Method

Creates a Rectangle with '_start','_end' coordinates and '_on_same_subchart' flag.

IRectangleObject Create(
ChartPoint start,
ChartPoint end,
bool onSameSubchart
);

Parameters

start
Rectangle's diagonal start point.
end
Rectangle's diagonal end point.
onSameSubchart
By default: false

Return Value

An instance of the interface describing Rectangle object.

See Also

IRectangleContainer Interface | PowerLanguage Namespace | IRectangleContainer.Create Overload List


IRectangleContainer.Create(ChartPoint, ChartPoint, Int32) Method

Creates a Rectangle with '_start','_end' coordinates and '_data_stream' number data stream.

IRectangleObject Create(
ChartPoint start,
ChartPoint end,
int dataStream
);

Parameters

start
Rectangle's diagonal start point.
end
Rectangle's diagonal end point.
dataStream
Data stream number. By default: 0

Return Value

An instance of the interface describing Rectangle object.

See Also

IRectangleContainer Interface | PowerLanguage Namespace | IRectangleContainer.Create Overload List


IRectangleContainer.GetRectangleObjects Method

A method for accessing collection’s elements using foreach.

IEnumerable<IRectangleObject> GetRectangleObjects(
EDrawingSource drawingSource
);

Parameters

drawingSource
By default: AnyTechOrManual

Return Value

See Also

IRectangleContainer Interface | PowerLanguage Namespace


IRectangleObject Interface

Rectangle drawing access interface.

For a list of all members of this type, see IRectangleObject Members .

public interface IRectangleObject : IDrawObject, IEquatable<IDrawObject>, IEquatable<IRectangleObject>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IRectangleObject Members | PowerLanguage Namespace


IRectangleObject Members

IRectangleObject overview

Public Instance Properties

Begin | Get/set property for '_start' coordinate of rectangle.
BorderStyle | Get/set property for rectangle border style. ToolSolid = 1, ToolDashed = 2, ToolDotted = 3, ToolDashed2 = 4, ToolDashed3 = 5.
Color | Get/set property for rectangle color.
End | Get/set property for '_end' coordinate of rectangle.
FillColor | Get/set property for the rectangle's fill color.
Pattern | Get/set property for rectangle pattern.
Size | Get/set property for rectangle width.

See Also

IRectangleObject Interface | PowerLanguage Namespace


IRectangleObject Properties

The properties of the IRectangleObject interface are listed below. For a complete list of IRectangleObject interface members, see the IRectangleObject Members topic.

Public Instance Properties

Begin | Get/set property for '_start' coordinate of rectangle.
BorderStyle | Get/set property for rectangle border style. ToolSolid = 1, ToolDashed = 2, ToolDotted = 3, ToolDashed2 = 4, ToolDashed3 = 5.
Color | Get/set property for rectangle color.
End | Get/set property for '_end' coordinate of rectangle.
FillColor | Get/set property for the rectangle's fill color.
Pattern | Get/set property for rectangle pattern.
Size | Get/set property for rectangle width.

See Also

IRectangleObject Interface | PowerLanguage Namespace


Begin Property

PowerLanguage.NET Help

IRectangleObject.Begin Property

Get/set property for '_start' coordinate of rectangle.

public ChartPoint Begin { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


BorderStyle Property

PowerLanguage.NET Help

IRectangleObject.BorderStyle Property

Get/set property for rectangle border style. ToolSolid = 1, ToolDashed = 2, ToolDotted = 3, ToolDashed2 = 4, ToolDashed3 = 5.

public ETLStyle BorderStyle { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


Color Property

PowerLanguage.NET Help

IRectangleObject.Color Property

Get/set property for rectangle color.

public Color Color { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


End Property

PowerLanguage.NET Help

IRectangleObject.End Property

Get/set property for '_end' coordinate of rectangle.

public ChartPoint End { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


FillColor Property

PowerLanguage.NET Help

IRectangleObject.FillColor Property

Get/set property for the rectangle's fill color.

public Color FillColor { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


Pattern Property

PowerLanguage.NET Help

IRectangleObject.Pattern Property

Get/set property for rectangle pattern.

public ERectPattern Pattern { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


Size Property

PowerLanguage.NET Help

IRectangleObject.Size Property

Get/set property for rectangle width.

public int Size { public get; public set; }

See Also

IRectangleObject Interface | PowerLanguage Namespace


IROList<T> Interface

Base interface for the read-only list.

For a list of all members of this type, see IROList<T> Members .

PowerLanguage.IROList<T>
PowerLanguage.IROListObjectEx`1

[DefaultMember(MemberName="Item")]
public interface IROList<T> : IEnumerable<T>, IEnumerable

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IROList<T> Members | PowerLanguage Namespace


IROList<T> Members

IROList<T> overview

Public Instance Properties

Count | Read-only property. Returns the count of read-only list.
Item | Returns the read-only list item at specified index.

See Also

IROList<T> Interface | PowerLanguage Namespace


IROList<T> Properties

The properties of the IROList<T> interface are listed below. For a complete list of IROList<T> interface members, see the IROList<T> Members topic.

Public Instance Properties

Count | Read-only property. Returns the count of read-only list.
Item | Returns the read-only list item at specified index.

See Also

IROList<T> Interface | PowerLanguage Namespace


Count Property

PowerLanguage.NET Help

IROList`1.Count Property

Read-only property. Returns the count of read-only list.

public int Count { public get; }

See Also

IROList<T> Interface | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

IROList`1.Item Property

Returns the read-only list item at specified index.

public T this[
int idx
] { public get; }

Parameters

idx
Item index.

See Also

IROList<T> Interface | PowerLanguage Namespace


IROListObjectEx<T> Interface

An interface describing enumerable read-only list.

For a list of all members of this type, see IROListObjectEx<T> Members .

public interface IROListObjectEx<T> : IROList<T>, IEnumerable<T>, IEnumerable

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IROListObjectEx<T> Members | PowerLanguage Namespace


IROListObjectEx<T> Members

IROListObjectEx<T> overview

Public Instance Properties

Items Read-only property. Returns list of items.

See Also

IROListObjectEx<T> Interface | PowerLanguage Namespace


IROListObjectEx<T> Properties

The properties of the IROListObjectEx<T> interface are listed below. For a complete list of IROListObjectEx<T> interface members, see the IROListObjectEx<T> Members topic.

Public Instance Properties

Items Read-only property. Returns list of items.

See Also

IROListObjectEx<T> Interface | PowerLanguage Namespace


Items Property

PowerLanguage.NET Help

IROListObjectEx`1.Items Property

Read-only property. Returns list of items.

public List<T> Items { public get; }

See Also

IROListObjectEx<T> Interface | PowerLanguage Namespace


ISeries<T> Interface

Base interface for functions, series variables, and price series. Provides access to historical values of inherited objects.

For a list of all members of this type, see ISeries<T> Members .

PowerLanguage.ISeries<T>
PowerLanguage.IFunctionObject`1
PowerLanguage.IPlotAttributesArray`1
PowerLanguage.IVar`1

[DefaultMember(MemberName="Item")]
public interface ISeries<T>

Types that implement ISeries<T>

Type | Description
ConstantObject<T> | ISeries implementation that emulates behavior of the simple property with a constant value.
CustomInstrumentBase.SeriesImpl<T> |
AccumSwingIndex |
AccumulationDistribution |
AdaptiveMovAvg |
AdvanceDeclineDiff |
ADX |
ADXCustom |
ADXR |
ADXRCustom |
AverageFC |
BarNumber |
C_3WhSolds_3BlkCrows |
C_BullEng_BearEng |
C_BullHar_BearHar |
C_Hammer_HangingMan |
C_MornDoji_EveDoji |
C_MornStar_EveStar |
C_PierceLine_DkCloud |
C_ShootingStar |
ChaikinOsc |
CloseD |
CloseS |
CSI |
Cum |
DirMovement |
draw_DOM_level |
ExtremesFC |
FastK |
FastKCustom |
FunctionSeries<T> | A series function’s base class. Feature of a series function is that its body is always calculated in the current context of execution (at the currently calculating bar), and the function always keeps its previous values.
FunctionSimple<T> | Simple function’s base class. Its peculiarity is that it doesn’t keep the history of its values, but rather calculates them each time in the context of calling an execution (on the bar, shifted relative to the current one for a specified number of bars).
HighD |
HighestFC |
HighS |
HPI |
HullMovAvg |
LinearReg |
LinearRegValue |
LowD |
LowestFC |
LowS |
LWAccDis |
MACD |
MassIndex |
McClellanOsc |
NormGradientColor |
OBV |
OHLCPeriodsAgo |
OpenD |
OpenS |
ParabolicSAR |
Pennant |
PivotHighVS |
PivotHighVSBar |
PivotLowVS |
PivotLowVSBar |
PivotReversalGen |
PriceOscillator |
PriceVolTrend |
RS_Average |
RS_BarsPerDay |
RS_DailyDataArray |
RS_Extremes |
RS_PriceExtension |
RS_ReversalPatterns |
RS_TrueExtremes |
RSI |
SharpeRatio |
SlowKCustom |
StdError |
Stochastic |
StochasticExp |
SummationFC |
SwingHigh |
SwingHighBar |
SwingLow |
SwingLowBar |
TimeSeriesForecast |
TriAverage |
TRIX |
UltimateOscillator |
Volatility |
VolatilityStdDev |
VolumeOsc |
vwapResettable |
XAverage |
XAverageOrig |
FunctionObject<T> | Class that describes a function object.
Lambda<T> | The lambda implementation of ISeries.
LambdaRef<T> | The lambda implementation of IVar.
VariableObject<T> | Class for simple variables, provides access to the value of the variable in the current context of study execution.
VariableSeries<T> | Class that allows access to and preserves historical variable values (for a series of variables).

Generic template parameters

T

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ISeries<T> Members | PowerLanguage Namespace


ISeries<T> Members

ISeries<T> overview

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | Read-only property. Returns series value.

See Also

ISeries<T> Interface | PowerLanguage Namespace


ISeries<T> Properties

The properties of the ISeries<T> interface are listed below. For a complete list of ISeries<T> interface members, see the ISeries<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | Read-only property. Returns series value.

See Also

ISeries<T> Interface | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

ISeries`1.Item Property

Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

public T this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression, specifying the number of bars back.

See Also

ISeries<T> Interface | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

ISeries`1.Value Property

Read-only property. Returns series value.

public T Value { public get; }

See Also

ISeries<T> Interface | PowerLanguage Namespace


ISeriesSymbolData Interface

Interface for access to symbol's price and time data.

For a list of all members of this type, see ISeriesSymbolData Members .

PowerLanguage.ISeriesSymbolData
PowerLanguage.IInstrument
PowerLanguage.ISeriesSymbolDataRand

public interface ISeriesSymbolData

Types that implement ISeriesSymbolData

Type | Description
CustomInstrument | Allows to access data series of another symbol without adding it as an additional data series. Note: after using CustomInstrument you need to call the Dispose() method for proper operation of MultiCharts application.
CustomInstrumentBase | Base class of custom instrument.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ISeriesSymbolData Members | PowerLanguage Namespace


ISeriesSymbolData Members

ISeriesSymbolData overview

Public Instance Properties

Close | Read-only property. Provides an array for accessing Close bars, previous to the current one. The array index is number of bars back (Bars ago).
DownTicks | Read-only property. Provides an array for accessing DownTick bars, previous to the current one. The array index is number of bars back (Bars ago).
High | Read-only property. Provides an array for accessing High bars previous to the current one. The array index is number of bars back (Bars ago).
Low | Read-only property. Provides an array for accessing Low bars, previous to the current one. The array index is number of bars back (Bars ago).
Open | Read-only property. Provides an array for accessing Open bars, previous to the current one. The array index is number of bars back (Bars ago).
OpenInt | Read-only property. Provides an array for accessing Open Interest bars, previous to the current one. The array index is number of bars back (Bars ago).
Ticks | Read-only property. Provides an array for accessing Tick bars,previous to the current one. The array index is number of bars back (Bars ago).
Time | Read-only property. Provides an array for accessing DateTime bars, previous to the current one. The array index is number of bars back (Bars ago).
UpTicks | Read-only property. Provides an array for accessing UpTick bars, previous to the current one. The array index is number of bars back (Bars ago).
Volume | Read-only property. Provides an array for accessing Volume bars, previous to the current one. The array index is number of bars back (Bars ago).

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


ISeriesSymbolData Properties

The properties of the ISeriesSymbolData interface are listed below. For a complete list of ISeriesSymbolData interface members, see the ISeriesSymbolData Members topic.

Public Instance Properties

Close | Read-only property. Provides an array for accessing Close bars, previous to the current one. The array index is number of bars back (Bars ago).
DownTicks | Read-only property. Provides an array for accessing DownTick bars, previous to the current one. The array index is number of bars back (Bars ago).
High | Read-only property. Provides an array for accessing High bars previous to the current one. The array index is number of bars back (Bars ago).
Low | Read-only property. Provides an array for accessing Low bars, previous to the current one. The array index is number of bars back (Bars ago).
Open | Read-only property. Provides an array for accessing Open bars, previous to the current one. The array index is number of bars back (Bars ago).
OpenInt | Read-only property. Provides an array for accessing Open Interest bars, previous to the current one. The array index is number of bars back (Bars ago).
Ticks | Read-only property. Provides an array for accessing Tick bars,previous to the current one. The array index is number of bars back (Bars ago).
Time | Read-only property. Provides an array for accessing DateTime bars, previous to the current one. The array index is number of bars back (Bars ago).
UpTicks | Read-only property. Provides an array for accessing UpTick bars, previous to the current one. The array index is number of bars back (Bars ago).
Volume | Read-only property. Provides an array for accessing Volume bars, previous to the current one. The array index is number of bars back (Bars ago).

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


Close Property

PowerLanguage.NET Help

ISeriesSymbolData.Close Property

Read-only property. Provides an array for accessing Close bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> Close { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


DownTicks Property

PowerLanguage.NET Help

ISeriesSymbolData.DownTicks Property

Read-only property. Provides an array for accessing DownTick bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> DownTicks { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


High Property

PowerLanguage.NET Help

ISeriesSymbolData.High Property

Read-only property. Provides an array for accessing High bars previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> High { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


Low Property

PowerLanguage.NET Help

ISeriesSymbolData.Low Property

Read-only property. Provides an array for accessing Low bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> Low { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


Open Property

PowerLanguage.NET Help

ISeriesSymbolData.Open Property

Read-only property. Provides an array for accessing Open bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> Open { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


OpenInt Property

PowerLanguage.NET Help

ISeriesSymbolData.OpenInt Property

Read-only property. Provides an array for accessing Open Interest bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> OpenInt { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


Ticks Property

PowerLanguage.NET Help

ISeriesSymbolData.Ticks Property

Read-only property. Provides an array for accessing Tick bars,previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> Ticks { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

ISeriesSymbolData.Time Property

Read-only property. Provides an array for accessing DateTime bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<DateTime> Time { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


UpTicks Property

PowerLanguage.NET Help

ISeriesSymbolData.UpTicks Property

Read-only property. Provides an array for accessing UpTick bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> UpTicks { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


Volume Property

PowerLanguage.NET Help

ISeriesSymbolData.Volume Property

Read-only property. Provides an array for accessing Volume bars, previous to the current one. The array index is number of bars back (Bars ago).

public ISeries<double> Volume { public get; }

See Also

ISeriesSymbolData Interface | PowerLanguage Namespace


ISeriesSymbolDataRand Interface

Interface for access to symbol's price and time data of any bar (no Max Number of Bar Reference limits).

For a list of all members of this type, see ISeriesSymbolDataRand Members .

public interface ISeriesSymbolDataRand : ISeriesSymbolData

Types that implement ISeriesSymbolDataRand

Type | Description
CustomInstrument | Allows to access data series of another symbol without adding it as an additional data series. Note: after using CustomInstrument you need to call the Dispose() method for proper operation of MultiCharts application.
CustomInstrumentBase | Base class of custom instrument.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ISeriesSymbolDataRand Members | PowerLanguage Namespace


ISeriesSymbolDataRand Members

ISeriesSymbolDataRand overview

Public Instance Properties

Count | Read-only property. Returns series bars count.
Current | Read-only property. Returns symbol's current bar number. Start from 1 to Count. Do not include original CurrentBar when calculating Max Number of Bar Reference offset.

See Also

ISeriesSymbolDataRand Interface | PowerLanguage Namespace


ISeriesSymbolDataRand Properties

The properties of the ISeriesSymbolDataRand interface are listed below. For a complete list of ISeriesSymbolDataRand interface members, see the ISeriesSymbolDataRand Members topic.

Public Instance Properties

Count | Read-only property. Returns series bars count.
Current | Read-only property. Returns symbol's current bar number. Start from 1 to Count. Do not include original CurrentBar when calculating Max Number of Bar Reference offset.

See Also

ISeriesSymbolDataRand Interface | PowerLanguage Namespace


Count Property

PowerLanguage.NET Help

ISeriesSymbolDataRand.Count Property

Read-only property. Returns series bars count.

public int Count { public get; }

See Also

ISeriesSymbolDataRand Interface | PowerLanguage Namespace


Current Property

PowerLanguage.NET Help

ISeriesSymbolDataRand.Current Property

Read-only property. Returns symbol's current bar number. Start from 1 to Count. Do not include original CurrentBar when calculating Max Number of Bar Reference offset.

public int Current { public get; }

See Also

ISeriesSymbolDataRand Interface | PowerLanguage Namespace


ISignalInfo Interface

For a list of all members of this type, see ISignalInfo Members .

public interface ISignalInfo

Types that implement ISignalInfo

Type | Description
PortfolioSignalObject |
SignalObject | Base class for strategies (inherit from SignalObject to create this kind of study).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ISignalInfo Members | PowerLanguage Namespace


ISignalInfo Members

ISignalInfo overview

Public Instance Methods

GetAllowSendOrdersAlways
GetCalcAtOpenNextBar
GetExitFromOneEntryOnce
GetIOGMode

See Also

ISignalInfo Interface | PowerLanguage Namespace


ISignalInfo Methods

The methods of the ISignalInfo interface are listed below. For a complete list of ISignalInfo interface members, see the ISignalInfo Members topic.

Public Instance Methods

GetAllowSendOrdersAlways
GetCalcAtOpenNextBar
GetExitFromOneEntryOnce
GetIOGMode

See Also

ISignalInfo Interface | PowerLanguage Namespace


ISignalInfo.GetAllowSendOrdersAlways Method

bool? GetAllowSendOrdersAlways();

See Also

ISignalInfo Interface | PowerLanguage Namespace


ISignalInfo.GetCalcAtOpenNextBar Method

bool? GetCalcAtOpenNextBar();

See Also

ISignalInfo Interface | PowerLanguage Namespace


ISignalInfo.GetExitFromOneEntryOnce Method

ExitFromOneEntryOnce? GetExitFromOneEntryOnce();

See Also

ISignalInfo Interface | PowerLanguage Namespace


ISignalInfo.GetIOGMode Method

IOGMode? GetIOGMode();

See Also

ISignalInfo Interface | PowerLanguage Namespace


IStatusLine Interface

Interface for an information reflected in Status Line.

For a list of all members of this type, see IStatusLine Members .

public interface IStatusLine

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IStatusLine Members | PowerLanguage Namespace


IStatusLine Members

IStatusLine overview

Public Instance Properties

Ask | Read-only property. Returns current Ask.
AskSize | Read-only property. Returns current Ask Size.
Bid | Read-only property. Returns current Bid.
BidSize | Read-only property. Returns current Bid Size.
Close | Read-only property. Returns daily Close.
DailyVolume | Read-only property. Returns daily Volume.
High | Read-only property. Returns daily High.
Last | Read-only property. Returns Last.
LastVolume | Read-only property. Returns Volume of Last price from status line.
Low | Read-only property. Returns daily Low.
Open | Read-only property. Returns daily Open.
OpenInt | Read-only property. Returns Open Interest.
PrevClose | Read-only property. Returns previous day’s Close.
Time | Read-only property. Returns current time.
TotalVolume | Read-only property. Returns Total Volume.

See Also

IStatusLine Interface | PowerLanguage Namespace


IStatusLine Properties

The properties of the IStatusLine interface are listed below. For a complete list of IStatusLine interface members, see the IStatusLine Members topic.

Public Instance Properties

Ask | Read-only property. Returns current Ask.
AskSize | Read-only property. Returns current Ask Size.
Bid | Read-only property. Returns current Bid.
BidSize | Read-only property. Returns current Bid Size.
Close | Read-only property. Returns daily Close.
DailyVolume | Read-only property. Returns daily Volume.
High | Read-only property. Returns daily High.
Last | Read-only property. Returns Last.
LastVolume | Read-only property. Returns Volume of Last price from status line.
Low | Read-only property. Returns daily Low.
Open | Read-only property. Returns daily Open.
OpenInt | Read-only property. Returns Open Interest.
PrevClose | Read-only property. Returns previous day’s Close.
Time | Read-only property. Returns current time.
TotalVolume | Read-only property. Returns Total Volume.

See Also

IStatusLine Interface | PowerLanguage Namespace


Ask Property

PowerLanguage.NET Help

IStatusLine.Ask Property

Read-only property. Returns current Ask.

public double Ask { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


AskSize Property

PowerLanguage.NET Help

IStatusLine.AskSize Property

Read-only property. Returns current Ask Size.

public double AskSize { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


Bid Property

PowerLanguage.NET Help

IStatusLine.Bid Property

Read-only property. Returns current Bid.

public double Bid { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


BidSize Property

PowerLanguage.NET Help

IStatusLine.BidSize Property

Read-only property. Returns current Bid Size.

public double BidSize { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


Close Property

PowerLanguage.NET Help

IStatusLine.Close Property

Read-only property. Returns daily Close.

public double Close { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


DailyVolume Property

PowerLanguage.NET Help

IStatusLine.DailyVolume Property

Read-only property. Returns daily Volume.

public double DailyVolume { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


High Property

PowerLanguage.NET Help

IStatusLine.High Property

Read-only property. Returns daily High.

public double High { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


Last Property

PowerLanguage.NET Help

IStatusLine.Last Property

Read-only property. Returns Last.

public double Last { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


LastVolume Property

PowerLanguage.NET Help

IStatusLine.LastVolume Property

Read-only property. Returns Volume of Last price from status line.

public double LastVolume { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


Low Property

PowerLanguage.NET Help

IStatusLine.Low Property

Read-only property. Returns daily Low.

public double Low { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


Open Property

PowerLanguage.NET Help

IStatusLine.Open Property

Read-only property. Returns daily Open.

public double Open { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


OpenInt Property

PowerLanguage.NET Help

IStatusLine.OpenInt Property

Read-only property. Returns Open Interest.

public double OpenInt { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


PrevClose Property

PowerLanguage.NET Help

IStatusLine.PrevClose Property

Read-only property. Returns previous day’s Close.

public double PrevClose { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

IStatusLine.Time Property

Read-only property. Returns current time.

public DateTime Time { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


TotalVolume Property

PowerLanguage.NET Help

IStatusLine.TotalVolume Property

Read-only property. Returns Total Volume.

public double TotalVolume { public get; }

See Also

IStatusLine Interface | PowerLanguage Namespace


IStrategy Interface

An interface describing the strategy.

For a list of all members of this type, see IStrategy Members .

public interface IStrategy : IStudy

Types that implement IStrategy

Type | Description
PortfolioSignalObject |
SignalObject | Base class for strategies (inherit from SignalObject to create this kind of study).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IStrategy Members | PowerLanguage Namespace


IStrategy Members

IStrategy overview

Public Instance Properties

AvgBarsEvenTrade | Read-only property. Returns the average length of even trades (without profit and loss) in terms of bars.
AvgBarsLosTrade | Read-only property. Returns the average length of losing trades in terms of bars.
AvgBarsWinTrade | Read-only property. Returns the average length of winning trades in terms of bars.
Commission | Read-only property. Returns 'Commission' from the Strategy Properties window.
CurrentPosition | Read-only property. Returns strategy's current position.
GrossLoss | Read-only property. Returns a non-positive number that indicates total strategy loss.
GrossProfit | Read-only property. Returns non-negative number that indicates total strategy profit.
InitialCapital | Read-only property. Returns 'Initial Capital' from the Strategy Properties window.
InterestRate | Read-only property. Returns 'Interest Rate' from the Strategy Properties window.
LargestLosTrade | Read-only property. Returns non-positive number with maximum loss of a single trade.
LargestWinTrade | Read-only property. Returns non-negative number with maximum profit of a single trade.
MaxConsecLosers | Read-only property. Returns maximum number of sequential unprofitable trades.
MaxConsecWinners | Read-only property. Returns maximum number of sequential profitable trades.
MaxDrawDown | Read-only property. Returns maximum potential loss (drawdown) during entire trading period.
MaxLotsHeld | Read-only property. Returns maximum number of sequential unprofitable trades.
NumEvenTrades | Read-only property. Returns total number of trades that did not bring any profit or loss.
NumLosTrades | Read-only property. Returns total number or losing trades.
NumWinTrades | Read-only property. Returns total number or profitable trades.
PercentProfit | Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).
Portfolio | Read-only property. Returns an interface which provides Portfolio Perfomance.
Positions | Read-only property. Returns a read-only collection of all strategy positions.
PositionSide | Read-only property. Returns strategy's MarketPosition.
Slippage | Read-only property. Returns 'Slippage' from the Strategy Properties window.
StrategyCurrencyCode | Returns currency code from Strategy settings (Base Currency)
TotalBarsEvenTrades | Read-only property. Returns the total number of bars during which even trades (without profit and loss) were open.
TotalBarsLosTrades | Read-only property. Returns the total number of bars during which losing trades were open.
TotalBarsWinTrades | Read-only property. Returns the total number of bars during which winning trades were open.
TotalTrades | Read-only property. Returns the total number of trades.

See Also

IStrategy Interface | PowerLanguage Namespace


IStrategy Properties

The properties of the IStrategy interface are listed below. For a complete list of IStrategy interface members, see the IStrategy Members topic.

Public Instance Properties

AvgBarsEvenTrade | Read-only property. Returns the average length of even trades (without profit and loss) in terms of bars.
AvgBarsLosTrade | Read-only property. Returns the average length of losing trades in terms of bars.
AvgBarsWinTrade | Read-only property. Returns the average length of winning trades in terms of bars.
Commission | Read-only property. Returns 'Commission' from the Strategy Properties window.
CurrentPosition | Read-only property. Returns strategy's current position.
GrossLoss | Read-only property. Returns a non-positive number that indicates total strategy loss.
GrossProfit | Read-only property. Returns non-negative number that indicates total strategy profit.
InitialCapital | Read-only property. Returns 'Initial Capital' from the Strategy Properties window.
InterestRate | Read-only property. Returns 'Interest Rate' from the Strategy Properties window.
LargestLosTrade | Read-only property. Returns non-positive number with maximum loss of a single trade.
LargestWinTrade | Read-only property. Returns non-negative number with maximum profit of a single trade.
MaxConsecLosers | Read-only property. Returns maximum number of sequential unprofitable trades.
MaxConsecWinners | Read-only property. Returns maximum number of sequential profitable trades.
MaxDrawDown | Read-only property. Returns maximum potential loss (drawdown) during entire trading period.
MaxLotsHeld | Read-only property. Returns maximum number of sequential unprofitable trades.
NumEvenTrades | Read-only property. Returns total number of trades that did not bring any profit or loss.
NumLosTrades | Read-only property. Returns total number or losing trades.
NumWinTrades | Read-only property. Returns total number or profitable trades.
PercentProfit | Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).
Portfolio | Read-only property. Returns an interface which provides Portfolio Perfomance.
Positions | Read-only property. Returns a read-only collection of all strategy positions.
PositionSide | Read-only property. Returns strategy's MarketPosition.
Slippage | Read-only property. Returns 'Slippage' from the Strategy Properties window.
StrategyCurrencyCode | Returns currency code from Strategy settings (Base Currency)
TotalBarsEvenTrades | Read-only property. Returns the total number of bars during which even trades (without profit and loss) were open.
TotalBarsLosTrades | Read-only property. Returns the total number of bars during which losing trades were open.
TotalBarsWinTrades | Read-only property. Returns the total number of bars during which winning trades were open.
TotalTrades | Read-only property. Returns the total number of trades.

See Also

IStrategy Interface | PowerLanguage Namespace


AvgBarsEvenTrade Property

PowerLanguage.NET Help

IStrategy.AvgBarsEvenTrade Property

Read-only property. Returns the average length of even trades (without profit and loss) in terms of bars.

public double AvgBarsEvenTrade { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


AvgBarsLosTrade Property

PowerLanguage.NET Help

IStrategy.AvgBarsLosTrade Property

Read-only property. Returns the average length of losing trades in terms of bars.

public double AvgBarsLosTrade { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


AvgBarsWinTrade Property

PowerLanguage.NET Help

IStrategy.AvgBarsWinTrade Property

Read-only property. Returns the average length of winning trades in terms of bars.

public double AvgBarsWinTrade { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


Commission Property

PowerLanguage.NET Help

IStrategy.Commission Property

Read-only property. Returns 'Commission' from the Strategy Properties window.

public double Commission { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


CurrentPosition Property

PowerLanguage.NET Help

IStrategy.CurrentPosition Property

Read-only property. Returns strategy's current position.

public IMarketPosition CurrentPosition { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


GrossLoss Property

PowerLanguage.NET Help

IStrategy.GrossLoss Property

Read-only property. Returns a non-positive number that indicates total strategy loss.

public double GrossLoss { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


GrossProfit Property

PowerLanguage.NET Help

IStrategy.GrossProfit Property

Read-only property. Returns non-negative number that indicates total strategy profit.

public double GrossProfit { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


InitialCapital Property

PowerLanguage.NET Help

IStrategy.InitialCapital Property

Read-only property. Returns 'Initial Capital' from the Strategy Properties window.

public double InitialCapital { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


InterestRate Property

PowerLanguage.NET Help

IStrategy.InterestRate Property

Read-only property. Returns 'Interest Rate' from the Strategy Properties window.

public double InterestRate { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


LargestLosTrade Property

PowerLanguage.NET Help

IStrategy.LargestLosTrade Property

Read-only property. Returns non-positive number with maximum loss of a single trade.

public double LargestLosTrade { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


LargestWinTrade Property

PowerLanguage.NET Help

IStrategy.LargestWinTrade Property

Read-only property. Returns non-negative number with maximum profit of a single trade.

public double LargestWinTrade { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


MaxConsecLosers Property

PowerLanguage.NET Help

IStrategy.MaxConsecLosers Property

Read-only property. Returns maximum number of sequential unprofitable trades.

public int MaxConsecLosers { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


MaxConsecWinners Property

PowerLanguage.NET Help

IStrategy.MaxConsecWinners Property

Read-only property. Returns maximum number of sequential profitable trades.

public int MaxConsecWinners { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


MaxDrawDown Property

PowerLanguage.NET Help

IStrategy.MaxDrawDown Property

Read-only property. Returns maximum potential loss (drawdown) during entire trading period.

public double MaxDrawDown { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


MaxLotsHeld Property

PowerLanguage.NET Help

IStrategy.MaxLotsHeld Property

Read-only property. Returns maximum number of sequential unprofitable trades.

public int MaxLotsHeld { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


NumEvenTrades Property

PowerLanguage.NET Help

IStrategy.NumEvenTrades Property

Read-only property. Returns total number of trades that did not bring any profit or loss.

public int NumEvenTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


NumLosTrades Property

PowerLanguage.NET Help

IStrategy.NumLosTrades Property

Read-only property. Returns total number or losing trades.

public int NumLosTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


NumWinTrades Property

PowerLanguage.NET Help

IStrategy.NumWinTrades Property

Read-only property. Returns total number or profitable trades.

public int NumWinTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


PercentProfit Property

PowerLanguage.NET Help

IStrategy.PercentProfit Property

Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).

public double PercentProfit { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


Portfolio Property

PowerLanguage.NET Help

IStrategy.Portfolio Property

Read-only property. Returns an interface which provides Portfolio Perfomance.

public IPortfolioPerformance Portfolio { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


Positions Property

PowerLanguage.NET Help

IStrategy.Positions Property

Read-only property. Returns a read-only collection of all strategy positions.

public IROList<IMarketPosition> Positions { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


PositionSide Property

PowerLanguage.NET Help

IStrategy.PositionSide Property

Read-only property. Returns strategy's MarketPosition.

public int PositionSide { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


Slippage Property

PowerLanguage.NET Help

IStrategy.Slippage Property

Read-only property. Returns 'Slippage' from the Strategy Properties window.

public double Slippage { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


StrategyCurrencyCode Property

PowerLanguage.NET Help

IStrategy.StrategyCurrencyCode Property

Returns currency code from Strategy settings (Base Currency)

public MTPA_MCSymbolCurrency StrategyCurrencyCode { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


TotalBarsEvenTrades Property

PowerLanguage.NET Help

IStrategy.TotalBarsEvenTrades Property

Read-only property. Returns the total number of bars during which even trades (without profit and loss) were open.

public int TotalBarsEvenTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


TotalBarsLosTrades Property

PowerLanguage.NET Help

IStrategy.TotalBarsLosTrades Property

Read-only property. Returns the total number of bars during which losing trades were open.

public int TotalBarsLosTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


TotalBarsWinTrades Property

PowerLanguage.NET Help

IStrategy.TotalBarsWinTrades Property

Read-only property. Returns the total number of bars during which winning trades were open.

public int TotalBarsWinTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


TotalTrades Property

PowerLanguage.NET Help

IStrategy.TotalTrades Property

Read-only property. Returns the total number of trades.

public int TotalTrades { public get; }

See Also

IStrategy Interface | PowerLanguage Namespace


IStrategyPerformance Interface

An interface for accessing strategy information.

For a list of all members of this type, see IStrategyPerformance Members .

public interface IStrategyPerformance

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IStrategyPerformance Members | PowerLanguage Namespace


IStrategyPerformance Members

IStrategyPerformance overview

Public Instance Properties

AvgEntryPrice | Read-only property. Returns average entry price.
AvgEntryPriceAtBroker | Read-only property. Returns average entry price for position that was requested from the broker.
AvgEntryPriceAtBrokerForTheStrategy | Read-only property. Returns average entry price for position requested from the broker for the current strategy.
ClosedEquity | Read-only property. Returns fixed profit.
MarketPosition | Read-only property. Returns current Market Position for strategy on the chart.
MarketPositionAtBroker | Read-only property. Returns Market Position requested from the broker.
MarketPositionAtBrokerForTheStrategy | Read-only property. Returns Market Position requested from the broker for the current strategy.
OpenEquity | Read-only property. Returns potential profit, i.e. current Profit and Loss, aka PnL.
Signals | Read-only property. Returns signals consisting strategy.

Public Instance Methods

ConvertCurrency | Converts amount of money from one currency into another one according to currency rate on specified date.
GetPlotValue | Returns "plot_num" value for the current bar that has been set previously by SetPlotValue.
SetPlotValue | Sets "plot_num" value for the current bar.

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


IStrategyPerformance Properties

The properties of the IStrategyPerformance interface are listed below. For a complete list of IStrategyPerformance interface members, see the IStrategyPerformance Members topic.

Public Instance Properties

AvgEntryPrice | Read-only property. Returns average entry price.
AvgEntryPriceAtBroker | Read-only property. Returns average entry price for position that was requested from the broker.
AvgEntryPriceAtBrokerForTheStrategy | Read-only property. Returns average entry price for position requested from the broker for the current strategy.
ClosedEquity | Read-only property. Returns fixed profit.
MarketPosition | Read-only property. Returns current Market Position for strategy on the chart.
MarketPositionAtBroker | Read-only property. Returns Market Position requested from the broker.
MarketPositionAtBrokerForTheStrategy | Read-only property. Returns Market Position requested from the broker for the current strategy.
OpenEquity | Read-only property. Returns potential profit, i.e. current Profit and Loss, aka PnL.
Signals | Read-only property. Returns signals consisting strategy.

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


AvgEntryPrice Property

PowerLanguage.NET Help

IStrategyPerformance.AvgEntryPrice Property

Read-only property. Returns average entry price.

public double AvgEntryPrice { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


AvgEntryPriceAtBroker Property

PowerLanguage.NET Help

IStrategyPerformance.AvgEntryPriceAtBroker Property

Read-only property. Returns average entry price for position that was requested from the broker.

public double AvgEntryPriceAtBroker { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


AvgEntryPriceAtBrokerForTheStrategy Property

PowerLanguage.NET Help

IStrategyPerformance.AvgEntryPriceAtBrokerForTheStrategy Property

Read-only property. Returns average entry price for position requested from the broker for the current strategy.

public double AvgEntryPriceAtBrokerForTheStrategy { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


ClosedEquity Property

PowerLanguage.NET Help

IStrategyPerformance.ClosedEquity Property

Read-only property. Returns fixed profit.

public double ClosedEquity { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


MarketPosition Property

PowerLanguage.NET Help

IStrategyPerformance.MarketPosition Property

Read-only property. Returns current Market Position for strategy on the chart.

public int MarketPosition { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


MarketPositionAtBroker Property

PowerLanguage.NET Help

IStrategyPerformance.MarketPositionAtBroker Property

Read-only property. Returns Market Position requested from the broker.

public int MarketPositionAtBroker { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


MarketPositionAtBrokerForTheStrategy Property

PowerLanguage.NET Help

IStrategyPerformance.MarketPositionAtBrokerForTheStrategy Property

Read-only property. Returns Market Position requested from the broker for the current strategy.

public int MarketPositionAtBrokerForTheStrategy { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


OpenEquity Property

PowerLanguage.NET Help

IStrategyPerformance.OpenEquity Property

Read-only property. Returns potential profit, i.e. current Profit and Loss, aka PnL.

public double OpenEquity { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


Signals Property

PowerLanguage.NET Help

IStrategyPerformance.Signals Property

Read-only property. Returns signals consisting strategy.

public IStrategy[] Signals { public get; }

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


IStrategyPerformance Methods

The methods of the IStrategyPerformance interface are listed below. For a complete list of IStrategyPerformance interface members, see the IStrategyPerformance Members topic.

Public Instance Methods

ConvertCurrency | Converts amount of money from one currency into another one according to currency rate on specified date.
GetPlotValue | Returns "plot_num" value for the current bar that has been set previously by SetPlotValue.
SetPlotValue | Sets "plot_num" value for the current bar.

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


IStrategyPerformance.ConvertCurrency Method

Converts amount of money from one currency into another one according to currency rate on specified date.

double ConvertCurrency(
DateTime when,
MTPA_MCSymbolCurrency from,
MTPA_MCSymbolCurrency to,
double value
);

Parameters

when
The date to specify.
from
Original currency of the amount of money.
to
Resulting currency of the amount of money.
value
The amount of money.

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


IStrategyPerformance.GetPlotValue Method

Returns "plot_num" value for the current bar that has been set previously by SetPlotValue.

double GetPlotValue(
int plot_num
);

Parameters

plot_num
Some identifier (key)

Return Value

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


IStrategyPerformance.SetPlotValue Method

Sets "plot_num" value for the current bar.

void SetPlotValue(
int plot_num,
double value
);

Parameters

plot_num
Some identifier (key)
value
Value

See Also

IStrategyPerformance Interface | PowerLanguage Namespace


IStudy Interface

Common base interface for data access.

For a list of all members of this type, see IStudy Members .

PowerLanguage.IStudy
PowerLanguage.IStrategy

public interface IStudy

Types that implement IStudy

Type | Description
CStudyAbstract | Base class for studies.
CStudyControl | Base class for studies.
AccumSwingIndex |
AccumulationDistribution |
AdaptiveMovAvg |
AdvanceDeclineDiff |
ADX |
ADXCustom |
ADXR |
ADXRCustom |
AverageFC |
BarNumber |
C_3WhSolds_3BlkCrows |
C_BullEng_BearEng |
C_BullHar_BearHar |
C_Hammer_HangingMan |
C_MornDoji_EveDoji |
C_MornStar_EveStar |
C_PierceLine_DkCloud |
C_ShootingStar |
ChaikinOsc |
CloseD |
CloseS |
CSI |
Cum |
DirMovement |
draw_DOM_level |
ExtremesFC |
FastK |
FastKCustom |
FunctionSeries<T> | A series function’s base class. Feature of a series function is that its body is always calculated in the current context of execution (at the currently calculating bar), and the function always keeps its previous values.
FunctionSimple<T> | Simple function’s base class. Its peculiarity is that it doesn’t keep the history of its values, but rather calculates them each time in the context of calling an execution (on the bar, shifted relative to the current one for a specified number of bars).
HighD |
HighestFC |
HighS |
HPI |
HullMovAvg |
LinearReg |
LinearRegValue |
LowD |
LowestFC |
LowS |
LWAccDis |
MACD |
MassIndex |
McClellanOsc |
NormGradientColor |
OBV |
OHLCPeriodsAgo |
OpenD |
OpenS |
ParabolicSAR |
Pennant |
PivotHighVS |
PivotHighVSBar |
PivotLowVS |
PivotLowVSBar |
PivotReversalGen |
PriceOscillator |
PriceVolTrend |
RS_Average |
RS_BarsPerDay |
RS_DailyDataArray |
RS_Extremes |
RS_PriceExtension |
RS_ReversalPatterns |
RS_TrueExtremes |
RSI |
SharpeRatio |
SlowKCustom |
StdError |
Stochastic |
StochasticExp |
SummationFC |
SwingHigh |
SwingHighBar |
SwingLow |
SwingLowBar |
TimeSeriesForecast |
TriAverage |
TRIX |
UltimateOscillator |
Volatility |
VolatilityStdDev |
VolumeOsc |
vwapResettable |
XAverage |
XAverageOrig |
FunctionObject<T> | Class that describes a function object.
IndicatorObject | Indicator’s base class (inherit from this class to create an indicator).
PortfolioSignalObject |
SignalObject | Base class for strategies (inherit from SignalObject to create this kind of study).

Remarks

Enjoy IStudy type and C#!

Enjoy it more!

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IStudy Members | PowerLanguage Namespace


IStudy Members

IStudy overview

Public Instance Properties

Alerts | Read-only property. Provides an interface for accessing Alerts.
Bars | Read-only property. Provides an interface for accessing current series' data.
DrwArrow | Read-only property. Provides an interface for accessing Arrow Drawings.
DrwText | Read-only property. Provides an interface for accessing Text Drawings.
DrwTrendLine | Read-only property. Provides an interface for accessing Trend Line Drawings.
Environment | Read-only property. Provides an interface for accessing the environment.
ExecControl | Read-only property. Provides an interface for controlling study’s calculation.
ExecInfo | Read-only property. Provides an interface for accessing information regarding study’s context.
ExpertCommentary | Read-only property. Provides an interface for accessing Expert Commentary.
MaxDataStream | Read-only property. The maximum index number of datastreams present on the chart.
Name | Read-only property. Returns study name.
Output | Read-only property. Provides an interface for accessing Output Window.
StrategyInfo | Read-only property. Provides an interface for accessing strategy information.
TPOBars | Read-only property. Provides an interface for accessing current series' TPO data.

Public Instance Methods

BarsOfData | Read-only property. Provides an interface for accessing data series on a particular datastream. Datastream number is provided in the parameter.
IsExist | Read-only property. Indicates whether there is a series with given number on the chart.
TPOBarsOfData | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.

See Also

IStudy Interface | PowerLanguage Namespace


IStudy Properties

The properties of the IStudy interface are listed below. For a complete list of IStudy interface members, see the IStudy Members topic.

Public Instance Properties

Alerts | Read-only property. Provides an interface for accessing Alerts.
Bars | Read-only property. Provides an interface for accessing current series' data.
DrwArrow | Read-only property. Provides an interface for accessing Arrow Drawings.
DrwText | Read-only property. Provides an interface for accessing Text Drawings.
DrwTrendLine | Read-only property. Provides an interface for accessing Trend Line Drawings.
Environment | Read-only property. Provides an interface for accessing the environment.
ExecControl | Read-only property. Provides an interface for controlling study’s calculation.
ExecInfo | Read-only property. Provides an interface for accessing information regarding study’s context.
ExpertCommentary | Read-only property. Provides an interface for accessing Expert Commentary.
MaxDataStream | Read-only property. The maximum index number of datastreams present on the chart.
Name | Read-only property. Returns study name.
Output | Read-only property. Provides an interface for accessing Output Window.
StrategyInfo | Read-only property. Provides an interface for accessing strategy information.
TPOBars | Read-only property. Provides an interface for accessing current series' TPO data.

See Also

IStudy Interface | PowerLanguage Namespace


Alerts Property

PowerLanguage.NET Help

IStudy.Alerts Property

Read-only property. Provides an interface for accessing Alerts.

public IAlert Alerts { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


Bars Property

PowerLanguage.NET Help

IStudy.Bars Property

Read-only property. Provides an interface for accessing current series' data.

public IInstrument Bars { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


DrwArrow Property

PowerLanguage.NET Help

IStudy.DrwArrow Property

Read-only property. Provides an interface for accessing Arrow Drawings.

public IArrowContainer DrwArrow { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


DrwText Property

PowerLanguage.NET Help

IStudy.DrwText Property

Read-only property. Provides an interface for accessing Text Drawings.

public ITextContainer DrwText { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


DrwTrendLine Property

PowerLanguage.NET Help

IStudy.DrwTrendLine Property

Read-only property. Provides an interface for accessing Trend Line Drawings.

public ITrendLineContainer DrwTrendLine { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


Environment Property

PowerLanguage.NET Help

IStudy.Environment Property

Read-only property. Provides an interface for accessing the environment.

public IApplicationInfo Environment { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


ExecControl Property

PowerLanguage.NET Help

IStudy.ExecControl Property

Read-only property. Provides an interface for controlling study’s calculation.

public ICalculationControl ExecControl { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


ExecInfo Property

PowerLanguage.NET Help

IStudy.ExecInfo Property

Read-only property. Provides an interface for accessing information regarding study’s context.

public ICalculationInfo ExecInfo { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


ExpertCommentary Property

PowerLanguage.NET Help

IStudy.ExpertCommentary Property

Read-only property. Provides an interface for accessing Expert Commentary.

public IExpertCommentary ExpertCommentary { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


MaxDataStream Property

PowerLanguage.NET Help

IStudy.MaxDataStream Property

Read-only property. The maximum index number of datastreams present on the chart.

public int MaxDataStream { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

IStudy.Name Property

Read-only property. Returns study name.

public string Name { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


Output Property

PowerLanguage.NET Help

IStudy.Output Property

Read-only property. Provides an interface for accessing Output Window.

public IOutput Output { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


StrategyInfo Property

PowerLanguage.NET Help

IStudy.StrategyInfo Property

Read-only property. Provides an interface for accessing strategy information.

public IStrategyPerformance StrategyInfo { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


TPOBars Property

PowerLanguage.NET Help

IStudy.TPOBars Property

Read-only property. Provides an interface for accessing current series' TPO data.

public IInstrumentTPO TPOBars { public get; }

See Also

IStudy Interface | PowerLanguage Namespace


IStudy Methods

The methods of the IStudy interface are listed below. For a complete list of IStudy interface members, see the IStudy Members topic.

Public Instance Methods

BarsOfData | Read-only property. Provides an interface for accessing data series on a particular datastream. Datastream number is provided in the parameter.
IsExist | Read-only property. Indicates whether there is a series with given number on the chart.
TPOBarsOfData | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.

See Also

IStudy Interface | PowerLanguage Namespace


IStudy.BarsOfData Method

Read-only property. Provides an interface for accessing data series on a particular datastream. Datastream number is provided in the parameter.

IInstrument BarsOfData(
int dataStream
);

See Also

IStudy Interface | PowerLanguage Namespace


IStudy.IsExist Method

Read-only property. Indicates whether there is a series with given number on the chart.

bool IsExist(
int dataStream
);

Parameters

dataStream
Data stream number.

Return Value

See Also

IStudy Interface | PowerLanguage Namespace


IStudy.TPOBarsOfData Method

Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.

IInstrumentTPO TPOBarsOfData(
int dataStream
);

See Also

IStudy Interface | PowerLanguage Namespace


IStudyInfo Interface

For a list of all members of this type, see IStudyInfo Members .

public interface IStudyInfo

Types that implement IStudyInfo

Type | Description
CStudyAbstract | Base class for studies.
IndicatorObject | Indicator’s base class (inherit from this class to create an indicator).
PortfolioSignalObject |
SignalObject | Base class for strategies (inherit from SignalObject to create this kind of study).

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IStudyInfo Members | PowerLanguage Namespace


IStudyInfo Members

IStudyInfo overview

Public Instance Methods

GetInputs
GetInputValue
GetMouseEvents
GetRecoverDrawings
SetInputValue

See Also

IStudyInfo Interface | PowerLanguage Namespace


IStudyInfo Methods

The methods of the IStudyInfo interface are listed below. For a complete list of IStudyInfo interface members, see the IStudyInfo Members topic.

Public Instance Methods

GetInputs
GetInputValue
GetMouseEvents
GetRecoverDrawings
SetInputValue

See Also

IStudyInfo Interface | PowerLanguage Namespace


IStudyInfo.GetInputs Method

InputInfo[] GetInputs();

See Also

IStudyInfo Interface | PowerLanguage Namespace


IStudyInfo.GetInputValue Method

object GetInputValue(
string name
);

See Also

IStudyInfo Interface | PowerLanguage Namespace


IStudyInfo.GetMouseEvents Method

bool? GetMouseEvents();

See Also

IStudyInfo Interface | PowerLanguage Namespace


IStudyInfo.GetRecoverDrawings Method

bool? GetRecoverDrawings();

See Also

IStudyInfo Interface | PowerLanguage Namespace


IStudyInfo.SetInputValue Method

void SetInputValue(
string name,
object value
);

See Also

IStudyInfo Interface | PowerLanguage Namespace


ISymbolsStorage Interface

An interface for accessing symbol storage.

For a list of all members of this type, see ISymbolsStorage Members .

public interface ISymbolsStorage : IDisposable

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ISymbolsStorage Members | PowerLanguage Namespace


ISymbolsStorage Members

ISymbolsStorage overview

Public Instance Methods

AddSymbol | Adding symbol to the symbol storage
GetDataFeeds | Returns data feed array.
GetSymbols | Overloaded. Returns symbol array.

See Also

ISymbolsStorage Interface | PowerLanguage Namespace


ISymbolsStorage Methods

The methods of the ISymbolsStorage interface are listed below. For a complete list of ISymbolsStorage interface members, see the ISymbolsStorage Members topic.

Public Instance Methods

AddSymbol | Adding symbol to the symbol storage
GetDataFeeds | Returns data feed array.
GetSymbols | Overloaded. Returns symbol array.

See Also

ISymbolsStorage Interface | PowerLanguage Namespace


ISymbolsStorage.AddSymbol Method

Adding symbol to the symbol storage

int AddSymbol(
MTPA_MCSymbolInfo2 symbol_info,
string data_feed,
ESymbolSettingsType settings_type
);

Parameters

symbol_info
Structure with the paramaters of the symbol that is being added
data_feed
Data source name of the symbol that is being added
settings_type
Settings type of the symbol that is being added (custom, exchange or dictionary)

Return Value

Returns ID of the symbol that is being added

See Also

ISymbolsStorage Interface | PowerLanguage Namespace


ISymbolsStorage.GetDataFeeds Method

Returns data feed array.

string[] GetDataFeeds();

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace


GetSymbols Method

PowerLanguage.NET Help

ISymbolsStorage.GetSymbols Method

Returns symbol array.

Overload List

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(string)

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(string,ESymbolCategory)

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(string,ESymbolCategory,string)

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(string,string)

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(string,string,ESymbolCategory)

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(string,string,ESymbolCategory,string)

See Also

ISymbolsStorage Interface | PowerLanguage Namespace


ISymbolsStorage.GetSymbols(String) Method

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(
string data_feed
);

Parameters

data_feed
Data feed name.

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace | ISymbolsStorage.GetSymbols Overload List


ISymbolsStorage.GetSymbols(String, ESymbolCategory) Method

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(
string data_feed,
ESymbolCategory _cat
);

Parameters

data_feed
Data feed name.
_cat
Symbol category.

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace | ISymbolsStorage.GetSymbols Overload List


ISymbolsStorage.GetSymbols(String, ESymbolCategory, String) Method

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(
string data_feed,
ESymbolCategory _cat,
string Exchange
);

Parameters

data_feed
Data feed name.
_cat
Symbol category.
Exchange
Symbol exchange.

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace | ISymbolsStorage.GetSymbols Overload List


ISymbolsStorage.GetSymbols(String, String) Method

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(
string data_feed,
string name
);

Parameters

data_feed
Data feed name.
name
Symbol name.

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace | ISymbolsStorage.GetSymbols Overload List


ISymbolsStorage.GetSymbols(String, String, ESymbolCategory) Method

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(
string data_feed,
string name,
ESymbolCategory _cat
);

Parameters

data_feed
Data feed name.
name
Symbol name.
_cat
Symbol category.

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace | ISymbolsStorage.GetSymbols Overload List


ISymbolsStorage.GetSymbols(String, String, ESymbolCategory, String) Method

Returns symbol array.

MTPA_MCSymbolInfo2[] GetSymbols(
string data_feed,
string name,
ESymbolCategory _cat,
string Exchange
);

Parameters

data_feed
Data feed name.
name
Symbol name.
_cat
Symbol category.
Exchange
Symbol exchange.

Return Value

See Also

ISymbolsStorage Interface | PowerLanguage Namespace | ISymbolsStorage.GetSymbols Overload List


ITextContainer Interface

Container for ITextObject.

For a list of all members of this type, see ITextContainer Members .

public interface ITextContainer

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITextContainer Members | PowerLanguage Namespace


ITextContainer Members

ITextContainer overview

Public Instance Properties

Active Read-only property. Returns an interface to the active TextDrawing, if any; otherwise returns 'nullptr'.

Public Instance Methods

Create | Overloaded. Creates a Text Drawings with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.
GetTextObjects | A method for accessing collection’s elements using foreach.

See Also

ITextContainer Interface | PowerLanguage Namespace


ITextContainer Properties

The properties of the ITextContainer interface are listed below. For a complete list of ITextContainer interface members, see the ITextContainer Members topic.

Public Instance Properties

Active Read-only property. Returns an interface to the active TextDrawing, if any; otherwise returns 'nullptr'.

See Also

ITextContainer Interface | PowerLanguage Namespace


Active Property

PowerLanguage.NET Help

ITextContainer.Active Property

Read-only property. Returns an interface to the active TextDrawing, if any; otherwise returns 'nullptr'.

public ITextObject Active { public get; }

See Also

ITextContainer Interface | PowerLanguage Namespace


ITextContainer Methods

The methods of the ITextContainer interface are listed below. For a complete list of ITextContainer interface members, see the ITextContainer Members topic.

Public Instance Methods

Create | Overloaded. Creates a Text Drawings with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.
GetTextObjects | A method for accessing collection’s elements using foreach.

See Also

ITextContainer Interface | PowerLanguage Namespace


Create Method

PowerLanguage.NET Help

ITextContainer.Create Method

Creates a Text Drawing with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

Overload List

Creates a Text Drawing with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

ITextObject Create(ChartPoint,string)

Creates a Text Drawing with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

ITextObject Create(ChartPoint,string,bool)

Creates a Text Drawings with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

ITextObject Create(ChartPoint,string,int)

See Also

ITextContainer Interface | PowerLanguage Namespace


ITextContainer.Create(ChartPoint, String) Method

Creates a Text Drawing with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

ITextObject Create(
ChartPoint point,
string text
);

Parameters

point
The point on the chart at which to create a text drawing.
text
Text string.

Return Value

An instance of the interface describing text object.

See Also

ITextContainer Interface | PowerLanguage Namespace | ITextContainer.Create Overload List


ITextContainer.Create(ChartPoint, String, Boolean) Method

Creates a Text Drawing with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

ITextObject Create(
ChartPoint point,
string text,
bool onSameSubchart
);

Parameters

point
The point on the chart at which to create a text drawing.
text
Text string.
onSameSubchart
By default: false

Return Value

An instance of the interface describing text object.

See Also

ITextContainer Interface | PowerLanguage Namespace | ITextContainer.Create Overload List


ITextContainer.Create(ChartPoint, String, Int32) Method

Creates a Text Drawings with point coordinates, '_text' text, '_data_stream' number data stream, and '_on_same_subchart' flag.

ITextObject Create(
ChartPoint point,
string text,
int dataStream
);

Parameters

point
The point on the chart at which to create a text drawing.
text
Text string.
dataStream
Data stream number. By default: 0

Return Value

An instance of the interface describing text object.

See Also

ITextContainer Interface | PowerLanguage Namespace | ITextContainer.Create Overload List


ITextContainer.GetTextObjects Method

A method for accessing collection’s elements using foreach.

IEnumerable<ITextObject> GetTextObjects(
EDrawingSource drawingSource
);

Parameters

drawingSource
By default: AnyTechOrManual

Return Value

See Also

ITextContainer Interface | PowerLanguage Namespace


ITextObject Interface

An interface for accessing Text Drawings.

For a list of all members of this type, see ITextObject Members .

public interface ITextObject : IDrawObject, IEquatable<IDrawObject>, IEquatable<ITextObject>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITextObject Members | PowerLanguage Namespace


ITextObject Members

ITextObject overview

Public Instance Properties

BGColor | Background Color get/set property.
Border | Text Drawing border get/set property.
Color | Text Drawing color get/set property.
FontName | Font name get/set property.
HStyle | Text Drawing horizontal text style get/set property. Right = 0, Left = 1, Center = 2
Location | Text Drawing current placement (date, time, and price) get/set property.
Size | Text Drawing size get/set property.
Text | Drawing’s text get/set property.
VStyle | Text Drawing vertical text style get/set property. Below = 0, Above = 1, Center = 2

Public Instance Methods

HaveFont | A method for requesting drawing’s font style.
SetFont | A method for setting drawing’s font style.

See Also

ITextObject Interface | PowerLanguage Namespace


ITextObject Properties

The properties of the ITextObject interface are listed below. For a complete list of ITextObject interface members, see the ITextObject Members topic.

Public Instance Properties

BGColor | Background Color get/set property.
Border | Text Drawing border get/set property.
Color | Text Drawing color get/set property.
FontName | Font name get/set property.
HStyle | Text Drawing horizontal text style get/set property. Right = 0, Left = 1, Center = 2
Location | Text Drawing current placement (date, time, and price) get/set property.
Size | Text Drawing size get/set property.
Text | Drawing’s text get/set property.
VStyle | Text Drawing vertical text style get/set property. Below = 0, Above = 1, Center = 2

See Also

ITextObject Interface | PowerLanguage Namespace


BGColor Property

PowerLanguage.NET Help

ITextObject.BGColor Property

Background Color get/set property.

public Color BGColor { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


Border Property

PowerLanguage.NET Help

ITextObject.Border Property

Text Drawing border get/set property.

public bool Border { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


Color Property

PowerLanguage.NET Help

ITextObject.Color Property

Text Drawing color get/set property.

public Color Color { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


FontName Property

PowerLanguage.NET Help

ITextObject.FontName Property

Font name get/set property.

public string FontName { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


HStyle Property

PowerLanguage.NET Help

ITextObject.HStyle Property

Text Drawing horizontal text style get/set property. Right = 0, Left = 1, Center = 2

public ETextStyleH HStyle { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


Location Property

PowerLanguage.NET Help

ITextObject.Location Property

Text Drawing current placement (date, time, and price) get/set property.

public ChartPoint Location { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


Size Property

PowerLanguage.NET Help

ITextObject.Size Property

Text Drawing size get/set property.

public int Size { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


Text Property

PowerLanguage.NET Help

ITextObject.Text Property

Drawing’s text get/set property.

public string Text { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


VStyle Property

PowerLanguage.NET Help

ITextObject.VStyle Property

Text Drawing vertical text style get/set property. Below = 0, Above = 1, Center = 2

public ETextStyleV VStyle { public get; public set; }

See Also

ITextObject Interface | PowerLanguage Namespace


ITextObject Methods

The methods of the ITextObject interface are listed below. For a complete list of ITextObject interface members, see the ITextObject Members topic.

Public Instance Methods

HaveFont | A method for requesting drawing’s font style.
SetFont | A method for setting drawing’s font style.

See Also

ITextObject Interface | PowerLanguage Namespace


ITextObject.HaveFont Method

A method for requesting drawing’s font style.

bool HaveFont(
FontStyle style
);

Parameters

style
The requested drawing’s font style.

Return Value

Indicates whether there is a requested font style in the text object.

See Also

ITextObject Interface | PowerLanguage Namespace


ITextObject.SetFont Method

A method for setting drawing’s font style.

void SetFont(
FontStyle style,
bool val
);

Parameters

style
Text object font style.
val
Drawing’s font style value.

See Also

ITextObject Interface | PowerLanguage Namespace


ITPOData Interface

Interface for TPO data access.

For a list of all members of this type, see ITPOData Members .

PowerLanguage.ITPOData
PowerLanguage.IInstrumentTPO
PowerLanguage.ITPODataRand

public interface ITPOData

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITPOData Members | PowerLanguage Namespace


ITPOData Members

ITPOData overview

Public Instance Properties

LevelHigh | TODO:
LevelLow | TODO:
LevelsCount | TPO levels count
POCBlocks | TODO:
POCPrice | TODO:

Public Instance Methods

BlocksByPrice | Overloaded. TODO:
SymbolBlocksByPrice | Overloaded. TODO:

See Also

ITPOData Interface | PowerLanguage Namespace


ITPOData Properties

The properties of the ITPOData interface are listed below. For a complete list of ITPOData interface members, see the ITPOData Members topic.

Public Instance Properties

LevelHigh | TODO:
LevelLow | TODO:
LevelsCount | TPO levels count
POCBlocks | TODO:
POCPrice | TODO:

See Also

ITPOData Interface | PowerLanguage Namespace


LevelHigh Property

PowerLanguage.NET Help

ITPOData.LevelHigh Property

TODO:

public ISeries<double> LevelHigh { public get; }

See Also

ITPOData Interface | PowerLanguage Namespace


LevelLow Property

PowerLanguage.NET Help

ITPOData.LevelLow Property

TODO:

public ISeries<double> LevelLow { public get; }

See Also

ITPOData Interface | PowerLanguage Namespace


LevelsCount Property

PowerLanguage.NET Help

ITPOData.LevelsCount Property

TPO levels count

public ISeries<int> LevelsCount { public get; }

See Also

ITPOData Interface | PowerLanguage Namespace


POCBlocks Property

PowerLanguage.NET Help

ITPOData.POCBlocks Property

TODO:

public ISeries<int> POCBlocks { public get; }

See Also

ITPOData Interface | PowerLanguage Namespace


POCPrice Property

PowerLanguage.NET Help

ITPOData.POCPrice Property

TODO:

public ISeries<double> POCPrice { public get; }

See Also

ITPOData Interface | PowerLanguage Namespace


ITPOData Methods

The methods of the ITPOData interface are listed below. For a complete list of ITPOData interface members, see the ITPOData Members topic.

Public Instance Methods

BlocksByPrice | Overloaded. TODO:
SymbolBlocksByPrice | Overloaded. TODO:

See Also

ITPOData Interface | PowerLanguage Namespace


BlocksByPrice Method

PowerLanguage.NET Help

ITPOData.BlocksByPrice Method

TODO:

Overload List

TODO:

int BlocksByPrice(double,int)

TODO:

int BlocksByPrice(double,int,int)

See Also

ITPOData Interface | PowerLanguage Namespace


ITPOData.BlocksByPrice(Double, Int32) Method

TODO:

int BlocksByPrice(
double Price,
int barsback
);

See Also

ITPOData Interface | PowerLanguage Namespace | ITPOData.BlocksByPrice Overload List


ITPOData.BlocksByPrice(Double, Int32, Int32) Method

TODO:

int BlocksByPrice(
double Price,
int barsback,
int dataNum
);

See Also

ITPOData Interface | PowerLanguage Namespace | ITPOData.BlocksByPrice Overload List


SymbolBlocksByPrice Method

PowerLanguage.NET Help

ITPOData.SymbolBlocksByPrice Method

TODO:

Overload List

TODO:

int SymbolBlocksByPrice(double,int)

TODO:

int SymbolBlocksByPrice(double,int,int)

See Also

ITPOData Interface | PowerLanguage Namespace


ITPOData.SymbolBlocksByPrice(Double, Int32) Method

TODO:

int SymbolBlocksByPrice(
double Price,
int barNum
);

See Also

ITPOData Interface | PowerLanguage Namespace | ITPOData.SymbolBlocksByPrice Overload List


ITPOData.SymbolBlocksByPrice(Double, Int32, Int32) Method

TODO:

int SymbolBlocksByPrice(
double Price,
int barNum,
int dataNum
);

See Also

ITPOData Interface | PowerLanguage Namespace | ITPOData.SymbolBlocksByPrice Overload List


ITPODataRand Interface

Interface for access to symbol's TPO data of any bar (no Max Number of Bar Reference limits).

For a list of all members of this type, see ITPODataRand Members .

public interface ITPODataRand : ITPOData

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITPODataRand Members | PowerLanguage Namespace


ITPODataRand Members

ITPODataRand overview

Public Instance Properties

CountTPO | Read-only property. Returns series bars count.
CurrentTPO | Read-only property. Returns symbol's current bar number. Start from 1 to Count. Do not include original CurrentBar when calculating Max Number of Bar Reference offset.

See Also

ITPODataRand Interface | PowerLanguage Namespace


ITPODataRand Properties

The properties of the ITPODataRand interface are listed below. For a complete list of ITPODataRand interface members, see the ITPODataRand Members topic.

Public Instance Properties

CountTPO | Read-only property. Returns series bars count.
CurrentTPO | Read-only property. Returns symbol's current bar number. Start from 1 to Count. Do not include original CurrentBar when calculating Max Number of Bar Reference offset.

See Also

ITPODataRand Interface | PowerLanguage Namespace


CountTPO Property

PowerLanguage.NET Help

ITPODataRand.CountTPO Property

Read-only property. Returns series bars count.

public int CountTPO { public get; }

See Also

ITPODataRand Interface | PowerLanguage Namespace


CurrentTPO Property

PowerLanguage.NET Help

ITPODataRand.CurrentTPO Property

Read-only property. Returns symbol's current bar number. Start from 1 to Count. Do not include original CurrentBar when calculating Max Number of Bar Reference offset.

public int CurrentTPO { public get; }

See Also

ITPODataRand Interface | PowerLanguage Namespace


ITPODynamicSettings Interface

Interface for accessing the dynamically retrievable settings of the TPO charts.

For a list of all members of this type, see ITPODynamicSettings Members .

public interface ITPODynamicSettings

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITPODynamicSettings Members | PowerLanguage Namespace


ITPODynamicSettings Members

ITPODynamicSettings overview

Public Instance Properties

InitialBalanceRange | Current Initial Balance Range value on TPO chart (the number of starting TPO intervals).
PriceIncrement | Current Price Increment on TPO chart.
ShowBlocksWithZeroTrades | Current Show Blocks with Zero Range value on TPO chart.
ValueArea | Current Value Area value on TPO chart (in percentages).
ValueArea2 | Current Value Area 2 value on TPO chart (in percentages).

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


ITPODynamicSettings Properties

The properties of the ITPODynamicSettings interface are listed below. For a complete list of ITPODynamicSettings interface members, see the ITPODynamicSettings Members topic.

Public Instance Properties

InitialBalanceRange | Current Initial Balance Range value on TPO chart (the number of starting TPO intervals).
PriceIncrement | Current Price Increment on TPO chart.
ShowBlocksWithZeroTrades | Current Show Blocks with Zero Range value on TPO chart.
ValueArea | Current Value Area value on TPO chart (in percentages).
ValueArea2 | Current Value Area 2 value on TPO chart (in percentages).

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


InitialBalanceRange Property

PowerLanguage.NET Help

ITPODynamicSettings.InitialBalanceRange Property

Current Initial Balance Range value on TPO chart (the number of starting TPO intervals).

public int InitialBalanceRange { public get; }

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


PriceIncrement Property

PowerLanguage.NET Help

ITPODynamicSettings.PriceIncrement Property

Current Price Increment on TPO chart.

public long PriceIncrement { public get; }

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


ShowBlocksWithZeroTrades Property

PowerLanguage.NET Help

ITPODynamicSettings.ShowBlocksWithZeroTrades Property

Current Show Blocks with Zero Range value on TPO chart.

public bool ShowBlocksWithZeroTrades { public get; }

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


ValueArea Property

PowerLanguage.NET Help

ITPODynamicSettings.ValueArea Property

Current Value Area value on TPO chart (in percentages).

public int ValueArea { public get; }

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


ValueArea2 Property

PowerLanguage.NET Help

ITPODynamicSettings.ValueArea2 Property

Current Value Area 2 value on TPO chart (in percentages).

public int ValueArea2 { public get; }

See Also

ITPODynamicSettings Interface | PowerLanguage Namespace


ITPOSettings Interface

Interface for TPO settings access.

For a list of all members of this type, see ITPOSettings Members .

public interface ITPOSettings

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITPOSettings Members | PowerLanguage Namespace


ITPOSettings Members

ITPOSettings overview

Public Instance Properties

Base | TODO:
IsTPOResolution | TODO:
PeriodSize | TODO:
PeriodType | TODO:
PriceIncrement | TODO:
TPOTickSize | TODO:

See Also

ITPOSettings Interface | PowerLanguage Namespace


ITPOSettings Properties

The properties of the ITPOSettings interface are listed below. For a complete list of ITPOSettings interface members, see the ITPOSettings Members topic.

Public Instance Properties

Base | TODO:
IsTPOResolution | TODO:
PeriodSize | TODO:
PeriodType | TODO:
PriceIncrement | TODO:
TPOTickSize | TODO:

See Also

ITPOSettings Interface | PowerLanguage Namespace


Base Property

PowerLanguage.NET Help

ITPOSettings.Base Property

TODO:

public TPOBase Base { public get; }

See Also

ITPOSettings Interface | PowerLanguage Namespace


IsTPOResolution Property

PowerLanguage.NET Help

ITPOSettings.IsTPOResolution Property

TODO:

public bool IsTPOResolution { public get; }

See Also

ITPOSettings Interface | PowerLanguage Namespace


PeriodSize Property

PowerLanguage.NET Help

ITPOSettings.PeriodSize Property

TODO:

public int PeriodSize { public get; }

See Also

ITPOSettings Interface | PowerLanguage Namespace


PeriodType Property

PowerLanguage.NET Help

ITPOSettings.PeriodType Property

TODO:

public EResolution PeriodType { public get; }

See Also

ITPOSettings Interface | PowerLanguage Namespace


PriceIncrement Property

PowerLanguage.NET Help

ITPOSettings.PriceIncrement Property

TODO:

public int PriceIncrement { public get; }

See Also

ITPOSettings Interface | PowerLanguage Namespace


TPOTickSize Property

PowerLanguage.NET Help

ITPOSettings.TPOTickSize Property

TODO:

public double TPOTickSize { public get; }

See Also

ITPOSettings Interface | PowerLanguage Namespace


ITrade Interface

An interface for accessing trade’s information.

For a list of all members of this type, see ITrade Members .

public interface ITrade

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITrade Members | PowerLanguage Namespace


ITrade Members

ITrade overview

Public Instance Properties

CommissionValue | Read-only property. Returns trade’s commission.
EntryOrder | Read-only property. Returns trade’s entry-order.
ExitOrder | Read-only property. Returns trade’s exit-order. Null, if trade is still open.
IsLong | Read-only property. Indicates if trade’s entry order is a long entry (Buy action).
IsOpen | Read-only property. Indicates if trade is open.
Profit | Read-only property. Returns trade’s profit.

See Also

ITrade Interface | PowerLanguage Namespace


ITrade Properties

The properties of the ITrade interface are listed below. For a complete list of ITrade interface members, see the ITrade Members topic.

Public Instance Properties

CommissionValue | Read-only property. Returns trade’s commission.
EntryOrder | Read-only property. Returns trade’s entry-order.
ExitOrder | Read-only property. Returns trade’s exit-order. Null, if trade is still open.
IsLong | Read-only property. Indicates if trade’s entry order is a long entry (Buy action).
IsOpen | Read-only property. Indicates if trade is open.
Profit | Read-only property. Returns trade’s profit.

See Also

ITrade Interface | PowerLanguage Namespace


CommissionValue Property

PowerLanguage.NET Help

ITrade.CommissionValue Property

Read-only property. Returns trade’s commission.

public double CommissionValue { public get; }

See Also

ITrade Interface | PowerLanguage Namespace


EntryOrder Property

PowerLanguage.NET Help

ITrade.EntryOrder Property

Read-only property. Returns trade’s entry-order.

public ITradeOrder EntryOrder { public get; }

See Also

ITrade Interface | PowerLanguage Namespace


ExitOrder Property

PowerLanguage.NET Help

ITrade.ExitOrder Property

Read-only property. Returns trade’s exit-order. Null, if trade is still open.

public ITradeOrder ExitOrder { public get; }

See Also

ITrade Interface | PowerLanguage Namespace


IsLong Property

PowerLanguage.NET Help

ITrade.IsLong Property

Read-only property. Indicates if trade’s entry order is a long entry (Buy action).

public bool IsLong { public get; }

See Also

ITrade Interface | PowerLanguage Namespace


IsOpen Property

PowerLanguage.NET Help

ITrade.IsOpen Property

Read-only property. Indicates if trade is open.

public bool IsOpen { public get; }

See Also

ITrade Interface | PowerLanguage Namespace


Profit Property

PowerLanguage.NET Help

ITrade.Profit Property

Read-only property. Returns trade’s profit.

public double Profit { public get; }

See Also

ITrade Interface | PowerLanguage Namespace


ITradeOrder Interface

An entry-point interface to information on trade’s orders (access to entry and exit of the trade).

For a list of all members of this type, see ITradeOrder Members .

public interface ITradeOrder

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITradeOrder Members | PowerLanguage Namespace


ITradeOrder Members

ITradeOrder overview

Public Instance Properties

Action | Read-only property. Enumerator with following values: Buy, Sell, SellShort, BuyToCover.
BarNumber | Read-only property. Order executions bar's number.
Category | Read-only property. Enumerator with following values: Market, MarketRange, Limit, Stop.
Contracts | Read-only property. Trade volume.
Name | Read-only property. Order name.
Price | Read-only property. Order execution price.
Time | Read-only property. Order execution bar's time.

See Also

ITradeOrder Interface | PowerLanguage Namespace


ITradeOrder Properties

The properties of the ITradeOrder interface are listed below. For a complete list of ITradeOrder interface members, see the ITradeOrder Members topic.

Public Instance Properties

Action | Read-only property. Enumerator with following values: Buy, Sell, SellShort, BuyToCover.
BarNumber | Read-only property. Order executions bar's number.
Category | Read-only property. Enumerator with following values: Market, MarketRange, Limit, Stop.
Contracts | Read-only property. Trade volume.
Name | Read-only property. Order name.
Price | Read-only property. Order execution price.
Time | Read-only property. Order execution bar's time.

See Also

ITradeOrder Interface | PowerLanguage Namespace


Action Property

PowerLanguage.NET Help

ITradeOrder.Action Property

Read-only property. Enumerator with following values: Buy, Sell, SellShort, BuyToCover.

public EOrderAction Action { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


BarNumber Property

PowerLanguage.NET Help

ITradeOrder.BarNumber Property

Read-only property. Order executions bar's number.

public int BarNumber { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


Category Property

PowerLanguage.NET Help

ITradeOrder.Category Property

Read-only property. Enumerator with following values: Market, MarketRange, Limit, Stop.

public OrderCategory Category { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


Contracts Property

PowerLanguage.NET Help

ITradeOrder.Contracts Property

Read-only property. Trade volume.

public int Contracts { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

ITradeOrder.Name Property

Read-only property. Order name.

public string Name { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


Price Property

PowerLanguage.NET Help

ITradeOrder.Price Property

Read-only property. Order execution price.

public double Price { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

ITradeOrder.Time Property

Read-only property. Order execution bar's time.

public DateTime Time { public get; }

See Also

ITradeOrder Interface | PowerLanguage Namespace


ITrendLineContainer Interface

Container for ITrendLineObject collection.

For a list of all members of this type, see ITrendLineContainer Members .

public interface ITrendLineContainer

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITrendLineContainer Members | PowerLanguage Namespace


ITrendLineContainer Members

ITrendLineContainer overview

Public Instance Properties

Active Read-only property. Active ITrendLineObject access interface, if any; nullptr otherwise.

Public Instance Methods

Create | Overloaded. Creates a TrendLine with '_start','_end' coordinates and '_data_stream' number data stream.
GetTrendLineObjects | A method for accessing collection’s elements using foreach.

See Also

ITrendLineContainer Interface | PowerLanguage Namespace


ITrendLineContainer Properties

The properties of the ITrendLineContainer interface are listed below. For a complete list of ITrendLineContainer interface members, see the ITrendLineContainer Members topic.

Public Instance Properties

Active Read-only property. Active ITrendLineObject access interface, if any; nullptr otherwise.

See Also

ITrendLineContainer Interface | PowerLanguage Namespace


Active Property

PowerLanguage.NET Help

ITrendLineContainer.Active Property

Read-only property. Active ITrendLineObject access interface, if any; nullptr otherwise.

public ITrendLineObject Active { public get; }

See Also

ITrendLineContainer Interface | PowerLanguage Namespace


ITrendLineContainer Methods

The methods of the ITrendLineContainer interface are listed below. For a complete list of ITrendLineContainer interface members, see the ITrendLineContainer Members topic.

Public Instance Methods

Create | Overloaded. Creates a TrendLine with '_start','_end' coordinates and '_data_stream' number data stream.
GetTrendLineObjects | A method for accessing collection’s elements using foreach.

See Also

ITrendLineContainer Interface | PowerLanguage Namespace


Create Method

PowerLanguage.NET Help

ITrendLineContainer.Create Method

Creates a TrendLine with '_start','_end' coordinates.

Overload List

Creates a TrendLine with '_start','_end' coordinates.

ITrendLineObject Create(ChartPoint,ChartPoint)

Creates a TrendLine with '_start','_end' coordinates and '_on_same_subchart' flag.

ITrendLineObject Create(ChartPoint,ChartPoint,bool)

Creates a TrendLine with '_start','_end' coordinates and '_data_stream' number data stream.

ITrendLineObject Create(ChartPoint,ChartPoint,int)

See Also

ITrendLineContainer Interface | PowerLanguage Namespace


ITrendLineContainer.Create(ChartPoint, ChartPoint) Method

Creates a TrendLine with '_start','_end' coordinates.

ITrendLineObject Create(
ChartPoint start,
ChartPoint end
);

Parameters

start
TrendLine's start point.
end
TrendLine's end point.

Return Value

An instance of the interface describing TrendLine object.

See Also

ITrendLineContainer Interface | PowerLanguage Namespace | ITrendLineContainer.Create Overload List


ITrendLineContainer.Create(ChartPoint, ChartPoint, Boolean) Method

Creates a TrendLine with '_start','_end' coordinates and '_on_same_subchart' flag.

ITrendLineObject Create(
ChartPoint start,
ChartPoint end,
bool onSameSubchart
);

Parameters

start
TrendLine's start point.
end
TrendLine's end point.
onSameSubchart
By default: false

Return Value

An instance of the interface describing TrendLine object.

See Also

ITrendLineContainer Interface | PowerLanguage Namespace | ITrendLineContainer.Create Overload List


ITrendLineContainer.Create(ChartPoint, ChartPoint, Int32) Method

Creates a TrendLine with '_start','_end' coordinates and '_data_stream' number data stream.

ITrendLineObject Create(
ChartPoint start,
ChartPoint end,
int dataStream
);

Parameters

start
TrendLine's start point.
end
TrendLine's end point.
dataStream
Data stream number. By default: 0

Return Value

An instance of the interface describing TrendLine object.

See Also

ITrendLineContainer Interface | PowerLanguage Namespace | ITrendLineContainer.Create Overload List


ITrendLineContainer.GetTrendLineObjects Method

A method for accessing collection’s elements using foreach.

IEnumerable<ITrendLineObject> GetTrendLineObjects(
EDrawingSource drawingSource
);

Parameters

drawingSource
By default: AnyTechOrManual

Return Value

See Also

ITrendLineContainer Interface | PowerLanguage Namespace


ITrendLineObject Interface

TrendLine Drawing access interface.

For a list of all members of this type, see ITrendLineObject Members .

public interface ITrendLineObject : IDrawObject, IEquatable<IDrawObject>, IEquatable<ITrendLineObject>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ITrendLineObject Members | PowerLanguage Namespace


ITrendLineObject Members

ITrendLineObject overview

Public Instance Properties

Alert | Get/set property for alert status. Disabled = 0, BreakoutIntrabar = 1, BreakoutOnClose = 2.
Begin | Get/set property for '_start' coordinate of TrendLine.
Color | Get/set property for TrendLine color.
End | Get/set property for '_end' coordinate of TrendLine.
ExtLeft | Get/set property for the Extended properties to the left.
ExtRight | Get/set property for the Extended properties to the right.
Size | Get/set property for TrendLine width.
Style | Get/set property for TrendLine style. ToolSolid = 1, ToolDashed = 2, ToolDotted = 3, ToolDashed2 = 4, ToolDashed3 = 5.

Public Instance Methods

PriceValue A function returning price value by DateTime.

See Also

ITrendLineObject Interface | PowerLanguage Namespace


ITrendLineObject Properties

The properties of the ITrendLineObject interface are listed below. For a complete list of ITrendLineObject interface members, see the ITrendLineObject Members topic.

Public Instance Properties

Alert | Get/set property for alert status. Disabled = 0, BreakoutIntrabar = 1, BreakoutOnClose = 2.
Begin | Get/set property for '_start' coordinate of TrendLine.
Color | Get/set property for TrendLine color.
End | Get/set property for '_end' coordinate of TrendLine.
ExtLeft | Get/set property for the Extended properties to the left.
ExtRight | Get/set property for the Extended properties to the right.
Size | Get/set property for TrendLine width.
Style | Get/set property for TrendLine style. ToolSolid = 1, ToolDashed = 2, ToolDotted = 3, ToolDashed2 = 4, ToolDashed3 = 5.

See Also

ITrendLineObject Interface | PowerLanguage Namespace


Alert Property

PowerLanguage.NET Help

ITrendLineObject.Alert Property

Get/set property for alert status. Disabled = 0, BreakoutIntrabar = 1, BreakoutOnClose = 2.

public EAlertType Alert { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


Begin Property

PowerLanguage.NET Help

ITrendLineObject.Begin Property

Get/set property for '_start' coordinate of TrendLine.

public ChartPoint Begin { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


Color Property

PowerLanguage.NET Help

ITrendLineObject.Color Property

Get/set property for TrendLine color.

public Color Color { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


End Property

PowerLanguage.NET Help

ITrendLineObject.End Property

Get/set property for '_end' coordinate of TrendLine.

public ChartPoint End { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


ExtLeft Property

PowerLanguage.NET Help

ITrendLineObject.ExtLeft Property

Get/set property for the Extended properties to the left.

public bool ExtLeft { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


ExtRight Property

PowerLanguage.NET Help

ITrendLineObject.ExtRight Property

Get/set property for the Extended properties to the right.

public bool ExtRight { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


Size Property

PowerLanguage.NET Help

ITrendLineObject.Size Property

Get/set property for TrendLine width.

public int Size { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


Style Property

PowerLanguage.NET Help

ITrendLineObject.Style Property

Get/set property for TrendLine style. ToolSolid = 1, ToolDashed = 2, ToolDotted = 3, ToolDashed2 = 4, ToolDashed3 = 5.

public ETLStyle Style { public get; public set; }

See Also

ITrendLineObject Interface | PowerLanguage Namespace


ITrendLineObject Methods

The methods of the ITrendLineObject interface are listed below. For a complete list of ITrendLineObject interface members, see the ITrendLineObject Members topic.

Public Instance Methods

PriceValue A function returning price value by DateTime.

See Also

ITrendLineObject Interface | PowerLanguage Namespace


ITrendLineObject.PriceValue Method

A function returning price value by DateTime.

double PriceValue(
DateTime dateTime
);

Parameters

dateTime
DateTime value for requested price value.

Return Value

Price value for specified DateTime.

See Also

ITrendLineObject Interface | PowerLanguage Namespace


IVar<T> Interface

The base interface for variables.

For a list of all members of this type, see IVar<T> Members .

public interface IVar<T> : ISeries<T>

Types that implement IVar<T>

Type | Description
LambdaRef<T> | The lambda implementation of IVar.
VariableObject<T> | Class for simple variables, provides access to the value of the variable in the current context of study execution.
VariableSeries<T> | Class that allows access to and preserves historical variable values (for a series of variables).

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

IVar<T> Members | PowerLanguage Namespace


IVar<T> Members

IVar<T> overview

Public Instance Properties

DefaultValue | Read-only propertry. Returns default value.
Value | Read-write property for accessing the value of the variable.

See Also

IVar<T> Interface | PowerLanguage Namespace


IVar<T> Properties

The properties of the IVar<T> interface are listed below. For a complete list of IVar<T> interface members, see the IVar<T> Members topic.

Public Instance Properties

DefaultValue | Read-only propertry. Returns default value.
Value | Read-write property for accessing the value of the variable.

See Also

IVar<T> Interface | PowerLanguage Namespace


DefaultValue Property

PowerLanguage.NET Help

IVar`1.DefaultValue Property

Read-only propertry. Returns default value.

public T DefaultValue { public set; }

See Also

IVar<T> Interface | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

IVar`1.Value Property

Read-write property for accessing the value of the variable.

public T Value { public get; public set; }

See Also

IVar<T> Interface | PowerLanguage Namespace


KagiOptions Enumeration

Enumeration represents options for Kagi chart type.

public enum KagiOptions

Members

Member Name | Description
REVERSAL_VALUE | Reversal fixed.
REVERSAL_TYPE | Reversal type.
REVERSAL_PERCENT | Reversal percent.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


KagiReversalType Enumeration

Enumeration represents the reversal type of Kagi chart.

public enum KagiReversalType

Members

Member Name | Description
FIXEDPRICE | Fixed price reversal.
PERCENT | Percent reversal.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


Lambda<T> Class

The lambda implementation of ISeries.

For a list of all members of this type, see Lambda<T> Members .

System.Object
Lambda<T>

[DefaultMember(MemberName="Item")]
public sealed class Lambda<T> : ISeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Lambda<T> Members | PowerLanguage Namespace


Lambda<T> Members

Lambda<T> overview

Public Instance Constructors

Lambda<T> Constructor Initializes a new instance of the Lambda.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | Read-only property. Returns series value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Lambda<T> Class | PowerLanguage Namespace


Lambda<T> Constructor

Initializes a new instance of the Lambda.

Lambda<T>(
GetLambda<T> expr
);

Parameters

expr
Lambda expression.

See Also

Lambda<T> Class | PowerLanguage Namespace


Lambda<T> Properties

The properties of the Lambda<T> class are listed below. For a complete list of Lambda<T> class members, see the Lambda<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | Read-only property. Returns series value.

See Also

Lambda<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

Lambda`1.Item Property

Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

public T this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression, specifying the number of bars back.

Implements

ISeries<T>.Item

See Also

Lambda<T> Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

Lambda`1.Value Property

Read-only property. Returns series value.

public T Value { public get; }

Implements

ISeries<T>.Value

See Also

Lambda<T> Class | PowerLanguage Namespace


LambdaRef<T> Class

The lambda implementation of IVar.

For a list of all members of this type, see LambdaRef<T> Members .

System.Object
LambdaRef<T>

[DefaultMember(MemberName="Item")]
public sealed class LambdaRef<T> : IVar<T>, ISeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

LambdaRef<T> Members | PowerLanguage Namespace


LambdaRef<T> Members

LambdaRef<T> overview

Public Instance Constructors

LambdaRef<T> Constructor Initializes a new instance of the LambdaRef.

Public Instance Properties

Item Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LambdaRef<T> Class | PowerLanguage Namespace


LambdaRef<T> Constructor

Initializes a new instance of the LambdaRef.

LambdaRef<T>(
GetLambda<T> getExpression,
SetLambda<T> setExpression
);

Parameters

getExpression
GetLambda expression.
setExpression
SetLambda expression.

See Also

LambdaRef<T> Class | PowerLanguage Namespace


LambdaRef<T> Properties

The properties of the LambdaRef<T> class are listed below. For a complete list of LambdaRef<T> class members, see the LambdaRef<T> Members topic.

Public Instance Properties

Item Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

See Also

LambdaRef<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

LambdaRef`1.Item Property

Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

public T this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression specifying the number of bars back.

Implements

ISeries<T>.Item

See Also

LambdaRef<T> Class | PowerLanguage Namespace


LineBreakOptions Enumeration

Enumeration represents options for LineBreak chart type.

public enum LineBreakOptions

Members

Member Name | Description
LINE_BREAK_COUNT | Line Break count.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


LoadDataCallback Delegate

LoadDataCallback delegate.

public delegate void LoadDataCallback(
IDataLoaderResult Result
);

Parameters

Result
Result object.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


MouseClickArgs Structure

The structure that defines mouse-click arguments.

For a list of all members of this type, see MouseClickArgs Members .

System.Object
MouseClickArgs

public struct MouseClickArgs

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

MouseClickArgs Members | PowerLanguage Namespace


MouseClickArgs Members

MouseClickArgs overview

Public Instance Constructors

MouseClickArgs Constructor Initializes a new instance of the MouseClickArgs.

Public Instance Fields

bar_number | Bar number where mouse was pressed.
buttons | Specifies pressed mouse button.
data_number | Data stream number.
keys | Specifies key codes and modifiers.
point | Specifies chart point where mouse was pressed.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs Constructor

Initializes a new instance of the MouseClickArgs.

MouseClickArgs(
Keys keys,
MouseButtons buttons,
ChartPoint point,
int dataNumber,
int barNumber
);

Parameters

keys
Specifies key codes and modifiers.
buttons
Specifies pressed mouse button.
point
Specifies chart point where mouse was pressed.
dataNumber
Data stream number.
barNumber
Bar number where mouse was pressed.

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs Fields

The fields of the MouseClickArgs structure are listed below. For a complete list of MouseClickArgs structure members, see the MouseClickArgs Members topic.

Public Instance Fields

bar_number | Bar number where mouse was pressed.
buttons | Specifies pressed mouse button.
data_number | Data stream number.
keys | Specifies key codes and modifiers.
point | Specifies chart point where mouse was pressed.

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs.bar_number Field

Bar number where mouse was pressed.

public int bar_number;

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs.buttons Field

Specifies pressed mouse button.

public MouseButtons buttons;

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs.data_number Field

Data stream number.

public int data_number;

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs.keys Field

Specifies key codes and modifiers.

public Keys keys;

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseClickArgs.point Field

Specifies chart point where mouse was pressed.

public ChartPoint point;

See Also

MouseClickArgs Class | PowerLanguage Namespace


MouseEventsAttribute Class

The class that defines MouseEventsAttribute.

For a list of all members of this type, see MouseEventsAttribute Members .

System.Object
Attribute
MouseEventsAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class MouseEventsAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

MouseEventsAttribute Members | PowerLanguage Namespace


MouseEventsAttribute Members

MouseEventsAttribute overview

Public Instance Constructors

MouseEventsAttribute Overloaded. Initializes a new instance of the MouseEventsAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. MouseEventsAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

MouseEventsAttribute Class | PowerLanguage Namespace


MouseEventsAttribute Constructor

Initializes a new instance of the MouseEventsAttribute class.

Overload List

Initializes a new instance of the MouseEventsAttribute class.

public MouseEventsAttribute()

Initializes a new instance of the MouseEventsAttribute class.

public MouseEventsAttribute(bool)

See Also

MouseEventsAttribute Class | PowerLanguage Namespace


MouseEventsAttribute Constructor

Initializes a new instance of the MouseEventsAttribute class.

MouseEventsAttribute(
bool value
);

Parameters

value
MouseEventsAttribute value.

See Also

MouseEventsAttribute Class | PowerLanguage Namespace | MouseEventsAttribute Constructor Overload List


MouseEventsAttribute Constructor

Initializes a new instance of the MouseEventsAttribute class.

MouseEventsAttribute();

See Also

MouseEventsAttribute Class | PowerLanguage Namespace | MouseEventsAttribute Constructor Overload List


MouseEventsAttribute Properties

The properties of the MouseEventsAttribute class are listed below. For a complete list of MouseEventsAttribute class members, see the MouseEventsAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. MouseEventsAttribute value.

See Also

MouseEventsAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

MouseEventsAttribute.Value Property

Read-write property. MouseEventsAttribute value.

public bool Value { public get; public set; }

See Also

MouseEventsAttribute Class | PowerLanguage Namespace


OptionType Enumeration

Enumeration that describes option type.

public enum OptionType

Members

Member Name | Description
Call | Option type is CALL
Put | Option type is PUT

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


Order Class

Class that contains information about the order.

For a list of all members of this type, see Order Members .

System.Object
Order

public sealed class Order

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Order Members | PowerLanguage Namespace


Order Members

Order overview

Public Static Methods

IsEntryAction | Indicates whether the specified order action is an entry.
IsLongAction | Indicates whether the specified order action is long.

Public Instance Constructors

Order Constructor Initializes a new instance of Order.

Public Instance Properties

Action | Read-only property. Order Action: Buy, Sell, SellShort, BuyToCover.
Category | Read-only property. Order category: Market, MarketRange, Limit, Stop.
Contracts | Read-only property. Information about lot’s type and quantity.
IsEntry | Read-only property. Indicates whether the order is an entry order.
IsExit | Read-only property. Indicates whether the order is an exit order.
IsLong | Read-only property. Indicates whether the order is Long.
IsShort | Read-only property. Indicates whether the order is Short.
Name | Read-only property. Order name.
OnClose | Read-only property. Indicates whether the order is a closing order.
OrderExit | Read-only property. Returns order exit information.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Order Class | PowerLanguage Namespace


Order Constructor

Initializes a new instance of Order.

Order(
string name,
EOrderAction action,
OrderCategory category,
Contracts lots,
bool openNextBar,
OrderExit exitInfo
);

Parameters

name
Order name.
action
Order action.
category
Order category.
lots
Order number of lots.
openNextBar
Indicates whether the order must be placed at the open of next bar.
exitInfo
Order exit information.

See Also

Order Class | PowerLanguage Namespace


Order Properties

The properties of the Order class are listed below. For a complete list of Order class members, see the Order Members topic.

Public Instance Properties

Action | Read-only property. Order Action: Buy, Sell, SellShort, BuyToCover.
Category | Read-only property. Order category: Market, MarketRange, Limit, Stop.
Contracts | Read-only property. Information about lot’s type and quantity.
IsEntry | Read-only property. Indicates whether the order is an entry order.
IsExit | Read-only property. Indicates whether the order is an exit order.
IsLong | Read-only property. Indicates whether the order is Long.
IsShort | Read-only property. Indicates whether the order is Short.
Name | Read-only property. Order name.
OnClose | Read-only property. Indicates whether the order is a closing order.
OrderExit | Read-only property. Returns order exit information.

See Also

Order Class | PowerLanguage Namespace


Action Property

PowerLanguage.NET Help

Order.Action Property

Read-only property. Order Action: Buy, Sell, SellShort, BuyToCover.

public EOrderAction Action { public get; }

See Also

Order Class | PowerLanguage Namespace


Category Property

PowerLanguage.NET Help

Order.Category Property

Read-only property. Order category: Market, MarketRange, Limit, Stop.

public OrderCategory Category { public get; }

See Also

Order Class | PowerLanguage Namespace


Contracts Property

PowerLanguage.NET Help

Order.Contracts Property

Read-only property. Information about lot’s type and quantity.

public Contracts Contracts { public get; }

See Also

Order Class | PowerLanguage Namespace


IsEntry Property

PowerLanguage.NET Help

Order.IsEntry Property

Read-only property. Indicates whether the order is an entry order.

public bool IsEntry { public get; }

See Also

Order Class | PowerLanguage Namespace


IsExit Property

PowerLanguage.NET Help

Order.IsExit Property

Read-only property. Indicates whether the order is an exit order.

public bool IsExit { public get; }

See Also

Order Class | PowerLanguage Namespace


IsLong Property

PowerLanguage.NET Help

Order.IsLong Property

Read-only property. Indicates whether the order is Long.

public bool IsLong { public get; }

See Also

Order Class | PowerLanguage Namespace


IsShort Property

PowerLanguage.NET Help

Order.IsShort Property

Read-only property. Indicates whether the order is Short.

public bool IsShort { public get; }

See Also

Order Class | PowerLanguage Namespace


Name Property

PowerLanguage.NET Help

Order.Name Property

Read-only property. Order name.

public string Name { public get; }

See Also

Order Class | PowerLanguage Namespace


OnClose Property

PowerLanguage.NET Help

Order.OnClose Property

Read-only property. Indicates whether the order is a closing order.

public bool OnClose { public get; }

See Also

Order Class | PowerLanguage Namespace


OrderExit Property

PowerLanguage.NET Help

Order.OrderExit Property

Read-only property. Returns order exit information.

public OrderExit OrderExit { public get; }

See Also

Order Class | PowerLanguage Namespace


Order Methods

The methods of the Order class are listed below. For a complete list of Order class members, see the Order Members topic.

Public Static Methods

IsEntryAction | Indicates whether the specified order action is an entry.
IsLongAction | Indicates whether the specified order action is long.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Order Class | PowerLanguage Namespace


Order.IsEntryAction Method

Indicates whether the specified order action is an entry.

public static bool IsEntryAction(
EOrderAction Action
);

Parameters

Action

Return Value

See Also

Order Class | PowerLanguage Namespace


Order.IsLongAction Method

Indicates whether the specified order action is long.

public static bool IsLongAction(
EOrderAction Action
);

Parameters

Action

Return Value

See Also

Order Class | PowerLanguage Namespace


OrderCategory Enumeration

Enumeration describing order category.

public enum OrderCategory

Members

Member Name | Description
Market | Market order category.
Limit | Limit order category.
Stop | Stop order category.
StopLimit | StopLimit order category.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


OrderCreator Class

Allows order generation.

For a list of all members of this type, see OrderCreator Members .

System.Object
OrderCreator

public abstract class OrderCreator : IOrderCreator

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

OrderCreator Members | PowerLanguage Namespace


OrderCreator Members

OrderCreator overview

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

OrderCreator Constructor Initializes a new instance of the OrderCreator class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

OrderCreator Class | PowerLanguage Namespace


OrderCreator Constructor

Initializes a new instance of the OrderCreator class.

OrderCreator();

See Also

OrderCreator Class | PowerLanguage Namespace


OrderExit Class

Class that contains information about the exit order.

For a list of all members of this type, see OrderExit Members .

System.Object
OrderExit

public class OrderExit

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

OrderExit Members | PowerLanguage Namespace


OrderExit Members

OrderExit overview

Public Static Properties

FromAll | Read-only property. Returns instance of the OrderExit with EExitType. "From All" exit type.
Total | Read-only property. Returns instance of the OrderExit with EExitType. "Total" exit type.

Public Static Methods

FromEntry | Overloaded. Read-only property. Returns instance of the OrderExit with EExitType.FromOne exit type.
FromEntryTotal | Overloaded. Read-only property. Returns instance of the OrderExit with EExitType.FromOneTotal exit type.

Public Instance Properties

EntryID | Returns entry order ID.
ExitType | Returns exit type.
IsTotal | Read-only property. Indicates whether the exit order has the 'Total' type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

OrderExit Class | PowerLanguage Namespace


OrderExit Properties

The properties of the OrderExit class are listed below. For a complete list of OrderExit class members, see the OrderExit Members topic.

Public Static Properties

FromAll | Read-only property. Returns instance of the OrderExit with EExitType. "From All" exit type.
Total | Read-only property. Returns instance of the OrderExit with EExitType. "Total" exit type.

Public Instance Properties

EntryID | Returns entry order ID.
ExitType | Returns exit type.
IsTotal | Read-only property. Indicates whether the exit order has the 'Total' type.

See Also

OrderExit Class | PowerLanguage Namespace


EntryID Property

PowerLanguage.NET Help

OrderExit.EntryID Property

Returns entry order ID.

public int EntryID { public get; private set; }

See Also

OrderExit Class | PowerLanguage Namespace


ExitType Property

PowerLanguage.NET Help

OrderExit.ExitType Property

Returns exit type.

public EExitType ExitType { public get; private set; }

See Also

OrderExit Class | PowerLanguage Namespace


FromAll Property

PowerLanguage.NET Help

OrderExit.FromAll Property

Read-only property. Returns instance of the OrderExit with EExitType. "From All" exit type.

public static OrderExit FromAll { public get; }

See Also

OrderExit Class | PowerLanguage Namespace


IsTotal Property

PowerLanguage.NET Help

OrderExit.IsTotal Property

Read-only property. Indicates whether the exit order has the 'Total' type.

public bool IsTotal { public get; }

See Also

OrderExit Class | PowerLanguage Namespace


Total Property

PowerLanguage.NET Help

OrderExit.Total Property

Read-only property. Returns instance of the OrderExit with EExitType. "Total" exit type.

public static OrderExit Total { public get; }

See Also

OrderExit Class | PowerLanguage Namespace


OrderExit Methods

The methods of the OrderExit class are listed below. For a complete list of OrderExit class members, see the OrderExit Members topic.

Public Static Methods

FromEntry | Overloaded. Read-only property. Returns instance of the OrderExit with EExitType.FromOne exit type.
FromEntryTotal | Overloaded. Read-only property. Returns instance of the OrderExit with EExitType.FromOneTotal exit type.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

OrderExit Class | PowerLanguage Namespace


FromEntry Method

PowerLanguage.NET Help

OrderExit.FromEntry Method

Overload List

public static OrderExit FromEntry()

Read-only property. Returns instance of the OrderExit with EExitType.FromOne exit type.

public static OrderExit FromEntry(IOrderObject)

See Also

OrderExit Class | PowerLanguage Namespace


OrderExit.FromEntry() Method

public static OrderExit FromEntry();

See Also

OrderExit Class | PowerLanguage Namespace | OrderExit.FromEntry Overload List


OrderExit.FromEntry(IOrderObject) Method

Read-only property. Returns instance of the OrderExit with EExitType.FromOne exit type.

public static OrderExit FromEntry(
IOrderObject entry
);

Parameters

entry
The entry order which will be closed.

Return Value

The instance of the OrderExit for closing the position, which was opened by entry order.

See Also

OrderExit Class | PowerLanguage Namespace | OrderExit.FromEntry Overload List


FromEntryTotal Method

PowerLanguage.NET Help

OrderExit.FromEntryTotal Method

Overload List

public static OrderExit FromEntryTotal()

Read-only property. Returns instance of the OrderExit with EExitType.FromOneTotal exit type.

public static OrderExit FromEntryTotal(IOrderObject)

See Also

OrderExit Class | PowerLanguage Namespace


OrderExit.FromEntryTotal() Method

public static OrderExit FromEntryTotal();

See Also

OrderExit Class | PowerLanguage Namespace | OrderExit.FromEntryTotal Overload List


OrderExit.FromEntryTotal(IOrderObject) Method

Read-only property. Returns instance of the OrderExit with EExitType.FromOneTotal exit type.

public static OrderExit FromEntryTotal(
IOrderObject entry
);

Parameters

entry
The entry order which will be closed.

Return Value

The instance of the OrderExit for closing the position, which was opened by entry order.

See Also

OrderExit Class | PowerLanguage Namespace | OrderExit.FromEntryTotal Overload List


OrderExit.EExitType Enumeration

Enumeration describing exit type.

public enum EExitType

Members

Member Name | Description
All | Close all entries.
Total | Close as many entry orders as possible (or all), with the condition that the sum of all closed contracts is not more than the specified number of contracts.
FromOne | Close a specific entry.
FromOneTotal | Close a specific entry totally.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


Pair<T> Class

Specialization of generic Pair class

For a list of all members of this type, see Pair<T> Members .

System.Object
Pair<TT,TT>
Pair<T>

public class Pair<T> : Pair<T, T>

Generic template parameters

T

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Pair<T> Members | PowerLanguage Namespace


Pair<T> Members

Pair<T> overview

Public Instance Constructors

Pair<T> Overloaded. Initializes a new instance of the Pair<T> class.

Public Instance Properties

First (inherited from Pair) | The first memeber
Second (inherited from Pair) | The second member

Public Instance Methods

Equals (inherited from Pair) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Pair) | Serves as a hash function for a particular type.
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Equals (inherited from Pair) | Overloaded.
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

Pair<T> Class | PowerLanguage Namespace


Pair`1 Constructor

Constructor

Overload List

Constructor

public Pair`1()

Constructor

public Pair`1(T,T)

See Also

Pair<T> Class | PowerLanguage Namespace


Pair<T> Constructor

Constructor

Pair<T>(
T first,
T second
);

Parameters

first
second

See Also

Pair<T> Class | PowerLanguage Namespace | Pair<T> Constructor Overload List


Pair<T> Constructor

Constructor

Pair<T>();

See Also

Pair<T> Class | PowerLanguage Namespace | Pair<T> Constructor Overload List


Pair<T1,T2> Class

Generic class for pair values

For a list of all members of this type, see Pair<T1,T2> Members .

System.Object
Pair<T1,T2>
Pair<T>

public class Pair<T1, T2>

Generic template parameters

T1
T2

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Pair<T1,T2> Members | PowerLanguage Namespace


Pair<T1,T2> Members

Pair<T1,T2> overview

Public Static Operators

Equality Operator
Inequality Operator

Public Instance Constructors

Pair<T1,T2> Overloaded. Initializes a new instance of the Pair<T1,T2> class.

Public Instance Properties

First | The first memeber
Second | The second member

Public Instance Methods

Equals | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Equals | Overloaded.
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Pair`2 Constructor

Constructor

Overload List

Constructor

public Pair`2()

Constructor

public Pair`2(T1,T2)

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Pair<T1,T2> Constructor

Constructor

Pair<T1, T2>(
T1 first,
T2 second
);

Parameters

first
second

See Also

Pair<T1, T2> Class | PowerLanguage Namespace | Pair<T1, T2> Constructor Overload List


Pair<T1,T2> Constructor

Constructor

Pair<T1, T2>();

See Also

Pair<T1, T2> Class | PowerLanguage Namespace | Pair<T1, T2> Constructor Overload List


Pair<T1,T2> Properties

The properties of the Pair<T1,T2> class are listed below. For a complete list of Pair<T1,T2> class members, see the Pair<T1,T2> Members topic.

Public Instance Properties

First | The first memeber
Second | The second member

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


First Property

PowerLanguage.NET Help

Pair`2.First Property

The first memeber

public T1 First { public get; public set; }

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Second Property

PowerLanguage.NET Help

Pair`2.Second Property

The second member

public T2 Second { public get; public set; }

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Pair<T1,T2> Methods

The methods of the Pair<T1,T2> class are listed below. For a complete list of Pair<T1,T2> class members, see the Pair<T1,T2> Members topic.

Public Instance Methods

Equals | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Equals | Overloaded.
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

Pair`2.Equals Method

Overload List

protected bool Equals(Pair<T1, T2>)

Determines whether the specified Object is equal to the current Object.

public override bool Equals(object)

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Pair<T1,T2>.Equals(Pair) Method

protected bool Pair(
Pair<T1, T2> other
);

See Also

Pair<T1, T2> Class | PowerLanguage Namespace | Pair<T1, T2>.Equals Overload List


Pair<T1,T2>.Equals(Object) Method

Determines whether the specified Object is equal to the current Object.

public override bool Pair(
object obj
);

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception Type | Condition
NullReferenceException | The obj parameter is null.

See Also

Pair<T1, T2> Class | PowerLanguage Namespace | Pair<T1, T2>.Equals Overload List


Pair<T1,T2>.GetHashCode Method

Serves as a hash function for a particular type.

public override int Pair();

Return Value

A hash code for the current Object.

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Pair<T1,T2> Operators

The operators of the Pair<T1,T2> class are listed below. For a complete list of Pair<T1,T2> class members, see the Pair<T1,T2> Members topic.

Public Static Operators

Equality Operator
Inequality Operator

See Also

Pair<T1, T2> Class | Pair<T1,T2> Members | PowerLanguage Namespace


Pair<T1,T2> Equality Operator

public static bool operator ==(
Pair<T1, T2> left,
Pair<T1, T2> right
);

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


Pair<T1,T2> Inequality Operator

public static bool operator !=(
Pair<T1, T2> left,
Pair<T1, T2> right
);

See Also

Pair<T1, T2> Class | PowerLanguage Namespace


PlotAlignment Enumeration

Output value alignment in Scanner's cell.

public enum PlotAlignment

Members

Member Name | Description
Left | Text alignment is set to Left
Center | Text alignment is set to Center
Right | Text alignment is set to Right

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


PlotAttributes Structure

A structure for plots initialization.

For a list of all members of this type, see PlotAttributes Members .

System.Object
PlotAttributes

public struct PlotAttributes

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PlotAttributes Members | PowerLanguage Namespace


PlotAttributes Members

PlotAttributes overview

Public Instance Constructors

PlotAttributes Overloaded. Initializes a new instance of the PlotAttributes class.

Public Instance Fields

Alignment | Plot value alignment in Scanner's cell.
BGColor | Plot’s background color.
Color | Plot’s foreground color.
Format | Plots data format in Scanner's cell.
MarkerLastPrice | Determines whether to show last price marker.
Name | Plot name.
Precision | Number of digits after decimal point
Style | Plot’s style.
Type | Plot type: Line, Histogram, Point, Cross, BarHigh, BarLow, LeftTick, RightTick
Width | Plot’s width.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

Overload List

Initializes a new instance of the PlotAttributes.

public PlotAttributes(int)

Initializes a new instance of the PlotAttributes.

public PlotAttributes(string)

Initializes a new instance of the PlotAttributes.

public PlotAttributes(string,EPlotShapes,Color)

Initializes a new instance of the PlotAttributes.

public PlotAttributes(string,EPlotShapes,Color,Color,int,EPlotStyle,bool)

Initializes a new instance of the PlotAttributes.

public PlotAttributes(string,EPlotShapes,Color,Color,int,int,bool)

Initializes a new instance of the PlotAttributes.

public PlotAttributes(string,int)

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

PlotAttributes(
string name,
EPlotShapes type,
Color fgColor,
Color bgColor,
int width,
EPlotStyle style,
bool showLastPriceMarker
);

Parameters

name
Plot name.
type
Plot type.
fgColor
Plot foreground color.
bgColor
Plot background color.
width
Plot width.
style
Plot style.
showLastPriceMarker
Determines whether to show last price marker.

See Also

PlotAttributes Class | PowerLanguage Namespace | PlotAttributes Constructor Overload List


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

PlotAttributes(
string name,
EPlotShapes type,
Color fgColor,
Color bgColor,
int width,
int style,
bool showLastPriceMarker
);

Parameters

name
Plot name.
type
Plot type.
fgColor
Plot foreground color.
bgColor
Plot background color.
width
Plot width.
style
Plot style.
showLastPriceMarker
Determines whether to show last price marker.

See Also

PlotAttributes Class | PowerLanguage Namespace | PlotAttributes Constructor Overload List


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

PlotAttributes(
string name,
EPlotShapes type,
Color fgColor
);

Parameters

name
Plot name.
type
Plot type.
fgColor
Plot foreground color.

See Also

PlotAttributes Class | PowerLanguage Namespace | PlotAttributes Constructor Overload List


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

PlotAttributes(
string name,
int plotNum
);

Parameters

name
Plot name.
plotNum
Plot number.

See Also

PlotAttributes Class | PowerLanguage Namespace | PlotAttributes Constructor Overload List


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

PlotAttributes(
string name
);

Parameters

name
Plot name.

See Also

PlotAttributes Class | PowerLanguage Namespace | PlotAttributes Constructor Overload List


PlotAttributes Constructor

Initializes a new instance of the PlotAttributes.

PlotAttributes(
int plotNum
);

Parameters

plotNum
Plot number.

See Also

PlotAttributes Class | PowerLanguage Namespace | PlotAttributes Constructor Overload List


PlotAttributes Fields

The fields of the PlotAttributes structure are listed below. For a complete list of PlotAttributes structure members, see the PlotAttributes Members topic.

Public Instance Fields

Alignment | Plot value alignment in Scanner's cell.
BGColor | Plot’s background color.
Color | Plot’s foreground color.
Format | Plots data format in Scanner's cell.
MarkerLastPrice | Determines whether to show last price marker.
Name | Plot name.
Precision | Number of digits after decimal point
Style | Plot’s style.
Type | Plot type: Line, Histogram, Point, Cross, BarHigh, BarLow, LeftTick, RightTick
Width | Plot’s width.

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Alignment Field

Plot value alignment in Scanner's cell.

public PlotAlignment Alignment;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.BGColor Field

Plot’s background color.

public Color BGColor;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Color Field

Plot’s foreground color.

public Color Color;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Format Field

Plots data format in Scanner's cell.

public PlotFormat Format;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.MarkerLastPrice Field

Determines whether to show last price marker.

public bool MarkerLastPrice;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Name Field

Plot name.

public string Name;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Precision Field

Number of digits after decimal point

public int Precision;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Style Field

Plot’s style.

public EPlotStyle Style;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Type Field

Plot type: Line, Histogram, Point, Cross, BarHigh, BarLow, LeftTick, RightTick

public EPlotShapes Type;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotAttributes.Width Field

Plot’s width.

public int Width;

See Also

PlotAttributes Class | PowerLanguage Namespace


PlotFormat Enumeration

Plots data format in Scanner's cell.

public enum PlotFormat

Members

Member Name | Description
SameAsInstrument | Scale format of output value is the same as instrument.
Number | Scale format of output value is set to show complete value.
Currency | Adds "$" sign after the output value.
Percentage | Adds "%" sign after the output value.
Date | Converts values from "datetime" format to "date" format.
Time | Converts values from "datetime" format to "time" format.
Text | Converts values to text format.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


PointAndFigureBasis Enumeration

Enumeration represents whether on Close or High/Low "Point And Figure" chart will be based on.

public enum PointAndFigureBasis

Members

Member Name | Description
Close | Chart based on Close values.
HighLow | Chart based on High and Low values.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


PointAndFigureOptions Enumeration

Enumeration represents options for Point And Figure chart type.

public enum PointAndFigureOptions

Members

Member Name | Description
BOXSIZE | Bos size.
REVERSAL | Reversal.
BASIS | Base for point and figures.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


Price Class

For a list of all members of this type, see Price Members .

System.Object
Price

public sealed class Price : IComparable<T>, IComparable, IEquatable<T>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Price Members | PowerLanguage Namespace


Price Members

Price overview

Public Static Properties

Empty

Public Static Methods

Convert Overloaded.

Public Static Operators and Type Conversions

Addition Operator
Equality Operator
Greater Than Operator
Greater Than Or Equal Operator
Inequality Operator
Less Than Operator
Less Than Or Equal Operator
Subtraction Operator
Explicit to Conversion
Explicit to Conversion

Public Instance Constructors

Price Overloaded. Initializes a new instance of the Price class.

Public Instance Properties

Dbl
Int
IsEmpty

Public Instance Methods

CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode |
GetNewPrice |
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Price Class | PowerLanguage Namespace


Price Constructor

Overload List

public Price(double,PriceCtx)

public Price(long,PriceCtx)

See Also

Price Class | PowerLanguage Namespace


Price Constructor

Price(
double mDbl,
PriceCtx _ctx
);

Parameters

mDbl
_ctx

See Also

Price Class | PowerLanguage Namespace | Price Constructor Overload List


Price Constructor

Price(
long mInt,
PriceCtx _ctx
);

Parameters

mInt
_ctx

See Also

Price Class | PowerLanguage Namespace | Price Constructor Overload List


Price Properties

The properties of the Price class are listed below. For a complete list of Price class members, see the Price Members topic.

Public Static Properties

Empty

Public Instance Properties

Dbl
Int
IsEmpty

See Also

Price Class | PowerLanguage Namespace


Dbl Property

PowerLanguage.NET Help

Price.Dbl Property

public double Dbl { public get; }

See Also

Price Class | PowerLanguage Namespace


Empty Property

PowerLanguage.NET Help

Price.Empty Property

public static Price Empty { public get; }

See Also

Price Class | PowerLanguage Namespace


Int Property

PowerLanguage.NET Help

Price.Int Property

public long Int { public get; }

See Also

Price Class | PowerLanguage Namespace


IsEmpty Property

PowerLanguage.NET Help

Price.IsEmpty Property

public bool IsEmpty { public get; }

See Also

Price Class | PowerLanguage Namespace


Price Methods

The methods of the Price class are listed below. For a complete list of Price class members, see the Price Members topic.

Public Static Methods

Convert Overloaded.

Public Instance Methods

CompareTo | Overloaded.
Equals | Overloaded.
GetHashCode |
GetNewPrice |
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Price Class | PowerLanguage Namespace


CompareTo Method

PowerLanguage.NET Help

Price.CompareTo Method

Overload List

public int CompareTo(Price)

public int CompareTo(object)

See Also

Price Class | PowerLanguage Namespace


Price.CompareTo(Price) Method

public int CompareTo(
Price obj
);

Implements

IComparable< Price>.CompareTo

See Also

Price Class | PowerLanguage Namespace | Price.CompareTo Overload List


Price.CompareTo(Object) Method

public int CompareTo(
object obj
);

Implements

IComparable.CompareTo

See Also

Price Class | PowerLanguage Namespace | Price.CompareTo Overload List


Convert Method

PowerLanguage.NET Help

Price.Convert Method

Overload List

public static long Convert(double,PriceCtx)

public static double Convert(long,PriceCtx)

See Also

Price Class | PowerLanguage Namespace


Price.Convert(Double, PriceCtx) Method

public static long Convert(
double _price,
PriceCtx _ctx
);

Parameters

_price
_ctx

Return Value

See Also

Price Class | PowerLanguage Namespace | Price.Convert Overload List


Price.Convert(Int64, PriceCtx) Method

public static double Convert(
long _price,
PriceCtx _ctx
);

Parameters

_price
_ctx

Return Value

See Also

Price Class | PowerLanguage Namespace | Price.Convert Overload List


Equals Method

PowerLanguage.NET Help

Price.Equals Method

Overload List

public bool Equals(Price)

public override bool Equals(object)

See Also

Price Class | PowerLanguage Namespace


Price.Equals(Price) Method

public bool Equals(
Price other
);

Implements

IEquatable< Price>.Equals

See Also

Price Class | PowerLanguage Namespace | Price.Equals Overload List


Price.Equals(Object) Method

public override bool Equals(
object obj
);

See Also

Price Class | PowerLanguage Namespace | Price.Equals Overload List


Price.GetHashCode Method

public override int GetHashCode();

See Also

Price Class | PowerLanguage Namespace


Price.GetNewPrice Method

public Price GetNewPrice(
double mDbl
);

See Also

Price Class | PowerLanguage Namespace


Price.ToString Method

public override string ToString();

See Also

Price Class | PowerLanguage Namespace


Price Operators and Type Conversions

The operators and type conversions of the Price class are listed below. For a complete list of Price class members, see the Price Members topic.

Public Static Operators and Type Conversions

Addition Operator
Equality Operator
Greater Than Operator
Greater Than Or Equal Operator
Inequality Operator
Less Than Operator
Less Than Or Equal Operator
Subtraction Operator
Explicit to Conversion
Explicit to Conversion

See Also

Price Class | Price Members | PowerLanguage Namespace


Price Addition Operator

public static Price operator +(
Price left,
int inc
);

Parameters

left
inc

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Equality Operator

public static bool operator ==(
Price left,
Price right
);

Parameters

left
right

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Greater Than Operator

public static bool operator >(
Price _p1,
Price _p2
);

Parameters

_p1
_p2

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Greater Than Or Equal Operator

public static bool operator >=(
Price _p1,
Price _p2
);

Parameters

_p1
_p2

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Inequality Operator

public static bool operator !=(
Price left,
Price right
);

Parameters

left
right

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Less Than Operator

public static bool operator <(
Price _p1,
Price _p2
);

Parameters

_p1
_p2

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Less Than Or Equal Operator

public static bool operator <=(
Price _p1,
Price _p2
);

Parameters

_p1
_p2

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Subtraction Operator

public static Price operator -(
Price left,
int dec
);

Parameters

left
dec

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Explicit to Conversion

public override static explicit operator double(
Price _p
);

Parameters

_p

Return Value

See Also

Price Class | PowerLanguage Namespace


Price Explicit to Conversion

public override static explicit operator long(
Price _p
);

Parameters

_p

Return Value

See Also

Price Class | PowerLanguage Namespace


PriceCtx Class

Utility class for prices.

For a list of all members of this type, see PriceCtx Members .

System.Object
PriceCtx

public sealed class PriceCtx

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PriceCtx Members | PowerLanguage Namespace


PriceCtx Members

PriceCtx overview

Public Instance Constructors

PriceCtx Overloaded. Initializes a new instance of the PriceCtx class.

Public Instance Properties

Digits | The number of digits after the decimal point
MinMove | Minimum price movement
PriceScale | price scale
PriceScaleType |

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Overloaded. Convert price to string
ToString (inherited from Object) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PriceCtx Class | PowerLanguage Namespace


PriceCtx Constructor

Overload List

Construct PriceCtx from instrument settings

public PriceCtx(IInstrumentSettings)

Construct PriceCtx from existing one and specify multiplier for MinMove.

public PriceCtx(PriceCtx,int)

public PriceCtx(double,int)

public PriceCtx(double,int,long)

See Also

PriceCtx Class | PowerLanguage Namespace


PriceCtx Constructor

PriceCtx(
double priceScale,
int minMove
);

See Also

PriceCtx Class | PowerLanguage Namespace | PriceCtx Constructor Overload List


PriceCtx Constructor

PriceCtx(
double priceScale,
int minMove,
long priceScaleType
);

See Also

PriceCtx Class | PowerLanguage Namespace | PriceCtx Constructor Overload List


PriceCtx Constructor

Construct PriceCtx from instrument settings

PriceCtx(
IInstrumentSettings _settings
);

Parameters

_settings

See Also

PriceCtx Class | PowerLanguage Namespace | PriceCtx Constructor Overload List


PriceCtx Constructor

Construct PriceCtx from existing one and specify multiplier for MinMove.

PriceCtx(
PriceCtx ctx,
int multiplier
);

Parameters

ctx
multiplier

See Also

PriceCtx Class | PowerLanguage Namespace | PriceCtx Constructor Overload List


PriceCtx Properties

The properties of the PriceCtx class are listed below. For a complete list of PriceCtx class members, see the PriceCtx Members topic.

Public Instance Properties

Digits | The number of digits after the decimal point
MinMove | Minimum price movement
PriceScale | price scale
PriceScaleType |

See Also

PriceCtx Class | PowerLanguage Namespace


Digits Property

PowerLanguage.NET Help

PriceCtx.Digits Property

The number of digits after the decimal point

public int Digits { public get; }

See Also

PriceCtx Class | PowerLanguage Namespace


MinMove Property

PowerLanguage.NET Help

PriceCtx.MinMove Property

Minimum price movement

public int MinMove { public get; private set; }

See Also

PriceCtx Class | PowerLanguage Namespace


PriceScale Property

PowerLanguage.NET Help

PriceCtx.PriceScale Property

price scale

public double PriceScale { public get; private set; }

See Also

PriceCtx Class | PowerLanguage Namespace


PriceScaleType Property

PowerLanguage.NET Help

PriceCtx.PriceScaleType Property

public long PriceScaleType { public get; private set; }

See Also

PriceCtx Class | PowerLanguage Namespace


PriceCtx Methods

The methods of the PriceCtx class are listed below. For a complete list of PriceCtx class members, see the PriceCtx Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString | Overloaded. Convert price to string
ToString (inherited from Object) | Overloaded.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PriceCtx Class | PowerLanguage Namespace


ToString Method

PowerLanguage.NET Help

PriceCtx.ToString Method

Convert price to string

Overload List

Inherited from Object.

public virtual string ToString()

Convert price to string

public string ToString(double)

Convert price to string

public string ToString(double,int)

See Also

PriceCtx Class | PowerLanguage Namespace


PriceCtx.ToString(Double) Method

Convert price to string

public string ToString(
double _price
);

Parameters

_price

Return Value

See Also

PriceCtx Class | PowerLanguage Namespace | PriceCtx.ToString Overload List


PriceCtx.ToString(Double, Int32) Method

Convert price to string

public string ToString(
double _price,
int digits_inc
);

Parameters

_price
Price value
digits_inc
Additional digits

Return Value

See Also

PriceCtx Class | PowerLanguage Namespace | PriceCtx.ToString Overload List


PriceLevel Structure

Structure that describes a price level for Volume Profile. BarPriceLevels

For a list of all members of this type, see PriceLevel Members .

System.Object
PriceLevel

public struct PriceLevel

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PriceLevel Members | PowerLanguage Namespace


PriceLevel Members

PriceLevel overview

Public Static Operators

Equality Operator | Indicates whether two instances of PriceLevel are equal.
Inequality Operator | Indicates whether two instances of PriceLevel are not equal.

Public Instance Fields

DownVolume | Down ticks Volume of the price level. A down tick is a tick with the price lower then the preceding tick.
Price | Price level.
UpVolume | Up ticks Volume of the price level. An up tick is a tick with the price higher then the preceding tick.

Public Instance Properties

TotalVolume Total Volume of the price level.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel Fields

The fields of the PriceLevel structure are listed below. For a complete list of PriceLevel structure members, see the PriceLevel Members topic.

Public Instance Fields

DownVolume | Down ticks Volume of the price level. A down tick is a tick with the price lower then the preceding tick.
Price | Price level.
UpVolume | Up ticks Volume of the price level. An up tick is a tick with the price higher then the preceding tick.

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel.DownVolume Field

Down ticks Volume of the price level. A down tick is a tick with the price lower then the preceding tick.

public double DownVolume;

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel.Price Field

Price level.

public double Price;

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel.UpVolume Field

Up ticks Volume of the price level. An up tick is a tick with the price higher then the preceding tick.

public double UpVolume;

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel Properties

The properties of the PriceLevel structure are listed below. For a complete list of PriceLevel structure members, see the PriceLevel Members topic.

Public Instance Properties

TotalVolume Total Volume of the price level.

See Also

PriceLevel Class | PowerLanguage Namespace


TotalVolume Property

PowerLanguage.NET Help

PriceLevel.TotalVolume Property

Total Volume of the price level.

public double TotalVolume { public get; }

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel Methods

The methods of the PriceLevel structure are listed below. For a complete list of PriceLevel structure members, see the PriceLevel Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PriceLevel Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

PriceLevel.Equals Method

Indicates whether this instance and the specified object are equal.

Overload List

Indicates whether this instance and the specified object are equal.

public bool Equals(PriceLevel)

Indicates whether this instance and the specified object are equal.

public override bool Equals(object)

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel.Equals(PriceLevel) Method

Indicates whether this instance and the specified object are equal.

public bool Equals(
PriceLevel other
);

Parameters

other
PriceLevel object for comparison.

Return Value

See Also

PriceLevel Class | PowerLanguage Namespace | PriceLevel.Equals Overload List


PriceLevel.Equals(Object) Method

Indicates whether this instance and the specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

PriceLevel Class | PowerLanguage Namespace | PriceLevel.Equals Overload List


PriceLevel.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel.ToString Method

public override string ToString();

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel Operators

The operators of the PriceLevel structure are listed below. For a complete list of PriceLevel structure members, see the PriceLevel Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances of PriceLevel are equal.
Inequality Operator | Indicates whether two instances of PriceLevel are not equal.

See Also

PriceLevel Class | PriceLevel Members | PowerLanguage Namespace


PriceLevel Equality Operator

Indicates whether two instances of PriceLevel are equal.

public static bool operator ==(
PriceLevel left,
PriceLevel right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are equal; otherwise false.

See Also

PriceLevel Class | PowerLanguage Namespace


PriceLevel Inequality Operator

Indicates whether two instances of PriceLevel are not equal.

public static bool operator !=(
PriceLevel left,
PriceLevel right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are not equal; otherwise false.

See Also

PriceLevel Class | PowerLanguage Namespace


PublicFunctions Class

A set of public functions for common use.

For a list of all members of this type, see PublicFunctions Members .

System.Object
PublicFunctions

[Extension]
public static class PublicFunctions

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PublicFunctions Members | PowerLanguage Namespace


PublicFunctions Members

PublicFunctions overview

Public Static Methods

Average | Overloaded. The function calculates the average of series values.
AverageCustom | Overloaded. The function calculates the average series value.
Avg | The function calculates average value of the args array.
BollingerBandCustom | The function calculates Bollinger Band custom.
Crosses<T> | Overloaded. The function checks that series1 crosses series2.
CrossesOver | Overloaded. The function checks that series1 crosses series2.
CrossesUnder | Overloaded. The function checks that series1 crosses series2.
CummRatio | The function calculates cumulative ratio value.
DoubleEquals | The function checks that lval is not less than rval or lval is not greater than rval.
DoubleGreater | The function checks that lval is greater than rval.
DoubleGreaterEquals | The function checks that lval is greater than rval or lval is not less than rval.
DoubleLess | The function checks that 'lval' is less than 'rval'.
DoubleLessEquals | The function checks that lval is less than rval or lval is not greater than rval.
ExtremeHigh | Overloaded. The function calculates extremum high value.
ExtremeLow | Overloaded. The function calculates extremum low value.
Extremum<T> | The function calculates extremum value.
GradientColor | The function to calculate gradient color of the input parameters.
Highest | Overloaded. The function calculates the highest series value.
Iff<T> | The function that returns trueVal if the condition is true and returns falseVal if the condition is false.
IsDayBased | Returns 'true' if resolution is Day or higher; otherwise returns 'false'.
LinearRegCustom | Overloaded. The function calculates linear reg custom.
Lowest | Overloaded. The function calculates the lowest series value.
Max | The function calculates min value from the args array.
Min | The function calculates min value from the 'args' array.
OpenNextBar | Return Open of a next bar. Can be used in signals/strategy with CalcAtOpenNextBarAttribute(true) attribute
Pivot<T> | Overloaded. The function calculates pivot values.
PivotHigh | Overloaded. The function calculates pivot high values.
PivotLow | Overloaded. The function calculates pivot low values.
RaiseRunTimeError | A function to raise a study's runtime exception.
StandardDeviation | The function calculates standard deviation.
StandardDeviationCustom | Overloaded. The function calculates custom standard deviation.
StandardError | The function calculates standard error value.
Summ | The function calculates the sum of series values.
SummationCustom | Overloaded. The function calculates the sum of series values.
SummationIf | Overloaded. The function calculates the sum of series values with condition.
SummCustom | This function calculates summ of array values
TimeNextBar | Return time for next bar. Can be used in signals/strategy with CalcAtOpenNextBarAttribute(true) attribute
TrueRange | Overloaded. The function returns TrueRange value for current bar of the base data stream.
TrueRangeCustom | Overloaded. The function returns TrueRangeCustom value for the offset 'bars ago' from current bar.
TrueRangeSeries | Overloaded. The function returns TrueRange series value.
UlcerIndex | The function calculates ulcer index.
Variance | The function calculates variance value.
VarianceCustom | Overloaded. The function calculates custom variance.
WAverageCustom | Overloaded. The function calculates the average series value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions Methods

The methods of the PublicFunctions class are listed below. For a complete list of PublicFunctions class members, see the PublicFunctions Members topic.

Public Static Methods

Average | Overloaded. The function calculates the average of series values.
AverageCustom | Overloaded. The function calculates the average series value.
Avg | The function calculates average value of the args array.
BollingerBandCustom | The function calculates Bollinger Band custom.
Crosses<T> | Overloaded. The function checks that series1 crosses series2.
CrossesOver | Overloaded. The function checks that series1 crosses series2.
CrossesUnder | Overloaded. The function checks that series1 crosses series2.
CummRatio | The function calculates cumulative ratio value.
DoubleEquals | The function checks that lval is not less than rval or lval is not greater than rval.
DoubleGreater | The function checks that lval is greater than rval.
DoubleGreaterEquals | The function checks that lval is greater than rval or lval is not less than rval.
DoubleLess | The function checks that 'lval' is less than 'rval'.
DoubleLessEquals | The function checks that lval is less than rval or lval is not greater than rval.
ExtremeHigh | Overloaded. The function calculates extremum high value.
ExtremeLow | Overloaded. The function calculates extremum low value.
Extremum<T> | The function calculates extremum value.
GradientColor | The function to calculate gradient color of the input parameters.
Highest | Overloaded. The function calculates the highest series value.
Iff<T> | The function that returns trueVal if the condition is true and returns falseVal if the condition is false.
IsDayBased | Returns 'true' if resolution is Day or higher; otherwise returns 'false'.
LinearRegCustom | Overloaded. The function calculates linear reg custom.
Lowest | Overloaded. The function calculates the lowest series value.
Max | The function calculates min value from the args array.
Min | The function calculates min value from the 'args' array.
OpenNextBar | Return Open of a next bar. Can be used in signals/strategy with CalcAtOpenNextBarAttribute(true) attribute
Pivot<T> | Overloaded. The function calculates pivot values.
PivotHigh | Overloaded. The function calculates pivot high values.
PivotLow | Overloaded. The function calculates pivot low values.
RaiseRunTimeError | A function to raise a study's runtime exception.
StandardDeviation | The function calculates standard deviation.
StandardDeviationCustom | Overloaded. The function calculates custom standard deviation.
StandardError | The function calculates standard error value.
Summ | The function calculates the sum of series values.
SummationCustom | Overloaded. The function calculates the sum of series values.
SummationIf | Overloaded. The function calculates the sum of series values with condition.
SummCustom | This function calculates summ of array values
TimeNextBar | Return time for next bar. Can be used in signals/strategy with CalcAtOpenNextBarAttribute(true) attribute
TrueRange | Overloaded. The function returns TrueRange value for current bar of the base data stream.
TrueRangeCustom | Overloaded. The function returns TrueRangeCustom value for the offset 'bars ago' from current bar.
TrueRangeSeries | Overloaded. The function returns TrueRange series value.
UlcerIndex | The function calculates ulcer index.
Variance | The function calculates variance value.
VarianceCustom | Overloaded. The function calculates custom variance.
WAverageCustom | Overloaded. The function calculates the average series value.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PublicFunctions Class | PowerLanguage Namespace


Average Method

PowerLanguage.NET Help

PublicFunctions.Average Method

The function calculates the average of series values from current bar.

Overload List

The function calculates the average of series values from current bar.

public static double Average(this ISeries<double>,this int)

The function calculates the average of series values.

public static double Average(this ISeries<double>,this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Average(ISeries, Int32) Method

The function calculates the average of series values from current bar.

[Extension]
public static double Average(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements.

Return Value

The average of series values from current bar.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Average Overload List


PublicFunctions.Average(ISeries, Int32, Int32) Method

The function calculates the average of series values.

[Extension]
public static double Average(
this ISeries<double> seria,
this int length,
this int barOffset
);

Parameters

seria
Series values.
length
The number of elements.
barOffset
The number of bars ago.

Return Value

The average of series values.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Average Overload List


AverageCustom Method

PowerLanguage.NET Help

PublicFunctions.AverageCustom Method

The function calculates the average series value.

Overload List

The function calculates the average series value.

public static double AverageCustom(this ISeries<double>,this int)

The function calculates the average series value.

public static double AverageCustom(this ISeries<double>,this int,this int)

This function calculates average value of array

public static double AverageCustom(this double[],this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.AverageCustom(ISeries, Int32) Method

The function calculates the average series value.

[Extension]
public static double AverageCustom(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.

Return Value

The average series values.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.AverageCustom Overload List


PublicFunctions.AverageCustom(ISeries, Int32, Int32) Method

The function calculates the average series value.

[Extension]
public static double AverageCustom(
this ISeries<double> seria,
this int length,
this int offset
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
offset
The number of bars ago.

Return Value

The average series values.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.AverageCustom Overload List


PublicFunctions.AverageCustom(Double, Int32) Method

This function calculates average value of array

[Extension]
public static double AverageCustom(
this double[] prices,
this int length
);

Parameters

prices
length

Return Value

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.AverageCustom Overload List


PublicFunctions.Avg Method

The function calculates average value of the args array.

public static double Avg(
double firstArg,
params double[] args
);

Parameters

firstArg
First argument.
args
An array of values where average will be found.

Return Value

An average value from args array.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.BollingerBandCustom Method

The function calculates Bollinger Band custom.

[Extension]
public static double BollingerBandCustom(
this ISeries<double> prices,
this int length,
this double numDevs
);

Parameters

prices
Series values.
length
The number of elements.
numDevs

Return Value

Bollinger Band custom value.

See Also

PublicFunctions Class | PowerLanguage Namespace


Crosses<T> Method

PowerLanguage.NET Help

PublicFunctions.Crosses<T> Method

The function checks that series1 has desired value.

Overload List

The function checks that series1 has desired value.

public static bool Crosses<T>(this ISeries<T>,this T,this int,this IComparer<T>)

The function checks that series1 crosses series2.

public static bool Crosses<T>(this ISeries<T>,this ISeries<T>,this int,this IComparer<T>)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Crosses<T>(ISeries, T, Int32, IComparer) Method

The function checks that series1 has desired value.

[Extension]
public static bool Crosses<T>(
this ISeries<T> seria1,
this T val,
this int maxLookBack,
this IComparer<T> comparator
);

Parameters

seria1
Series values.
val
The desired value.
maxLookBack
The number of max bars back.
comparator
Comparator to find the crosses.

Return Value

True if series has desired value and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Crosses<T> Overload List


PublicFunctions.Crosses<T>(ISeries, ISeries, Int32, IComparer) Method

The function checks that series1 crosses series2.

[Extension]
public static bool Crosses<T>(
this ISeries<T> seria1,
this ISeries<T> seria2,
this int maxLookBack,
this IComparer<T> comparator
);

Parameters

seria1
First series values.
seria2
Second series values.
maxLookBack
The number of max bars back.
comparator
Comparator to find crosses.

Return Value

True if series1 crosses series2 and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Crosses<T> Overload List


CrossesOver Method

PowerLanguage.NET Help

PublicFunctions.CrossesOver Method

The function checks that series1 crosses series2.

Overload List

The function checks that series1 crosses series2.

public static bool CrossesOver(this ISeries<double>,this ISeries<double>,this int)

The function checks that series has desired value.

public static bool CrossesOver(this ISeries<double>,this double,this int)

The function checks that series1 crosses over series2.

public static bool CrossesOver(this IStudy,this ISeries<double>,this ISeries<double>)

The function checks that series has desired value.

public static bool CrossesOver(this IStudy,this ISeries<double>,this double)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.CrossesOver(ISeries, ISeries, Int32) Method

The function checks that series1 crosses series2.

[Extension]
public static bool CrossesOver(
this ISeries<double> seria1,
this ISeries<double> seria2,
this int maxLookBack
);

Parameters

seria1
First series values.
seria2
Second series values.
maxLookBack
The number of max bars back.

Return Value

True if series1 crosses series2 and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesOver Overload List


PublicFunctions.CrossesOver(ISeries, Double, Int32) Method

The function checks that series has desired value.

[Extension]
public static bool CrossesOver(
this ISeries<double> seria,
this double value,
this int maxLookBack
);

Parameters

seria
Series values.
value
The desired value.
maxLookBack
The number of max bars back.

Return Value

True if series has desired value and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesOver Overload List


PublicFunctions.CrossesOver(IStudy, ISeries, ISeries) Method

The function checks that series1 crosses over series2.

[Extension]
public static bool CrossesOver(
this IStudy _this,
this ISeries<double> seria1,
this ISeries<double> seria2
);

Parameters

_this
Study data.
seria1
First series values.
seria2
Second series values.

Return Value

True if series1 crosses series2 and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesOver Overload List


PublicFunctions.CrossesOver(IStudy, ISeries, Double) Method

The function checks that series has desired value.

[Extension]
public static bool CrossesOver(
this IStudy _this,
this ISeries<double> seria,
this double value
);

Parameters

_this
Study data.
seria
Series values.
value
The desired value.

Return Value

True if series has desired value and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesOver Overload List


CrossesUnder Method

PowerLanguage.NET Help

PublicFunctions.CrossesUnder Method

The function checks that series1 crosses series2.

Overload List

The function checks that series1 crosses series2.

public static bool CrossesUnder(this ISeries<double>,this ISeries<double>,this int)

The function checks that series has desired value.

public static bool CrossesUnder(this ISeries<double>,this double,this int)

The function checks that series1 crosses under series2.

public static bool CrossesUnder(this IStudy,this ISeries<double>,this ISeries<double>)

The function checks that series has desired value.

public static bool CrossesUnder(this IStudy,this ISeries<double>,this double)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.CrossesUnder(ISeries, ISeries, Int32) Method

The function checks that series1 crosses series2.

[Extension]
public static bool CrossesUnder(
this ISeries<double> seria1,
this ISeries<double> seria2,
this int maxLookBack
);

Parameters

seria1
First series values.
seria2
Second series values.
maxLookBack
The number of max bars back.

Return Value

True if series1 crosses series2 and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesUnder Overload List


PublicFunctions.CrossesUnder(ISeries, Double, Int32) Method

The function checks that series has desired value.

[Extension]
public static bool CrossesUnder(
this ISeries<double> seria,
this double value,
this int maxLookBack
);

Parameters

seria
Series values.
value
The desired value.
maxLookBack
The number of max bars back.

Return Value

True if series has desired value and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesUnder Overload List


PublicFunctions.CrossesUnder(IStudy, ISeries, ISeries) Method

The function checks that series1 crosses under series2.

[Extension]
public static bool CrossesUnder(
this IStudy _this,
this ISeries<double> seria1,
this ISeries<double> seria2
);

Parameters

_this
Study data.
seria1
First series values.
seria2
Second series values.

Return Value

True if series1 crosses series2 and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesUnder Overload List


PublicFunctions.CrossesUnder(IStudy, ISeries, Double) Method

The function checks that series has desired value.

[Extension]
public static bool CrossesUnder(
this IStudy _this,
this ISeries<double> seria,
this double value
);

Parameters

_this
Study data.
seria
Series values.
value
The desired value.

Return Value

True if series has desired value and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.CrossesUnder Overload List


PublicFunctions.CummRatio Method

The function calculates cumulative ratio value.

public static void CummRatio(
double[] _src,
double[] _dst,
int _count,
double _initial_value
);

Parameters

_src
Source data.
_dst
Destination data.
_count
Count of elements.
_initial_value
Initial value.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.DoubleEquals Method

The function checks that lval is not less than rval or lval is not greater than rval.

public static bool DoubleEquals(
double lval,
double rval
);

Parameters

lval
First value.
rval
Second value.

Return Value

True if lval is equal to rval, and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.DoubleGreater Method

The function checks that lval is greater than rval.

public static bool DoubleGreater(
double lval,
double rval
);

Parameters

lval
First value.
rval
Second value.

Return Value

True if lval is greater than rval, and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.DoubleGreaterEquals Method

The function checks that lval is greater than rval or lval is not less than rval.

public static bool DoubleGreaterEquals(
double lval,
double rval
);

Parameters

lval
First value.
rval
Second value.

Return Value

True if lval is greater than rval or lval is not less than rval, and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.DoubleLess Method

The function checks that 'lval' is less than 'rval'.

public static bool DoubleLess(
double lval,
double rval
);

Parameters

lval
First value.
rval
Second value.

Return Value

True if lval is less than rval, and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.DoubleLessEquals Method

The function checks that lval is less than rval or lval is not greater than rval.

public static bool DoubleLessEquals(
double lval,
double rval
);

Parameters

lval
First value.
rval
Second value.

Return Value

True if lval is less than rval or lval is not greater than rval, and false otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace


ExtremeHigh Method

PowerLanguage.NET Help

PublicFunctions.ExtremeHigh Method

The function calculates extremum high value.

Overload List

The function calculates extremum high value.

public static double ExtremeHigh(this ISeries<double>,this int,this int,this ref int)

The function calculates extremum high value.

public static double ExtremeHigh(this ISeries<double>,this int,this ref int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.ExtremeHigh(ISeries, Int32, Int32, Int32) Method

The function calculates extremum high value.

[Extension]
public static double ExtremeHigh(
this ISeries<double> seria,
this int length,
this int offset,
this ref int extremeBar
);

Parameters

seria
Series values.
length
The number of elements.
offset
Offset interval.
extremeBar
Extremum bar index.

Return Value

Extremum high value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.ExtremeHigh Overload List


PublicFunctions.ExtremeHigh(ISeries, Int32, Int32) Method

The function calculates extremum high value.

[Extension]
public static double ExtremeHigh(
this ISeries<double> seria,
this int length,
this ref int extremeBar
);

Parameters

seria
Series values.
length
The number of elements.
extremeBar
Extremum bar index.

Return Value

Extremum high value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.ExtremeHigh Overload List


ExtremeLow Method

PowerLanguage.NET Help

PublicFunctions.ExtremeLow Method

The function calculates extremum low value.

Overload List

The function calculates extremum low value.

public static double ExtremeLow(this ISeries<double>,this int,this int,this ref int)

The function calculates extremum low value.

public static double ExtremeLow(this ISeries<double>,this int,this ref int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.ExtremeLow(ISeries, Int32, Int32, Int32) Method

The function calculates extremum low value.

[Extension]
public static double ExtremeLow(
this ISeries<double> seria,
this int length,
this int offset,
this ref int extremeBar
);

Parameters

seria
Series values.
length
The number of elements.
offset
Offset interval.
extremeBar
Extremum bar index.

Return Value

Extremum low value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.ExtremeLow Overload List


PublicFunctions.ExtremeLow(ISeries, Int32, Int32) Method

The function calculates extremum low value.

[Extension]
public static double ExtremeLow(
this ISeries<double> seria,
this int length,
this ref int extremeBar
);

Parameters

seria
Series values.
length
The number of elements.
extremeBar
Extremum bar index.

Return Value

Extremum low value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.ExtremeLow Overload List


PublicFunctions.Extremum<T> Method

The function calculates extremum value.

[Extension]
public static T Extremum<T>(
this ISeries<T> seria1,
this int length,
this int offset,
this IComparer<T> comparator,
this ref int extremeBar
);

Parameters

seria1
Series values.
length
The number of elements.
offset
Offset interval for searsh.
comparator
Comparator to find the extremum.
extremeBar
Extremum bar index.

Return Value

Extremum value.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.GradientColor Method

The function to calculate gradient color of the input parameters.

public static Color GradientColor(
double val,
double min,
double max,
Color lcolor,
Color rcolor
);

Parameters

val
Value.
min
Min value.
max
Max value.
lcolor
Left color.
rcolor
Right color.

Return Value

Gradient color of the input parameters.

See Also

PublicFunctions Class | PowerLanguage Namespace


Highest Method

PowerLanguage.NET Help

PublicFunctions.Highest Method

The function calculates the highest series value.

Overload List

The function calculates the highest series value.

public static double Highest(this ISeries<double>,this int)

The function calculates the highest series value.

public static double Highest(this ISeries<double>,this int,this int)

The function calculates the highest series value.

public static double Highest(this ISeries<double>,this int,this out int)

The function calculates the highest series value.

public static double Highest(this ISeries<double>,this int,this out int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Highest(ISeries, Int32) Method

The function calculates the highest series value.

[Extension]
public static double Highest(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.

Return Value

The highest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Highest Overload List


PublicFunctions.Highest(ISeries, Int32, Int32) Method

The function calculates the highest series value.

[Extension]
public static double Highest(
this ISeries<double> seria,
this int length,
this int barsback
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
barsback
Bars back number.

Return Value

The highest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Highest Overload List


PublicFunctions.Highest(ISeries, Int32, Int32) Method

The function calculates the highest series value.

[Extension]
public static double Highest(
this ISeries<double> seria,
this int length,
this out int barOffset
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
barOffset
Index of highest series value.

Return Value

The highest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Highest Overload List


PublicFunctions.Highest(ISeries, Int32, Int32, Int32) Method

The function calculates the highest series value.

[Extension]
public static double Highest(
this ISeries<double> seria,
this int length,
this out int barOffset,
this int barsback
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
barOffset
Index of highest series value.
barsback
Bars back number.

Return Value

The highest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Highest Overload List


PublicFunctions.Iff<T> Method

The function that returns trueVal if the condition is true and returns falseVal if the condition is false.

public static T Iff<T>(
bool condition,
T trueVal,
T falseVal
);

Parameters

condition
Condition.
trueVal
Function returns value if the condition is true.
falseVal
Function returns value if the condition is false.

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.IsDayBased Method

Returns 'true' if resolution is Day or higher; otherwise returns 'false'.

[Extension]
public static bool IsDayBased(
this EResolution resolution
);

Parameters

resolution

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace


LinearRegCustom Method

PowerLanguage.NET Help

PublicFunctions.LinearRegCustom Method

The function calculates linear reg custom.

Overload List

The function calculates linear reg custom.

public static double LinearRegCustom(this ISeries<double>,this int,this int,this ref double,this ref double,this ref double)

The function calculates linear reg custom.

public static double LinearRegCustom(this ISeries<double>,this int,this int,this int,this ref double,this ref double,this ref double)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.LinearRegCustom(ISeries, Int32, Int32, Double, Double, Double) Method

The function calculates linear reg custom.

[Extension]
public static double LinearRegCustom(
this ISeries<double> seria,
this int length,
this int targetBar,
this ref double slope,
this ref double angle,
this ref double intercept
);

Parameters

seria
Series values.
length
The number of elements.
targetBar
Target bar value.
slope
Slope value.
angle
Angle value.
intercept
Intercept value.

Return Value

Linear reg custom value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.LinearRegCustom Overload List


PublicFunctions.LinearRegCustom(ISeries, Int32, Int32, Int32, Double, Double, Double) Method

The function calculates linear reg custom.

[Extension]
public static double LinearRegCustom(
this ISeries<double> seria,
this int length,
this int targetBar,
this int offset,
this ref double slope,
this ref double angle,
this ref double intercept
);

Parameters

seria
Series values.
length
Number of elements.
targetBar
Target bar value.
offset
Offset value.
slope
Slope value.
angle
Angle value.
intercept
Intercept value.

Return Value

Linear reg custom value.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.LinearRegCustom Overload List


Lowest Method

PowerLanguage.NET Help

PublicFunctions.Lowest Method

The function calculates the lowest series value.

Overload List

The function calculates the lowest series value.

public static double Lowest(this ISeries<double>,this int)

The function calculates the lowest series value.

public static double Lowest(this ISeries<double>,this int,this int)

The function calculates the lowest series value.

public static double Lowest(this ISeries<double>,this int,this out int)

The function calculates the lowest series value.

public static double Lowest(this ISeries<double>,this int,this out int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Lowest(ISeries, Int32) Method

The function calculates the lowest series value.

[Extension]
public static double Lowest(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.

Return Value

The lowest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Lowest Overload List


PublicFunctions.Lowest(ISeries, Int32, Int32) Method

The function calculates the lowest series value.

[Extension]
public static double Lowest(
this ISeries<double> seria,
this int length,
this int barsback
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
barsback
Bars back number.

Return Value

The lowest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Lowest Overload List


PublicFunctions.Lowest(ISeries, Int32, Int32) Method

The function calculates the lowest series value.

[Extension]
public static double Lowest(
this ISeries<double> seria,
this int length,
this out int barOffset
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
barOffset
Index of lowest series value.

Return Value

The lowest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Lowest Overload List


PublicFunctions.Lowest(ISeries, Int32, Int32, Int32) Method

The function calculates the lowest series value.

[Extension]
public static double Lowest(
this ISeries<double> seria,
this int length,
this out int barOffset,
this int barsback
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
barOffset
Index of lowest seria value.
barsback
Bars back number.

Return Value

The lowest series value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Lowest Overload List


PublicFunctions.Max Method

The function calculates min value from the args array.

public static double Max(
double firstArg,
params double[] args
);

Parameters

firstArg
First argument.
args
An array of values where maximum will be found.

Return Value

A max value from args array.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Min Method

The function calculates min value from the 'args' array.

public static double Min(
double firstArg,
params double[] args
);

Parameters

firstArg
First argument.
args
An array of values where minimum will be found.

Return Value

A min value from args array.

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.OpenNextBar Method

Return Open of a next bar. Can be used in signals/strategy with CalcAtOpenNextBarAttribute(true) attribute

[Extension]
public static double OpenNextBar(
this ISeriesSymbolData _this
);

Parameters

_this

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace


Pivot<T> Method

PowerLanguage.NET Help

PublicFunctions.Pivot<T> Method

The function calculates pivot values.

Overload List

The function calculates pivot values.

public static int Pivot<T>(this IStudy,this ISeries<T>,this int,this int,this int,this int,this int,this bool,this ref T,this ref int)

The function calculates pivot values.

public static int Pivot<T>(this IStudy,this ISeries<T>,this int,this int,this int,this int,this int,this IComparer<T>,this ref T,this ref int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Pivot<T>(IStudy, ISeries, Int32, Int32, Int32, Int32, Int32, Boolean, T, Int32) Method

The function calculates pivot values.

[Extension]
public static int Pivot<T>(
this IStudy tech,
this ISeries<T> seria,
this int barsLookBack,
this int leftStrength,
this int rightStrength,
this int instance,
this int offset,
this bool highLow,
this ref T pivotPrice,
this ref int pivotBar
)
where T : IComparable;

Parameters

tech
Technique data.
seria
Series values.
barsLookBack
Bars look back value.
leftStrength
The left strength value.
rightStrength
The right strength value.
instance
Instance value.
offset
Offset value.
highLow
Indicates whether high or low.
pivotPrice
Found pivot price.
pivotBar
Found pivot bar.

Return Value

1 if pivot is found and -1 otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Pivot<T> Overload List


PublicFunctions.Pivot<T>(IStudy, ISeries, Int32, Int32, Int32, Int32, Int32, IComparer, T, Int32) Method

The function calculates pivot values.

[Extension]
public static int Pivot<T>(
this IStudy tech,
this ISeries<T> seria,
this int length,
this int leftStrength,
this int rightStrength,
this int instance,
this int offset,
this IComparer<T> comparator,
this ref T pivotPrice,
this ref int pivotBar
);

Parameters

tech
Technique data.
seria
Series values.
length
The number of elements.
leftStrength
The left strength value.
rightStrength
The right strength value.
instance
Instance value.
offset
Offset value.
comparator
Comparator to find the pivot.
pivotPrice
Found pivot price.
pivotBar
Found pivot bar.

Return Value

1 if pivot is found and -1 otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.Pivot<T> Overload List


PivotHigh Method

PowerLanguage.NET Help

PublicFunctions.PivotHigh Method

The function calculates pivot high values.

Overload List

The function calculates pivot high values.

public static double PivotHigh(this IStudy,this ISeries<double>,this int,this int,this int,this int,this int,this ref int)

The function calculates pivot high values.

public static double PivotHigh(this IStudy,this ISeries<double>,this int,this int,this int,this int,this ref int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.PivotHigh(IStudy, ISeries, Int32, Int32, Int32, Int32, Int32, Int32) Method

The function calculates pivot high values.

[Extension]
public static double PivotHigh(
this IStudy tech,
this ISeries<double> seria,
this int barsLookBack,
this int leftStrength,
this int rightStrength,
this int instance,
this int offset,
this ref int pivotBar
);

Parameters

tech
Technique data.
seria
Series values.
barsLookBack
Bars look back value.
leftStrength
The left strength value.
rightStrength
The right strength value.
instance
Instance value.
offset
Offset value.
pivotBar
Found pivot bar.

Return Value

1 if pivot is found and -1 otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.PivotHigh Overload List


PublicFunctions.PivotHigh(IStudy, ISeries, Int32, Int32, Int32, Int32, Int32) Method

The function calculates pivot high values.

[Extension]
public static double PivotHigh(
this IStudy tech,
this ISeries<double> seria,
this int barsLookBack,
this int leftStrength,
this int rightStrength,
this int instance,
this ref int pivotBar
);

Parameters

tech
Technique data.
seria
Series values.
barsLookBack
Bars look back value.
leftStrength
The left strength value.
rightStrength
The right strength value.
instance
Instance value.
pivotBar
Found pivot bar.

Return Value

1 if pivot is found and -1 otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.PivotHigh Overload List


PivotLow Method

PowerLanguage.NET Help

PublicFunctions.PivotLow Method

The function calculates pivot low values.

Overload List

The function calculates pivot low values.

public static double PivotLow(this IStudy,this ISeries<double>,this int,this int,this int,this int,this int,this ref int)

The function calculates pivot low values.

public static double PivotLow(this IStudy,this ISeries<double>,this int,this int,this int,this int,this ref int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.PivotLow(IStudy, ISeries, Int32, Int32, Int32, Int32, Int32, Int32) Method

The function calculates pivot low values.

[Extension]
public static double PivotLow(
this IStudy tech,
this ISeries<double> seria,
this int barsLookBack,
this int leftStrength,
this int rightStrength,
this int instance,
this int offset,
this ref int pivotBar
);

Parameters

tech
Study data.
seria
Series values.
barsLookBack
Bars look back value.
leftStrength
The left strength value.
rightStrength
The right strength value.
instance
Instance value.
offset
Offset value.
pivotBar
Found pivot bar.

Return Value

1 if pivot is found and -1 otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.PivotLow Overload List


PublicFunctions.PivotLow(IStudy, ISeries, Int32, Int32, Int32, Int32, Int32) Method

The function calculates pivot low values.

[Extension]
public static double PivotLow(
this IStudy tech,
this ISeries<double> seria,
this int barsLookBack,
this int leftStrength,
this int rightStrength,
this int instance,
this ref int pivotBar
);

Parameters

tech
Study data.
seria
Series values.
barsLookBack
Bars look back value.
leftStrength
The left strength value.
rightStrength
The right strength value.
instance
Instance value.
pivotBar
Found pivot bar.

Return Value

1 if pivot is found and -1 otherwise.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.PivotLow Overload List


PublicFunctions.RaiseRunTimeError Method

A function to raise a study's runtime exception.

public static string RaiseRunTimeError(
string message
);

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.StandardDeviation Method

The function calculates standard deviation.

[Extension]
public static double StandardDeviation(
this double[] prices
);

Parameters

prices
Prices array.

Return Value

Standard deviation value.

See Also

PublicFunctions Class | PowerLanguage Namespace


StandardDeviationCustom Method

PowerLanguage.NET Help

PublicFunctions.StandardDeviationCustom Method

The function calculates custom standard deviation.

Overload List

The function calculates custom standard deviation.

public static double StandardDeviationCustom(this ISeries<double>,this int,this int)

The function calculates custom standard deviation.

public static double StandardDeviationCustom(this double[],this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.StandardDeviationCustom(ISeries, Int32, Int32) Method

The function calculates custom standard deviation.

[Extension]
public static double StandardDeviationCustom(
this ISeries<double> prices,
this int length,
this int dataType
);

Parameters

prices
Series values.
length
The number of elements.
dataType
Data type.

Return Value

Custom standard deviation value.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.StandardDeviationCustom Overload List


PublicFunctions.StandardDeviationCustom(Double, Int32, Int32) Method

The function calculates custom standard deviation.

[Extension]
public static double StandardDeviationCustom(
this double[] prices,
this int length,
this int dataType
);

Parameters

prices
length
dataType

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.StandardDeviationCustom Overload List


PublicFunctions.StandardError Method

The function calculates standard error value.

[Extension]
public static double StandardError(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements.

Return Value

Standard error value.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Summ Method

The function calculates the sum of series values.

[Extension]
public static double Summ(
this ISeries<double> seria,
this int length,
this int barOffset
);

Parameters

seria
Series values.
length
The number of elements.
barOffset
The number of bars ago.

Return Value

The sum of series values.

See Also

PublicFunctions Class | PowerLanguage Namespace


SummationCustom Method

PowerLanguage.NET Help

PublicFunctions.SummationCustom Method

The function calculates the sum of series values for current bar.

Overload List

The function calculates the sum of series values for current bar.

public static double SummationCustom(this ISeries<double>,this int)

The function calculates the sum of series values.

public static double SummationCustom(this ISeries<double>,this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.SummationCustom(ISeries, Int32) Method

The function calculates the sum of series values for current bar.

[Extension]
public static double SummationCustom(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.

Return Value

The sum of series values.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.SummationCustom Overload List


PublicFunctions.SummationCustom(ISeries, Int32, Int32) Method

The function calculates the sum of series values.

[Extension]
public static double SummationCustom(
this ISeries<double> seria,
this int length,
this int offset
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
offset
The number of bars ago.

Return Value

The sum of series values.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.SummationCustom Overload List


SummationIf Method

PowerLanguage.NET Help

PublicFunctions.SummationIf Method

The function calculates the sum of series values with condition for current bar.

Overload List

The function calculates the sum of series values with condition for current bar.

public static double SummationIf(ISeries<bool>,ISeries<double>,int)

The function calculates the sum of series values with condition.

public static double SummationIf(ISeries<bool>,ISeries<double>,int,int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.SummationIf(ISeries, ISeries, Int32) Method

The function calculates the sum of series values with condition for current bar.

public static double SummationIf(
ISeries<bool> ifSeria,
ISeries<double> seria,
int length
);

Parameters

ifSeria
Conditions array.
seria
Series values.
length
The number of elements. Parameter should be > 0.

Return Value

The sum of series values with conditions.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.SummationIf Overload List


PublicFunctions.SummationIf(ISeries, ISeries, Int32, Int32) Method

The function calculates the sum of series values with condition.

public static double SummationIf(
ISeries<bool> ifSeria,
ISeries<double> seria,
int length,
int offset
);

Parameters

ifSeria
Conditions array.
seria
Series values.
length
The number of elements. Parameter should be > 0.
offset
The number of bars ago.

Return Value

The sum of series values with conditions.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.SummationIf Overload List


PublicFunctions.SummCustom Method

This function calculates summ of array values

[Extension]
public static double SummCustom(
this double[] prices,
this int length
);

Parameters

prices
length

Return Value

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.TimeNextBar Method

Return time for next bar. Can be used in signals/strategy with CalcAtOpenNextBarAttribute(true) attribute

[Extension]
public static DateTime TimeNextBar(
this ISeriesSymbolData _this
);

Parameters

_this

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace


TrueRange Method

PowerLanguage.NET Help

PublicFunctions.TrueRange Method

The function returns TrueRange value for current bar of the base data stream.

Overload List

The function returns TrueRange value for current bar of the base data stream.

public static double TrueRange(this IStudy)

The function returns TrueRange value for the base datastream.

public static double TrueRange(this IStudy,this int)

The function returns TrueRangeCustom value for '_this' study data on data stream and 'barsback' bars ago.

public static double TrueRange(this IStudy,this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.TrueRange(IStudy) Method

The function returns TrueRange value for current bar of the base data stream.

[Extension]
public static double TrueRange(
this IStudy _this
);

Parameters

_this

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRange Overload List


PublicFunctions.TrueRange(IStudy, Int32) Method

The function returns TrueRange value for the base datastream.

[Extension]
public static double TrueRange(
this IStudy _this,
this int barsback
);

Parameters

_this
barsback

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRange Overload List


PublicFunctions.TrueRange(IStudy, Int32, Int32) Method

The function returns TrueRangeCustom value for '_this' study data on data stream and 'barsback' bars ago.

[Extension]
public static double TrueRange(
this IStudy _this,
this int barsback,
this int datastream
);

Parameters

_this
Study info.
barsback
Number of bars ago.
datastream
Data stream number.

Return Value

TrueRangeCustom value for '_this' study data on data stream and 'barsback' bars ago.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRange Overload List


TrueRangeCustom Method

PowerLanguage.NET Help

PublicFunctions.TrueRangeCustom Method

The function returns TrueRangeCustom value for the current bar.

Overload List

The function returns TrueRangeCustom value for the current bar.

public static double TrueRangeCustom(this ISeries<double>,this ISeries<double>,this ISeries<double>)

The function returns TrueRangeCustom value for the offset 'bars ago' from current bar.

public static double TrueRangeCustom(this ISeries<double>,this ISeries<double>,this ISeries<double>,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.TrueRangeCustom(ISeries, ISeries, ISeries) Method

The function returns TrueRangeCustom value for the current bar.

[Extension]
public static double TrueRangeCustom(
this ISeries<double> high,
this ISeries<double> low,
this ISeries<double> close
);

Parameters

high
Hight series values.
low
Low series values.
close
Close series values.

Return Value

TrueRangeCustom value for the current bar.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRangeCustom Overload List


PublicFunctions.TrueRangeCustom(ISeries, ISeries, ISeries, Int32) Method

The function returns TrueRangeCustom value for the offset 'bars ago' from current bar.

[Extension]
public static double TrueRangeCustom(
this ISeries<double> high,
this ISeries<double> low,
this ISeries<double> close,
this int offset
);

Parameters

high
High series values.
low
Low series values.
close
Close series values.
offset
The numerical expression specifying the number of bars back.

Return Value

TrueRangeCustom value for the offset 'bars ago' from current bar.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRangeCustom Overload List


TrueRangeSeries Method

PowerLanguage.NET Help

PublicFunctions.TrueRangeSeries Method

The function returns TrueRange series value.

Overload List

The function returns TrueRange series value.

public static ISeries<double> TrueRangeSeries(this IStudy)

The function returns TrueRange series value.

public static ISeries<double> TrueRangeSeries(this IStudy,this int)

The function returns TrueRange series value.

public static ISeries<double> TrueRangeSeries(this IStudy,this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.TrueRangeSeries(IStudy) Method

The function returns TrueRange series value.

[Extension]
public static ISeries<double> TrueRangeSeries(
this IStudy _this
);

Parameters

_this

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRangeSeries Overload List


PublicFunctions.TrueRangeSeries(IStudy, Int32) Method

The function returns TrueRange series value.

[Extension]
public static ISeries<double> TrueRangeSeries(
this IStudy _this,
this int bb
);

Parameters

_this
bb

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRangeSeries Overload List


PublicFunctions.TrueRangeSeries(IStudy, Int32, Int32) Method

The function returns TrueRange series value.

[Extension]
public static ISeries<double> TrueRangeSeries(
this IStudy _this,
this int bb,
this int datastream
);

Parameters

_this
bb
datastream

Return Value

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.TrueRangeSeries Overload List


PublicFunctions.UlcerIndex Method

The function calculates ulcer index.

[Extension]
public static double UlcerIndex(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements.

Return Value

Ulcer index value.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.Variance Method

The function calculates variance value.

[Extension]
public static double Variance(
this double[] prices
);

Parameters

prices
Prices array.

Return Value

Variance value.

See Also

PublicFunctions Class | PowerLanguage Namespace


VarianceCustom Method

PowerLanguage.NET Help

PublicFunctions.VarianceCustom Method

The function calculates custom variance.

Overload List

The function calculates custom variance.

public static double VarianceCustom(this ISeries<double>,this int,this int)

The function calculates custom variance.

public static double VarianceCustom(this double[],this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.VarianceCustom(ISeries, Int32, Int32) Method

The function calculates custom variance.

[Extension]
public static double VarianceCustom(
this ISeries<double> prices,
this int length,
this int dataType
);

Parameters

prices
Series values.
length
The number of elements.
dataType
Data type.

Return Value

Custom variance value.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.VarianceCustom Overload List


PublicFunctions.VarianceCustom(Double, Int32, Int32) Method

The function calculates custom variance.

[Extension]
public static double VarianceCustom(
this double[] prices,
this int length,
this int dataType
);

Parameters

prices
length
dataType

Return Value

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.VarianceCustom Overload List


WAverageCustom Method

PowerLanguage.NET Help

PublicFunctions.WAverageCustom Method

The function calculates the average series value.

Overload List

The function calculates the average series value.

public static double WAverageCustom(this ISeries<double>,this int)

The function calculates the average series value.

public static double WAverageCustom(this ISeries<double>,this int,this int)

See Also

PublicFunctions Class | PowerLanguage Namespace


PublicFunctions.WAverageCustom(ISeries, Int32) Method

The function calculates the average series value.

[Extension]
public static double WAverageCustom(
this ISeries<double> seria,
this int length
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.

Return Value

The average series values.

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.WAverageCustom Overload List


PublicFunctions.WAverageCustom(ISeries, Int32, Int32) Method

The function calculates the average series value.

[Extension]
public static double WAverageCustom(
this ISeries<double> seria,
this int length,
this int offset
);

Parameters

seria
Series values.
length
The number of elements. Parameter should be > 0.
offset
The number of bars ago. Parameter should be > 0.

Return Value

The average series values.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException |

See Also

PublicFunctions Class | PowerLanguage Namespace | PublicFunctions.WAverageCustom Overload List


RecoverDrawingsAttribute Class

The class that defines RecoverDrawingsAttribute.

For a list of all members of this type, see RecoverDrawingsAttribute Members .

System.Object
Attribute
RecoverDrawingsAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class RecoverDrawingsAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

RecoverDrawingsAttribute Members | PowerLanguage Namespace


RecoverDrawingsAttribute Members

RecoverDrawingsAttribute overview

Public Instance Constructors

RecoverDrawingsAttribute Overloaded. Initializes a new instance of the RecoverDrawingsAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. RecoverDrawingsAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

RecoverDrawingsAttribute Class | PowerLanguage Namespace


RecoverDrawingsAttribute Constructor

Initializes a new instance of the RecoverDrawingsAttribute class.

Overload List

Initializes a new instance of the RecoverDrawingsAttribute class.

public RecoverDrawingsAttribute()

Initializes a new instance of the RecoverDrawingsAttribute class.

public RecoverDrawingsAttribute(bool)

See Also

RecoverDrawingsAttribute Class | PowerLanguage Namespace


RecoverDrawingsAttribute Constructor

Initializes a new instance of the RecoverDrawingsAttribute class.

RecoverDrawingsAttribute(
bool value
);

Parameters

value
RecoverDrawingsAttribute value.

See Also

RecoverDrawingsAttribute Class | PowerLanguage Namespace | RecoverDrawingsAttribute Constructor Overload List


RecoverDrawingsAttribute Constructor

Initializes a new instance of the RecoverDrawingsAttribute class.

RecoverDrawingsAttribute();

See Also

RecoverDrawingsAttribute Class | PowerLanguage Namespace | RecoverDrawingsAttribute Constructor Overload List


RecoverDrawingsAttribute Properties

The properties of the RecoverDrawingsAttribute class are listed below. For a complete list of RecoverDrawingsAttribute class members, see the RecoverDrawingsAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. RecoverDrawingsAttribute value.

See Also

RecoverDrawingsAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

RecoverDrawingsAttribute.Value Property

Read-write property. RecoverDrawingsAttribute value.

public bool Value { public get; public set; }

See Also

RecoverDrawingsAttribute Class | PowerLanguage Namespace


RenkoBasis Enumeration

Enumeration represents whether on Close or OHLC "Renko" chart will be based on.

public enum RenkoBasis

Members

Member Name | Description
Close | Chart based on Close values.
OHLC | Chart based on open/high/low/close values.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


RenkoOptions Enumeration

Enumeration represents options for Renko chart type.

public enum RenkoOptions

Members

Member Name | Description
BOXSIZE | Bos size value.
SHOW_FANTOM_BAR | Show 'phantom' bars.
SHOW_WICK | Show wick.
SHOW_REAL_OPEN | Show real open.
BOXSIZE_TYPE | Box size value type.
BASIS | Base for Renko.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


RequestQuoteField Enumeration

Enumeration that describes quote field for the request.

public enum RequestQuoteField

Members

Member Name | Description
Bid | Bid Fields.
Trade | Trade Fields.
Ask | Ask Fields.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


RequestTimeZone Enumeration

Enumeration that describes time zone for the request.

public enum RequestTimeZone

Members

Member Name | Description
Local | Local Time Zone.
GMT | GMT Time Zone.
Exchange | Exchange Time Zone.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


Resolution Structure

The structure that defines a resolution.

For a list of all members of this type, see Resolution Members .

System.Object
Resolution

[Serializable]
public struct Resolution : IEquatable<T>

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

Resolution Members | PowerLanguage Namespace


Resolution Members

Resolution overview

Public Static Methods

CreateCumulativeDelta | Creates new instance of Cumulative Delta Resolution object.
CreateCustomDeltaResolution | Creates new instance of the regular resolution with volume data.
CreateCustomResolution | Creates new instance of Custom resolution.
CreateDeltaResolution | Creates new instance of the regular resolution with volume data.
CreateFootPrint | Creates new instance of Volume Delta Resolution object.
CreateHeikinAshi | Creates new instance of Heikin-Ashi Resolution object.
CreateHeikinAshiDelta | Creates new instance of Heikin-Ashi Resolution object with volume data.
CreateHeikinAshiParams | Creates "set of parameters" object for Heikin-Ashi plugin.
CreateKagi | Creates new instance of Kagi Resolution object.
CreateKagiDelta | Creates new instance of Kagi Resolution object with volume data.
CreateKagiParams | Creates "set of parameters" object for Kagi plugin.
CreateLineBreak | Creates new instance of Line Break Resolution object.
CreateLineBreakDelta | Creates new instance of Line Break Resolution object with volume data.
CreateLineBreakParams | Creates "set of parameters" object for Line Break plugin.
CreatePointAndFigure | Creates new instance of Point and Figure Resolution object.
CreatePointAndFigureDelta | Creates new instance of Point and Figure Resolution object with volume data.
CreatePointAndFigureParams | Creates "set of parameters" object for Point and Figure plugin.
CreateRenko | Overloaded. Creates new instance of Renko Resolution object.
CreateRenkoDelta | Creates new instance of Renko Resolution object with volume data.
CreateRenkoParams | Creates "set of parameters" object for Renko plugin.
CreateTPOResolution | Overloaded. Creates new instance of the regular resolution with TPO data.

Public Instance Constructors

Resolution Constructor Initializes a new instance of the Resolution object.

Public Instance Properties

Attributes | Read-write property. Resolution attributes.
BoxSize | Read-only property. Returns Box Size for Renko and Point and Figure chart types. Returns Reversal for Kagi chart type.
BoxType | Read-only property. Returns Box Type for Renko and Point and Figure chart types. Returns Reversal Type for Kagi chart type.
ChartType | Read-write property. Resolution chart type.
CustomResolutionName | Read-write property. Resolution chart type.
CustomResolutionParams | Read-write property. Resolution attributes.
DeltaType | Read-write property. Resolution delta type.
HaveDelta | Read-only property. Resolution attribute, providing information, whether the object supports loading of additional data with volume.
ResolutionName | Read-write property. Custom resolution name.
ResolutionUID | Read-write property. Resolution UID.
Size | Read-write property. Resolution size.
Type | Read-write property. Resolution type.

Public Instance Methods

Equals | Overloaded.
GetHashCode |
GetType (inherited from Object) |
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Resolution Class | PowerLanguage Namespace


Resolution Constructor

Initializes a new instance of the Resolution object.

Resolution(
EResolution type,
uint size
);

Parameters

type
Resolution type.
size
Resolution size.

See Also

Resolution Class | PowerLanguage Namespace


Resolution Properties

The properties of the Resolution structure are listed below. For a complete list of Resolution structure members, see the Resolution Members topic.

Public Instance Properties

Attributes | Read-write property. Resolution attributes.
BoxSize | Read-only property. Returns Box Size for Renko and Point and Figure chart types. Returns Reversal for Kagi chart type.
BoxType | Read-only property. Returns Box Type for Renko and Point and Figure chart types. Returns Reversal Type for Kagi chart type.
ChartType | Read-write property. Resolution chart type.
CustomResolutionName | Read-write property. Resolution chart type.
CustomResolutionParams | Read-write property. Resolution attributes.
DeltaType | Read-write property. Resolution delta type.
HaveDelta | Read-only property. Resolution attribute, providing information, whether the object supports loading of additional data with volume.
ResolutionName | Read-write property. Custom resolution name.
ResolutionUID | Read-write property. Resolution UID.
Size | Read-write property. Resolution size.
Type | Read-write property. Resolution type.

See Also

Resolution Class | PowerLanguage Namespace


Attributes Property

PowerLanguage.NET Help

Resolution.Attributes Property

Read-write property. Resolution attributes.

public Dictionary<int, object> Attributes { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


BoxSize Property

PowerLanguage.NET Help

Resolution.BoxSize Property

Read-only property. Returns Box Size for Renko and Point and Figure chart types. Returns Reversal for Kagi chart type.

public double BoxSize { public get; }

See Also

Resolution Class | PowerLanguage Namespace


BoxType Property

PowerLanguage.NET Help

Resolution.BoxType Property

Read-only property. Returns Box Type for Renko and Point and Figure chart types. Returns Reversal Type for Kagi chart type.

public BoxSizeType BoxType { public get; }

See Also

Resolution Class | PowerLanguage Namespace


ChartType Property

PowerLanguage.NET Help

Resolution.ChartType Property

Read-write property. Resolution chart type.

public ChartType ChartType { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


CustomResolutionName Property

PowerLanguage.NET Help

Resolution.CustomResolutionName Property

Read-write property. Resolution chart type.

public string CustomResolutionName { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


CustomResolutionParams Property

PowerLanguage.NET Help

Resolution.CustomResolutionParams Property

Read-write property. Resolution attributes.

public Dictionary<int, object> CustomResolutionParams { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


DeltaType Property

PowerLanguage.NET Help

Resolution.DeltaType Property

Read-write property. Resolution delta type.

public DeltaType DeltaType { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


HaveDelta Property

PowerLanguage.NET Help

Resolution.HaveDelta Property

Read-only property. Resolution attribute, providing information, whether the object supports loading of additional data with volume.

public bool HaveDelta { public get; }

See Also

Resolution Class | PowerLanguage Namespace


ResolutionName Property

PowerLanguage.NET Help

Resolution.ResolutionName Property

Read-write property. Custom resolution name.

public string ResolutionName { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


ResolutionUID Property

PowerLanguage.NET Help

Resolution.ResolutionUID Property

Read-write property. Resolution UID.

public string ResolutionUID { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


Size Property

PowerLanguage.NET Help

Resolution.Size Property

Read-write property. Resolution size.

public uint Size { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


Type Property

PowerLanguage.NET Help

Resolution.Type Property

Read-write property. Resolution type.

public EResolution Type { public get; public set; }

See Also

Resolution Class | PowerLanguage Namespace


Resolution Methods

The methods of the Resolution structure are listed below. For a complete list of Resolution structure members, see the Resolution Members topic.

Public Static Methods

CreateCumulativeDelta | Creates new instance of Cumulative Delta Resolution object.
CreateCustomDeltaResolution | Creates new instance of the regular resolution with volume data.
CreateCustomResolution | Creates new instance of Custom resolution.
CreateDeltaResolution | Creates new instance of the regular resolution with volume data.
CreateFootPrint | Creates new instance of Volume Delta Resolution object.
CreateHeikinAshi | Creates new instance of Heikin-Ashi Resolution object.
CreateHeikinAshiDelta | Creates new instance of Heikin-Ashi Resolution object with volume data.
CreateHeikinAshiParams | Creates "set of parameters" object for Heikin-Ashi plugin.
CreateKagi | Creates new instance of Kagi Resolution object.
CreateKagiDelta | Creates new instance of Kagi Resolution object with volume data.
CreateKagiParams | Creates "set of parameters" object for Kagi plugin.
CreateLineBreak | Creates new instance of Line Break Resolution object.
CreateLineBreakDelta | Creates new instance of Line Break Resolution object with volume data.
CreateLineBreakParams | Creates "set of parameters" object for Line Break plugin.
CreatePointAndFigure | Creates new instance of Point and Figure Resolution object.
CreatePointAndFigureDelta | Creates new instance of Point and Figure Resolution object with volume data.
CreatePointAndFigureParams | Creates "set of parameters" object for Point and Figure plugin.
CreateRenko | Overloaded. Creates new instance of Renko Resolution object.
CreateRenkoDelta | Creates new instance of Renko Resolution object with volume data.
CreateRenkoParams | Creates "set of parameters" object for Renko plugin.
CreateTPOResolution | Overloaded. Creates new instance of the regular resolution with TPO data.

Public Instance Methods

Equals | Overloaded.
GetHashCode |
GetType (inherited from Object) |
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateCumulativeDelta Method

Creates new instance of Cumulative Delta Resolution object.

public static Resolution CreateCumulativeDelta(
EResolution based_res_type,
uint based_res_size,
CumulativeDeltaChartType cum_delta_chart_type,
bool break_on_session
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
cum_delta_chart_type
Breakdown by: ... (Ack vs Bid, UpTicks vs DownTicks). CumulativeDeltaChartType
break_on_session
Break on session.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateCustomDeltaResolution Method

Creates new instance of the regular resolution with volume data.

public static Resolution CreateCustomDeltaResolution(
EResolution based_res_type,
uint based_res_size,
string plugin_name,
Dictionary<int, object> plugin_params,
bool break_on_session,
DeltaType deltaType,
BreakdownType breakdownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
plugin_name
Name of the user’s plugin.
plugin_params
Set of parameters for the plugin.
break_on_session
Break on session.
deltaType
Delta type value, used for resolution creation.
breakdownType
Breakdown by: ... (Ask vs Bid, UpTicks vs DownTicks).

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateCustomResolution Method

Creates new instance of Custom resolution.

public static Resolution CreateCustomResolution(
EResolution based_res_type,
uint based_res_size,
string plugin_name,
Dictionary<int, object> plugin_params,
bool break_on_session
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
plugin_name
Name of the user’s plugin.
plugin_params
Set of parameters for the plugin.
break_on_session
Break on session.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateDeltaResolution Method

Creates new instance of the regular resolution with volume data.

public static Resolution CreateDeltaResolution(
EResolution based_res_type,
uint based_res_size,
bool break_on_session,
DeltaType deltaType,
BreakdownType breakdownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
break_on_session
Break on session.
deltaType
Delta type value, used for resolution creation.
breakdownType
Breakdown by: ... (Ask vs Bid, UpTicks vs DownTicks).

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateFootPrint Method

Creates new instance of Volume Delta Resolution object.

public static Resolution CreateFootPrint(
EResolution based_res_type,
uint based_res_size,
CumulativeDeltaChartType cum_delta_chart_type,
FootPrintChartType foot_print_chart_type,
bool disp_as_percentage
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
cum_delta_chart_type
Breakdown by: ... (Ack vs Bid, UpTicks vs DownTicks). CumulativeDeltaChartType
foot_print_chart_type
Show Volume as: ... (Bid/Ask, Total, Delta). FootPrintChartType
disp_as_percentage
Displayed as a percentage.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateHeikinAshi Method

Creates new instance of Heikin-Ashi Resolution object.

public static Resolution CreateHeikinAshi(
EResolution based_res_type,
uint based_res_size,
bool break_on_session
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
break_on_session
Break on session.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateHeikinAshiDelta Method

Creates new instance of Heikin-Ashi Resolution object with volume data.

public static Resolution CreateHeikinAshiDelta(
EResolution based_res_type,
uint based_res_size,
bool break_on_session,
DeltaType deltaType,
BreakdownType breakDownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
break_on_session
Break on session.
deltaType
Delta type value, used for resolution creation.
breakDownType

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateHeikinAshiParams Method

Creates "set of parameters" object for Heikin-Ashi plugin.

public static Dictionary<int, object> CreateHeikinAshiParams();

Parameters

Return Value

Set of parameters for Heikin-Ashi plugin.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateKagi Method

Creates new instance of Kagi Resolution object.

public static Resolution CreateKagi(
EResolution based_res_type,
uint based_res_size,
KagiReversalType Type,
double Reversal,
double ReversalAsPercent,
bool break_on_session
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
Type
Kagi reversal type.
Reversal
Kagi reversal fixed value.
ReversalAsPercent
Kagi reversal value in percents.
break_on_session
Break on session.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateKagiDelta Method

Creates new instance of Kagi Resolution object with volume data.

public static Resolution CreateKagiDelta(
EResolution based_res_type,
uint based_res_size,
KagiReversalType Type,
double Reversal,
double ReversalAsPercent,
bool break_on_session,
DeltaType deltaType,
BreakdownType breakDownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
Type
Kagi reversal type.
Reversal
Kagi reversal fixed value.
ReversalAsPercent
Kagi reversal value in percents.
break_on_session
Break on session.
deltaType
Delta type value, used for resolution creation.
breakDownType

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateKagiParams Method

Creates "set of parameters" object for Kagi plugin.

public static Dictionary<int, object> CreateKagiParams(
KagiReversalType Type,
double Reversal
);

Parameters

Type
Kagi reversal type.
Reversal
Kagi reversal fixed value.

Return Value

Set of parameters for Kagi plugin.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateLineBreak Method

Creates new instance of Line Break Resolution object.

public static Resolution CreateLineBreak(
EResolution based_res_type,
uint based_res_size,
int line_break_count,
bool break_on_session
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
line_break_count
Line Breaks count.
break_on_session
Break on session.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateLineBreakDelta Method

Creates new instance of Line Break Resolution object with volume data.

public static Resolution CreateLineBreakDelta(
EResolution based_res_type,
uint based_res_size,
int line_break_count,
bool break_on_session,
DeltaType deltaType,
BreakdownType breakDownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
line_break_count
Line Breaks count.
break_on_session
Break on session.
deltaType
Delta type value, used for resolution creation.
breakDownType

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateLineBreakParams Method

Creates "set of parameters" object for Line Break plugin.

public static Dictionary<int, object> CreateLineBreakParams(
int line_break_count
);

Parameters

line_break_count
Line Breaks count.

Return Value

Set of parameters for Line Break plugin.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreatePointAndFigure Method

Creates new instance of Point and Figure Resolution object.

public static Resolution CreatePointAndFigure(
EResolution based_res_type,
uint based_res_size,
double box_size,
int reversal,
PointAndFigureBasis _basis,
bool break_on_session
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
box_size
Box size.
reversal
Reversal.
_basis
Point and Figure basis.
break_on_session
Break on session.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreatePointAndFigureDelta Method

Creates new instance of Point and Figure Resolution object with volume data.

public static Resolution CreatePointAndFigureDelta(
EResolution based_res_type,
uint based_res_size,
double box_size,
int reversal,
PointAndFigureBasis _basis,
bool break_on_session,
DeltaType deltaType,
BreakdownType breakDownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
box_size
Box size.
reversal
Reversal.
_basis
Point and Figure basis.
break_on_session
Break on session.
deltaType
Delta type value, used for resolution creation.
breakDownType

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreatePointAndFigureParams Method

Creates "set of parameters" object for Point and Figure plugin.

public static Dictionary<int, object> CreatePointAndFigureParams(
double box_size,
int reversal,
PointAndFigureBasis _basis
);

Parameters

box_size
Box size.
reversal
Reversal.
_basis
Point and Figure basis.

Return Value

Set of parameters for Point and Figure plugin.

See Also

Resolution Class | PowerLanguage Namespace


CreateRenko Method

PowerLanguage.NET Help

Resolution.CreateRenko Method

Creates new instance of Renko Resolution object.

Overload List

Creates new instance of Renko Resolution object.

public static Resolution CreateRenko(EResolution,uint,BoxSizeType,double,RenkoBasis,bool,bool,bool,bool)

Creates new instance of Renko Resolution object.

public static Resolution CreateRenko(EResolution,uint,BoxSizeType,double,bool,bool,bool,bool)

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateRenko(EResolution, UInt32, BoxSizeType, Double, RenkoBasis, Boolean, Boolean, Boolean, Boolean) Method

Creates new instance of Renko Resolution object.

public static Resolution CreateRenko(
EResolution based_res_type,
uint based_res_size,
BoxSizeType Type,
double BoxSize,
RenkoBasis basis,
bool break_on_session,
bool show_fantom_bars,
bool show_wick,
bool show_real_open
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
Type
Box Size type.
BoxSize
Box Size value.
basis
Renko basis.
break_on_session
Break on session.
show_fantom_bars
Show 'Phantom' bars.
show_wick
Show wick.
show_real_open
Show real open.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace | Resolution.CreateRenko Overload List


Resolution.CreateRenko(EResolution, UInt32, BoxSizeType, Double, Boolean, Boolean, Boolean, Boolean) Method

Creates new instance of Renko Resolution object.

public static Resolution CreateRenko(
EResolution based_res_type,
uint based_res_size,
BoxSizeType Type,
double BoxSize,
bool break_on_session,
bool show_fantom_bars,
bool show_wick,
bool show_real_open
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
Type
Box Size type.
BoxSize
Box Size value.
break_on_session
Break on session.
show_fantom_bars
Show 'Phantom' bars.
show_wick
Show wick.
show_real_open
Show real open.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace | Resolution.CreateRenko Overload List


Resolution.CreateRenkoDelta Method

Creates new instance of Renko Resolution object with volume data.

public static Resolution CreateRenkoDelta(
EResolution based_res_type,
uint based_res_size,
BoxSizeType Type,
double BoxSize,
RenkoBasis basis,
bool break_on_session,
bool show_fantom_bars,
bool show_wick,
bool show_real_open,
DeltaType deltaType,
BreakdownType breakDownType
);

Parameters

based_res_type
Resolution type.
based_res_size
Resolution size.
Type
Box Size type.
BoxSize
Box Size value.
basis
Renko basis.
break_on_session
Break on session.
show_fantom_bars
Show 'Phantom' bars.
show_wick
Show wick.
show_real_open
Show real open.
deltaType
Delta type value, used for resolution creation.
breakDownType

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateRenkoParams Method

Creates "set of parameters" object for Renko plugin.

public static Dictionary<int, object> CreateRenkoParams(
BoxSizeType Type,
double BoxSize,
RenkoBasis basis,
bool show_fantom_bars,
bool show_wick,
bool show_real_open
);

Parameters

Type
Box Size type.
BoxSize
Box Size value.
basis
Renko basis.
show_fantom_bars
Show 'Phantom' bars.
show_wick
Show wick.
show_real_open
Show real open.

Return Value

Set of parameters for Renko plugin.

See Also

Resolution Class | PowerLanguage Namespace


CreateTPOResolution Method

PowerLanguage.NET Help

Resolution.CreateTPOResolution Method

Creates new instance of the regular resolution with TPO data.

Overload List

Creates new instance of the regular resolution with TPO data.

public static Resolution CreateTPOResolution(EResolution,uint,TPOBase)

Creates new instance of the regular resolution with TPO data.

public static Resolution CreateTPOResolution(EResolution,uint,TPOBase,int)

See Also

Resolution Class | PowerLanguage Namespace


Resolution.CreateTPOResolution(EResolution, UInt32, TPOBase) Method

Creates new instance of the regular resolution with TPO data.

public static Resolution CreateTPOResolution(
EResolution based_res_type,
uint based_res_size,
TPOBase _base
);

Parameters

based_res_type
Resolution type. TPO can be build on Day, Month, Quarter or Year resolutions.
based_res_size
Resolution size.
_base
TPO base type. Possible values: ticks, minutes, days.

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace | Resolution.CreateTPOResolution Overload List


Resolution.CreateTPOResolution(EResolution, UInt32, TPOBase, Int32) Method

Creates new instance of the regular resolution with TPO data.

public static Resolution CreateTPOResolution(
EResolution based_res_type,
uint based_res_size,
TPOBase _base,
int block_size
);

Parameters

based_res_type
Resolution type. TPO can be build on Day, Month, Quarter or Year resolutions.
based_res_size
Resolution size.
_base
TPO base type. Possible values: ticks, minutes, days.
block_size
Block size value, used for resolution creation. Is ignored when based_res_type equals Month, Quarter or Year (for this types equals 1).

Return Value

New Resolution instance.

See Also

Resolution Class | PowerLanguage Namespace | Resolution.CreateTPOResolution Overload List


Equals Method

PowerLanguage.NET Help

Resolution.Equals Method

Overload List

public bool Equals(Resolution)

public override bool Equals(object)

See Also

Resolution Class | PowerLanguage Namespace


Resolution.Equals(Resolution) Method

public bool Equals(
Resolution other
);

Implements

IEquatable< Resolution>.Equals

See Also

Resolution Class | PowerLanguage Namespace | Resolution.Equals Overload List


Resolution.Equals(Object) Method

public override bool Equals(
object obj
);

See Also

Resolution Class | PowerLanguage Namespace | Resolution.Equals Overload List


Resolution.GetHashCode Method

public override int GetHashCode();

See Also

Resolution Class | PowerLanguage Namespace


ResourceUtils Class

Resource Utils class

For a list of all members of this type, see ResourceUtils Members .

System.Object
ResourceUtils

[Extension]
public static class ResourceUtils

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

ResourceUtils Members | PowerLanguage Namespace


ResourceUtils Members

ResourceUtils overview

Public Static Properties

ActualCategories | Actual categories
ActualResolutions | Actual resolutions
AllBuildVolumeOns | All resolutions
AllCategories | All categories
AllRequestQuoteFields | All resolutions
AllRequestTimeZones | All resolutions
AllResolutions | All resolutions

Public Static Methods

ToBuildVolumeOn | Convert resource name to actual BuildVolumeOn
ToCommandLine | Convert actual categories to CommandLine
ToRequestQuoteField | Convert resource name to actual RequestQuoteField
ToRequestTimeZone | Convert resource name to actual RequestTimeZone
ToResolution | Convert resource name to actual resolution
ToResourceName | Overloaded. Convert actual categories to resource name
ToResourceNameOrValue | Overloaded. Convert actual categories to resource name
ToSymbolCategory | Convert resource name to actual category

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils Properties

The properties of the ResourceUtils class are listed below. For a complete list of ResourceUtils class members, see the ResourceUtils Members topic.

Public Static Properties

ActualCategories | Actual categories
ActualResolutions | Actual resolutions
AllBuildVolumeOns | All resolutions
AllCategories | All categories
AllRequestQuoteFields | All resolutions
AllRequestTimeZones | All resolutions
AllResolutions | All resolutions

See Also

ResourceUtils Class | PowerLanguage Namespace


ActualCategories Property

PowerLanguage.NET Help

ResourceUtils.ActualCategories Property

Actual categories

public static ESymbolCategory[] ActualCategories { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


ActualResolutions Property

PowerLanguage.NET Help

ResourceUtils.ActualResolutions Property

Actual resolutions

public static EResolution[] ActualResolutions { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


AllBuildVolumeOns Property

PowerLanguage.NET Help

ResourceUtils.AllBuildVolumeOns Property

All resolutions

public static BuildVolumeOn[] AllBuildVolumeOns { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


AllCategories Property

PowerLanguage.NET Help

ResourceUtils.AllCategories Property

All categories

public static ESymbolCategory[] AllCategories { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


AllRequestQuoteFields Property

PowerLanguage.NET Help

ResourceUtils.AllRequestQuoteFields Property

All resolutions

public static RequestQuoteField[] AllRequestQuoteFields { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


AllRequestTimeZones Property

PowerLanguage.NET Help

ResourceUtils.AllRequestTimeZones Property

All resolutions

public static RequestTimeZone[] AllRequestTimeZones { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


AllResolutions Property

PowerLanguage.NET Help

ResourceUtils.AllResolutions Property

All resolutions

public static EResolution[] AllResolutions { public get; }

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils Methods

The methods of the ResourceUtils class are listed below. For a complete list of ResourceUtils class members, see the ResourceUtils Members topic.

Public Static Methods

ToBuildVolumeOn | Convert resource name to actual BuildVolumeOn
ToCommandLine | Convert actual categories to CommandLine
ToRequestQuoteField | Convert resource name to actual RequestQuoteField
ToRequestTimeZone | Convert resource name to actual RequestTimeZone
ToResolution | Convert resource name to actual resolution
ToResourceName | Overloaded. Convert actual categories to resource name
ToResourceNameOrValue | Overloaded. Convert actual categories to resource name
ToSymbolCategory | Convert resource name to actual category

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToBuildVolumeOn Method

Convert resource name to actual BuildVolumeOn

[Extension]
public static BuildVolumeOn ToBuildVolumeOn(
this string value
);

Parameters

value

Return Value

BuildVolumeOn

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToCommandLine Method

Convert actual categories to CommandLine

[Extension]
public static string ToCommandLine(
this ESymbolCategory symbolCategory
);

Parameters

symbolCategory

Return Value

Command line

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToRequestQuoteField Method

Convert resource name to actual RequestQuoteField

[Extension]
public static RequestQuoteField ToRequestQuoteField(
this string value
);

Parameters

value

Return Value

RequestQuoteField

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToRequestTimeZone Method

Convert resource name to actual RequestTimeZone

[Extension]
public static RequestTimeZone ToRequestTimeZone(
this string value
);

Parameters

value

Return Value

RequestTimeZone

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToResolution Method

Convert resource name to actual resolution

[Extension]
public static EResolution ToResolution(
this string resourceName
);

Parameters

resourceName

Return Value

Resolution

See Also

ResourceUtils Class | PowerLanguage Namespace


ToResourceName Method

PowerLanguage.NET Help

ResourceUtils.ToResourceName Method

Convert actual BuildVolumeOn to resource name

Overload List

Convert actual BuildVolumeOn to resource name

public static string ToResourceName(this BuildVolumeOn)

Convert actual resolutions to resource name

public static string ToResourceName(this EResolution)

Convert actual categories to resource name

public static string ToResourceName(this ESymbolCategory)

Convert actual RequestQuoteField to resource name

public static string ToResourceName(this RequestQuoteField)

Convert actual RequestTimeZone to resource name

public static string ToResourceName(this RequestTimeZone)

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToResourceName(BuildVolumeOn) Method

Convert actual BuildVolumeOn to resource name

[Extension]
public static string ToResourceName(
this BuildVolumeOn value
);

Parameters

value

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceName Overload List


ResourceUtils.ToResourceName(EResolution) Method

Convert actual resolutions to resource name

[Extension]
public static string ToResourceName(
this EResolution resolution
);

Parameters

resolution

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceName Overload List


ResourceUtils.ToResourceName(ESymbolCategory) Method

Convert actual categories to resource name

[Extension]
public static string ToResourceName(
this ESymbolCategory symbolCategory
);

Parameters

symbolCategory

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceName Overload List


ResourceUtils.ToResourceName(RequestQuoteField) Method

Convert actual RequestQuoteField to resource name

[Extension]
public static string ToResourceName(
this RequestQuoteField value
);

Parameters

value

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceName Overload List


ResourceUtils.ToResourceName(RequestTimeZone) Method

Convert actual RequestTimeZone to resource name

[Extension]
public static string ToResourceName(
this RequestTimeZone value
);

Parameters

value

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceName Overload List


ToResourceNameOrValue Method

PowerLanguage.NET Help

ResourceUtils.ToResourceNameOrValue Method

Convert actual BuildVolumeOn to resource name

Overload List

Convert actual BuildVolumeOn to resource name

public static string ToResourceNameOrValue(this BuildVolumeOn)

Convert actual resolutions to resource name

public static string ToResourceNameOrValue(this EResolution)

Convert actual categories to resource name

public static string ToResourceNameOrValue(this ESymbolCategory)

Convert actual RequestQuoteField to resource name

public static string ToResourceNameOrValue(this RequestQuoteField)

Convert actual RequestTimeZone to resource name

public static string ToResourceNameOrValue(this RequestTimeZone)

See Also

ResourceUtils Class | PowerLanguage Namespace


ResourceUtils.ToResourceNameOrValue(BuildVolumeOn) Method

Convert actual BuildVolumeOn to resource name

[Extension]
public static string ToResourceNameOrValue(
this BuildVolumeOn value
);

Parameters

value

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceNameOrValue Overload List


ResourceUtils.ToResourceNameOrValue(EResolution) Method

Convert actual resolutions to resource name

[Extension]
public static string ToResourceNameOrValue(
this EResolution resolution
);

Parameters

resolution

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceNameOrValue Overload List


ResourceUtils.ToResourceNameOrValue(ESymbolCategory) Method

Convert actual categories to resource name

[Extension]
public static string ToResourceNameOrValue(
this ESymbolCategory symbolCategory
);

Parameters

symbolCategory

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceNameOrValue Overload List


ResourceUtils.ToResourceNameOrValue(RequestQuoteField) Method

Convert actual RequestQuoteField to resource name

[Extension]
public static string ToResourceNameOrValue(
this RequestQuoteField value
);

Parameters

value

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceNameOrValue Overload List


ResourceUtils.ToResourceNameOrValue(RequestTimeZone) Method

Convert actual RequestTimeZone to resource name

[Extension]
public static string ToResourceNameOrValue(
this RequestTimeZone value
);

Parameters

value

Return Value

Resource name

See Also

ResourceUtils Class | PowerLanguage Namespace | ResourceUtils.ToResourceNameOrValue Overload List


ResourceUtils.ToSymbolCategory Method

Convert resource name to actual category

[Extension]
public static ESymbolCategory ToSymbolCategory(
this string resourceName
);

Parameters

resourceName

Return Value

Symbol category

See Also

ResourceUtils Class | PowerLanguage Namespace


SameAsSymbolAttribute Class

Setting that defines whether the indicator is marked "Same As Symbol" or not.

For a list of all members of this type, see SameAsSymbolAttribute Members .

System.Object
Attribute
SameAsSymbolAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class SameAsSymbolAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SameAsSymbolAttribute Members | PowerLanguage Namespace


SameAsSymbolAttribute Members

SameAsSymbolAttribute overview

Public Instance Constructors

SameAsSymbolAttribute Overloaded. Initializes a new instance of the SameAsSymbolAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. SameAsSymbolAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SameAsSymbolAttribute Class | PowerLanguage Namespace


SameAsSymbolAttribute Constructor

Initializes a new instance of the SameAsSymbolAttribute class.

Overload List

Initializes a new instance of the SameAsSymbolAttribute class.

public SameAsSymbolAttribute()

Initializes a new instance of the SameAsSymbolAttribute class.

public SameAsSymbolAttribute(bool)

See Also

SameAsSymbolAttribute Class | PowerLanguage Namespace


SameAsSymbolAttribute Constructor

Initializes a new instance of the SameAsSymbolAttribute class.

SameAsSymbolAttribute(
bool value
);

Parameters

value
SameAsSymbolAttribute value.

See Also

SameAsSymbolAttribute Class | PowerLanguage Namespace | SameAsSymbolAttribute Constructor Overload List


SameAsSymbolAttribute Constructor

Initializes a new instance of the SameAsSymbolAttribute class.

SameAsSymbolAttribute();

See Also

SameAsSymbolAttribute Class | PowerLanguage Namespace | SameAsSymbolAttribute Constructor Overload List


SameAsSymbolAttribute Properties

The properties of the SameAsSymbolAttribute class are listed below. For a complete list of SameAsSymbolAttribute class members, see the SameAsSymbolAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. SameAsSymbolAttribute value.

See Also

SameAsSymbolAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

SameAsSymbolAttribute.Value Property

Read-write property. SameAsSymbolAttribute value.

public bool Value { public get; public set; }

See Also

SameAsSymbolAttribute Class | PowerLanguage Namespace


SessionNotFoundException Class

The exception displayed when a session is not found.

For a list of all members of this type, see SessionNotFoundException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
SessionNotFoundException

[Serializable]
public class SessionNotFoundException : ExecuteStudyException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SessionNotFoundException Members | PowerLanguage Namespace


SessionNotFoundException Members

SessionNotFoundException overview

Public Instance Constructors

SessionNotFoundException Overloaded. Initializes a new instance of the SessionNotFoundException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
HResult (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

SessionNotFoundException Overloaded. Initializes a new instance of the SessionNotFoundException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

SessionNotFoundException Class | PowerLanguage Namespace


SessionNotFoundException Constructor

Initializes a new instance of the SessionNotFoundException class.

Overload List

Initializes a new instance of the SessionNotFoundException class.

protected SessionNotFoundException(SerializationInfo,StreamingContext)

Initializes a new instance of the SessionNotFoundException class.

public SessionNotFoundException(string)

See Also

SessionNotFoundException Class | PowerLanguage Namespace


SessionNotFoundException Constructor

Initializes a new instance of the SessionNotFoundException class.

SessionNotFoundException(
string errorMsg
);

See Also

SessionNotFoundException Class | PowerLanguage Namespace | SessionNotFoundException Constructor Overload List


SessionNotFoundException Constructor

Initializes a new instance of the SessionNotFoundException class.

SessionNotFoundException(
SerializationInfo info,
StreamingContext context
);

See Also

SessionNotFoundException Class | PowerLanguage Namespace | SessionNotFoundException Constructor Overload List


SessionObject Class

The class that defines a session object.

For a list of all members of this type, see SessionObject Members .

System.Object
SessionObject

public class SessionObject

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SessionObject Members | PowerLanguage Namespace


SessionObject Members

SessionObject overview

Public Static Operators

Equality Operator
Inequality Operator

Public Instance Constructors

SessionObject Overloaded. Initializes a new instance of the SessionObject class.

Public Instance Properties

EndDay | End session day.
EndOfSession | End of session attribute.
EndTime | End session time.
StartDay | Start session day.
StartTime | Start session time.

Public Instance Methods

Equals | Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject Constructor

Initializes a new instance of the SessionObject.

Overload List

Initializes a new instance of the SessionObject.

public SessionObject(DayOfWeek,DayOfWeek,TimeSpan,TimeSpan,bool)

Initializes a new instance of the SessionObject.

public SessionObject(int,int,double,double,bool)

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject Constructor

Initializes a new instance of the SessionObject.

SessionObject(
DayOfWeek startDay,
DayOfWeek endDay,
TimeSpan startTime,
TimeSpan endTime,
bool seok
);

Parameters

startDay
Start session day.
endDay
End session day.
startTime
Start session time.
endTime
End session time.
seok
End of session attribute.

See Also

SessionObject Class | PowerLanguage Namespace | SessionObject Constructor Overload List


SessionObject Constructor

Initializes a new instance of the SessionObject.

SessionObject(
int startDay,
int endDay,
double startTime,
double endTime,
bool seok
);

Parameters

startDay
Start session day.
endDay
End session day.
startTime
Start session time.
endTime
End session time.
seok
End of session attribute.

See Also

SessionObject Class | PowerLanguage Namespace | SessionObject Constructor Overload List


SessionObject Properties

The properties of the SessionObject class are listed below. For a complete list of SessionObject class members, see the SessionObject Members topic.

Public Instance Properties

EndDay | End session day.
EndOfSession | End of session attribute.
EndTime | End session time.
StartDay | Start session day.
StartTime | Start session time.

See Also

SessionObject Class | PowerLanguage Namespace


EndDay Property

PowerLanguage.NET Help

SessionObject.EndDay Property

End session day.

public DayOfWeek EndDay { public get; private set; }

See Also

SessionObject Class | PowerLanguage Namespace


EndOfSession Property

PowerLanguage.NET Help

SessionObject.EndOfSession Property

End of session attribute.

public bool EndOfSession { public get; private set; }

See Also

SessionObject Class | PowerLanguage Namespace


EndTime Property

PowerLanguage.NET Help

SessionObject.EndTime Property

End session time.

public TimeSpan EndTime { public get; private set; }

See Also

SessionObject Class | PowerLanguage Namespace


StartDay Property

PowerLanguage.NET Help

SessionObject.StartDay Property

Start session day.

public DayOfWeek StartDay { public get; private set; }

See Also

SessionObject Class | PowerLanguage Namespace


StartTime Property

PowerLanguage.NET Help

SessionObject.StartTime Property

Start session time.

public TimeSpan StartTime { public get; private set; }

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject Methods

The methods of the SessionObject class are listed below. For a complete list of SessionObject class members, see the SessionObject Members topic.

Public Instance Methods

Equals | Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject.Equals Method

Determines whether the specified Object is equal to the current Object.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with the current Object.

Return Value

true if the specified Object is equal to the current Object; otherwise, false.

Exceptions

Exception Type | Condition
NullReferenceException | The obj parameter is null.

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject.GetHashCode Method

Serves as a hash function for a particular type.

public override int GetHashCode();

Return Value

A hash code for the current Object.

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject Operators

The operators of the SessionObject class are listed below. For a complete list of SessionObject class members, see the SessionObject Members topic.

Public Static Operators

Equality Operator
Inequality Operator

See Also

SessionObject Class | SessionObject Members | PowerLanguage Namespace


SessionObject Equality Operator

public static bool operator ==(
SessionObject left,
SessionObject right
);

Parameters

left
right

Return Value

See Also

SessionObject Class | PowerLanguage Namespace


SessionObject Inequality Operator

public static bool operator !=(
SessionObject left,
SessionObject right
);

Parameters

left
right

Return Value

See Also

SessionObject Class | PowerLanguage Namespace


SessionsParser Class

Sessions parser class

For a list of all members of this type, see SessionsParser Members .

System.Object
SessionsParser

public sealed class SessionsParser

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SessionsParser Members | PowerLanguage Namespace


SessionsParser Members

SessionsParser overview

Public Static Methods

ParseTZI

Public Instance Constructors

SessionsParser Constructor Initializes a new instance of the SessionsParser class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SessionsParser Class | PowerLanguage Namespace


SessionsParser Constructor

Initializes a new instance of the SessionsParser class.

SessionsParser();

See Also

SessionsParser Class | PowerLanguage Namespace


SessionsParser Methods

The methods of the SessionsParser class are listed below. For a complete list of SessionsParser class members, see the SessionsParser Members topic.

Public Static Methods

ParseTZI

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SessionsParser Class | PowerLanguage Namespace


SessionsParser.ParseTZI Method

public static TimeZoneInfo ParseTZI(
string _session_time_zone_info
);

See Also

SessionsParser Class | PowerLanguage Namespace


SetLambda<T> Delegate

Delegate SetLambda

public delegate void SetLambda<T>(
T value
);

Parameters

value

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


SkipIdenticalTicksAttribute Class

The class that defines SkipIdenticalTicksAttribute.

For a list of all members of this type, see SkipIdenticalTicksAttribute Members .

System.Object
Attribute
SkipIdenticalTicksAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class SkipIdenticalTicksAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SkipIdenticalTicksAttribute Members | PowerLanguage Namespace


SkipIdenticalTicksAttribute Members

SkipIdenticalTicksAttribute overview

Public Instance Constructors

SkipIdenticalTicksAttribute Overloaded. Initializes a new instance of the SkipIdenticalTicksAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. SkipIdenticalTicksAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SkipIdenticalTicksAttribute Class | PowerLanguage Namespace


SkipIdenticalTicksAttribute Constructor

Initializes a new instance of the SkipIdenticalTicksAttribute class.

Overload List

Initializes a new instance of the SkipIdenticalTicksAttribute class.

public SkipIdenticalTicksAttribute()

Initializes a new instance of the SkipIdenticalTicksAttribute class.

public SkipIdenticalTicksAttribute(bool)

See Also

SkipIdenticalTicksAttribute Class | PowerLanguage Namespace


SkipIdenticalTicksAttribute Constructor

Initializes a new instance of the SkipIdenticalTicksAttribute class.

SkipIdenticalTicksAttribute(
bool value
);

Parameters

value
SkipIdenticalTicksAttribute value.

See Also

SkipIdenticalTicksAttribute Class | PowerLanguage Namespace | SkipIdenticalTicksAttribute Constructor Overload List


SkipIdenticalTicksAttribute Constructor

Initializes a new instance of the SkipIdenticalTicksAttribute class.

SkipIdenticalTicksAttribute();

See Also

SkipIdenticalTicksAttribute Class | PowerLanguage Namespace | SkipIdenticalTicksAttribute Constructor Overload List


SkipIdenticalTicksAttribute Properties

The properties of the SkipIdenticalTicksAttribute class are listed below. For a complete list of SkipIdenticalTicksAttribute class members, see the SkipIdenticalTicksAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. SkipIdenticalTicksAttribute value.

See Also

SkipIdenticalTicksAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

SkipIdenticalTicksAttribute.Value Property

Read-write property. SkipIdenticalTicksAttribute value.

public bool Value { public get; public set; }

See Also

SkipIdenticalTicksAttribute Class | PowerLanguage Namespace


SOrderParameters Structure

A structure containing information for order creation.

For a list of all members of this type, see SOrderParameters Members .

System.Object
SOrderParameters

public struct SOrderParameters

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SOrderParameters Members | PowerLanguage Namespace


SOrderParameters Members

SOrderParameters overview

Public Instance Constructors

SOrderParameters Overloaded. Initializes a new instance of the SOrderParameters class.

Public Instance Fields

Action | Order Action: Buy, Sell, SellShort, BuyToCover.
ExitTypeInfo | Order exit information.
Lots | Contracts quantity and type.
Name | Order name.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SOrderParameters Class | PowerLanguage Namespace


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

Overload List

Initializes a new instance of the SessionObject.

public SOrderParameters(Contracts,EOrderAction)

Initializes a new instance of the SessionObject.

public SOrderParameters(Contracts,EOrderAction,OrderExit)

Initializes a new instance of the SessionObject.

public SOrderParameters(Contracts,string,EOrderAction)

Initializes a new instance of the SessionObject.

public SOrderParameters(Contracts,string,EOrderAction,OrderExit)

Initializes a new instance of the SessionObject.

public SOrderParameters(EOrderAction)

Initializes a new instance of the SessionObject.

public SOrderParameters(EOrderAction,string)

See Also

SOrderParameters Class | PowerLanguage Namespace


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

SOrderParameters(
Contracts lots,
string name,
EOrderAction action,
OrderExit exitInfo
);

Parameters

lots
Number of lots.
name
Order name.
action
Order action.
exitInfo
Order exit info.

See Also

SOrderParameters Class | PowerLanguage Namespace | SOrderParameters Constructor Overload List


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

SOrderParameters(
EOrderAction action
);

Parameters

action
Order action.

See Also

SOrderParameters Class | PowerLanguage Namespace | SOrderParameters Constructor Overload List


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

SOrderParameters(
EOrderAction action,
string name
);

Parameters

action
Order action.
name
Order name.

See Also

SOrderParameters Class | PowerLanguage Namespace | SOrderParameters Constructor Overload List


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

SOrderParameters(
Contracts lots,
string name,
EOrderAction action
);

Parameters

lots
Number of lots.
name
Order name.
action
Order action.

See Also

SOrderParameters Class | PowerLanguage Namespace | SOrderParameters Constructor Overload List


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

SOrderParameters(
Contracts lots,
EOrderAction action
);

Parameters

lots
Number of lots.
action
Order action.

See Also

SOrderParameters Class | PowerLanguage Namespace | SOrderParameters Constructor Overload List


SOrderParameters Constructor

Initializes a new instance of the SessionObject.

SOrderParameters(
Contracts lots,
EOrderAction action,
OrderExit exitInfo
);

Parameters

lots
Number of lots.
action
Order action.
exitInfo
Order exit info.

See Also

SOrderParameters Class | PowerLanguage Namespace | SOrderParameters Constructor Overload List


SOrderParameters Fields

The fields of the SOrderParameters structure are listed below. For a complete list of SOrderParameters structure members, see the SOrderParameters Members topic.

Public Instance Fields

Action | Order Action: Buy, Sell, SellShort, BuyToCover.
ExitTypeInfo | Order exit information.
Lots | Contracts quantity and type.
Name | Order name.

See Also

SOrderParameters Class | PowerLanguage Namespace


SOrderParameters.Action Field

Order Action: Buy, Sell, SellShort, BuyToCover.

public readonly EOrderAction Action;

See Also

SOrderParameters Class | PowerLanguage Namespace


SOrderParameters.ExitTypeInfo Field

Order exit information.

public readonly OrderExit ExitTypeInfo;

See Also

SOrderParameters Class | PowerLanguage Namespace


SOrderParameters.Lots Field

Contracts quantity and type.

public readonly Contracts Lots;

See Also

SOrderParameters Class | PowerLanguage Namespace


SOrderParameters.Name Field

Order name.

public readonly string Name;

See Also

SOrderParameters Class | PowerLanguage Namespace


StatusLineData Structure

For a list of all members of this type, see StatusLineData Members .

System.Object
StatusLineData

public struct StatusLineData

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

StatusLineData Members | PowerLanguage Namespace


StatusLineData Members

StatusLineData overview

Public Instance Fields

Ask
AskVolume
Bid
BidVolume
Close
Date
High
Last
LastVolume
Low
Open
TotalVolume

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData Fields

The fields of the StatusLineData structure are listed below. For a complete list of StatusLineData structure members, see the StatusLineData Members topic.

Public Instance Fields

Ask
AskVolume
Bid
BidVolume
Close
Date
High
Last
LastVolume
Low
Open
TotalVolume

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Ask Field

public double? Ask;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.AskVolume Field

public int? AskVolume;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Bid Field

public double? Bid;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.BidVolume Field

public int? BidVolume;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Close Field

public double? Close;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Date Field

public DateTime? Date;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.High Field

public double? High;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Last Field

public double? Last;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.LastVolume Field

public int? LastVolume;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Low Field

public double? Low;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.Open Field

public double? Open;

See Also

StatusLineData Class | PowerLanguage Namespace


StatusLineData.TotalVolume Field

public int? TotalVolume;

See Also

StatusLineData Class | PowerLanguage Namespace


StrategyOnlyKeywordException Class

The exception that is displayed when a strategy keyword is used outside of a strategy.

For a list of all members of this type, see StrategyOnlyKeywordException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
WrongContextException
StrategyOnlyKeywordException

[Serializable]
public class StrategyOnlyKeywordException : WrongContextException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

StrategyOnlyKeywordException Members | PowerLanguage Namespace


StrategyOnlyKeywordException Members

StrategyOnlyKeywordException overview

Public Instance Constructors

StrategyOnlyKeywordException Overloaded. Initializes a new instance of the StrategyOnlyKeywordException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
HResult (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

StrategyOnlyKeywordException Overloaded. Initializes a new instance of the StrategyOnlyKeywordException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

StrategyOnlyKeywordException Class | PowerLanguage Namespace


StrategyOnlyKeywordException Constructor

Initializes a new instance of the StrategyOnlyKeywordException class.

Overload List

Initializes a new instance of the StrategyOnlyKeywordException class.

public StrategyOnlyKeywordException()

Initializes a new instance of the StrategyOnlyKeywordException class.

protected StrategyOnlyKeywordException(SerializationInfo,StreamingContext)

See Also

StrategyOnlyKeywordException Class | PowerLanguage Namespace


StrategyOnlyKeywordException Constructor

Initializes a new instance of the StrategyOnlyKeywordException class.

StrategyOnlyKeywordException();

See Also

StrategyOnlyKeywordException Class | PowerLanguage Namespace | StrategyOnlyKeywordException Constructor Overload List


StrategyOnlyKeywordException Constructor

Initializes a new instance of the StrategyOnlyKeywordException class.

StrategyOnlyKeywordException(
SerializationInfo info,
StreamingContext context
);

See Also

StrategyOnlyKeywordException Class | PowerLanguage Namespace | StrategyOnlyKeywordException Constructor Overload List


StringPlotAttributes Structure

A structure for string plot initialization.

For a list of all members of this type, see StringPlotAttributes Members .

System.Object
StringPlotAttributes

public struct StringPlotAttributes

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

StringPlotAttributes Members | PowerLanguage Namespace


StringPlotAttributes Members

StringPlotAttributes overview

Public Instance Constructors

StringPlotAttributes Overloaded. Initializes a new instance of the StringPlotAttributes class.

Public Instance Fields

Alignment | Plot value alignment in Scanner's cell.
BGColor | Plot’s background color.
Color | Plot’s foreground color.
Name | Plot name.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StringPlotAttributes Constructor

Initializes a new instance of the StringPlotAttributes.

Overload List

Initializes a new instance of the StringPlotAttributes.

public StringPlotAttributes(int)

Initializes a new instance of the StringPlotAttributes.

public StringPlotAttributes(string,Color)

Initializes a new instance of the StringPlotAttributes.

public StringPlotAttributes(string,Color,Color)

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StringPlotAttributes Constructor

Initializes a new instance of the StringPlotAttributes.

StringPlotAttributes(
string name,
Color color,
Color bgColor
);

Parameters

name
Plot name.
color
Plot’s foreground color.
bgColor
Plot’s background color.

See Also

StringPlotAttributes Class | PowerLanguage Namespace | StringPlotAttributes Constructor Overload List


StringPlotAttributes Constructor

Initializes a new instance of the StringPlotAttributes.

StringPlotAttributes(
string name,
Color color
);

Parameters

name
Plot name.
color
Plot’s foreground color.

See Also

StringPlotAttributes Class | PowerLanguage Namespace | StringPlotAttributes Constructor Overload List


StringPlotAttributes Constructor

Initializes a new instance of the StringPlotAttributes.

StringPlotAttributes(
int plotNum
);

Parameters

plotNum
Plot number.

See Also

StringPlotAttributes Class | PowerLanguage Namespace | StringPlotAttributes Constructor Overload List


StringPlotAttributes Fields

The fields of the StringPlotAttributes structure are listed below. For a complete list of StringPlotAttributes structure members, see the StringPlotAttributes Members topic.

Public Instance Fields

Alignment | Plot value alignment in Scanner's cell.
BGColor | Plot’s background color.
Color | Plot’s foreground color.
Name | Plot name.

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StringPlotAttributes.Alignment Field

Plot value alignment in Scanner's cell.

public PlotAlignment Alignment;

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StringPlotAttributes.BGColor Field

Plot’s background color.

public Color BGColor;

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StringPlotAttributes.Color Field

Plot’s foreground color.

public Color Color;

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StringPlotAttributes.Name Field

Plot name.

public string Name;

See Also

StringPlotAttributes Class | PowerLanguage Namespace


StudyRuntimeException Class

The exception that is displayed when a study runtime error occurs.

For a list of all members of this type, see StudyRuntimeException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
StudyRuntimeException

[Serializable]
public class StudyRuntimeException : ExecuteStudyException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

StudyRuntimeException Members | PowerLanguage Namespace


StudyRuntimeException Members

StudyRuntimeException overview

Public Instance Constructors

StudyRuntimeException Overloaded. Initializes a new instance of the StudyRuntimeException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
HResult (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

StudyRuntimeException Overloaded. Initializes a new instance of the StudyRuntimeException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

StudyRuntimeException Class | PowerLanguage Namespace


StudyRuntimeException Constructor

Initializes a new instance of the StudyRuntimeException class.

Overload List

Initializes a new instance of the StudyRuntimeException class.

protected StudyRuntimeException(SerializationInfo,StreamingContext)

Initializes a new instance of the StudyRuntimeException class.

public StudyRuntimeException(string)

See Also

StudyRuntimeException Class | PowerLanguage Namespace


StudyRuntimeException Constructor

Initializes a new instance of the StudyRuntimeException class.

StudyRuntimeException(
string errorMsg
);

See Also

StudyRuntimeException Class | PowerLanguage Namespace | StudyRuntimeException Constructor Overload List


StudyRuntimeException Constructor

Initializes a new instance of the StudyRuntimeException class.

StudyRuntimeException(
SerializationInfo info,
StreamingContext context
);

See Also

StudyRuntimeException Class | PowerLanguage Namespace | StudyRuntimeException Constructor Overload List


SubscribeStatusLineMode Enumeration

public enum SubscribeStatusLineMode

Members

Member Name | Description
StatusLineOn |
StatusLineOff |
StatusLineOnly |

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


SymbolNotFoundException Class

The exception displayed when a symbol is not found.

For a list of all members of this type, see SymbolNotFoundException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
SymbolNotFoundException

[Serializable]
public class SymbolNotFoundException : ExecuteStudyException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

SymbolNotFoundException Members | PowerLanguage Namespace


SymbolNotFoundException Members

SymbolNotFoundException overview

Public Instance Constructors

SymbolNotFoundException Overloaded. Initializes a new instance of the SymbolNotFoundException class.

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
HResult (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

SymbolNotFoundException Overloaded. Initializes a new instance of the SymbolNotFoundException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

SymbolNotFoundException Class | PowerLanguage Namespace


SymbolNotFoundException Constructor

Initializes a new instance of the SymbolNotFoundException class.

Overload List

Initializes a new instance of the SymbolNotFoundException class.

protected SymbolNotFoundException(SerializationInfo,StreamingContext)

Initializes a new instance of the SymbolNotFoundException class.

public SymbolNotFoundException(string)

See Also

SymbolNotFoundException Class | PowerLanguage Namespace


SymbolNotFoundException Constructor

Initializes a new instance of the SymbolNotFoundException class.

SymbolNotFoundException(
string errorMsg
);

See Also

SymbolNotFoundException Class | PowerLanguage Namespace | SymbolNotFoundException Constructor Overload List


SymbolNotFoundException Constructor

Initializes a new instance of the SymbolNotFoundException class.

SymbolNotFoundException(
SerializationInfo info,
StreamingContext context
);

See Also

SymbolNotFoundException Class | PowerLanguage Namespace | SymbolNotFoundException Constructor Overload List


TextObjectException Class

The exception that is displayed when working with text objects.

For a list of all members of this type, see TextObjectException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
DrawingObjectException
TextObjectException

[Serializable]
public class TextObjectException : DrawingObjectException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

TextObjectException Members | PowerLanguage Namespace


TextObjectException Members

TextObjectException overview

Public Instance Constructors

TextObjectException Overloaded. Initializes a new instance of the TextObjectException class.

Public Instance Properties

Data (inherited from Exception) |
Error (inherited from DrawingObjectException) | Returns error code.
HelpLink (inherited from Exception) |
HResult (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object) |
GetBaseException (inherited from Exception) |
GetHashCode (inherited from Object) |
GetObjectData (inherited from DrawingObjectException) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) |
ToString (inherited from Exception) |

Protected Instance Constructors

TextObjectException Overloaded. Initializes a new instance of the TextObjectException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

TextObjectException Class | PowerLanguage Namespace


TextObjectException Constructor

Initializes a new instance of the TextObjectException class.

Overload List

Initializes a new instance of the TextObjectException class.

public TextObjectException(int)

Initializes a new instance of the TextObjectException class.

protected TextObjectException(SerializationInfo,StreamingContext)

See Also

TextObjectException Class | PowerLanguage Namespace


TextObjectException Constructor

Initializes a new instance of the TextObjectException class.

TextObjectException(
int errCode
);

Parameters

errCode
A code that describes the error

See Also

TextObjectException Class | PowerLanguage Namespace | TextObjectException Constructor Overload List


TextObjectException Constructor

Initializes a new instance of the TextObjectException class.

TextObjectException(
SerializationInfo info,
StreamingContext context
);

See Also

TextObjectException Class | PowerLanguage Namespace | TextObjectException Constructor Overload List


ToolBarAction Delegate

Defines signature of the callback function, which will be called when access to chart's toolbar is requested. Contains the toolbar as a parameter to be sent.

public delegate void ToolBarAction(
ToolStrip tb
);

Parameters

tb
Chart's toolbar.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


TPOAttributes Enumeration

Enumeration represents possible TPO attributes.

public enum TPOAttributes

Members

Member Name | Description
TPO_BASE_ON_RESOLUTION | TODO:
TPO_BLOCK_SIZE | Attribute value, specifying block resolution size.
TPO_BLOCK_SIZE_RESOLUTION | Attribute value, specifying block resolution.
TPO_PROFILE_BUILD_FROM_RANGE | Attribute value, specifying range type. For session time = 0, for specific time = -1
TPO_PROFILE_BUILD_FROM_TIME | Attribute value, specifying time of day for TPO profile building time. Measured in total seconds from 0 to 24*60*60, or -1 (same as TPO profile building from session)
TPO_RESOLUTION |
TPO_RESOLUTION_SIZE |

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


TPOBar Structure

TODO:

For a list of all members of this type, see TPOBar Members .

System.Object
TPOBar

public struct TPOBar

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

TPOBar Members | PowerLanguage Namespace


TPOBar Members

TPOBar overview

Public Static Operators

Equality Operator | Indicates whether two instances of TPOBar are equal.
Inequality Operator | Indicates whether two instances of TPOBar are not equal.

Public Instance Constructors

TPOBar Constructor TODO:

Public Instance Fields

Close | TODO:
High | TODO:
IBRHigh | TODO:
IBRLow | TODO:
Low | TODO:
MidPoint | TODO:
Open | TODO:
POC | TODO:
POCBlocks | TODO:
VAHigh | TODO:
VALow | TODO:

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar Constructor

TODO:

TPOBar(
double open,
double high,
double low,
double close,
double MidPoint,
uint priceLevelCount,
uint TotalBlockCount,
double IBRHigh,
double IBRLow,
double VAHigh,
double VALow,
double POC,
uint POCBlocks
);

Parameters

open
high
low
close
MidPoint
priceLevelCount
TotalBlockCount
IBRHigh
IBRLow
VAHigh
VALow
POC
POCBlocks

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar Fields

The fields of the TPOBar structure are listed below. For a complete list of TPOBar structure members, see the TPOBar Members topic.

Public Instance Fields

Close | TODO:
High | TODO:
IBRHigh | TODO:
IBRLow | TODO:
Low | TODO:
MidPoint | TODO:
Open | TODO:
POC | TODO:
POCBlocks | TODO:
VAHigh | TODO:
VALow | TODO:

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.Close Field

TODO:

public double Close;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.High Field

TODO:

public double High;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.IBRHigh Field

TODO:

public double IBRHigh;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.IBRLow Field

TODO:

public double IBRLow;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.Low Field

TODO:

public double Low;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.MidPoint Field

TODO:

public double MidPoint;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.Open Field

TODO:

public double Open;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.POC Field

TODO:

public double POC;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.POCBlocks Field

TODO:

public uint POCBlocks;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.VAHigh Field

TODO:

public double VAHigh;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.VALow Field

TODO:

public double VALow;

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar Methods

The methods of the TPOBar structure are listed below. For a complete list of TPOBar structure members, see the TPOBar Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOBar Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

TPOBar.Equals Method

Indicates whether this instance and the specified object are equal.

Overload List

Indicates whether this instance and the specified object are equal.

public bool Equals(TPOBar)

Indicates whether this instance and the specified object are equal.

public override bool Equals(object)

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.Equals(TPOBar) Method

Indicates whether this instance and the specified object are equal.

public bool Equals(
TPOBar other
);

Parameters

other
TPOBar object for comparison.

Return Value

See Also

TPOBar Class | PowerLanguage Namespace | TPOBar.Equals Overload List


TPOBar.Equals(Object) Method

Indicates whether this instance and the specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

TPOBar Class | PowerLanguage Namespace | TPOBar.Equals Overload List


TPOBar.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar.ToString Method

public override string ToString();

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar Operators

The operators of the TPOBar structure are listed below. For a complete list of TPOBar structure members, see the TPOBar Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances of TPOBar are equal.
Inequality Operator | Indicates whether two instances of TPOBar are not equal.

See Also

TPOBar Class | TPOBar Members | PowerLanguage Namespace


TPOBar Equality Operator

Indicates whether two instances of TPOBar are equal.

public static bool operator ==(
TPOBar left,
TPOBar right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are equal; otherwise false.

See Also

TPOBar Class | PowerLanguage Namespace


TPOBar Inequality Operator

Indicates whether two instances of TPOBar are not equal.

public static bool operator !=(
TPOBar left,
TPOBar right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are not equal; otherwise false.

See Also

TPOBar Class | PowerLanguage Namespace


TPOBase Enumeration

Enumeration describing TPO base.

public enum TPOBase

Members

Member Name | Description
NotTPOResolution |
TickBased |
MinuteBased |
DayBased |

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage Namespace


TPOBlock Structure

TODO:

For a list of all members of this type, see TPOBlock Members .

System.Object
TPOBlock

public struct TPOBlock

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

TPOBlock Members | PowerLanguage Namespace


TPOBlock Members

TPOBlock overview

Public Static Operators

Equality Operator | Indicates whether two instances of TPOBlock are equal.
Inequality Operator | Indicates whether two instances of TPOBlock are not equal.

Public Instance Fields

BlockId | TODO:
DownVolume | Down ticks Volume of the block. A down tick is a tick with the price lower then the preceding tick.
Time | TODO:
UpVolume | Up ticks Volume of the block. An up tick is a tick with the price higher then the preceding tick.

Public Instance Properties

TotalVolume Total Volume of the block.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock Fields

The fields of the TPOBlock structure are listed below. For a complete list of TPOBlock structure members, see the TPOBlock Members topic.

Public Instance Fields

BlockId | TODO:
DownVolume | Down ticks Volume of the block. A down tick is a tick with the price lower then the preceding tick.
Time | TODO:
UpVolume | Up ticks Volume of the block. An up tick is a tick with the price higher then the preceding tick.

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock.BlockId Field

TODO:

public uint BlockId;

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock.DownVolume Field

Down ticks Volume of the block. A down tick is a tick with the price lower then the preceding tick.

public double DownVolume;

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock.Time Field

TODO:

public DateTime Time;

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock.UpVolume Field

Up ticks Volume of the block. An up tick is a tick with the price higher then the preceding tick.

public double UpVolume;

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock Properties

The properties of the TPOBlock structure are listed below. For a complete list of TPOBlock structure members, see the TPOBlock Members topic.

Public Instance Properties

TotalVolume Total Volume of the block.

See Also

TPOBlock Class | PowerLanguage Namespace


TotalVolume Property

PowerLanguage.NET Help

TPOBlock.TotalVolume Property

Total Volume of the block.

public double TotalVolume { public get; }

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock Methods

The methods of the TPOBlock structure are listed below. For a complete list of TPOBlock structure members, see the TPOBlock Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOBlock Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

TPOBlock.Equals Method

Indicates whether this instance and the specified object are equal.

Overload List

Indicates whether this instance and the specified object are equal.

public bool Equals(TPOBlock)

Indicates whether this instance and the specified object are equal.

public override bool Equals(object)

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock.Equals(TPOBlock) Method

Indicates whether this instance and the specified object are equal.

public bool Equals(
TPOBlock other
);

Parameters

other
TPOBlock object for comparison.

Return Value

See Also

TPOBlock Class | PowerLanguage Namespace | TPOBlock.Equals Overload List


TPOBlock.Equals(Object) Method

Indicates whether this instance and the specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

TPOBlock Class | PowerLanguage Namespace | TPOBlock.Equals Overload List


TPOBlock.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock.ToString Method

public override string ToString();

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock Operators

The operators of the TPOBlock structure are listed below. For a complete list of TPOBlock structure members, see the TPOBlock Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances of TPOBlock are equal.
Inequality Operator | Indicates whether two instances of TPOBlock are not equal.

See Also

TPOBlock Class | TPOBlock Members | PowerLanguage Namespace


TPOBlock Equality Operator

Indicates whether two instances of TPOBlock are equal.

public static bool operator ==(
TPOBlock left,
TPOBlock right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are equal; otherwise false.

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlock Inequality Operator

Indicates whether two instances of TPOBlock are not equal.

public static bool operator !=(
TPOBlock left,
TPOBlock right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are not equal; otherwise false.

See Also

TPOBlock Class | PowerLanguage Namespace


TPOBlocks Structure

TODO:

For a list of all members of this type, see TPOBlocks Members .

System.Object
TPOBlocks

public struct TPOBlocks

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

TPOBlocks Members | PowerLanguage Namespace


TPOBlocks Members

TPOBlocks overview

Public Static Operators

Equality Operator | Indicates whether two instances of TPOBlocks are equal.
Inequality Operator | Indicates whether two instances of TPOBlocks are not equal.

Public Instance Constructors

TPOBlocks Constructor TODO:

Public Instance Fields

Price TODO:

Public Instance Properties

Blocks TODO:

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks Constructor

TODO:

TPOBlocks(
double price,
TPOBlock[] blocks
);

Parameters

price
blocks

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks Fields

The fields of the TPOBlocks structure are listed below. For a complete list of TPOBlocks structure members, see the TPOBlocks Members topic.

Public Instance Fields

Price TODO:

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks.Price Field

TODO:

public double Price;

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks Properties

The properties of the TPOBlocks structure are listed below. For a complete list of TPOBlocks structure members, see the TPOBlocks Members topic.

Public Instance Properties

Blocks TODO:

See Also

TPOBlocks Class | PowerLanguage Namespace


Blocks Property

PowerLanguage.NET Help

TPOBlocks.Blocks Property

TODO:

public TPOBlock[] Blocks { public get; public set; }

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks Methods

The methods of the TPOBlocks structure are listed below. For a complete list of TPOBlocks structure members, see the TPOBlocks Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and the specified object are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOBlocks Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

TPOBlocks.Equals Method

Indicates whether this instance and the specified object are equal.

Overload List

Indicates whether this instance and the specified object are equal.

public bool Equals(TPOBlocks)

Indicates whether this instance and the specified object are equal.

public override bool Equals(object)

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks.Equals(TPOBlocks) Method

Indicates whether this instance and the specified object are equal.

public bool Equals(
TPOBlocks other
);

Parameters

other
TPOBlocks object for comparison.

Return Value

See Also

TPOBlocks Class | PowerLanguage Namespace | TPOBlocks.Equals Overload List


TPOBlocks.Equals(Object) Method

Indicates whether this instance and the specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

TPOBlocks Class | PowerLanguage Namespace | TPOBlocks.Equals Overload List


TPOBlocks.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks.ToString Method

public override string ToString();

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks Operators

The operators of the TPOBlocks structure are listed below. For a complete list of TPOBlocks structure members, see the TPOBlocks Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances of TPOBlocks are equal.
Inequality Operator | Indicates whether two instances of TPOBlocks are not equal.

See Also

TPOBlocks Class | TPOBlocks Members | PowerLanguage Namespace


TPOBlocks Equality Operator

Indicates whether two instances of TPOBlocks are equal.

public static bool operator ==(
TPOBlocks left,
TPOBlocks right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are equal; otherwise false.

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOBlocks Inequality Operator

Indicates whether two instances of TPOBlocks are not equal.

public static bool operator !=(
TPOBlocks left,
TPOBlocks right
);

Parameters

left
First instance.
right
Second instance.

Return Value

True if instances are not equal; otherwise false.

See Also

TPOBlocks Class | PowerLanguage Namespace


TPOProfile Structure

Structure describes volume data by showing at specific prices for a bar (Bar's Volume Profile).

For a list of all members of this type, see TPOProfile Members .

System.Object
TPOProfile

public struct TPOProfile

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

TPOProfile Members | PowerLanguage Namespace


TPOProfile Members

TPOProfile overview

Public Static Operators

Equality Operator | Indicates whether two instances of BarPriceLevels are equal.
Inequality Operator | Indicates whether two instances of BarPriceLevels are not equal.

Public Instance Constructors

TPOProfile Constructor TODO:

Public Instance Properties

Bar | Read-write property. Bar object.
Index | Read-write property. Bar's index.
PriceLevelBlocks | Read-write property. Bar's price levels. Volume profile of the bar. PriceLevel
TickID | Read-write property. Bar's tick ID.
Time | Read-write property. Bar's time.
TPOBar |

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and other instance of BarPriceLevels are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile Constructor

TODO:

TPOProfile(
Bar bar,
TPOBar tpoBar,
TPOBlocks[] blocks,
int index
);

Parameters

bar
tpoBar
blocks
index

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile Properties

The properties of the TPOProfile structure are listed below. For a complete list of TPOProfile structure members, see the TPOProfile Members topic.

Public Instance Properties

Bar | Read-write property. Bar object.
Index | Read-write property. Bar's index.
PriceLevelBlocks | Read-write property. Bar's price levels. Volume profile of the bar. PriceLevel
TickID | Read-write property. Bar's tick ID.
Time | Read-write property. Bar's time.
TPOBar |

See Also

TPOProfile Class | PowerLanguage Namespace


Bar Property

PowerLanguage.NET Help

TPOProfile.Bar Property

Read-write property. Bar object.

public Bar Bar { public get; public set; }

See Also

TPOProfile Class | PowerLanguage Namespace


Index Property

PowerLanguage.NET Help

TPOProfile.Index Property

Read-write property. Bar's index.

public int Index { public get; public set; }

See Also

TPOProfile Class | PowerLanguage Namespace


PriceLevelBlocks Property

PowerLanguage.NET Help

TPOProfile.PriceLevelBlocks Property

Read-write property. Bar's price levels. Volume profile of the bar. PriceLevel

public TPOBlocks[] PriceLevelBlocks { public get; public set; }

See Also

TPOProfile Class | PowerLanguage Namespace


TickID Property

PowerLanguage.NET Help

TPOProfile.TickID Property

Read-write property. Bar's tick ID.

public uint TickID { public get; public set; }

See Also

TPOProfile Class | PowerLanguage Namespace


Time Property

PowerLanguage.NET Help

TPOProfile.Time Property

Read-write property. Bar's time.

public DateTime Time { public get; public set; }

See Also

TPOProfile Class | PowerLanguage Namespace


TPOBar Property

PowerLanguage.NET Help

TPOProfile.TPOBar Property

public TPOBar TPOBar { public get; public set; }

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile Methods

The methods of the TPOProfile structure are listed below. For a complete list of TPOProfile structure members, see the TPOProfile Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether this instance and other instance of BarPriceLevels are equal.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) |
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOProfile Class | PowerLanguage Namespace


Equals Method

PowerLanguage.NET Help

TPOProfile.Equals Method

Indicates whether this instance and other instance of BarPriceLevels are equal.

Overload List

Indicates whether this instance and other instance of BarPriceLevels are equal.

public bool Equals(TPOProfile)

Indicates whether this instance and a specified object are equal.

public override bool Equals(object)

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile.Equals(TPOProfile) Method

Indicates whether this instance and other instance of BarPriceLevels are equal.

public bool Equals(
TPOProfile other
);

Parameters

other
Instance of BarPriceLevels object for comparison.

Return Value

true if the other parameter is equal to the current BarPriceLevels object; otherwise, false.

See Also

TPOProfile Class | PowerLanguage Namespace | TPOProfile.Equals Overload List


TPOProfile.Equals(Object) Method

Indicates whether this instance and a specified object are equal.

public override bool Equals(
object obj
);

Parameters

obj
Another object to compare to.

Return Value

true if obj and this instance are the same type and represent the same value; otherwise, false.

See Also

TPOProfile Class | PowerLanguage Namespace | TPOProfile.Equals Overload List


TPOProfile.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

A 32-bit signed integer that is the hash code for this instance.

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile.ToString Method

public override string ToString();

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile Operators

The operators of the TPOProfile structure are listed below. For a complete list of TPOProfile structure members, see the TPOProfile Members topic.

Public Static Operators

Equality Operator | Indicates whether two instances of BarPriceLevels are equal.
Inequality Operator | Indicates whether two instances of BarPriceLevels are not equal.

See Also

TPOProfile Class | TPOProfile Members | PowerLanguage Namespace


TPOProfile Equality Operator

Indicates whether two instances of BarPriceLevels are equal.

public static bool operator ==(
TPOProfile left,
TPOProfile right
);

Parameters

left
First instance of BarPriceLevels object for comparison.
right
Second instance of BarPriceLevels object for comparison.

Return Value

true if first instance is equal to the second; otherwise, false.

See Also

TPOProfile Class | PowerLanguage Namespace


TPOProfile Inequality Operator

Indicates whether two instances of BarPriceLevels are not equal.

public static bool operator !=(
TPOProfile left,
TPOProfile right
);

Parameters

left
First instance of BarPriceLevels object for comparison.
right
Second instance of BarPriceLevels object for comparison.

Return Value

true if first instance is not equal to the second; otherwise, false.

See Also

TPOProfile Class | PowerLanguage Namespace


TrendLineObjectException Class

The exception that is displayed when working with trend line objects.

For a list of all members of this type, see TrendLineObjectException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
DrawingObjectException
TrendLineObjectException

[Serializable]
public class TrendLineObjectException : DrawingObjectException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

TrendLineObjectException Members | PowerLanguage Namespace


TrendLineObjectException Members

TrendLineObjectException overview

Public Instance Constructors

TrendLineObjectException Overloaded. Initializes a new instance of the TrendLineObjectException class.

Public Instance Properties

Data (inherited from Exception) |
Error (inherited from DrawingObjectException) | Returns error code.
HelpLink (inherited from Exception) |
HResult (inherited from Exception) |
InnerException (inherited from Exception) |
Message (inherited from Exception) |
Source (inherited from Exception) |
StackTrace (inherited from Exception) |
TargetSite (inherited from Exception) |

Public Instance Methods

Equals (inherited from Object) |
GetBaseException (inherited from Exception) |
GetHashCode (inherited from Object) |
GetObjectData (inherited from DrawingObjectException) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) |
ToString (inherited from Exception) |

Protected Instance Constructors

TrendLineObjectException Overloaded. Initializes a new instance of the TrendLineObjectException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

TrendLineObjectException Class | PowerLanguage Namespace


TrendLineObjectException Constructor

Initializes a new instance of the TrendLineObjectException class.

Overload List

Initializes a new instance of the TrendLineObjectException class.

public TrendLineObjectException(int)

Initializes a new instance of the TrendLineObjectException class.

protected TrendLineObjectException(SerializationInfo,StreamingContext)

See Also

TrendLineObjectException Class | PowerLanguage Namespace


TrendLineObjectException Constructor

Initializes a new instance of the TrendLineObjectException class.

TrendLineObjectException(
int errCode
);

Parameters

errCode
A code that describes the error

See Also

TrendLineObjectException Class | PowerLanguage Namespace | TrendLineObjectException Constructor Overload List


TrendLineObjectException Constructor

Initializes a new instance of the TrendLineObjectException class.

TrendLineObjectException(
SerializationInfo info,
StreamingContext context
);

See Also

TrendLineObjectException Class | PowerLanguage Namespace | TrendLineObjectException Constructor Overload List


UpdateOnEveryTickAttribute Class

The class that defines UpdateOnEveryTickAttribute.

For a list of all members of this type, see UpdateOnEveryTickAttribute Members .

System.Object
Attribute
UpdateOnEveryTickAttribute

[Serializable]
[AttributeUsage(ValidOn=AttributeTargets.Class, AllowMultiple=False, Inherited=True)]
public class UpdateOnEveryTickAttribute : Attribute

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

UpdateOnEveryTickAttribute Members | PowerLanguage Namespace


UpdateOnEveryTickAttribute Members

UpdateOnEveryTickAttribute overview

Public Instance Constructors

UpdateOnEveryTickAttribute Overloaded. Initializes a new instance of the UpdateOnEveryTickAttribute class.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. UpdateOnEveryTickAttribute value.

Public Instance Methods

Equals (inherited from Attribute)
GetHashCode (inherited from Attribute)
GetType (inherited from Object)
IsDefaultAttribute (inherited from Attribute)
Match (inherited from Attribute)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

UpdateOnEveryTickAttribute Class | PowerLanguage Namespace


UpdateOnEveryTickAttribute Constructor

Initializes a new instance of the UpdateOnEveryTickAttribute class.

Overload List

Initializes a new instance of the UpdateOnEveryTickAttribute class.

public UpdateOnEveryTickAttribute()

Initializes a new instance of the UpdateOnEveryTickAttribute class.

public UpdateOnEveryTickAttribute(bool)

See Also

UpdateOnEveryTickAttribute Class | PowerLanguage Namespace


UpdateOnEveryTickAttribute Constructor

Initializes a new instance of the UpdateOnEveryTickAttribute class.

UpdateOnEveryTickAttribute(
bool value
);

Parameters

value
UpdateOnEveryTickAttribute value.

See Also

UpdateOnEveryTickAttribute Class | PowerLanguage Namespace | UpdateOnEveryTickAttribute Constructor Overload List


UpdateOnEveryTickAttribute Constructor

Initializes a new instance of the UpdateOnEveryTickAttribute class.

UpdateOnEveryTickAttribute();

See Also

UpdateOnEveryTickAttribute Class | PowerLanguage Namespace | UpdateOnEveryTickAttribute Constructor Overload List


UpdateOnEveryTickAttribute Properties

The properties of the UpdateOnEveryTickAttribute class are listed below. For a complete list of UpdateOnEveryTickAttribute class members, see the UpdateOnEveryTickAttribute Members topic.

Public Instance Properties

TypeId (inherited from Attribute) |
Value | Read-write property. UpdateOnEveryTickAttribute value.

See Also

UpdateOnEveryTickAttribute Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

UpdateOnEveryTickAttribute.Value Property

Read-write property. UpdateOnEveryTickAttribute value.

public bool Value { public get; public set; }

See Also

UpdateOnEveryTickAttribute Class | PowerLanguage Namespace


VariableObject<T> Class

Class for simple variables, provides access to the value of the variable in the current context of study execution.

For a list of all members of this type, see VariableObject<T> Members .

System.Object
VariableObject<T>

[DefaultMember(MemberName="Item")]
public sealed class VariableObject<T> : IVar<T>, ISeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

VariableObject<T> Members | PowerLanguage Namespace


VariableObject<T> Members

VariableObject<T> overview

Public Instance Constructors

VariableObject<T> Overloaded. Initializes a new instance of the VariableObject<T> class.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | A read-write property for accessing the value of the variable.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Private Instance Properties

DefaultValue A read-write property for accessing the default value of the variable.

See Also

VariableObject<T> Class | PowerLanguage Namespace


VariableObject`1 Constructor

Initializes a new instance of the VariableObject.

Overload List

Initializes a new instance of the VariableObject.

public VariableObject`1(IStudyControl)

Initializes a new instance of the VariableObject.

public VariableObject`1(IStudyControl,T)

Initializes a new instance of the VariableObject.

public VariableObject`1(IStudyControl,T,int)

See Also

VariableObject<T> Class | PowerLanguage Namespace


VariableObject<T> Constructor

Initializes a new instance of the VariableObject.

VariableObject<T>(
IStudyControl master
);

Parameters

master
Study object which manages this variable object.

See Also

VariableObject<T> Class | PowerLanguage Namespace | VariableObject<T> Constructor Overload List


VariableObject<T> Constructor

Initializes a new instance of the VariableObject.

VariableObject<T>(
IStudyControl master,
T defaultVal
);

Parameters

master
Study object which manages this variable object.
defaultVal
Simple variable default value.

See Also

VariableObject<T> Class | PowerLanguage Namespace | VariableObject<T> Constructor Overload List


VariableObject<T> Constructor

Initializes a new instance of the VariableObject.

VariableObject<T>(
IStudyControl master,
T defaultVal,
int dataStream
);

Parameters

master
Study object which manages this variable object.
defaultVal
Simple variable default value.
dataStream
Simple variable base data stream number.

See Also

VariableObject<T> Class | PowerLanguage Namespace | VariableObject<T> Constructor Overload List


VariableObject<T> Properties

The properties of the VariableObject<T> class are listed below. For a complete list of VariableObject<T> class members, see the VariableObject<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | A read-write property for accessing the value of the variable.

Private Instance Properties

DefaultValue A read-write property for accessing the default value of the variable.

See Also

VariableObject<T> Class | PowerLanguage Namespace


DefaultValue Property

PowerLanguage.NET Help

VariableObject`1.DefaultValue Property

A read-write property for accessing the default value of the variable.

private T DefaultValue { private get; public set; }

Implements

IVar<T>.DefaultValue

See Also

VariableObject<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

VariableObject`1.Item Property

Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

public T this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression, specifying the number of bars back.

Implements

ISeries<T>.Item

See Also

VariableObject<T> Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

VariableObject`1.Value Property

A read-write property for accessing the value of the variable.

public T Value { public get; public set; }

Implements

ISeries<T>.Value

See Also

VariableObject<T> Class | PowerLanguage Namespace


VariableSeries<T> Class

Class that allows access to and preserves historical variable values (for a series of variables).

For a list of all members of this type, see VariableSeries<T> Members .

System.Object
VariableSeries<T>

[DefaultMember(MemberName="Item")]
public sealed class VariableSeries<T> : IVar<T>, ISeries<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

VariableSeries<T> Members | PowerLanguage Namespace


VariableSeries<T> Members

VariableSeries<T> overview

Public Instance Constructors

VariableSeries<T> Overloaded. Initializes a new instance of the VariableSeries<T> class.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | A read-write property for accessing the value of the variable.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Private Instance Properties

DefaultValue A read-write property for accessing the default value of the variable.

See Also

VariableSeries<T> Class | PowerLanguage Namespace


VariableSeries`1 Constructor

Initializes a new instance of the VariableSeries.

Overload List

Initializes a new instance of the VariableSeries.

public VariableSeries`1(IStudyControl)

Initializes a new instance of the VariableSeries.

public VariableSeries`1(IStudyControl,T)

Initializes a new instance of the VariableSeries.

public VariableSeries`1(IStudyControl,T,int)

Initializes a new instance of the VariableSeries.

public VariableSeries`1(IStudyControl,T,int,bool)

See Also

VariableSeries<T> Class | PowerLanguage Namespace


VariableSeries<T> Constructor

Initializes a new instance of the VariableSeries.

VariableSeries<T>(
IStudyControl master
);

Parameters

master
Study object which manages this variable object.

See Also

VariableSeries<T> Class | PowerLanguage Namespace | VariableSeries<T> Constructor Overload List


VariableSeries<T> Constructor

Initializes a new instance of the VariableSeries.

VariableSeries<T>(
IStudyControl master,
T defaultVal
);

Parameters

master
Study object which manages this variable object.
defaultVal
Series variable default value.

See Also

VariableSeries<T> Class | PowerLanguage Namespace | VariableSeries<T> Constructor Overload List


VariableSeries<T> Constructor

Initializes a new instance of the VariableSeries.

VariableSeries<T>(
IStudyControl master,
T defaultVal,
int dataStream
);

Parameters

master
Study object which manages this variable object.
defaultVal
Series variable default value.
dataStream
Series variable base data stream number.

See Also

VariableSeries<T> Class | PowerLanguage Namespace | VariableSeries<T> Constructor Overload List


VariableSeries<T> Constructor

Initializes a new instance of the VariableSeries.

VariableSeries<T>(
IStudyControl master,
T defaultVal,
int dataStream,
bool intrabarPersist
);

Parameters

master
Study object which manages this variable object.
defaultVal
Series variable default value.
dataStream
Series variable base data stream number.
intrabarPersist
If true: Series variable does not reset its value (from the previous bar) before the calculation is done on the next bar.

See Also

VariableSeries<T> Class | PowerLanguage Namespace | VariableSeries<T> Constructor Overload List


VariableSeries<T> Properties

The properties of the VariableSeries<T> class are listed below. For a complete list of VariableSeries<T> class members, see the VariableSeries<T> Members topic.

Public Instance Properties

Item | Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.
Value | A read-write property for accessing the value of the variable.

Private Instance Properties

DefaultValue A read-write property for accessing the default value of the variable.

See Also

VariableSeries<T> Class | PowerLanguage Namespace


DefaultValue Property

PowerLanguage.NET Help

VariableSeries`1.DefaultValue Property

A read-write property for accessing the default value of the variable.

private T DefaultValue { private get; public set; }

Implements

IVar<T>.DefaultValue

See Also

VariableSeries<T> Class | PowerLanguage Namespace


Item Property

PowerLanguage.NET Help

VariableSeries`1.Item Property

Read-only property. Returns a reference to a bar located a specified number of bars back from the current bar.

public T this[
int barsAgo
] { public get; }

Parameters

barsAgo
The numerical expression specifying the number of bars back.

Implements

ISeries<T>.Item

See Also

VariableSeries<T> Class | PowerLanguage Namespace


Value Property

PowerLanguage.NET Help

VariableSeries`1.Value Property

A read-write property for accessing the value of the variable.

public T Value { public get; public set; }

Implements

ISeries<T>.Value

See Also

VariableSeries<T> Class | PowerLanguage Namespace


WrongContextException Class

The exception that is displayed when a context is wrong.

For a list of all members of this type, see WrongContextException Members .

System.Object
Exception
ApplicationException
ExecuteStudyException
WrongContextException
StrategyOnlyKeywordException

[Serializable]
public class WrongContextException : ExecuteStudyException

Requirements

Namespace: PowerLanguage

Assembly: PLTypes (in PLTypes.dll)

See Also

WrongContextException Members | PowerLanguage Namespace


WrongContextException Members

WrongContextException overview

Public Instance Properties

Data (inherited from Exception)
HelpLink (inherited from Exception)
HResult (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Exception)
ToString (inherited from Exception)

Protected Instance Constructors

WrongContextException Overloaded. Initializes a new instance of the WrongContextException class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

Protected Instance Events

SerializeObjectState (inherited from Exception)

See Also

WrongContextException Class | PowerLanguage Namespace


WrongContextException Constructor

Initializes a new instance of the ArrowObjectException class.

Overload List

Initializes a new instance of the ArrowObjectException class.

protected WrongContextException(SerializationInfo,StreamingContext)

Initializes a new instance of the ArrowObjectException class.

protected WrongContextException(string)

See Also

WrongContextException Class | PowerLanguage Namespace


WrongContextException Constructor

Initializes a new instance of the ArrowObjectException class.

WrongContextException(
string message
);

See Also

WrongContextException Class | PowerLanguage Namespace | WrongContextException Constructor Overload List


WrongContextException Constructor

Initializes a new instance of the ArrowObjectException class.

WrongContextException(
SerializationInfo info,
StreamingContext context
);

See Also

WrongContextException Class | PowerLanguage Namespace | WrongContextException Constructor Overload List


PowerLanguage.DataLoader

PowerLanguage.NET Help

PowerLanguage.DataLoader Namespace

Namespace Hierarchy

Classes

Class | Description
DataLoaderCache | DataLoader singleton service. Caches LoadData requests, what allows to avoid same data over-requesting. It increases the speed of script calculation.


DataLoaderCache Class

DataLoader singleton service. Caches LoadData requests, what allows to avoid same data over-requesting. It increases the speed of script calculation.

For a list of all members of this type, see DataLoaderCache Members .

System.Object
DataLoaderCache

public sealed class DataLoaderCache : IDataLoader, IDisposable

Requirements

Namespace: PowerLanguage.DataLoader

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

DataLoaderCache Members | PowerLanguage.DataLoader Namespace


DataLoaderCache Members

DataLoaderCache overview

Public Static Properties

Instance Returns reference to IDataLoader.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DataLoaderCache Class | PowerLanguage.DataLoader Namespace


DataLoaderCache Properties

The properties of the DataLoaderCache class are listed below. For a complete list of DataLoaderCache class members, see the DataLoaderCache Members topic.

Public Static Properties

Instance Returns reference to IDataLoader.

See Also

DataLoaderCache Class | PowerLanguage.DataLoader Namespace


Instance Property

PowerLanguage.NET Help

DataLoaderCache.Instance Property

Returns reference to IDataLoader.

public static IDataLoader Instance { public get; }

See Also

DataLoaderCache Class | PowerLanguage.DataLoader Namespace


PowerLanguage.Function

PowerLanguage.NET Help

PowerLanguage.Function Namespace

Namespace Hierarchy

Classes

Class | Description
_AdvanceDeclineRatio |
_AvgPrice |
_CCI |
_CountIf |
_Detrend |
_Doji |
_HighestBar |
_LowestBar |
_MedianPrice |
_MFI |
_Momentum |
_MoneyFlow |
_Next3rdFriday |
_PercentChange |
_PercentR |
_PortfolioDataUtils |
_Range |
_RateOfChange |
_Round2Fraction |
_Text_Float |
_TrueHigh |
_TrueLow |
_TypicalPrice |
_VolumeROC |
_WeightedClose |
AccumSwingIndex |
AccumulationDistribution |
AdaptiveMovAvg |
AdvanceDeclineDiff |
ADX |
ADXCustom |
ADXR |
ADXRCustom |
ArmsIndex |
AverageFC |
AvgTrueRange |
BarNumber |
C_3WhSolds_3BlkCrows |
C_BullEng_BearEng |
C_BullHar_BearHar |
C_Hammer_HangingMan |
C_MornDoji_EveDoji |
C_MornStar_EveStar |
C_PierceLine_DkCloud |
C_ShootingStar |
ChaikinOsc |
CloseD |
CloseS |
Correlation |
CSI |
Cum |
CurrencyHelper |
DirMovement |
draw_DOM_level |
EaseOfMovement |
EntriesToday |
ExitsToday |
ExtremesFC |
FastK |
FastKCustom |
FunctionSeries<T> | A series function’s base class. Feature of a series function is that its body is always calculated in the current context of execution (at the currently calculating bar), and the function always keeps its previous values.
FunctionSimple<T> | Simple function’s base class. Its peculiarity is that it doesn’t keep the history of its values, but rather calculates them each time in the context of calling an execution (on the bar, shifted relative to the current one for a specified number of bars).
HighD |
HighestFC |
HighS |
HPI |
HullMovAvg |
LinearReg |
LinearRegValue |
LowD |
LowestFC |
LowS |
LWAccDis |
MACD |
MassIndex |
McClellanOsc |
NormGradientColor |
OBV |
OHLCPeriodsAgo |
OpenD |
OpenS |
ParabolicSAR |
Pennant |
PivotHighVS |
PivotHighVSBar |
PivotLowVS |
PivotLowVSBar |
PivotReversalGen |
PortfolioHelpFunctions |
PriceOscillator |
PriceVolTrend |
RS_Average |
RS_BarsPerDay |
RS_DailyDataArray |
RS_Extremes |
RS_PriceExtension |
RS_ReversalPatterns |
RS_TrueExtremes |
RSI |
SharpeRatio |
SlowKCustom |
StdError |
Stochastic |
StochasticExp |
SummationFC |
SwingHigh |
SwingHighBar |
SwingIndex |
SwingLow |
SwingLowBar |
TimeSeriesForecast |
TPOVAHighLow |
TriAverage |
TRIX |
UltimateOscillator |
Volatility |
VolatilityStdDev |
VolumeOsc |
vwapResettable |
XAverage |
XAverageOrig |

Enumerations

Enumeration | Description
SharpeRatio.EPeriod |


_AdvanceDeclineRatio Class

For a list of all members of this type, see _AdvanceDeclineRatio Members .

System.Object
_AdvanceDeclineRatio

[Extension]
public static class _AdvanceDeclineRatio

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_AdvanceDeclineRatio Members | PowerLanguage.Function Namespace


_AdvanceDeclineRatio Members

_AdvanceDeclineRatio overview

Public Static Methods

AdvanceDeclineRatio

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_AdvanceDeclineRatio Class | PowerLanguage.Function Namespace


_AdvanceDeclineRatio Methods

The methods of the _AdvanceDeclineRatio class are listed below. For a complete list of _AdvanceDeclineRatio class members, see the _AdvanceDeclineRatio Members topic.

Public Static Methods

AdvanceDeclineRatio

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_AdvanceDeclineRatio Class | PowerLanguage.Function Namespace


_AdvanceDeclineRatio.AdvanceDeclineRatio Method

[Extension]
public static double AdvanceDeclineRatio(
this ISeries<double> advissues,
this ISeries<double> decissues
);

See Also

_AdvanceDeclineRatio Class | PowerLanguage.Function Namespace


_AvgPrice Class

For a list of all members of this type, see _AvgPrice Members .

System.Object
_AvgPrice

[Extension]
public static class _AvgPrice

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_AvgPrice Members | PowerLanguage.Function Namespace


_AvgPrice Members

_AvgPrice overview

Public Static Methods

AvgPrice

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_AvgPrice Class | PowerLanguage.Function Namespace


_AvgPrice Methods

The methods of the _AvgPrice class are listed below. For a complete list of _AvgPrice class members, see the _AvgPrice Members topic.

Public Static Methods

AvgPrice

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_AvgPrice Class | PowerLanguage.Function Namespace


_AvgPrice.AvgPrice Method

[Extension]
public static double AvgPrice(
this IInstrument Bars,
this int _bb
);

See Also

_AvgPrice Class | PowerLanguage.Function Namespace


_CCI Class

For a list of all members of this type, see _CCI Members .

System.Object
_CCI

[Extension]
public static class _CCI

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_CCI Members | PowerLanguage.Function Namespace


_CCI Members

_CCI overview

Public Static Methods

CCI

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_CCI Class | PowerLanguage.Function Namespace


_CCI Methods

The methods of the _CCI class are listed below. For a complete list of _CCI class members, see the _CCI Members topic.

Public Static Methods

CCI

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_CCI Class | PowerLanguage.Function Namespace


_CCI.CCI Method

[Extension]
public static double CCI(
this IInstrument Bars,
this int length
);

See Also

_CCI Class | PowerLanguage.Function Namespace


_CountIf Class

For a list of all members of this type, see _CountIf Members .

System.Object
_CountIf

[Extension]
public static class _CountIf

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_CountIf Members | PowerLanguage.Function Namespace


_CountIf Members

_CountIf overview

Public Static Methods

CountIF Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_CountIf Class | PowerLanguage.Function Namespace


_CountIf Methods

The methods of the _CountIf class are listed below. For a complete list of _CountIf class members, see the _CountIf Members topic.

Public Static Methods

CountIF Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_CountIf Class | PowerLanguage.Function Namespace


CountIF Method

PowerLanguage.NET Help

_CountIf.CountIF Method

Overload List

public static int CountIF(this ISeries<bool>,this int)

public static int CountIF(this Func<int, bool>,this int)

See Also

_CountIf Class | PowerLanguage.Function Namespace


_CountIf.CountIF(ISeries, Int32) Method

[Extension]
public static int CountIF(
this ISeries<bool> test,
this int length
);

See Also

_CountIf Class | PowerLanguage.Function Namespace | _CountIf.CountIF Overload List


_CountIf.CountIF(Func, Int32) Method

[Extension]
public static int CountIF(
this Func<int, bool> test,
this int length
);

See Also

_CountIf Class | PowerLanguage.Function Namespace | _CountIf.CountIF Overload List


_Detrend Class

For a list of all members of this type, see _Detrend Members .

System.Object
_Detrend

[Extension]
public static class _Detrend

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Detrend Members | PowerLanguage.Function Namespace


_Detrend Members

_Detrend overview

Public Static Methods

Detrend

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Detrend Class | PowerLanguage.Function Namespace


_Detrend Methods

The methods of the _Detrend class are listed below. For a complete list of _Detrend class members, see the _Detrend Members topic.

Public Static Methods

Detrend

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Detrend Class | PowerLanguage.Function Namespace


_Detrend.Detrend Method

[Extension]
public static double Detrend(
this ISeries<double> price,
this int length
);

See Also

_Detrend Class | PowerLanguage.Function Namespace


_Doji Class

For a list of all members of this type, see _Doji Members .

System.Object
_Doji

[Extension]
public static class _Doji

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Doji Members | PowerLanguage.Function Namespace


_Doji Members

_Doji overview

Public Static Methods

Doji

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Doji Class | PowerLanguage.Function Namespace


_Doji Methods

The methods of the _Doji class are listed below. For a complete list of _Doji class members, see the _Doji Members topic.

Public Static Methods

Doji

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Doji Class | PowerLanguage.Function Namespace


_Doji.Doji Method

[Extension]
public static bool Doji(
this IInstrument Bars,
this double percent,
this int _bb
);

See Also

_Doji Class | PowerLanguage.Function Namespace


_HighestBar Class

For a list of all members of this type, see _HighestBar Members .

System.Object
_HighestBar

[Extension]
public static class _HighestBar

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_HighestBar Members | PowerLanguage.Function Namespace


_HighestBar Members

_HighestBar overview

Public Static Methods

HighestBar

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_HighestBar Class | PowerLanguage.Function Namespace


_HighestBar Methods

The methods of the _HighestBar class are listed below. For a complete list of _HighestBar class members, see the _HighestBar Members topic.

Public Static Methods

HighestBar

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_HighestBar Class | PowerLanguage.Function Namespace


_HighestBar.HighestBar Method

[Extension]
public static int HighestBar(
this ISeries<double> price,
this int length
);

See Also

_HighestBar Class | PowerLanguage.Function Namespace


_LowestBar Class

For a list of all members of this type, see _LowestBar Members .

System.Object
_LowestBar

[Extension]
public static class _LowestBar

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_LowestBar Members | PowerLanguage.Function Namespace


_LowestBar Members

_LowestBar overview

Public Static Methods

LowestBar

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_LowestBar Class | PowerLanguage.Function Namespace


_LowestBar Methods

The methods of the _LowestBar class are listed below. For a complete list of _LowestBar class members, see the _LowestBar Members topic.

Public Static Methods

LowestBar

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_LowestBar Class | PowerLanguage.Function Namespace


_LowestBar.LowestBar Method

[Extension]
public static int LowestBar(
this ISeries<double> price,
this int length
);

See Also

_LowestBar Class | PowerLanguage.Function Namespace


_MedianPrice Class

For a list of all members of this type, see _MedianPrice Members .

System.Object
_MedianPrice

[Extension]
public static class _MedianPrice

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_MedianPrice Members | PowerLanguage.Function Namespace


_MedianPrice Members

_MedianPrice overview

Public Static Methods

MedianPrice

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_MedianPrice Class | PowerLanguage.Function Namespace


_MedianPrice Methods

The methods of the _MedianPrice class are listed below. For a complete list of _MedianPrice class members, see the _MedianPrice Members topic.

Public Static Methods

MedianPrice

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_MedianPrice Class | PowerLanguage.Function Namespace


_MedianPrice.MedianPrice Method

[Extension]
public static double MedianPrice(
this IInstrument Bars,
this int _bb
);

See Also

_MedianPrice Class | PowerLanguage.Function Namespace


_MFI Class

For a list of all members of this type, see _MFI Members .

System.Object
_MFI

[Extension]
public static class _MFI

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_MFI Members | PowerLanguage.Function Namespace


_MFI Members

_MFI overview

Public Static Methods

MFI Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_MFI Class | PowerLanguage.Function Namespace


_MFI Methods

The methods of the _MFI class are listed below. For a complete list of _MFI class members, see the _MFI Members topic.

Public Static Methods

MFI Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_MFI Class | PowerLanguage.Function Namespace


MFI Method

PowerLanguage.NET Help

_MFI.MFI Method

Overload List

public static double MFI(this IInstrument)

public static double MFI(this IInstrument,this ISeries<double>,this int)

public static double MFI(this IInstrument,this int)

See Also

_MFI Class | PowerLanguage.Function Namespace


_MFI.MFI(IInstrument) Method

[Extension]
public static double MFI(
this IInstrument _Bars
);

See Also

_MFI Class | PowerLanguage.Function Namespace | _MFI.MFI Overload List


_MFI.MFI(IInstrument, ISeries, Int32) Method

[Extension]
public static double MFI(
this IInstrument _Bars,
this ISeries<double> anyvol,
this int _bb
);

See Also

_MFI Class | PowerLanguage.Function Namespace | _MFI.MFI Overload List


_MFI.MFI(IInstrument, Int32) Method

[Extension]
public static double MFI(
this IInstrument _Bars,
this int bb
);

See Also

_MFI Class | PowerLanguage.Function Namespace | _MFI.MFI Overload List


_Momentum Class

For a list of all members of this type, see _Momentum Members .

System.Object
_Momentum

[Extension]
public static class _Momentum

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Momentum Members | PowerLanguage.Function Namespace


_Momentum Members

_Momentum overview

Public Static Methods

Momentum | Overloaded.
MomentumSeries |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Momentum Class | PowerLanguage.Function Namespace


_Momentum Methods

The methods of the _Momentum class are listed below. For a complete list of _Momentum class members, see the _Momentum Members topic.

Public Static Methods

Momentum | Overloaded.
MomentumSeries |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Momentum Class | PowerLanguage.Function Namespace


Momentum Method

PowerLanguage.NET Help

_Momentum.Momentum Method

Overload List

public static double Momentum(this ISeries<double>,this int)

public static double Momentum(this ISeries<double>,this int,this int)

See Also

_Momentum Class | PowerLanguage.Function Namespace


_Momentum.Momentum(ISeries, Int32) Method

[Extension]
public static double Momentum(
this ISeries<double> price,
this int length
);

See Also

_Momentum Class | PowerLanguage.Function Namespace | _Momentum.Momentum Overload List


_Momentum.Momentum(ISeries, Int32, Int32) Method

[Extension]
public static double Momentum(
this ISeries<double> price,
this int length,
this int _bb
);

See Also

_Momentum Class | PowerLanguage.Function Namespace | _Momentum.Momentum Overload List


_Momentum.MomentumSeries Method

[Extension]
public static ISeries<double> MomentumSeries(
this ISeries<double> price,
this int length
);

See Also

_Momentum Class | PowerLanguage.Function Namespace


_MoneyFlow Class

For a list of all members of this type, see _MoneyFlow Members .

System.Object
_MoneyFlow

[Extension]
public static class _MoneyFlow

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_MoneyFlow Members | PowerLanguage.Function Namespace


_MoneyFlow Members

_MoneyFlow overview

Public Static Methods

MoneyFlow

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_MoneyFlow Class | PowerLanguage.Function Namespace


_MoneyFlow Methods

The methods of the _MoneyFlow class are listed below. For a complete list of _MoneyFlow class members, see the _MoneyFlow Members topic.

Public Static Methods

MoneyFlow

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_MoneyFlow Class | PowerLanguage.Function Namespace


_MoneyFlow.MoneyFlow Method

[Extension]
public static double MoneyFlow(
this IInstrument Bars,
this int length
);

See Also

_MoneyFlow Class | PowerLanguage.Function Namespace


_Next3rdFriday Class

For a list of all members of this type, see _Next3rdFriday Members .

System.Object
_Next3rdFriday

[Extension]
public static class _Next3rdFriday

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Next3rdFriday Members | PowerLanguage.Function Namespace


_Next3rdFriday Members

_Next3rdFriday overview

Public Static Methods

Next3rdFriday

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Next3rdFriday Class | PowerLanguage.Function Namespace


_Next3rdFriday Methods

The methods of the _Next3rdFriday class are listed below. For a complete list of _Next3rdFriday class members, see the _Next3rdFriday Members topic.

Public Static Methods

Next3rdFriday

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Next3rdFriday Class | PowerLanguage.Function Namespace


_Next3rdFriday.Next3rdFriday Method

[Extension]
public static int Next3rdFriday(
this IInstrument Bars,
this int series,
this int _bb
);

See Also

_Next3rdFriday Class | PowerLanguage.Function Namespace


_PercentChange Class

For a list of all members of this type, see _PercentChange Members .

System.Object
_PercentChange

[Extension]
public static class _PercentChange

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_PercentChange Members | PowerLanguage.Function Namespace


_PercentChange Members

_PercentChange overview

Public Static Methods

PercentChange

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_PercentChange Class | PowerLanguage.Function Namespace


_PercentChange Methods

The methods of the _PercentChange class are listed below. For a complete list of _PercentChange class members, see the _PercentChange Members topic.

Public Static Methods

PercentChange

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_PercentChange Class | PowerLanguage.Function Namespace


_PercentChange.PercentChange Method

[Extension]
public static double PercentChange(
this ISeries<double> price,
this int length,
this int _bb
);

See Also

_PercentChange Class | PowerLanguage.Function Namespace


_PercentR Class

For a list of all members of this type, see _PercentR Members .

System.Object
_PercentR

[Extension]
public static class _PercentR

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_PercentR Members | PowerLanguage.Function Namespace


_PercentR Members

_PercentR overview

Public Static Methods

PercentR

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_PercentR Class | PowerLanguage.Function Namespace


_PercentR Methods

The methods of the _PercentR class are listed below. For a complete list of _PercentR class members, see the _PercentR Members topic.

Public Static Methods

PercentR

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_PercentR Class | PowerLanguage.Function Namespace


_PercentR.PercentR Method

[Extension]
public static double PercentR(
this IInstrument Bars,
this int length
);

See Also

_PercentR Class | PowerLanguage.Function Namespace


_PortfolioDataUtils Class

For a list of all members of this type, see _PortfolioDataUtils Members .

System.Object
_PortfolioDataUtils

[Extension]
public static class _PortfolioDataUtils

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_PortfolioDataUtils Members | PowerLanguage.Function Namespace


_PortfolioDataUtils Members

_PortfolioDataUtils overview

Public Static Methods

safe_cast2double

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_PortfolioDataUtils Class | PowerLanguage.Function Namespace


_PortfolioDataUtils Methods

The methods of the _PortfolioDataUtils class are listed below. For a complete list of _PortfolioDataUtils class members, see the _PortfolioDataUtils Members topic.

Public Static Methods

safe_cast2double

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_PortfolioDataUtils Class | PowerLanguage.Function Namespace


_PortfolioDataUtils.safe_cast2double Method

[Extension]
public static double safe_cast2double(
this object o
);

See Also

_PortfolioDataUtils Class | PowerLanguage.Function Namespace


_Range Class

For a list of all members of this type, see _Range Members .

System.Object
_Range

[Extension]
public static class _Range

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Range Members | PowerLanguage.Function Namespace


_Range Members

_Range overview

Public Static Methods

Range | Overloaded.
RangeSeries |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Range Class | PowerLanguage.Function Namespace


_Range Methods

The methods of the _Range class are listed below. For a complete list of _Range class members, see the _Range Members topic.

Public Static Methods

Range | Overloaded.
RangeSeries |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Range Class | PowerLanguage.Function Namespace


Range Method

PowerLanguage.NET Help

_Range.Range Method

Overload List

public static double Range(this IInstrument)

public static double Range(this IInstrument,this int)

See Also

_Range Class | PowerLanguage.Function Namespace


_Range.Range(IInstrument) Method

[Extension]
public static double Range(
this IInstrument Bars
);

See Also

_Range Class | PowerLanguage.Function Namespace | _Range.Range Overload List


_Range.Range(IInstrument, Int32) Method

[Extension]
public static double Range(
this IInstrument Bars,
this int _bb
);

See Also

_Range Class | PowerLanguage.Function Namespace | _Range.Range Overload List


_Range.RangeSeries Method

[Extension]
public static ISeries<double> RangeSeries(
this IInstrument Bars
);

See Also

_Range Class | PowerLanguage.Function Namespace


_RateOfChange Class

For a list of all members of this type, see _RateOfChange Members .

System.Object
_RateOfChange

[Extension]
public static class _RateOfChange

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_RateOfChange Members | PowerLanguage.Function Namespace


_RateOfChange Members

_RateOfChange overview

Public Static Methods

RateOfChange

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_RateOfChange Class | PowerLanguage.Function Namespace


_RateOfChange Methods

The methods of the _RateOfChange class are listed below. For a complete list of _RateOfChange class members, see the _RateOfChange Members topic.

Public Static Methods

RateOfChange

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_RateOfChange Class | PowerLanguage.Function Namespace


_RateOfChange.RateOfChange Method

[Extension]
public static double RateOfChange(
this ISeries<double> price,
this int length
);

See Also

_RateOfChange Class | PowerLanguage.Function Namespace


_Round2Fraction Class

For a list of all members of this type, see _Round2Fraction Members .

System.Object
_Round2Fraction

[Extension]
public static class _Round2Fraction

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Round2Fraction Members | PowerLanguage.Function Namespace


_Round2Fraction Members

_Round2Fraction overview

Public Static Methods

Round2Fraction

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Round2Fraction Class | PowerLanguage.Function Namespace


_Round2Fraction Methods

The methods of the _Round2Fraction class are listed below. For a complete list of _Round2Fraction class members, see the _Round2Fraction Members topic.

Public Static Methods

Round2Fraction

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Round2Fraction Class | PowerLanguage.Function Namespace


_Round2Fraction.Round2Fraction Method

[Extension]
public static double Round2Fraction(
this IInstrument Bars,
this double val
);

See Also

_Round2Fraction Class | PowerLanguage.Function Namespace


_Text_Float Class

For a list of all members of this type, see _Text_Float Members .

System.Object
_Text_Float

[Extension]
public static class _Text_Float

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_Text_Float Members | PowerLanguage.Function Namespace


_Text_Float Members

_Text_Float overview

Public Static Methods

Text_Float

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Text_Float Class | PowerLanguage.Function Namespace


_Text_Float Methods

The methods of the _Text_Float class are listed below. For a complete list of _Text_Float class members, see the _Text_Float Members topic.

Public Static Methods

Text_Float

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_Text_Float Class | PowerLanguage.Function Namespace


_Text_Float.Text_Float Method

[Extension]
public static void Text_Float(
this IStudy _this,
this ITextObject textid,
this int textbarsback,
this double textpricepercent
);

See Also

_Text_Float Class | PowerLanguage.Function Namespace


_TrueHigh Class

For a list of all members of this type, see _TrueHigh Members .

System.Object
_TrueHigh

[Extension]
public static class _TrueHigh

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_TrueHigh Members | PowerLanguage.Function Namespace


_TrueHigh Members

_TrueHigh overview

Public Static Methods

TrueHigh | Overloaded.
TrueHighSeries | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_TrueHigh Class | PowerLanguage.Function Namespace


_TrueHigh Methods

The methods of the _TrueHigh class are listed below. For a complete list of _TrueHigh class members, see the _TrueHigh Members topic.

Public Static Methods

TrueHigh | Overloaded.
TrueHighSeries | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_TrueHigh Class | PowerLanguage.Function Namespace


TrueHigh Method

PowerLanguage.NET Help

_TrueHigh.TrueHigh Method

Overload List

public static double TrueHigh(this IInstrument)

public static double TrueHigh(this IInstrument,this int)

See Also

_TrueHigh Class | PowerLanguage.Function Namespace


_TrueHigh.TrueHigh(IInstrument) Method

[Extension]
public static double TrueHigh(
this IInstrument Bars
);

See Also

_TrueHigh Class | PowerLanguage.Function Namespace | _TrueHigh.TrueHigh Overload List


_TrueHigh.TrueHigh(IInstrument, Int32) Method

[Extension]
public static double TrueHigh(
this IInstrument Bars,
this int bb
);

See Also

_TrueHigh Class | PowerLanguage.Function Namespace | _TrueHigh.TrueHigh Overload List


TrueHighSeries Method

PowerLanguage.NET Help

_TrueHigh.TrueHighSeries Method

Overload List

public static ISeries<double> TrueHighSeries(this IInstrument)

public static ISeries<double> TrueHighSeries(this IInstrument,this int)

See Also

_TrueHigh Class | PowerLanguage.Function Namespace


_TrueHigh.TrueHighSeries(IInstrument) Method

[Extension]
public static ISeries<double> TrueHighSeries(
this IInstrument Bars
);

See Also

_TrueHigh Class | PowerLanguage.Function Namespace | _TrueHigh.TrueHighSeries Overload List


_TrueHigh.TrueHighSeries(IInstrument, Int32) Method

[Extension]
public static ISeries<double> TrueHighSeries(
this IInstrument Bars,
this int bb
);

See Also

_TrueHigh Class | PowerLanguage.Function Namespace | _TrueHigh.TrueHighSeries Overload List


_TrueLow Class

For a list of all members of this type, see _TrueLow Members .

System.Object
_TrueLow

[Extension]
public static class _TrueLow

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_TrueLow Members | PowerLanguage.Function Namespace


_TrueLow Members

_TrueLow overview

Public Static Methods

TrueLow | Overloaded.
TrueLowSeries | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_TrueLow Class | PowerLanguage.Function Namespace


_TrueLow Methods

The methods of the _TrueLow class are listed below. For a complete list of _TrueLow class members, see the _TrueLow Members topic.

Public Static Methods

TrueLow | Overloaded.
TrueLowSeries | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_TrueLow Class | PowerLanguage.Function Namespace


TrueLow Method

PowerLanguage.NET Help

_TrueLow.TrueLow Method

Overload List

public static double TrueLow(this IInstrument)

public static double TrueLow(this IInstrument,this int)

See Also

_TrueLow Class | PowerLanguage.Function Namespace


_TrueLow.TrueLow(IInstrument) Method

[Extension]
public static double TrueLow(
this IInstrument Bars
);

See Also

_TrueLow Class | PowerLanguage.Function Namespace | _TrueLow.TrueLow Overload List


_TrueLow.TrueLow(IInstrument, Int32) Method

[Extension]
public static double TrueLow(
this IInstrument Bars,
this int bb
);

See Also

_TrueLow Class | PowerLanguage.Function Namespace | _TrueLow.TrueLow Overload List


TrueLowSeries Method

PowerLanguage.NET Help

_TrueLow.TrueLowSeries Method

Overload List

public static ISeries<double> TrueLowSeries(this IInstrument)

public static ISeries<double> TrueLowSeries(this IInstrument,this int)

See Also

_TrueLow Class | PowerLanguage.Function Namespace


_TrueLow.TrueLowSeries(IInstrument) Method

[Extension]
public static ISeries<double> TrueLowSeries(
this IInstrument Bars
);

See Also

_TrueLow Class | PowerLanguage.Function Namespace | _TrueLow.TrueLowSeries Overload List


_TrueLow.TrueLowSeries(IInstrument, Int32) Method

[Extension]
public static ISeries<double> TrueLowSeries(
this IInstrument Bars,
this int bb
);

See Also

_TrueLow Class | PowerLanguage.Function Namespace | _TrueLow.TrueLowSeries Overload List


_TypicalPrice Class

For a list of all members of this type, see _TypicalPrice Members .

System.Object
_TypicalPrice

[Extension]
public static class _TypicalPrice

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_TypicalPrice Members | PowerLanguage.Function Namespace


_TypicalPrice Members

_TypicalPrice overview

Public Static Methods

TypicalPrice
TypicalPriceSeries

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_TypicalPrice Class | PowerLanguage.Function Namespace


_TypicalPrice Methods

The methods of the _TypicalPrice class are listed below. For a complete list of _TypicalPrice class members, see the _TypicalPrice Members topic.

Public Static Methods

TypicalPrice
TypicalPriceSeries

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_TypicalPrice Class | PowerLanguage.Function Namespace


_TypicalPrice.TypicalPrice Method

[Extension]
public static double TypicalPrice(
this IInstrument Bars,
this int bb
);

See Also

_TypicalPrice Class | PowerLanguage.Function Namespace


_TypicalPrice.TypicalPriceSeries Method

[Extension]
public static ISeries<double> TypicalPriceSeries(
this IInstrument Bars,
this int bb
);

See Also

_TypicalPrice Class | PowerLanguage.Function Namespace


_VolumeROC Class

For a list of all members of this type, see _VolumeROC Members .

System.Object
_VolumeROC

[Extension]
public static class _VolumeROC

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_VolumeROC Members | PowerLanguage.Function Namespace


_VolumeROC Members

_VolumeROC overview

Public Static Methods

VolumeROC

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_VolumeROC Class | PowerLanguage.Function Namespace


_VolumeROC Methods

The methods of the _VolumeROC class are listed below. For a complete list of _VolumeROC class members, see the _VolumeROC Members topic.

Public Static Methods

VolumeROC

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_VolumeROC Class | PowerLanguage.Function Namespace


_VolumeROC.VolumeROC Method

[Extension]
public static double VolumeROC(
this IInstrument bars,
this int length
);

See Also

_VolumeROC Class | PowerLanguage.Function Namespace


_WeightedClose Class

For a list of all members of this type, see _WeightedClose Members .

System.Object
_WeightedClose

[Extension]
public static class _WeightedClose

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

_WeightedClose Members | PowerLanguage.Function Namespace


_WeightedClose Members

_WeightedClose overview

Public Static Methods

WeightedClose

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_WeightedClose Class | PowerLanguage.Function Namespace


_WeightedClose Methods

The methods of the _WeightedClose class are listed below. For a complete list of _WeightedClose class members, see the _WeightedClose Members topic.

Public Static Methods

WeightedClose

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

_WeightedClose Class | PowerLanguage.Function Namespace


_WeightedClose.WeightedClose Method

[Extension]
public static double WeightedClose(
this IInstrument Bars,
this int bb
);

See Also

_WeightedClose Class | PowerLanguage.Function Namespace


AccumSwingIndex Class

For a list of all members of this type, see AccumSwingIndex Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
AccumSwingIndex

[DefaultMember(MemberName="Item")]
public class AccumSwingIndex : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

AccumSwingIndex Members | PowerLanguage.Function Namespace


AccumSwingIndex Members

AccumSwingIndex overview

Public Instance Constructors

AccumSwingIndex Overloaded. Initializes a new instance of the AccumSwingIndex class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

AccumSwingIndex Class | PowerLanguage.Function Namespace


AccumSwingIndex Constructor

Overload List

public AccumSwingIndex(CStudyControl)

public AccumSwingIndex(CStudyControl,int)

See Also

AccumSwingIndex Class | PowerLanguage.Function Namespace


AccumSwingIndex Constructor

AccumSwingIndex(
CStudyControl ctx
);

See Also

AccumSwingIndex Class | PowerLanguage.Function Namespace | AccumSwingIndex Constructor Overload List


AccumSwingIndex Constructor

AccumSwingIndex(
CStudyControl ctx,
int data_stream
);

See Also

AccumSwingIndex Class | PowerLanguage.Function Namespace | AccumSwingIndex Constructor Overload List


AccumSwingIndex Methods

The methods of the AccumSwingIndex class are listed below. For a complete list of AccumSwingIndex class members, see the AccumSwingIndex Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

AccumSwingIndex Class | PowerLanguage.Function Namespace


AccumSwingIndex.CalcBar Method

protected override double CalcBar();

See Also

AccumSwingIndex Class | PowerLanguage.Function Namespace


AccumulationDistribution Class

For a list of all members of this type, see AccumulationDistribution Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
AccumulationDistribution

[DefaultMember(MemberName="Item")]
public class AccumulationDistribution : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

AccumulationDistribution Members | PowerLanguage.Function Namespace


AccumulationDistribution Members

AccumulationDistribution overview

Public Instance Constructors

AccumulationDistribution Overloaded. Initializes a new instance of the AccumulationDistribution class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
AnyVolume |
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace


AccumulationDistribution Constructor

Overload List

public AccumulationDistribution(CStudyControl)

public AccumulationDistribution(CStudyControl,int)

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace


AccumulationDistribution Constructor

AccumulationDistribution(
CStudyControl ctx
);

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace | AccumulationDistribution Constructor Overload List


AccumulationDistribution Constructor

AccumulationDistribution(
CStudyControl ctx,
int data_stream
);

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace | AccumulationDistribution Constructor Overload List


AccumulationDistribution Properties

The properties of the AccumulationDistribution class are listed below. For a complete list of AccumulationDistribution class members, see the AccumulationDistribution Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
AnyVolume |
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace


AnyVolume Property

PowerLanguage.NET Help

AccumulationDistribution.AnyVolume Property

public ISeries<double> AnyVolume { public get; public set; }

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace


AccumulationDistribution Methods

The methods of the AccumulationDistribution class are listed below. For a complete list of AccumulationDistribution class members, see the AccumulationDistribution Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace


AccumulationDistribution.CalcBar Method

protected override double CalcBar();

See Also

AccumulationDistribution Class | PowerLanguage.Function Namespace


AdaptiveMovAvg Class

For a list of all members of this type, see AdaptiveMovAvg Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
AdaptiveMovAvg

[DefaultMember(MemberName="Item")]
public class AdaptiveMovAvg : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

AdaptiveMovAvg Members | PowerLanguage.Function Namespace


AdaptiveMovAvg Members

AdaptiveMovAvg overview

Public Instance Constructors

AdaptiveMovAvg Overloaded. Initializes a new instance of the AdaptiveMovAvg class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
effratiolength |
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastavglength |
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
slowavglength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


AdaptiveMovAvg Constructor

Overload List

public AdaptiveMovAvg(CStudyControl)

public AdaptiveMovAvg(CStudyControl,int)

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


AdaptiveMovAvg Constructor

AdaptiveMovAvg(
CStudyControl ctx
);

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace | AdaptiveMovAvg Constructor Overload List


AdaptiveMovAvg Constructor

AdaptiveMovAvg(
CStudyControl ctx,
int data_stream
);

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace | AdaptiveMovAvg Constructor Overload List


AdaptiveMovAvg Properties

The properties of the AdaptiveMovAvg class are listed below. For a complete list of AdaptiveMovAvg class members, see the AdaptiveMovAvg Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
effratiolength |
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastavglength |
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
slowavglength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


effratiolength Property

PowerLanguage.NET Help

AdaptiveMovAvg.effratiolength Property

public int effratiolength { public get; public set; }

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


fastavglength Property

PowerLanguage.NET Help

AdaptiveMovAvg.fastavglength Property

public int fastavglength { public get; public set; }

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

AdaptiveMovAvg.price Property

public ISeries<double> price { public get; public set; }

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


slowavglength Property

PowerLanguage.NET Help

AdaptiveMovAvg.slowavglength Property

public int slowavglength { public get; public set; }

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


AdaptiveMovAvg Methods

The methods of the AdaptiveMovAvg class are listed below. For a complete list of AdaptiveMovAvg class members, see the AdaptiveMovAvg Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


AdaptiveMovAvg.CalcBar Method

protected override double CalcBar();

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


AdaptiveMovAvg.StartCalc Method

protected override void StartCalc();

See Also

AdaptiveMovAvg Class | PowerLanguage.Function Namespace


AdvanceDeclineDiff Class

For a list of all members of this type, see AdvanceDeclineDiff Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
AdvanceDeclineDiff

[DefaultMember(MemberName="Item")]
public class AdvanceDeclineDiff : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

AdvanceDeclineDiff Members | PowerLanguage.Function Namespace


AdvanceDeclineDiff Members

AdvanceDeclineDiff overview

Public Instance Constructors

AdvanceDeclineDiff Overloaded. Initializes a new instance of the AdvanceDeclineDiff class.

Public Instance Properties

advissues |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
decissues |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


AdvanceDeclineDiff Constructor

Overload List

public AdvanceDeclineDiff(CStudyControl)

public AdvanceDeclineDiff(CStudyControl,int)

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


AdvanceDeclineDiff Constructor

AdvanceDeclineDiff(
CStudyControl ctx
);

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace | AdvanceDeclineDiff Constructor Overload List


AdvanceDeclineDiff Constructor

AdvanceDeclineDiff(
CStudyControl ctx,
int data_stream
);

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace | AdvanceDeclineDiff Constructor Overload List


AdvanceDeclineDiff Properties

The properties of the AdvanceDeclineDiff class are listed below. For a complete list of AdvanceDeclineDiff class members, see the AdvanceDeclineDiff Members topic.

Public Instance Properties

advissues |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
decissues |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


advissues Property

PowerLanguage.NET Help

AdvanceDeclineDiff.advissues Property

public ISeries<double> advissues { public get; public set; }

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


decissues Property

PowerLanguage.NET Help

AdvanceDeclineDiff.decissues Property

public ISeries<double> decissues { public get; public set; }

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


AdvanceDeclineDiff Methods

The methods of the AdvanceDeclineDiff class are listed below. For a complete list of AdvanceDeclineDiff class members, see the AdvanceDeclineDiff Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


AdvanceDeclineDiff.CalcBar Method

protected override double CalcBar();

See Also

AdvanceDeclineDiff Class | PowerLanguage.Function Namespace


ADX Class

For a list of all members of this type, see ADX Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
ADX

[DefaultMember(MemberName="Item")]
public sealed class ADX : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ADX Members | PowerLanguage.Function Namespace


ADX Members

ADX overview

Public Instance Constructors

ADX Overloaded. Initializes a new instance of the ADX class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADX Class | PowerLanguage.Function Namespace


ADX Constructor

Overload List

public ADX(CStudyControl)

public ADX(CStudyControl,int)

See Also

ADX Class | PowerLanguage.Function Namespace


ADX Constructor

ADX(
CStudyControl _master
);

See Also

ADX Class | PowerLanguage.Function Namespace | ADX Constructor Overload List


ADX Constructor

ADX(
CStudyControl _master,
int _data_stream
);

See Also

ADX Class | PowerLanguage.Function Namespace | ADX Constructor Overload List


ADX Properties

The properties of the ADX class are listed below. For a complete list of ADX class members, see the ADX Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ADX Class | PowerLanguage.Function Namespace


Length Property

PowerLanguage.NET Help

ADX.Length Property

public int Length { public get; public set; }

See Also

ADX Class | PowerLanguage.Function Namespace


ADX Methods

The methods of the ADX class are listed below. For a complete list of ADX class members, see the ADX Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADX Class | PowerLanguage.Function Namespace


ADX.CalcBar Method

protected override double CalcBar();

See Also

ADX Class | PowerLanguage.Function Namespace


ADX.Create Method

protected override void Create();

See Also

ADX Class | PowerLanguage.Function Namespace


ADX.StartCalc Method

protected override void StartCalc();

See Also

ADX Class | PowerLanguage.Function Namespace


ADXCustom Class

For a list of all members of this type, see ADXCustom Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
ADXCustom

[DefaultMember(MemberName="Item")]
public class ADXCustom : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ADXCustom Members | PowerLanguage.Function Namespace


ADXCustom Members

ADXCustom overview

Public Instance Constructors

ADXCustom Overloaded. Initializes a new instance of the ADXCustom class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXCustom Constructor

Overload List

public ADXCustom(CStudyControl)

public ADXCustom(CStudyControl,int)

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXCustom Constructor

ADXCustom(
CStudyControl ctx
);

See Also

ADXCustom Class | PowerLanguage.Function Namespace | ADXCustom Constructor Overload List


ADXCustom Constructor

ADXCustom(
CStudyControl ctx,
int data_stream
);

See Also

ADXCustom Class | PowerLanguage.Function Namespace | ADXCustom Constructor Overload List


ADXCustom Properties

The properties of the ADXCustom class are listed below. For a complete list of ADXCustom class members, see the ADXCustom Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ADXCustom Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

ADXCustom.length Property

public int length { public get; public set; }

See Also

ADXCustom Class | PowerLanguage.Function Namespace


pricec Property

PowerLanguage.NET Help

ADXCustom.pricec Property

public ISeries<double> pricec { public get; public set; }

See Also

ADXCustom Class | PowerLanguage.Function Namespace


priceh Property

PowerLanguage.NET Help

ADXCustom.priceh Property

public ISeries<double> priceh { public get; public set; }

See Also

ADXCustom Class | PowerLanguage.Function Namespace


pricel Property

PowerLanguage.NET Help

ADXCustom.pricel Property

public ISeries<double> pricel { public get; public set; }

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXCustom Methods

The methods of the ADXCustom class are listed below. For a complete list of ADXCustom class members, see the ADXCustom Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXCustom.CalcBar Method

protected override double CalcBar();

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXCustom.Create Method

protected override void Create();

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXCustom.StartCalc Method

protected override void StartCalc();

See Also

ADXCustom Class | PowerLanguage.Function Namespace


ADXR Class

For a list of all members of this type, see ADXR Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
ADXR

[DefaultMember(MemberName="Item")]
public sealed class ADXR : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ADXR Members | PowerLanguage.Function Namespace


ADXR Members

ADXR overview

Public Instance Constructors

ADXR Overloaded. Initializes a new instance of the ADXR class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXR Constructor

Overload List

public ADXR(CStudyControl)

public ADXR(CStudyControl,int)

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXR Constructor

ADXR(
CStudyControl _master
);

See Also

ADXR Class | PowerLanguage.Function Namespace | ADXR Constructor Overload List


ADXR Constructor

ADXR(
CStudyControl _master,
int _data_stream
);

See Also

ADXR Class | PowerLanguage.Function Namespace | ADXR Constructor Overload List


ADXR Properties

The properties of the ADXR class are listed below. For a complete list of ADXR class members, see the ADXR Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ADXR Class | PowerLanguage.Function Namespace


Length Property

PowerLanguage.NET Help

ADXR.Length Property

public int Length { public get; public set; }

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXR Methods

The methods of the ADXR class are listed below. For a complete list of ADXR class members, see the ADXR Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXR.CalcBar Method

protected override double CalcBar();

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXR.Create Method

protected override void Create();

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXR.StartCalc Method

protected override void StartCalc();

See Also

ADXR Class | PowerLanguage.Function Namespace


ADXRCustom Class

For a list of all members of this type, see ADXRCustom Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
ADXRCustom

[DefaultMember(MemberName="Item")]
public class ADXRCustom : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ADXRCustom Members | PowerLanguage.Function Namespace


ADXRCustom Members

ADXRCustom overview

Public Instance Constructors

ADXRCustom Overloaded. Initializes a new instance of the ADXRCustom class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ADXRCustom Constructor

Overload List

public ADXRCustom(CStudyControl)

public ADXRCustom(CStudyControl,int)

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ADXRCustom Constructor

ADXRCustom(
CStudyControl ctx
);

See Also

ADXRCustom Class | PowerLanguage.Function Namespace | ADXRCustom Constructor Overload List


ADXRCustom Constructor

ADXRCustom(
CStudyControl ctx,
int data_stream
);

See Also

ADXRCustom Class | PowerLanguage.Function Namespace | ADXRCustom Constructor Overload List


ADXRCustom Properties

The properties of the ADXRCustom class are listed below. For a complete list of ADXRCustom class members, see the ADXRCustom Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

ADXRCustom.length Property

public int length { public get; public set; }

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


pricec Property

PowerLanguage.NET Help

ADXRCustom.pricec Property

public ISeries<double> pricec { public get; public set; }

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


priceh Property

PowerLanguage.NET Help

ADXRCustom.priceh Property

public ISeries<double> priceh { public get; public set; }

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


pricel Property

PowerLanguage.NET Help

ADXRCustom.pricel Property

public ISeries<double> pricel { public get; public set; }

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ADXRCustom Methods

The methods of the ADXRCustom class are listed below. For a complete list of ADXRCustom class members, see the ADXRCustom Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ADXRCustom.CalcBar Method

protected override double CalcBar();

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ADXRCustom.Create Method

protected override void Create();

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ADXRCustom.StartCalc Method

protected override void StartCalc();

See Also

ADXRCustom Class | PowerLanguage.Function Namespace


ArmsIndex Class

For a list of all members of this type, see ArmsIndex Members .

System.Object
ArmsIndex

public static class ArmsIndex

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ArmsIndex Members | PowerLanguage.Function Namespace


ArmsIndex Members

ArmsIndex overview

Public Static Methods

Calc

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ArmsIndex Class | PowerLanguage.Function Namespace


ArmsIndex Methods

The methods of the ArmsIndex class are listed below. For a complete list of ArmsIndex class members, see the ArmsIndex Members topic.

Public Static Methods

Calc

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ArmsIndex Class | PowerLanguage.Function Namespace


ArmsIndex.Calc Method

public static double Calc(
ISeries<double> advissues,
ISeries<double> advvolume,
ISeries<double> decissues,
ISeries<double> decvolume
);

See Also

ArmsIndex Class | PowerLanguage.Function Namespace


AverageFC Class

For a list of all members of this type, see AverageFC Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
AverageFC

[DefaultMember(MemberName="Item")]
public class AverageFC : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

AverageFC Members | PowerLanguage.Function Namespace


AverageFC Members

AverageFC overview

Public Instance Constructors

AverageFC Overloaded. Initializes a new instance of the AverageFC class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

AverageFC Class | PowerLanguage.Function Namespace


AverageFC Constructor

Overload List

public AverageFC(CStudyControl)

public AverageFC(CStudyControl,int)

See Also

AverageFC Class | PowerLanguage.Function Namespace


AverageFC Constructor

AverageFC(
CStudyControl ctx
);

See Also

AverageFC Class | PowerLanguage.Function Namespace | AverageFC Constructor Overload List


AverageFC Constructor

AverageFC(
CStudyControl ctx,
int data_stream
);

See Also

AverageFC Class | PowerLanguage.Function Namespace | AverageFC Constructor Overload List


AverageFC Properties

The properties of the AverageFC class are listed below. For a complete list of AverageFC class members, see the AverageFC Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

AverageFC Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

AverageFC.length Property

public int length { public get; public set; }

See Also

AverageFC Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

AverageFC.price Property

public ISeries<double> price { public get; public set; }

See Also

AverageFC Class | PowerLanguage.Function Namespace


AverageFC Methods

The methods of the AverageFC class are listed below. For a complete list of AverageFC class members, see the AverageFC Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

AverageFC Class | PowerLanguage.Function Namespace


AverageFC.CalcBar Method

protected override double CalcBar();

See Also

AverageFC Class | PowerLanguage.Function Namespace


AverageFC.Create Method

protected override void Create();

See Also

AverageFC Class | PowerLanguage.Function Namespace


AverageFC.StartCalc Method

protected override void StartCalc();

See Also

AverageFC Class | PowerLanguage.Function Namespace


AvgTrueRange Class

For a list of all members of this type, see AvgTrueRange Members .

System.Object
AvgTrueRange

[Extension]
public static class AvgTrueRange

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

AvgTrueRange Members | PowerLanguage.Function Namespace


AvgTrueRange Members

AvgTrueRange overview

Public Static Methods

AverageTrueRange | Overloaded.
AverageTrueRangeSeries |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace


AvgTrueRange Methods

The methods of the AvgTrueRange class are listed below. For a complete list of AvgTrueRange class members, see the AvgTrueRange Members topic.

Public Static Methods

AverageTrueRange | Overloaded.
AverageTrueRangeSeries |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace


AverageTrueRange Method

PowerLanguage.NET Help

AvgTrueRange.AverageTrueRange Method

Overload List

public static double AverageTrueRange(this IStudy,this int)

public static double AverageTrueRange(this IStudy,this int,this int)

public static double AverageTrueRange(this IStudy,this int,this int,this int)

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace


AvgTrueRange.AverageTrueRange(IStudy, Int32) Method

[Extension]
public static double AverageTrueRange(
this IStudy _this,
this int length
);

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace | AvgTrueRange.AverageTrueRange Overload List


AvgTrueRange.AverageTrueRange(IStudy, Int32, Int32) Method

[Extension]
public static double AverageTrueRange(
this IStudy _this,
this int length,
this int bb
);

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace | AvgTrueRange.AverageTrueRange Overload List


AvgTrueRange.AverageTrueRange(IStudy, Int32, Int32, Int32) Method

[Extension]
public static double AverageTrueRange(
this IStudy _this,
this int length,
this int bb,
this int datastream
);

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace | AvgTrueRange.AverageTrueRange Overload List


AvgTrueRange.AverageTrueRangeSeries Method

[Extension]
public static ISeries<double> AverageTrueRangeSeries(
this IStudy _this,
this int length
);

See Also

AvgTrueRange Class | PowerLanguage.Function Namespace


BarNumber Class

For a list of all members of this type, see BarNumber Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSeries<Int32>
BarNumber

[DefaultMember(MemberName="Item")]
public class BarNumber : FunctionSeries<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

BarNumber Members | PowerLanguage.Function Namespace


BarNumber Members

BarNumber overview

Public Instance Constructors

BarNumber Overloaded. Initializes a new instance of the BarNumber class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

BarNumber Class | PowerLanguage.Function Namespace


BarNumber Constructor

Overload List

public BarNumber(CStudyControl)

public BarNumber(CStudyControl,int)

See Also

BarNumber Class | PowerLanguage.Function Namespace


BarNumber Constructor

BarNumber(
CStudyControl ctx
);

See Also

BarNumber Class | PowerLanguage.Function Namespace | BarNumber Constructor Overload List


BarNumber Constructor

BarNumber(
CStudyControl ctx,
int data_stream
);

See Also

BarNumber Class | PowerLanguage.Function Namespace | BarNumber Constructor Overload List


BarNumber Methods

The methods of the BarNumber class are listed below. For a complete list of BarNumber class members, see the BarNumber Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

BarNumber Class | PowerLanguage.Function Namespace


BarNumber.CalcBar Method

protected override int CalcBar();

See Also

BarNumber Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows Class

For a list of all members of this type, see C_3WhSolds_3BlkCrows Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
C_3WhSolds_3BlkCrows

[DefaultMember(MemberName="Item")]
public class C_3WhSolds_3BlkCrows : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_3WhSolds_3BlkCrows Members | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows Members

C_3WhSolds_3BlkCrows overview

Public Instance Constructors

C_3WhSolds_3BlkCrows Overloaded. Initializes a new instance of the C_3WhSolds_3BlkCrows class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
o3blackcrows |
o3whitesoldiers |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
percent |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows Constructor

Overload List

public C_3WhSolds_3BlkCrows(CStudyControl)

public C_3WhSolds_3BlkCrows(CStudyControl,int)

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows Constructor

C_3WhSolds_3BlkCrows(
CStudyControl ctx
);

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace | C_3WhSolds_3BlkCrows Constructor Overload List


C_3WhSolds_3BlkCrows Constructor

C_3WhSolds_3BlkCrows(
CStudyControl ctx,
int data_stream
);

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace | C_3WhSolds_3BlkCrows Constructor Overload List


C_3WhSolds_3BlkCrows Properties

The properties of the C_3WhSolds_3BlkCrows class are listed below. For a complete list of C_3WhSolds_3BlkCrows class members, see the C_3WhSolds_3BlkCrows Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
o3blackcrows |
o3whitesoldiers |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
percent |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_3WhSolds_3BlkCrows.length Property

public int length { public get; public set; }

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


o3blackcrows Property

PowerLanguage.NET Help

C_3WhSolds_3BlkCrows.o3blackcrows Property

public IVar<int> o3blackcrows { public get; public set; }

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


o3whitesoldiers Property

PowerLanguage.NET Help

C_3WhSolds_3BlkCrows.o3whitesoldiers Property

public IVar<int> o3whitesoldiers { public get; public set; }

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


percent Property

PowerLanguage.NET Help

C_3WhSolds_3BlkCrows.percent Property

public double percent { public get; public set; }

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows Methods

The methods of the C_3WhSolds_3BlkCrows class are listed below. For a complete list of C_3WhSolds_3BlkCrows class members, see the C_3WhSolds_3BlkCrows Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows.CalcBar Method

protected override double CalcBar();

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows.Create Method

protected override void Create();

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_3WhSolds_3BlkCrows.StartCalc Method

protected override void StartCalc();

See Also

C_3WhSolds_3BlkCrows Class | PowerLanguage.Function Namespace


C_BullEng_BearEng Class

For a list of all members of this type, see C_BullEng_BearEng Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSeries<Int32>
C_BullEng_BearEng

[DefaultMember(MemberName="Item")]
public class C_BullEng_BearEng : FunctionSeries<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_BullEng_BearEng Members | PowerLanguage.Function Namespace


C_BullEng_BearEng Members

C_BullEng_BearEng overview

Public Instance Constructors

C_BullEng_BearEng Overloaded. Initializes a new instance of the C_BullEng_BearEng class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
obearishengulfing |
obullishengulfing |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullEng_BearEng Constructor

Overload List

public C_BullEng_BearEng(CStudyControl)

public C_BullEng_BearEng(CStudyControl,int)

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullEng_BearEng Constructor

C_BullEng_BearEng(
CStudyControl ctx
);

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace | C_BullEng_BearEng Constructor Overload List


C_BullEng_BearEng Constructor

C_BullEng_BearEng(
CStudyControl ctx,
int data_stream
);

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace | C_BullEng_BearEng Constructor Overload List


C_BullEng_BearEng Properties

The properties of the C_BullEng_BearEng class are listed below. For a complete list of C_BullEng_BearEng class members, see the C_BullEng_BearEng Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
obearishengulfing |
obullishengulfing |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


Length Property

PowerLanguage.NET Help

C_BullEng_BearEng.Length Property

public int Length { public get; public set; }

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


obearishengulfing Property

PowerLanguage.NET Help

C_BullEng_BearEng.obearishengulfing Property

public IVar<int> obearishengulfing { public get; public set; }

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


obullishengulfing Property

PowerLanguage.NET Help

C_BullEng_BearEng.obullishengulfing Property

public IVar<int> obullishengulfing { public get; public set; }

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullEng_BearEng Methods

The methods of the C_BullEng_BearEng class are listed below. For a complete list of C_BullEng_BearEng class members, see the C_BullEng_BearEng Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullEng_BearEng.CalcBar Method

protected override int CalcBar();

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullEng_BearEng.Create Method

protected override void Create();

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullEng_BearEng.StartCalc Method

protected override void StartCalc();

See Also

C_BullEng_BearEng Class | PowerLanguage.Function Namespace


C_BullHar_BearHar Class

For a list of all members of this type, see C_BullHar_BearHar Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
C_BullHar_BearHar

[DefaultMember(MemberName="Item")]
public class C_BullHar_BearHar : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_BullHar_BearHar Members | PowerLanguage.Function Namespace


C_BullHar_BearHar Members

C_BullHar_BearHar overview

Public Instance Constructors

C_BullHar_BearHar Overloaded. Initializes a new instance of the C_BullHar_BearHar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
obearishharami |
obullishharami |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_BullHar_BearHar Constructor

Overload List

public C_BullHar_BearHar(CStudyControl)

public C_BullHar_BearHar(CStudyControl,int)

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_BullHar_BearHar Constructor

C_BullHar_BearHar(
CStudyControl ctx
);

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace | C_BullHar_BearHar Constructor Overload List


C_BullHar_BearHar Constructor

C_BullHar_BearHar(
CStudyControl ctx,
int data_stream
);

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace | C_BullHar_BearHar Constructor Overload List


C_BullHar_BearHar Properties

The properties of the C_BullHar_BearHar class are listed below. For a complete list of C_BullHar_BearHar class members, see the C_BullHar_BearHar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
obearishharami |
obullishharami |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_BullHar_BearHar.length Property

public int length { public get; public set; }

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


obearishharami Property

PowerLanguage.NET Help

C_BullHar_BearHar.obearishharami Property

public IVar<int> obearishharami { public get; public set; }

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


obullishharami Property

PowerLanguage.NET Help

C_BullHar_BearHar.obullishharami Property

public IVar<int> obullishharami { public get; public set; }

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_BullHar_BearHar Methods

The methods of the C_BullHar_BearHar class are listed below. For a complete list of C_BullHar_BearHar class members, see the C_BullHar_BearHar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_BullHar_BearHar.CalcBar Method

protected override double CalcBar();

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_BullHar_BearHar.Create Method

protected override void Create();

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_BullHar_BearHar.StartCalc Method

protected override void StartCalc();

See Also

C_BullHar_BearHar Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan Class

For a list of all members of this type, see C_Hammer_HangingMan Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
C_Hammer_HangingMan

[DefaultMember(MemberName="Item")]
public class C_Hammer_HangingMan : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_Hammer_HangingMan Members | PowerLanguage.Function Namespace


C_Hammer_HangingMan Members

C_Hammer_HangingMan overview

Public Instance Constructors

C_Hammer_HangingMan Overloaded. Initializes a new instance of the C_Hammer_HangingMan class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
factor |
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
ohammer |
ohangingman |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan Constructor

Overload List

public C_Hammer_HangingMan(CStudyControl)

public C_Hammer_HangingMan(CStudyControl,int)

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan Constructor

C_Hammer_HangingMan(
CStudyControl ctx
);

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace | C_Hammer_HangingMan Constructor Overload List


C_Hammer_HangingMan Constructor

C_Hammer_HangingMan(
CStudyControl ctx,
int data_stream
);

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace | C_Hammer_HangingMan Constructor Overload List


C_Hammer_HangingMan Properties

The properties of the C_Hammer_HangingMan class are listed below. For a complete list of C_Hammer_HangingMan class members, see the C_Hammer_HangingMan Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
factor |
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
ohammer |
ohangingman |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


factor Property

PowerLanguage.NET Help

C_Hammer_HangingMan.factor Property

public double factor { public get; public set; }

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_Hammer_HangingMan.length Property

public int length { public get; public set; }

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


ohammer Property

PowerLanguage.NET Help

C_Hammer_HangingMan.ohammer Property

public IVar<int> ohammer { public get; public set; }

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


ohangingman Property

PowerLanguage.NET Help

C_Hammer_HangingMan.ohangingman Property

public IVar<int> ohangingman { public get; public set; }

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan Methods

The methods of the C_Hammer_HangingMan class are listed below. For a complete list of C_Hammer_HangingMan class members, see the C_Hammer_HangingMan Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan.CalcBar Method

protected override double CalcBar();

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan.Create Method

protected override void Create();

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_Hammer_HangingMan.StartCalc Method

protected override void StartCalc();

See Also

C_Hammer_HangingMan Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji Class

For a list of all members of this type, see C_MornDoji_EveDoji Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
C_MornDoji_EveDoji

[DefaultMember(MemberName="Item")]
public class C_MornDoji_EveDoji : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_MornDoji_EveDoji Members | PowerLanguage.Function Namespace


C_MornDoji_EveDoji Members

C_MornDoji_EveDoji overview

Public Instance Constructors

C_MornDoji_EveDoji Overloaded. Initializes a new instance of the C_MornDoji_EveDoji class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oeveningdojistar |
omorningdojistar |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
percent |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji Constructor

Overload List

public C_MornDoji_EveDoji(CStudyControl)

public C_MornDoji_EveDoji(CStudyControl,int)

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji Constructor

C_MornDoji_EveDoji(
CStudyControl ctx
);

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace | C_MornDoji_EveDoji Constructor Overload List


C_MornDoji_EveDoji Constructor

C_MornDoji_EveDoji(
CStudyControl ctx,
int data_stream
);

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace | C_MornDoji_EveDoji Constructor Overload List


C_MornDoji_EveDoji Properties

The properties of the C_MornDoji_EveDoji class are listed below. For a complete list of C_MornDoji_EveDoji class members, see the C_MornDoji_EveDoji Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oeveningdojistar |
omorningdojistar |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
percent |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_MornDoji_EveDoji.length Property

public int length { public get; public set; }

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


oeveningdojistar Property

PowerLanguage.NET Help

C_MornDoji_EveDoji.oeveningdojistar Property

public IVar<int> oeveningdojistar { public get; public set; }

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


omorningdojistar Property

PowerLanguage.NET Help

C_MornDoji_EveDoji.omorningdojistar Property

public IVar<int> omorningdojistar { public get; public set; }

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


percent Property

PowerLanguage.NET Help

C_MornDoji_EveDoji.percent Property

public double percent { public get; public set; }

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji Methods

The methods of the C_MornDoji_EveDoji class are listed below. For a complete list of C_MornDoji_EveDoji class members, see the C_MornDoji_EveDoji Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji.CalcBar Method

protected override double CalcBar();

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji.Create Method

protected override void Create();

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornDoji_EveDoji.StartCalc Method

protected override void StartCalc();

See Also

C_MornDoji_EveDoji Class | PowerLanguage.Function Namespace


C_MornStar_EveStar Class

For a list of all members of this type, see C_MornStar_EveStar Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
C_MornStar_EveStar

[DefaultMember(MemberName="Item")]
public class C_MornStar_EveStar : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_MornStar_EveStar Members | PowerLanguage.Function Namespace


C_MornStar_EveStar Members

C_MornStar_EveStar overview

Public Instance Constructors

C_MornStar_EveStar Overloaded. Initializes a new instance of the C_MornStar_EveStar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oeveningstar |
omorningstar |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_MornStar_EveStar Constructor

Overload List

public C_MornStar_EveStar(CStudyControl)

public C_MornStar_EveStar(CStudyControl,int)

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_MornStar_EveStar Constructor

C_MornStar_EveStar(
CStudyControl ctx
);

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace | C_MornStar_EveStar Constructor Overload List


C_MornStar_EveStar Constructor

C_MornStar_EveStar(
CStudyControl ctx,
int data_stream
);

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace | C_MornStar_EveStar Constructor Overload List


C_MornStar_EveStar Properties

The properties of the C_MornStar_EveStar class are listed below. For a complete list of C_MornStar_EveStar class members, see the C_MornStar_EveStar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oeveningstar |
omorningstar |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_MornStar_EveStar.length Property

public int length { public get; public set; }

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


oeveningstar Property

PowerLanguage.NET Help

C_MornStar_EveStar.oeveningstar Property

public IVar<int> oeveningstar { public get; public set; }

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


omorningstar Property

PowerLanguage.NET Help

C_MornStar_EveStar.omorningstar Property

public IVar<int> omorningstar { public get; public set; }

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_MornStar_EveStar Methods

The methods of the C_MornStar_EveStar class are listed below. For a complete list of C_MornStar_EveStar class members, see the C_MornStar_EveStar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_MornStar_EveStar.CalcBar Method

protected override double CalcBar();

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_MornStar_EveStar.Create Method

protected override void Create();

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_MornStar_EveStar.StartCalc Method

protected override void StartCalc();

See Also

C_MornStar_EveStar Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud Class

For a list of all members of this type, see C_PierceLine_DkCloud Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
C_PierceLine_DkCloud

[DefaultMember(MemberName="Item")]
public class C_PierceLine_DkCloud : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_PierceLine_DkCloud Members | PowerLanguage.Function Namespace


C_PierceLine_DkCloud Members

C_PierceLine_DkCloud overview

Public Instance Constructors

C_PierceLine_DkCloud Overloaded. Initializes a new instance of the C_PierceLine_DkCloud class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
odarkcloud |
opiercingline |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud Constructor

Overload List

public C_PierceLine_DkCloud(CStudyControl)

public C_PierceLine_DkCloud(CStudyControl,int)

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud Constructor

C_PierceLine_DkCloud(
CStudyControl ctx
);

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace | C_PierceLine_DkCloud Constructor Overload List


C_PierceLine_DkCloud Constructor

C_PierceLine_DkCloud(
CStudyControl ctx,
int data_stream
);

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace | C_PierceLine_DkCloud Constructor Overload List


C_PierceLine_DkCloud Properties

The properties of the C_PierceLine_DkCloud class are listed below. For a complete list of C_PierceLine_DkCloud class members, see the C_PierceLine_DkCloud Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
odarkcloud |
opiercingline |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_PierceLine_DkCloud.length Property

public int length { public get; public set; }

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


odarkcloud Property

PowerLanguage.NET Help

C_PierceLine_DkCloud.odarkcloud Property

public IVar<int> odarkcloud { public get; public set; }

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


opiercingline Property

PowerLanguage.NET Help

C_PierceLine_DkCloud.opiercingline Property

public IVar<int> opiercingline { public get; public set; }

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud Methods

The methods of the C_PierceLine_DkCloud class are listed below. For a complete list of C_PierceLine_DkCloud class members, see the C_PierceLine_DkCloud Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud.CalcBar Method

protected override double CalcBar();

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud.Create Method

protected override void Create();

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_PierceLine_DkCloud.StartCalc Method

protected override void StartCalc();

See Also

C_PierceLine_DkCloud Class | PowerLanguage.Function Namespace


C_ShootingStar Class

For a list of all members of this type, see C_ShootingStar Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSeries<Int32>
C_ShootingStar

[DefaultMember(MemberName="Item")]
public class C_ShootingStar : FunctionSeries<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

C_ShootingStar Members | PowerLanguage.Function Namespace


C_ShootingStar Members

C_ShootingStar overview

Public Instance Constructors

C_ShootingStar Overloaded. Initializes a new instance of the C_ShootingStar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
factor |
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


C_ShootingStar Constructor

Overload List

public C_ShootingStar(CStudyControl)

public C_ShootingStar(CStudyControl,int)

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


C_ShootingStar Constructor

C_ShootingStar(
CStudyControl ctx
);

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace | C_ShootingStar Constructor Overload List


C_ShootingStar Constructor

C_ShootingStar(
CStudyControl ctx,
int data_stream
);

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace | C_ShootingStar Constructor Overload List


C_ShootingStar Properties

The properties of the C_ShootingStar class are listed below. For a complete list of C_ShootingStar class members, see the C_ShootingStar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
factor |
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


factor Property

PowerLanguage.NET Help

C_ShootingStar.factor Property

public double factor { public get; public set; }

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

C_ShootingStar.length Property

public int length { public get; public set; }

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


C_ShootingStar Methods

The methods of the C_ShootingStar class are listed below. For a complete list of C_ShootingStar class members, see the C_ShootingStar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


C_ShootingStar.CalcBar Method

protected override int CalcBar();

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


C_ShootingStar.Create Method

protected override void Create();

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


C_ShootingStar.StartCalc Method

protected override void StartCalc();

See Also

C_ShootingStar Class | PowerLanguage.Function Namespace


ChaikinOsc Class

For a list of all members of this type, see ChaikinOsc Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
ChaikinOsc

[DefaultMember(MemberName="Item")]
public class ChaikinOsc : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ChaikinOsc Members | PowerLanguage.Function Namespace


ChaikinOsc Members

ChaikinOsc overview

Public Instance Constructors

ChaikinOsc Overloaded. Initializes a new instance of the ChaikinOsc class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
anyvol |
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
longlength |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
shortlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


ChaikinOsc Constructor

Overload List

public ChaikinOsc(CStudyControl)

public ChaikinOsc(CStudyControl,int)

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


ChaikinOsc Constructor

ChaikinOsc(
CStudyControl ctx
);

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace | ChaikinOsc Constructor Overload List


ChaikinOsc Constructor

ChaikinOsc(
CStudyControl ctx,
int data_stream
);

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace | ChaikinOsc Constructor Overload List


ChaikinOsc Properties

The properties of the ChaikinOsc class are listed below. For a complete list of ChaikinOsc class members, see the ChaikinOsc Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
anyvol |
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
longlength |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
shortlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


anyvol Property

PowerLanguage.NET Help

ChaikinOsc.anyvol Property

public ISeries<double> anyvol { public get; public set; }

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


longlength Property

PowerLanguage.NET Help

ChaikinOsc.longlength Property

public int longlength { public get; public set; }

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


shortlength Property

PowerLanguage.NET Help

ChaikinOsc.shortlength Property

public int shortlength { public get; public set; }

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


ChaikinOsc Methods

The methods of the ChaikinOsc class are listed below. For a complete list of ChaikinOsc class members, see the ChaikinOsc Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


ChaikinOsc.CalcBar Method

protected override double CalcBar();

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


ChaikinOsc.Create Method

protected override void Create();

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


ChaikinOsc.StartCalc Method

protected override void StartCalc();

See Also

ChaikinOsc Class | PowerLanguage.Function Namespace


CloseD Class

For a list of all members of this type, see CloseD Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
CloseD

[DefaultMember(MemberName="Item")]
public class CloseD : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CloseD Members | PowerLanguage.Function Namespace


CloseD Members

CloseD overview

Public Instance Constructors

CloseD Overloaded. Initializes a new instance of the CloseD class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseD Constructor

Overload List

public CloseD(CStudyControl)

public CloseD(CStudyControl,int)

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseD Constructor

CloseD(
CStudyControl ctx
);

See Also

CloseD Class | PowerLanguage.Function Namespace | CloseD Constructor Overload List


CloseD Constructor

CloseD(
CStudyControl ctx,
int data_stream
);

See Also

CloseD Class | PowerLanguage.Function Namespace | CloseD Constructor Overload List


CloseD Properties

The properties of the CloseD class are listed below. For a complete list of CloseD class members, see the CloseD Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

CloseD Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

CloseD.periodsago Property

public int periodsago { public get; public set; }

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseD Methods

The methods of the CloseD class are listed below. For a complete list of CloseD class members, see the CloseD Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseD.CalcBar Method

protected override double CalcBar();

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseD.Create Method

protected override void Create();

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseD.StartCalc Method

protected override void StartCalc();

See Also

CloseD Class | PowerLanguage.Function Namespace


CloseS Class

For a list of all members of this type, see CloseS Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
CloseS

[DefaultMember(MemberName="Item")]
public class CloseS : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CloseS Members | PowerLanguage.Function Namespace


CloseS Members

CloseS overview

Public Instance Constructors

CloseS Overloaded. Initializes a new instance of the CloseS class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

CloseS Class | PowerLanguage.Function Namespace


CloseS Constructor

Overload List

public CloseS(CStudyControl)

public CloseS(CStudyControl,int)

See Also

CloseS Class | PowerLanguage.Function Namespace


CloseS Constructor

CloseS(
CStudyControl ctx
);

See Also

CloseS Class | PowerLanguage.Function Namespace | CloseS Constructor Overload List


CloseS Constructor

CloseS(
CStudyControl ctx,
int data_stream
);

See Also

CloseS Class | PowerLanguage.Function Namespace | CloseS Constructor Overload List


CloseS Properties

The properties of the CloseS class are listed below. For a complete list of CloseS class members, see the CloseS Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

CloseS Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

CloseS.periodsago Property

public int periodsago { public get; public set; }

See Also

CloseS Class | PowerLanguage.Function Namespace


CloseS Methods

The methods of the CloseS class are listed below. For a complete list of CloseS class members, see the CloseS Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

CloseS Class | PowerLanguage.Function Namespace


CloseS.CalcBar Method

protected override double CalcBar();

See Also

CloseS Class | PowerLanguage.Function Namespace


CloseS.Create Method

protected override void Create();

See Also

CloseS Class | PowerLanguage.Function Namespace


CloseS.StartCalc Method

protected override void StartCalc();

See Also

CloseS Class | PowerLanguage.Function Namespace


Correlation Class

For a list of all members of this type, see Correlation Members .

System.Object
Correlation

public static class Correlation

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

Correlation Members | PowerLanguage.Function Namespace


Correlation Members

Correlation overview

Public Static Methods

CalcCorrelation

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Correlation Class | PowerLanguage.Function Namespace


Correlation Methods

The methods of the Correlation class are listed below. For a complete list of Correlation class members, see the Correlation Members topic.

Public Static Methods

CalcCorrelation

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Correlation Class | PowerLanguage.Function Namespace


Correlation.CalcCorrelation Method

public static double CalcCorrelation(
ISeries<double> indep,
ISeries<double> dep,
int length
);

See Also

Correlation Class | PowerLanguage.Function Namespace


CSI Class

For a list of all members of this type, see CSI Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
CSI

[DefaultMember(MemberName="Item")]
public class CSI : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CSI Members | PowerLanguage.Function Namespace


CSI Members

CSI overview

Public Instance Constructors

CSI Overloaded. Initializes a new instance of the CSI class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
mycommission |
mymargin |
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

CSI Class | PowerLanguage.Function Namespace


CSI Constructor

Overload List

public CSI(CStudyControl)

public CSI(CStudyControl,int)

See Also

CSI Class | PowerLanguage.Function Namespace


CSI Constructor

CSI(
CStudyControl ctx
);

See Also

CSI Class | PowerLanguage.Function Namespace | CSI Constructor Overload List


CSI Constructor

CSI(
CStudyControl ctx,
int data_stream
);

See Also

CSI Class | PowerLanguage.Function Namespace | CSI Constructor Overload List


CSI Properties

The properties of the CSI class are listed below. For a complete list of CSI class members, see the CSI Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
mycommission |
mymargin |
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

CSI Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

CSI.length Property

public int length { public get; public set; }

See Also

CSI Class | PowerLanguage.Function Namespace


mycommission Property

PowerLanguage.NET Help

CSI.mycommission Property

public double mycommission { public get; public set; }

See Also

CSI Class | PowerLanguage.Function Namespace


mymargin Property

PowerLanguage.NET Help

CSI.mymargin Property

public double mymargin { public get; public set; }

See Also

CSI Class | PowerLanguage.Function Namespace


CSI Methods

The methods of the CSI class are listed below. For a complete list of CSI class members, see the CSI Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

CSI Class | PowerLanguage.Function Namespace


CSI.CalcBar Method

protected override double CalcBar();

See Also

CSI Class | PowerLanguage.Function Namespace


CSI.Create Method

protected override void Create();

See Also

CSI Class | PowerLanguage.Function Namespace


CSI.StartCalc Method

protected override void StartCalc();

See Also

CSI Class | PowerLanguage.Function Namespace


Cum Class

For a list of all members of this type, see Cum Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
Cum

[DefaultMember(MemberName="Item")]
public class Cum : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

Cum Members | PowerLanguage.Function Namespace


Cum Members

Cum overview

Public Instance Constructors

Cum Overloaded. Initializes a new instance of the Cum class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

Cum Class | PowerLanguage.Function Namespace


Cum Constructor

Overload List

public Cum(CStudyControl)

public Cum(CStudyControl,int)

See Also

Cum Class | PowerLanguage.Function Namespace


Cum Constructor

Cum(
CStudyControl ctx
);

See Also

Cum Class | PowerLanguage.Function Namespace | Cum Constructor Overload List


Cum Constructor

Cum(
CStudyControl ctx,
int data_stream
);

See Also

Cum Class | PowerLanguage.Function Namespace | Cum Constructor Overload List


Cum Properties

The properties of the Cum class are listed below. For a complete list of Cum class members, see the Cum Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

Cum Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

Cum.price Property

public ISeries<double> price { public get; public set; }

See Also

Cum Class | PowerLanguage.Function Namespace


Cum Methods

The methods of the Cum class are listed below. For a complete list of Cum class members, see the Cum Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

Cum Class | PowerLanguage.Function Namespace


Cum.CalcBar Method

protected override double CalcBar();

See Also

Cum Class | PowerLanguage.Function Namespace


CurrencyHelper Class

For a list of all members of this type, see CurrencyHelper Members .

System.Object
CurrencyHelper

public static class CurrencyHelper

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

CurrencyHelper Members | PowerLanguage.Function Namespace


CurrencyHelper Members

CurrencyHelper overview

Public Static Methods

CurrencyToString

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CurrencyHelper Class | PowerLanguage.Function Namespace


CurrencyHelper Methods

The methods of the CurrencyHelper class are listed below. For a complete list of CurrencyHelper class members, see the CurrencyHelper Members topic.

Public Static Methods

CurrencyToString

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CurrencyHelper Class | PowerLanguage.Function Namespace


CurrencyHelper.CurrencyToString Method

public static string CurrencyToString(
int currency
);

See Also

CurrencyHelper Class | PowerLanguage.Function Namespace


DirMovement Class

For a list of all members of this type, see DirMovement Members .

System.Object
CStudyControl
FunctionObject<Boolean>
FunctionSeries<Boolean>
DirMovement

[DefaultMember(MemberName="Item")]
public sealed class DirMovement : FunctionSeries<bool>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

DirMovement Members | PowerLanguage.Function Namespace


DirMovement Members

DirMovement overview

Public Instance Constructors

DirMovement Overloaded. Initializes a new instance of the DirMovement class.

Public Instance Properties

ADX |
ADXR |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DMI |
DMIMinus |
DMIPlus |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
PriceC |
PriceH |
PriceL |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
Volty |
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

DirMovement Class | PowerLanguage.Function Namespace


DirMovement Constructor

Overload List

public DirMovement(CStudyControl)

public DirMovement(CStudyControl,int)

See Also

DirMovement Class | PowerLanguage.Function Namespace


DirMovement Constructor

DirMovement(
CStudyControl _master
);

See Also

DirMovement Class | PowerLanguage.Function Namespace | DirMovement Constructor Overload List


DirMovement Constructor

DirMovement(
CStudyControl _master,
int _data_stream
);

See Also

DirMovement Class | PowerLanguage.Function Namespace | DirMovement Constructor Overload List


DirMovement Properties

The properties of the DirMovement class are listed below. For a complete list of DirMovement class members, see the DirMovement Members topic.

Public Instance Properties

ADX |
ADXR |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DMI |
DMIMinus |
DMIPlus |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
Length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
PriceC |
PriceH |
PriceL |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
Volty |
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

DirMovement Class | PowerLanguage.Function Namespace


ADX Property

PowerLanguage.NET Help

DirMovement.ADX Property

public ISeries<double> ADX { public get; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


ADXR Property

PowerLanguage.NET Help

DirMovement.ADXR Property

public ISeries<double> ADXR { public get; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


DMI Property

PowerLanguage.NET Help

DirMovement.DMI Property

public ISeries<double> DMI { public get; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


DMIMinus Property

PowerLanguage.NET Help

DirMovement.DMIMinus Property

public ISeries<double> DMIMinus { public get; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


DMIPlus Property

PowerLanguage.NET Help

DirMovement.DMIPlus Property

public ISeries<double> DMIPlus { public get; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


Length Property

PowerLanguage.NET Help

DirMovement.Length Property

public int Length { public get; public set; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


PriceC Property

PowerLanguage.NET Help

DirMovement.PriceC Property

public ISeries<double> PriceC { public get; public set; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


PriceH Property

PowerLanguage.NET Help

DirMovement.PriceH Property

public ISeries<double> PriceH { public get; public set; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


PriceL Property

PowerLanguage.NET Help

DirMovement.PriceL Property

public ISeries<double> PriceL { public get; public set; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


Volty Property

PowerLanguage.NET Help

DirMovement.Volty Property

public ISeries<double> Volty { public get; }

See Also

DirMovement Class | PowerLanguage.Function Namespace


DirMovement Methods

The methods of the DirMovement class are listed below. For a complete list of DirMovement class members, see the DirMovement Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

DirMovement Class | PowerLanguage.Function Namespace


DirMovement.CalcBar Method

protected override bool CalcBar();

See Also

DirMovement Class | PowerLanguage.Function Namespace


DirMovement.Create Method

protected override void Create();

See Also

DirMovement Class | PowerLanguage.Function Namespace


DirMovement.StartCalc Method

protected override void StartCalc();

See Also

DirMovement Class | PowerLanguage.Function Namespace


draw_DOM_level Class

For a list of all members of this type, see draw_DOM_level Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
draw_DOM_level

[DefaultMember(MemberName="Item")]
public class draw_DOM_level : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

draw_DOM_level Members | PowerLanguage.Function Namespace


draw_DOM_level Members

draw_DOM_level overview

Public Instance Constructors

draw_DOM_level Constructor

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
Data |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
From |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
maxsize |
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
To |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


draw_DOM_level Constructor

draw_DOM_level(
CStudyControl ctx
);

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


draw_DOM_level Properties

The properties of the draw_DOM_level class are listed below. For a complete list of draw_DOM_level class members, see the draw_DOM_level Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
Data |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
From |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
maxsize |
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
To |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


Data Property

PowerLanguage.NET Help

draw_DOM_level.Data Property

public ISeries<DOMPrice> Data { public get; public set; }

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


From Property

PowerLanguage.NET Help

draw_DOM_level.From Property

public Color From { public get; public set; }

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


maxsize Property

PowerLanguage.NET Help

draw_DOM_level.maxsize Property

public ISeries<double> maxsize { public get; public set; }

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


To Property

PowerLanguage.NET Help

draw_DOM_level.To Property

public Color To { public get; public set; }

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


draw_DOM_level Methods

The methods of the draw_DOM_level class are listed below. For a complete list of draw_DOM_level class members, see the draw_DOM_level Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


draw_DOM_level.CalcBar Method

protected override double CalcBar();

See Also

draw_DOM_level Class | PowerLanguage.Function Namespace


EaseOfMovement Class

For a list of all members of this type, see EaseOfMovement Members .

System.Object
EaseOfMovement

[Extension]
public static class EaseOfMovement

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

EaseOfMovement Members | PowerLanguage.Function Namespace


EaseOfMovement Members

EaseOfMovement overview

Public Static Methods

CalcEaseOfMovement
CalcEaseOfMovementSeries
TrueVolume

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

EaseOfMovement Class | PowerLanguage.Function Namespace


EaseOfMovement Methods

The methods of the EaseOfMovement class are listed below. For a complete list of EaseOfMovement class members, see the EaseOfMovement Members topic.

Public Static Methods

CalcEaseOfMovement
CalcEaseOfMovementSeries
TrueVolume

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

EaseOfMovement Class | PowerLanguage.Function Namespace


EaseOfMovement.CalcEaseOfMovement Method

[Extension]
public static double CalcEaseOfMovement(
this IInstrument Bars
);

See Also

EaseOfMovement Class | PowerLanguage.Function Namespace


EaseOfMovement.CalcEaseOfMovementSeries Method

[Extension]
public static ISeries<double> CalcEaseOfMovementSeries(
this IInstrument Bars
);

See Also

EaseOfMovement Class | PowerLanguage.Function Namespace


EaseOfMovement.TrueVolume Method

[Extension]
public static ISeries<double> TrueVolume(
this IInstrument Bars
);

See Also

EaseOfMovement Class | PowerLanguage.Function Namespace


EntriesToday Class

For a list of all members of this type, see EntriesToday Members .

System.Object
EntriesToday

[Extension]
public static class EntriesToday

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

EntriesToday Members | PowerLanguage.Function Namespace


EntriesToday Members

EntriesToday overview

Public Static Methods

CalcEntriesToday

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

EntriesToday Class | PowerLanguage.Function Namespace


EntriesToday Methods

The methods of the EntriesToday class are listed below. For a complete list of EntriesToday class members, see the EntriesToday Members topic.

Public Static Methods

CalcEntriesToday

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

EntriesToday Class | PowerLanguage.Function Namespace


EntriesToday.CalcEntriesToday Method

[Extension]
public static int CalcEntriesToday(
this IStrategy _this,
this DateTime targetdate
);

See Also

EntriesToday Class | PowerLanguage.Function Namespace


ExitsToday Class

For a list of all members of this type, see ExitsToday Members .

System.Object
ExitsToday

[Extension]
public static class ExitsToday

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ExitsToday Members | PowerLanguage.Function Namespace


ExitsToday Members

ExitsToday overview

Public Static Methods

CalcExitsToday

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ExitsToday Class | PowerLanguage.Function Namespace


ExitsToday Methods

The methods of the ExitsToday class are listed below. For a complete list of ExitsToday class members, see the ExitsToday Members topic.

Public Static Methods

CalcExitsToday

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

ExitsToday Class | PowerLanguage.Function Namespace


ExitsToday.CalcExitsToday Method

[Extension]
public static int CalcExitsToday(
this IStrategy _this,
this DateTime targetdate
);

See Also

ExitsToday Class | PowerLanguage.Function Namespace


ExtremesFC Class

For a list of all members of this type, see ExtremesFC Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
ExtremesFC

[DefaultMember(MemberName="Item")]
public class ExtremesFC : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ExtremesFC Members | PowerLanguage.Function Namespace


ExtremesFC Members

ExtremesFC overview

Public Instance Constructors

ExtremesFC Overloaded. Initializes a new instance of the ExtremesFC class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
hilo |
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oextremebarraw |
oextremeval |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


ExtremesFC Constructor

Overload List

public ExtremesFC(CStudyControl)

public ExtremesFC(CStudyControl,int)

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


ExtremesFC Constructor

ExtremesFC(
CStudyControl ctx
);

See Also

ExtremesFC Class | PowerLanguage.Function Namespace | ExtremesFC Constructor Overload List


ExtremesFC Constructor

ExtremesFC(
CStudyControl ctx,
int data_stream
);

See Also

ExtremesFC Class | PowerLanguage.Function Namespace | ExtremesFC Constructor Overload List


ExtremesFC Properties

The properties of the ExtremesFC class are listed below. For a complete list of ExtremesFC class members, see the ExtremesFC Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
hilo |
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oextremebarraw |
oextremeval |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


hilo Property

PowerLanguage.NET Help

ExtremesFC.hilo Property

public int hilo { public get; public set; }

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

ExtremesFC.length Property

public int length { public get; public set; }

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


oextremebarraw Property

PowerLanguage.NET Help

ExtremesFC.oextremebarraw Property

public IVar<int> oextremebarraw { public get; public set; }

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


oextremeval Property

PowerLanguage.NET Help

ExtremesFC.oextremeval Property

public IVar<double> oextremeval { public get; public set; }

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

ExtremesFC.price Property

public ISeries<double> price { public get; public set; }

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


ExtremesFC Methods

The methods of the ExtremesFC class are listed below. For a complete list of ExtremesFC class members, see the ExtremesFC Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


ExtremesFC.CalcBar Method

protected override double CalcBar();

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


ExtremesFC.Create Method

protected override void Create();

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


ExtremesFC.StartCalc Method

protected override void StartCalc();

See Also

ExtremesFC Class | PowerLanguage.Function Namespace


FastK Class

For a list of all members of this type, see FastK Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
FastK

[DefaultMember(MemberName="Item")]
public class FastK : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

FastK Members | PowerLanguage.Function Namespace


FastK Members

FastK overview

Public Instance Constructors

FastK Overloaded. Initializes a new instance of the FastK class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

FastK Class | PowerLanguage.Function Namespace


FastK Constructor

Overload List

public FastK(CStudyControl)

public FastK(CStudyControl,int)

See Also

FastK Class | PowerLanguage.Function Namespace


FastK Constructor

FastK(
CStudyControl ctx
);

See Also

FastK Class | PowerLanguage.Function Namespace | FastK Constructor Overload List


FastK Constructor

FastK(
CStudyControl ctx,
int data_stream
);

See Also

FastK Class | PowerLanguage.Function Namespace | FastK Constructor Overload List


FastK Properties

The properties of the FastK class are listed below. For a complete list of FastK class members, see the FastK Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

FastK Class | PowerLanguage.Function Namespace


stochlength Property

PowerLanguage.NET Help

FastK.stochlength Property

public int stochlength { public get; public set; }

See Also

FastK Class | PowerLanguage.Function Namespace


FastK Methods

The methods of the FastK class are listed below. For a complete list of FastK class members, see the FastK Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

FastK Class | PowerLanguage.Function Namespace


FastK.CalcBar Method

protected override double CalcBar();

See Also

FastK Class | PowerLanguage.Function Namespace


FastK.Create Method

protected override void Create();

See Also

FastK Class | PowerLanguage.Function Namespace


FastK.StartCalc Method

protected override void StartCalc();

See Also

FastK Class | PowerLanguage.Function Namespace


FastKCustom Class

For a list of all members of this type, see FastKCustom Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
FastKCustom

[DefaultMember(MemberName="Item")]
public class FastKCustom : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

FastKCustom Members | PowerLanguage.Function Namespace


FastKCustom Members

FastKCustom overview

Public Instance Constructors

FastKCustom Overloaded. Initializes a new instance of the FastKCustom class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
dataseries |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FastKCustom Class | PowerLanguage.Function Namespace


FastKCustom Constructor

Overload List

public FastKCustom(CStudyControl)

public FastKCustom(CStudyControl,int)

See Also

FastKCustom Class | PowerLanguage.Function Namespace


FastKCustom Constructor

FastKCustom(
CStudyControl ctx
);

See Also

FastKCustom Class | PowerLanguage.Function Namespace | FastKCustom Constructor Overload List


FastKCustom Constructor

FastKCustom(
CStudyControl ctx,
int data_stream
);

See Also

FastKCustom Class | PowerLanguage.Function Namespace | FastKCustom Constructor Overload List


FastKCustom Properties

The properties of the FastKCustom class are listed below. For a complete list of FastKCustom class members, see the FastKCustom Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
dataseries |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

FastKCustom Class | PowerLanguage.Function Namespace


dataseries Property

PowerLanguage.NET Help

FastKCustom.dataseries Property

public ISeries<double> dataseries { public set; }

See Also

FastKCustom Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

FastKCustom.length Property

public int length { public get; public set; }

See Also

FastKCustom Class | PowerLanguage.Function Namespace


pricec Property

PowerLanguage.NET Help

FastKCustom.pricec Property

public ISeries<double> pricec { public get; public set; }

See Also

FastKCustom Class | PowerLanguage.Function Namespace


priceh Property

PowerLanguage.NET Help

FastKCustom.priceh Property

public ISeries<double> priceh { public get; public set; }

See Also

FastKCustom Class | PowerLanguage.Function Namespace


pricel Property

PowerLanguage.NET Help

FastKCustom.pricel Property

public ISeries<double> pricel { public get; public set; }

See Also

FastKCustom Class | PowerLanguage.Function Namespace


FastKCustom Methods

The methods of the FastKCustom class are listed below. For a complete list of FastKCustom class members, see the FastKCustom Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FastKCustom Class | PowerLanguage.Function Namespace


FastKCustom.CalcBar Method

protected override double CalcBar();

See Also

FastKCustom Class | PowerLanguage.Function Namespace


FunctionSeries<T> Class

A series function’s base class. Feature of a series function is that its body is always calculated in the current context of execution (at the currently calculating bar), and the function always keeps its previous values.

For a list of all members of this type, see FunctionSeries<T> Members .

System.Object
CStudyControl
FunctionObject<T>
FunctionSeries<T>
Derived types

[DefaultMember(MemberName="Item")]
public abstract class FunctionSeries<T> : FunctionObject<T>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

FunctionSeries<T> Members | PowerLanguage.Function Namespace


FunctionSeries<T> Members

FunctionSeries<T> overview

Public Instance Constructors

FunctionSeries<T> Overloaded. Initializes a new instance of the FunctionSeries<T> class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace


FunctionSeries`1 Constructor

Initializes a new instance of the FunctionSeries class.

Overload List

Initializes a new instance of the FunctionSeries class.

public FunctionSeries`1(CStudyControl)

Initializes a new instance of the FunctionSeries class.

public FunctionSeries`1(CStudyControl,int)

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace


FunctionSeries<T> Constructor

Initializes a new instance of the FunctionSeries class.

FunctionSeries<T>(
CStudyControl master
);

Parameters

master
Study object which manages this FunctionSimple object.

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace | FunctionSeries<T> Constructor Overload List


FunctionSeries<T> Constructor

Initializes a new instance of the FunctionSeries class.

FunctionSeries<T>(
CStudyControl master,
int dataStream
);

Parameters

master
Study object which manages this FunctionSimple object.
dataStream
This object base data stream number.

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace | FunctionSeries<T> Constructor Overload List


FunctionSeries<T> Properties

The properties of the FunctionSeries<T> class are listed below. For a complete list of FunctionSeries<T> class members, see the FunctionSeries<T> Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace


Item Property

PowerLanguage.NET Help

FunctionSeries`1.Item Property

public T this[
int barsAgo
] { public get; }

Implements

ISeries<T>.Item

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace


FunctionSeries<T> Methods

The methods of the FunctionSeries<T> class are listed below. For a complete list of FunctionSeries<T> class members, see the FunctionSeries<T> Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace


FunctionSeries<T>.Dispose Method

protected override void FunctionSeries(
bool A_0
);

See Also

FunctionSeries<T> Class | PowerLanguage.Function Namespace


FunctionSimple<T> Class

Simple function’s base class. Its peculiarity is that it doesn’t keep the history of its values, but rather calculates them each time in the context of calling an execution (on the bar, shifted relative to the current one for a specified number of bars).

For a list of all members of this type, see FunctionSimple<T> Members .

System.Object
CStudyControl
FunctionObject<T>
FunctionSimple<T>
Derived types

[DefaultMember(MemberName="Item")]
public abstract class FunctionSimple<T> : FunctionObject<T>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

FunctionSimple<T> Members | PowerLanguage.Function Namespace


FunctionSimple<T> Members

FunctionSimple<T> overview

Public Instance Constructors

FunctionSimple<T> Overloaded. Initializes a new instance of the FunctionSimple<T> class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace


FunctionSimple`1 Constructor

Initializes a new instance of the FunctionSimple class.

Overload List

Initializes a new instance of the FunctionSimple class.

public FunctionSimple`1(CStudyControl)

Initializes a new instance of the FunctionSimple class.

public FunctionSimple`1(CStudyControl,int)

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace


FunctionSimple<T> Constructor

Initializes a new instance of the FunctionSimple class.

FunctionSimple<T>(
CStudyControl master
);

Parameters

master
Study object which manages this FunctionSimple object.

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace | FunctionSimple<T> Constructor Overload List


FunctionSimple<T> Constructor

Initializes a new instance of the FunctionSimple class.

FunctionSimple<T>(
CStudyControl master,
int dataStream
);

Parameters

master
Study object which manages this FunctionSimple object.
dataStream
This object base data stream number.

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace | FunctionSimple<T> Constructor Overload List


FunctionSimple<T> Properties

The properties of the FunctionSimple<T> class are listed below. For a complete list of FunctionSimple<T> class members, see the FunctionSimple<T> Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace


Item Property

PowerLanguage.NET Help

FunctionSimple`1.Item Property

public T this[
int barsAgo
] { public get; }

Implements

ISeries<T>.Item

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace


FunctionSimple<T> Methods

The methods of the FunctionSimple<T> class are listed below. For a complete list of FunctionSimple<T> class members, see the FunctionSimple<T> Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace


FunctionSimple<T>.Dispose Method

protected override void FunctionSimple(
bool A_0
);

See Also

FunctionSimple<T> Class | PowerLanguage.Function Namespace


HighD Class

For a list of all members of this type, see HighD Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
HighD

[DefaultMember(MemberName="Item")]
public class HighD : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

HighD Members | PowerLanguage.Function Namespace


HighD Members

HighD overview

Public Instance Constructors

HighD Overloaded. Initializes a new instance of the HighD class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HighD Class | PowerLanguage.Function Namespace


HighD Constructor

Overload List

public HighD(CStudyControl)

public HighD(CStudyControl,int)

See Also

HighD Class | PowerLanguage.Function Namespace


HighD Constructor

HighD(
CStudyControl ctx
);

See Also

HighD Class | PowerLanguage.Function Namespace | HighD Constructor Overload List


HighD Constructor

HighD(
CStudyControl ctx,
int data_stream
);

See Also

HighD Class | PowerLanguage.Function Namespace | HighD Constructor Overload List


HighD Properties

The properties of the HighD class are listed below. For a complete list of HighD class members, see the HighD Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

HighD Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

HighD.periodsago Property

public int periodsago { public get; public set; }

See Also

HighD Class | PowerLanguage.Function Namespace


HighD Methods

The methods of the HighD class are listed below. For a complete list of HighD class members, see the HighD Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HighD Class | PowerLanguage.Function Namespace


HighD.CalcBar Method

protected override double CalcBar();

See Also

HighD Class | PowerLanguage.Function Namespace


HighD.Create Method

protected override void Create();

See Also

HighD Class | PowerLanguage.Function Namespace


HighD.StartCalc Method

protected override void StartCalc();

See Also

HighD Class | PowerLanguage.Function Namespace


HighestFC Class

For a list of all members of this type, see HighestFC Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
HighestFC

[DefaultMember(MemberName="Item")]
public class HighestFC : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

HighestFC Members | PowerLanguage.Function Namespace


HighestFC Members

HighestFC overview

Public Instance Constructors

HighestFC Overloaded. Initializes a new instance of the HighestFC class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
len |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricevalue |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighestFC Constructor

Overload List

public HighestFC(CStudyControl)

public HighestFC(CStudyControl,int)

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighestFC Constructor

HighestFC(
CStudyControl ctx
);

See Also

HighestFC Class | PowerLanguage.Function Namespace | HighestFC Constructor Overload List


HighestFC Constructor

HighestFC(
CStudyControl ctx,
int data_stream
);

See Also

HighestFC Class | PowerLanguage.Function Namespace | HighestFC Constructor Overload List


HighestFC Properties

The properties of the HighestFC class are listed below. For a complete list of HighestFC class members, see the HighestFC Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
len |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricevalue |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

HighestFC Class | PowerLanguage.Function Namespace


len Property

PowerLanguage.NET Help

HighestFC.len Property

public int len { public get; public set; }

See Also

HighestFC Class | PowerLanguage.Function Namespace


pricevalue Property

PowerLanguage.NET Help

HighestFC.pricevalue Property

public ISeries<double> pricevalue { public get; public set; }

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighestFC Methods

The methods of the HighestFC class are listed below. For a complete list of HighestFC class members, see the HighestFC Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighestFC.CalcBar Method

protected override double CalcBar();

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighestFC.Create Method

protected override void Create();

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighestFC.StartCalc Method

protected override void StartCalc();

See Also

HighestFC Class | PowerLanguage.Function Namespace


HighS Class

For a list of all members of this type, see HighS Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
HighS

[DefaultMember(MemberName="Item")]
public class HighS : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

HighS Members | PowerLanguage.Function Namespace


HighS Members

HighS overview

Public Instance Constructors

HighS Overloaded. Initializes a new instance of the HighS class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HighS Class | PowerLanguage.Function Namespace


HighS Constructor

Overload List

public HighS(CStudyControl)

public HighS(CStudyControl,int)

See Also

HighS Class | PowerLanguage.Function Namespace


HighS Constructor

HighS(
CStudyControl ctx
);

See Also

HighS Class | PowerLanguage.Function Namespace | HighS Constructor Overload List


HighS Constructor

HighS(
CStudyControl ctx,
int data_stream
);

See Also

HighS Class | PowerLanguage.Function Namespace | HighS Constructor Overload List


HighS Properties

The properties of the HighS class are listed below. For a complete list of HighS class members, see the HighS Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

HighS Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

HighS.periodsago Property

public int periodsago { public get; public set; }

See Also

HighS Class | PowerLanguage.Function Namespace


HighS Methods

The methods of the HighS class are listed below. For a complete list of HighS class members, see the HighS Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HighS Class | PowerLanguage.Function Namespace


HighS.CalcBar Method

protected override double CalcBar();

See Also

HighS Class | PowerLanguage.Function Namespace


HighS.Create Method

protected override void Create();

See Also

HighS Class | PowerLanguage.Function Namespace


HighS.StartCalc Method

protected override void StartCalc();

See Also

HighS Class | PowerLanguage.Function Namespace


HPI Class

For a list of all members of this type, see HPI Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
HPI

[DefaultMember(MemberName="Item")]
public class HPI : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

HPI Members | PowerLanguage.Function Namespace


HPI Members

HPI overview

Public Instance Constructors

HPI Overloaded. Initializes a new instance of the HPI class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
onecent |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
smfactor |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HPI Class | PowerLanguage.Function Namespace


HPI Constructor

Overload List

public HPI(CStudyControl)

public HPI(CStudyControl,int)

See Also

HPI Class | PowerLanguage.Function Namespace


HPI Constructor

HPI(
CStudyControl ctx
);

See Also

HPI Class | PowerLanguage.Function Namespace | HPI Constructor Overload List


HPI Constructor

HPI(
CStudyControl ctx,
int data_stream
);

See Also

HPI Class | PowerLanguage.Function Namespace | HPI Constructor Overload List


HPI Properties

The properties of the HPI class are listed below. For a complete list of HPI class members, see the HPI Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
onecent |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
smfactor |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

HPI Class | PowerLanguage.Function Namespace


onecent Property

PowerLanguage.NET Help

HPI.onecent Property

public double onecent { public get; public set; }

See Also

HPI Class | PowerLanguage.Function Namespace


smfactor Property

PowerLanguage.NET Help

HPI.smfactor Property

public double smfactor { public get; public set; }

See Also

HPI Class | PowerLanguage.Function Namespace


HPI Methods

The methods of the HPI class are listed below. For a complete list of HPI class members, see the HPI Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HPI Class | PowerLanguage.Function Namespace


HPI.CalcBar Method

protected override double CalcBar();

See Also

HPI Class | PowerLanguage.Function Namespace


HPI.Create Method

protected override void Create();

See Also

HPI Class | PowerLanguage.Function Namespace


HPI.StartCalc Method

protected override void StartCalc();

See Also

HPI Class | PowerLanguage.Function Namespace


HullMovAvg Class

For a list of all members of this type, see HullMovAvg Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
HullMovAvg

[DefaultMember(MemberName="Item")]
public class HullMovAvg : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

HullMovAvg Members | PowerLanguage.Function Namespace


HullMovAvg Members

HullMovAvg overview

Public Instance Constructors

HullMovAvg Overloaded. Initializes a new instance of the HullMovAvg class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

Private Instance Properties

length
price

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


HullMovAvg Constructor

Overload List

public HullMovAvg(CStudyControl)

public HullMovAvg(CStudyControl,int)

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


HullMovAvg Constructor

HullMovAvg(
CStudyControl _master
);

See Also

HullMovAvg Class | PowerLanguage.Function Namespace | HullMovAvg Constructor Overload List


HullMovAvg Constructor

HullMovAvg(
CStudyControl _master,
int _ds
);

See Also

HullMovAvg Class | PowerLanguage.Function Namespace | HullMovAvg Constructor Overload List


HullMovAvg Properties

The properties of the HullMovAvg class are listed below. For a complete list of HullMovAvg class members, see the HullMovAvg Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Private Instance Properties

length
price

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

HullMovAvg.length Property

private int length { private get; public set; }

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

HullMovAvg.price Property

private ISeries<double> price { private get; public set; }

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


HullMovAvg Methods

The methods of the HullMovAvg class are listed below. For a complete list of HullMovAvg class members, see the HullMovAvg Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


HullMovAvg.CalcBar Method

protected override double CalcBar();

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


HullMovAvg.Create Method

protected override void Create();

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


HullMovAvg.StartCalc Method

protected override void StartCalc();

See Also

HullMovAvg Class | PowerLanguage.Function Namespace


LinearReg Class

For a list of all members of this type, see LinearReg Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
LinearReg

[DefaultMember(MemberName="Item")]
public class LinearReg : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

LinearReg Members | PowerLanguage.Function Namespace


LinearReg Members

LinearReg overview

Public Instance Constructors

LinearReg Overloaded. Initializes a new instance of the LinearReg class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
olrangle |
olrintercept |
olrslope |
olrvalue |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
tgtbar |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

LinearReg Class | PowerLanguage.Function Namespace


LinearReg Constructor

Overload List

public LinearReg(CStudyControl)

public LinearReg(CStudyControl,int)

See Also

LinearReg Class | PowerLanguage.Function Namespace


LinearReg Constructor

LinearReg(
CStudyControl ctx
);

See Also

LinearReg Class | PowerLanguage.Function Namespace | LinearReg Constructor Overload List


LinearReg Constructor

LinearReg(
CStudyControl ctx,
int data_stream
);

See Also

LinearReg Class | PowerLanguage.Function Namespace | LinearReg Constructor Overload List


LinearReg Properties

The properties of the LinearReg class are listed below. For a complete list of LinearReg class members, see the LinearReg Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
olrangle |
olrintercept |
olrslope |
olrvalue |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
tgtbar |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

LinearReg Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

LinearReg.length Property

public int length { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


olrangle Property

PowerLanguage.NET Help

LinearReg.olrangle Property

public double olrangle { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


olrintercept Property

PowerLanguage.NET Help

LinearReg.olrintercept Property

public double olrintercept { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


olrslope Property

PowerLanguage.NET Help

LinearReg.olrslope Property

public double olrslope { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


olrvalue Property

PowerLanguage.NET Help

LinearReg.olrvalue Property

public double olrvalue { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

LinearReg.price Property

public ISeries<double> price { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


tgtbar Property

PowerLanguage.NET Help

LinearReg.tgtbar Property

public int tgtbar { public get; public set; }

See Also

LinearReg Class | PowerLanguage.Function Namespace


LinearReg Methods

The methods of the LinearReg class are listed below. For a complete list of LinearReg class members, see the LinearReg Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

LinearReg Class | PowerLanguage.Function Namespace


LinearReg.CalcBar Method

protected override int CalcBar();

See Also

LinearReg Class | PowerLanguage.Function Namespace


LinearRegValue Class

For a list of all members of this type, see LinearRegValue Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
LinearRegValue

[DefaultMember(MemberName="Item")]
public class LinearRegValue : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

LinearRegValue Members | PowerLanguage.Function Namespace


LinearRegValue Members

LinearRegValue overview

Public Instance Constructors

LinearRegValue Overloaded. Initializes a new instance of the LinearRegValue class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
tgtbar |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LinearRegValue Constructor

Overload List

public LinearRegValue(CStudyControl)

public LinearRegValue(CStudyControl,int)

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LinearRegValue Constructor

LinearRegValue(
CStudyControl ctx
);

See Also

LinearRegValue Class | PowerLanguage.Function Namespace | LinearRegValue Constructor Overload List


LinearRegValue Constructor

LinearRegValue(
CStudyControl ctx,
int data_stream
);

See Also

LinearRegValue Class | PowerLanguage.Function Namespace | LinearRegValue Constructor Overload List


LinearRegValue Properties

The properties of the LinearRegValue class are listed below. For a complete list of LinearRegValue class members, see the LinearRegValue Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
tgtbar |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

LinearRegValue.length Property

public int length { public get; public set; }

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

LinearRegValue.price Property

public ISeries<double> price { public get; public set; }

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


tgtbar Property

PowerLanguage.NET Help

LinearRegValue.tgtbar Property

public int tgtbar { public get; public set; }

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LinearRegValue Methods

The methods of the LinearRegValue class are listed below. For a complete list of LinearRegValue class members, see the LinearRegValue Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LinearRegValue.CalcBar Method

protected override double CalcBar();

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LinearRegValue.Create Method

protected override void Create();

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LinearRegValue.StartCalc Method

protected override void StartCalc();

See Also

LinearRegValue Class | PowerLanguage.Function Namespace


LowD Class

For a list of all members of this type, see LowD Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
LowD

[DefaultMember(MemberName="Item")]
public class LowD : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

LowD Members | PowerLanguage.Function Namespace


LowD Members

LowD overview

Public Instance Constructors

LowD Overloaded. Initializes a new instance of the LowD class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LowD Class | PowerLanguage.Function Namespace


LowD Constructor

Overload List

public LowD(CStudyControl)

public LowD(CStudyControl,int)

See Also

LowD Class | PowerLanguage.Function Namespace


LowD Constructor

LowD(
CStudyControl ctx
);

See Also

LowD Class | PowerLanguage.Function Namespace | LowD Constructor Overload List


LowD Constructor

LowD(
CStudyControl ctx,
int data_stream
);

See Also

LowD Class | PowerLanguage.Function Namespace | LowD Constructor Overload List


LowD Properties

The properties of the LowD class are listed below. For a complete list of LowD class members, see the LowD Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

LowD Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

LowD.periodsago Property

public int periodsago { public get; public set; }

See Also

LowD Class | PowerLanguage.Function Namespace


LowD Methods

The methods of the LowD class are listed below. For a complete list of LowD class members, see the LowD Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LowD Class | PowerLanguage.Function Namespace


LowD.CalcBar Method

protected override double CalcBar();

See Also

LowD Class | PowerLanguage.Function Namespace


LowD.Create Method

protected override void Create();

See Also

LowD Class | PowerLanguage.Function Namespace


LowD.StartCalc Method

protected override void StartCalc();

See Also

LowD Class | PowerLanguage.Function Namespace


LowestFC Class

For a list of all members of this type, see LowestFC Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
LowestFC

[DefaultMember(MemberName="Item")]
public class LowestFC : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

LowestFC Members | PowerLanguage.Function Namespace


LowestFC Members

LowestFC overview

Public Instance Constructors

LowestFC Overloaded. Initializes a new instance of the LowestFC class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
len |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricevalue |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowestFC Constructor

Overload List

public LowestFC(CStudyControl)

public LowestFC(CStudyControl,int)

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowestFC Constructor

LowestFC(
CStudyControl ctx
);

See Also

LowestFC Class | PowerLanguage.Function Namespace | LowestFC Constructor Overload List


LowestFC Constructor

LowestFC(
CStudyControl ctx,
int data_stream
);

See Also

LowestFC Class | PowerLanguage.Function Namespace | LowestFC Constructor Overload List


LowestFC Properties

The properties of the LowestFC class are listed below. For a complete list of LowestFC class members, see the LowestFC Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
len |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricevalue |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

LowestFC Class | PowerLanguage.Function Namespace


len Property

PowerLanguage.NET Help

LowestFC.len Property

public int len { public get; public set; }

See Also

LowestFC Class | PowerLanguage.Function Namespace


pricevalue Property

PowerLanguage.NET Help

LowestFC.pricevalue Property

public ISeries<double> pricevalue { public get; public set; }

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowestFC Methods

The methods of the LowestFC class are listed below. For a complete list of LowestFC class members, see the LowestFC Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowestFC.CalcBar Method

protected override double CalcBar();

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowestFC.Create Method

protected override void Create();

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowestFC.StartCalc Method

protected override void StartCalc();

See Also

LowestFC Class | PowerLanguage.Function Namespace


LowS Class

For a list of all members of this type, see LowS Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
LowS

[DefaultMember(MemberName="Item")]
public class LowS : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

LowS Members | PowerLanguage.Function Namespace


LowS Members

LowS overview

Public Instance Constructors

LowS Overloaded. Initializes a new instance of the LowS class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LowS Class | PowerLanguage.Function Namespace


LowS Constructor

Overload List

public LowS(CStudyControl)

public LowS(CStudyControl,int)

See Also

LowS Class | PowerLanguage.Function Namespace


LowS Constructor

LowS(
CStudyControl ctx
);

See Also

LowS Class | PowerLanguage.Function Namespace | LowS Constructor Overload List


LowS Constructor

LowS(
CStudyControl ctx,
int data_stream
);

See Also

LowS Class | PowerLanguage.Function Namespace | LowS Constructor Overload List


LowS Properties

The properties of the LowS class are listed below. For a complete list of LowS class members, see the LowS Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

LowS Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

LowS.periodsago Property

public int periodsago { public get; public set; }

See Also

LowS Class | PowerLanguage.Function Namespace


LowS Methods

The methods of the LowS class are listed below. For a complete list of LowS class members, see the LowS Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

LowS Class | PowerLanguage.Function Namespace


LowS.CalcBar Method

protected override double CalcBar();

See Also

LowS Class | PowerLanguage.Function Namespace


LowS.Create Method

protected override void Create();

See Also

LowS Class | PowerLanguage.Function Namespace


LowS.StartCalc Method

protected override void StartCalc();

See Also

LowS Class | PowerLanguage.Function Namespace


LWAccDis Class

For a list of all members of this type, see LWAccDis Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
LWAccDis

[DefaultMember(MemberName="Item")]
public class LWAccDis : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

LWAccDis Members | PowerLanguage.Function Namespace


LWAccDis Members

LWAccDis overview

Public Instance Constructors

LWAccDis Overloaded. Initializes a new instance of the LWAccDis class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

LWAccDis Class | PowerLanguage.Function Namespace


LWAccDis Constructor

Overload List

public LWAccDis(CStudyControl)

public LWAccDis(CStudyControl,int)

See Also

LWAccDis Class | PowerLanguage.Function Namespace


LWAccDis Constructor

LWAccDis(
CStudyControl ctx
);

See Also

LWAccDis Class | PowerLanguage.Function Namespace | LWAccDis Constructor Overload List


LWAccDis Constructor

LWAccDis(
CStudyControl ctx,
int data_stream
);

See Also

LWAccDis Class | PowerLanguage.Function Namespace | LWAccDis Constructor Overload List


LWAccDis Methods

The methods of the LWAccDis class are listed below. For a complete list of LWAccDis class members, see the LWAccDis Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

LWAccDis Class | PowerLanguage.Function Namespace


LWAccDis.CalcBar Method

protected override double CalcBar();

See Also

LWAccDis Class | PowerLanguage.Function Namespace


MACD Class

For a list of all members of this type, see MACD Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
MACD

[DefaultMember(MemberName="Item")]
public sealed class MACD : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

MACD Members | PowerLanguage.Function Namespace


MACD Members

MACD overview

Public Instance Constructors

MACD Overloaded. Initializes a new instance of the MACD class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

Private Instance Properties

FastLength
Price
SlowLength

See Also

MACD Class | PowerLanguage.Function Namespace


MACD Constructor

Overload List

public MACD(CStudyControl)

public MACD(CStudyControl,int)

See Also

MACD Class | PowerLanguage.Function Namespace


MACD Constructor

MACD(
CStudyControl _master
);

See Also

MACD Class | PowerLanguage.Function Namespace | MACD Constructor Overload List


MACD Constructor

MACD(
CStudyControl _master,
int _ds
);

See Also

MACD Class | PowerLanguage.Function Namespace | MACD Constructor Overload List


MACD Properties

The properties of the MACD class are listed below. For a complete list of MACD class members, see the MACD Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Private Instance Properties

FastLength
Price
SlowLength

See Also

MACD Class | PowerLanguage.Function Namespace


FastLength Property

PowerLanguage.NET Help

MACD.FastLength Property

private int FastLength { private get; public set; }

See Also

MACD Class | PowerLanguage.Function Namespace


Price Property

PowerLanguage.NET Help

MACD.Price Property

private ISeries<double> Price { private get; public set; }

See Also

MACD Class | PowerLanguage.Function Namespace


SlowLength Property

PowerLanguage.NET Help

MACD.SlowLength Property

private int SlowLength { private get; public set; }

See Also

MACD Class | PowerLanguage.Function Namespace


MACD Methods

The methods of the MACD class are listed below. For a complete list of MACD class members, see the MACD Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

MACD Class | PowerLanguage.Function Namespace


MACD.CalcBar Method

protected override double CalcBar();

See Also

MACD Class | PowerLanguage.Function Namespace


MACD.Create Method

protected override void Create();

See Also

MACD Class | PowerLanguage.Function Namespace


MACD.StartCalc Method

protected override void StartCalc();

See Also

MACD Class | PowerLanguage.Function Namespace


MassIndex Class

For a list of all members of this type, see MassIndex Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
MassIndex

[DefaultMember(MemberName="Item")]
public class MassIndex : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

MassIndex Members | PowerLanguage.Function Namespace


MassIndex Members

MassIndex overview

Public Instance Constructors

MassIndex Overloaded. Initializes a new instance of the MassIndex class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
smoothinglength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
summationlength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

MassIndex Class | PowerLanguage.Function Namespace


MassIndex Constructor

Overload List

public MassIndex(CStudyControl)

public MassIndex(CStudyControl,int)

See Also

MassIndex Class | PowerLanguage.Function Namespace


MassIndex Constructor

MassIndex(
CStudyControl ctx
);

See Also

MassIndex Class | PowerLanguage.Function Namespace | MassIndex Constructor Overload List


MassIndex Constructor

MassIndex(
CStudyControl ctx,
int data_stream
);

See Also

MassIndex Class | PowerLanguage.Function Namespace | MassIndex Constructor Overload List


MassIndex Properties

The properties of the MassIndex class are listed below. For a complete list of MassIndex class members, see the MassIndex Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
smoothinglength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
summationlength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

MassIndex Class | PowerLanguage.Function Namespace


smoothinglength Property

PowerLanguage.NET Help

MassIndex.smoothinglength Property

public int smoothinglength { public get; public set; }

See Also

MassIndex Class | PowerLanguage.Function Namespace


summationlength Property

PowerLanguage.NET Help

MassIndex.summationlength Property

public int summationlength { public get; public set; }

See Also

MassIndex Class | PowerLanguage.Function Namespace


MassIndex Methods

The methods of the MassIndex class are listed below. For a complete list of MassIndex class members, see the MassIndex Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

MassIndex Class | PowerLanguage.Function Namespace


MassIndex.CalcBar Method

protected override double CalcBar();

See Also

MassIndex Class | PowerLanguage.Function Namespace


MassIndex.Create Method

protected override void Create();

See Also

MassIndex Class | PowerLanguage.Function Namespace


MassIndex.StartCalc Method

protected override void StartCalc();

See Also

MassIndex Class | PowerLanguage.Function Namespace


McClellanOsc Class

For a list of all members of this type, see McClellanOsc Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
McClellanOsc

[DefaultMember(MemberName="Item")]
public class McClellanOsc : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

McClellanOsc Members | PowerLanguage.Function Namespace


McClellanOsc Members

McClellanOsc overview

Public Instance Constructors

McClellanOsc Overloaded. Initializes a new instance of the McClellanOsc class.

Public Instance Properties

advissues |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
decissues |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastlength |
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
slowlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


McClellanOsc Constructor

Overload List

public McClellanOsc(CStudyControl)

public McClellanOsc(CStudyControl,int)

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


McClellanOsc Constructor

McClellanOsc(
CStudyControl ctx
);

See Also

McClellanOsc Class | PowerLanguage.Function Namespace | McClellanOsc Constructor Overload List


McClellanOsc Constructor

McClellanOsc(
CStudyControl ctx,
int data_stream
);

See Also

McClellanOsc Class | PowerLanguage.Function Namespace | McClellanOsc Constructor Overload List


McClellanOsc Properties

The properties of the McClellanOsc class are listed below. For a complete list of McClellanOsc class members, see the McClellanOsc Members topic.

Public Instance Properties

advissues |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
decissues |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastlength |
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
slowlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


advissues Property

PowerLanguage.NET Help

McClellanOsc.advissues Property

public ISeries<double> advissues { public get; public set; }

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


decissues Property

PowerLanguage.NET Help

McClellanOsc.decissues Property

public ISeries<double> decissues { public get; public set; }

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


fastlength Property

PowerLanguage.NET Help

McClellanOsc.fastlength Property

public int fastlength { public get; public set; }

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


slowlength Property

PowerLanguage.NET Help

McClellanOsc.slowlength Property

public int slowlength { public get; public set; }

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


McClellanOsc Methods

The methods of the McClellanOsc class are listed below. For a complete list of McClellanOsc class members, see the McClellanOsc Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


McClellanOsc.CalcBar Method

protected override double CalcBar();

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


McClellanOsc.Create Method

protected override void Create();

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


McClellanOsc.StartCalc Method

protected override void StartCalc();

See Also

McClellanOsc Class | PowerLanguage.Function Namespace


NormGradientColor Class

For a list of all members of this type, see NormGradientColor Members .

System.Object
CStudyControl
FunctionObject<Color>
FunctionSimple<Color>
NormGradientColor

[DefaultMember(MemberName="Item")]
public class NormGradientColor : FunctionSimple<Color>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

NormGradientColor Members | PowerLanguage.Function Namespace


NormGradientColor Members

NormGradientColor overview

Public Instance Constructors

NormGradientColor Overloaded. Initializes a new instance of the NormGradientColor class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
colornormlength |
crosseszero |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
dataseriesvalue |
dncolor |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
upcolor |
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


NormGradientColor Constructor

Overload List

public NormGradientColor(CStudyControl)

public NormGradientColor(CStudyControl,int)

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


NormGradientColor Constructor

NormGradientColor(
CStudyControl ctx
);

See Also

NormGradientColor Class | PowerLanguage.Function Namespace | NormGradientColor Constructor Overload List


NormGradientColor Constructor

NormGradientColor(
CStudyControl ctx,
int data_stream
);

See Also

NormGradientColor Class | PowerLanguage.Function Namespace | NormGradientColor Constructor Overload List


NormGradientColor Properties

The properties of the NormGradientColor class are listed below. For a complete list of NormGradientColor class members, see the NormGradientColor Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
colornormlength |
crosseszero |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
dataseriesvalue |
dncolor |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
upcolor |
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


colornormlength Property

PowerLanguage.NET Help

NormGradientColor.colornormlength Property

public int colornormlength { public get; public set; }

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


crosseszero Property

PowerLanguage.NET Help

NormGradientColor.crosseszero Property

public bool crosseszero { public get; public set; }

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


dataseriesvalue Property

PowerLanguage.NET Help

NormGradientColor.dataseriesvalue Property

public ISeries<double> dataseriesvalue { public get; public set; }

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


dncolor Property

PowerLanguage.NET Help

NormGradientColor.dncolor Property

public Color dncolor { public get; public set; }

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


upcolor Property

PowerLanguage.NET Help

NormGradientColor.upcolor Property

public Color upcolor { public get; public set; }

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


NormGradientColor Methods

The methods of the NormGradientColor class are listed below. For a complete list of NormGradientColor class members, see the NormGradientColor Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


NormGradientColor.CalcBar Method

protected override Color CalcBar();

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


NormGradientColor.Create Method

protected override void Create();

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


NormGradientColor.StartCalc Method

protected override void StartCalc();

See Also

NormGradientColor Class | PowerLanguage.Function Namespace


OBV Class

For a list of all members of this type, see OBV Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
OBV

[DefaultMember(MemberName="Item")]
public class OBV : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

OBV Members | PowerLanguage.Function Namespace


OBV Members

OBV overview

Public Instance Constructors

OBV Overloaded. Initializes a new instance of the OBV class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

OBV Class | PowerLanguage.Function Namespace


OBV Constructor

Overload List

public OBV(CStudyControl)

public OBV(CStudyControl,int)

See Also

OBV Class | PowerLanguage.Function Namespace


OBV Constructor

OBV(
CStudyControl ctx
);

See Also

OBV Class | PowerLanguage.Function Namespace | OBV Constructor Overload List


OBV Constructor

OBV(
CStudyControl ctx,
int data_stream
);

See Also

OBV Class | PowerLanguage.Function Namespace | OBV Constructor Overload List


OBV Methods

The methods of the OBV class are listed below. For a complete list of OBV class members, see the OBV Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

OBV Class | PowerLanguage.Function Namespace


OBV.CalcBar Method

protected override double CalcBar();

See Also

OBV Class | PowerLanguage.Function Namespace


OBV.StartCalc Method

protected override void StartCalc();

See Also

OBV Class | PowerLanguage.Function Namespace


OHLCPeriodsAgo Class

For a list of all members of this type, see OHLCPeriodsAgo Members .

System.Object
CStudyControl
FunctionObject<Boolean>
FunctionSeries<Boolean>
OHLCPeriodsAgo

[DefaultMember(MemberName="Item")]
public class OHLCPeriodsAgo : FunctionSeries<bool>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

OHLCPeriodsAgo Members | PowerLanguage.Function Namespace


OHLCPeriodsAgo Members

OHLCPeriodsAgo overview

Public Instance Constructors

OHLCPeriodsAgo Overloaded. Initializes a new instance of the OHLCPeriodsAgo class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
operiodclose |
operiodhigh |
operiodlow |
operiodopen |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
periodtype |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
UseSessionAsPeriod |
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


OHLCPeriodsAgo Constructor

Overload List

public OHLCPeriodsAgo(CStudyControl)

public OHLCPeriodsAgo(CStudyControl,int)

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


OHLCPeriodsAgo Constructor

OHLCPeriodsAgo(
CStudyControl ctx
);

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace | OHLCPeriodsAgo Constructor Overload List


OHLCPeriodsAgo Constructor

OHLCPeriodsAgo(
CStudyControl ctx,
int dataStream
);

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace | OHLCPeriodsAgo Constructor Overload List


OHLCPeriodsAgo Properties

The properties of the OHLCPeriodsAgo class are listed below. For a complete list of OHLCPeriodsAgo class members, see the OHLCPeriodsAgo Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
operiodclose |
operiodhigh |
operiodlow |
operiodopen |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
periodtype |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
UseSessionAsPeriod |
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


operiodclose Property

PowerLanguage.NET Help

OHLCPeriodsAgo.operiodclose Property

public IVar<double> operiodclose { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


operiodhigh Property

PowerLanguage.NET Help

OHLCPeriodsAgo.operiodhigh Property

public IVar<double> operiodhigh { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


operiodlow Property

PowerLanguage.NET Help

OHLCPeriodsAgo.operiodlow Property

public IVar<double> operiodlow { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


operiodopen Property

PowerLanguage.NET Help

OHLCPeriodsAgo.operiodopen Property

public IVar<double> operiodopen { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

OHLCPeriodsAgo.periodsago Property

public int periodsago { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


periodtype Property

PowerLanguage.NET Help

OHLCPeriodsAgo.periodtype Property

public EResolution periodtype { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


UseSessionAsPeriod Property

PowerLanguage.NET Help

OHLCPeriodsAgo.UseSessionAsPeriod Property

public bool UseSessionAsPeriod { public get; public set; }

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


OHLCPeriodsAgo Methods

The methods of the OHLCPeriodsAgo class are listed below. For a complete list of OHLCPeriodsAgo class members, see the OHLCPeriodsAgo Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


OHLCPeriodsAgo.CalcBar Method

protected override bool CalcBar();

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


OHLCPeriodsAgo.Create Method

protected override void Create();

See Also

OHLCPeriodsAgo Class | PowerLanguage.Function Namespace


OpenD Class

For a list of all members of this type, see OpenD Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
OpenD

[DefaultMember(MemberName="Item")]
public class OpenD : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

OpenD Members | PowerLanguage.Function Namespace


OpenD Members

OpenD overview

Public Instance Constructors

OpenD Overloaded. Initializes a new instance of the OpenD class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenD Constructor

Overload List

public OpenD(CStudyControl)

public OpenD(CStudyControl,int)

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenD Constructor

OpenD(
CStudyControl ctx
);

See Also

OpenD Class | PowerLanguage.Function Namespace | OpenD Constructor Overload List


OpenD Constructor

OpenD(
CStudyControl ctx,
int data_stream
);

See Also

OpenD Class | PowerLanguage.Function Namespace | OpenD Constructor Overload List


OpenD Properties

The properties of the OpenD class are listed below. For a complete list of OpenD class members, see the OpenD Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

OpenD Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

OpenD.periodsago Property

public int periodsago { public get; public set; }

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenD Methods

The methods of the OpenD class are listed below. For a complete list of OpenD class members, see the OpenD Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenD.CalcBar Method

protected override double CalcBar();

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenD.Create Method

protected override void Create();

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenD.StartCalc Method

protected override void StartCalc();

See Also

OpenD Class | PowerLanguage.Function Namespace


OpenS Class

For a list of all members of this type, see OpenS Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
OpenS

[DefaultMember(MemberName="Item")]
public class OpenS : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

OpenS Members | PowerLanguage.Function Namespace


OpenS Members

OpenS overview

Public Instance Constructors

OpenS Overloaded. Initializes a new instance of the OpenS class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

OpenS Class | PowerLanguage.Function Namespace


OpenS Constructor

Overload List

public OpenS(CStudyControl)

public OpenS(CStudyControl,int)

See Also

OpenS Class | PowerLanguage.Function Namespace


OpenS Constructor

OpenS(
CStudyControl ctx
);

See Also

OpenS Class | PowerLanguage.Function Namespace | OpenS Constructor Overload List


OpenS Constructor

OpenS(
CStudyControl ctx,
int data_stream
);

See Also

OpenS Class | PowerLanguage.Function Namespace | OpenS Constructor Overload List


OpenS Properties

The properties of the OpenS class are listed below. For a complete list of OpenS class members, see the OpenS Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
periodsago |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

OpenS Class | PowerLanguage.Function Namespace


periodsago Property

PowerLanguage.NET Help

OpenS.periodsago Property

public int periodsago { public get; public set; }

See Also

OpenS Class | PowerLanguage.Function Namespace


OpenS Methods

The methods of the OpenS class are listed below. For a complete list of OpenS class members, see the OpenS Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

OpenS Class | PowerLanguage.Function Namespace


OpenS.CalcBar Method

protected override double CalcBar();

See Also

OpenS Class | PowerLanguage.Function Namespace


OpenS.Create Method

protected override void Create();

See Also

OpenS Class | PowerLanguage.Function Namespace


OpenS.StartCalc Method

protected override void StartCalc();

See Also

OpenS Class | PowerLanguage.Function Namespace


ParabolicSAR Class

For a list of all members of this type, see ParabolicSAR Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
ParabolicSAR

[DefaultMember(MemberName="Item")]
public class ParabolicSAR : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

ParabolicSAR Members | PowerLanguage.Function Namespace


ParabolicSAR Members

ParabolicSAR overview

Public Instance Constructors

ParabolicSAR Overloaded. Initializes a new instance of the ParabolicSAR class.

Public Instance Properties

aflimit |
afstep |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oparcl |
oparop |
oposition |
otransition |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


ParabolicSAR Constructor

Overload List

public ParabolicSAR(CStudyControl)

public ParabolicSAR(CStudyControl,int)

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


ParabolicSAR Constructor

ParabolicSAR(
CStudyControl ctx
);

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace | ParabolicSAR Constructor Overload List


ParabolicSAR Constructor

ParabolicSAR(
CStudyControl ctx,
int data_stream
);

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace | ParabolicSAR Constructor Overload List


ParabolicSAR Properties

The properties of the ParabolicSAR class are listed below. For a complete list of ParabolicSAR class members, see the ParabolicSAR Members topic.

Public Instance Properties

aflimit |
afstep |
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
oparcl |
oparop |
oposition |
otransition |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


aflimit Property

PowerLanguage.NET Help

ParabolicSAR.aflimit Property

public double aflimit { public get; public set; }

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


afstep Property

PowerLanguage.NET Help

ParabolicSAR.afstep Property

public double afstep { public get; public set; }

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


oparcl Property

PowerLanguage.NET Help

ParabolicSAR.oparcl Property

public IVar<double> oparcl { public get; public set; }

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


oparop Property

PowerLanguage.NET Help

ParabolicSAR.oparop Property

public IVar<double> oparop { public get; public set; }

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


oposition Property

PowerLanguage.NET Help

ParabolicSAR.oposition Property

public IVar<int> oposition { public get; public set; }

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


otransition Property

PowerLanguage.NET Help

ParabolicSAR.otransition Property

public IVar<int> otransition { public get; public set; }

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


ParabolicSAR Methods

The methods of the ParabolicSAR class are listed below. For a complete list of ParabolicSAR class members, see the ParabolicSAR Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


ParabolicSAR.CalcBar Method

protected override double CalcBar();

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


ParabolicSAR.Create Method

protected override void Create();

See Also

ParabolicSAR Class | PowerLanguage.Function Namespace


Pennant Class

For a list of all members of this type, see Pennant Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSeries<Int32>
Pennant

[DefaultMember(MemberName="Item")]
public class Pennant : FunctionSeries<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

Pennant Members | PowerLanguage.Function Namespace


Pennant Members

Pennant overview

Public Instance Constructors

Pennant Overloaded. Initializes a new instance of the Pennant class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
barspast |
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
maxconsolindex |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
otlhiendpr |
otlhistartpr |
otlloendpr |
otllostartpr |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

Pennant Class | PowerLanguage.Function Namespace


Pennant Constructor

Overload List

public Pennant(CStudyControl)

public Pennant(CStudyControl,int)

See Also

Pennant Class | PowerLanguage.Function Namespace


Pennant Constructor

Pennant(
CStudyControl ctx
);

See Also

Pennant Class | PowerLanguage.Function Namespace | Pennant Constructor Overload List


Pennant Constructor

Pennant(
CStudyControl ctx,
int data_stream
);

See Also

Pennant Class | PowerLanguage.Function Namespace | Pennant Constructor Overload List


Pennant Properties

The properties of the Pennant class are listed below. For a complete list of Pennant class members, see the Pennant Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
barspast |
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
maxconsolindex |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
otlhiendpr |
otlhistartpr |
otlloendpr |
otllostartpr |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

Pennant Class | PowerLanguage.Function Namespace


barspast Property

PowerLanguage.NET Help

Pennant.barspast Property

public int barspast { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

Pennant.length Property

public int length { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


maxconsolindex Property

PowerLanguage.NET Help

Pennant.maxconsolindex Property

public double maxconsolindex { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


otlhiendpr Property

PowerLanguage.NET Help

Pennant.otlhiendpr Property

public IVar<double> otlhiendpr { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


otlhistartpr Property

PowerLanguage.NET Help

Pennant.otlhistartpr Property

public IVar<double> otlhistartpr { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


otlloendpr Property

PowerLanguage.NET Help

Pennant.otlloendpr Property

public IVar<double> otlloendpr { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


otllostartpr Property

PowerLanguage.NET Help

Pennant.otllostartpr Property

public IVar<double> otllostartpr { public get; public set; }

See Also

Pennant Class | PowerLanguage.Function Namespace


Pennant Methods

The methods of the Pennant class are listed below. For a complete list of Pennant class members, see the Pennant Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

Pennant Class | PowerLanguage.Function Namespace


Pennant.CalcBar Method

protected override int CalcBar();

See Also

Pennant Class | PowerLanguage.Function Namespace


Pennant.Create Method

protected override void Create();

See Also

Pennant Class | PowerLanguage.Function Namespace


Pennant.StartCalc Method

protected override void StartCalc();

See Also

Pennant Class | PowerLanguage.Function Namespace


PivotHighVS Class

For a list of all members of this type, see PivotHighVS Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
PivotHighVS

[DefaultMember(MemberName="Item")]
public class PivotHighVS : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PivotHighVS Members | PowerLanguage.Function Namespace


PivotHighVS Members

PivotHighVS overview

Public Instance Constructors

PivotHighVS Overloaded. Initializes a new instance of the PivotHighVS class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


PivotHighVS Constructor

Overload List

public PivotHighVS(CStudyControl)

public PivotHighVS(CStudyControl,int)

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


PivotHighVS Constructor

PivotHighVS(
CStudyControl ctx
);

See Also

PivotHighVS Class | PowerLanguage.Function Namespace | PivotHighVS Constructor Overload List


PivotHighVS Constructor

PivotHighVS(
CStudyControl ctx,
int data_stream
);

See Also

PivotHighVS Class | PowerLanguage.Function Namespace | PivotHighVS Constructor Overload List


PivotHighVS Properties

The properties of the PivotHighVS class are listed below. For a complete list of PivotHighVS class members, see the PivotHighVS Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

PivotHighVS.instance Property

public int instance { public get; public set; }

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


leftstrength Property

PowerLanguage.NET Help

PivotHighVS.leftstrength Property

public int leftstrength { public get; public set; }

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

PivotHighVS.length Property

public int length { public get; public set; }

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

PivotHighVS.price Property

public ISeries<double> price { public get; public set; }

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


rightstrength Property

PowerLanguage.NET Help

PivotHighVS.rightstrength Property

public int rightstrength { public get; public set; }

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


PivotHighVS Methods

The methods of the PivotHighVS class are listed below. For a complete list of PivotHighVS class members, see the PivotHighVS Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


PivotHighVS.CalcBar Method

protected override double CalcBar();

See Also

PivotHighVS Class | PowerLanguage.Function Namespace


PivotHighVSBar Class

For a list of all members of this type, see PivotHighVSBar Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
PivotHighVSBar

[DefaultMember(MemberName="Item")]
public class PivotHighVSBar : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PivotHighVSBar Members | PowerLanguage.Function Namespace


PivotHighVSBar Members

PivotHighVSBar overview

Public Instance Constructors

PivotHighVSBar Overloaded. Initializes a new instance of the PivotHighVSBar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


PivotHighVSBar Constructor

Overload List

public PivotHighVSBar(CStudyControl)

public PivotHighVSBar(CStudyControl,int)

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


PivotHighVSBar Constructor

PivotHighVSBar(
CStudyControl ctx
);

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace | PivotHighVSBar Constructor Overload List


PivotHighVSBar Constructor

PivotHighVSBar(
CStudyControl ctx,
int data_stream
);

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace | PivotHighVSBar Constructor Overload List


PivotHighVSBar Properties

The properties of the PivotHighVSBar class are listed below. For a complete list of PivotHighVSBar class members, see the PivotHighVSBar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

PivotHighVSBar.instance Property

public int instance { public get; public set; }

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


leftstrength Property

PowerLanguage.NET Help

PivotHighVSBar.leftstrength Property

public int leftstrength { public get; public set; }

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

PivotHighVSBar.length Property

public int length { public get; public set; }

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

PivotHighVSBar.price Property

public ISeries<double> price { public get; public set; }

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


rightstrength Property

PowerLanguage.NET Help

PivotHighVSBar.rightstrength Property

public int rightstrength { public get; public set; }

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


PivotHighVSBar Methods

The methods of the PivotHighVSBar class are listed below. For a complete list of PivotHighVSBar class members, see the PivotHighVSBar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


PivotHighVSBar.CalcBar Method

protected override int CalcBar();

See Also

PivotHighVSBar Class | PowerLanguage.Function Namespace


PivotLowVS Class

For a list of all members of this type, see PivotLowVS Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
PivotLowVS

[DefaultMember(MemberName="Item")]
public class PivotLowVS : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PivotLowVS Members | PowerLanguage.Function Namespace


PivotLowVS Members

PivotLowVS overview

Public Instance Constructors

PivotLowVS Overloaded. Initializes a new instance of the PivotLowVS class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


PivotLowVS Constructor

Overload List

public PivotLowVS(CStudyControl)

public PivotLowVS(CStudyControl,int)

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


PivotLowVS Constructor

PivotLowVS(
CStudyControl ctx
);

See Also

PivotLowVS Class | PowerLanguage.Function Namespace | PivotLowVS Constructor Overload List


PivotLowVS Constructor

PivotLowVS(
CStudyControl ctx,
int data_stream
);

See Also

PivotLowVS Class | PowerLanguage.Function Namespace | PivotLowVS Constructor Overload List


PivotLowVS Properties

The properties of the PivotLowVS class are listed below. For a complete list of PivotLowVS class members, see the PivotLowVS Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

PivotLowVS.instance Property

public int instance { public get; public set; }

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


leftstrength Property

PowerLanguage.NET Help

PivotLowVS.leftstrength Property

public int leftstrength { public get; public set; }

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

PivotLowVS.length Property

public int length { public get; public set; }

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

PivotLowVS.price Property

public ISeries<double> price { public get; public set; }

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


rightstrength Property

PowerLanguage.NET Help

PivotLowVS.rightstrength Property

public int rightstrength { public get; public set; }

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


PivotLowVS Methods

The methods of the PivotLowVS class are listed below. For a complete list of PivotLowVS class members, see the PivotLowVS Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


PivotLowVS.CalcBar Method

protected override double CalcBar();

See Also

PivotLowVS Class | PowerLanguage.Function Namespace


PivotLowVSBar Class

For a list of all members of this type, see PivotLowVSBar Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
PivotLowVSBar

[DefaultMember(MemberName="Item")]
public class PivotLowVSBar : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PivotLowVSBar Members | PowerLanguage.Function Namespace


PivotLowVSBar Members

PivotLowVSBar overview

Public Instance Constructors

PivotLowVSBar Overloaded. Initializes a new instance of the PivotLowVSBar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


PivotLowVSBar Constructor

Overload List

public PivotLowVSBar(CStudyControl)

public PivotLowVSBar(CStudyControl,int)

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


PivotLowVSBar Constructor

PivotLowVSBar(
CStudyControl ctx
);

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace | PivotLowVSBar Constructor Overload List


PivotLowVSBar Constructor

PivotLowVSBar(
CStudyControl ctx,
int data_stream
);

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace | PivotLowVSBar Constructor Overload List


PivotLowVSBar Properties

The properties of the PivotLowVSBar class are listed below. For a complete list of PivotLowVSBar class members, see the PivotLowVSBar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
leftstrength |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
rightstrength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

PivotLowVSBar.instance Property

public int instance { public get; public set; }

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


leftstrength Property

PowerLanguage.NET Help

PivotLowVSBar.leftstrength Property

public int leftstrength { public get; public set; }

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

PivotLowVSBar.length Property

public int length { public get; public set; }

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

PivotLowVSBar.price Property

public ISeries<double> price { public get; public set; }

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


rightstrength Property

PowerLanguage.NET Help

PivotLowVSBar.rightstrength Property

public int rightstrength { public get; public set; }

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


PivotLowVSBar Methods

The methods of the PivotLowVSBar class are listed below. For a complete list of PivotLowVSBar class members, see the PivotLowVSBar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


PivotLowVSBar.CalcBar Method

protected override int CalcBar();

See Also

PivotLowVSBar Class | PowerLanguage.Function Namespace


PivotReversalGen Class

For a list of all members of this type, see PivotReversalGen Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSeries<Int32>
PivotReversalGen

[DefaultMember(MemberName="Item")]
public class PivotReversalGen : FunctionSeries<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PivotReversalGen Members | PowerLanguage.Function Namespace


PivotReversalGen Members

PivotReversalGen overview

Public Instance Constructors

PivotReversalGen Overloaded. Initializes a new instance of the PivotReversalGen class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
drawlines |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
hilo |
Item (inherited from FunctionSeries) |
linescolor |
lrfactor |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
maxrstren |
minrstren |
Name (inherited from CStudyControl) | Read-only property. Returns name.
opivotlstren |
opivotprice |
opivotrstren |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PivotReversalGen Constructor

Overload List

public PivotReversalGen(CStudyControl)

public PivotReversalGen(CStudyControl,int)

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PivotReversalGen Constructor

PivotReversalGen(
CStudyControl ctx
);

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace | PivotReversalGen Constructor Overload List


PivotReversalGen Constructor

PivotReversalGen(
CStudyControl ctx,
int data_stream
);

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace | PivotReversalGen Constructor Overload List


PivotReversalGen Properties

The properties of the PivotReversalGen class are listed below. For a complete list of PivotReversalGen class members, see the PivotReversalGen Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
drawlines |
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
hilo |
Item (inherited from FunctionSeries) |
linescolor |
lrfactor |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
maxrstren |
minrstren |
Name (inherited from CStudyControl) | Read-only property. Returns name.
opivotlstren |
opivotprice |
opivotrstren |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


drawlines Property

PowerLanguage.NET Help

PivotReversalGen.drawlines Property

public bool drawlines { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


hilo Property

PowerLanguage.NET Help

PivotReversalGen.hilo Property

public int hilo { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


linescolor Property

PowerLanguage.NET Help

PivotReversalGen.linescolor Property

public Color linescolor { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


lrfactor Property

PowerLanguage.NET Help

PivotReversalGen.lrfactor Property

public double lrfactor { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


maxrstren Property

PowerLanguage.NET Help

PivotReversalGen.maxrstren Property

public double maxrstren { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


minrstren Property

PowerLanguage.NET Help

PivotReversalGen.minrstren Property

public double minrstren { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


opivotlstren Property

PowerLanguage.NET Help

PivotReversalGen.opivotlstren Property

public IVar<double> opivotlstren { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


opivotprice Property

PowerLanguage.NET Help

PivotReversalGen.opivotprice Property

public IVar<double> opivotprice { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


opivotrstren Property

PowerLanguage.NET Help

PivotReversalGen.opivotrstren Property

public IVar<double> opivotrstren { public get; public set; }

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PivotReversalGen Methods

The methods of the PivotReversalGen class are listed below. For a complete list of PivotReversalGen class members, see the PivotReversalGen Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PivotReversalGen.CalcBar Method

protected override int CalcBar();

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PivotReversalGen.Create Method

protected override void Create();

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PivotReversalGen.StartCalc Method

protected override void StartCalc();

See Also

PivotReversalGen Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions Class

For a list of all members of this type, see PortfolioHelpFunctions Members .

System.Object
PortfolioHelpFunctions

[Extension]
public static class PortfolioHelpFunctions

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PortfolioHelpFunctions Members | PowerLanguage.Function Namespace


PortfolioHelpFunctions Members

PortfolioHelpFunctions overview

Public Static Fields

MoneyCostForInvestPerCtrct
PotentialEntryPrice

Public Static Methods

CalcContractsForEntry
CalcMoneyForEntryPerCntrct
FromPortfolioToSymbolCurrency
FromSymbolToPortfolioCurrency
GetFirstStrategyIndexBySymbolName
GetNextStrategyIndexBySymbolName
PortfolioEquity
StrategiesDenyEntriesAll
StrategiesInLong
StrategiesInPosition
StrategiesInShort
StudyAsPortfolio

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions Fields

The fields of the PortfolioHelpFunctions class are listed below. For a complete list of PortfolioHelpFunctions class members, see the PortfolioHelpFunctions Members topic.

Public Static Fields

MoneyCostForInvestPerCtrct
PotentialEntryPrice

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.MoneyCostForInvestPerCtrct Field

public static string MoneyCostForInvestPerCtrct;

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.PotentialEntryPrice Field

public static string PotentialEntryPrice;

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions Methods

The methods of the PortfolioHelpFunctions class are listed below. For a complete list of PortfolioHelpFunctions class members, see the PortfolioHelpFunctions Members topic.

Public Static Methods

CalcContractsForEntry
CalcMoneyForEntryPerCntrct
FromPortfolioToSymbolCurrency
FromSymbolToPortfolioCurrency
GetFirstStrategyIndexBySymbolName
GetNextStrategyIndexBySymbolName
PortfolioEquity
StrategiesDenyEntriesAll
StrategiesInLong
StrategiesInPosition
StrategiesInShort
StudyAsPortfolio

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.CalcContractsForEntry Method

[Extension]
public static int CalcContractsForEntry(
this IStrategy _this,
this double percent,
this int strategyIndex
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.CalcMoneyForEntryPerCntrct Method

[Extension]
public static double CalcMoneyForEntryPerCntrct(
this IStudy _this,
this double entryPrice,
this double portfolioLossPerCntrct
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.FromPortfolioToSymbolCurrency Method

[Extension]
public static double FromPortfolioToSymbolCurrency(
this IStudy _this,
this double money
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.FromSymbolToPortfolioCurrency Method

[Extension]
public static double FromSymbolToPortfolioCurrency(
this IStudy _this,
this double money
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.GetFirstStrategyIndexBySymbolName Method

[Extension]
public static int GetFirstStrategyIndexBySymbolName(
this IPortfolio _this,
this string symbolName
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.GetNextStrategyIndexBySymbolName Method

[Extension]
public static int GetNextStrategyIndexBySymbolName(
this IPortfolio _this,
this int startingIdx,
this string symbolName
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.PortfolioEquity Method

[Extension]
public static double PortfolioEquity(
this IStrategy _this
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.StrategiesDenyEntriesAll Method

[Extension]
public static void StrategiesDenyEntriesAll(
this IPortfolio _this
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.StrategiesInLong Method

[Extension]
public static int StrategiesInLong(
this IPortfolio _this,
this ref List<int> strategiesInPos
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.StrategiesInPosition Method

[Extension]
public static int StrategiesInPosition(
this IPortfolio _this,
this ref List<int> strategiesInPos
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.StrategiesInShort Method

[Extension]
public static int StrategiesInShort(
this IPortfolio _this,
this ref List<int> strategiesInPos
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PortfolioHelpFunctions.StudyAsPortfolio Method

[Extension]
public static IPortfolio StudyAsPortfolio(
this IStudy _this
);

See Also

PortfolioHelpFunctions Class | PowerLanguage.Function Namespace


PriceOscillator Class

For a list of all members of this type, see PriceOscillator Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
PriceOscillator

[DefaultMember(MemberName="Item")]
public class PriceOscillator : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PriceOscillator Members | PowerLanguage.Function Namespace


PriceOscillator Members

PriceOscillator overview

Public Instance Constructors

PriceOscillator Overloaded. Initializes a new instance of the PriceOscillator class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastlength |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
slowlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceOscillator Constructor

Overload List

public PriceOscillator(CStudyControl)

public PriceOscillator(CStudyControl,int)

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceOscillator Constructor

PriceOscillator(
CStudyControl ctx
);

See Also

PriceOscillator Class | PowerLanguage.Function Namespace | PriceOscillator Constructor Overload List


PriceOscillator Constructor

PriceOscillator(
CStudyControl ctx,
int data_stream
);

See Also

PriceOscillator Class | PowerLanguage.Function Namespace | PriceOscillator Constructor Overload List


PriceOscillator Properties

The properties of the PriceOscillator class are listed below. For a complete list of PriceOscillator class members, see the PriceOscillator Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastlength |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
slowlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


fastlength Property

PowerLanguage.NET Help

PriceOscillator.fastlength Property

public int fastlength { public get; public set; }

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

PriceOscillator.price Property

public ISeries<double> price { public get; public set; }

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


slowlength Property

PowerLanguage.NET Help

PriceOscillator.slowlength Property

public int slowlength { public get; public set; }

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceOscillator Methods

The methods of the PriceOscillator class are listed below. For a complete list of PriceOscillator class members, see the PriceOscillator Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceOscillator.CalcBar Method

protected override double CalcBar();

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceOscillator.Create Method

protected override void Create();

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceOscillator.StartCalc Method

protected override void StartCalc();

See Also

PriceOscillator Class | PowerLanguage.Function Namespace


PriceVolTrend Class

For a list of all members of this type, see PriceVolTrend Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
PriceVolTrend

[DefaultMember(MemberName="Item")]
public class PriceVolTrend : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PriceVolTrend Members | PowerLanguage.Function Namespace


PriceVolTrend Members

PriceVolTrend overview

Public Instance Constructors

PriceVolTrend Overloaded. Initializes a new instance of the PriceVolTrend class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace


PriceVolTrend Constructor

Overload List

public PriceVolTrend(CStudyControl)

public PriceVolTrend(CStudyControl,int)

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace


PriceVolTrend Constructor

PriceVolTrend(
CStudyControl ctx
);

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace | PriceVolTrend Constructor Overload List


PriceVolTrend Constructor

PriceVolTrend(
CStudyControl ctx,
int data_stream
);

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace | PriceVolTrend Constructor Overload List


PriceVolTrend Methods

The methods of the PriceVolTrend class are listed below. For a complete list of PriceVolTrend class members, see the PriceVolTrend Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace


PriceVolTrend.CalcBar Method

protected override double CalcBar();

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace


PriceVolTrend.StartCalc Method

protected override void StartCalc();

See Also

PriceVolTrend Class | PowerLanguage.Function Namespace


RS_Average Class

For a list of all members of this type, see RS_Average Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
RS_Average

[DefaultMember(MemberName="Item")]
public class RS_Average : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_Average Members | PowerLanguage.Function Namespace


RS_Average Members

RS_Average overview

Public Instance Constructors

RS_Average Overloaded. Initializes a new instance of the RS_Average class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
offset |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
rowtoavg |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_Average Class | PowerLanguage.Function Namespace


RS_Average Constructor

Overload List

public RS_Average(CStudyControl)

public RS_Average(CStudyControl,int)

See Also

RS_Average Class | PowerLanguage.Function Namespace


RS_Average Constructor

RS_Average(
CStudyControl ctx
);

See Also

RS_Average Class | PowerLanguage.Function Namespace | RS_Average Constructor Overload List


RS_Average Constructor

RS_Average(
CStudyControl ctx,
int data_stream
);

See Also

RS_Average Class | PowerLanguage.Function Namespace | RS_Average Constructor Overload List


RS_Average Properties

The properties of the RS_Average class are listed below. For a complete list of RS_Average class members, see the RS_Average Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
offset |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
rowtoavg |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RS_Average Class | PowerLanguage.Function Namespace


dataarray Property

PowerLanguage.NET Help

RS_Average.dataarray Property

public IArraySeries2D<double> dataarray { public get; public set; }

See Also

RS_Average Class | PowerLanguage.Function Namespace


index Property

PowerLanguage.NET Help

RS_Average.index Property

public ISeries<int> index { public get; public set; }

See Also

RS_Average Class | PowerLanguage.Function Namespace


numdays Property

PowerLanguage.NET Help

RS_Average.numdays Property

public int numdays { public get; public set; }

See Also

RS_Average Class | PowerLanguage.Function Namespace


offset Property

PowerLanguage.NET Help

RS_Average.offset Property

public int offset { public get; public set; }

See Also

RS_Average Class | PowerLanguage.Function Namespace


rowtoavg Property

PowerLanguage.NET Help

RS_Average.rowtoavg Property

public int rowtoavg { public get; public set; }

See Also

RS_Average Class | PowerLanguage.Function Namespace


RS_Average Methods

The methods of the RS_Average class are listed below. For a complete list of RS_Average class members, see the RS_Average Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_Average Class | PowerLanguage.Function Namespace


RS_Average.CalcBar Method

protected override double CalcBar();

See Also

RS_Average Class | PowerLanguage.Function Namespace


RS_BarsPerDay Class

For a list of all members of this type, see RS_BarsPerDay Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
RS_BarsPerDay

[DefaultMember(MemberName="Item")]
public class RS_BarsPerDay : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_BarsPerDay Members | PowerLanguage.Function Namespace


RS_BarsPerDay Members

RS_BarsPerDay overview

Public Instance Constructors

RS_BarsPerDay Overloaded. Initializes a new instance of the RS_BarsPerDay class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace


RS_BarsPerDay Constructor

Overload List

public RS_BarsPerDay(CStudyControl)

public RS_BarsPerDay(CStudyControl,int)

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace


RS_BarsPerDay Constructor

RS_BarsPerDay(
CStudyControl ctx
);

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace | RS_BarsPerDay Constructor Overload List


RS_BarsPerDay Constructor

RS_BarsPerDay(
CStudyControl ctx,
int data_stream
);

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace | RS_BarsPerDay Constructor Overload List


RS_BarsPerDay Methods

The methods of the RS_BarsPerDay class are listed below. For a complete list of RS_BarsPerDay class members, see the RS_BarsPerDay Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace


RS_BarsPerDay.CalcBar Method

protected override int CalcBar();

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace


RS_BarsPerDay.StartCalc Method

protected override void StartCalc();

See Also

RS_BarsPerDay Class | PowerLanguage.Function Namespace


RS_DailyDataArray Class

For a list of all members of this type, see RS_DailyDataArray Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
RS_DailyDataArray

[DefaultMember(MemberName="Item")]
public class RS_DailyDataArray : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_DailyDataArray Members | PowerLanguage.Function Namespace


RS_DailyDataArray Members

RS_DailyDataArray overview

Public Instance Constructors

RS_DailyDataArray Overloaded. Initializes a new instance of the RS_DailyDataArray class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
odataarray |
oindex |
osubarray |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_DailyDataArray Constructor

Overload List

public RS_DailyDataArray(CStudyControl)

public RS_DailyDataArray(CStudyControl,int)

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_DailyDataArray Constructor

RS_DailyDataArray(
CStudyControl ctx
);

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace | RS_DailyDataArray Constructor Overload List


RS_DailyDataArray Constructor

RS_DailyDataArray(
CStudyControl ctx,
int data_stream
);

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace | RS_DailyDataArray Constructor Overload List


RS_DailyDataArray Properties

The properties of the RS_DailyDataArray class are listed below. For a complete list of RS_DailyDataArray class members, see the RS_DailyDataArray Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
odataarray |
oindex |
osubarray |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


numdays Property

PowerLanguage.NET Help

RS_DailyDataArray.numdays Property

public int numdays { public get; public set; }

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


odataarray Property

PowerLanguage.NET Help

RS_DailyDataArray.odataarray Property

public IArraySeries2D<double> odataarray { public get; public set; }

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


oindex Property

PowerLanguage.NET Help

RS_DailyDataArray.oindex Property

public IVar<int> oindex { public get; public set; }

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


osubarray Property

PowerLanguage.NET Help

RS_DailyDataArray.osubarray Property

public IArraySeries<double> osubarray { public get; public set; }

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_DailyDataArray Methods

The methods of the RS_DailyDataArray class are listed below. For a complete list of RS_DailyDataArray class members, see the RS_DailyDataArray Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_DailyDataArray.CalcBar Method

protected override double CalcBar();

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_DailyDataArray.Create Method

protected override void Create();

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_DailyDataArray.StartCalc Method

protected override void StartCalc();

See Also

RS_DailyDataArray Class | PowerLanguage.Function Namespace


RS_Extremes Class

For a list of all members of this type, see RS_Extremes Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
RS_Extremes

[DefaultMember(MemberName="Item")]
public class RS_Extremes : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_Extremes Members | PowerLanguage.Function Namespace


RS_Extremes Members

RS_Extremes overview

Public Instance Constructors

RS_Extremes Overloaded. Initializes a new instance of the RS_Extremes class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
oprevhighest |
oprevhighestday |
oprevlowest |
oprevlowestday |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


RS_Extremes Constructor

Overload List

public RS_Extremes(CStudyControl)

public RS_Extremes(CStudyControl,int)

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


RS_Extremes Constructor

RS_Extremes(
CStudyControl ctx
);

See Also

RS_Extremes Class | PowerLanguage.Function Namespace | RS_Extremes Constructor Overload List


RS_Extremes Constructor

RS_Extremes(
CStudyControl ctx,
int data_stream
);

See Also

RS_Extremes Class | PowerLanguage.Function Namespace | RS_Extremes Constructor Overload List


RS_Extremes Properties

The properties of the RS_Extremes class are listed below. For a complete list of RS_Extremes class members, see the RS_Extremes Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
oprevhighest |
oprevhighestday |
oprevlowest |
oprevlowestday |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


dataarray Property

PowerLanguage.NET Help

RS_Extremes.dataarray Property

public IArraySeries2D<double> dataarray { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


index Property

PowerLanguage.NET Help

RS_Extremes.index Property

public ISeries<int> index { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


numdays Property

PowerLanguage.NET Help

RS_Extremes.numdays Property

public int numdays { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


oprevhighest Property

PowerLanguage.NET Help

RS_Extremes.oprevhighest Property

public IVar<double> oprevhighest { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


oprevhighestday Property

PowerLanguage.NET Help

RS_Extremes.oprevhighestday Property

public IVar<double> oprevhighestday { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


oprevlowest Property

PowerLanguage.NET Help

RS_Extremes.oprevlowest Property

public IVar<double> oprevlowest { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


oprevlowestday Property

PowerLanguage.NET Help

RS_Extremes.oprevlowestday Property

public IVar<double> oprevlowestday { public get; public set; }

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


RS_Extremes Methods

The methods of the RS_Extremes class are listed below. For a complete list of RS_Extremes class members, see the RS_Extremes Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


RS_Extremes.CalcBar Method

protected override double CalcBar();

See Also

RS_Extremes Class | PowerLanguage.Function Namespace


RS_PriceExtension Class

For a list of all members of this type, see RS_PriceExtension Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
RS_PriceExtension

[DefaultMember(MemberName="Item")]
public class RS_PriceExtension : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_PriceExtension Members | PowerLanguage.Function Namespace


RS_PriceExtension Members

RS_PriceExtension overview

Public Instance Constructors

RS_PriceExtension Overloaded. Initializes a new instance of the RS_PriceExtension class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
finalrangefactor |
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
minconsolindex |
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
prevatr |
prevtrhighest |
prevtrlowest |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


RS_PriceExtension Constructor

Overload List

public RS_PriceExtension(CStudyControl)

public RS_PriceExtension(CStudyControl,int)

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


RS_PriceExtension Constructor

RS_PriceExtension(
CStudyControl ctx
);

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace | RS_PriceExtension Constructor Overload List


RS_PriceExtension Constructor

RS_PriceExtension(
CStudyControl ctx,
int data_stream
);

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace | RS_PriceExtension Constructor Overload List


RS_PriceExtension Properties

The properties of the RS_PriceExtension class are listed below. For a complete list of RS_PriceExtension class members, see the RS_PriceExtension Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
finalrangefactor |
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
minconsolindex |
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
prevatr |
prevtrhighest |
prevtrlowest |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


dataarray Property

PowerLanguage.NET Help

RS_PriceExtension.dataarray Property

public IArraySeries2D<double> dataarray { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


finalrangefactor Property

PowerLanguage.NET Help

RS_PriceExtension.finalrangefactor Property

public double finalrangefactor { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


index Property

PowerLanguage.NET Help

RS_PriceExtension.index Property

public ISeries<int> index { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


minconsolindex Property

PowerLanguage.NET Help

RS_PriceExtension.minconsolindex Property

public double minconsolindex { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


numdays Property

PowerLanguage.NET Help

RS_PriceExtension.numdays Property

public int numdays { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


prevatr Property

PowerLanguage.NET Help

RS_PriceExtension.prevatr Property

public ISeries<double> prevatr { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


prevtrhighest Property

PowerLanguage.NET Help

RS_PriceExtension.prevtrhighest Property

public ISeries<double> prevtrhighest { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


prevtrlowest Property

PowerLanguage.NET Help

RS_PriceExtension.prevtrlowest Property

public ISeries<double> prevtrlowest { public get; public set; }

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


RS_PriceExtension Methods

The methods of the RS_PriceExtension class are listed below. For a complete list of RS_PriceExtension class members, see the RS_PriceExtension Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


RS_PriceExtension.CalcBar Method

protected override int CalcBar();

See Also

RS_PriceExtension Class | PowerLanguage.Function Namespace


RS_ReversalPatterns Class

For a list of all members of this type, see RS_ReversalPatterns Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
RS_ReversalPatterns

[DefaultMember(MemberName="Item")]
public class RS_ReversalPatterns : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_ReversalPatterns Members | PowerLanguage.Function Namespace


RS_ReversalPatterns Members

RS_ReversalPatterns overview

Public Instance Constructors

RS_ReversalPatterns Overloaded. Initializes a new instance of the RS_ReversalPatterns class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
gapsizefactor |
index |
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
osetup |
otrigger |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
revcriteria |
revdirection |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
subarray |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


RS_ReversalPatterns Constructor

Overload List

public RS_ReversalPatterns(CStudyControl)

public RS_ReversalPatterns(CStudyControl,int)

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


RS_ReversalPatterns Constructor

RS_ReversalPatterns(
CStudyControl ctx
);

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace | RS_ReversalPatterns Constructor Overload List


RS_ReversalPatterns Constructor

RS_ReversalPatterns(
CStudyControl ctx,
int data_stream
);

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace | RS_ReversalPatterns Constructor Overload List


RS_ReversalPatterns Properties

The properties of the RS_ReversalPatterns class are listed below. For a complete list of RS_ReversalPatterns class members, see the RS_ReversalPatterns Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
gapsizefactor |
index |
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
osetup |
otrigger |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
revcriteria |
revdirection |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
subarray |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


dataarray Property

PowerLanguage.NET Help

RS_ReversalPatterns.dataarray Property

public IArraySeries2D<double> dataarray { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


gapsizefactor Property

PowerLanguage.NET Help

RS_ReversalPatterns.gapsizefactor Property

public double gapsizefactor { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


index Property

PowerLanguage.NET Help

RS_ReversalPatterns.index Property

public ISeries<int> index { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


osetup Property

PowerLanguage.NET Help

RS_ReversalPatterns.osetup Property

public IVar<int> osetup { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


otrigger Property

PowerLanguage.NET Help

RS_ReversalPatterns.otrigger Property

public IVar<double> otrigger { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


revcriteria Property

PowerLanguage.NET Help

RS_ReversalPatterns.revcriteria Property

public int revcriteria { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


revdirection Property

PowerLanguage.NET Help

RS_ReversalPatterns.revdirection Property

public ISeries<int> revdirection { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


subarray Property

PowerLanguage.NET Help

RS_ReversalPatterns.subarray Property

public IArraySeries<double> subarray { public get; public set; }

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


RS_ReversalPatterns Methods

The methods of the RS_ReversalPatterns class are listed below. For a complete list of RS_ReversalPatterns class members, see the RS_ReversalPatterns Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


RS_ReversalPatterns.CalcBar Method

protected override double CalcBar();

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


RS_ReversalPatterns.Create Method

protected override void Create();

See Also

RS_ReversalPatterns Class | PowerLanguage.Function Namespace


RS_TrueExtremes Class

For a list of all members of this type, see RS_TrueExtremes Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
RS_TrueExtremes

[DefaultMember(MemberName="Item")]
public class RS_TrueExtremes : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RS_TrueExtremes Members | PowerLanguage.Function Namespace


RS_TrueExtremes Members

RS_TrueExtremes overview

Public Instance Constructors

RS_TrueExtremes Overloaded. Initializes a new instance of the RS_TrueExtremes class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
oprevatr |
oprevtrhighest |
oprevtrlowest |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


RS_TrueExtremes Constructor

Overload List

public RS_TrueExtremes(CStudyControl)

public RS_TrueExtremes(CStudyControl,int)

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


RS_TrueExtremes Constructor

RS_TrueExtremes(
CStudyControl ctx
);

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace | RS_TrueExtremes Constructor Overload List


RS_TrueExtremes Constructor

RS_TrueExtremes(
CStudyControl ctx,
int data_stream
);

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace | RS_TrueExtremes Constructor Overload List


RS_TrueExtremes Properties

The properties of the RS_TrueExtremes class are listed below. For a complete list of RS_TrueExtremes class members, see the RS_TrueExtremes Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
dataarray |
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
index |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
oprevatr |
oprevtrhighest |
oprevtrlowest |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


dataarray Property

PowerLanguage.NET Help

RS_TrueExtremes.dataarray Property

public IArraySeries2D<double> dataarray { public get; public set; }

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


index Property

PowerLanguage.NET Help

RS_TrueExtremes.index Property

public ISeries<int> index { public get; public set; }

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


numdays Property

PowerLanguage.NET Help

RS_TrueExtremes.numdays Property

public int numdays { public get; public set; }

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


oprevatr Property

PowerLanguage.NET Help

RS_TrueExtremes.oprevatr Property

public IVar<double> oprevatr { public get; public set; }

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


oprevtrhighest Property

PowerLanguage.NET Help

RS_TrueExtremes.oprevtrhighest Property

public IVar<double> oprevtrhighest { public get; public set; }

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


oprevtrlowest Property

PowerLanguage.NET Help

RS_TrueExtremes.oprevtrlowest Property

public IVar<double> oprevtrlowest { public get; public set; }

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


RS_TrueExtremes Methods

The methods of the RS_TrueExtremes class are listed below. For a complete list of RS_TrueExtremes class members, see the RS_TrueExtremes Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


RS_TrueExtremes.CalcBar Method

protected override double CalcBar();

See Also

RS_TrueExtremes Class | PowerLanguage.Function Namespace


RSI Class

For a list of all members of this type, see RSI Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
RSI

[DefaultMember(MemberName="Item")]
public class RSI : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

RSI Members | PowerLanguage.Function Namespace


RSI Members

RSI overview

Public Instance Constructors

RSI Overloaded. Initializes a new instance of the RSI class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

RSI Class | PowerLanguage.Function Namespace


RSI Constructor

Overload List

public RSI(CStudyControl)

public RSI(CStudyControl,int)

See Also

RSI Class | PowerLanguage.Function Namespace


RSI Constructor

RSI(
CStudyControl ctx
);

See Also

RSI Class | PowerLanguage.Function Namespace | RSI Constructor Overload List


RSI Constructor

RSI(
CStudyControl ctx,
int data_stream
);

See Also

RSI Class | PowerLanguage.Function Namespace | RSI Constructor Overload List


RSI Properties

The properties of the RSI class are listed below. For a complete list of RSI class members, see the RSI Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

RSI Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

RSI.length Property

public int length { public get; public set; }

See Also

RSI Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

RSI.price Property

public ISeries<double> price { public get; public set; }

See Also

RSI Class | PowerLanguage.Function Namespace


RSI Methods

The methods of the RSI class are listed below. For a complete list of RSI class members, see the RSI Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

RSI Class | PowerLanguage.Function Namespace


RSI.CalcBar Method

protected override double CalcBar();

See Also

RSI Class | PowerLanguage.Function Namespace


RSI.Create Method

protected override void Create();

See Also

RSI Class | PowerLanguage.Function Namespace


RSI.StartCalc Method

protected override void StartCalc();

See Also

RSI Class | PowerLanguage.Function Namespace


SharpeRatio Class

For a list of all members of this type, see SharpeRatio Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
SharpeRatio

[DefaultMember(MemberName="Item")]
public class SharpeRatio : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SharpeRatio Members | PowerLanguage.Function Namespace


SharpeRatio Members

SharpeRatio overview

Public Instance Constructors

SharpeRatio Constructor

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
Period |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio Constructor

SharpeRatio(
SignalObject ctx
);

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio Properties

The properties of the SharpeRatio class are listed below. For a complete list of SharpeRatio class members, see the SharpeRatio Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
Period |
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


Period Property

PowerLanguage.NET Help

SharpeRatio.Period Property

public EPeriod Period { public get; public set; }

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio Methods

The methods of the SharpeRatio class are listed below. For a complete list of SharpeRatio class members, see the SharpeRatio Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio.CalcBar Method

protected override double CalcBar();

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio.Create Method

protected override void Create();

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio.StartCalc Method

protected override void StartCalc();

See Also

SharpeRatio Class | PowerLanguage.Function Namespace


SharpeRatio.EPeriod Enumeration

public enum EPeriod

Members

Member Name | Description
Monthly |
Daily |

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

PowerLanguage.Function Namespace


SlowKCustom Class

For a list of all members of this type, see SlowKCustom Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
SlowKCustom

[DefaultMember(MemberName="Item")]
public class SlowKCustom : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SlowKCustom Members | PowerLanguage.Function Namespace


SlowKCustom Members

SlowKCustom overview

Public Instance Constructors

SlowKCustom Overloaded. Initializes a new instance of the SlowKCustom class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


SlowKCustom Constructor

Overload List

public SlowKCustom(CStudyControl)

public SlowKCustom(CStudyControl,int)

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


SlowKCustom Constructor

SlowKCustom(
CStudyControl ctx
);

See Also

SlowKCustom Class | PowerLanguage.Function Namespace | SlowKCustom Constructor Overload List


SlowKCustom Constructor

SlowKCustom(
CStudyControl ctx,
int data_stream
);

See Also

SlowKCustom Class | PowerLanguage.Function Namespace | SlowKCustom Constructor Overload List


SlowKCustom Properties

The properties of the SlowKCustom class are listed below. For a complete list of SlowKCustom class members, see the SlowKCustom Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


pricec Property

PowerLanguage.NET Help

SlowKCustom.pricec Property

public ISeries<double> pricec { public get; public set; }

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


priceh Property

PowerLanguage.NET Help

SlowKCustom.priceh Property

public ISeries<double> priceh { public get; public set; }

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


pricel Property

PowerLanguage.NET Help

SlowKCustom.pricel Property

public ISeries<double> pricel { public get; public set; }

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


stochlength Property

PowerLanguage.NET Help

SlowKCustom.stochlength Property

public int stochlength { public get; public set; }

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


SlowKCustom Methods

The methods of the SlowKCustom class are listed below. For a complete list of SlowKCustom class members, see the SlowKCustom Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


SlowKCustom.CalcBar Method

protected override double CalcBar();

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


SlowKCustom.Create Method

protected override void Create();

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


SlowKCustom.StartCalc Method

protected override void StartCalc();

See Also

SlowKCustom Class | PowerLanguage.Function Namespace


StdError Class

For a list of all members of this type, see StdError Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
StdError

[DefaultMember(MemberName="Item")]
public class StdError : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

StdError Members | PowerLanguage.Function Namespace


StdError Members

StdError overview

Public Instance Constructors

StdError Overloaded. Initializes a new instance of the StdError class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

StdError Class | PowerLanguage.Function Namespace


StdError Constructor

Overload List

public StdError(CStudyControl)

public StdError(CStudyControl,int)

See Also

StdError Class | PowerLanguage.Function Namespace


StdError Constructor

StdError(
CStudyControl ctx
);

See Also

StdError Class | PowerLanguage.Function Namespace | StdError Constructor Overload List


StdError Constructor

StdError(
CStudyControl ctx,
int data_stream
);

See Also

StdError Class | PowerLanguage.Function Namespace | StdError Constructor Overload List


StdError Properties

The properties of the StdError class are listed below. For a complete list of StdError class members, see the StdError Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

StdError Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

StdError.length Property

public int length { public get; public set; }

See Also

StdError Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

StdError.price Property

public ISeries<double> price { public get; public set; }

See Also

StdError Class | PowerLanguage.Function Namespace


StdError Methods

The methods of the StdError class are listed below. For a complete list of StdError class members, see the StdError Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

StdError Class | PowerLanguage.Function Namespace


StdError.CalcBar Method

protected override double CalcBar();

See Also

StdError Class | PowerLanguage.Function Namespace


Stochastic Class

For a list of all members of this type, see Stochastic Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
Stochastic

[DefaultMember(MemberName="Item")]
public class Stochastic : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

Stochastic Members | PowerLanguage.Function Namespace


Stochastic Members

Stochastic overview

Public Instance Constructors

Stochastic Overloaded. Initializes a new instance of the Stochastic class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length1 |
length2 |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
ofastd |
ofastk |
oslowd |
oslowk |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
smoothingtype |
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

Stochastic Class | PowerLanguage.Function Namespace


Stochastic Constructor

Overload List

public Stochastic(CStudyControl)

public Stochastic(CStudyControl,int)

See Also

Stochastic Class | PowerLanguage.Function Namespace


Stochastic Constructor

Stochastic(
CStudyControl ctx
);

See Also

Stochastic Class | PowerLanguage.Function Namespace | Stochastic Constructor Overload List


Stochastic Constructor

Stochastic(
CStudyControl ctx,
int data_stream
);

See Also

Stochastic Class | PowerLanguage.Function Namespace | Stochastic Constructor Overload List


Stochastic Properties

The properties of the Stochastic class are listed below. For a complete list of Stochastic class members, see the Stochastic Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length1 |
length2 |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
ofastd |
ofastk |
oslowd |
oslowk |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
smoothingtype |
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

Stochastic Class | PowerLanguage.Function Namespace


length1 Property

PowerLanguage.NET Help

Stochastic.length1 Property

public int length1 { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


length2 Property

PowerLanguage.NET Help

Stochastic.length2 Property

public int length2 { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


ofastd Property

PowerLanguage.NET Help

Stochastic.ofastd Property

public IVar<double> ofastd { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


ofastk Property

PowerLanguage.NET Help

Stochastic.ofastk Property

public IVar<double> ofastk { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


oslowd Property

PowerLanguage.NET Help

Stochastic.oslowd Property

public IVar<double> oslowd { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


oslowk Property

PowerLanguage.NET Help

Stochastic.oslowk Property

public IVar<double> oslowk { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


pricec Property

PowerLanguage.NET Help

Stochastic.pricec Property

public ISeries<double> pricec { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


priceh Property

PowerLanguage.NET Help

Stochastic.priceh Property

public ISeries<double> priceh { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


pricel Property

PowerLanguage.NET Help

Stochastic.pricel Property

public ISeries<double> pricel { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


smoothingtype Property

PowerLanguage.NET Help

Stochastic.smoothingtype Property

public int smoothingtype { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


stochlength Property

PowerLanguage.NET Help

Stochastic.stochlength Property

public int stochlength { public get; public set; }

See Also

Stochastic Class | PowerLanguage.Function Namespace


Stochastic Methods

The methods of the Stochastic class are listed below. For a complete list of Stochastic class members, see the Stochastic Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

Stochastic Class | PowerLanguage.Function Namespace


Stochastic.CalcBar Method

protected override double CalcBar();

See Also

Stochastic Class | PowerLanguage.Function Namespace


Stochastic.Create Method

protected override void Create();

See Also

Stochastic Class | PowerLanguage.Function Namespace


Stochastic.StartCalc Method

protected override void StartCalc();

See Also

Stochastic Class | PowerLanguage.Function Namespace


StochasticExp Class

For a list of all members of this type, see StochasticExp Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
StochasticExp

[DefaultMember(MemberName="Item")]
public class StochasticExp : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

StochasticExp Members | PowerLanguage.Function Namespace


StochasticExp Members

StochasticExp overview

Public Instance Constructors

StochasticExp Overloaded. Initializes a new instance of the StochasticExp class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
ofastd |
oslowd |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
smoothinglength1 |
smoothinglength2 |
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

StochasticExp Class | PowerLanguage.Function Namespace


StochasticExp Constructor

Overload List

public StochasticExp(CStudyControl)

public StochasticExp(CStudyControl,int)

See Also

StochasticExp Class | PowerLanguage.Function Namespace


StochasticExp Constructor

StochasticExp(
CStudyControl ctx
);

See Also

StochasticExp Class | PowerLanguage.Function Namespace | StochasticExp Constructor Overload List


StochasticExp Constructor

StochasticExp(
CStudyControl ctx,
int data_stream
);

See Also

StochasticExp Class | PowerLanguage.Function Namespace | StochasticExp Constructor Overload List


StochasticExp Properties

The properties of the StochasticExp class are listed below. For a complete list of StochasticExp class members, see the StochasticExp Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
ofastd |
oslowd |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
pricec |
priceh |
pricel |
smoothinglength1 |
smoothinglength2 |
stochlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

StochasticExp Class | PowerLanguage.Function Namespace


ofastd Property

PowerLanguage.NET Help

StochasticExp.ofastd Property

public IVar<double> ofastd { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


oslowd Property

PowerLanguage.NET Help

StochasticExp.oslowd Property

public IVar<double> oslowd { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


pricec Property

PowerLanguage.NET Help

StochasticExp.pricec Property

public ISeries<double> pricec { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


priceh Property

PowerLanguage.NET Help

StochasticExp.priceh Property

public ISeries<double> priceh { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


pricel Property

PowerLanguage.NET Help

StochasticExp.pricel Property

public ISeries<double> pricel { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


smoothinglength1 Property

PowerLanguage.NET Help

StochasticExp.smoothinglength1 Property

public int smoothinglength1 { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


smoothinglength2 Property

PowerLanguage.NET Help

StochasticExp.smoothinglength2 Property

public int smoothinglength2 { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


stochlength Property

PowerLanguage.NET Help

StochasticExp.stochlength Property

public int stochlength { public get; public set; }

See Also

StochasticExp Class | PowerLanguage.Function Namespace


StochasticExp Methods

The methods of the StochasticExp class are listed below. For a complete list of StochasticExp class members, see the StochasticExp Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

StochasticExp Class | PowerLanguage.Function Namespace


StochasticExp.CalcBar Method

protected override double CalcBar();

See Also

StochasticExp Class | PowerLanguage.Function Namespace


StochasticExp.Create Method

protected override void Create();

See Also

StochasticExp Class | PowerLanguage.Function Namespace


StochasticExp.StartCalc Method

protected override void StartCalc();

See Also

StochasticExp Class | PowerLanguage.Function Namespace


SummationFC Class

For a list of all members of this type, see SummationFC Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
SummationFC

[DefaultMember(MemberName="Item")]
public class SummationFC : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SummationFC Members | PowerLanguage.Function Namespace


SummationFC Members

SummationFC overview

Public Instance Constructors

SummationFC Overloaded. Initializes a new instance of the SummationFC class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

SummationFC Class | PowerLanguage.Function Namespace


SummationFC Constructor

Overload List

public SummationFC(CStudyControl)

public SummationFC(CStudyControl,int)

See Also

SummationFC Class | PowerLanguage.Function Namespace


SummationFC Constructor

SummationFC(
CStudyControl ctx
);

See Also

SummationFC Class | PowerLanguage.Function Namespace | SummationFC Constructor Overload List


SummationFC Constructor

SummationFC(
CStudyControl ctx,
int data_stream
);

See Also

SummationFC Class | PowerLanguage.Function Namespace | SummationFC Constructor Overload List


SummationFC Properties

The properties of the SummationFC class are listed below. For a complete list of SummationFC class members, see the SummationFC Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SummationFC Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

SummationFC.length Property

public int length { public get; public set; }

See Also

SummationFC Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

SummationFC.price Property

public ISeries<double> price { public get; public set; }

See Also

SummationFC Class | PowerLanguage.Function Namespace


SummationFC Methods

The methods of the SummationFC class are listed below. For a complete list of SummationFC class members, see the SummationFC Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

SummationFC Class | PowerLanguage.Function Namespace


SummationFC.CalcBar Method

protected override double CalcBar();

See Also

SummationFC Class | PowerLanguage.Function Namespace


SummationFC.Create Method

protected override void Create();

See Also

SummationFC Class | PowerLanguage.Function Namespace


SummationFC.StartCalc Method

protected override void StartCalc();

See Also

SummationFC Class | PowerLanguage.Function Namespace


SwingHigh Class

For a list of all members of this type, see SwingHigh Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
SwingHigh

[DefaultMember(MemberName="Item")]
public class SwingHigh : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SwingHigh Members | PowerLanguage.Function Namespace


SwingHigh Members

SwingHigh overview

Public Instance Constructors

SwingHigh Overloaded. Initializes a new instance of the SwingHigh class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingHigh Class | PowerLanguage.Function Namespace


SwingHigh Constructor

Overload List

public SwingHigh(CStudyControl)

public SwingHigh(CStudyControl,int)

See Also

SwingHigh Class | PowerLanguage.Function Namespace


SwingHigh Constructor

SwingHigh(
CStudyControl ctx
);

See Also

SwingHigh Class | PowerLanguage.Function Namespace | SwingHigh Constructor Overload List


SwingHigh Constructor

SwingHigh(
CStudyControl ctx,
int data_stream
);

See Also

SwingHigh Class | PowerLanguage.Function Namespace | SwingHigh Constructor Overload List


SwingHigh Properties

The properties of the SwingHigh class are listed below. For a complete list of SwingHigh class members, see the SwingHigh Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SwingHigh Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

SwingHigh.instance Property

public int instance { public get; public set; }

See Also

SwingHigh Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

SwingHigh.length Property

public int length { public get; public set; }

See Also

SwingHigh Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

SwingHigh.price Property

public ISeries<double> price { public get; public set; }

See Also

SwingHigh Class | PowerLanguage.Function Namespace


strength Property

PowerLanguage.NET Help

SwingHigh.strength Property

public int strength { public get; public set; }

See Also

SwingHigh Class | PowerLanguage.Function Namespace


SwingHigh Methods

The methods of the SwingHigh class are listed below. For a complete list of SwingHigh class members, see the SwingHigh Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingHigh Class | PowerLanguage.Function Namespace


SwingHigh.CalcBar Method

protected override double CalcBar();

See Also

SwingHigh Class | PowerLanguage.Function Namespace


SwingHighBar Class

For a list of all members of this type, see SwingHighBar Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
SwingHighBar

[DefaultMember(MemberName="Item")]
public class SwingHighBar : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SwingHighBar Members | PowerLanguage.Function Namespace


SwingHighBar Members

SwingHighBar overview

Public Instance Constructors

SwingHighBar Overloaded. Initializes a new instance of the SwingHighBar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


SwingHighBar Constructor

Overload List

public SwingHighBar(CStudyControl)

public SwingHighBar(CStudyControl,int)

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


SwingHighBar Constructor

SwingHighBar(
CStudyControl ctx
);

See Also

SwingHighBar Class | PowerLanguage.Function Namespace | SwingHighBar Constructor Overload List


SwingHighBar Constructor

SwingHighBar(
CStudyControl ctx,
int data_stream
);

See Also

SwingHighBar Class | PowerLanguage.Function Namespace | SwingHighBar Constructor Overload List


SwingHighBar Properties

The properties of the SwingHighBar class are listed below. For a complete list of SwingHighBar class members, see the SwingHighBar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

SwingHighBar.instance Property

public int instance { public get; public set; }

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

SwingHighBar.length Property

public int length { public get; public set; }

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

SwingHighBar.price Property

public ISeries<double> price { public get; public set; }

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


strength Property

PowerLanguage.NET Help

SwingHighBar.strength Property

public int strength { public get; public set; }

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


SwingHighBar Methods

The methods of the SwingHighBar class are listed below. For a complete list of SwingHighBar class members, see the SwingHighBar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


SwingHighBar.CalcBar Method

protected override int CalcBar();

See Also

SwingHighBar Class | PowerLanguage.Function Namespace


SwingIndex Class

For a list of all members of this type, see SwingIndex Members .

System.Object
SwingIndex

[Extension]
public static class SwingIndex

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SwingIndex Members | PowerLanguage.Function Namespace


SwingIndex Members

SwingIndex overview

Public Static Methods

Calc

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SwingIndex Class | PowerLanguage.Function Namespace


SwingIndex Methods

The methods of the SwingIndex class are listed below. For a complete list of SwingIndex class members, see the SwingIndex Members topic.

Public Static Methods

Calc

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SwingIndex Class | PowerLanguage.Function Namespace


SwingIndex.Calc Method

[Extension]
public static double Calc(
this IInstrument Bars,
this int bb
);

See Also

SwingIndex Class | PowerLanguage.Function Namespace


SwingLow Class

For a list of all members of this type, see SwingLow Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
SwingLow

[DefaultMember(MemberName="Item")]
public class SwingLow : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SwingLow Members | PowerLanguage.Function Namespace


SwingLow Members

SwingLow overview

Public Instance Constructors

SwingLow Overloaded. Initializes a new instance of the SwingLow class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingLow Class | PowerLanguage.Function Namespace


SwingLow Constructor

Overload List

public SwingLow(CStudyControl)

public SwingLow(CStudyControl,int)

See Also

SwingLow Class | PowerLanguage.Function Namespace


SwingLow Constructor

SwingLow(
CStudyControl ctx
);

See Also

SwingLow Class | PowerLanguage.Function Namespace | SwingLow Constructor Overload List


SwingLow Constructor

SwingLow(
CStudyControl ctx,
int data_stream
);

See Also

SwingLow Class | PowerLanguage.Function Namespace | SwingLow Constructor Overload List


SwingLow Properties

The properties of the SwingLow class are listed below. For a complete list of SwingLow class members, see the SwingLow Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SwingLow Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

SwingLow.instance Property

public int instance { public get; public set; }

See Also

SwingLow Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

SwingLow.length Property

public int length { public get; public set; }

See Also

SwingLow Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

SwingLow.price Property

public ISeries<double> price { public get; public set; }

See Also

SwingLow Class | PowerLanguage.Function Namespace


strength Property

PowerLanguage.NET Help

SwingLow.strength Property

public int strength { public get; public set; }

See Also

SwingLow Class | PowerLanguage.Function Namespace


SwingLow Methods

The methods of the SwingLow class are listed below. For a complete list of SwingLow class members, see the SwingLow Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingLow Class | PowerLanguage.Function Namespace


SwingLow.CalcBar Method

protected override double CalcBar();

See Also

SwingLow Class | PowerLanguage.Function Namespace


SwingLowBar Class

For a list of all members of this type, see SwingLowBar Members .

System.Object
CStudyControl
FunctionObject<Int32>
FunctionSimple<Int32>
SwingLowBar

[DefaultMember(MemberName="Item")]
public class SwingLowBar : FunctionSimple<int>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

SwingLowBar Members | PowerLanguage.Function Namespace


SwingLowBar Members

SwingLowBar overview

Public Instance Constructors

SwingLowBar Overloaded. Initializes a new instance of the SwingLowBar class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


SwingLowBar Constructor

Overload List

public SwingLowBar(CStudyControl)

public SwingLowBar(CStudyControl,int)

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


SwingLowBar Constructor

SwingLowBar(
CStudyControl ctx
);

See Also

SwingLowBar Class | PowerLanguage.Function Namespace | SwingLowBar Constructor Overload List


SwingLowBar Constructor

SwingLowBar(
CStudyControl ctx,
int data_stream
);

See Also

SwingLowBar Class | PowerLanguage.Function Namespace | SwingLowBar Constructor Overload List


SwingLowBar Properties

The properties of the SwingLowBar class are listed below. For a complete list of SwingLowBar class members, see the SwingLowBar Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
instance |
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
strength |
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


instance Property

PowerLanguage.NET Help

SwingLowBar.instance Property

public int instance { public get; public set; }

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

SwingLowBar.length Property

public int length { public get; public set; }

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

SwingLowBar.price Property

public ISeries<double> price { public get; public set; }

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


strength Property

PowerLanguage.NET Help

SwingLowBar.strength Property

public int strength { public get; public set; }

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


SwingLowBar Methods

The methods of the SwingLowBar class are listed below. For a complete list of SwingLowBar class members, see the SwingLowBar Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


SwingLowBar.CalcBar Method

protected override int CalcBar();

See Also

SwingLowBar Class | PowerLanguage.Function Namespace


TimeSeriesForecast Class

For a list of all members of this type, see TimeSeriesForecast Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
TimeSeriesForecast

[DefaultMember(MemberName="Item")]
public class TimeSeriesForecast : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

TimeSeriesForecast Members | PowerLanguage.Function Namespace


TimeSeriesForecast Members

TimeSeriesForecast overview

Public Instance Constructors

TimeSeriesForecast Overloaded. Initializes a new instance of the TimeSeriesForecast class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
tgtbar |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TimeSeriesForecast Constructor

Overload List

public TimeSeriesForecast(CStudyControl)

public TimeSeriesForecast(CStudyControl,int)

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TimeSeriesForecast Constructor

TimeSeriesForecast(
CStudyControl ctx
);

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace | TimeSeriesForecast Constructor Overload List


TimeSeriesForecast Constructor

TimeSeriesForecast(
CStudyControl ctx,
int data_stream
);

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace | TimeSeriesForecast Constructor Overload List


TimeSeriesForecast Properties

The properties of the TimeSeriesForecast class are listed below. For a complete list of TimeSeriesForecast class members, see the TimeSeriesForecast Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
tgtbar |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

TimeSeriesForecast.length Property

public int length { public get; public set; }

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


tgtbar Property

PowerLanguage.NET Help

TimeSeriesForecast.tgtbar Property

public int tgtbar { public get; public set; }

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TimeSeriesForecast Methods

The methods of the TimeSeriesForecast class are listed below. For a complete list of TimeSeriesForecast class members, see the TimeSeriesForecast Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TimeSeriesForecast.CalcBar Method

protected override double CalcBar();

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TimeSeriesForecast.Create Method

protected override void Create();

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TimeSeriesForecast.StartCalc Method

protected override void StartCalc();

See Also

TimeSeriesForecast Class | PowerLanguage.Function Namespace


TPOVAHighLow Class

For a list of all members of this type, see TPOVAHighLow Members .

System.Object
TPOVAHighLow

[Extension]
public static class TPOVAHighLow

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

TPOVAHighLow Members | PowerLanguage.Function Namespace


TPOVAHighLow Members

TPOVAHighLow overview

Public Static Methods

TPO_TotalBlocks |
TPO_VAHigh | Overloaded.
TPO_VAHighLow |
TPO_VALow | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace


TPOVAHighLow Methods

The methods of the TPOVAHighLow class are listed below. For a complete list of TPOVAHighLow class members, see the TPOVAHighLow Members topic.

Public Static Methods

TPO_TotalBlocks |
TPO_VAHigh | Overloaded.
TPO_VAHighLow |
TPO_VALow | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace


TPOVAHighLow.TPO_TotalBlocks Method

[Extension]
public static long TPO_TotalBlocks(
this IInstrumentTPO TPOBars,
this int _bb
);

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace


TPO_VAHigh Method

PowerLanguage.NET Help

TPOVAHighLow.TPO_VAHigh Method

Overload List

public static double TPO_VAHigh(this IInstrumentTPO,this int)

public static double TPO_VAHigh(this IInstrumentTPO,this int,this int)

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace


TPOVAHighLow.TPO_VAHigh(IInstrumentTPO, Int32) Method

[Extension]
public static double TPO_VAHigh(
this IInstrumentTPO TPOBars,
this int VAPercent
);

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace | TPOVAHighLow.TPO_VAHigh Overload List


TPOVAHighLow.TPO_VAHigh(IInstrumentTPO, Int32, Int32) Method

[Extension]
public static double TPO_VAHigh(
this IInstrumentTPO TPOBars,
this int VAPercent,
this int _bb
);

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace | TPOVAHighLow.TPO_VAHigh Overload List


TPOVAHighLow.TPO_VAHighLow Method

[Extension]
public static bool TPO_VAHighLow(
this IInstrumentTPO TPOBars,
this int VAPercent,
this int _bb,
this ref double VAHigh,
this ref double VALow
);

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace


TPO_VALow Method

PowerLanguage.NET Help

TPOVAHighLow.TPO_VALow Method

Overload List

public static double TPO_VALow(this IInstrumentTPO,this int)

public static double TPO_VALow(this IInstrumentTPO,this int,this int)

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace


TPOVAHighLow.TPO_VALow(IInstrumentTPO, Int32) Method

[Extension]
public static double TPO_VALow(
this IInstrumentTPO TPOBars,
this int VAPercent
);

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace | TPOVAHighLow.TPO_VALow Overload List


TPOVAHighLow.TPO_VALow(IInstrumentTPO, Int32, Int32) Method

[Extension]
public static double TPO_VALow(
this IInstrumentTPO TPOBars,
this int VAPercent,
this int _bb
);

See Also

TPOVAHighLow Class | PowerLanguage.Function Namespace | TPOVAHighLow.TPO_VALow Overload List


TriAverage Class

For a list of all members of this type, see TriAverage Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
TriAverage

[DefaultMember(MemberName="Item")]
public class TriAverage : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

TriAverage Members | PowerLanguage.Function Namespace


TriAverage Members

TriAverage overview

Public Instance Constructors

TriAverage Overloaded. Initializes a new instance of the TriAverage class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

TriAverage Class | PowerLanguage.Function Namespace


TriAverage Constructor

Overload List

public TriAverage(CStudyControl)

public TriAverage(CStudyControl,int)

See Also

TriAverage Class | PowerLanguage.Function Namespace


TriAverage Constructor

TriAverage(
CStudyControl ctx
);

See Also

TriAverage Class | PowerLanguage.Function Namespace | TriAverage Constructor Overload List


TriAverage Constructor

TriAverage(
CStudyControl ctx,
int data_stream
);

See Also

TriAverage Class | PowerLanguage.Function Namespace | TriAverage Constructor Overload List


TriAverage Properties

The properties of the TriAverage class are listed below. For a complete list of TriAverage class members, see the TriAverage Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

TriAverage Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

TriAverage.length Property

public int length { public get; public set; }

See Also

TriAverage Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

TriAverage.price Property

public ISeries<double> price { public get; public set; }

See Also

TriAverage Class | PowerLanguage.Function Namespace


TriAverage Methods

The methods of the TriAverage class are listed below. For a complete list of TriAverage class members, see the TriAverage Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

TriAverage Class | PowerLanguage.Function Namespace


TriAverage.CalcBar Method

protected override double CalcBar();

See Also

TriAverage Class | PowerLanguage.Function Namespace


TriAverage.StartCalc Method

protected override void StartCalc();

See Also

TriAverage Class | PowerLanguage.Function Namespace


TRIX Class

For a list of all members of this type, see TRIX Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
TRIX

[DefaultMember(MemberName="Item")]
public class TRIX : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

TRIX Members | PowerLanguage.Function Namespace


TRIX Members

TRIX overview

Public Instance Constructors

TRIX Overloaded. Initializes a new instance of the TRIX class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

TRIX Class | PowerLanguage.Function Namespace


TRIX Constructor

Overload List

public TRIX(CStudyControl)

public TRIX(CStudyControl,int)

See Also

TRIX Class | PowerLanguage.Function Namespace


TRIX Constructor

TRIX(
CStudyControl ctx
);

See Also

TRIX Class | PowerLanguage.Function Namespace | TRIX Constructor Overload List


TRIX Constructor

TRIX(
CStudyControl ctx,
int data_stream
);

See Also

TRIX Class | PowerLanguage.Function Namespace | TRIX Constructor Overload List


TRIX Properties

The properties of the TRIX class are listed below. For a complete list of TRIX class members, see the TRIX Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

TRIX Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

TRIX.length Property

public int length { public get; public set; }

See Also

TRIX Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

TRIX.price Property

public ISeries<double> price { public get; public set; }

See Also

TRIX Class | PowerLanguage.Function Namespace


TRIX Methods

The methods of the TRIX class are listed below. For a complete list of TRIX class members, see the TRIX Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

TRIX Class | PowerLanguage.Function Namespace


TRIX.CalcBar Method

protected override double CalcBar();

See Also

TRIX Class | PowerLanguage.Function Namespace


TRIX.Create Method

protected override void Create();

See Also

TRIX Class | PowerLanguage.Function Namespace


TRIX.StartCalc Method

protected override void StartCalc();

See Also

TRIX Class | PowerLanguage.Function Namespace


UltimateOscillator Class

For a list of all members of this type, see UltimateOscillator Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
UltimateOscillator

[DefaultMember(MemberName="Item")]
public class UltimateOscillator : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

UltimateOscillator Members | PowerLanguage.Function Namespace


UltimateOscillator Members

UltimateOscillator overview

Public Instance Constructors

UltimateOscillator Overloaded. Initializes a new instance of the UltimateOscillator class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
longlength |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
middllength |
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
shortlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


UltimateOscillator Constructor

Overload List

public UltimateOscillator(CStudyControl)

public UltimateOscillator(CStudyControl,int)

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


UltimateOscillator Constructor

UltimateOscillator(
CStudyControl ctx
);

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace | UltimateOscillator Constructor Overload List


UltimateOscillator Constructor

UltimateOscillator(
CStudyControl ctx,
int data_stream
);

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace | UltimateOscillator Constructor Overload List


UltimateOscillator Properties

The properties of the UltimateOscillator class are listed below. For a complete list of UltimateOscillator class members, see the UltimateOscillator Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
longlength |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
middllength |
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
shortlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


longlength Property

PowerLanguage.NET Help

UltimateOscillator.longlength Property

public int longlength { public get; public set; }

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


middllength Property

PowerLanguage.NET Help

UltimateOscillator.middllength Property

public int middllength { public get; public set; }

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


shortlength Property

PowerLanguage.NET Help

UltimateOscillator.shortlength Property

public int shortlength { public get; public set; }

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


UltimateOscillator Methods

The methods of the UltimateOscillator class are listed below. For a complete list of UltimateOscillator class members, see the UltimateOscillator Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


UltimateOscillator.CalcBar Method

protected override double CalcBar();

See Also

UltimateOscillator Class | PowerLanguage.Function Namespace


Volatility Class

For a list of all members of this type, see Volatility Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
Volatility

[DefaultMember(MemberName="Item")]
public class Volatility : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

Volatility Members | PowerLanguage.Function Namespace


Volatility Members

Volatility overview

Public Instance Constructors

Volatility Overloaded. Initializes a new instance of the Volatility class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

Volatility Class | PowerLanguage.Function Namespace


Volatility Constructor

Overload List

public Volatility(CStudyControl)

public Volatility(CStudyControl,int)

See Also

Volatility Class | PowerLanguage.Function Namespace


Volatility Constructor

Volatility(
CStudyControl ctx
);

See Also

Volatility Class | PowerLanguage.Function Namespace | Volatility Constructor Overload List


Volatility Constructor

Volatility(
CStudyControl ctx,
int data_stream
);

See Also

Volatility Class | PowerLanguage.Function Namespace | Volatility Constructor Overload List


Volatility Properties

The properties of the Volatility class are listed below. For a complete list of Volatility class members, see the Volatility Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

Volatility Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

Volatility.length Property

public int length { public get; public set; }

See Also

Volatility Class | PowerLanguage.Function Namespace


Volatility Methods

The methods of the Volatility class are listed below. For a complete list of Volatility class members, see the Volatility Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

Volatility Class | PowerLanguage.Function Namespace


Volatility.CalcBar Method

protected override double CalcBar();

See Also

Volatility Class | PowerLanguage.Function Namespace


Volatility.Create Method

protected override void Create();

See Also

Volatility Class | PowerLanguage.Function Namespace


Volatility.StartCalc Method

protected override void StartCalc();

See Also

Volatility Class | PowerLanguage.Function Namespace


VolatilityStdDev Class

For a list of all members of this type, see VolatilityStdDev Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
VolatilityStdDev

[DefaultMember(MemberName="Item")]
public class VolatilityStdDev : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

VolatilityStdDev Members | PowerLanguage.Function Namespace


VolatilityStdDev Members

VolatilityStdDev overview

Public Instance Constructors

VolatilityStdDev Overloaded. Initializes a new instance of the VolatilityStdDev class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace


VolatilityStdDev Constructor

Overload List

public VolatilityStdDev(CStudyControl)

public VolatilityStdDev(CStudyControl,int)

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace


VolatilityStdDev Constructor

VolatilityStdDev(
CStudyControl ctx
);

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace | VolatilityStdDev Constructor Overload List


VolatilityStdDev Constructor

VolatilityStdDev(
CStudyControl ctx,
int data_stream
);

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace | VolatilityStdDev Constructor Overload List


VolatilityStdDev Properties

The properties of the VolatilityStdDev class are listed below. For a complete list of VolatilityStdDev class members, see the VolatilityStdDev Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
numdays |
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace


numdays Property

PowerLanguage.NET Help

VolatilityStdDev.numdays Property

public int numdays { public get; public set; }

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace


VolatilityStdDev Methods

The methods of the VolatilityStdDev class are listed below. For a complete list of VolatilityStdDev class members, see the VolatilityStdDev Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace


VolatilityStdDev.CalcBar Method

protected override double CalcBar();

See Also

VolatilityStdDev Class | PowerLanguage.Function Namespace


VolumeOsc Class

For a list of all members of this type, see VolumeOsc Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
VolumeOsc

[DefaultMember(MemberName="Item")]
public class VolumeOsc : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

VolumeOsc Members | PowerLanguage.Function Namespace


VolumeOsc Members

VolumeOsc overview

Public Instance Constructors

VolumeOsc Overloaded. Initializes a new instance of the VolumeOsc class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastlength |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
slowlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


VolumeOsc Constructor

Overload List

public VolumeOsc(CStudyControl)

public VolumeOsc(CStudyControl,int)

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


VolumeOsc Constructor

VolumeOsc(
CStudyControl ctx
);

See Also

VolumeOsc Class | PowerLanguage.Function Namespace | VolumeOsc Constructor Overload List


VolumeOsc Constructor

VolumeOsc(
CStudyControl ctx,
int data_stream
);

See Also

VolumeOsc Class | PowerLanguage.Function Namespace | VolumeOsc Constructor Overload List


VolumeOsc Properties

The properties of the VolumeOsc class are listed below. For a complete list of VolumeOsc class members, see the VolumeOsc Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
fastlength |
Item (inherited from FunctionSimple) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
slowlength |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


fastlength Property

PowerLanguage.NET Help

VolumeOsc.fastlength Property

public int fastlength { public get; public set; }

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


slowlength Property

PowerLanguage.NET Help

VolumeOsc.slowlength Property

public int slowlength { public get; public set; }

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


VolumeOsc Methods

The methods of the VolumeOsc class are listed below. For a complete list of VolumeOsc class members, see the VolumeOsc Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


VolumeOsc.CalcBar Method

protected override double CalcBar();

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


VolumeOsc.Create Method

protected override void Create();

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


VolumeOsc.StartCalc Method

protected override void StartCalc();

See Also

VolumeOsc Class | PowerLanguage.Function Namespace


vwapResettable Class

For a list of all members of this type, see vwapResettable Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSimple<Double>
vwapResettable

[DefaultMember(MemberName="Item")]
public class vwapResettable : FunctionSimple<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

vwapResettable Members | PowerLanguage.Function Namespace


vwapResettable Members

vwapResettable overview

Public Instance Constructors

vwapResettable Overloaded. Initializes a new instance of the vwapResettable class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
localhrsoffset |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
time1 |
time2 |
time3 |
time4 |
time5 |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

vwapResettable Class | PowerLanguage.Function Namespace


vwapResettable Constructor

Overload List

public vwapResettable(CStudyControl)

public vwapResettable(CStudyControl,int)

See Also

vwapResettable Class | PowerLanguage.Function Namespace


vwapResettable Constructor

vwapResettable(
CStudyControl ctx
);

See Also

vwapResettable Class | PowerLanguage.Function Namespace | vwapResettable Constructor Overload List


vwapResettable Constructor

vwapResettable(
CStudyControl ctx,
int data_stream
);

See Also

vwapResettable Class | PowerLanguage.Function Namespace | vwapResettable Constructor Overload List


vwapResettable Properties

The properties of the vwapResettable class are listed below. For a complete list of vwapResettable class members, see the vwapResettable Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSimple) |
localhrsoffset |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
time1 |
time2 |
time3 |
time4 |
time5 |
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

vwapResettable Class | PowerLanguage.Function Namespace


localhrsoffset Property

PowerLanguage.NET Help

vwapResettable.localhrsoffset Property

public int localhrsoffset { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

vwapResettable.price Property

public ISeries<double> price { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


time1 Property

PowerLanguage.NET Help

vwapResettable.time1 Property

public DateTime time1 { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


time2 Property

PowerLanguage.NET Help

vwapResettable.time2 Property

public DateTime time2 { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


time3 Property

PowerLanguage.NET Help

vwapResettable.time3 Property

public DateTime time3 { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


time4 Property

PowerLanguage.NET Help

vwapResettable.time4 Property

public DateTime time4 { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


time5 Property

PowerLanguage.NET Help

vwapResettable.time5 Property

public DateTime time5 { public get; public set; }

See Also

vwapResettable Class | PowerLanguage.Function Namespace


vwapResettable Methods

The methods of the vwapResettable class are listed below. For a complete list of vwapResettable class members, see the vwapResettable Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
Create |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSimple) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

vwapResettable Class | PowerLanguage.Function Namespace


vwapResettable.CalcBar Method

protected override double CalcBar();

See Also

vwapResettable Class | PowerLanguage.Function Namespace


vwapResettable.Create Method

protected override void Create();

See Also

vwapResettable Class | PowerLanguage.Function Namespace


XAverage Class

For a list of all members of this type, see XAverage Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
XAverage

[DefaultMember(MemberName="Item")]
public sealed class XAverage : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

XAverage Members | PowerLanguage.Function Namespace


XAverage Members

XAverage overview

Public Instance Constructors

XAverage Overloaded. Initializes a new instance of the XAverage class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

Private Instance Properties

Length
Price

See Also

XAverage Class | PowerLanguage.Function Namespace


XAverage Constructor

Overload List

public XAverage(CStudyControl)

public XAverage(CStudyControl,int)

See Also

XAverage Class | PowerLanguage.Function Namespace


XAverage Constructor

XAverage(
CStudyControl _master
);

See Also

XAverage Class | PowerLanguage.Function Namespace | XAverage Constructor Overload List


XAverage Constructor

XAverage(
CStudyControl _master,
int _ds
);

See Also

XAverage Class | PowerLanguage.Function Namespace | XAverage Constructor Overload List


XAverage Properties

The properties of the XAverage class are listed below. For a complete list of XAverage class members, see the XAverage Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Private Instance Properties

Length
Price

See Also

XAverage Class | PowerLanguage.Function Namespace


Length Property

PowerLanguage.NET Help

XAverage.Length Property

private int Length { private get; public set; }

See Also

XAverage Class | PowerLanguage.Function Namespace


Price Property

PowerLanguage.NET Help

XAverage.Price Property

private ISeries<double> Price { private get; public set; }

See Also

XAverage Class | PowerLanguage.Function Namespace


XAverage Methods

The methods of the XAverage class are listed below. For a complete list of XAverage class members, see the XAverage Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

XAverage Class | PowerLanguage.Function Namespace


XAverage.CalcBar Method

protected override double CalcBar();

See Also

XAverage Class | PowerLanguage.Function Namespace


XAverageOrig Class

For a list of all members of this type, see XAverageOrig Members .

System.Object
CStudyControl
FunctionObject<Double>
FunctionSeries<Double>
XAverageOrig

[DefaultMember(MemberName="Item")]
public class XAverageOrig : FunctionSeries<double>

Requirements

Namespace: PowerLanguage.Function

Assembly: PLBuiltInFunctions (in PLBuiltInFunctions.dll)

See Also

XAverageOrig Members | PowerLanguage.Function Namespace


XAverageOrig Members

XAverageOrig overview

Public Instance Constructors

XAverageOrig Overloaded. Initializes a new instance of the XAverageOrig class.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


XAverageOrig Constructor

Overload List

public XAverageOrig(CStudyControl)

public XAverageOrig(CStudyControl,int)

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


XAverageOrig Constructor

XAverageOrig(
CStudyControl ctx
);

See Also

XAverageOrig Class | PowerLanguage.Function Namespace | XAverageOrig Constructor Overload List


XAverageOrig Constructor

XAverageOrig(
CStudyControl ctx,
int data_stream
);

See Also

XAverageOrig Class | PowerLanguage.Function Namespace | XAverageOrig Constructor Overload List


XAverageOrig Properties

The properties of the XAverageOrig class are listed below. For a complete list of XAverageOrig class members, see the XAverageOrig Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
Item (inherited from FunctionSeries) |
length |
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
price |
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
Value (inherited from FunctionObject) | Read-only property. Returns a reference to the curent bar.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

MyStrategy (inherited from FunctionObject) Read-only property. Returns a reference to the current strategy.

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


length Property

PowerLanguage.NET Help

XAverageOrig.length Property

public int length { public get; public set; }

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


price Property

PowerLanguage.NET Help

XAverageOrig.price Property

public ISeries<double> price { public get; public set; }

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


XAverageOrig Methods

The methods of the XAverageOrig class are listed below. For a complete list of XAverageOrig class members, see the XAverageOrig Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Call (inherited from FunctionObject) | Overloaded. Returns a reference to the curent bar.
DoDestroy (inherited from FunctionObject) |
DoInitializeVars (inherited from FunctionObject) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
CalcBar |
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Dispose (inherited from FunctionSeries) |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
StartCalc |

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


XAverageOrig.CalcBar Method

protected override double CalcBar();

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


XAverageOrig.StartCalc Method

protected override void StartCalc();

See Also

XAverageOrig Class | PowerLanguage.Function Namespace


PowerLanguage.Indicator

PowerLanguage.NET Help

PowerLanguage.Indicator Namespace

Namespace Hierarchy

Classes

Class | Description
IndicatorObject | Indicator’s base class (inherit from this class to create an indicator).


IndicatorObject Class

Indicator’s base class (inherit from this class to create an indicator).

For a list of all members of this type, see IndicatorObject Members .

System.Object
CStudyControl
CStudyAbstract
IndicatorObject

public abstract class IndicatorObject : CStudyAbstract, IIndicatorInfo

Requirements

Namespace: PowerLanguage.Indicator

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

IndicatorObject Members | PowerLanguage.Indicator Namespace


IndicatorObject Members

IndicatorObject overview

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
Plots | Read-only property. Returns indicator’s existing plots list.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetDataStream (inherited from CStudyAbstract) |
GetHashCode (inherited from Object) |
GetInputs (inherited from CStudyAbstract) |
GetInputValue (inherited from CStudyAbstract) |
GetMouseEvents (inherited from CStudyAbstract) |
GetRecoverDrawings (inherited from CStudyAbstract) |
GetSameAsSymbol |
GetSkipIdenticalTicks |
GetType (inherited from Object) |
GetUpdateOnEveryTick |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue (inherited from CStudyAbstract) |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Constructors

IndicatorObject Constructor Initializes a new instance of the IndicatorObject class.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
AddIndicator (inherited from CStudyAbstract) | Overloaded.
AddPlot | Overloaded. A method for a string plot adding with 'info' parameters.
CalcBar (inherited from CStudyAbstract) | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create (inherited from CStudyAbstract) | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy (inherited from CStudyAbstract) | This method is called once when the study is removed from the chart(scanner).
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
OnBrokerPositionChange (inherited from CStudyAbstract) | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent (inherited from CStudyAbstract) | Allows control of mouse-click events on the chart.
OnOrderRejected (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent (inherited from CStudyAbstract) | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent (inherited from CStudyAbstract) | Event that happens after the Close Position button is pressed in Portfolio Trader
StartCalc (inherited from CStudyAbstract) | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc (inherited from CStudyAbstract) | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject Constructor

Initializes a new instance of the IndicatorObject class.

IndicatorObject(
object _ctx
);

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject Properties

The properties of the IndicatorObject class are listed below. For a complete list of IndicatorObject class members, see the IndicatorObject Members topic.

Public Instance Properties

Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
Name (inherited from CStudyControl) | Read-only property. Returns name.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
Plots | Read-only property. Returns indicator’s existing plots list.
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


Plots Property

PowerLanguage.NET Help

IndicatorObject.Plots Property

Read-only property. Returns indicator’s existing plots list.

public IList<IPlotObject> Plots { public get; }

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject Methods

The methods of the IndicatorObject class are listed below. For a complete list of IndicatorObject class members, see the IndicatorObject Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetDataStream (inherited from CStudyAbstract) |
GetHashCode (inherited from Object) |
GetInputs (inherited from CStudyAbstract) |
GetInputValue (inherited from CStudyAbstract) |
GetMouseEvents (inherited from CStudyAbstract) |
GetRecoverDrawings (inherited from CStudyAbstract) |
GetSameAsSymbol |
GetSkipIdenticalTicks |
GetType (inherited from Object) |
GetUpdateOnEveryTick |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue (inherited from CStudyAbstract) |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl) |
AddIndicator (inherited from CStudyAbstract) | Overloaded.
AddPlot | Overloaded. A method for a string plot adding with 'info' parameters.
CalcBar (inherited from CStudyAbstract) | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create (inherited from CStudyAbstract) | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy (inherited from CStudyAbstract) | This method is called once when the study is removed from the chart(scanner).
Dispose |
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
OnBrokerPositionChange (inherited from CStudyAbstract) | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent (inherited from CStudyAbstract) | Allows control of mouse-click events on the chart.
OnOrderRejected (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent (inherited from CStudyAbstract) | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent (inherited from CStudyAbstract) | Event that happens after the Close Position button is pressed in Portfolio Trader
StartCalc (inherited from CStudyAbstract) | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc (inherited from CStudyAbstract) | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


AddPlot Method

PowerLanguage.NET Help

IndicatorObject.AddPlot Method

A method for a plot adding.

Overload List

A method for a plot adding.

protected IPlotObject AddPlot()

A method for a plot adding with 'info' parameters.

protected IPlotObject AddPlot(PlotAttributes)

A method for a string plot adding with 'info' parameters.

protected IPlotObjectStr AddPlot(StringPlotAttributes)

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject.AddPlot() Method

A method for a plot adding.

protected IPlotObject AddPlot();

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace | IndicatorObject.AddPlot Overload List


IndicatorObject.AddPlot(PlotAttributes) Method

A method for a plot adding with 'info' parameters.

protected IPlotObject AddPlot(
PlotAttributes info
);

Parameters

info
Specifies attributes for the new plot object.

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace | IndicatorObject.AddPlot Overload List | PlotAttributes


IndicatorObject.AddPlot(StringPlotAttributes) Method

A method for a string plot adding with 'info' parameters.

protected IPlotObjectStr AddPlot(
StringPlotAttributes info
);

Parameters

info
Specifies attributes for the new plot object.

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace | IndicatorObject.AddPlot Overload List | StringPlotAttributes


IndicatorObject.Dispose Method

[HandleProcessCorruptedStateExceptions]
protected override void Dispose(
bool A_0
);

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject.GetSameAsSymbol Method

public override bool? GetSameAsSymbol();

Implements

IIndicatorInfo.GetSameAsSymbol

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject.GetSkipIdenticalTicks Method

public override bool? GetSkipIdenticalTicks();

Implements

IIndicatorInfo.GetSkipIdenticalTicks

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


IndicatorObject.GetUpdateOnEveryTick Method

public override bool? GetUpdateOnEveryTick();

Implements

IIndicatorInfo.GetUpdateOnEveryTick

See Also

IndicatorObject Class | PowerLanguage.Indicator Namespace


PowerLanguage.Strategy

PowerLanguage.NET Help

PowerLanguage.Strategy Namespace

Namespace Hierarchy

Classes

Class | Description
PortfolioSignalObject |
SignalObject | Base class for strategies (inherit from SignalObject to create this kind of study).

Interfaces

Interface | Description
IPortfolio | Allows signals to interact with each other and with MultiCharts Portfolio Trader.
IPortfolioData | Allows strategies to access and operate data between each other in MultiCharts Portfolio Trader.
IPortfolioStrategy | Allows access to strategy applied to specific traded symbol.


IPortfolio Interface

Allows signals to interact with each other and with MultiCharts Portfolio Trader.

For a list of all members of this type, see IPortfolio Members .

public interface IPortfolio

Types that implement IPortfolio

Type | Description
PortfolioSignalObject |

Requirements

Namespace: PowerLanguage.Strategy

Assembly: PLTypes (in PLTypes.dll)

See Also

IPortfolio Members | PowerLanguage.Strategy Namespace


IPortfolio Members

IPortfolio overview

Public Instance Properties

CommonPortfolioData | Allows access to common variables in MultiCharts Portfolio Trader.
MyPortfolioData | Allows access to variables of the current strategy.
PortfolioCurrency | Allows access to currency of the account.
PortfolioStrategies | Allows access to all strategies.

See Also

IPortfolio Interface | PowerLanguage.Strategy Namespace


IPortfolio Properties

The properties of the IPortfolio interface are listed below. For a complete list of IPortfolio interface members, see the IPortfolio Members topic.

Public Instance Properties

CommonPortfolioData | Allows access to common variables in MultiCharts Portfolio Trader.
MyPortfolioData | Allows access to variables of the current strategy.
PortfolioCurrency | Allows access to currency of the account.
PortfolioStrategies | Allows access to all strategies.

See Also

IPortfolio Interface | PowerLanguage.Strategy Namespace


CommonPortfolioData Property

PowerLanguage.NET Help

IPortfolio.CommonPortfolioData Property

Allows access to common variables in MultiCharts Portfolio Trader.

public IPortfolioData CommonPortfolioData { public get; }

See Also

IPortfolio Interface | PowerLanguage.Strategy Namespace


MyPortfolioData Property

PowerLanguage.NET Help

IPortfolio.MyPortfolioData Property

Allows access to variables of the current strategy.

public IPortfolioData MyPortfolioData { public get; }

See Also

IPortfolio Interface | PowerLanguage.Strategy Namespace


PortfolioCurrency Property

PowerLanguage.NET Help

IPortfolio.PortfolioCurrency Property

Allows access to currency of the account.

public MTPA_MCSymbolCurrency PortfolioCurrency { public get; }

See Also

IPortfolio Interface | PowerLanguage.Strategy Namespace


PortfolioStrategies Property

PowerLanguage.NET Help

IPortfolio.PortfolioStrategies Property

Allows access to all strategies.

public IROList<IPortfolioStrategy> PortfolioStrategies { public get; }

See Also

IPortfolio Interface | PowerLanguage.Strategy Namespace


IPortfolioData Interface

Allows strategies to access and operate data between each other in MultiCharts Portfolio Trader.

For a list of all members of this type, see IPortfolioData Members .

[DefaultMember(MemberName="Item")]
public interface IPortfolioData

Requirements

Namespace: PowerLanguage.Strategy

Assembly: PLTypes (in PLTypes.dll)

See Also

IPortfolioData Members | PowerLanguage.Strategy Namespace


IPortfolioData Members

IPortfolioData overview

Public Instance Properties

Item Indexer for data objects.

Public Instance Methods

ContainsKey Returns true if variable exists, otherwise false.

See Also

IPortfolioData Interface | PowerLanguage.Strategy Namespace


IPortfolioData Properties

The properties of the IPortfolioData interface are listed below. For a complete list of IPortfolioData interface members, see the IPortfolioData Members topic.

Public Instance Properties

Item Indexer for data objects.

See Also

IPortfolioData Interface | PowerLanguage.Strategy Namespace


Item Property

PowerLanguage.NET Help

IPortfolioData.Item Property

Indexer for data objects.

public object this[
string name
] { public get; public set; }

See Also

IPortfolioData Interface | PowerLanguage.Strategy Namespace


IPortfolioData Methods

The methods of the IPortfolioData interface are listed below. For a complete list of IPortfolioData interface members, see the IPortfolioData Members topic.

Public Instance Methods

ContainsKey Returns true if variable exists, otherwise false.

See Also

IPortfolioData Interface | PowerLanguage.Strategy Namespace


IPortfolioData.ContainsKey Method

Returns true if variable exists, otherwise false.

bool ContainsKey(
string name
);

Parameters

name
Variable name

Return Value

See Also

IPortfolioData Interface | PowerLanguage.Strategy Namespace


IPortfolioStrategy Interface

Allows access to strategy applied to specific traded symbol.

For a list of all members of this type, see IPortfolioStrategy Members .

public interface IPortfolioStrategy : IDisposable

Requirements

Namespace: PowerLanguage.Strategy

Assembly: PLTypes (in PLTypes.dll)

See Also

IPortfolioStrategy Members | PowerLanguage.Strategy Namespace


IPortfolioStrategy Members

IPortfolioStrategy overview

Public Instance Properties

AllowEntries | Allows/forbids entry order placement.
AllowEntriesLong | Allows/forbids long entry order placement.
AllowEntriesShort | Allows/forbids short entry order placement.
AllowExits | Allows/forbids exit order placement.
AllowExitsLong | Allows/forbids long exit order placement.
AllowExitsShort | Allows/forbids short exit order placement.
EntryContracts | Returns/set the number of contracts to open market position. Allowed values: 1) Less than "0" - not set. The number of contracts specified in code for each order is used. 2) "0" - default value. The number of contracts specified in Strategy Properties is used, no matter what number of contracts is specified for each order in code and in the Strategy Properties. 3) More than "0" - the set value is used for every entry, no matter what number of contracts is specified for each order in code and in the Strategy Properties.
MyIndex | Returns index of the strategy in portfolio.
Paused | Allows/forbids order placement.
PortfolioData | Allows access to variables of the strategy.
RiskCapital | Returns the amount of capital in currency of the account that is taken by the strategy for marginal security (maximum loss).
Signals | Returns collection of the signals, which form the strategy.
Status | Text message that is displayed in the "Custom Text" column of Portfolio Real-Time Window.

Public Instance Methods

ForceClosePosition | Forced closing of open market position.
PartialClosePosition | Partial closing of open market position.

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


IPortfolioStrategy Properties

The properties of the IPortfolioStrategy interface are listed below. For a complete list of IPortfolioStrategy interface members, see the IPortfolioStrategy Members topic.

Public Instance Properties

AllowEntries | Allows/forbids entry order placement.
AllowEntriesLong | Allows/forbids long entry order placement.
AllowEntriesShort | Allows/forbids short entry order placement.
AllowExits | Allows/forbids exit order placement.
AllowExitsLong | Allows/forbids long exit order placement.
AllowExitsShort | Allows/forbids short exit order placement.
EntryContracts | Returns/set the number of contracts to open market position. Allowed values: 1) Less than "0" - not set. The number of contracts specified in code for each order is used. 2) "0" - default value. The number of contracts specified in Strategy Properties is used, no matter what number of contracts is specified for each order in code and in the Strategy Properties. 3) More than "0" - the set value is used for every entry, no matter what number of contracts is specified for each order in code and in the Strategy Properties.
MyIndex | Returns index of the strategy in portfolio.
Paused | Allows/forbids order placement.
PortfolioData | Allows access to variables of the strategy.
RiskCapital | Returns the amount of capital in currency of the account that is taken by the strategy for marginal security (maximum loss).
Signals | Returns collection of the signals, which form the strategy.
Status | Text message that is displayed in the "Custom Text" column of Portfolio Real-Time Window.

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


AllowEntries Property

PowerLanguage.NET Help

IPortfolioStrategy.AllowEntries Property

Allows/forbids entry order placement.

public bool AllowEntries { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


AllowEntriesLong Property

PowerLanguage.NET Help

IPortfolioStrategy.AllowEntriesLong Property

Allows/forbids long entry order placement.

public bool AllowEntriesLong { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


AllowEntriesShort Property

PowerLanguage.NET Help

IPortfolioStrategy.AllowEntriesShort Property

Allows/forbids short entry order placement.

public bool AllowEntriesShort { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


AllowExits Property

PowerLanguage.NET Help

IPortfolioStrategy.AllowExits Property

Allows/forbids exit order placement.

public bool AllowExits { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


AllowExitsLong Property

PowerLanguage.NET Help

IPortfolioStrategy.AllowExitsLong Property

Allows/forbids long exit order placement.

public bool AllowExitsLong { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


AllowExitsShort Property

PowerLanguage.NET Help

IPortfolioStrategy.AllowExitsShort Property

Allows/forbids short exit order placement.

public bool AllowExitsShort { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


EntryContracts Property

PowerLanguage.NET Help

IPortfolioStrategy.EntryContracts Property

Returns/set the number of contracts to open market position. Allowed values: 1) Less than "0" - not set. The number of contracts specified in code for each order is used. 2) "0" - default value. The number of contracts specified in Strategy Properties is used, no matter what number of contracts is specified for each order in code and in the Strategy Properties. 3) More than "0" - the set value is used for every entry, no matter what number of contracts is specified for each order in code and in the Strategy Properties.

public int EntryContracts { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


MyIndex Property

PowerLanguage.NET Help

IPortfolioStrategy.MyIndex Property

Returns index of the strategy in portfolio.

public int MyIndex { public get; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


Paused Property

PowerLanguage.NET Help

IPortfolioStrategy.Paused Property

Allows/forbids order placement.

public bool Paused { public get; public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


PortfolioData Property

PowerLanguage.NET Help

IPortfolioStrategy.PortfolioData Property

Allows access to variables of the strategy.

public IPortfolioData PortfolioData { public get; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


RiskCapital Property

PowerLanguage.NET Help

IPortfolioStrategy.RiskCapital Property

Returns the amount of capital in currency of the account that is taken by the strategy for marginal security (maximum loss).

public double RiskCapital { public get; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


Signals Property

PowerLanguage.NET Help

IPortfolioStrategy.Signals Property

Returns collection of the signals, which form the strategy.

public IStrategy[] Signals { public get; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


Status Property

PowerLanguage.NET Help

IPortfolioStrategy.Status Property

Text message that is displayed in the "Custom Text" column of Portfolio Real-Time Window.

public string Status { public set; }

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


IPortfolioStrategy Methods

The methods of the IPortfolioStrategy interface are listed below. For a complete list of IPortfolioStrategy interface members, see the IPortfolioStrategy Members topic.

Public Instance Methods

ForceClosePosition | Forced closing of open market position.
PartialClosePosition | Partial closing of open market position.

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


IPortfolioStrategy.ForceClosePosition Method

Forced closing of open market position.

void ForceClosePosition();

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


IPortfolioStrategy.PartialClosePosition Method

Partial closing of open market position.

void PartialClosePosition(
bool isNextBar,
int contracts
);

See Also

IPortfolioStrategy Interface | PowerLanguage.Strategy Namespace


PortfolioSignalObject Class

For a list of all members of this type, see PortfolioSignalObject Members .

System.Object
CStudyControl
CStudyAbstract
SignalObject
PortfolioSignalObject

public abstract class PortfolioSignalObject : SignalObject, IPortfolio

Requirements

Namespace: PowerLanguage.Strategy

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

PortfolioSignalObject Members | PowerLanguage.Strategy Namespace


PortfolioSignalObject Members

PortfolioSignalObject overview

Public Instance Properties

Account (inherited from SignalObject) | Returns current account name.
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
AvgBarsEvenTrade (inherited from SignalObject) | Returns the average length of even trades (without profit and loss) in terms of bars.
AvgBarsLosTrade (inherited from SignalObject) | Returns the average length of losing trades in terms of bars.
AvgBarsWinTrade (inherited from SignalObject) | Returns the average length of winning trades in terms of bars.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
Commission (inherited from SignalObject) | Returns 'Commission' from the Strategy Properties window.
CommonPortfolioData |
CurrentPosition (inherited from SignalObject) | Returns strategy's current position.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
GrossLoss (inherited from SignalObject) | Returns a non-positive number that indicates total strategy loss.
GrossProfit (inherited from SignalObject) | Returns non-negative number that indicates total strategy profit.
InitialCapital (inherited from SignalObject) | Returns 'Initial Capital' from the Strategy Properties window.
InterestRate (inherited from SignalObject) | Returns 'Interest Rate' from the Strategy Properties window.
LargestLosTrade (inherited from SignalObject) | Returns non-positive number with the maximum loss of a single trade.
LargestWinTrade (inherited from SignalObject) | Returns non-negative number with maximum profit of a single trade.
MaxConsecLosers (inherited from SignalObject) | Returns maximum number of sequential unprofitable trades.
MaxConsecWinners (inherited from SignalObject) | Returns maximum number of sequential profitable trades.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
MaxDrawDown (inherited from SignalObject) | Returns maximum potential loss (drawdown) during entire trading period.
MaxLotsHeld (inherited from SignalObject) | Returns maximal number of sequential unprofitable trades.
MyPortfolioData |
Name (inherited from CStudyControl) | Read-only property. Returns name.
NetProfit (inherited from SignalObject) | Returns strategy's fixed net profit.
NumEvenTrades (inherited from SignalObject) | Returns total number of trades that did not bring any profit or loss.
NumLosTrades (inherited from SignalObject) | Returns total number or losing trades.
NumWinTrades (inherited from SignalObject) | Returns total number or profitable trades.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PercentProfit (inherited from SignalObject) | Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
Portfolio (inherited from SignalObject) | Returns the interface which provides Portfolio Perfomance.
PortfolioCurrency |
PortfolioStrategies |
Positions (inherited from SignalObject) | Returns a read-only collection of all strategy positions.
PositionSide (inherited from SignalObject) | Returns strategy's market position.
Profile (inherited from SignalObject) | Returns current trading profile name.
Slippage (inherited from SignalObject) | Returns 'Slippage' from the Strategy Properties window.
StrategyCurrencyCode (inherited from SignalObject) | Returns currency code from Strategy settings (Base Currency)
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TotalBarsEvenTrades (inherited from SignalObject) | Returns the total number of bars during which even trades (without profit and loss) were open.
TotalBarsLosTrades (inherited from SignalObject) | Returns the total number of bars during which losing trades were open.
TotalBarsWinTrades (inherited from SignalObject) | Returns the total number of bars during which winning trades were open.
TotalTrades (inherited from SignalObject) | Return total number of trades.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetAllowSendOrdersAlways (inherited from SignalObject) |
GetCalcAtOpenNextBar (inherited from SignalObject) |
GetDataStream (inherited from CStudyAbstract) |
GetExitFromOneEntryOnce (inherited from SignalObject) |
GetHashCode (inherited from Object) |
GetInputs (inherited from CStudyAbstract) |
GetInputValue (inherited from CStudyAbstract) |
GetIOGMode (inherited from SignalObject) |
GetMouseEvents (inherited from CStudyAbstract) |
GetRecoverDrawings (inherited from CStudyAbstract) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue (inherited from CStudyAbstract) |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

CurSpecOrdersMode (inherited from SignalObject) | Property for requesting or setting special orders mode: perLot, perPosition.
CustomFitnessValue (inherited from SignalObject) | Set calculated fitness value. This method may be used during strategy optimization to pass custom calculated optimization criteria value.
OrderCreator (inherited from SignalObject) | Returns the order generation interface (IOrderCreator).

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl)
AddIndicator (inherited from CStudyAbstract) | Overloaded.
BeforeInitializeImpl
CalcBar (inherited from CStudyAbstract) | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create (inherited from CStudyAbstract) | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy (inherited from CStudyAbstract) | This method is called once when the study is removed from the chart(scanner).
Dispose
Finalize (inherited from Object)
GenerateATMarketOrder (inherited from SignalObject) | Market order generation.
GenerateBreakEven (inherited from SignalObject) | BreakEven order generation. Closes out the entire position or the entry if it is at the breakeven point after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether SetBreakEven will be applied to the entire position or to each contract or share individually; by default, SetBreakEven is applied to the entire position. GenerateBreakEven function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateBreakEvenPt (inherited from SignalObject) | BreakEven order generation. Same as GenerateBreakEven, but amount in points.
GenerateDollarTrailing (inherited from SignalObject) | DollarTrailing order generation. Closes out the entire position or the entry if the current profit is less than the maximum profit by the specified amount; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified ammount is ¤50 and the profit has reached the maximum of ¤120, the position will be closed once the profit drops to ¤70. Use CurSpecOrdersMode property to determine whether SetDollarTrailing will be applied to the entire position or to each contract or share individually; by default, SetDollarTrailing is applied to the entire position. GenerateDollarTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateExitOnClose (inherited from SignalObject) | ExitOnClose order generation.
GeneratePercentTrailing (inherited from SignalObject) | PercentTrailing order generation. Closes out the entire position or the entry if the specified percentage of the maximum profit is lost after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified profit is ¤100 and the specified percentage is 50, and the profit has reached the maximum of ¤120, the position will be closed once the profit falls back to ¤60. Use CurSpecOrdersMode property to determine whether SetPercentTrailing will be applied to the entire position or each contract or share individually; by default, SetPercentTrailing is applied to the entire position. GeneratePercentTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GeneratePercentTrailingPt (inherited from SignalObject) | PercentTrailing order generation. Same as GeneratePercentTrailing, but amount in points.
GenerateProfitTarget (inherited from SignalObject) | ProfitTarget order generation. Closes out the entire position or the entry if profit reaches the specified currency value; generates the appropriate Limit exit order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the profit target will be applied to the entire position or to each contract or share individualy; by default, profit target is applied to the entire position. GenerateProfitTarget function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateProfitTargetPt (inherited from SignalObject) | ProfitTarget order generation. Same as GenerateProfitTarget, but amount in points.
GenerateStopLoss (inherited from SignalObject) | StopLoss order generation. Closes out the entire position or the entry if the loss reaches the specified currency value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the stop loss will be applied to the entire position or to each contract or share individually; by default, stop loss is applied to the entire position. GenerateStopLoss function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateStopLossPt (inherited from SignalObject) | StopLoss order generation. Same as GenerateStopLoss, but amount in points.
GenerateTrailingStopPt (inherited from SignalObject) | TrailingStop order generation. Same as GenerateDollarTrailing, but amount in points.
MemberwiseClone (inherited from Object)
OnBrokerPositionChange (inherited from CStudyAbstract) | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent (inherited from CStudyAbstract) | Allows control of mouse-click events on the chart.
OnOrderRejected (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent (inherited from CStudyAbstract) | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent (inherited from CStudyAbstract) | Event that happens after the Close Position button is pressed in Portfolio Trader
SetInitialBrokerPosition (inherited from SignalObject) | Overloaded. Assign initial market position at broker for the strategy.
StartCalc (inherited from CStudyAbstract) | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc (inherited from CStudyAbstract) | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


PortfolioSignalObject Properties

The properties of the PortfolioSignalObject class are listed below. For a complete list of PortfolioSignalObject class members, see the PortfolioSignalObject Members topic.

Public Instance Properties

Account (inherited from SignalObject) | Returns current account name.
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
AvgBarsEvenTrade (inherited from SignalObject) | Returns the average length of even trades (without profit and loss) in terms of bars.
AvgBarsLosTrade (inherited from SignalObject) | Returns the average length of losing trades in terms of bars.
AvgBarsWinTrade (inherited from SignalObject) | Returns the average length of winning trades in terms of bars.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
Commission (inherited from SignalObject) | Returns 'Commission' from the Strategy Properties window.
CommonPortfolioData |
CurrentPosition (inherited from SignalObject) | Returns strategy's current position.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
GrossLoss (inherited from SignalObject) | Returns a non-positive number that indicates total strategy loss.
GrossProfit (inherited from SignalObject) | Returns non-negative number that indicates total strategy profit.
InitialCapital (inherited from SignalObject) | Returns 'Initial Capital' from the Strategy Properties window.
InterestRate (inherited from SignalObject) | Returns 'Interest Rate' from the Strategy Properties window.
LargestLosTrade (inherited from SignalObject) | Returns non-positive number with the maximum loss of a single trade.
LargestWinTrade (inherited from SignalObject) | Returns non-negative number with maximum profit of a single trade.
MaxConsecLosers (inherited from SignalObject) | Returns maximum number of sequential unprofitable trades.
MaxConsecWinners (inherited from SignalObject) | Returns maximum number of sequential profitable trades.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
MaxDrawDown (inherited from SignalObject) | Returns maximum potential loss (drawdown) during entire trading period.
MaxLotsHeld (inherited from SignalObject) | Returns maximal number of sequential unprofitable trades.
MyPortfolioData |
Name (inherited from CStudyControl) | Read-only property. Returns name.
NetProfit (inherited from SignalObject) | Returns strategy's fixed net profit.
NumEvenTrades (inherited from SignalObject) | Returns total number of trades that did not bring any profit or loss.
NumLosTrades (inherited from SignalObject) | Returns total number or losing trades.
NumWinTrades (inherited from SignalObject) | Returns total number or profitable trades.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PercentProfit (inherited from SignalObject) | Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
Portfolio (inherited from SignalObject) | Returns the interface which provides Portfolio Perfomance.
PortfolioCurrency |
PortfolioStrategies |
Positions (inherited from SignalObject) | Returns a read-only collection of all strategy positions.
PositionSide (inherited from SignalObject) | Returns strategy's market position.
Profile (inherited from SignalObject) | Returns current trading profile name.
Slippage (inherited from SignalObject) | Returns 'Slippage' from the Strategy Properties window.
StrategyCurrencyCode (inherited from SignalObject) | Returns currency code from Strategy settings (Base Currency)
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TotalBarsEvenTrades (inherited from SignalObject) | Returns the total number of bars during which even trades (without profit and loss) were open.
TotalBarsLosTrades (inherited from SignalObject) | Returns the total number of bars during which losing trades were open.
TotalBarsWinTrades (inherited from SignalObject) | Returns the total number of bars during which winning trades were open.
TotalTrades (inherited from SignalObject) | Return total number of trades.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

CurSpecOrdersMode (inherited from SignalObject) | Property for requesting or setting special orders mode: perLot, perPosition.
CustomFitnessValue (inherited from SignalObject) | Set calculated fitness value. This method may be used during strategy optimization to pass custom calculated optimization criteria value.
OrderCreator (inherited from SignalObject) | Returns the order generation interface (IOrderCreator).

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


CommonPortfolioData Property

PowerLanguage.NET Help

PortfolioSignalObject.CommonPortfolioData Property

public IPortfolioData CommonPortfolioData { public get; }

Implements

IPortfolio.CommonPortfolioData

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


MyPortfolioData Property

PowerLanguage.NET Help

PortfolioSignalObject.MyPortfolioData Property

public IPortfolioData MyPortfolioData { public get; }

Implements

IPortfolio.MyPortfolioData

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


PortfolioCurrency Property

PowerLanguage.NET Help

PortfolioSignalObject.PortfolioCurrency Property

public MTPA_MCSymbolCurrency PortfolioCurrency { public get; }

Implements

IPortfolio.PortfolioCurrency

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


PortfolioStrategies Property

PowerLanguage.NET Help

PortfolioSignalObject.PortfolioStrategies Property

public IROList<IPortfolioStrategy> PortfolioStrategies { public get; }

Implements

IPortfolio.PortfolioStrategies

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


PortfolioSignalObject Methods

The methods of the PortfolioSignalObject class are listed below. For a complete list of PortfolioSignalObject class members, see the PortfolioSignalObject Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetAllowSendOrdersAlways (inherited from SignalObject) |
GetCalcAtOpenNextBar (inherited from SignalObject) |
GetDataStream (inherited from CStudyAbstract) |
GetExitFromOneEntryOnce (inherited from SignalObject) |
GetHashCode (inherited from Object) |
GetInputs (inherited from CStudyAbstract) |
GetInputValue (inherited from CStudyAbstract) |
GetIOGMode (inherited from SignalObject) |
GetMouseEvents (inherited from CStudyAbstract) |
GetRecoverDrawings (inherited from CStudyAbstract) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue (inherited from CStudyAbstract) |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl)
AddIndicator (inherited from CStudyAbstract) | Overloaded.
BeforeInitializeImpl
CalcBar (inherited from CStudyAbstract) | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create (inherited from CStudyAbstract) | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy (inherited from CStudyAbstract) | This method is called once when the study is removed from the chart(scanner).
Dispose
Finalize (inherited from Object)
GenerateATMarketOrder (inherited from SignalObject) | Market order generation.
GenerateBreakEven (inherited from SignalObject) | BreakEven order generation. Closes out the entire position or the entry if it is at the breakeven point after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether SetBreakEven will be applied to the entire position or to each contract or share individually; by default, SetBreakEven is applied to the entire position. GenerateBreakEven function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateBreakEvenPt (inherited from SignalObject) | BreakEven order generation. Same as GenerateBreakEven, but amount in points.
GenerateDollarTrailing (inherited from SignalObject) | DollarTrailing order generation. Closes out the entire position or the entry if the current profit is less than the maximum profit by the specified amount; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified ammount is ¤50 and the profit has reached the maximum of ¤120, the position will be closed once the profit drops to ¤70. Use CurSpecOrdersMode property to determine whether SetDollarTrailing will be applied to the entire position or to each contract or share individually; by default, SetDollarTrailing is applied to the entire position. GenerateDollarTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateExitOnClose (inherited from SignalObject) | ExitOnClose order generation.
GeneratePercentTrailing (inherited from SignalObject) | PercentTrailing order generation. Closes out the entire position or the entry if the specified percentage of the maximum profit is lost after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified profit is ¤100 and the specified percentage is 50, and the profit has reached the maximum of ¤120, the position will be closed once the profit falls back to ¤60. Use CurSpecOrdersMode property to determine whether SetPercentTrailing will be applied to the entire position or each contract or share individually; by default, SetPercentTrailing is applied to the entire position. GeneratePercentTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GeneratePercentTrailingPt (inherited from SignalObject) | PercentTrailing order generation. Same as GeneratePercentTrailing, but amount in points.
GenerateProfitTarget (inherited from SignalObject) | ProfitTarget order generation. Closes out the entire position or the entry if profit reaches the specified currency value; generates the appropriate Limit exit order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the profit target will be applied to the entire position or to each contract or share individualy; by default, profit target is applied to the entire position. GenerateProfitTarget function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateProfitTargetPt (inherited from SignalObject) | ProfitTarget order generation. Same as GenerateProfitTarget, but amount in points.
GenerateStopLoss (inherited from SignalObject) | StopLoss order generation. Closes out the entire position or the entry if the loss reaches the specified currency value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the stop loss will be applied to the entire position or to each contract or share individually; by default, stop loss is applied to the entire position. GenerateStopLoss function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateStopLossPt (inherited from SignalObject) | StopLoss order generation. Same as GenerateStopLoss, but amount in points.
GenerateTrailingStopPt (inherited from SignalObject) | TrailingStop order generation. Same as GenerateDollarTrailing, but amount in points.
MemberwiseClone (inherited from Object)
OnBrokerPositionChange (inherited from CStudyAbstract) | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent (inherited from CStudyAbstract) | Allows control of mouse-click events on the chart.
OnOrderRejected (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent (inherited from CStudyAbstract) | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent (inherited from CStudyAbstract) | Event that happens after the Close Position button is pressed in Portfolio Trader
SetInitialBrokerPosition (inherited from SignalObject) | Overloaded. Assign initial market position at broker for the strategy.
StartCalc (inherited from CStudyAbstract) | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc (inherited from CStudyAbstract) | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


PortfolioSignalObject.BeforeInitializeImpl Method

protected void BeforeInitializeImpl();

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


PortfolioSignalObject.Dispose Method

[HandleProcessCorruptedStateExceptions]
protected override void Dispose(
bool A_0
);

See Also

PortfolioSignalObject Class | PowerLanguage.Strategy Namespace


SignalObject Class

Base class for strategies (inherit from SignalObject to create this kind of study).

For a list of all members of this type, see SignalObject Members .

System.Object
CStudyControl
CStudyAbstract
SignalObject
PortfolioSignalObject

public abstract class SignalObject : CStudyAbstract, IStrategy, ISignalInfo

Requirements

Namespace: PowerLanguage.Strategy

Assembly: PLStudiesProxy (in PLStudiesProxy.dll)

See Also

SignalObject Members | PowerLanguage.Strategy Namespace


SignalObject Members

SignalObject overview

Public Instance Properties

Account | Returns current account name.
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
AvgBarsEvenTrade | Returns the average length of even trades (without profit and loss) in terms of bars.
AvgBarsLosTrade | Returns the average length of losing trades in terms of bars.
AvgBarsWinTrade | Returns the average length of winning trades in terms of bars.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
Commission | Returns 'Commission' from the Strategy Properties window.
CurrentPosition | Returns strategy's current position.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
GrossLoss | Returns a non-positive number that indicates total strategy loss.
GrossProfit | Returns non-negative number that indicates total strategy profit.
InitialCapital | Returns 'Initial Capital' from the Strategy Properties window.
InterestRate | Returns 'Interest Rate' from the Strategy Properties window.
LargestLosTrade | Returns non-positive number with the maximum loss of a single trade.
LargestWinTrade | Returns non-negative number with maximum profit of a single trade.
MaxConsecLosers | Returns maximum number of sequential unprofitable trades.
MaxConsecWinners | Returns maximum number of sequential profitable trades.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
MaxDrawDown | Returns maximum potential loss (drawdown) during entire trading period.
MaxLotsHeld | Returns maximal number of sequential unprofitable trades.
Name (inherited from CStudyControl) | Read-only property. Returns name.
NetProfit | Returns strategy's fixed net profit.
NumEvenTrades | Returns total number of trades that did not bring any profit or loss.
NumLosTrades | Returns total number or losing trades.
NumWinTrades | Returns total number or profitable trades.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PercentProfit | Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
Portfolio | Returns the interface which provides Portfolio Perfomance.
Positions | Returns a read-only collection of all strategy positions.
PositionSide | Returns strategy's market position.
Profile | Returns current trading profile name.
Slippage | Returns 'Slippage' from the Strategy Properties window.
StrategyCurrencyCode | Returns currency code from Strategy settings (Base Currency)
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TotalBarsEvenTrades | Returns the total number of bars during which even trades (without profit and loss) were open.
TotalBarsLosTrades | Returns the total number of bars during which losing trades were open.
TotalBarsWinTrades | Returns the total number of bars during which winning trades were open.
TotalTrades | Return total number of trades.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetAllowSendOrdersAlways |
GetCalcAtOpenNextBar |
GetDataStream (inherited from CStudyAbstract) |
GetExitFromOneEntryOnce |
GetHashCode (inherited from Object) |
GetInputs (inherited from CStudyAbstract) |
GetInputValue (inherited from CStudyAbstract) |
GetIOGMode |
GetMouseEvents (inherited from CStudyAbstract) |
GetRecoverDrawings (inherited from CStudyAbstract) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue (inherited from CStudyAbstract) |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Properties

CurSpecOrdersMode | Property for requesting or setting special orders mode: perLot, perPosition.
CustomFitnessValue | Set calculated fitness value. This method may be used during strategy optimization to pass custom calculated optimization criteria value.
OrderCreator | Returns the order generation interface (IOrderCreator).

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl)
AddIndicator (inherited from CStudyAbstract) | Overloaded.
CalcBar (inherited from CStudyAbstract) | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create (inherited from CStudyAbstract) | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy (inherited from CStudyAbstract) | This method is called once when the study is removed from the chart(scanner).
Dispose
Finalize (inherited from Object)
GenerateATMarketOrder | Market order generation.
GenerateBreakEven | BreakEven order generation. Closes out the entire position or the entry if it is at the breakeven point after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether SetBreakEven will be applied to the entire position or to each contract or share individually; by default, SetBreakEven is applied to the entire position. GenerateBreakEven function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateBreakEvenPt | BreakEven order generation. Same as GenerateBreakEven, but amount in points.
GenerateDollarTrailing | DollarTrailing order generation. Closes out the entire position or the entry if the current profit is less than the maximum profit by the specified amount; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified ammount is ¤50 and the profit has reached the maximum of ¤120, the position will be closed once the profit drops to ¤70. Use CurSpecOrdersMode property to determine whether SetDollarTrailing will be applied to the entire position or to each contract or share individually; by default, SetDollarTrailing is applied to the entire position. GenerateDollarTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateExitOnClose | ExitOnClose order generation.
GeneratePercentTrailing | PercentTrailing order generation. Closes out the entire position or the entry if the specified percentage of the maximum profit is lost after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified profit is ¤100 and the specified percentage is 50, and the profit has reached the maximum of ¤120, the position will be closed once the profit falls back to ¤60. Use CurSpecOrdersMode property to determine whether SetPercentTrailing will be applied to the entire position or each contract or share individually; by default, SetPercentTrailing is applied to the entire position. GeneratePercentTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GeneratePercentTrailingPt | PercentTrailing order generation. Same as GeneratePercentTrailing, but amount in points.
GenerateProfitTarget | ProfitTarget order generation. Closes out the entire position or the entry if profit reaches the specified currency value; generates the appropriate Limit exit order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the profit target will be applied to the entire position or to each contract or share individualy; by default, profit target is applied to the entire position. GenerateProfitTarget function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateProfitTargetPt | ProfitTarget order generation. Same as GenerateProfitTarget, but amount in points.
GenerateStopLoss | StopLoss order generation. Closes out the entire position or the entry if the loss reaches the specified currency value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the stop loss will be applied to the entire position or to each contract or share individually; by default, stop loss is applied to the entire position. GenerateStopLoss function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateStopLossPt | StopLoss order generation. Same as GenerateStopLoss, but amount in points.
GenerateTrailingStopPt | TrailingStop order generation. Same as GenerateDollarTrailing, but amount in points.
MemberwiseClone (inherited from Object)
OnBrokerPositionChange (inherited from CStudyAbstract) | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent (inherited from CStudyAbstract) | Allows control of mouse-click events on the chart.
OnOrderRejected (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent (inherited from CStudyAbstract) | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent (inherited from CStudyAbstract) | Event that happens after the Close Position button is pressed in Portfolio Trader
SetInitialBrokerPosition | Overloaded. Assign initial market position at broker for the strategy.
StartCalc (inherited from CStudyAbstract) | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc (inherited from CStudyAbstract) | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject Properties

The properties of the SignalObject class are listed below. For a complete list of SignalObject class members, see the SignalObject Members topic.

Public Instance Properties

Account | Returns current account name.
Alerts (inherited from CStudyControl) | Read-only property. Returns an interface for working with Alerts.
AvgBarsEvenTrade | Returns the average length of even trades (without profit and loss) in terms of bars.
AvgBarsLosTrade | Returns the average length of losing trades in terms of bars.
AvgBarsWinTrade | Returns the average length of winning trades in terms of bars.
Bars (inherited from CStudyControl) | Read-only property. Returns base instrument.
ChartCommands (inherited from CStudyControl) |
ChartCustomDraw (inherited from CStudyControl) | Read-only property. Allows registering your own custom "drawer" for customizing drawing on chart using GDI+ (Drawing).
ChartToolBar (inherited from CStudyControl) | Read-only property. Returns an interface for accessing the toolbar for the chart that has the study applied. Gives access to toolbar ToolStrip and lets you set its visibility.
Commission | Returns 'Commission' from the Strategy Properties window.
CurrentPosition | Returns strategy's current position.
DataLoader (inherited from CStudyControl) | Read-only property. Returns an interface for data loading.
DrwArrow (inherited from CStudyControl) | Read-only property. Returns a container for collection of specific IArrowObject.
DrwRectangle (inherited from CStudyControl) | Read-only property. Returns a container for IRectangleObject collection.
DrwText (inherited from CStudyControl) | Read-only property. Returns a container for ITextObject collection.
DrwTrendLine (inherited from CStudyControl) | Read-only property. Returns a container for ITrendLineObject collection.
Environment (inherited from CStudyControl) | Read-only property. Returns environment access interface.
ExecControl (inherited from CStudyControl) | Read-only property. Returns an interface for controlling strategy calculation.
ExecInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing current execution context.
ExpertCommentary (inherited from CStudyControl) | Read-only property. Returns an interface for controlling expert commentary.
GrossLoss | Returns a non-positive number that indicates total strategy loss.
GrossProfit | Returns non-negative number that indicates total strategy profit.
InitialCapital | Returns 'Initial Capital' from the Strategy Properties window.
InterestRate | Returns 'Interest Rate' from the Strategy Properties window.
LargestLosTrade | Returns non-positive number with the maximum loss of a single trade.
LargestWinTrade | Returns non-negative number with maximum profit of a single trade.
MaxConsecLosers | Returns maximum number of sequential unprofitable trades.
MaxConsecWinners | Returns maximum number of sequential profitable trades.
MaxDataStream (inherited from CStudyControl) | Read-only property. Returns max data stream.
MaxDrawDown | Returns maximum potential loss (drawdown) during entire trading period.
MaxLotsHeld | Returns maximal number of sequential unprofitable trades.
Name (inherited from CStudyControl) | Read-only property. Returns name.
NetProfit | Returns strategy's fixed net profit.
NumEvenTrades | Returns total number of trades that did not bring any profit or loss.
NumLosTrades | Returns total number or losing trades.
NumWinTrades | Returns total number or profitable trades.
Output (inherited from CStudyControl) | Read-only property. Returns an interface to access Output Window.
PercentProfit | Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).
PersistData (inherited from CStudyControl) | This string is saved to workspace and loaded from workspace.
Portfolio | Returns the interface which provides Portfolio Perfomance.
Positions | Returns a read-only collection of all strategy positions.
PositionSide | Returns strategy's market position.
Profile | Returns current trading profile name.
Slippage | Returns 'Slippage' from the Strategy Properties window.
StrategyCurrencyCode | Returns currency code from Strategy settings (Base Currency)
StrategyInfo (inherited from CStudyControl) | Read-only property. Returns an interface for accessing strategy information.
SymbolStorage (inherited from CStudyControl) | Read-only property. Returns an interface for accessing symbol storage.
TotalBarsEvenTrades | Returns the total number of bars during which even trades (without profit and loss) were open.
TotalBarsLosTrades | Returns the total number of bars during which losing trades were open.
TotalBarsWinTrades | Returns the total number of bars during which winning trades were open.
TotalTrades | Return total number of trades.
TPOBars (inherited from CStudyControl) | Read-only property. Provides an interface for accessing current series' TPO data.
TradeManager (inherited from CStudyControl) | Returns interface for accessing trading functionality.
VolumeProfile (inherited from CStudyControl) | Returns interface for accessing volume profile.

Protected Instance Properties

CurSpecOrdersMode | Property for requesting or setting special orders mode: perLot, perPosition.
CustomFitnessValue | Set calculated fitness value. This method may be used during strategy optimization to pass custom calculated optimization criteria value.
OrderCreator | Returns the order generation interface (IOrderCreator).

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


Account Property

PowerLanguage.NET Help

SignalObject.Account Property

Returns current account name.

public string Account { public get; }

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


AvgBarsEvenTrade Property

PowerLanguage.NET Help

SignalObject.AvgBarsEvenTrade Property

Returns the average length of even trades (without profit and loss) in terms of bars.

public double AvgBarsEvenTrade { public get; }

Implements

IStrategy.AvgBarsEvenTrade

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


AvgBarsLosTrade Property

PowerLanguage.NET Help

SignalObject.AvgBarsLosTrade Property

Returns the average length of losing trades in terms of bars.

public double AvgBarsLosTrade { public get; }

Implements

IStrategy.AvgBarsLosTrade

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


AvgBarsWinTrade Property

PowerLanguage.NET Help

SignalObject.AvgBarsWinTrade Property

Returns the average length of winning trades in terms of bars.

public double AvgBarsWinTrade { public get; }

Implements

IStrategy.AvgBarsWinTrade

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


Commission Property

PowerLanguage.NET Help

SignalObject.Commission Property

Returns 'Commission' from the Strategy Properties window.

public double Commission { public get; }

Implements

IStrategy.Commission

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


CurrentPosition Property

PowerLanguage.NET Help

SignalObject.CurrentPosition Property

Returns strategy's current position.

public IMarketPosition CurrentPosition { public get; }

Implements

IStrategy.CurrentPosition

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


CurSpecOrdersMode Property

PowerLanguage.NET Help

SignalObject.CurSpecOrdersMode Property

Property for requesting or setting special orders mode: perLot, perPosition.

protected ESpecOrdersMode CurSpecOrdersMode { protected get; protected set; }

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


CustomFitnessValue Property

PowerLanguage.NET Help

SignalObject.CustomFitnessValue Property

Set calculated fitness value. This method may be used during strategy optimization to pass custom calculated optimization criteria value.

protected double CustomFitnessValue { protected set; }

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


GrossLoss Property

PowerLanguage.NET Help

SignalObject.GrossLoss Property

Returns a non-positive number that indicates total strategy loss.

public double GrossLoss { public get; }

Implements

IStrategy.GrossLoss

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


GrossProfit Property

PowerLanguage.NET Help

SignalObject.GrossProfit Property

Returns non-negative number that indicates total strategy profit.

public double GrossProfit { public get; }

Implements

IStrategy.GrossProfit

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


InitialCapital Property

PowerLanguage.NET Help

SignalObject.InitialCapital Property

Returns 'Initial Capital' from the Strategy Properties window.

public double InitialCapital { public get; }

Implements

IStrategy.InitialCapital

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


InterestRate Property

PowerLanguage.NET Help

SignalObject.InterestRate Property

Returns 'Interest Rate' from the Strategy Properties window.

public double InterestRate { public get; }

Implements

IStrategy.InterestRate

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


LargestLosTrade Property

PowerLanguage.NET Help

SignalObject.LargestLosTrade Property

Returns non-positive number with the maximum loss of a single trade.

public double LargestLosTrade { public get; }

Implements

IStrategy.LargestLosTrade

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


LargestWinTrade Property

PowerLanguage.NET Help

SignalObject.LargestWinTrade Property

Returns non-negative number with maximum profit of a single trade.

public double LargestWinTrade { public get; }

Implements

IStrategy.LargestWinTrade

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


MaxConsecLosers Property

PowerLanguage.NET Help

SignalObject.MaxConsecLosers Property

Returns maximum number of sequential unprofitable trades.

public int MaxConsecLosers { public get; }

Implements

IStrategy.MaxConsecLosers

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


MaxConsecWinners Property

PowerLanguage.NET Help

SignalObject.MaxConsecWinners Property

Returns maximum number of sequential profitable trades.

public int MaxConsecWinners { public get; }

Implements

IStrategy.MaxConsecWinners

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


MaxDrawDown Property

PowerLanguage.NET Help

SignalObject.MaxDrawDown Property

Returns maximum potential loss (drawdown) during entire trading period.

public double MaxDrawDown { public get; }

Implements

IStrategy.MaxDrawDown

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


MaxLotsHeld Property

PowerLanguage.NET Help

SignalObject.MaxLotsHeld Property

Returns maximal number of sequential unprofitable trades.

public int MaxLotsHeld { public get; }

Implements

IStrategy.MaxLotsHeld

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


NetProfit Property

PowerLanguage.NET Help

SignalObject.NetProfit Property

Returns strategy's fixed net profit.

public double NetProfit { public get; }

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


NumEvenTrades Property

PowerLanguage.NET Help

SignalObject.NumEvenTrades Property

Returns total number of trades that did not bring any profit or loss.

public int NumEvenTrades { public get; }

Implements

IStrategy.NumEvenTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


NumLosTrades Property

PowerLanguage.NET Help

SignalObject.NumLosTrades Property

Returns total number or losing trades.

public int NumLosTrades { public get; }

Implements

IStrategy.NumLosTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


NumWinTrades Property

PowerLanguage.NET Help

SignalObject.NumWinTrades Property

Returns total number or profitable trades.

public int NumWinTrades { public get; }

Implements

IStrategy.NumWinTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


OrderCreator Property

PowerLanguage.NET Help

SignalObject.OrderCreator Property

Returns the order generation interface (IOrderCreator).

protected IOrderCreator OrderCreator { protected get; }

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


PercentProfit Property

PowerLanguage.NET Help

SignalObject.PercentProfit Property

Returns a ratio of profitable trades to total number of trades expressed in percent ( 100*(NumWinTrades/TotalTrades)).

public double PercentProfit { public get; }

Implements

IStrategy.PercentProfit

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


Portfolio Property

PowerLanguage.NET Help

SignalObject.Portfolio Property

Returns the interface which provides Portfolio Perfomance.

public IPortfolioPerformance Portfolio { public get; }

Implements

IStrategy.Portfolio

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


Positions Property

PowerLanguage.NET Help

SignalObject.Positions Property

Returns a read-only collection of all strategy positions.

public IROList<IMarketPosition> Positions { public get; }

Implements

IStrategy.Positions

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


PositionSide Property

PowerLanguage.NET Help

SignalObject.PositionSide Property

Returns strategy's market position.

public int PositionSide { public get; }

Implements

IStrategy.PositionSide

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


Profile Property

PowerLanguage.NET Help

SignalObject.Profile Property

Returns current trading profile name.

public string Profile { public get; }

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


Slippage Property

PowerLanguage.NET Help

SignalObject.Slippage Property

Returns 'Slippage' from the Strategy Properties window.

public double Slippage { public get; }

Implements

IStrategy.Slippage

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


StrategyCurrencyCode Property

PowerLanguage.NET Help

SignalObject.StrategyCurrencyCode Property

Returns currency code from Strategy settings (Base Currency)

public MTPA_MCSymbolCurrency StrategyCurrencyCode { public get; }

Implements

IStrategy.StrategyCurrencyCode

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


TotalBarsEvenTrades Property

PowerLanguage.NET Help

SignalObject.TotalBarsEvenTrades Property

Returns the total number of bars during which even trades (without profit and loss) were open.

public int TotalBarsEvenTrades { public get; }

Implements

IStrategy.TotalBarsEvenTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


TotalBarsLosTrades Property

PowerLanguage.NET Help

SignalObject.TotalBarsLosTrades Property

Returns the total number of bars during which losing trades were open.

public int TotalBarsLosTrades { public get; }

Implements

IStrategy.TotalBarsLosTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


TotalBarsWinTrades Property

PowerLanguage.NET Help

SignalObject.TotalBarsWinTrades Property

Returns the total number of bars during which winning trades were open.

public int TotalBarsWinTrades { public get; }

Implements

IStrategy.TotalBarsWinTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


TotalTrades Property

PowerLanguage.NET Help

SignalObject.TotalTrades Property

Return total number of trades.

public int TotalTrades { public get; }

Implements

IStrategy.TotalTrades

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject Methods

The methods of the SignalObject class are listed below. For a complete list of SignalObject class members, see the SignalObject Members topic.

Public Instance Methods

BarsOfData (inherited from CStudyControl) | Returns instrument for specified data stream number.
Equals (inherited from Object) |
GetAllowSendOrdersAlways |
GetCalcAtOpenNextBar |
GetDataStream (inherited from CStudyAbstract) |
GetExitFromOneEntryOnce |
GetHashCode (inherited from Object) |
GetInputs (inherited from CStudyAbstract) |
GetInputValue (inherited from CStudyAbstract) |
GetIOGMode |
GetMouseEvents (inherited from CStudyAbstract) |
GetRecoverDrawings (inherited from CStudyAbstract) |
GetType (inherited from Object) |
IsExist (inherited from CStudyControl) | Returns whether there is data at a specified data stream number.
SetInputValue (inherited from CStudyAbstract) |
ToString (inherited from Object) |
TPOBarsOfData (inherited from CStudyControl) | Read-only property. Provides an interface for accessing TPO's data series on a particular datastream. Datastream number is provided in the parameter.
VerifyLicense (inherited from CStudyControl) | Allows study developers to use MultiCharts .NET Special Edition authorization services.
VolumeProfileByDataStream (inherited from CStudyControl) | Returns interface for accessing volume profile for specified instrument.

Protected Instance Methods

_check_for_disposed (inherited from CStudyControl)
AddIndicator (inherited from CStudyAbstract) | Overloaded.
CalcBar (inherited from CStudyAbstract) | This method is called every tick from the calculation's beginning bar until the last historical bar. Every real-time tick (or bar close, optionally) after the historical calculation.
Create (inherited from CStudyAbstract) | Method which is called once when the study object is created. Here, and only here, access the following: 1) add plot objects (for indicator objects only) , 2) create order objects OrderCreator (for signal objects only) , 3) create function objects, 4) add variable objects CreateSimpleVar<T> CreateSeriesVar<T>
CreateSeriesVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableSeries object.
CreateSimpleVar<T> (inherited from CStudyControl) | Overloaded. Creates VariableObject object.
Destroy (inherited from CStudyAbstract) | This method is called once when the study is removed from the chart(scanner).
Dispose
Finalize (inherited from Object)
GenerateATMarketOrder | Market order generation.
GenerateBreakEven | BreakEven order generation. Closes out the entire position or the entry if it is at the breakeven point after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether SetBreakEven will be applied to the entire position or to each contract or share individually; by default, SetBreakEven is applied to the entire position. GenerateBreakEven function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateBreakEvenPt | BreakEven order generation. Same as GenerateBreakEven, but amount in points.
GenerateDollarTrailing | DollarTrailing order generation. Closes out the entire position or the entry if the current profit is less than the maximum profit by the specified amount; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified ammount is ¤50 and the profit has reached the maximum of ¤120, the position will be closed once the profit drops to ¤70. Use CurSpecOrdersMode property to determine whether SetDollarTrailing will be applied to the entire position or to each contract or share individually; by default, SetDollarTrailing is applied to the entire position. GenerateDollarTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateExitOnClose | ExitOnClose order generation.
GeneratePercentTrailing | PercentTrailing order generation. Closes out the entire position or the entry if the specified percentage of the maximum profit is lost after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified profit is ¤100 and the specified percentage is 50, and the profit has reached the maximum of ¤120, the position will be closed once the profit falls back to ¤60. Use CurSpecOrdersMode property to determine whether SetPercentTrailing will be applied to the entire position or each contract or share individually; by default, SetPercentTrailing is applied to the entire position. GeneratePercentTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GeneratePercentTrailingPt | PercentTrailing order generation. Same as GeneratePercentTrailing, but amount in points.
GenerateProfitTarget | ProfitTarget order generation. Closes out the entire position or the entry if profit reaches the specified currency value; generates the appropriate Limit exit order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the profit target will be applied to the entire position or to each contract or share individualy; by default, profit target is applied to the entire position. GenerateProfitTarget function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateProfitTargetPt | ProfitTarget order generation. Same as GenerateProfitTarget, but amount in points.
GenerateStopLoss | StopLoss order generation. Closes out the entire position or the entry if the loss reaches the specified currency value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the stop loss will be applied to the entire position or to each contract or share individually; by default, stop loss is applied to the entire position. GenerateStopLoss function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.
GenerateStopLossPt | StopLoss order generation. Same as GenerateStopLoss, but amount in points.
GenerateTrailingStopPt | TrailingStop order generation. Same as GenerateDollarTrailing, but amount in points.
MemberwiseClone (inherited from Object)
OnBrokerPositionChange (inherited from CStudyAbstract) | Event that occurs after MarketPosition and/or average Entry Price changed at broker.
OnBrokerStategyOrderFilled (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Filled at broker. This method can be used only for automated trading, not for manual trading.
OnMouseEvent (inherited from CStudyAbstract) | Allows control of mouse-click events on the chart.
OnOrderRejected (inherited from CStudyAbstract) | Event that occurs after strategy Order has been Rejected at broker. This method can be used only for automated trading, not for manual trading.
OnRecalcLastBarAfterEvent (inherited from CStudyAbstract) | Event that happens after timeout in RecalcLastBarAfter function occurs.
OnUserClickClosePositionButtonEvent (inherited from CStudyAbstract) | Event that happens after the Close Position button is pressed in Portfolio Trader
SetInitialBrokerPosition | Overloaded. Assign initial market position at broker for the strategy.
StartCalc (inherited from CStudyAbstract) | Method which is called once at the start of the calculation process. Here you can initialize study variables.
StopCalc (inherited from CStudyAbstract) | Method which is called once at the end of the calculation process when technique was switched off or removed. IMPORTANT! This method may be called in main thread (UI) or in working thread (calculation).

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.Dispose Method

[HandleProcessCorruptedStateExceptions]
protected override void Dispose(
bool A_0
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateATMarketOrder Method

Market order generation.

[return : MarshalAs(SafeArraySubType=VarEnum.VT_EMPTY, SafeArrayUserDefinedSubType=null, IidParameterIndex=0, ArraySubType=UnmanagedType.0, SizeParamIndex=0, SizeConst=0, MarshalType="null", MarshalTypeRef=null, MarshalCookie="null", Value=UnmanagedType.U1)]
protected bool GenerateATMarketOrder(
bool buy,
bool entry,
int lots
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateBreakEven Method

BreakEven order generation. Closes out the entire position or the entry if it is at the breakeven point after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether SetBreakEven will be applied to the entire position or to each contract or share individually; by default, SetBreakEven is applied to the entire position. GenerateBreakEven function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.

protected void GenerateBreakEven(
double profit
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateBreakEvenPt Method

BreakEven order generation. Same as GenerateBreakEven, but amount in points.

protected void GenerateBreakEvenPt(
double amount
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateDollarTrailing Method

DollarTrailing order generation. Closes out the entire position or the entry if the current profit is less than the maximum profit by the specified amount; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified ammount is ¤50 and the profit has reached the maximum of ¤120, the position will be closed once the profit drops to ¤70. Use CurSpecOrdersMode property to determine whether SetDollarTrailing will be applied to the entire position or to each contract or share individually; by default, SetDollarTrailing is applied to the entire position. GenerateDollarTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.

protected void GenerateDollarTrailing(
double profit
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateExitOnClose Method

ExitOnClose order generation.

protected void GenerateExitOnClose();

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GeneratePercentTrailing Method

PercentTrailing order generation. Closes out the entire position or the entry if the specified percentage of the maximum profit is lost after the profit has reached the specified value; generates the appropriate Stop order depending on whether the position is long or short. For example, if the specified profit is ¤100 and the specified percentage is 50, and the profit has reached the maximum of ¤120, the position will be closed once the profit falls back to ¤60. Use CurSpecOrdersMode property to determine whether SetPercentTrailing will be applied to the entire position or each contract or share individually; by default, SetPercentTrailing is applied to the entire position. GeneratePercentTrailing function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.

protected void GeneratePercentTrailing(
double profit,
double percentage
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GeneratePercentTrailingPt Method

PercentTrailing order generation. Same as GeneratePercentTrailing, but amount in points.

protected void GeneratePercentTrailingPt(
double amount,
double percentage
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateProfitTarget Method

ProfitTarget order generation. Closes out the entire position or the entry if profit reaches the specified currency value; generates the appropriate Limit exit order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the profit target will be applied to the entire position or to each contract or share individualy; by default, profit target is applied to the entire position. GenerateProfitTarget function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.

protected void GenerateProfitTarget(
double amount
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateProfitTargetPt Method

ProfitTarget order generation. Same as GenerateProfitTarget, but amount in points.

protected void GenerateProfitTargetPt(
double amount
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateStopLoss Method

StopLoss order generation. Closes out the entire position or the entry if the loss reaches the specified currency value; generates the appropriate Stop order depending on whether the position is long or short. Use CurSpecOrdersMode property to determine whether the stop loss will be applied to the entire position or to each contract or share individually; by default, stop loss is applied to the entire position. GenerateStopLoss function is evaluated intra-bar and not only on close of a bar, and can exit within the same bar as the entry. Note: Amount can be set either in the currency of the symbol or in the currecy of the strategy, depending on the key set in Windows Registry. Go to HKEY_CURRENT_USER\Software\TS Support\[ProductName]\StrategyProp and create a key DWORD Value: SpecOrdersAmountIsStrategyCurr. 0 - calculate Amount in the currency of the symbol. 1 - calculate Amount in the currency of the strategy/Portfolio (by default). [ProductName] is name of product, for example, "MultiCharts .NET", "MultiCharts .NET64" etc. If there is no such a key, Amount is calculated in the currency of the strategy/Portfolio.

protected void GenerateStopLoss(
double amount
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateStopLossPt Method

StopLoss order generation. Same as GenerateStopLoss, but amount in points.

protected void GenerateStopLossPt(
double amount
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GenerateTrailingStopPt Method

TrailingStop order generation. Same as GenerateDollarTrailing, but amount in points.

protected void GenerateTrailingStopPt(
double amount
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GetAllowSendOrdersAlways Method

public override bool? GetAllowSendOrdersAlways();

Implements

ISignalInfo.GetAllowSendOrdersAlways

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GetCalcAtOpenNextBar Method

public override bool? GetCalcAtOpenNextBar();

Implements

ISignalInfo.GetCalcAtOpenNextBar

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GetExitFromOneEntryOnce Method

public override ExitFromOneEntryOnce? GetExitFromOneEntryOnce();

Implements

ISignalInfo.GetExitFromOneEntryOnce

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.GetIOGMode Method

public override IOGMode? GetIOGMode();

Implements

ISignalInfo.GetIOGMode

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SetInitialBrokerPosition Method

PowerLanguage.NET Help

SignalObject.SetInitialBrokerPosition Method

Assign initial market position at broker for the strategy.

Overload List

Assign initial market position at broker for the strategy.

protected void SetInitialBrokerPosition(IOrderObject,int,double,double)

Assign initial market position at broker for the strategy.

protected void SetInitialBrokerPosition(int,double,double)

See Also

SignalObject Class | PowerLanguage.Strategy Namespace


SignalObject.SetInitialBrokerPosition(IOrderObject, Int32, Double, Double) Method

Assign initial market position at broker for the strategy.

protected void SetInitialBrokerPosition(
IOrderObject _entry,
int market_pos,
double avg_price,
double max_op
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace | SignalObject.SetInitialBrokerPosition Overload List


SignalObject.SetInitialBrokerPosition(Int32, Double, Double) Method

Assign initial market position at broker for the strategy.

protected void SetInitialBrokerPosition(
int market_pos,
double avg_price,
double max_op
);

See Also

SignalObject Class | PowerLanguage.Strategy Namespace | SignalObject.SetInitialBrokerPosition Overload List


PowerLanguage.TradeManager

PowerLanguage.NET Help

PowerLanguage.TradeManager Namespace

Namespace Hierarchy

Interfaces

Interface | Description
IAccounts | An 'accounts' access interface.
IBaseFilter<T> | A base filter interface.
IBaseFilterNotify | A base filter 'notify' interface.
IDataSource<T> | A base data source interface.
IDateTimeFilter | A DateTime filter interface.
IDentifiable | An interface for identification.
IListFilter<T> | Interface for list filter.
ILogs | A 'logs' source interface.
IOrders | An 'orders data' source interface.
IPositions | A 'positions data' source interface.
ITradeManager | Trade manager access interface.
ITradingData | Trade data access interface.
ITradingProfile | An interface for accessing trading profile.

Structures

Structure | Description
Account | The structure that defines account information.
Log | The structure that defines log string.
MCSymbolInfo | Structure that defines MultiCharts' symbol info.
Order | The structure that defines order info.
OrderParams | Structure describing parameters of the order.
Position | The structure that defines position info.

Delegates

Delegate | Description
TConnection | New connection state delegate.
TItemsChanged<T> | Items changed delegate.
TRealtime | New real time data delegate.


Account Structure

The structure that defines account information.

For a list of all members of this type, see Account Members .

System.Object
Account

public struct Account : IDentifiable

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

Account Members | PowerLanguage.TradeManager Namespace


Account Members

Account overview

Public Instance Constructors

Account Constructor Initializes a new instance of Account.

Public Instance Properties

AvailableToTrade | Amount available to trade value.
Balance | Balance value.
BalanceInPrcnt | Indicates balance in percent.
CurrencyAbbr | Currency abbreviation string "USD" for USA dollar, "EUR" for euro, etc
Equity | Equity value.
EquityInPrcnt | Indicates equity in percent.
ExtAttributes | Extended parameters from broker
ID | Read-only property. Returns account ID.
Margin | Margin value.
MarginAsPrcnt | Margin as percent value.
Name | Account name.
OpenPL | Open profit/loss (PnL) value.
Profile | Profile name.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Account Class | PowerLanguage.TradeManager Namespace


Account Constructor

Initializes a new instance of Account.

Account(
ITC_AccountItem item
);

Parameters

item
Account information.

See Also

Account Class | PowerLanguage.TradeManager Namespace


Account Properties

The properties of the Account structure are listed below. For a complete list of Account structure members, see the Account Members topic.

Public Instance Properties

AvailableToTrade | Amount available to trade value.
Balance | Balance value.
BalanceInPrcnt | Indicates balance in percent.
CurrencyAbbr | Currency abbreviation string "USD" for USA dollar, "EUR" for euro, etc
Equity | Equity value.
EquityInPrcnt | Indicates equity in percent.
ExtAttributes | Extended parameters from broker
ID | Read-only property. Returns account ID.
Margin | Margin value.
MarginAsPrcnt | Margin as percent value.
Name | Account name.
OpenPL | Open profit/loss (PnL) value.
Profile | Profile name.

See Also

Account Class | PowerLanguage.TradeManager Namespace


AvailableToTrade Property

PowerLanguage.NET Help

Account.AvailableToTrade Property

Amount available to trade value.

[Browsable(Browsable=False)]
public double? AvailableToTrade { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


Balance Property

PowerLanguage.NET Help

Account.Balance Property

Balance value.

[Browsable(Browsable=False)]
public double? Balance { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


BalanceInPrcnt Property

PowerLanguage.NET Help

Account.BalanceInPrcnt Property

Indicates balance in percent.

[Browsable(Browsable=False)]
public bool BalanceInPrcnt { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


CurrencyAbbr Property

PowerLanguage.NET Help

Account.CurrencyAbbr Property

Currency abbreviation string "USD" for USA dollar, "EUR" for euro, etc

[Browsable(Browsable=False)]
public string CurrencyAbbr { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


Equity Property

PowerLanguage.NET Help

Account.Equity Property

Equity value.

[Browsable(Browsable=False)]
public double? Equity { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


EquityInPrcnt Property

PowerLanguage.NET Help

Account.EquityInPrcnt Property

Indicates equity in percent.

[Browsable(Browsable=False)]
public bool EquityInPrcnt { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


ExtAttributes Property

PowerLanguage.NET Help

Account.ExtAttributes Property

Extended parameters from broker

[Browsable(Browsable=False)]
public Dictionary<string, string> ExtAttributes { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


ID Property

PowerLanguage.NET Help

Account.ID Property

Read-only property. Returns account ID.

[Browsable(Browsable=False)]
public string ID { public get; private set; }

Implements

IDentifiable.ID

See Also

Account Class | PowerLanguage.TradeManager Namespace


Margin Property

PowerLanguage.NET Help

Account.Margin Property

Margin value.

[Browsable(Browsable=False)]
public double? Margin { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


MarginAsPrcnt Property

PowerLanguage.NET Help

Account.MarginAsPrcnt Property

Margin as percent value.

[Browsable(Browsable=False)]
public double? MarginAsPrcnt { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


Name Property

PowerLanguage.NET Help

Account.Name Property

Account name.

public string Name { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


OpenPL Property

PowerLanguage.NET Help

Account.OpenPL Property

Open profit/loss (PnL) value.

[Browsable(Browsable=False)]
public double? OpenPL { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


Profile Property

PowerLanguage.NET Help

Account.Profile Property

Profile name.

public string Profile { public get; private set; }

See Also

Account Class | PowerLanguage.TradeManager Namespace


IAccounts Interface

An 'accounts' access interface.

public interface IAccounts : IDataSource<Account>

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage.TradeManager Namespace


IBaseFilter<T> Interface

A base filter interface.

For a list of all members of this type, see IBaseFilter<T> Members .

PowerLanguage.TradeManager.IBaseFilter<T>
PowerLanguage.TradeManager.IListFilter`1

public interface IBaseFilter<T> : IBaseFilterNotify

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IBaseFilter<T> Members | PowerLanguage.TradeManager Namespace


IBaseFilter<T> Members

IBaseFilter<T> overview

Public Instance Properties

CurrentIsAll | Read-only property. Indicates whether current filter is set to 'all', i.e. there is no filtering.
CurrentValue | Read-write property. Current filter value.
Values | Read-only property. Returns filter values.

See Also

IBaseFilter<T> Interface | PowerLanguage.TradeManager Namespace


IBaseFilter<T> Properties

The properties of the IBaseFilter<T> interface are listed below. For a complete list of IBaseFilter<T> interface members, see the IBaseFilter<T> Members topic.

Public Instance Properties

CurrentIsAll | Read-only property. Indicates whether current filter is set to 'all', i.e. there is no filtering.
CurrentValue | Read-write property. Current filter value.
Values | Read-only property. Returns filter values.

See Also

IBaseFilter<T> Interface | PowerLanguage.TradeManager Namespace


CurrentIsAll Property

PowerLanguage.NET Help

IBaseFilter`1.CurrentIsAll Property

Read-only property. Indicates whether current filter is set to 'all', i.e. there is no filtering.

public bool CurrentIsAll { public get; }

See Also

IBaseFilter<T> Interface | PowerLanguage.TradeManager Namespace


CurrentValue Property

PowerLanguage.NET Help

IBaseFilter`1.CurrentValue Property

Read-write property. Current filter value.

public T CurrentValue { public get; public set; }

See Also

IBaseFilter<T> Interface | PowerLanguage.TradeManager Namespace


Values Property

PowerLanguage.NET Help

IBaseFilter`1.Values Property

Read-only property. Returns filter values.

public T[] Values { public get; }

See Also

IBaseFilter<T> Interface | PowerLanguage.TradeManager Namespace


IBaseFilterNotify Interface

A base filter 'notify' interface.

For a list of all members of this type, see IBaseFilterNotify Members .

PowerLanguage.TradeManager.IBaseFilterNotify
PowerLanguage.TradeManager.IBaseFilter`1
PowerLanguage.TradeManager.IDateTimeFilter
PowerLanguage.TradeManager.IListFilter`1

public interface IBaseFilterNotify

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IBaseFilterNotify Members | PowerLanguage.TradeManager Namespace


IBaseFilterNotify Members

IBaseFilterNotify overview

Public Instance Events

CurrentChanged Raised when current filter is changed.

See Also

IBaseFilterNotify Interface | PowerLanguage.TradeManager Namespace


IBaseFilterNotify Events

The events of the IBaseFilterNotify interface are listed below. For a complete list of IBaseFilterNotify interface members, see the IBaseFilterNotify Members topic.

Public Instance Events

CurrentChanged Raised when current filter is changed.

See Also

IBaseFilterNotify Interface | PowerLanguage.TradeManager Namespace


IBaseFilterNotify.CurrentChanged Event

Raised when current filter is changed.

event EventHandler CurrentChanged;

See Also

IBaseFilterNotify Interface | PowerLanguage.TradeManager Namespace


IDataSource<T> Interface

A base data source interface.

For a list of all members of this type, see IDataSource<T> Members .

PowerLanguage.TradeManager.IDataSource<T>
PowerLanguage.TradeManager.IAccounts
PowerLanguage.TradeManager.ILogs
PowerLanguage.TradeManager.IOrders
PowerLanguage.TradeManager.IPositions

public interface IDataSource<T>

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IDataSource<T> Members | PowerLanguage.TradeManager Namespace


IDataSource<T> Members

IDataSource<T> overview

Public Instance Events

Added | Raised when 'item' is added.
Changed | Raised when 'item' is changed.
Deleted | Raised when 'item' is deleted.
DeletedAll | Raised when all 'items' are deleted.
FinishChanging | FinishChanging event occurs after the data was changed.
ReloadFinished | Raised when 'reload' is finished.
ReloadStarted | Raised when 'reload' is started.
StartChanging | StartChanging event occurs before the data is changed.

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T> Events

The events of the IDataSource<T> interface are listed below. For a complete list of IDataSource<T> interface members, see the IDataSource<T> Members topic.

Public Instance Events

Added | Raised when 'item' is added.
Changed | Raised when 'item' is changed.
Deleted | Raised when 'item' is deleted.
DeletedAll | Raised when all 'items' are deleted.
FinishChanging | FinishChanging event occurs after the data was changed.
ReloadFinished | Raised when 'reload' is finished.
ReloadStarted | Raised when 'reload' is started.
StartChanging | StartChanging event occurs before the data is changed.

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.Added Event

Raised when 'item' is added.

event TItemsChanged<T> Added;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.Changed Event

Raised when 'item' is changed.

event TItemsChanged<T> Changed;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.Deleted Event

Raised when 'item' is deleted.

event TItemsChanged<T> Deleted;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.DeletedAll Event

Raised when all 'items' are deleted.

event EventHandler DeletedAll;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.FinishChanging Event

FinishChanging event occurs after the data was changed.

event EventHandler FinishChanging;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.ReloadFinished Event

Raised when 'reload' is finished.

event EventHandler ReloadFinished;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.ReloadStarted Event

Raised when 'reload' is started.

event EventHandler ReloadStarted;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDataSource<T>.StartChanging Event

StartChanging event occurs before the data is changed.

event EventHandler StartChanging;

See Also

IDataSource<T> Interface | PowerLanguage.TradeManager Namespace


IDateTimeFilter Interface

A DateTime filter interface.

For a list of all members of this type, see IDateTimeFilter Members .

public interface IDateTimeFilter : IBaseFilterNotify

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IDateTimeFilter Members | PowerLanguage.TradeManager Namespace


IDateTimeFilter Members

IDateTimeFilter overview

Public Instance Properties

From | 'From DateTime' filter value.
To | 'To DateTime' filter value.

Public Instance Methods

Set Set both filter values

See Also

IDateTimeFilter Interface | PowerLanguage.TradeManager Namespace


IDateTimeFilter Properties

The properties of the IDateTimeFilter interface are listed below. For a complete list of IDateTimeFilter interface members, see the IDateTimeFilter Members topic.

Public Instance Properties

From | 'From DateTime' filter value.
To | 'To DateTime' filter value.

See Also

IDateTimeFilter Interface | PowerLanguage.TradeManager Namespace


From Property

PowerLanguage.NET Help

IDateTimeFilter.From Property

'From DateTime' filter value.

public DateTime From { public get; public set; }

See Also

IDateTimeFilter Interface | PowerLanguage.TradeManager Namespace


To Property

PowerLanguage.NET Help

IDateTimeFilter.To Property

'To DateTime' filter value.

public DateTime To { public get; public set; }

See Also

IDateTimeFilter Interface | PowerLanguage.TradeManager Namespace


IDateTimeFilter Methods

The methods of the IDateTimeFilter interface are listed below. For a complete list of IDateTimeFilter interface members, see the IDateTimeFilter Members topic.

Public Instance Methods

Set Set both filter values

See Also

IDateTimeFilter Interface | PowerLanguage.TradeManager Namespace


IDateTimeFilter.Set Method

Set both filter values

void Set(
DateTime from,
DateTime to
);

Parameters

from
to

See Also

IDateTimeFilter Interface | PowerLanguage.TradeManager Namespace


IDentifiable Interface

An interface for identification.

For a list of all members of this type, see IDentifiable Members .

public interface IDentifiable

Types that implement IDentifiable

Type | Description
Account | The structure that defines account information.
Log | The structure that defines log string.
Order | The structure that defines order info.
Position | The structure that defines position info.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IDentifiable Members | PowerLanguage.TradeManager Namespace


IDentifiable Members

IDentifiable overview

Public Instance Properties

ID Read-only property. Returns ID.

See Also

IDentifiable Interface | PowerLanguage.TradeManager Namespace


IDentifiable Properties

The properties of the IDentifiable interface are listed below. For a complete list of IDentifiable interface members, see the IDentifiable Members topic.

Public Instance Properties

ID Read-only property. Returns ID.

See Also

IDentifiable Interface | PowerLanguage.TradeManager Namespace


ID Property

PowerLanguage.NET Help

IDentifiable.ID Property

Read-only property. Returns ID.

public string ID { public get; }

See Also

IDentifiable Interface | PowerLanguage.TradeManager Namespace


IListFilter<T> Interface

Interface for list filter.

public interface IListFilter<T> : IBaseFilter<T>, IBaseFilterNotify

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage.TradeManager Namespace


ILogs Interface

A 'logs' source interface.

For a list of all members of this type, see ILogs Members .

public interface ILogs : IDataSource<Log>

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

ILogs Members | PowerLanguage.TradeManager Namespace


ILogs Members

ILogs overview

Public Instance Properties

CategoryFltr | Read-only property. Returns message category filter.
IntervalFltr | Read-only property. Returns DateTime interval filter.
ProfileFltr | Read-only property. Returns profile filter.
SourceFltr | Read-only property. Returns source filter.
SymbolFltr | Read-only property. Returns symbol filter.

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


ILogs Properties

The properties of the ILogs interface are listed below. For a complete list of ILogs interface members, see the ILogs Members topic.

Public Instance Properties

CategoryFltr | Read-only property. Returns message category filter.
IntervalFltr | Read-only property. Returns DateTime interval filter.
ProfileFltr | Read-only property. Returns profile filter.
SourceFltr | Read-only property. Returns source filter.
SymbolFltr | Read-only property. Returns symbol filter.

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


CategoryFltr Property

PowerLanguage.NET Help

ILogs.CategoryFltr Property

Read-only property. Returns message category filter.

public IListFilter<ETM_MessageCategory> CategoryFltr { public get; }

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


IntervalFltr Property

PowerLanguage.NET Help

ILogs.IntervalFltr Property

Read-only property. Returns DateTime interval filter.

public IDateTimeFilter IntervalFltr { public get; }

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


ProfileFltr Property

PowerLanguage.NET Help

ILogs.ProfileFltr Property

Read-only property. Returns profile filter.

public IListFilter<string> ProfileFltr { public get; }

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


SourceFltr Property

PowerLanguage.NET Help

ILogs.SourceFltr Property

Read-only property. Returns source filter.

public IListFilter<string> SourceFltr { public get; }

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


SymbolFltr Property

PowerLanguage.NET Help

ILogs.SymbolFltr Property

Read-only property. Returns symbol filter.

public IListFilter<string> SymbolFltr { public get; }

See Also

ILogs Interface | PowerLanguage.TradeManager Namespace


IOrders Interface

An 'orders data' source interface.

For a list of all members of this type, see IOrders Members .

public interface IOrders : IDataSource<Order>

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IOrders Members | PowerLanguage.TradeManager Namespace


IOrders Members

IOrders overview

Public Instance Properties

AccountFltr | Read-only property. Returns account filter.
IntervalFltr | Read-only property. Returns DateTime interval filter.
ProfileFltr | Read-only property. Returns profile filter.
StatesFilter | Read-only property. Returns order state filter.
StrategyIDFltr | Read-only property. For internal use only. Avoid using it to prevent unpredicted results!
SymbolFltr | Read-only property. Returns symbol filter.

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


IOrders Properties

The properties of the IOrders interface are listed below. For a complete list of IOrders interface members, see the IOrders Members topic.

Public Instance Properties

AccountFltr | Read-only property. Returns account filter.
IntervalFltr | Read-only property. Returns DateTime interval filter.
ProfileFltr | Read-only property. Returns profile filter.
StatesFilter | Read-only property. Returns order state filter.
StrategyIDFltr | Read-only property. For internal use only. Avoid using it to prevent unpredicted results!
SymbolFltr | Read-only property. Returns symbol filter.

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


AccountFltr Property

PowerLanguage.NET Help

IOrders.AccountFltr Property

Read-only property. Returns account filter.

public IListFilter<string> AccountFltr { public get; }

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


IntervalFltr Property

PowerLanguage.NET Help

IOrders.IntervalFltr Property

Read-only property. Returns DateTime interval filter.

public IDateTimeFilter IntervalFltr { public get; }

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


ProfileFltr Property

PowerLanguage.NET Help

IOrders.ProfileFltr Property

Read-only property. Returns profile filter.

public IListFilter<string> ProfileFltr { public get; }

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


StatesFilter Property

PowerLanguage.NET Help

IOrders.StatesFilter Property

Read-only property. Returns order state filter.

public IListFilter<ETM_FilterOrdersStates> StatesFilter { public get; }

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


StrategyIDFltr Property

PowerLanguage.NET Help

IOrders.StrategyIDFltr Property

Read-only property. For internal use only. Avoid using it to prevent unpredicted results!

public IListFilter<int> StrategyIDFltr { public get; }

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


SymbolFltr Property

PowerLanguage.NET Help

IOrders.SymbolFltr Property

Read-only property. Returns symbol filter.

public IListFilter<string> SymbolFltr { public get; }

See Also

IOrders Interface | PowerLanguage.TradeManager Namespace


IPositions Interface

A 'positions data' source interface.

For a list of all members of this type, see IPositions Members .

public interface IPositions : IDataSource<Position>

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

IPositions Members | PowerLanguage.TradeManager Namespace


IPositions Members

IPositions overview

Public Instance Properties

AccountFltr | Read-only property. Returns account filter.
ProfileFltr | Read-only property. Returns profile filter.
SymbolFltr | Read-only property. Returns symbol filter.

See Also

IPositions Interface | PowerLanguage.TradeManager Namespace


IPositions Properties

The properties of the IPositions interface are listed below. For a complete list of IPositions interface members, see the IPositions Members topic.

Public Instance Properties

AccountFltr | Read-only property. Returns account filter.
ProfileFltr | Read-only property. Returns profile filter.
SymbolFltr | Read-only property. Returns symbol filter.

See Also

IPositions Interface | PowerLanguage.TradeManager Namespace


AccountFltr Property

PowerLanguage.NET Help

IPositions.AccountFltr Property

Read-only property. Returns account filter.

public IListFilter<string> AccountFltr { public get; }

See Also

IPositions Interface | PowerLanguage.TradeManager Namespace


ProfileFltr Property

PowerLanguage.NET Help

IPositions.ProfileFltr Property

Read-only property. Returns profile filter.

public IListFilter<string> ProfileFltr { public get; }

See Also

IPositions Interface | PowerLanguage.TradeManager Namespace


SymbolFltr Property

PowerLanguage.NET Help

IPositions.SymbolFltr Property

Read-only property. Returns symbol filter.

public IListFilter<string> SymbolFltr { public get; }

See Also

IPositions Interface | PowerLanguage.TradeManager Namespace


ITradeManager Interface

Trade manager access interface.

For a list of all members of this type, see ITradeManager Members .

public interface ITradeManager

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

ITradeManager Members | PowerLanguage.TradeManager Namespace


ITradeManager Members

ITradeManager overview

Public Instance Properties

TradingData | Read-only property. Returns trading data.
TradingProfiles | Read-only property. Returns profile array.

Public Instance Methods

ProcessEvents Overloaded. Process trade manager events.

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace


ITradeManager Properties

The properties of the ITradeManager interface are listed below. For a complete list of ITradeManager interface members, see the ITradeManager Members topic.

Public Instance Properties

TradingData | Read-only property. Returns trading data.
TradingProfiles | Read-only property. Returns profile array.

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace


TradingData Property

PowerLanguage.NET Help

ITradeManager.TradingData Property

Read-only property. Returns trading data.

public ITradingData TradingData { public get; }

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace


TradingProfiles Property

PowerLanguage.NET Help

ITradeManager.TradingProfiles Property

Read-only property. Returns profile array.

public ITradingProfile[] TradingProfiles { public get; }

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace


ITradeManager Methods

The methods of the ITradeManager interface are listed below. For a complete list of ITradeManager interface members, see the ITradeManager Members topic.

Public Instance Methods

ProcessEvents Overloaded. Process trade manager events.

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace


ProcessEvents Method

PowerLanguage.NET Help

ITradeManager.ProcessEvents Method

Process trade manager events.

Overload List

Process trade manager events.

void ProcessEvents()

Process trade manager events.

void ProcessEvents(TimeSpan)

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace


ITradeManager.ProcessEvents() Method

Process trade manager events.

void ProcessEvents();

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace | ITradeManager.ProcessEvents Overload List


ITradeManager.ProcessEvents(TimeSpan) Method

Process trade manager events.

void ProcessEvents(
TimeSpan max_time
);

Parameters

max_time
Time interval.

See Also

ITradeManager Interface | PowerLanguage.TradeManager Namespace | ITradeManager.ProcessEvents Overload List


ITradingData Interface

Trade data access interface.

For a list of all members of this type, see ITradingData Members .

public interface ITradingData

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

ITradingData Members | PowerLanguage.TradeManager Namespace


ITradingData Members

ITradingData overview

Public Instance Properties

Accounts | Read-only property. Returns accounts info.
Logs | Read-only properties. Returns logs info.
Orders | Read-only properties. Returns orders info.
Positions | Read-only properties. Returns position info.

See Also

ITradingData Interface | PowerLanguage.TradeManager Namespace


ITradingData Properties

The properties of the ITradingData interface are listed below. For a complete list of ITradingData interface members, see the ITradingData Members topic.

Public Instance Properties

Accounts | Read-only property. Returns accounts info.
Logs | Read-only properties. Returns logs info.
Orders | Read-only properties. Returns orders info.
Positions | Read-only properties. Returns position info.

See Also

ITradingData Interface | PowerLanguage.TradeManager Namespace


Accounts Property

PowerLanguage.NET Help

ITradingData.Accounts Property

Read-only property. Returns accounts info.

public IAccounts Accounts { public get; }

See Also

ITradingData Interface | PowerLanguage.TradeManager Namespace


Logs Property

PowerLanguage.NET Help

ITradingData.Logs Property

Read-only properties. Returns logs info.

public ILogs Logs { public get; }

See Also

ITradingData Interface | PowerLanguage.TradeManager Namespace


Orders Property

PowerLanguage.NET Help

ITradingData.Orders Property

Read-only properties. Returns orders info.

public IOrders Orders { public get; }

See Also

ITradingData Interface | PowerLanguage.TradeManager Namespace


Positions Property

PowerLanguage.NET Help

ITradingData.Positions Property

Read-only properties. Returns position info.

public IPositions Positions { public get; }

See Also

ITradingData Interface | PowerLanguage.TradeManager Namespace


ITradingProfile Interface

An interface for accessing trading profile.

For a list of all members of this type, see ITradingProfile Members .

public interface ITradingProfile

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

ITradingProfile Members | PowerLanguage.TradeManager Namespace


ITradingProfile Members

ITradingProfile overview

Public Instance Properties

Accounts | Read-only property. Returns the list of accounts in the trading profile.
ConnectionState | Read-only property. Returns trading profile actual connection state. The possible values are: eTM_CC_Connected, eTM_CC_Connecting, eTM_CC_Disconnected
CurrentAccount | Read-write property for accessing the current account in the trading profile.
CurrentSymbol | Read-write property for accessing the current symbol in the trading profile.
ModifiableFields | Read-only property. Returns order fields that may be modified.
Name | Read-only property. Returns trading profile name.
PluginName | Read-only property. Returns trading profile plug-in name.

Public Instance Methods

CancelOrder | Cancel specified order.
ModifyOrder | Modify specified order.
PlaceOCOOrders | Places One-Cancel-Others (OCO) group order with specified parameters.
PlaceOrder | Places new order with specified parameters.

Public Instance Events

Connection | Raised when connection is changed.
RT | Raised when real-time data added.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile Properties

The properties of the ITradingProfile interface are listed below. For a complete list of ITradingProfile interface members, see the ITradingProfile Members topic.

Public Instance Properties

Accounts | Read-only property. Returns the list of accounts in the trading profile.
ConnectionState | Read-only property. Returns trading profile actual connection state. The possible values are: eTM_CC_Connected, eTM_CC_Connecting, eTM_CC_Disconnected
CurrentAccount | Read-write property for accessing the current account in the trading profile.
CurrentSymbol | Read-write property for accessing the current symbol in the trading profile.
ModifiableFields | Read-only property. Returns order fields that may be modified.
Name | Read-only property. Returns trading profile name.
PluginName | Read-only property. Returns trading profile plug-in name.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


Accounts Property

PowerLanguage.NET Help

ITradingProfile.Accounts Property

Read-only property. Returns the list of accounts in the trading profile.

public string[] Accounts { public get; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ConnectionState Property

PowerLanguage.NET Help

ITradingProfile.ConnectionState Property

Read-only property. Returns trading profile actual connection state. The possible values are: eTM_CC_Connected, eTM_CC_Connecting, eTM_CC_Disconnected

public ETM_ConnectionChanged ConnectionState { public get; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


CurrentAccount Property

PowerLanguage.NET Help

ITradingProfile.CurrentAccount Property

Read-write property for accessing the current account in the trading profile.

public string CurrentAccount { public get; public set; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


CurrentSymbol Property

PowerLanguage.NET Help

ITradingProfile.CurrentSymbol Property

Read-write property for accessing the current symbol in the trading profile.

public MCSymbolInfo CurrentSymbol { public get; public set; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ModifiableFields Property

PowerLanguage.NET Help

ITradingProfile.ModifiableFields Property

Read-only property. Returns order fields that may be modified.

public MTPA_ModifiableOrderFields ModifiableFields { public get; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


Name Property

PowerLanguage.NET Help

ITradingProfile.Name Property

Read-only property. Returns trading profile name.

public string Name { public get; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


PluginName Property

PowerLanguage.NET Help

ITradingProfile.PluginName Property

Read-only property. Returns trading profile plug-in name.

public string PluginName { public get; }

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile Methods

The methods of the ITradingProfile interface are listed below. For a complete list of ITradingProfile interface members, see the ITradingProfile Members topic.

Public Instance Methods

CancelOrder | Cancel specified order.
ModifyOrder | Modify specified order.
PlaceOCOOrders | Places One-Cancel-Others (OCO) group order with specified parameters.
PlaceOrder | Places new order with specified parameters.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile.CancelOrder Method

Cancel specified order.

void CancelOrder(
int order_id
);

Parameters

order_id
Cancelled order ID.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile.ModifyOrder Method

Modify specified order.

void ModifyOrder(
int order_id,
OrderParams order,
MTPA_ModifiableOrderFields fields_for_modify
);

Parameters

order_id
Specified order ID.
order
New order parameters.
fields_for_modify
Modified order fields.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile.PlaceOCOOrders Method

Places One-Cancel-Others (OCO) group order with specified parameters.

int[] PlaceOCOOrders(
MTPA_OCOGroupType oco_type,
params OrderParams[] orders
);

Parameters

oco_type
OCO group type.
orders
Order parameters.

Return Value

Array of IDs for new orders.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile.PlaceOrder Method

Places new order with specified parameters.

int PlaceOrder(
OrderParams order
);

Parameters

order
Order parameters.

Return Value

New order ID.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile Events

The events of the ITradingProfile interface are listed below. For a complete list of ITradingProfile interface members, see the ITradingProfile Members topic.

Public Instance Events

Connection | Raised when connection is changed.
RT | Raised when real-time data added.

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile.Connection Event

Raised when connection is changed.

event TConnection Connection;

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


ITradingProfile.RT Event

Raised when real-time data added.

event TRealtime RT;

See Also

ITradingProfile Interface | PowerLanguage.TradeManager Namespace


Log Structure

The structure that defines log string.

For a list of all members of this type, see Log Members .

System.Object
Log

public struct Log : IDentifiable

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

Log Members | PowerLanguage.TradeManager Namespace


Log Members

Log overview

Public Instance Properties

Category | Returns category of this message.
ID |
Profile | Returns the name of the profile from which this message was received.
Source | Returns the strategy name from which this message was received.
Symbol | Returns symbol name (for messages from a strategies).
Text | Returns text of message.
Time | Returns time when this log message was issued.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Log Class | PowerLanguage.TradeManager Namespace


Log Properties

The properties of the Log structure are listed below. For a complete list of Log structure members, see the Log Members topic.

Public Instance Properties

Category | Returns category of this message.
ID |
Profile | Returns the name of the profile from which this message was received.
Source | Returns the strategy name from which this message was received.
Symbol | Returns symbol name (for messages from a strategies).
Text | Returns text of message.
Time | Returns time when this log message was issued.

See Also

Log Class | PowerLanguage.TradeManager Namespace


Category Property

PowerLanguage.NET Help

Log.Category Property

Returns category of this message.

[Browsable(Browsable=False)]
public ETM_MessageCategory Category { public get; private set; }

See Also

Log Class | PowerLanguage.TradeManager Namespace


ID Property

PowerLanguage.NET Help

Log.ID Property

[Browsable(Browsable=False)]
public string ID { public get; private set; }

Implements

IDentifiable.ID

See Also

Log Class | PowerLanguage.TradeManager Namespace


Profile Property

PowerLanguage.NET Help

Log.Profile Property

Returns the name of the profile from which this message was received.

public string Profile { public get; private set; }

See Also

Log Class | PowerLanguage.TradeManager Namespace


Source Property

PowerLanguage.NET Help

Log.Source Property

Returns the strategy name from which this message was received.

public string Source { public get; private set; }

See Also

Log Class | PowerLanguage.TradeManager Namespace


Symbol Property

PowerLanguage.NET Help

Log.Symbol Property

Returns symbol name (for messages from a strategies).

public string Symbol { public get; private set; }

See Also

Log Class | PowerLanguage.TradeManager Namespace


Text Property

PowerLanguage.NET Help

Log.Text Property

Returns text of message.

public string Text { public get; private set; }

See Also

Log Class | PowerLanguage.TradeManager Namespace


Time Property

PowerLanguage.NET Help

Log.Time Property

Returns time when this log message was issued.

public DateTime Time { public get; private set; }

See Also

Log Class | PowerLanguage.TradeManager Namespace


MCSymbolInfo Structure

Structure that defines MultiCharts' symbol info.

For a list of all members of this type, see MCSymbolInfo Members .

System.Object
MCSymbolInfo

public struct MCSymbolInfo

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

MCSymbolInfo Members | PowerLanguage.TradeManager Namespace


MCSymbolInfo Members

MCSymbolInfo overview

Public Instance Constructors

MCSymbolInfo Constructor Initializes a new instance of DOMPrice.

Public Instance Fields

data_feed | Data source.
symbol | Symbol information.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

MCSymbolInfo Class | PowerLanguage.TradeManager Namespace


MCSymbolInfo Constructor

Initializes a new instance of DOMPrice.

MCSymbolInfo(
MTPA_MCSymbolInfo2 symbol,
string dataFeed
);

Parameters

symbol
Symbol information.
dataFeed
Data source.

See Also

MCSymbolInfo Class | PowerLanguage.TradeManager Namespace


MCSymbolInfo Fields

The fields of the MCSymbolInfo structure are listed below. For a complete list of MCSymbolInfo structure members, see the MCSymbolInfo Members topic.

Public Instance Fields

data_feed | Data source.
symbol | Symbol information.

See Also

MCSymbolInfo Class | PowerLanguage.TradeManager Namespace


MCSymbolInfo.data_feed Field

Data source.

public string data_feed;

See Also

MCSymbolInfo Class | PowerLanguage.TradeManager Namespace


MCSymbolInfo.symbol Field

Symbol information.

public MTPA_MCSymbolInfo2 symbol;

See Also

MCSymbolInfo Class | PowerLanguage.TradeManager Namespace


Order Structure

The structure that defines order info.

For a list of all members of this type, see Order Members .

System.Object
Order

public struct Order : IDentifiable

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

Order Members | PowerLanguage.TradeManager Namespace


Order Members

Order overview

Public Static Methods

CompareByDT Compare orders by time. If order doesn't have a final state (Filled, Cancelled, Rejected) its time is GeneratedDT; otherwise FinalDT.

Public Instance Constructors

Order Constructor Initializes a new instance of Order.

Public Instance Properties

Account | Account name.
Action | Order action.
BrokerSpecificID | Broker ID value.
BrokerSymbol | Broker symbol name.
Category | Order category.
Contracts | Number of contracts.
ExecPrice | Executed price value.
FilledContracts | Number of filled contracts.
FinalDT | Return order's last update time.
GeneratedDT | Return order's place time.
IsManual | Indicates whether the order is manual.
LeftContracts | Number of filled contracts.
LimitPrice | Limit price value.
MCSymbol | MC symbol name.
Name | Order name.
OCOGroupID | One-Cancel-Others group's ID value.
OrderID | Order ID value.
Profile | Profile name.
Resolution | Resolution as string.
State | Order state.
StopPrice | Stop price value.
StrategyName | Strategy name.
TIF | Order's Time In Force value.
TIFDate | Order's Time In Force date. Must be specified for Good Till Date.
Workspace | Workspace name.

Public Instance Methods

Equals
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Order Class | PowerLanguage.TradeManager Namespace


Order Constructor

Initializes a new instance of Order.

Order(
ITC_OrderItem order
);

Parameters

order
Raw order information.

See Also

Order Class | PowerLanguage.TradeManager Namespace


Order Properties

The properties of the Order structure are listed below. For a complete list of Order structure members, see the Order Members topic.

Public Instance Properties

Account | Account name.
Action | Order action.
BrokerSpecificID | Broker ID value.
BrokerSymbol | Broker symbol name.
Category | Order category.
Contracts | Number of contracts.
ExecPrice | Executed price value.
FilledContracts | Number of filled contracts.
FinalDT | Return order's last update time.
GeneratedDT | Return order's place time.
IsManual | Indicates whether the order is manual.
LeftContracts | Number of filled contracts.
LimitPrice | Limit price value.
MCSymbol | MC symbol name.
Name | Order name.
OCOGroupID | One-Cancel-Others group's ID value.
OrderID | Order ID value.
Profile | Profile name.
Resolution | Resolution as string.
State | Order state.
StopPrice | Stop price value.
StrategyName | Strategy name.
TIF | Order's Time In Force value.
TIFDate | Order's Time In Force date. Must be specified for Good Till Date.
Workspace | Workspace name.

See Also

Order Class | PowerLanguage.TradeManager Namespace


Account Property

PowerLanguage.NET Help

Order.Account Property

Account name.

public string Account { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Action Property

PowerLanguage.NET Help

Order.Action Property

Order action.

[Browsable(Browsable=False)]
public ETM_OrderAction Action { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


BrokerSpecificID Property

PowerLanguage.NET Help

Order.BrokerSpecificID Property

Broker ID value.

public string BrokerSpecificID { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


BrokerSymbol Property

PowerLanguage.NET Help

Order.BrokerSymbol Property

Broker symbol name.

[Browsable(Browsable=False)]
public string BrokerSymbol { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Category Property

PowerLanguage.NET Help

Order.Category Property

Order category.

[Browsable(Browsable=False)]
public ETM_OrderCategory Category { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Contracts Property

PowerLanguage.NET Help

Order.Contracts Property

Number of contracts.

public int Contracts { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


ExecPrice Property

PowerLanguage.NET Help

Order.ExecPrice Property

Executed price value.

[Browsable(Browsable=False)]
public double? ExecPrice { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


FilledContracts Property

PowerLanguage.NET Help

Order.FilledContracts Property

Number of filled contracts.

public int FilledContracts { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


FinalDT Property

PowerLanguage.NET Help

Order.FinalDT Property

Return order's last update time.

public DateTime? FinalDT { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


GeneratedDT Property

PowerLanguage.NET Help

Order.GeneratedDT Property

Return order's place time.

public DateTime GeneratedDT { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


IsManual Property

PowerLanguage.NET Help

Order.IsManual Property

Indicates whether the order is manual.

[Browsable(Browsable=False)]
public bool IsManual { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


LeftContracts Property

PowerLanguage.NET Help

Order.LeftContracts Property

Number of filled contracts.

public int LeftContracts { public get; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


LimitPrice Property

PowerLanguage.NET Help

Order.LimitPrice Property

Limit price value.

[Browsable(Browsable=False)]
public double? LimitPrice { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


MCSymbol Property

PowerLanguage.NET Help

Order.MCSymbol Property

MC symbol name.

[Browsable(Browsable=False)]
public string MCSymbol { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Name Property

PowerLanguage.NET Help

Order.Name Property

Order name.

public string Name { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


OCOGroupID Property

PowerLanguage.NET Help

Order.OCOGroupID Property

One-Cancel-Others group's ID value.

public string OCOGroupID { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


OrderID Property

PowerLanguage.NET Help

Order.OrderID Property

Order ID value.

[Browsable(Browsable=False)]
public int OrderID { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Profile Property

PowerLanguage.NET Help

Order.Profile Property

Profile name.

public string Profile { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Resolution Property

PowerLanguage.NET Help

Order.Resolution Property

Resolution as string.

public string Resolution { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


State Property

PowerLanguage.NET Help

Order.State Property

Order state.

[Browsable(Browsable=False)]
public ETM_OrderState State { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


StopPrice Property

PowerLanguage.NET Help

Order.StopPrice Property

Stop price value.

[Browsable(Browsable=False)]
public double? StopPrice { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


StrategyName Property

PowerLanguage.NET Help

Order.StrategyName Property

Strategy name.

public string StrategyName { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


TIF Property

PowerLanguage.NET Help

Order.TIF Property

Order's Time In Force value.

[Browsable(Browsable=False)]
public ETM_OrderTIF TIF { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


TIFDate Property

PowerLanguage.NET Help

Order.TIFDate Property

Order's Time In Force date. Must be specified for Good Till Date.

[Browsable(Browsable=False)]
public DateTime? TIFDate { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Workspace Property

PowerLanguage.NET Help

Order.Workspace Property

Workspace name.

public string Workspace { public get; private set; }

See Also

Order Class | PowerLanguage.TradeManager Namespace


Order Methods

The methods of the Order structure are listed below. For a complete list of Order structure members, see the Order Members topic.

Public Static Methods

CompareByDT Compare orders by time. If order doesn't have a final state (Filled, Cancelled, Rejected) its time is GeneratedDT; otherwise FinalDT.

Public Instance Methods

Equals
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Order Class | PowerLanguage.TradeManager Namespace


Order.CompareByDT Method

Compare orders by time. If order doesn't have a final state (Filled, Cancelled, Rejected) its time is GeneratedDT; otherwise FinalDT.

public static int CompareByDT(
Order left,
Order right
);

Parameters

left
right

Return Value

See Also

Order Class | PowerLanguage.TradeManager Namespace


Order.Equals Method

public override bool Equals(
object obj
);

See Also

Order Class | PowerLanguage.TradeManager Namespace


OrderParams Structure

Structure describing parameters of the order.

For a list of all members of this type, see OrderParams Members .

System.Object
OrderParams

public struct OrderParams

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

OrderParams Members | PowerLanguage.TradeManager Namespace


OrderParams Members

OrderParams overview

Public Instance Fields

action | Order action field. The possible values are eMTPA_OA_Buy and eMTPA_OA_Sell.
category | Order category field. The possible values are: eMTPA_OA_Sell, eMTPA_OC_Market, eMTPA_OC_MarketRange, eMTPA_OC_Stop, eMTPA_OC_StopLimit, eMTPA_OC_Unsupported
contracts | Number of contracts in the order.
gtd | The 'good till date' (GTD) value. Must be determined if the Time In Force (TIF) is eMTPA_TIF_GTD.
limit_price | Limit price value.
stop_price | Stop price value.
tif | The time in force. The possible values are: eMTPA_TIF_AON, eMTPA_TIF_DAY, eMTPA_TIF_FOK, eMTPA_TIF_GTC, eMTPA_TIF_GTD, eMTPA_TIF_IOC, eMTPA_TIF_UNSPECIFIED, eMTPA_TIF_Unsupported

Public Instance Properties

AsMTPA Read-only property. Returns order as MTPA_SOrder3.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams Fields

The fields of the OrderParams structure are listed below. For a complete list of OrderParams structure members, see the OrderParams Members topic.

Public Instance Fields

action | Order action field. The possible values are eMTPA_OA_Buy and eMTPA_OA_Sell.
category | Order category field. The possible values are: eMTPA_OA_Sell, eMTPA_OC_Market, eMTPA_OC_MarketRange, eMTPA_OC_Stop, eMTPA_OC_StopLimit, eMTPA_OC_Unsupported
contracts | Number of contracts in the order.
gtd | The 'good till date' (GTD) value. Must be determined if the Time In Force (TIF) is eMTPA_TIF_GTD.
limit_price | Limit price value.
stop_price | Stop price value.
tif | The time in force. The possible values are: eMTPA_TIF_AON, eMTPA_TIF_DAY, eMTPA_TIF_FOK, eMTPA_TIF_GTC, eMTPA_TIF_GTD, eMTPA_TIF_IOC, eMTPA_TIF_UNSPECIFIED, eMTPA_TIF_Unsupported

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.action Field

Order action field. The possible values are eMTPA_OA_Buy and eMTPA_OA_Sell.

public MTPA_OrdrActn action;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.category Field

Order category field. The possible values are: eMTPA_OA_Sell, eMTPA_OC_Market, eMTPA_OC_MarketRange, eMTPA_OC_Stop, eMTPA_OC_StopLimit, eMTPA_OC_Unsupported

public MTPA_OrdrCtgry category;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.contracts Field

Number of contracts in the order.

public int contracts;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.gtd Field

The 'good till date' (GTD) value. Must be determined if the Time In Force (TIF) is eMTPA_TIF_GTD.

public DateTime gtd;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.limit_price Field

Limit price value.

public double limit_price;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.stop_price Field

Stop price value.

public double stop_price;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams.tif Field

The time in force. The possible values are: eMTPA_TIF_AON, eMTPA_TIF_DAY, eMTPA_TIF_FOK, eMTPA_TIF_GTC, eMTPA_TIF_GTD, eMTPA_TIF_IOC, eMTPA_TIF_UNSPECIFIED, eMTPA_TIF_Unsupported

public MTPA_OrdrTimeInForce tif;

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


OrderParams Properties

The properties of the OrderParams structure are listed below. For a complete list of OrderParams structure members, see the OrderParams Members topic.

Public Instance Properties

AsMTPA Read-only property. Returns order as MTPA_SOrder3.

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


AsMTPA Property

PowerLanguage.NET Help

OrderParams.AsMTPA Property

Read-only property. Returns order as MTPA_SOrder3.

public MTPA_SOrder3 AsMTPA { public get; }

See Also

OrderParams Class | PowerLanguage.TradeManager Namespace


Position Structure

The structure that defines position info.

For a list of all members of this type, see Position Members .

System.Object
Position

public struct Position : IDentifiable

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

Position Members | PowerLanguage.TradeManager Namespace


Position Members

Position overview

Public Instance Constructors

Position Constructor Initializes a new instance of Position.

Public Instance Properties

Account | Account name.
AvgPrice | Average Price value.
BrokerID | Position ID with broker symbol.
BrokerSymbol | Broker symbol name.
CurrencyAbbr | Currency abbreviation string "USD" for USA dollar, "EUR" for euro, etc
ID | Position ID.
MCSymbol | MC symbol name.
OpenPL | Open profit/loss value.
Profile | Profile name.
Value | Position value.

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Position Class | PowerLanguage.TradeManager Namespace


Position Constructor

Initializes a new instance of Position.

Position(
ITC_PositionItem item
);

Parameters

item
Raw position information.

See Also

Position Class | PowerLanguage.TradeManager Namespace


Position Properties

The properties of the Position structure are listed below. For a complete list of Position structure members, see the Position Members topic.

Public Instance Properties

Account | Account name.
AvgPrice | Average Price value.
BrokerID | Position ID with broker symbol.
BrokerSymbol | Broker symbol name.
CurrencyAbbr | Currency abbreviation string "USD" for USA dollar, "EUR" for euro, etc
ID | Position ID.
MCSymbol | MC symbol name.
OpenPL | Open profit/loss value.
Profile | Profile name.
Value | Position value.

See Also

Position Class | PowerLanguage.TradeManager Namespace


Account Property

PowerLanguage.NET Help

Position.Account Property

Account name.

public string Account { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


AvgPrice Property

PowerLanguage.NET Help

Position.AvgPrice Property

Average Price value.

[Browsable(Browsable=False)]
public double AvgPrice { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


BrokerID Property

PowerLanguage.NET Help

Position.BrokerID Property

Position ID with broker symbol.

[Browsable(Browsable=False)]
public string BrokerID { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


BrokerSymbol Property

PowerLanguage.NET Help

Position.BrokerSymbol Property

Broker symbol name.

[Browsable(Browsable=False)]
public string BrokerSymbol { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


CurrencyAbbr Property

PowerLanguage.NET Help

Position.CurrencyAbbr Property

Currency abbreviation string "USD" for USA dollar, "EUR" for euro, etc

[Browsable(Browsable=False)]
public string CurrencyAbbr { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


ID Property

PowerLanguage.NET Help

Position.ID Property

Position ID.

[Browsable(Browsable=False)]
public string ID { public get; private set; }

Implements

IDentifiable.ID

See Also

Position Class | PowerLanguage.TradeManager Namespace


MCSymbol Property

PowerLanguage.NET Help

Position.MCSymbol Property

MC symbol name.

[Browsable(Browsable=False)]
public string MCSymbol { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


OpenPL Property

PowerLanguage.NET Help

Position.OpenPL Property

Open profit/loss value.

[Browsable(Browsable=False)]
public double OpenPL { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


Profile Property

PowerLanguage.NET Help

Position.Profile Property

Profile name.

public string Profile { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


Value Property

PowerLanguage.NET Help

Position.Value Property

Position value.

public int Value { public get; private set; }

See Also

Position Class | PowerLanguage.TradeManager Namespace


TConnection Delegate

New connection state delegate.

public delegate void TConnection(
ETM_ConnectionChanged _state
);

Parameters

_state
New connection state.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage.TradeManager Namespace


TItemsChanged<T> Delegate

Items changed delegate.

public delegate void TItemsChanged<T>(
params T[] _items
);

Parameters

_items
Changed items

Generic template parameters

T
Any type - double, int, string, etc.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage.TradeManager Namespace


TRealtime Delegate

New real time data delegate.

public delegate void TRealtime(
double bid,
double ask
);

Parameters

bid
Bid price.
ask
Ask price.

Requirements

Namespace: PowerLanguage.TradeManager

Assembly: PLTypes (in PLTypes.dll)

See Also

PowerLanguage.TradeManager Namespace


SimplesNET

PowerLanguage.NET Help

SimplesNET Namespace

Namespace Hierarchy

Classes

Class | Description
DrawingColorHelper |


DrawingColorHelper Class

For a list of all members of this type, see DrawingColorHelper Members .

System.Object
DrawingColorHelper

public static class DrawingColorHelper

Requirements

Namespace: SimplesNET

Assembly: PLTypes (in PLTypes.dll)

See Also

DrawingColorHelper Members | SimplesNET Namespace


DrawingColorHelper Members

DrawingColorHelper overview

Public Static Methods

ByteArrayToColor
ColorToByteArray
ColorToInt
IntToColor
StrHexToColor

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawingColorHelper Class | SimplesNET Namespace


DrawingColorHelper Methods

The methods of the DrawingColorHelper class are listed below. For a complete list of DrawingColorHelper class members, see the DrawingColorHelper Members topic.

Public Static Methods

ByteArrayToColor
ColorToByteArray
ColorToInt
IntToColor
StrHexToColor

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawingColorHelper Class | SimplesNET Namespace


DrawingColorHelper.ByteArrayToColor Method

public static Color ByteArrayToColor(
byte[] bytes,
AlphaType alphaType,
ARGBScheme scheme
);

See Also

DrawingColorHelper Class | SimplesNET Namespace


DrawingColorHelper.ColorToByteArray Method

public static byte[] ColorToByteArray(
Color color,
AlphaType alphaType,
ARGBScheme scheme
);

See Also

DrawingColorHelper Class | SimplesNET Namespace


DrawingColorHelper.ColorToInt Method

public static int ColorToInt(
Color color,
AlphaType alphaType,
ARGBScheme scheme
);

See Also

DrawingColorHelper Class | SimplesNET Namespace


DrawingColorHelper.IntToColor Method

public static Color IntToColor(
int color,
AlphaType alphaType,
ARGBScheme scheme
);

See Also

DrawingColorHelper Class | SimplesNET Namespace


DrawingColorHelper.StrHexToColor Method

public static int StrHexToColor(
string strHexColor,
string strHexDefault
);

See Also

DrawingColorHelper Class | SimplesNET Namespace


SimplesNET.GridUISettings

PowerLanguage.NET Help

SimplesNET.GridUISettings Namespace

Namespace Hierarchy

Classes

Class | Description
GridColumnSettingsRegistry |
GridSettingsRegistry |


GridColumnSettingsRegistry Class

For a list of all members of this type, see GridColumnSettingsRegistry Members .

System.Object
Notify
GridColumnSettingsRegistry

public class GridColumnSettingsRegistry : Notify

Requirements

Namespace: SimplesNET.GridUISettings

Assembly: PLTypes (in PLTypes.dll)

See Also

GridColumnSettingsRegistry Members | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry Members

GridColumnSettingsRegistry overview

Public Instance Constructors

GridColumnSettingsRegistry Constructor

Public Instance Properties

Background
Foreground
IsOnFireChange (inherited from SimplesNET.Notify)
isPropertyChanged (inherited from SimplesNET.Notify)
Name

Public Instance Methods

Apply |
ApplyAndSave |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
InitToDefault |
InitToRegistry |
OnPropertyChangedEmpty (inherited from SimplesNET.Notify) | Overloaded.
Revert |
ToString (inherited from Object) |

Public Instance Events

PropertyChanged (inherited from SimplesNET.Notify)

Protected Instance Methods

Finalize (inherited from SimplesNET.Notify) |
MemberwiseClone (inherited from Object) |
OnPropertyChanged (inherited from SimplesNET.Notify) | Overloaded.
OnPropertyChanged<T> (inherited from SimplesNET.Notify) | Overloaded.

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry Constructor

GridColumnSettingsRegistry(
GridSettingsRegistry gridSettings,
string name,
int defaultBackground,
int defaultForeground
);

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry Properties

The properties of the GridColumnSettingsRegistry class are listed below. For a complete list of GridColumnSettingsRegistry class members, see the GridColumnSettingsRegistry Members topic.

Public Instance Properties

Background
Foreground
IsOnFireChange (inherited from SimplesNET.Notify)
isPropertyChanged (inherited from SimplesNET.Notify)
Name

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


Background Property

PowerLanguage.NET Help

GridColumnSettingsRegistry.Background Property

public int Background { public get; public set; }

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


Foreground Property

PowerLanguage.NET Help

GridColumnSettingsRegistry.Foreground Property

public int Foreground { public get; public set; }

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


Name Property

PowerLanguage.NET Help

GridColumnSettingsRegistry.Name Property

public string Name { public get; private set; }

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry Methods

The methods of the GridColumnSettingsRegistry class are listed below. For a complete list of GridColumnSettingsRegistry class members, see the GridColumnSettingsRegistry Members topic.

Public Instance Methods

Apply |
ApplyAndSave |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
InitToDefault |
InitToRegistry |
OnPropertyChangedEmpty (inherited from SimplesNET.Notify) | Overloaded.
Revert |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from SimplesNET.Notify) |
MemberwiseClone (inherited from Object) |
OnPropertyChanged (inherited from SimplesNET.Notify) | Overloaded.
OnPropertyChanged<T> (inherited from SimplesNET.Notify) | Overloaded.

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry.Apply Method

public void Apply();

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry.ApplyAndSave Method

public void ApplyAndSave();

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry.InitToDefault Method

public void InitToDefault(
bool isOnFireChange
);

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry.InitToRegistry Method

public void InitToRegistry(
bool isOnFireChange
);

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridColumnSettingsRegistry.Revert Method

public void Revert(
bool isOnFireChange
);

See Also

GridColumnSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry Class

For a list of all members of this type, see GridSettingsRegistry Members .

System.Object
Notify
GridSettingsRegistry

[DefaultMember(MemberName="Item")]
public class GridSettingsRegistry : Notify

Requirements

Namespace: SimplesNET.GridUISettings

Assembly: PLTypes (in PLTypes.dll)

See Also

GridSettingsRegistry Members | SimplesNET.GridUISettings Namespace


GridSettingsRegistry Members

GridSettingsRegistry overview

Public Instance Constructors

GridSettingsRegistry Constructor

Public Instance Properties

FontBoldData
FontBoldHeader
FontNameData
FontNameHeader
FontSizeData
FontSizeHeader
IsOnFireChange (inherited from SimplesNET.Notify)
isPropertyChanged (inherited from SimplesNET.Notify)
Item
Name
RegistryPath

Public Instance Methods

AddColumnSettings |
Apply |
ApplyAndSave |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
InitToDefault |
InitToRegistry |
OnPropertyChangedEmpty (inherited from SimplesNET.Notify) | Overloaded.
Revert |
ToString (inherited from Object) |

Public Instance Events

PropertyChanged (inherited from SimplesNET.Notify)

Protected Instance Methods

Finalize (inherited from SimplesNET.Notify) |
MemberwiseClone (inherited from Object) |
OnPropertyChanged (inherited from SimplesNET.Notify) | Overloaded.
OnPropertyChanged<T> (inherited from SimplesNET.Notify) | Overloaded.

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry Constructor

GridSettingsRegistry(
string registryPath,
string name,
string defaultFontNameHeader,
int defaultFontSizeHeader,
bool defaultFontBoldHeader,
string defaultFontNameData,
int defaultFontSizeData,
bool defaultFontBoldData
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry Properties

The properties of the GridSettingsRegistry class are listed below. For a complete list of GridSettingsRegistry class members, see the GridSettingsRegistry Members topic.

Public Instance Properties

FontBoldData
FontBoldHeader
FontNameData
FontNameHeader
FontSizeData
FontSizeHeader
IsOnFireChange (inherited from SimplesNET.Notify)
isPropertyChanged (inherited from SimplesNET.Notify)
Item
Name
RegistryPath

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FontBoldData Property

PowerLanguage.NET Help

GridSettingsRegistry.FontBoldData Property

public bool FontBoldData { public get; public set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FontBoldHeader Property

PowerLanguage.NET Help

GridSettingsRegistry.FontBoldHeader Property

public bool FontBoldHeader { public get; public set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FontNameData Property

PowerLanguage.NET Help

GridSettingsRegistry.FontNameData Property

public string FontNameData { public get; public set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FontNameHeader Property

PowerLanguage.NET Help

GridSettingsRegistry.FontNameHeader Property

public string FontNameHeader { public get; public set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FontSizeData Property

PowerLanguage.NET Help

GridSettingsRegistry.FontSizeData Property

public int FontSizeData { public get; public set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FontSizeHeader Property

PowerLanguage.NET Help

GridSettingsRegistry.FontSizeHeader Property

public int FontSizeHeader { public get; public set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


Item Property

PowerLanguage.NET Help

GridSettingsRegistry.Item Property

public GridColumnSettingsRegistry this[
string key
] { public get; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


Name Property

PowerLanguage.NET Help

GridSettingsRegistry.Name Property

public string Name { public get; private set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


RegistryPath Property

PowerLanguage.NET Help

GridSettingsRegistry.RegistryPath Property

public string RegistryPath { public get; private set; }

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry Methods

The methods of the GridSettingsRegistry class are listed below. For a complete list of GridSettingsRegistry class members, see the GridSettingsRegistry Members topic.

Public Instance Methods

AddColumnSettings |
Apply |
ApplyAndSave |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
InitToDefault |
InitToRegistry |
OnPropertyChangedEmpty (inherited from SimplesNET.Notify) | Overloaded.
Revert |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from SimplesNET.Notify) |
MemberwiseClone (inherited from Object) |
OnPropertyChanged (inherited from SimplesNET.Notify) | Overloaded.
OnPropertyChanged<T> (inherited from SimplesNET.Notify) | Overloaded.

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry.AddColumnSettings Method

public void AddColumnSettings(
string name,
int defaultBackground,
int defaultForeground
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry.Apply Method

public void Apply(
bool isAll
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry.ApplyAndSave Method

public void ApplyAndSave(
bool isAll
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry.InitToDefault Method

public void InitToDefault(
bool isOnFireChange,
bool isAll
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry.InitToRegistry Method

public void InitToRegistry(
bool isOnFireChange,
bool isAll
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


GridSettingsRegistry.Revert Method

public void Revert(
bool isOnFireChange,
bool isAll
);

See Also

GridSettingsRegistry Class | SimplesNET.GridUISettings Namespace


FunctionSeries`1 Hierarchy

System.Object

FunctionSeries`1
AccumSwingIndex
AccumulationDistribution
AdaptiveMovAvg
AdvanceDeclineDiff
ADXCustom
ADXRCustom
BarNumber
C_3WhSolds_3BlkCrows
C_BullEng_BearEng
C_BullHar_BearHar
C_Hammer_HangingMan
C_MornDoji_EveDoji
C_MornStar_EveStar
C_PierceLine_DkCloud
C_ShootingStar
ChaikinOsc
CloseD
CloseS
CSI
Cum
DirMovement
ExtremesFC
HighD
HighestFC
HighS
HPI
LowD
LowestFC
LowS
LWAccDis
MassIndex
McClellanOsc
OBV
OHLCPeriodsAgo
OpenD
OpenS
ParabolicSAR
Pennant
PivotReversalGen
PriceVolTrend
RS_DailyDataArray
RS_ReversalPatterns
RSI
SharpeRatio
SlowKCustom
Stochastic
StochasticExp
SummationFC
TRIX
XAverage
XAverageOrig

See Also

FunctionSeries<T> Class | FunctionSeries<T> Members | PowerLanguage.Function Namespace


FunctionSimple`1 Hierarchy

System.Object

FunctionSimple`1
ADX
ADXR
AverageFC
draw_DOM_level
FastK
FastKCustom
HullMovAvg
LinearReg
LinearRegValue
MACD
NormGradientColor
PivotHighVS
PivotHighVSBar
PivotLowVS
PivotLowVSBar
PriceOscillator
RS_Average
RS_BarsPerDay
RS_Extremes
RS_PriceExtension
RS_TrueExtremes
StdError
SwingHigh
SwingHighBar
SwingLow
SwingLowBar
TimeSeriesForecast
TriAverage
UltimateOscillator
Volatility
VolatilityStdDev
VolumeOsc
vwapResettable

See Also

FunctionSimple<T> Class | FunctionSimple<T> Members | PowerLanguage.Function Namespace


PowerLanguage.DataLoaderHierarchy

PowerLanguage.NET Help

PowerLanguage.DataLoader Hierarchy

Object
DataLoaderCache ---- IDataLoader, IDisposable

See Also

PowerLanguage.DataLoader Namespace


PowerLanguage.FunctionHierarchy

PowerLanguage.NET Help

PowerLanguage.Function Hierarchy

Object
CStudyControl ---- IChartCommands, IStudy, IDisposable
FunctionObject<T> ---- IFunctionObject<T>, ISeries<T>
FunctionSeries<T>
AccumSwingIndex
AccumulationDistribution
AdaptiveMovAvg
AdvanceDeclineDiff
ADXCustom
ADXRCustom
BarNumber
C_3WhSolds_3BlkCrows
C_BullEng_BearEng
C_BullHar_BearHar
C_Hammer_HangingMan
C_MornDoji_EveDoji
C_MornStar_EveStar
C_PierceLine_DkCloud
C_ShootingStar
ChaikinOsc
CloseD
CloseS
CSI
Cum
DirMovement
ExtremesFC
HighD
HighestFC
HighS
HPI
LowD
LowestFC
LowS
LWAccDis
MassIndex
McClellanOsc
OBV
OHLCPeriodsAgo
OpenD
OpenS
ParabolicSAR
Pennant
PivotReversalGen
PriceVolTrend
RS_DailyDataArray
RS_ReversalPatterns
RSI
SharpeRatio
SlowKCustom
Stochastic
StochasticExp
SummationFC
TRIX
XAverage
XAverageOrig
FunctionSimple<T>
ADX
ADXR
AverageFC
draw_DOM_level
FastK
FastKCustom
HullMovAvg
LinearReg
LinearRegValue
MACD
NormGradientColor
PivotHighVS
PivotHighVSBar
PivotLowVS
PivotLowVSBar
PriceOscillator
RS_Average
RS_BarsPerDay
RS_Extremes
RS_PriceExtension
RS_TrueExtremes
StdError
SwingHigh
SwingHighBar
SwingLow
SwingLowBar
TimeSeriesForecast
TriAverage
UltimateOscillator
Volatility
VolatilityStdDev
VolumeOsc
vwapResettable
_AdvanceDeclineRatio
_AvgPrice
_CCI
_CountIf
_Detrend
_Doji
_HighestBar
_LowestBar
_MedianPrice
_MFI
_Momentum
_MoneyFlow
_Next3rdFriday
_PercentChange
_PercentR
_PortfolioDataUtils
_Range
_RateOfChange
_Round2Fraction
_Text_Float
_TrueHigh
_TrueLow
_TypicalPrice
_VolumeROC
_WeightedClose
ArmsIndex
AvgTrueRange
Correlation
CurrencyHelper
EaseOfMovement
EntriesToday
ExitsToday
PortfolioHelpFunctions
SwingIndex
TPOVAHighLow
ValueType
Enum ---- IComparable, IConvertible, IFormattable
SharpeRatio.EPeriod

See Also

PowerLanguage.Function Namespace


PowerLanguage.IndicatorHierarchy

PowerLanguage.NET Help

PowerLanguage.Indicator Hierarchy

Object
CStudyControl ---- IChartCommands, IStudy, IDisposable
CStudyAbstract ---- IStudyInfo
IndicatorObject ---- IIndicatorInfo

See Also

PowerLanguage.Indicator Namespace


PowerLanguage.StrategyHierarchy

PowerLanguage.NET Help

PowerLanguage.Strategy Hierarchy

Object
CStudyControl ---- IChartCommands, IStudy, IDisposable
CStudyAbstract ---- IStudyInfo
SignalObject ---- ISignalInfo, IStrategy
PortfolioSignalObject ---- IPortfolio
IPortfolio
IPortfolioData
IPortfolioStrategy ---- IDisposable

See Also

PowerLanguage.Strategy Namespace


PowerLanguage.TradeManagerHierarchy

PowerLanguage.NET Help

PowerLanguage.TradeManager Hierarchy

Object
IAccounts ---- IDataSource<T>
IBaseFilter<T> ---- IBaseFilterNotify
IBaseFilterNotify
IDataSource<T>
IDateTimeFilter ---- IBaseFilterNotify
IDentifiable
IListFilter<T> ---- IBaseFilter<T>, IBaseFilterNotify
ILogs ---- IDataSource<T>
IOrders ---- IDataSource<T>
IPositions ---- IDataSource<T>
ITradeManager
ITradingData
ITradingProfile
Delegate ---- ICloneable, ISerializable
MulticastDelegate
TConnection
TItemsChanged<T>
TRealtime
ValueType
Account ---- IDentifiable
Log ---- IDentifiable
MCSymbolInfo
Order ---- IDentifiable
OrderParams
Position ---- IDentifiable

See Also

PowerLanguage.TradeManager Namespace


PowerLanguageHierarchy

PowerLanguage.NET Help

PowerLanguage Hierarchy

Object
ConstantObject<T> ---- ISeries<T>
CStudyControl ---- IChartCommands, IStudy, IDisposable
CStudyAbstract ---- IStudyInfo
FunctionObject<T> ---- IFunctionObject<T>, ISeries<T>
CustomInstrumentBase ---- IInstrument, ISeriesSymbolData, ISeriesSymbolDataRand, IDisposable
CustomInstrument
CustomInstrumentBase.InstrumentSettingsImpl ---- IInstrumentSettings
CustomInstrumentBase.SeriesImpl<T> ---- ISeries<T>
DrawContext
IAlert
IApplicationInfo
IArray<T> ---- IArraySeries<T>
IArray2D<T> ---- IArraySeries2D<T>
IArraySeries<T>
IArraySeries2D<T>
IArrowContainer
IArrowObject ---- IDrawObject, IEquatable<T>
ICalculationControl
ICalculationInfo
IChartCommands
IChartCustomDrawer
IChartCustomDrawRegistrator
ICustomToolBar
IDataLoader ---- IDisposable
IDataLoaderResult
IDOMData
IDrawDataEnviroment
IDrawObject ---- IEquatable<T>
IDrawSymbolBars
IExpertCommentary
IFunctionObject<T> ---- ISeries<T>
IIndicatorInfo
IInstrument ---- ISeriesSymbolData
IInstrumentSettings
IInstrumentSettingsTZI
IInstrumentTPO ---- ITPOData
IMarketPosition
InputInfo
IOrderCreator
IOrderMarket ---- IOrderObject
IOrderObject
IOrderPriced ---- IOrderObject
IOrderStopLimit ---- IOrderObject
IOutput
IPlotAttributesArray<T> ---- ISeries<T>
IPlotObject ---- IPlotObjectBase<T>
IPlotObjectBase<T>
IPlotObjectStr ---- IPlotObjectBase<T>
IPortfolioPerformance
IRectangleContainer
IRectangleObject ---- IDrawObject, IEquatable<T>
IROList<T> ---- IEnumerable<T>, IEnumerable
IROListObjectEx<T> ---- IROList<T>, IEnumerable<T>, IEnumerable
ISeries<T>
ISeriesSymbolData
ISeriesSymbolDataRand ---- ISeriesSymbolData
ISignalInfo
IStatusLine
IStrategy ---- IStudy
IStrategyPerformance
IStudy
IStudyInfo
ISymbolsStorage ---- IDisposable
ITextContainer
ITextObject ---- IDrawObject, IEquatable<T>
ITPOData
ITPODataRand ---- ITPOData
ITPODynamicSettings
ITPOSettings
ITrade
ITradeOrder
ITrendLineContainer
ITrendLineObject ---- IDrawObject, IEquatable<T>
IVar<T> ---- ISeries<T>
Lambda<T> ---- ISeries<T>
LambdaRef<T> ---- ISeries<T>, IVar<T>
Order
OrderCreator ---- IOrderCreator
OrderExit
Pair<T1,T2>
Pair<T>
Price ---- IComparable, IComparable<T>, IEquatable<T>
PriceCtx
PublicFunctions
ResourceUtils
SessionObject
SessionsParser
VariableObject<T> ---- ISeries<T>, IVar<T>
VariableSeries<T> ---- ISeries<T>, IVar<T>
Attribute
AllowSendOrdersAlwaysAttribute
CalcAtOpenNextBarAttribute
ExitFromOneEntryOnceAttribute
InputAttribute
IOGModeAttribute
MouseEventsAttribute
RecoverDrawingsAttribute
SameAsSymbolAttribute
SkipIdenticalTicksAttribute
UpdateOnEveryTickAttribute
Delegate ---- ICloneable, ISerializable
MulticastDelegate
CustomInstrumentBase.TBarFldGetter<T>
GetLambda<T>
LoadDataCallback
SetLambda<T>
ToolBarAction
ValueType
Bar ---- IEquatable<T>
BarPriceLevels
ChartPoint
Contracts
DataRequest ---- IEquatable<T>
DOMPrice
InstrumentDataRequest ---- IEquatable<T>
MouseClickArgs
PlotAttributes
PriceLevel
Resolution ---- IEquatable<T>
SOrderParameters
StatusLineData
StringPlotAttributes
TPOBar
TPOBlock
TPOBlocks
TPOProfile
Enum ---- IComparable, IConvertible, IFormattable
BoxSizeType
BreakdownType
BuildVolumeOn
CalculationReason
ChartType
ChartTypeCommonOptions
Contracts.EContractsType
CumulativeDeltaAttributes
CumulativeDeltaChartType
DataLoadedEvent
DataRequestType
DeltaAttributes
DeltaType
EAlertType
EApplicationCode
EArrowForms
EBarState
EDrawingSource
EDrawPhases
EMarketPositionSide
EOrderAction
EPlotShapes
EPlotStyle
ERectPattern
EResolution
ESpecOrdersMode
ESymbolCategory
ESymbolSettingsType
ETextStyleH
ETextStyleV
ETickTradedSide
ETickTradedSideEx
ETLStyle
ExitFromOneEntryOnce
FootPrintAttributes
FootPrintChartType
IOGMode
KagiOptions
KagiReversalType
LineBreakOptions
OptionType
OrderCategory
OrderExit.EExitType
PlotAlignment
PlotFormat
PointAndFigureBasis
PointAndFigureOptions
RenkoBasis
RenkoOptions
RequestQuoteField
RequestTimeZone
SubscribeStatusLineMode
TPOAttributes
TPOBase

See Also

PowerLanguage Namespace


SimplesNET.GridUISettingsHierarchy

PowerLanguage.NET Help

SimplesNET.GridUISettings Hierarchy

Object
Notify ---- INotifyPropertyChanged
GridColumnSettingsRegistry
GridSettingsRegistry

See Also

SimplesNET.GridUISettings Namespace


SimplesNETHierarchy

PowerLanguage.NET Help

SimplesNET Hierarchy

Object
DrawingColorHelper

See Also

SimplesNET Namespace