Charts not updating but still trading & calculating open P/L

Questions about MultiCharts and user contributed studies.
Splint
Posts: 96
Joined: 25 Nov 2011
Has thanked: 12 times
Been thanked: 1 time

Charts not updating but still trading & calculating open P/L

Postby Splint » 09 Jul 2012

Hi,

None of my charts are updating with the price as seen in TWS, but open P/L in the Order and Postition tracker window is updating. Merge data into a single chart is ticked, all of the instruments for the real time data look to be correct, chart session is 24/5, automatic order execution is switched on. It's still trading as ZR went long one contract at 1523 while the chart remained at 1517.5.

If I go into Format Instrument, I can change the real time instrument to something completely different, plot the chart and the revert back to the correct real time instrument it will update to the last trade then not update any thing after that.

Any idea what's going on with this?

Cheers
Splint

SUPER
Posts: 632
Joined: 03 Mar 2007
Has thanked: 105 times
Been thanked: 81 times

Re: Charts not updating but still trading & calculating open

Postby SUPER » 09 Jul 2012

I encountered quite similar sitauation this morning, few charts were updating while others were not for same instrument on different workspace. A reboot cleared out the problem.I have seen this behaviour before not often enough to bother me though. MC generated a error log file which was sent out, I hope it can provide some clues.

Splint
Posts: 96
Joined: 25 Nov 2011
Has thanked: 12 times
Been thanked: 1 time

Re: Charts not updating but still trading & calculating open

Postby Splint » 10 Jul 2012

Teah, a reboot seems to have got it moving. I'll keep an eye on it and see what it does.


Return to “MultiCharts”