compile does not work anymore

Questions about MultiCharts and user contributed studies.
lbj_theking
Posts: 14
Joined: 19 Mar 2013
Has thanked: 1 time

compile does not work anymore

Postby lbj_theking » 17 May 2013

Hello
I have to say I am really a bit angry. In March I upgraded to MC 8.5 and had a lot of problems, see my old remark (in this thread viewtopic.php?f=1&t=13221) . Then after the problems could not be fixed. I installed the old version which was a hell of work since you are not able to downgrade. But then everything worked again. Then a couple of days ago, I installed a new iqfeed version from then on I had problems with my intraday data in MC. On of MC support suggested, I was supposed to upgrade which I then relucantly did. At least, the iqfeed problem was solved.

Nevertheless, nearly every time I close MC now, I got an error message. Very comforting.

Furthermore, as I experienced today, I am not able to compile anything anymore in the PLeditor. Definetly error-free codes got the following compiling message:
------ Compiled with error(s): ------
Compile error
errLine 0, errColumn 0, errLineEnd 0, errColumnEnd 0
causal study: (Function)

Really super. I am really wondering why are you doing this to me. I had a super stable system with which I was totally satisfied. Now I was kind of forced to upgrade to 8.5 and have error after error...

Hope you can help me and that the time of having an unreliable sytsem is limited...

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: compile does not work anymore

Postby Henry MultiСharts » 17 May 2013

Hello lbj_theking,

The problem you have reported in this thread had been already fixed by the moment you have reported it. See my reply same day as your post.
Nevertheless, nearly every time I close MC now, I got an error message. Very comforting.
What is the exact message you have?
I am not able to compile anything anymore in the PLeditor.
Please follow this step by step gui to resolve this issue:
Compilation Error (errLine 0, errColumn 0, errLineEnd 0, errColumnEnd 0)
If this solution didn't help and you still have the issue-please come to our live chat Monday-Friday 6:30 am - 4 pm EST.

lbj_theking
Posts: 14
Joined: 19 Mar 2013
Has thanked: 1 time

Re: compile does not work anymore

Postby lbj_theking » 17 May 2013

Hello Henry

Thx for the timely feedback.

I followed the step-by-step gui. Now I would have to restart my PC which I cannot do at the moment because the market is still open. But I will keep you posted regarding the outcome...

Regarding the other issue. When I close MC, this window pops up that some error has occured and that I can send the error messages to you which I usually do.

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: compile does not work anymore

Postby Henry MultiСharts » 17 May 2013

Regarding the other issue. When I close MC, this window pops up that some error has occured and that I can send the error messages to you which I usually do.
Please send me your PC name (right click on My Computer->Properties->Computer name) so that I can find the dumps you have uploaded.

lbj_theking
Posts: 14
Joined: 19 Mar 2013
Has thanked: 1 time

Re: compile does not work anymore

Postby lbj_theking » 18 May 2013

Hello Henry

Compiling works again ! Thx for that.

And I have sent you my PC name via PM.

KAA
Posts: 2
Joined: 04 Jun 2013

Re: compile does not work anymore

Postby KAA » 04 Jun 2013

I have the same problem compiling... only my study server folder doesnt exist so i cant use the fix(es).

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: compile does not work anymore

Postby Henry MultiСharts » 04 Jun 2013

Hello KAA,

1) What is your version and build number of MultiCharts? (Help tab->About MultiCharts)
2) What is your version and edition of Windows? Do you have service pack installed for it?
For Windows Vista/7 you can find this information here: Control Panel\System and Security\System or right click on the Computer icon and select properties.
For Windows XP you can find this information here: Control Panel\System\General or right click on the Computer icon and select properties.
Please make a screenshot of this window.
3) What is the error message in compiler_error.log?
You can find the StudyServer folder here:
Windows 7/8: C:\ProgramData\TS Support\MultiCharts\StudyServer\Studies
Windows XP: %allusersprofile%\Application Data\TS Support\MultiCharts\StudyServer\Studies

KAA
Posts: 2
Joined: 04 Jun 2013

Re: compile does not work anymore

Postby KAA » 04 Jun 2013

1) MultiCharts64 Version 8.5 Release (Build 6778)
2) Win 7 Service Pack 1.
3) I cant see the compiler_error.log as I dont have a study server folder. (Which is why i cant use the fixes stated in the link you posted)

P.S. If its unclear when trying to compile i get the same message as lbj_theking

Compile error
errLine 0, errColumn 0, errLineEnd 0, errColumnEnd 0
causal study: (Function)

but i dont have any other issues he had/have.

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: compile does not work anymore

Postby Henry MultiСharts » 05 Jun 2013

KAA, have you tried to repair MultiCharts?

Please go to the Windows Control Panel-> Programs and Feature if it’s Windows 7(Add or Remove Programs if it’s Windows XP)-> MultiCharts64-> double left click –> Next-> Repair.

If this solution didn't help and you still have the issue-please come to our live chat Monday-Friday 6:30 am - 4 pm EST. We will do our best to help you.

SP
Posts: 455
Joined: 06 Feb 2006
Has thanked: 36 times
Been thanked: 283 times

Re: compile does not work anymore

Postby SP » 05 Jun 2013

Dont know if that cause the error here, but after i exported all studies and ignoring the warning
"Exporting of non-compiled studies may damage the archive's integrity." i had the same error on a previous version. I got a compiling error on all new indicators.

After reinstalling the error was gone, but after this i never do export all with uncompiled studies.

lisa
Posts: 7
Joined: 14 Aug 2012
Been thanked: 1 time

Re: compile does not work anymore

Postby lisa » 19 Jun 2013

I can't recollect what happened but I've got the same problem en no log directory
(win8/MC64)

Before making "repair": what self/custom made things (indicators, scanners with special indicators, chart features etc) will be disappeared afterwards?
How can I protect myself from loosing those things ?

Lisa

problem solved. thanks Henry
Lisa
Last edited by lisa on 19 Jun 2013, edited 1 time in total.

User avatar
LRP
Posts: 135
Joined: 07 Apr 2008
Location: Switzerland
Has thanked: 86 times
Been thanked: 12 times

Re: compile does not work anymore

Postby LRP » 19 Jun 2013

Dear Support
I am the first time at MC 64 Beta 2 @ Win 8 64bit (uptodate) and have always compile Errors with PLE. Tried already the things above, but did not help.

Compile log:
g++.exe : error: Support\MultiCharts64\StudyServer\Studies\SrcCpp\INDICA~1\IB_B40~1.dll: No such file or directory
C:\Program Files\TSSUPP~1\MULTIC~1\make\MinGW64\bin\dllwrap.exe: C:\Program Files\TSSUPP~1\MULTIC~1\make\MinGW64\bin\g++.exe exited with status 1

May i ask you to solve the problem?
Thank you very much.

User avatar
LRP
Posts: 135
Joined: 07 Apr 2008
Location: Switzerland
Has thanked: 86 times
Been thanked: 12 times

Re: compile does not work anymore

Postby LRP » 19 Jun 2013

Dear Support
I am the first time at MC 64 Beta 2 @ Win 8 64bit (uptodate) and have always compile Errors with PLE. Tried already the things above, but did not help.

Compile log:
g++.exe : error: Support\MultiCharts64\StudyServer\Studies\SrcCpp\INDICA~1\IB_B40~1.dll: No such file or directory
C:\Program Files\TSSUPP~1\MULTIC~1\make\MinGW64\bin\dllwrap.exe: C:\Program Files\TSSUPP~1\MULTIC~1\make\MinGW64\bin\g++.exe exited with status 1

May i ask you to solve the problem?
Thank you very much.
Problem solved remotly by Alex from TS-Support Team.
Thank you very much!

tfkiev
Posts: 1
Joined: 02 Jan 2014

Re: compile does not work anymore

Postby tfkiev » 02 Jan 2014

I have the same problem.

My log:
C:\MC\make\MinGW\bin\dllwrap.exe: C:\MC\make\MinGW\bin\g++.exe exited with status 1

Could you please help me?

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: compile does not work anymore

Postby Henry MultiСharts » 06 Jan 2014

I have the same problem.
My log:
C:\MC\make\MinGW\bin\dllwrap.exe: C:\MC\make\MinGW\bin\g++.exe exited with status 1
Could you please help me?
Hello tfkiev,

Please follow these instructions:
1) If you have ZoneAlarm application installed on your PC - uninstall it;
2) Follow the How to resolve the Compilation Error instructions;
3) if none of the above helps - please come to our live chat Monday-Friday 6:30 am - 4 pm EST.


Return to “MultiCharts”