LMAX: Chart not Updating at Market Opening

Questions about MultiCharts and user contributed studies.
User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

LMAX: Chart not Updating at Market Opening

Postby swz168 » 24 Jul 2013

I experience the following Chart problems with LMAX when the markets open on sunday:

- Candlessticks on Chart (60 min) is not updating, new candles are not created.
- But: Profit and Loss and the status line (Open, Close, High, Low) is updated correctly.

On weekdays, everything works fine without restarting, but I have to restart on every sunday shortly after the market has opened.

Problems happens on real account. Traded instrument is EURUSD.
I am running MC 8.7 Build 7472 on Windows Server 2008 R2.

Please check this behavior on your side! Thanks a lot.

Edit: One more Addition to the findings above: Price marker (bid) is also not updating.
Last edited by swz168 on 08 Aug 2013, edited 1 time in total.

User avatar
Henry MultiСharts
Posts: 9149
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2932 times

Re: LMAX: Chart not Updating at Market Opening on Sunday

Postby Henry MultiСharts » 01 Aug 2013

Hello swz168,

Please attach screenshots of the following windows for the problem chart/symbol:
1) Format->Instrument->Settings tab;
2) MultiCharts->File->New->QuoteManager window->double click on the problem symbol->Sessions tab.

Have you tried re-adding LMAX symbols from the data source? (QuoteManager->Instrument tab->Add symbol->From data source->LMAX)
Have you tried using the latest builds 7570/7569 of MultiCharts 8.7 Release?

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening on Sunday

Postby swz168 » 01 Aug 2013

1) Format->Instrument->Settings tab;
EUR_USD_Setting.png
(17.44 KiB) Downloaded 1555 times
2) MultiCharts->File->New->QuoteManager window->double click on the problem symbol->Sessions tab.
EUR_USD_Symbol_Sessions.png
(14.92 KiB) Downloaded 1538 times
Have you tried re-adding LMAX symbols from the data source? (QuoteManager->Instrument tab->Add symbol->From data source->LMAX)
Have you tried using the latest builds 7570/7569 of MultiCharts 8.7 Release?
I added all symbol the way you mentioned, when I opened my LMAX account a month ago. Not tried readding again.

I have installed the newest Build 7569 a couple of days ago. I will report whether that will solve the issue.

Anything wrong with the settings?

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening on Sunday

Postby swz168 » 05 Aug 2013

Great, with Build 7569, there was no chart updating problems with LMAX last Sunday. I will keep an eye on this issue the following weekends.

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening on Sunday

Postby swz168 » 06 Aug 2013

- Candlessticks on Chart (60 min) is not updating, new candles are not created.
- But: Profit and Loss and the status line (Open, Close, High, Low) is updated correctly.
Today, when I entered one trade, the profit and loss display on chart (showing Euro profit/loss)
immediateley showed a profit! It was an totally wrong value. And that value stayed always the same (fixed). Due to real account trading I had to restart immdiateley.

Please investigate. ( It is the second time I expierence this)!

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening on Sunday

Postby swz168 » 07 Aug 2013

Maybe not directly related to LMAX, but it is an chart/indicator updating problem in the status line. This happened several times without being reproduce every step leading to it. It seems to be more random, when having Multicharts on, and doing nothing but suddenly the indicator stop updating. Everything else on chart is fine, data are received.

See picture:
BidAskSpread_not_updating.png
(1.75 KiB) Downloaded 1535 times
That is the code:

Code: Select all

variables:
var0( 0 ),
var1( 0 ),
var2( 0 ),
multiplier (0);


if GetAppInfo( aiRealTimeCalc ) = 1 then
begin
var0 = InsideBid ;
var1 = InsideAsk ;

multiplier = PriceScale/10;
var2 = (var1-var0)* multiplier ;

Plot1( var0, "Bid" ) ;
Plot2( var1, "Ask" ) ;
plot3( var2, "Spread" );

end ;
Here are the properties:
BidAskSpread_Property.png
(9.48 KiB) Downloaded 1527 times

When I copy and paste the chart, the new chart updates the bid/ask/spread indicator, but it is only a matter of time that it won't. A restart solves the problem only temporarily.

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening

Postby swz168 » 08 Aug 2013

Unfortunately, with build 7569, it seems the chart updating problem mentioned in post #1 is not solved.

Yesterday, the chart wasn't updating new candles at session opening for the symbol "Wall Street 30". All other CFDs and currency updated without problem.

I changed the subject of this thread, since it seems not only the sunday is a problem, the chart updating problem could be at any other day at session begin, and it could be any instrument.

The strange thing is, sometimes everything is fine, sometimes, suddenly no chart update at session begin. Not all open chart have the problem, even for the same symbols (copied chart), one updates, the other not.

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: LMAX: Chart not Updating at Market Opening

Postby Andrew MultiCharts » 08 Aug 2013

Should be fixed in 7633/7634 builds.

Please come to our live chat to let our operators connect to your PC if the issue persists with the builds above.

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening

Postby swz168 » 19 Aug 2013

My assumption in viewtopic.php?f=1&t=43360&p=97491&sid=1 ... 09b#p96409 (Post #7) was right. Nothing has changed.

The problem in mentioned in this thread (#1) appeared again. I restarted again and everything was fine. Currently I'm not able to do an live chat session due to full time job. And when this occured, the live chat is offline (Sunday 23:05 German time, market opening time of LMAX, EURUSD)

I would really like to listen to TJ's advice to not upgrade to a new version of MC, if everything works fine and no new features is needed. Unfortunately, since I own a MC licence, I was always forced to upgrade due to several bugs.

In the newest release, I only have this chart updating problem, everything else works perfectly. MC, please implement mechanisms that avoids chart updating problems. (As mentioned, data is received, but chart not correctly updated)

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: LMAX: Chart not Updating at Market Opening

Postby Andrew MultiCharts » 19 Aug 2013

If the issue takes place with latest MC builds (7833 or 7634), unfortunately we will not be able to study and fix the issue without remote connection to your PC.

User avatar
swz168
Posts: 120
Joined: 30 Sep 2010
Location: Germany
Has thanked: 47 times
Been thanked: 32 times

Re: LMAX: Chart not Updating at Market Opening

Postby swz168 » 19 Aug 2013

Andrew, I'm using the latest build 7634. It is very unsatisfying to hear that nothing can be fixed without remote connection! If the markets open on Sunday, I would have to wait for more than 11 or 12 hours to have someone checking remotely the problem. As I said, I'm trading live, so that will not be possible. I would love to, but currently it is not possible for me to spend maybe hours for remote sessions. So due to this situation, I have to restart Multicharts.

Is there anything I can do on my side, so that it would still be possible for you to check the problem?

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: LMAX: Chart not Updating at Market Opening

Postby Andrew MultiCharts » 21 Aug 2013

We will continue studying the case and trying to reproduce it to our end. I'll update you as soon as i have any news.

User avatar
t-rader
Posts: 139
Joined: 02 Feb 2011
Location: Australia
Has thanked: 11 times
Been thanked: 27 times

Re: LMAX: Chart not Updating at Market Opening

Postby t-rader » 02 Sep 2013

I too am getting this issue and wanted to make it aware this isn't just a single user issue. I've not yet updated to the latest version but will update as soon as I can.

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: LMAX: Chart not Updating at Market Opening

Postby Andrew MultiCharts » 16 Sep 2013

After fixing a related issue, the problem has not occur. Please wait for coming MC 8.8 beta 1 to install and try to reproduce the issue. Should be working fine then.


Return to “MultiCharts”