IQFeed - Unused symbols are not released

Questions about MultiCharts and user contributed studies.
dahmen walter
Posts: 53
Joined: 19 Oct 2007
Has thanked: 43 times
Been thanked: 2 times

IQFeed - Unused symbols are not released

Postby dahmen walter » 02 Sep 2013

Hello,

on the weekend I switched from 8.5 to the latest 8.7634.400 and from IQFeed 5.0.0.14 to the latest IQFeed 5.1.0 .3.
I realized that opening a workspace increases the counter of symbols in IQFeed Feed Stats Connection Manager but closing of the workspace does not decrease the number of symbols and therefore limiting the access to symbols dramatically. Switching back to IQFeed 5.0.0.14 does not change this behavior so I assume that something in Quotemanger management of symbols has changed from pre 8.7x releases to the current one.
Please restore previous behavior.

Kind regards

Walter

sptrader
Posts: 710
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 470 times
Been thanked: 261 times
Contact:

Re: Bug with IQFeed - Unused symbols are not released

Postby sptrader » 02 Sep 2013

IQFeed 5.1.0.4. is the latest version , but I don't know if it will make a difference...
I use IQfeed as well but I don't use more han 100 symbols, so it doesn't affect me, if the symbols aren't "released"... I didn't know that they were supposed to be...released..when a chart was closed.. I've never checked it before, I'll try to remember to try it tomorrow..

User avatar
Henry MultiСharts
Posts: 9136
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2929 times

Re: IQFeed - Unused symbols are not released

Postby Henry MultiСharts » 18 Sep 2013

Walter, please make sure you are not running Portfolio Backtester and Collect RT data w/o plotting is turned off for your IQFeed symbols in the QuoteManager.

dahmen walter
Posts: 53
Joined: 19 Oct 2007
Has thanked: 43 times
Been thanked: 2 times

Re: IQFeed - Unused symbols are not released

Postby dahmen walter » 18 Sep 2013

Walter, please make sure you are not running Portfolio Backtester and Collect RT data w/o plotting is turned off for your IQFeed symbols in the QuoteManager.
Henry, i have not running Portfolio Backtester and only a few of the symbols (41 of the NYSE and 8 of the NASDAQ out of totally 500 Stock symbols on NYSE and NASDAQ) are set to collect RT w/o plotting in Quotemanger. Behavior is new to the latest MC version but disconnect for symbols from eSignal works as in the previous version. Though this does not affect my trading as I use a total of about 250 symbols to collect data from but the non release of scanner workspaces with alerts enabled to send mails to my local mail server just to check for daily signals requires me to close MC and QuoteManager completely twice to enforce the disconnection. IQFed 5.1.0.5 makes no difference to the behavior.

Doing it manually inside QuoteManager shows the same effect live on IQFeed connection manager as shown here http://www.screencast.com/t/tSuQ8lYXy.

User avatar
Henry MultiСharts
Posts: 9136
Joined: 25 Aug 2011
Has thanked: 1260 times
Been thanked: 2929 times

Re: IQFeed - Unused symbols are not released

Postby Henry MultiСharts » 19 Sep 2013

This issue has been confirmed. The fix is targeted to one of the future versions (not MultiCharts 8.8 beta 1).


Return to “MultiCharts”