Data collection and backtest  [SOLVED]

Questions about MultiCharts and user contributed studies.
Wally_AD
Posts: 47
Joined: 28 Jan 2014
Has thanked: 8 times
Been thanked: 7 times

Data collection and backtest

Postby Wally_AD » 10 May 2014

I run a backtest some days with data from data IQFeed for one year.
In the Quote Manager "Collect RT Data" was set to ON.
Trying to run the same backtest in the Portfolio Backtester some days later without an internet connection did not work. The missing internet connection was the reason. I thougth data are collected in the database of the Quote manager and can be used later without other downloads.

User avatar
JoshM
Posts: 2151
Joined: 20 May 2011
Location: The Netherlands
Has thanked: 1534 times
Been thanked: 1529 times
Contact:

Re: Data collection and backtest

Postby JoshM » 12 May 2014

Trying to run the same backtest in the Portfolio Backtester some days later without an internet connection did not work. The missing internet connection was the reason. I thougth data are collected in the database of the Quote manager and can be used later without other downloads.
What were your Data Download Mode settings in the Portfolio Backtester?


Wally_AD
Posts: 47
Joined: 28 Jan 2014
Has thanked: 8 times
Been thanked: 7 times

Re: Data collection and backtest

Postby Wally_AD » 12 May 2014

I guess "Download Data Before Backtesting" checkbox is activated. Can't check right now as MC is running on another machine.

The issue is then that if one day - the last day - is missing in the database the backtest is not started.
Correct, but without any hint not user friendly.

regards

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: Data collection and backtest

Postby Andrew MultiCharts » 13 May 2014

... the backtest is not started...
Do you mean there is an error message?

Wally_AD
Posts: 47
Joined: 28 Jan 2014
Has thanked: 8 times
Been thanked: 7 times

Re: Data collection and backtest  [SOLVED]

Postby Wally_AD » 18 May 2014

There is a window shown:
"Loading Data ... "

Instrument --- Status
@ES#C,IQFeed --- None

No error message. The program tries to load data and was waiting for ever for a connection.

The user has to cancel the backtest and change the data range, so that more data do not need to be downloaded.

This is not an issue.
I can't remember the problem I had two week before. So this topic can be closed.

Thank you Andrew.


Return to “MultiCharts”