KSE K200 June contract: No Data after 24/3/2017  [SOLVED]

Questions about MultiCharts and user contributed studies.
benho
Posts: 45
Joined: 27 Dec 2015
Has thanked: 10 times
Been thanked: 1 time

KSE K200 June contract: No Data after 24/3/2017

Postby benho » 07 Apr 2017

Hi there,

Is there anyone having problem in receiving data and charting Korea K200 futures, particularly the June contract 017M ? I can backfill the previous months contracts as usual. However, I can't backfill the June contract (017M). There is no data collected for June contract since 24th, March 2017. More information as follow:

1. Data feed: IB
2. I can see the live data of June contract from IB TWS as usual.
3. No real time data is collected in QM since 24/3. Collect RT Data w/o Plotting is ON.
4. If I remove the 017M symbol and add it back again in QM: Add Symbol -> From Data Source -> InteractiveBrokers
Then I start a new chart, it shows "No Data". See attached capture.

I didn't change anything in my MC settings. Is there anything change in IB or KSE which causes this problem ? Any hint is appreciated.

Thanks.
Attachments
Untitled2.png
Untitled2.png (37.64 KiB) Viewed 339 times
Untitled.png
Untitled.png (36.77 KiB) Viewed 339 times

wzero
Posts: 142
Joined: 10 Jul 2014
Has thanked: 12 times
Been thanked: 10 times

Re: KSE K200 June contract: No Data after 24/3/2017

Postby wzero » 08 Apr 2017

I have no problem with the 017M symbol.

benho
Posts: 45
Joined: 27 Dec 2015
Has thanked: 10 times
Been thanked: 1 time

Re: KSE K200 June contract: No Data after 24/3/2017

Postby benho » 08 Apr 2017

wzero wrote:I have no problem with the 017M symbol.


Data feed= IB ?

wzero
Posts: 142
Joined: 10 Jul 2014
Has thanked: 12 times
Been thanked: 10 times

Re: KSE K200 June contract: No Data after 24/3/2017

Postby wzero » 08 Apr 2017

benho wrote:
wzero wrote:I have no problem with the 017M symbol.


Data feed= IB ?


Sure, IB data feed. MC.Net 9.1

benho
Posts: 45
Joined: 27 Dec 2015
Has thanked: 10 times
Been thanked: 1 time

Re: KSE K200 June contract: No Data after 24/3/2017

Postby benho » 08 Apr 2017

wzero wrote:
benho wrote:
wzero wrote:I have no problem with the 017M symbol.


Data feed= IB ?


Sure, IB data feed. MC.Net 9.1


It seems there is something wrong with my MC platform. Mine is MC 10.0

It is very strange that when I plot 017M symbol => reload all data ... MC seems just ignore this request.
However, if I repeat the same data reload process with 017H symbol, it works as usual.
It is so strange !!

benho
Posts: 45
Joined: 27 Dec 2015
Has thanked: 10 times
Been thanked: 1 time

Re: KSE K200 June contract: No Data after 24/3/2017  [SOLVED]

Postby benho » 08 Apr 2017

Hi there,

I just find the root cause.
The symbol (017M) multiplier is changed. So IB API just doesn't recognize the symbol with incorrect multiplier.


Return to “MultiCharts”