Chart not loading all quotes  [SOLVED]

Questions about MultiCharts and user contributed studies.
Automeq
Posts: 103
Joined: 16 Apr 2014
Has thanked: 14 times
Been thanked: 1 time

Chart not loading all quotes

Postby Automeq » 14 Jun 2018

I have the QQQ quotes in Quote manager, from 9/Mar/99 to 11/Jun/18, Metastock format (taken from Yahoo, converted to Metastock format and imported to Multichart).

As you see, if I load in Quote manager the end is 11/Jun/18.
QQQ.JPG
(252.26 KiB) Downloaded 544 times
However in MC the chart only loads until Mar/18
QQQ1.JPG
(116.04 KiB) Downloaded 544 times
QQQ2.JPG
(50.81 KiB) Downloaded 544 times

I have already tried several things, with no result (the problem subsist):

- Closed fully MC. No result

- Closed fully MC and turned off the PC. No result.

- Clear chache in symbol quote manager. No result

- Closed QQQ chart, deleted QQQ symbol, created QQQ symbol again, import again quotes (all is imported until Jun/18), Open a new chart. No result

- Created a symbol QQQtest, import quotes. This worked. When I opened the symbol QQQtest I had all the quotes (this means that the import file is OK). I deleted QQQ symbol, and renamed QQQtest to QQQ. However, when I open a new chart with QQQ the problem came back (nothing loaded after 10/Mar/18)

Any ideas why this is happening and what can I do to overtake it ?
MultiCharts64 Version 11.0 Release (Build 16148)

User avatar
Anna MultiCharts
Posts: 461
Joined: 14 Jul 2017
Has thanked: 31 times
Been thanked: 113 times

Re: Chart not loading all quotes

Postby Anna MultiCharts » 18 Jun 2018

Hello, Automeq!

Most likely there’s an issue with your database.
Please send us the Logs by going Help -> Feedback. You need just “Attach a screenshot”, “Attach Log files…”, “Attach minidump…”, “Data for active instruments…” and “Upload collected data to helpdesk” options checked.

Automeq
Posts: 103
Joined: 16 Apr 2014
Has thanked: 14 times
Been thanked: 1 time

Re: Chart not loading all quotes

Postby Automeq » 19 Jun 2018

Thanks. Already sent.

Automeq
Posts: 103
Joined: 16 Apr 2014
Has thanked: 14 times
Been thanked: 1 time

Re: Chart not loading all quotes  [SOLVED]

Postby Automeq » 20 Jun 2018

I found the cause of this.
This database was initially imported in Metastock using a csv file.
Multicharts (or QuoteManager) was reading the Metastock directory directly (as far as I understand).
In the meantime I updated missing dates in QuoteManager instead of updating them in Metastock.
Therefore, although we can see all the dates in QuoteManager, they are not displayed in the chart (I don't know why)

Now I tried to updated the missing dates in Metastock and after doing that I can already display all dates in Multicharts without any problem.

For me this is solved. Up to you guys if you want to see anything else. If not please close the ticket (this was sent to Svetlana and she passed it to the engineering team).


Return to “MultiCharts”