Broker disappears from Order and Position Tracker

Questions about MultiCharts and user contributed studies.
firemag
Posts: 41
Joined: 15 Sep 2017
Has thanked: 8 times
Been thanked: 2 times

Broker disappears from Order and Position Tracker

Postby firemag » 15 Mar 2018

I have a recurring problem with the Order and Position Tracker. I have two brokers - GAIN Capital and IB. Gain Capital will often disappear from the open positions tab. When I try to display All or just select a single broker, only IB shows up in the list:

2018-03-15_21-21-33.png
2018-03-15_21-21-33.png (27.65 KiB) Viewed 256 times


As you can see, the broker GAIN Capital is still connected and "green". But it does not show up in the broker list below in the Tracker. When I click "Multiple", only IB shows up.

The only way I have found to correct this is to disconnect Gain Capital and reconnect. Then the broker and all open positions immediately show up in the tracker. But, of course, this disables all the strategies associated with Gain Capital and I have to turn them all back on, as well as deal with any open stops. So that "solution" doesn't work well.

I am running MultiCharts64 Version 11.0 Release (Build 15808)

Why is GAIN Capital disappearing from the tracker?

User avatar
Henry MultiСharts
Posts: 9047
Joined: 25 Aug 2011
Has thanked: 1250 times
Been thanked: 2905 times

Re: Broker disappears from Order and Position Tracker

Postby Henry MultiСharts » 16 Mar 2018

Hello firemag,

If it happens again please go to Help tab->Feedback (or Windows Start menu->All programs->MultiCharts64->Feedback).
Select these options:
- Attach a screenshot;
- Attach log files to help us understand what happened
- Upload collected data to Help Desk.
Uncheck the other options as we do not need them right now.

firemag
Posts: 41
Joined: 15 Sep 2017
Has thanked: 8 times
Been thanked: 2 times

Re: Broker disappears from Order and Position Tracker

Postby firemag » 16 Mar 2018

Henry MultiСharts wrote:If it happens again please go to Help tab->Feedback (or Windows Start menu->All programs->MultiCharts64->Feedback).
Ok, thanks. Will do.


Return to “MultiCharts”