Performance Issue - Drawing objects

Questions about MultiCharts and user contributed studies.
PK1
Posts: 79
Joined: 12 Jun 2011
Has thanked: 32 times
Been thanked: 8 times

Performance Issue - Drawing objects

Postby PK1 » 21 Mar 2019

Hello,

since a few months my two MC-Workspaces I use mainly have become slowly and almost impossible to do something with the charts like scrolling, selecting something, opening propery windows or alike. Everything I do inside MC is juddering, not going smoothly as it used to be. Even trying to draw a simple trendline then I click onto the icon for the trendline and have to wait a few seconds in order to click the start end end point on the chart. The same applies when opening a property window or anything like that.

From the last years I know that MC can be really fast even with many indicators and windows and some major versions had good performance improvements but the last months it was just a pain to use MC while trading at the same time ... it simply costs me money and I was in the need of changing to a faster application after 8 years using MC.

So I checked many things like reducing the amount of charts, checking all my indicators, log-files, external libs, there's more than enough memory, everything is SSD-based, etc. pp. --> Nothing, even simple scrolling is juddering. Also weeks ago I changed to Win10 with a complete new installation of MC plus importing the existing workspaces. Using IB I know that the TWS has a known memory leak problem (Java-Garbage-Collector running into problems) sometimes causing a freeze of TWS and closing MC is helping (because of releasing ressources needed for the API). But the problem now is also in Offline-Mode. With new installation of MC for Win10 I was thinking to optimize the existing MC-Database but couldn't figure out whether this is still needed, the docs were very old regarding that topic.

It seemed that in the background something is dragging the entire performance and every simple action has like a brake on it. Like as if there where too many handles to be processed every time I do something on the charts, dragging the performance down. Clicking on an icon for a new drawing object MC seems to do a alot internal things before I can actually apply/draw the new drawing object onto the chart. Before the chart is flashing many times.

So I was thinking MC maybe has to iterate over existing indicators and/or drawing objects everytime I do something in the chart and what I've seen that thinking was right, dragging the performance down. Imho that's an performance bottleneck.

Checking further I separated different types of drawing objects and found the major issue ---> one single ARC I had drawn months ago. Actually I never use that kind of object because there's no real usage for it and the behavior is strange when applying it. There's the need for drawing a semicircle like seen on many charts for marking head and shoulderss for example but MC has no good possibility for that except maybe boxes.

Removing that single ARC and thereafter scrolling the chart and drawing new objects was a huge difference, way better. Unfortunately I can't reproduce it with a newly created ARC (except maybe with a backup of the workspace). So it seems MC was treating that ARC created long ago differently which was causing the performance problem.

I can't figure out why the single ARC was making such a difference and newly applied ARCs don't when working with MC but I'd appreciate it if developer would check what could have been the problem. All the fancy new features are without any interest if there's such a performance issue coming out of nowhere making it almost impossible using MC while trading.

User avatar
Anna MultiCharts
Posts: 464
Joined: 14 Jul 2017
Has thanked: 31 times
Been thanked: 113 times

Re: Performance Issue - Drawing objects

Postby Anna MultiCharts » 21 Mar 2019

Hello, PK1!

We’d be able to analyze this case if you could provide us the testing environment. Do you still have a backup of that workspace with the old arc? If you open it now will the issue be reproduced? If it is easily reproduced on this workspace, please come to demonstrate the issue to our Live Chat Monday-Friday before 1PM EST (6PM GMT). We’ll do your best to help you.

PK1
Posts: 79
Joined: 12 Jun 2011
Has thanked: 32 times
Been thanked: 8 times

Re: Performance Issue - Drawing objects

Postby PK1 » 21 Mar 2019

Hello, PK1!

We’d be able to analyze this case if you could provide us the testing environment. Do you still have a backup of that workspace with the old arc? If you open it now will the issue be reproduced? If it is easily reproduced on this workspace, please come to demonstrate the issue to our Live Chat Monday-Friday before 1PM EST (6PM GMT). We’ll do your best to help you.
Ok, I'll do as suggested. The workspace is backed up.

PK1
Posts: 79
Joined: 12 Jun 2011
Has thanked: 32 times
Been thanked: 8 times

Re: Performance Issue - Drawing objects

Postby PK1 » 22 Mar 2019

Hello, PK1!

We’d be able to analyze this case if you could provide us the testing environment. Do you still have a backup of that workspace with the old arc? If you open it now will the issue be reproduced? If it is easily reproduced on this workspace, please come to demonstrate the issue to our Live Chat Monday-Friday before 1PM EST (6PM GMT). We’ll do your best to help you.
Ok, I'll do as suggested. The workspace is backed up.
Had no time for live-chat, been too busy but a check of the workspace-file before and after the only thing I've seen was that the coordinates for the object were set to 0, 0. That object removed things became better and faster but imho there are other things I need to improve like database compress for example and maybe the connection to IB can be a performance-problem too? Years ago I had way more workspaces and indicators and things were much faster.

On the attached screenshot the two pieces of code from the workspace, the upper one with the drawn arc which seemed to drag the performance down, the part below is when I draw the arc again (via mouse) The coordinates 6306, 6395 could fit as that window is on the fourth monitor right from the main-screen. Don't ask me why the coord were 0, 0. I never use MC on that monitor where 0, 0 would be.
Attachments
Chart 00027.jpg
(63.17 KiB) Downloaded 224 times

User avatar
Anna MultiCharts
Posts: 464
Joined: 14 Jul 2017
Has thanked: 31 times
Been thanked: 113 times

Re: Performance Issue - Drawing objects

Postby Anna MultiCharts » 26 Mar 2019

PK1,

I’m afraid we cannot tell anything from this screenshot. We need to view and troubleshoot the issue on site. Right now we don’t even have any idea of how this workspace impacts your performance. Please come to demonstrate the issue to Live Chat once you have a chance.
As per your suggestions about databases – unfortunately database compression is not possible in MultiCharts. But you can try reducing the size of them as described here: https://www.multicharts.com/trading-sof ... abase_Size
“maybe the connection to IB can be a performance-problem too?” – if the number of requests per second to IB is not exceeded, then all should work fine, and we do monitor this aspect from within MultiCharts and don’t send more requests than allowed.


Return to “MultiCharts”