Missing data in offline mode

Questions about MultiCharts and user contributed studies.
janus
Posts: 755
Joined: 25 May 2009
Has thanked: 41 times
Been thanked: 84 times

Missing data in offline mode

Postby janus » 14 Mar 2012

Very often when I exit MC while it was running in real-time mode then enter it in off-line mode, I can't view the most recent data collected part way through the last session. It appears I have to wait until the current session is completed while in real-time mode before I can see it in off-line mode. I checked using QM and all the data is there. So why isn't MC displaying the latest data in off-line mode until I've collected all the data in real-time mode for the latest session? I doubt very much this is the expected behaviour. So anyone else seen this?

User avatar
Henry MultiСharts
Posts: 8503
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2731 times

Re: Missing data in offline mode

Postby Henry MultiСharts » 15 Mar 2012

Please let me know who is your data feed and what resolution you are using.

janus
Posts: 755
Joined: 25 May 2009
Has thanked: 41 times
Been thanked: 84 times

Re: Missing data in offline mode

Postby janus » 15 Mar 2012

Henry Multicharts wrote:Please let me know who is your data feed and what resolution you are using.


Data feed is IB and I have several plots open with resolutions ranging from 1-minute to 10-minute. I'm going to do some further tests to see if occurs across instruments other than the one I've focused on, which happens to have a custom session template applied to it.

janus
Posts: 755
Joined: 25 May 2009
Has thanked: 41 times
Been thanked: 84 times

Re: Missing data in offline mode

Postby janus » 15 Mar 2012

I did some more checks and the latest occurrence of problem happened when the instrument in question had expired part way through the day, which is a sort of dumb thing for the exchange to do especially these days. The contract is the ASX200 SPI futures and it expired around mid-day. At other trading days the normal closing time for the day session is late in the afternoon. Today I cycled through MC several times during the day session and the data was all there in off-line mode. It doesn't explain why to data on expiry day was not displayed in off-line mode until after the normal day closing time of the session was reached. I'm certain this problem sometimes occurs during normal trading sessions as well. So, I'll keep an eye on it to see when it happens again and record under what circumstances it did to try and determine the pattern. Unfortunately, the problem, when it does occur can't be replicated for long because when the end of session arrives it disappears. Very odd I must say.

User avatar
Henry MultiСharts
Posts: 8503
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2731 times

Re: Missing data in offline mode

Postby Henry MultiСharts » 20 Mar 2012

Hello Janus,

In MultiCharts realtime IB minute data is built from ticks. These bars are not saved to the database because the bar can be different from the actual historical minute bar. So MultiCharts requests the minute data from IB server next time you request this information.

I would also recommend checking that "end time and date" in Edit data window of QuoteManager is correct and does not have any incorrect data. Erroneous bars can appear in case you have changed your PC timezone/clock or session templates.

janus
Posts: 755
Joined: 25 May 2009
Has thanked: 41 times
Been thanked: 84 times

Re: Missing data in offline mode

Postby janus » 20 Mar 2012

Thanks for the tips Henry. I will check it again in about three months when the front month contract expires. Even if it does it again, and I suspect it will possibly for the reason I highlighted, I don't think I'll worry about. It's just one day our of every three months.


Return to “MultiCharts”