Data not updating on charts

Questions about MultiCharts and user contributed studies.
Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Data not updating on charts

Postby Splint » 28 Mar 2012

Hi,

I've updated my daily historical data from Pinnacle and the data up intil 3/27/12 appears in the ASCII file but the chart does not update. Even if I create a new chart window, the most recent historical data in the chart is 3/23/12.

I also see there is no live data appearing in the chart window. I only started running live data to multicharts a couple of days ago, so I am not sure if this is normal. This may actually be due to time zones and trading hours, I'm not yet fully up to speed with that. What should I expect to see in the way of live data coming through?

Thanks
David

User avatar
Henry MultiСharts
Posts: 8503
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2731 times

Re: Data not updating on charts

Postby Henry MultiСharts » 28 Mar 2012

Hello David,

Please let me know whether you are using ASCII mapping or ASCII import.
The chart will be updated only if you are using ASCII mapping.
ASCII import is one time data import that will not update the chart automatically with the data from the source file.

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Data not updating on charts

Postby Splint » 29 Mar 2012

Hi Henry,

Yes it is ASCII Mapping. It says ASCII Mapping at the top of all chart windows.

Thanks
Splint

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Data not updating on charts

Postby Splint » 29 Mar 2012

Ok, I've done some investigating. I unticked Download Missing Historical Data in the Data Server Mode as the historical data will come from ASCII and live from IB. I also went into QM and switched on Collect R/T Data w/o Plotting and set it to collect all fields. Did this for all broker symbols. I think everything is ok now. I guess it should start placing trades in the simulated account now.

Thanks
Splint

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Data not updating on charts

Postby Splint » 05 Apr 2012

OK, I'm a little stumped at the moment. I have a chart of Comex Gold futures. I have ASCII mapping for the historical data and IB for live data. The numbers in the status line in the chart are changing but the live bar is not being created. The green arrow on the right never moves off the close of the most recent ASCII bar. I cannot figure out what is wrong with this.

I have a chart set up the same way with NASDAQ mini futures and as it updates the live data bar and the green arrow moves accordingly.

What could be wrong with this?
Attachments
Live data not plotting.jpg
Live data not plotting.jpg (92.92 KiB) Viewed 133 times

User avatar
Henry MultiСharts
Posts: 8503
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2731 times

Re: Data not updating on charts

Postby Henry MultiСharts » 05 Apr 2012

Are you able to chart IB real-time data only (without merging with historical ASCII data)?

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Data not updating on charts

Postby Splint » 05 Apr 2012

Strangely enough, I left it for about an hour and when I came back it was working correctly. Not sure why, but it seems OK now.


Return to “MultiCharts”