Chart not updating for Hang Seng Index

Questions about MultiCharts and user contributed studies.
Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Chart not updating for Hang Seng Index

Postby Splint » 14 May 2012

Hi,

TWS shows live price data for the Hang Seng Index but I am unable to get any live data into a chart of HSI, whether it be merged with ascii historical data or as a chart of live data by itself.
When I try and plot live data by itself it just says "no data" and leaves the chart blank. I have tried MAy 12 and June 12 contracts, both of which are updating in TWS.

This issue seems to be unique to HSI as I have other charts updating in real time without any issues. As far as I know, if the prices in TWS are shown to be updating in real time then the charts in Multicharts should also be able to update.

Anyone know what's going on with this?

Thanks
David

User avatar
TJ
Posts: 6583
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 970 times
Been thanked: 1907 times

Re: Chart not updating for Hang Seng Index

Postby TJ » 14 May 2012

Splint wrote:Hi,

TWS shows live price data for the Hang Seng Index but I am unable to get any live data into a chart of HSI, whether it be merged with ascii historical data or as a chart of live data by itself.
When I try and plot live data by itself it just says "no data" and leaves the chart blank. I have tried MAy 12 and June 12 contracts, both of which are updating in TWS.

This issue seems to be unique to HSI as I have other charts updating in real time without any issues. As far as I know, if the prices in TWS are shown to be updating in real time then the charts in Multicharts should also be able to update.

Anyone know what's going on with this?

Thanks
David

Have you had it working before?

What are your settings in Edit Symbol?

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Chart not updating for Hang Seng Index

Postby Splint » 15 May 2012

TJ,

No this is the first time I've tried. I am using Symbol Dictionary Sessions which doesn't look right. I'll wait until the market is open and try a custom setting.

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Chart not updating for Hang Seng Index

Postby Splint » 15 May 2012

OK,

I tried the custom template 24/5 00:00 to 23:59 and on the may and June contracts, that did not resolve the issue. I did close the chart window and open a new one in both cases to make sure the settings were applied properly.

I did also notice that even though the Collect R/T Data w/o Plotting is set to on, nothing is being received. I can see the prices updating in TWS as I type this message.

See attached images.
Attachments
HSIM12 2.jpg
HSIM12 2.jpg (36.21 KiB) Viewed 251 times
HSIM12 3.jpg
HSIM12 3.jpg (50 KiB) Viewed 243 times
HSIM12 4.jpg
HSIM12 4.jpg (19.74 KiB) Viewed 236 times
HSIM12 5.jpg
HSIM12 5.jpg (32.16 KiB) Viewed 239 times
HSIM12 6.jpg
HSIM12 6.jpg (35.85 KiB) Viewed 236 times

Splint
Posts: 77
Joined: 25 Nov 2011
Has thanked: 4 times

Re: Chart not updating for Hang Seng Index

Postby Splint » 15 May 2012

One more image.
Attachments
HSIM12 1.jpg
HSIM12 1.jpg (40.49 KiB) Viewed 245 times

User avatar
TJ
Posts: 6583
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 970 times
Been thanked: 1907 times

Re: Chart not updating for Hang Seng Index

Postby TJ » 15 May 2012

1. We are trading the May contract right now, there is hardly any activities in the June contract.

2. You are requesting data from 1983. June contract started on April 1, 2012. That's why you are getting a no data message.

3. Take your sesssion time out of 24 hrs. Otherwise MultiCharts will keep on requesting data that does not exist, and you will keep on getting a no data message.

User avatar
Henry MultiСharts
Posts: 8503
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2731 times

Re: Chart not updating for Hang Seng Index

Postby Henry MultiСharts » 16 May 2012

Splint, you need to set the correct session settings for the instrument in QuoteManager->Edit symbol.
If you do not have this information please do the following:
1) Close all charts for HSIK12 instrument. Rename it into HSIK12_old in the QuoteManager.
2) Add a new HSIK12 from the data source.
3) Create a new chart for HSIK12 instrument only (merging disabled), set the session template to 24/5 or 24/7, data range 10-14 days back in MultiCharts->Format instrument->Settings tab.

Now the data should be present on the chart and the chart should be updated in real time.

Splint wrote:I did also notice that even though the Collect R/T Data w/o Plotting is set to on, nothing is being received. I can see the prices updating in TWS as I type this message.

You need to right click on the instrument in the QuoteManager->Fields to collect.
If you are collecting only daily data-the bar values would be written into the database on the bar closing time specified in the instrument sessions tab.

If this solution didn't help and you still have the issue-please come to our live chat Monday-Friday 6:30 am - 4 pm EST. We will do our best to help you.


Return to “MultiCharts”