Use as default not working for indicators for colors and wei

Questions about MultiCharts .NET and user contributed studies.
dahmen walter
Posts: 46
Joined: 19 Oct 2007
Has thanked: 42 times
Been thanked: 2 times

Use as default not working for indicators for colors and wei

Postby dahmen walter » 24 Aug 2012

Hello,

I just realized that the check mark for personal preferences of colors is not working in MC.NET neither colors nor line weights or line styles are stored for the next use - anything special to be observed?

User avatar
Henry MultiСharts
Posts: 8434
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2701 times

Re: Use as default not working for indicators for colors and

Postby Henry MultiСharts » 27 Aug 2012

Hello Walter,

We will check that.
These users thanked the author Henry MultiСharts for the post:
dahmen walter

User avatar
Henry MultiСharts
Posts: 8434
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2701 times

Re: Use as default not working for indicators for colors and

Postby Henry MultiСharts » 28 Aug 2012

Walter, all default values are specified while constructing the corresponding object.

That means there is no need in "Use as default" option for study style. It will be eliminated in one of the future versions of MultiCharts .Net.

bluejack
Posts: 42
Joined: 02 Aug 2012
Has thanked: 25 times
Been thanked: 27 times

Re: Use as default not working for indicators for colors and

Postby bluejack » 28 Aug 2012

Henry Multicharts wrote:Walter, all default values are specified while constructing the corresponding object.

That means there is no need in "Use as default" option for study style. It will be eliminated in one of the future versions of MultiCharts .Net.

From a user point of view it would be important that this feature "Use as default" can be used in some way with the script. Imagine if I would use a protected script (if that is possible) of someone else and want other inputs by default.
These users thanked the author bluejack for the post:
dahmen walter

dahmen walter
Posts: 46
Joined: 19 Oct 2007
Has thanked: 42 times
Been thanked: 2 times

Re: Use as default not working for indicators for colors and

Postby dahmen walter » 28 Aug 2012

bluejack wrote:
Henry Multicharts wrote:Walter, all default values are specified while constructing the corresponding object.

That means there is no need in "Use as default" option for study style. It will be eliminated in one of the future versions of MultiCharts .Net.

From a user point of view it would be important that this feature "Use as default" can be used in some way with the script. Imagine if I would use a protected script (if that is possible) of someone else and want other inputs by default.


I agree there ought to be a way to gave defaults stored in xml or whatever format to be changed without changing the underlying code.

User avatar
Henry MultiСharts
Posts: 8434
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2701 times

Re: Use as default not working for indicators for colors and

Postby Henry MultiСharts » 05 Sep 2012

Unfortunately this functionality cannot be technically implemented in MultiCharts .Net.
Please specify the default values while constructing the corresponding object.
These users thanked the author Henry MultiСharts for the post:
dahmen walter


Return to “MultiCharts .NET”