Upgrading to latest beta

Questions about MultiCharts and user contributed studies.
rt1

Upgrading to latest beta

Postby rt1 » 05 Feb 2007

Is it necessary to remove 717.1171 beta before installing the new release - or will the new release install over the top of 717?

I ask as I have had problems in past where the only successful approach was to remove/reinstall which then necessitated recompling all indicators.

Thanks

User avatar
Stanley Miller
Posts: 556
Joined: 26 Jul 2005
Has thanked: 3 times

Postby Stanley Miller » 05 Feb 2007

You can uninstall the previous version or select "Repair" option, it doesn't matter and both should work without problems.

Albert

Postby Albert » 07 Feb 2007

Stanley

I tried the 'repair' option to upgrade to the latest beta and it did not do anything. It seemed to go through the process and even asked to restart the pc but then in the 'about' window, the displayed version is still the previous one ie 717.1171.

Can you advise on this? If this doesn't work I will have to unistall the previous build completely and install the new one (maybe this is how it should work). In this case can you tell me how to transfer my easylanguage studies from the previous beta 717.1171 to the latest one?

Thanks
Albert

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 07 Feb 2007

Dear Albert,

In this case can you tell me how to transfer my easylanguage studies from the previous beta 717.1171 to the latest one?


To completely backup your studies you need to export them, install new version, import the studies back.
To do so:
1. Run PLEditor.
2. File -> Export.
3. Click Select All.
4. Click OK.
5. Set .xml file destination.
6. Click Save.

After the new version is installed:
1. Run PLEditor.
2. File -> Import.
3. Select .xml file type.
4. Navigate to .xml file destination.
5. Select the file and click Open.
6. Make sure all are selected and click OK.

Now you have all the studies imported into new version.

You can make a look at online tutorial: http://www.tssupport.com/products/multi ... tudies.htm


Is it necessary to remove 717.1171 beta before installing the new release - or will the new release install over the top of 717?

When you are sure you backupes your studies you can install the new version. Usually the way to go is as following:
1. You double-click new installer file.
2. Click Remove.
It will remove the current version.
3. Double-click new installer file again and install the new version.

denizen2
Posts: 125
Joined: 17 Jul 2005

Postby denizen2 » 08 Feb 2007

One of the problems that users have with installing a new version is the "Install Wizard" is really a 'wizard' :wink: . In fact, it is more like .... well let's just say it is confusing to use :roll: . E.g. If the wizard is about 'installing', then why does it not lead you through the whole installing :?: . Instead, it first ask if you want to repair or remove, and nothing is explained about 'installing'. So, unless the user has been lucky enough to read elsewhere (on this forum) that he MUST un-install first, then the user is confused by the directions given by the install wizard. If that is what is needed, either the "install wizard" should (a) do the uninstall automatically, or (b) tell the user to first un-install (manually), etc.

Obviously, the best from the user's standpoint would be for the 'wizard' to handle both the un-install (if needed), and then the install process. So please change the wizard to at least communicate more clearly what steps and options are provided (by the wizard) so the user does not have to rely on other 'resources' to figure out what to do.


Return to “MultiCharts”