Quotemanager-Feb 18 ver  [SOLVED]

Questions about MultiCharts and user contributed studies.
3

Quotemanager-Feb 18 ver

Postby 3 » 20 Feb 2007

Thanks for continually improving the overall MC product.

With the latest general release of MC 2, I find the quote manager confusing as to how it goes about requesting and loading back-fill (historical) IB data.

Upon initially starting Quotemanager,and then MC with 'fill missing data' enabled,after already having IB's TWS running,
quotes start being collected very rapidly,then move to a 2 second interval between requests,and then progress to a much slower 20 second interval. Why is this?
In the FEB 3rd release,I 'think' the max interval was 10 seconds?

I would suppose that the amount of incoming 'Live Data' has a bearing?

Anyway,the following may be a bug or something that will be included in the next release? - Last night I forgot to change the IB exit setting from PM to AM,so the IB tws shut down at 11:59 PM.
When I came into the office at 4:30 AM this morning,I restarted ib's TWS,but Quotemanager and MC (which were running the whole night) just connected to that datafeed,and started collecting whatever live data was coming in,but they did Not attempt to fill in any of the back-data.

I had to close BOTH MC and Quotemanager to get them to start collecting 'fill in' data from overnight.
Is this the way it was designed,or will there be a change to having it work Without a shutdown?

User avatar
Kate
Posts: 758
Joined: 08 Dec 2006

  [SOLVED]

Postby Kate » 20 Feb 2007

quotes start being collected very rapidly,then move to a 2 second interval between requests,and then progress to a much slower 20 second interval. Why is this?
In the FEB 3rd release,I 'think' the max interval was 10 seconds?


The intervals between requests depend on the speed at which theses requests are fulfilled.

Last night I forgot to change the IB exit setting from PM to AM,so the IB tws shut down at 11:59 PM.
When I came into the office at 4:30 AM this morning,I restarted ib's TWS,but Quotemanager and MC (which were running the whole night) just connected to that datafeed,and started collecting whatever live data was coming in,but they did Not attempt to fill in any of the back-data.


Since you restarted MultiCharts, the logs were not saved and we cannot analyze the reasons of this problem. Anyway, please contact us if you still have a gap after restarting MultiCharts.


Return to “MultiCharts”