Compile Issue

Questions about MultiCharts and user contributed studies.
Thomas Mann
Posts: 173
Joined: 25 Aug 2007

Compile Issue

Postby Thomas Mann » 05 Nov 2007

I ran into a weird issue with a function I have been using for months. It will not compile and gives the error listed below on one of my machines. It works just fine on the other. Is there a way to tell what DLL is used in MC to functions so I can try to isolate the issue and correct it ? I have tried to repair MC already with no luck.

Function name is:

Function code:
[LegacyColorValue = TRUE];

Inputs: XDate(NumericSimple),XTime(NumericSimple);

Variables: LMinutes(0);

LMinutes = DateToJulian(CurrentDate) * 1440 + TimeToMinutes(CurrentTime) - DateToJulian(XDate) * 1440 - TimeToMinutes(XTime);
//print("LMinutes Is ",LMinutes);
XceTimeDiffMin = LMinutes;

Error is :
Compile error
errLine 0, errColumn 0, errLineEnd 0, errColumnEnd 0

User avatar
Posts: 96
Joined: 10 Jul 2007
Has thanked: 1 time
Been thanked: 1 time

Postby gautama2 » 05 Nov 2007


i tried and it works.

Maybe your function name is not correct. Perhaps a typo.


P.S. sorry i saw now that it is only on one machine. Then i don't know :(

Thomas Mann
Posts: 173
Joined: 25 Aug 2007

Postby Thomas Mann » 06 Nov 2007

Well it appears the problem can me migrated to a different machine by exporting a XML file.
I now have the issue on two different machines.
Does anyone know of a decent timer routine I could use instead of this function ?

Thomas Mann
Posts: 173
Joined: 25 Aug 2007

Postby Thomas Mann » 07 Nov 2007

I figured out the compile issue. It seems if you are not logged in as a Admin on the local machine it causes MC not to compile or work correctly.
I have no idfea why that would matter, but when I log back into the local box instead of the network I am on it works fine.

Posts: 58
Joined: 03 Jun 2007

Postby maxpi » 07 Nov 2007

That could be considered a bug. Good software does not require admin priveleges to run... somebody should tell TS that....

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 09 Nov 2007

Hi Thomas Mann,

What OS are you using? On the machine where you couldn't compile the code?

Return to “MultiCharts”