DLL for TWS 878

Questions about MultiCharts and user contributed studies.
User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

DLL for TWS 878

Postby Marina Pashkova » 06 Nov 2007

Attached please find a dll for the latest 878 version of TWS.

This dll is needed to have daily bars plotted correctly in MultiCharts.
When using this dll, please make sure to choose the same session settings in QuoteManager as in TWS.

Please unzip this file, close MultiCharts and copy it to the following folder:
YOUR DRIVE:\Program Files\TS Support\MultiCharts\Datafeeds\
and overwrite the existing file with the new one.
Attachments
tsIBDataFeed.zip
(448.78 KiB) Downloaded 122 times

User avatar
TJ
Posts: 6520
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 957 times
Been thanked: 1883 times

Postby TJ » 06 Nov 2007

instructions:

To update your IB dll,

1. download tsIBDataFeed.zip from the above post.
2. Close MultiCharts and TWS.
3. Unzip the downloaded dll file and copy to the following folder:
DRIVE:\Program Files\TS Support\MultiCharts\Datafeeds\tsibdatafeed.dll
4. if the computer asks, overwrite the old file.

The DLL will come into effect when you restart MultiCharts and TWS.

cael
Posts: 89
Joined: 06 Sep 2006
Has thanked: 2 times

Postby cael » 15 Nov 2007

I have downloaded this new DLL and replaced it on my folder but I still have trouble printing daily charts. On a new symbol I can get only 1 daily bar.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 16 Nov 2007

Hi Cael,

Please make sure you did the following:

1. Unpacked the DLL
2. Placed it into the indicated folder
3. Tried reloading the chart (ctrl+R)
4. Deleted the data for the symbol and requested it again.

If the above doesn't help, please contact us through LiveChat and we will help you through HelpDesk.

Best regards.

cael
Posts: 89
Joined: 06 Sep 2006
Has thanked: 2 times

Postby cael » 16 Nov 2007

Ouch, I didn't do that, I didn't delete the symbol (and I have quite a few).

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 16 Nov 2007

Cael,

You don't need to delete the symbol. Just the daily data for the symbol.

Best regards.

momentum
Posts: 315
Joined: 23 Nov 2005
Has thanked: 8 times
Been thanked: 14 times

Postby momentum » 16 Nov 2007

How do you delete just the daily data?

Iris Yeung
Posts: 4
Joined: 25 Aug 2007

TWS version879

Postby Iris Yeung » 17 Dec 2007

The dll do not work in TWS version 879. I still have missing data.

User avatar
TJ
Posts: 6520
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 957 times
Been thanked: 1883 times

Postby TJ » 17 Dec 2007

I am using TWS 879.8 with no problem.

giles117
Posts: 5
Joined: 12 Jun 2007

Postby giles117 » 17 Dec 2007

Not directly related to this thread title, but have you improved the data gathering from IB yet? I remember reading that you were going to adopt a data collection method similar to AB way fo breaking up the data retrieval.

There is one other thing I love about their data retrieval. I can configure how many days back it will pull historical data. So if I have a full chart I can make restarts nimble by only rewuest 1-5 days worth of data for every active symbol. Or I can change the length to fill in a chart for a newly added symbol.

Thanks....

User avatar
danilo
Posts: 170
Joined: 02 Jan 2007
Location: Italy
Has thanked: 4 times
Been thanked: 8 times

TWS 878.6 Backfill problem

Postby danilo » 19 Dec 2007

I have troubles to update daily data from IB for some symbol. For example yesterday I have added the following symbols : DXSP, DBXD traded on DTB, and I was able to get the historical data till 18-Dic-07. Today I'm not able to read the daily data for 19-Dic-07. The only workaround I have found is to delete at least the last 3 days from QuoteManager, because if I delete only 1 day the 18-Dic-07, the QuoteManager get from IB the daily data for 19-Dic-07 but skip the daily data for 18-Dic-07 that is lost.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 21 Dec 2007

Hello danilo,

Are you using the latest dll posted in this thread?

If you are, but the daily data won't display properly, please contact us through LiveChat http://messenger.providesupport.com/mes ... pport.html and our customer support representatives will help you on-line, using HelpDesk, our remote desktop connection utility if necessary.

Best regards.


Return to “MultiCharts”