autotrading problem

Questions about MultiCharts and user contributed studies.
engelmeyer elisabeth
Posts: 5
Joined: 03 Nov 2007

autotrading problem

Postby engelmeyer elisabeth » 12 Nov 2007

Running MC in autotrade I have to manualy click the yes button in the pop up window:
(Accept incoming connection attemt? YES)
when TWS is loging in again after a broken connection to the server.
Is it possible to reconnect to TWS without being prompted?

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 13 Nov 2007

Hi Elisabeth,

Currently, you need to manually click YES to accept incoming connection attempt.

This has been done to protect your computer from unauthorized incoming connections.

Regards.

nuno-online
Posts: 166
Joined: 31 Jan 2006
Has thanked: 72 times
Been thanked: 3 times

Postby nuno-online » 20 May 2009

hi
NOW,
Is it possible to reconnect to TWS without being prompted?

NR

SUPER
Posts: 624
Joined: 03 Mar 2007
Has thanked: 99 times
Been thanked: 80 times

Postby SUPER » 20 May 2009

hi
NOW,
Is it possible to reconnect to TWS without being prompted?

NR


It connects automatically now. I am using the latest beta.

nuno-online
Posts: 166
Joined: 31 Jan 2006
Has thanked: 72 times
Been thanked: 3 times

Postby nuno-online » 20 May 2009

Super

I am also using the latest beta
why this pop up opens?

SUPER
Posts: 624
Joined: 03 Mar 2007
Has thanked: 99 times
Been thanked: 80 times

Postby SUPER » 20 May 2009

You will see a pop-up for few seconds, but you don't have to do anything it will go away as soon as connection is made. Is that not the case at your end?

If it keeps happening frequently then you have to think about your internet connection which may be having interuptions.

brendanh
Posts: 154
Joined: 07 Apr 2007

Postby brendanh » 20 May 2009

You can avoid the prompt appearing completely by adding your IP to the list of Trusted Addresses in TWS: Configure, API, All API Settings, then add your Trading PC's IP address, see screenshot attached. I use the loopback IP address 127.0.0.1 which is always the local computer.
Attachments
IB API connect no prompt.gif
IB API connect no prompt.gif (3.92 KiB) Viewed 286 times

nuno-online
Posts: 166
Joined: 31 Jan 2006
Has thanked: 72 times
Been thanked: 3 times

Postby nuno-online » 20 May 2009

If i don' click yes , the pop is always here and i don't have Realtime in MC

with the solution given by brendanh, that's ok

thank you Super and brendanh

NR


Return to “MultiCharts”