PL Editor compilation error

Questions about MultiCharts and user contributed studies.
glam_100
Posts: 157
Joined: 14 Jun 2006
Has thanked: 2 times
Been thanked: 4 times

PL Editor compilation error

Postby glam_100 » 30 Jan 2008

I got the a "Cannot Sell from a SellShort strategy." error compiling the following code under MC 3.0 Beta:

-------------------------------------------------------------------
buy ("buy LE") next bar high stop;
sell short ("sell SE") next bar low stop;

buy to cover from entry ("sell SE") next bar low - 10 stop;
sell from entry ("buy LE") next bar high + 10 stop;
--------------------------------------------------------------------

Which is correct code that compiles in TS alright. The error occurs at the "Buy to cover" keyword. It seems like PL Editor mistaken "Buy to cover" with the "Sell" key word.

This problem didn't exist in the MC 2.1 version.

Please check. Thanks!

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 30 Jan 2008

This is a bug which will be fixed.

Thank you for reporting it!

glam_100
Posts: 157
Joined: 14 Jun 2006
Has thanked: 2 times
Been thanked: 4 times

Postby glam_100 » 30 Jan 2008

Any chance of this being a quick fix? I can't really do anything with the new build with EasyLanguage compilation error and I've already removed my MC 2.1 in the process of installing the latest beta...

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 31 Jan 2008

Hi,

This bug will be fixed by the end of February.

glam_100
Posts: 157
Joined: 14 Jun 2006
Has thanked: 2 times
Been thanked: 4 times

Postby glam_100 » 31 Jan 2008

by the end of feb?

What's the use of the new 3.0 beta when I can't even compile EasyLanguage with it?

I strongly urge for a quick fix for the compiler. It's one of the most basic functions.

User avatar
MC_Prog
Posts: 330
Joined: 28 Feb 2007
Has thanked: 64 times
Been thanked: 33 times

Postby MC_Prog » 01 Feb 2008

Glam - it could be the developers are taking a well-earned vacation (just my speculation ...) 8)

glam_100
Posts: 157
Joined: 14 Jun 2006
Has thanked: 2 times
Been thanked: 4 times

Postby glam_100 » 01 Feb 2008

The new beta is amazing. EL speed is much better and data loading speed has improved. My hat is off to the programming team and I know they deserve a vacation.

However I've waited for a long time for this build (since Oct 07) and now that I have the build and I got this EL compilation error. The EL compiler is a fundamental piece, and without a working compiler there is not much I can do with the new MC build. This bug wasn't in the MC 2.1

Please make it a high priority fix...

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 02 Feb 2008

Glam_100,
Marina told you that it should be fixed by the end of February, because we are going to release Beta 2 with the rest of functionality and all known bug fixes. However we do understand that we need keep releasing hot fixes for Beta 1. This is why we decided to release the next hot fix this Tuesday. The bug you reported will be fixed in this build.

glam_100
Posts: 157
Joined: 14 Jun 2006
Has thanked: 2 times
Been thanked: 4 times

Postby glam_100 » 02 Feb 2008

Thanks Andrew.

This is exactly what I meant. I was expecting frequent hot fixes for a beta build.


Return to “MultiCharts”