MC9 upgrade - IB Feed no longer works  [SOLVED]

Questions about MultiCharts and user contributed studies.
cael
Posts: 89
Joined: 06 Sep 2006
Has thanked: 2 times

MC9 upgrade - IB Feed no longer works

Postby cael » 09 Oct 2014

When I upgraded to MC9 I found that MC can no longer to download charts from Interactive Brokers or download positions. Used to work in the old version.

jpartner
Posts: 8
Joined: 22 Sep 2013
Has thanked: 2 times

Re: MC9 upgrade - IB Feed no longer works

Postby jpartner » 09 Oct 2014

Same thing here. I need to roll back to 8.8, but MC won't allow a rollback it seems. How do I go about rollling back?

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: MC9 upgrade - IB Feed no longer works

Postby Andrew MultiCharts » 10 Oct 2014

Hello cael and jpartner,

There is no need to roll back. If the issue still persists, please come to our live chat during working hours (6:30 am – 2:45 pm EST) to let our operators connect to your computer remotely and help you: http://messenger.providesupport.com/mes ... pport.html

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: MC9 upgrade - IB Feed no longer works

Postby Andrew MultiCharts » 13 Oct 2014

Just in case anyone else exprience the same issue:
  1. Open IB TWS configurations.
  2. API
  3. Settings
  4. Add 127.0.0.1 to the list of Trusted IP Addresses
  5. Click "OK".

RBN
Posts: 7
Joined: 04 Sep 2012
Has thanked: 4 times
Been thanked: 2 times

Re: MC9 upgrade - IB Feed no longer works

Postby RBN » 15 Oct 2014

Hi Andrew,

I chatted with Henry just before close of business today, and adding the trusted IP address appears to fixed it for me. But I had an Order and Position Tracker Log error that says, "No security definition has been found for the request". Do you know what that is? Thanks.

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 558 times

Re: MC9 upgrade - IB Feed no longer works  [SOLVED]

Postby Andrew MultiCharts » 16 Oct 2014

..."No security definition has been found for the request". Do you know what that is?
The "No security definition has been found for the request" message occurs when a user has incorrect Symbol Mapping settings.

Since MultiCharts can work with multiple data feeds and brokers, and most of these have a unique instrument symbology and a set of required parameters for a correct order placement, there is a way the software can automatically set up a correct symbol mapping between the same symbols from different sources with different names and exchanges.

Symbol mapping should be set up manually if the data source of the chart symbol and brokerage of the broker symbol are different.

The other reason is that one (or few) of the symbols were added incorrectly to MultiCharts/QuoteManager and they should be re-added exactly by means of symbol lookup (not manually) and the whole symbol mapping using thoses symbols should be reconfigured. For IB symbols a lot of necessary information is hidden in the description of symbols and it is vital for symbol mapping and trading in general to have the symbols in QuoteManager with correct description (added through lookup).

RBN
Posts: 7
Joined: 04 Sep 2012
Has thanked: 4 times
Been thanked: 2 times

Re: MC9 upgrade - IB Feed no longer works

Postby RBN » 16 Oct 2014

Thanks Andrew. I was messing with a couple of symbols in the quote manager that I don't currently use on current charts. I'll look at that again.


Return to “MultiCharts”