Regular Trading Hours Session Template Issue  [SOLVED]

Questions about MultiCharts and user contributed studies.
PD Quig
Posts: 151
Joined: 27 Apr 2010
Location: San Jose
Has thanked: 53 times
Been thanked: 8 times

Regular Trading Hours Session Template Issue

Postby PD Quig » 19 Oct 2017

Only one of my charts (a 30-min) uses a regular trading hour (RTH) session template. When I switched instruments from @TFS# (the ICE Russell emini contract) to the @RTY# (the CME Russell emini contract), I noticed that two bars now plot after the 16:00 session end for RTY--causing a custom indicator to stop working properly. The chart still works as expected for TFS. See attached pics.

I re-checked the session template in Quote Manager and it's fine. I even tried creating my own RTH custom template and using that. The 16:30 and 17:00 bars are still plotted for RTY only.

Any ideas why on the same chart one instrument would add bars outside the defined session hours while another would not?
Pic_1.png
Pic_1.png (231.32 KiB) Viewed 137 times
Pic_2.png
Pic_2.png (238.63 KiB) Viewed 137 times
Pic_3.png
Pic_3.png (249.38 KiB) Viewed 137 times
Pic_4.png
Pic_4.png (402.61 KiB) Viewed 137 times

User avatar
Anna MultiCharts
Posts: 73
Joined: 14 Jul 2017
Has thanked: 1 time
Been thanked: 14 times

Re: Regular Trading Hours Session Template Issue

Postby Anna MultiCharts » 31 Oct 2017

Hello, PD Quig!

ICE and CME exchanges are located in different time zones: UTC - 5 Eastern Time (US & Canada) and UTC - 6 Central Time (US & Canada) correspondingly.
If you plot the chart in Local time zone then there can be a 1 hour shift for one of the symbols which results in extra bars. If you plot the chart in Exchange time zone, then you should receive the expected results.
These users thanked the author Anna MultiCharts for the post:
PD Quig

PD Quig
Posts: 151
Joined: 27 Apr 2010
Location: San Jose
Has thanked: 53 times
Been thanked: 8 times

Re: Regular Trading Hours Session Template Issue  [SOLVED]

Postby PD Quig » 31 Oct 2017

D'oh!! Thanks, Anna. All my charts but that one use the 24/7 session. I created a custom CME RTH setting and it's all good now.


Return to “MultiCharts”