IB Symbols - N/A

Questions about MultiCharts and user contributed studies.
syswizard
Posts: 158
Joined: 15 Dec 2012
Has thanked: 13 times
Been thanked: 5 times

IB Symbols - N/A

Postby syswizard » 15 Nov 2018

I've got IQ Feed with an Emini futures subscription (not the full CME sub)
Couple of observations:
1) IQ Feed will indicate an exchange of "CME" while IB indicates it as "GLOBEX".
2) Some active Emini futures symbols are not available on IB for trading, but I can plot them with the IQ Feed:
- CD (Canadian Dollar)
- XAU (Utilities Sector)
- AD (Australian Dollar)

Strange, no ?

AlexS MultiCharts
Posts: 5
Joined: 12 Oct 2018
Been thanked: 1 time

Re: IB Symbols - N/A

Postby AlexS MultiCharts » 16 Nov 2018

Hello Syswizard!

1) Yes this is normal behavior: each data feed sets an exchange for the symbol, IQFeed having 1 exchange for example.
2) The selected Emini futures are available on IB for trading. You can add them via lookup in the futures tab in Quote Manager:
-CAD (Canadian Dollar)
-IXU (Utilities Sector)
-AUD (Australian Dollar)
Instructions on adding symbols via data source can be found here:
https://www.multicharts.com/trading-sof ... plied_List

syswizard
Posts: 158
Joined: 15 Dec 2012
Has thanked: 13 times
Been thanked: 5 times

Re: IB Symbols - N/A

Postby syswizard » 16 Nov 2018

Ah....but the symbols can be different and now I see the procedure for doing a comprehensive FIND. Thanks for that.
When I went to add AUD, the futures symbol was @AD at Interactive.
However, the symbol is @AD#C at IQ Feed.
When I attempted to map the two together, I got an error: Invalid Value in Field #6035.
Oh, another thing: on the mapping when you go to Add a new entry from the data feed side, it assumes the exact same symbol name for the broker side.....and it has an expiration date of 2013.
Even after correcting the expiration date, any attempts to edit/change the broker side symbol designation fail with the above error.
From the LOG in IB Gateway:
16:38:58:812 <- 9-7-703881560-0-@AD-FUT-20130331-0----USD-@AD#C--0---
16:38:58:834 -> 4-2-703881560-200-Invalid value in field # 6035-

AlexS MultiCharts
Posts: 5
Joined: 12 Oct 2018
Been thanked: 1 time

Re: IB Symbols - N/A

Postby AlexS MultiCharts » 19 Nov 2018

Hello Syswizard!


You will need to add individual IB futures contracts for trading. First of all, you will need to add ADU9 from Interactive Brokers in Quote Manager. To do that, please go to Quote Manager->Instrument->Add Symbol->From Data Source->Interactive Brokers->Futures tab->type in AUD->Click Lookup-> add ‘ADU9’.
Having done that, please go to symbol mapping and map IQFeed’s @AD#C onto Interactive Brokers ADU9 via symbol lookup.

syswizard
Posts: 158
Joined: 15 Dec 2012
Has thanked: 13 times
Been thanked: 5 times

Re: IB Symbols - N/A

Postby syswizard » 20 Nov 2018

Something is wrong with the mapping function. I have the following mappings:
@NQ#C ->NQZ8
@ES#C ->ESZ8
@AD#C ->6AF9
@CD#C -> 6CZ8
After I close the mapping form, and then I reopen it, another entry is somehow AUTOMATICALLY put in the list:
@ES -> @ES
I am unable to remove it !!!
Also, every time I hit the Apply button, I get the "invalid value in field # 6035" error message. After searching the IB API forum, I was unable to find what this field means.
What is going on here ?

AlexS MultiCharts
Posts: 5
Joined: 12 Oct 2018
Been thanked: 1 time

Re: IB Symbols - N/A

Postby AlexS MultiCharts » 20 Nov 2018

Hello Syswizard!

Symbol mapping entry @ES -> @ES can be added automatically if you have a chart trading panel open with this symbol (@ES) or you are starting Auto Trading using it.
You are receiving this error message because IB does not have a native @ES symbol.
The issue will disappear as soon as you adjust your symbol mapping (turn @ES into ESZ8 to have @ES -> ESZ8 mapping).

syswizard
Posts: 158
Joined: 15 Dec 2012
Has thanked: 13 times
Been thanked: 5 times

Re: IB Symbols - N/A

Postby syswizard » 21 Nov 2018

Thanks Alex, but I do not have a chart trading panel open with symbol @ES.
I do have one referencing @ES#C.
To eliminate the error message, I'll take your advice and change the mapping entry to ESZ8.


Return to “MultiCharts”