PowerLanguage .NET Editor problem

Questions about MultiCharts .NET and user contributed studies.
sylfvdk
Posts: 57
Joined: 06 Dec 2005

PowerLanguage .NET Editor problem

Postby sylfvdk » 04 Jan 2019

Hi, Dear Support.

From time to time my PowerLanguage .NET Editor is losing custom settings. Particular:
-- It loses my custom Folders, moving all studies to its original default folders
-- It loses my custom References;

This bug was at least for 10 years from now and I am supprosed it is not fixed.
Please, Fix this bug or let me know to how avoid it.

It happens for 100% when new version is reinstalled, and also it happens from time to time (I can't get certain pattern)

Please, help on this, because I have pretty heavy Folder structure and restore it all the time is a pain.

Thanks,
Victor

User avatar
Henry MultiСharts
Posts: 9121
Joined: 25 Aug 2011
Has thanked: 1258 times
Been thanked: 2927 times

Re: PowerLanguage .NET Editor problem

Postby Henry MultiСharts » 14 Jan 2019

Hello Victor,

All references and folders should be added through PowerLanguage .Net Editor only as there is only one direction of synchronization: from МultiСharts .Net editor to PlStudies* project. The changes done in VS for PlStudies* project would not be saved and would not show up in MC.Net editor.

sylfvdk
Posts: 57
Joined: 06 Dec 2005

Re: PowerLanguage .NET Editor problem

Postby sylfvdk » 14 Jan 2019

Thanks, Henry. But this is not my case. I don't even use Visual Studio and only using .NET Power Language .NET editor.

Once more, Henry. I have been using MC with .NET power language for at least 10 years and this issue was always here.
Working ONLY with power language editor, from time to time Folders and References get lost.

I didn't find exact pattern. When new release downloaded and reinstalled - it happens for 100%. But happens in other cases as well.

Please, communicate this issue, and let me know what is this, how to avoid this. Or may be, I can save some configuration file for this and when it is corrupted - restore that?

Thanks,
Victor

sylfvdk
Posts: 57
Joined: 06 Dec 2005

Re: PowerLanguage .NET Editor problem

Postby sylfvdk » 25 Jan 2019

Dear Multi Chart Support, Henry.

Could I get constructive response on my issue, Please?

Thanks,
Victor

User avatar
Henry MultiСharts
Posts: 9121
Joined: 25 Aug 2011
Has thanked: 1258 times
Been thanked: 2927 times

Re: PowerLanguage .NET Editor problem

Postby Henry MultiСharts » 31 Jan 2019

Victor,

As discussed with Svetlana in the live chat - the behavior that you describe is not reproduced on our end. We need to know the steps you perform to reproduce it. It's desired to do a remote session so that you can demonstrate the issue to the engineers. If you have MultiCharts 12 release 1, we could connect to your PC and update to the latest Release (5) and see if the issue is reproduced. Please come to the live chat to demonstrate it, when you are ready.


Return to “MultiCharts .NET”