puzzled about performance issue

Questions about MultiCharts and user contributed studies.
tortoise
Posts: 70
Joined: 01 Feb 2007
Has thanked: 4 times
Been thanked: 1 time

puzzled about performance issue

Postby tortoise » 03 Jun 2008

Hello -- I just purchased a new Quad core. I'm puzzled to find that MC compiles code four times more slowly on my new machine than it did on the E6600 duo core it replaced. The new machine is 64-bit, running Vista Premium. Old machine is 32-but, running XP.

I have gone through the usual optimization techniques to reduce Vista's bloat. Any other ideas? Thanks

User avatar
TJ
Posts: 6601
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1910 times

Postby TJ » 04 Jun 2008

I am running 3.1.1300.201 on a Q6600 w/ 4GB RAM, VISTA Home Premium 64bit.

Here's a screen shot of the Task Manager while compiling.
You can see all 4 cores are utilized (but not equally), and the total load is only ~ 33%.
Attachments
2008-06-04 07.52.1901.jpg
2008-06-04 07.52.1901.jpg (64.83 KiB) Viewed 398 times

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 11 Jun 2008

Hi guys,

Compilation does not use multiple processors. What's important for the compilation speed is the frequency of a single core. So if the frequency on your new machine is lower than on the old machine, compilation on the new machine will take longer.

Regards.

User avatar
TJ
Posts: 6601
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1910 times

Postby TJ » 11 Jun 2008

no wonder only one core is loaded !


Return to “MultiCharts”