ADE: Error in study ... Can't find dll "elcollections2.dll"

Questions about MultiCharts and user contributed studies.
Doctor Al
Posts: 24
Joined: 15 Aug 2019
Has thanked: 4 times

ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby Doctor Al » 16 Aug 2019

Hello,

I am new to MultiCharts. I have used ADE in TS, but can't seem to get it working in MultiCharts 64 Bit, which I just recently installed after investing in a lifetime license (? big mistake)

I am trying to run one of my indicators that stores custom oscillator values from a higher time frame chart into an ADE data file.
In TS, the data files wind up in the "C:\ADE\Data" folder, and then they are accessed by strategies running on a shorter time frame chart

In MultiCharts 64 bit I am getting this error message when trying to store my oscillator values from the higher time frame chart:
Error in study ... Can't find dll "elcollections2.dll"

Placing the elcollections2.dll and the ELCServer application (copied from my TS directory) into the MultiCharts directory
{C:\Program Files\TS Support\MultiCharts64} is not solving the issue.

Can anyone help me fix this? Please be aware that I am new to MultiCharts and may need detailed explanations of what to do as I don't necessarily have detailed understanding of how things work.

User avatar
TJ
Posts: 7354
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 993 times
Been thanked: 2100 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby TJ » 16 Aug 2019

Are you using the 64 bit version of ELCollections?

Doctor Al
Posts: 24
Joined: 15 Aug 2019
Has thanked: 4 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby Doctor Al » 16 Aug 2019

How would I know whether I'm using the 64 bit version of EasyLanguage Collections? If I'm not, how do I get and install/set up that version? The representation when I installed MultiCharts 64 ( a few days ago) was that I did not have to run a separate installation utility for ADE. One would assume that 64 bit Multicharts, if set up for ADE, as represented, would include 64 bit EasyLanguage Collections. In TS, you do have to run a separate installer -it's called TS_ADE-ELC_Installer2.01 . Is there a comparable installer for MultiCharts?

In TS the instructions are specific and understandable. One can follow their instructions.

So far, with MultiCharts, I have not gotten the instructions/help that I require, and it has been very frustrating.

Obviously, I lack a lot of knowledge of MultiCharts , but if you can help, I would greatly appreciate it. Thanks.

User avatar
TJ
Posts: 7354
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 993 times
Been thanked: 2100 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby TJ » 16 Aug 2019

Global Variable is included in the MC installation, not ADE.

User avatar
TJ
Posts: 7354
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 993 times
Been thanked: 2100 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby TJ » 16 Aug 2019

Please see:
[Advanced Topic] MultiCharts 64 bit Resources (3rd Party)
viewtopic.php?t=10094

Doctor Al
Posts: 24
Joined: 15 Aug 2019
Has thanked: 4 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby Doctor Al » 16 Aug 2019

No Go - Same error messages.

I again placed the 64 bit ELCollections file (must be for the third time since the file shows up as ElCollections(3).dll in my
C:\Program Files\TS Support\MultiCharts64 folder. I also removed all the prior versions , some of which I had renamed with "_Old"
added to the name. I also have ELCServer in the directory (I copied it from my TS set-up because it says you need it in the TS Forum threads).

One thing that I did notice is that in the MultiCharts directory is "elkit32.dll" Since this is supposed to be 64 bit, I'm not sure if elkit32.dll
is a problem.

Other than that ElCollections 64 bit download that i have done numerous times already, is there anything else to try?

Thanks.

User avatar
TJ
Posts: 7354
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 993 times
Been thanked: 2100 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby TJ » 16 Aug 2019

I would add the dll to ALL the possible directories... anywhere you see dll, add a copy there too, just in case MC is looking at that directory.

Failing the above, you can use LiveChat with techsupport, they can sort it out for you.

Doctor Al
Posts: 24
Joined: 15 Aug 2019
Has thanked: 4 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby Doctor Al » 19 Aug 2019

TechSupport really hasn't been able to help me get this working for 64 bit Multicharts. ADE is a third party program from TS, which is a 32 bit program. I am told by EasyLanguage Engineers at TS that there is no 64 bit version of ELCollections2.dll. I doubt that there is a 64 bit version of ELCollections.dll, since it would not be needed for TS. I did not specifically ask , but there is no reason to think the TS developer needed to write a 64 bit dll. I am perplexed that ADE is reported to work for 64 bit MultiCharts.
When I look at one of my typical ADE indicators - that I would use on a sender chart - the code uses these functions:

(1)ADE.OpenMap >>>> uses ELCollections2.dll
(2)MapSN.Put >>>> uses ELCollections.dll
(3) ADE.PutBarInfo
(4)ADE.SaveMap >>>>> uses ELCollections2.dll

Numbers (1) and (4) use ELCollections2.dll and (2) uses ELCollections.dll

Did someone write 64 bit versions of ELCollections.dll and ELCollections2.dll for Multichart users?
Is it not necessary to use ADE.OpenMap, MapSN.Put, and ADE.SaveMap in order to use ADE effectively?
Will functions (1),(2) and (4) above still work if you delete the top lines (see example in 2 lines below)

external method: "ELCollections2.dll", int, "ADE_BarToDateAndTime", int64, int64, int64;
external method: "ELCollections2.dll", int, "ADE_BarToDateTimeCount", int64, int64, int64, int64;

I would appreciate hearing from anyone who is successfully using ADE in MultiCharts 64 if they could check their 4 functions listed above and let me know what they have in their PowerLanguage Editor, or if they have more info as to how they are getting ADE to work in MC 64 bit.

Is it possible that an older version of ADE does not use those .dll's and that is what MC 64 users are using?

Thank you.

User avatar
TJ
Posts: 7354
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 993 times
Been thanked: 2100 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby TJ » 19 Aug 2019

Have you read post #5 above?
[Advanced Topic] MultiCharts 64 bit Resources (3rd Party)

This is not something new; I wrote the post in 2012 !!!
People have been using MC64 with ADE for years.

Doctor Al
Posts: 24
Joined: 15 Aug 2019
Has thanked: 4 times

Re: ADE: Error in study ... Can't find dll "elcollections2.dll"

Postby Doctor Al » 20 Aug 2019

Okay, It appears that I finally got it working. There are different versions of ADE and I believe you need the one without references to or any use of ELCollections2.dll . It may be that if you are migrating from TS, as I did, you may be more likely to encounter this issue if you have indicators or strategies that use ADE, and you are transferring them to MultiCharts

Thanks TJ for the 64 bit version of ELCollections.dll

I believe I found the correct version of ADE to use in 64 bit MultiCharts here (in the top post by Bamboo):

https://community.TS.com/Disc ... xactMatch=

and by clicking on:

Attachment:DATA/20050126201437ADE.zip 148513 bytes

which gives All-Data-Everywhere Version 1.07

There may be a newer version, but it won't work because we don't have a 64 bit version of ELCollections2.dll, at least as far as I know.

When you open the function ADE.OpenMap it should begin with:

[LegacyColorValue = TRUE];

external method: "ELCollections.dll", int, "_DateAndTimeToBar", double, double, double;
external method: "ELCollections.dll", int, "_DateTimeCountToBar", double, double, double, double;

If it says ELCollections2.dll, then you have the wrong version - probably a newer version. I notice that in the TS forums I can find
places where it says that : 2.01 is the latest version of ADE/ELC [I don't think that version will work for 64 bit Multicharts (unless you create a 64 bit version of ELCollections2.dll)]


Return to “MultiCharts”