Missing data

Questions about MultiCharts and user contributed studies.
johnyx2
Posts: 36
Joined: 18 Apr 2008

Missing data

Postby johnyx2 » 05 Jun 2008

Hello there:

Not all missing historical data is downloaded when relaunching MC. I suspect that even some data that was already downloaded while running does not plot when relaunching MC.

On daily charts even full days are missing. I can reproduce this, I see it everyday in many workspaces. I work with 1min. and daily. Last 3.1 beta version, but I have seen this in 3.0.

Please see images

Thanks
Attachments
dataplot.jpg
dataplot.jpg (138.94 KiB) Viewed 155 times
dataplot2.jpg
dataplot2.jpg (124.41 KiB) Viewed 160 times

User avatar
TJ
Posts: 6586
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1907 times

Postby TJ » 05 Jun 2008

Sometimes the IB server can deliver live quote, but is unavailable for backfill.
You can open the QuoteManager to check the EventLog. If the problem is at the IB side, the eventlog will show that the IB server is not responding to backfill requests.

johnyx2
Posts: 36
Joined: 18 Apr 2008

Postby johnyx2 » 05 Jun 2008

I see, thanks TJ for your replay.

One question you might be able to answer:
When I open the QuoteManager the column 'Collect RT data w/o plotting' says off on all symbols. Then I select all symbols and right click connect symbol and it starts counting received (I guess) ticks.
Maybe this is why sometimes it seems as MC is downloading the whole data series every time I launch it, and is missing data I suspect should be there since it was running during those times.
Is this related? should this column be counting all the time? Should I open the QM and connect all symbols every time?

Thanks for your help

User avatar
TJ
Posts: 6586
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1907 times

Postby TJ » 05 Jun 2008

When the number is counting, I think it is live data streaming.

Check the EventLog. When MC is receiving backfill data, it will say something like this:
Interactive Brokers Sending ESM8 1 Minute Trade history to data server: 585 quotes downloaded (key=.....

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Re: Missing data

Postby Marina Pashkova » 10 Jun 2008

Hello there:

Not all missing historical data is downloaded when relaunching MC. I suspect that even some data that was already downloaded while running does not plot when relaunching MC.

On daily charts even full days are missing. I can reproduce this, I see it everyday in many workspaces. I work with 1min. and daily. Last 3.1 beta version, but I have seen this in 3.0.

Please see images

Thanks


Hi johnyx2,

What might have happened is that the connection with the datafeed was lost at times where you can see the gaps in data.

If you believe that this is not the case, please send us your workspaces with the detailed description of how to reproduce the problem.

Regerds.


Return to “MultiCharts”