New autotrading bug ?

Questions about MultiCharts and user contributed studies.
User avatar
danilo
Posts: 170
Joined: 02 Jan 2007
Location: Italy
Has thanked: 4 times
Been thanked: 9 times

New autotrading bug ?

Postby danilo » 10 Jun 2008

I have installed the patch to donwload historical data from expired futures, the patch is working fine, but now the autotrading engine is not working, I receive a message like : "Error validating request:-'qb' : cause - Please enter a local symbol or an expiry" (Error)".
I have attached the MC logs.

regards,
Danilo
Attachments
TradingServer.zip
(10.98 KiB) Downloaded 39 times

liang323
Posts: 27
Joined: 12 Mar 2006

Postby liang323 » 11 Jun 2008

hello, this can happen sometime, you just need to right click your strategy from the chart, then go to Properties, and manually input the expiry date for the symbol, then i will work fine without the error msg.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Re: New autotrading bug ?

Postby Marina Pashkova » 11 Jun 2008

I have installed the patch to donwload historical data from expired futures, the patch is working fine, but now the autotrading engine is not working, I receive a message like : "Error validating request:-'qb' : cause - Please enter a local symbol or an expiry" (Error)".
I have attached the MC logs.

regards,
Danilo


Danilo,

Please go to the symbol dictionary and make sure that all the parameters for the symbol have been entered correctly.

Regards.

User avatar
danilo
Posts: 170
Joined: 02 Jan 2007
Location: Italy
Has thanked: 4 times
Been thanked: 9 times

Postby danilo » 11 Jun 2008

Hi Marina,

the problem has been solved, I had to remove and then re-add the symbol in the dictionary for some reason was missing but after having re-added the symbol all the parameters has been properly set.

regards,
Danilo

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 12 Jun 2008

Hi Danilo,

If you have any problem with autotrading or anything else again, please feel free to contact us via LiveChat right away.

Regards.

cdf
Posts: 20
Joined: 15 Apr 2008
Has thanked: 12 times

Re: New autotrading bug ?

Postby cdf » 14 Jun 2008

I have installed the patch to donwload historical data from expired futures, the patch is working fine, but now the autotrading engine is not working, I receive a message like : "Error validating request:-'qb' : cause - Please enter a local symbol or an expiry" (Error)".
I have attached the MC logs.

regards,
Danilo



hi, Danilo,

How did you collect the "TradingServer" log?
where is the location?

Autotrading cannot work for me.
1) the buy/sell signal cannot be triggered just as in chart
2) position is TWS cannot be retrieved
3) autotrade mode will be end without control.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 19 Jun 2008

Hi cdf,

Please contact our customer support representatives at http://messenger.providesupport.com/mes ... pport.html and they will help you set up auto trading and understand what are the causes of the problems you have encountered.

Please note that the support hours are 6:30 am - 4:00 pm EST, Monday through Friday.

Regards.

User avatar
TJ
Posts: 6585
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1907 times

Postby TJ » 19 Jun 2008

support time extended to 4:00 pm EST now !
That's great.


Return to “MultiCharts”