Daily bars do not download missing historical data

Questions about MultiCharts and user contributed studies.
johnyx2
Posts: 36
Joined: 18 Apr 2008

Daily bars do not download missing historical data

Postby johnyx2 » 24 Jun 2008

Hello there,

Charts with Daily bars, do not download missing historical data when this option is selected in the Data Server mode preferences.

Thanks

fs

Postby fs » 25 Jun 2008

This is probably by design to speed up plotting. :)

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Re: Daily bars do not download missing historical data

Postby Marina Pashkova » 27 Jun 2008

Hello there,

Charts with Daily bars, do not download missing historical data when this option is selected in the Data Server mode preferences.

Thanks


Hi johnyx2,

We've been trying to reproduce this problem for a couple of days. So far all the gaps were filled upon restarting MultiCharts and loading a workspace. We are going to repeat the test on Monday - to see if the weekend gap will be closed automatically.

If you can reproduce the problem regularly, please contact our customer support representatives at http://messenger.providesupport.com/mes ... pport.html
They would connect to your pc to see what exactly goes on.

Thank you!

flipflopper
Posts: 261
Joined: 28 Feb 2008
Has thanked: 2 times
Been thanked: 1 time

Postby flipflopper » 28 Jun 2008

I have had the same probalem and have demostrated it to support.

I use esignal data so I'm not sure if its only a problem with that data.

All intraday data updates fine.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 01 Jul 2008

Hi flipflopper,

We did have some issues with gaps in data from eSignal in one of the previous versions. However, I am not sure it is the same problem that johnyx2 is referring to. We need to have a look at what is going on his computer first.

By the way, what version of MC are you using? Do you still have problems filling gaps on daily charts?

flipflopper
Posts: 261
Joined: 28 Feb 2008
Has thanked: 2 times
Been thanked: 1 time

Postby flipflopper » 01 Jul 2008

Hi Marina,

I'm using version 3.1.1353.400.

And yes I still have problems with daily bars.

When I open MC for the first time of the day and begin going through my $SPX, $INDU, $COMPQ, $VIX etc... I notice missing bars (usually yesterdays bar) sometimes the past few days). A refresh fixes the issue.

I have all these charts saved as workspaces since I draw trendlines and fibs on them and Multicharts does not save trendlines to symbols. So while we're on the subject will Multicharts have this feature anytime soon?

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 02 Jul 2008

Hi Marina,

I'm using version 3.1.1353.400.

And yes I still have problems with daily bars.

When I open MC for the first time of the day and begin going through my $SPX, $INDU, $COMPQ, $VIX etc... I notice missing bars (usually yesterdays bar) sometimes the past few days). A refresh fixes the issue.


Hi flipflopper,

Could you send us the logs when you see the bars missing again? When you run MultiCharts, open the workspaces and see that there are bars missing, just go to Start -> Programs -> MultiCharts -> Logs and send us those logs.

I have all these charts saved as workspaces since I draw trendlines and fibs on them and Multicharts does not save trendlines to symbols. So while we're on the subject will Multicharts have this feature anytime soon?


We are not planning to add this feature in the nearest future.

Regards.

User avatar
TJ
Posts: 6585
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1907 times

Postby TJ » 02 Jul 2008

I noticed my daily charts do not always show the last day (prev day).

I have to refresh the chart to force a data refresh, even though I should have the data in my computer; I had the chart opened all day yesterday, the program would have downloaded all the data during the day.

I suspect there are 2 problems:

1. MC did not save the data to the data store, that's why when I open the chart in the morning, I do not see yesterday's bar drawn.

2. MC did not download the missing data during chart loading.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 02 Jul 2008

I noticed my daily charts do not always show the last day (prev day).

I have to refresh the chart to force a data refresh, even though I should have the data in my computer; I had the chart opened all day yesterday, the program would have downloaded all the data during the day.

I suspect there are 2 problems:

1. MC did not save the data to the data store, that's why when I open the chart in the morning, I do not see yesterday's bar drawn.

2. MC did not download the missing data during chart loading.


Hi TJ,

Could you, too, send us the logs when you see daily bars missing again? Start -> Programs -> MultiCharts -> Logs. Just zip all those logs and e-mail them to us as an attachment.

Regards.

User avatar
TJ
Posts: 6585
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 971 times
Been thanked: 1907 times

Postby TJ » 02 Jul 2008

Hi TJ,

Could you, too, send us the logs when you see daily bars missing again? Start -> Programs -> MultiCharts -> Logs. Just zip all those logs and e-mail them to us as an attachment.

Regards.

ok

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 02 Jul 2008

Thank you guys!

Nick
Posts: 490
Joined: 04 Aug 2006
Has thanked: 4 times
Been thanked: 24 times

Postby Nick » 03 Jul 2008

I also have the 'last day problem' thats using IB and has always been an issue. Always need to hit ^R in each daily chart since way back.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 03 Jul 2008

Hi flipflopper, TJ, and Nick:

We have run several tests to see if there are any problems with downloading missing daily bars on opening a workspace. No problems have been noticed.

This is why we need logs from you: to understand what might be going on in your particular cases. Until we receive the logs, it will be impossible to identify and solve the problem.

Please archive send the logs from Start -> Programs -> MultiCharts -> Logs to mpashkova@tssupport.com

Thank you.

flipflopper
Posts: 261
Joined: 28 Feb 2008
Has thanked: 2 times
Been thanked: 1 time

Postby flipflopper » 10 Jul 2008

Hi flipflopper, TJ, and Nick:

We have run several tests to see if there are any problems with downloading missing daily bars on opening a workspace. No problems have been noticed.

This is why we need logs from you: to understand what might be going on in your particular cases. Until we receive the logs, it will be impossible to identify and solve the problem.

Please archive send the logs from Start -> Programs -> MultiCharts -> Logs to mpashkova@tssupport.com

Thank you.


Hi Marina, I sent the logs via email a while back and will resend them now. Also earlier in the week I tried to use chat to work with an engineer on the issue but was told to hold on them about 10 minutes later the support guy just left the room!!! :shock:

Hopefully this will get resolved soon. I will try to contact you again tomorrow.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 11 Jul 2008

Hi flipflopper,

Please do contact us again.

As for the terminated livechat session, I am sure it was caused by the connection issues.

Regards.


Return to “MultiCharts”