Problem with realtime and backtesting

Questions about MultiCharts and user contributed studies.
phil
Posts: 47
Joined: 09 May 2007

Problem with realtime and backtesting

Postby phil » 15 Jul 2008

I don't know if others persons have this problem. When I check the signals from a strategy. I have diferrent signal in backtesting and realtime.

Can some persons confirm this?

User avatar
TJ
Posts: 6551
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 966 times
Been thanked: 1892 times

Postby TJ » 15 Jul 2008


phil
Posts: 47
Joined: 09 May 2007

Postby phil » 15 Jul 2008

but my problem his that I'm comparing two chart with intraday bar generation on it. I don't think it's the problem with look the look inside bar generation. Because some signal perfectly synchro with the realtime chart but with little difference in term of when the trade are generate inside the bar. but sometime the realtime chart and the backtesting chart are telling me different signal.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 16 Jul 2008

Hi phil,

There might be several reasons as to why the signals on real-time are different from the ones on history.

1. Historical and real-time data from the same data provider can be different. For example, this is often the case with eSignal.
2. The calculation is different. In real-time signals are calculated on every tick, on history - O,H,L,C.

If you believe that your case is different, please contact us via LiveChat to demonstrate the problem.

Regards.


Return to “MultiCharts”