Duplicate Bars and PLE crash to report

Questions about MultiCharts and user contributed studies.
elaskaris
Posts: 17
Joined: 31 Mar 2008

Duplicate Bars and PLE crash to report

Postby elaskaris » 09 Aug 2008

With the new beta I noticed two issues to bring to the developers attention:

1) When I load a chart ( ESignal Provider) often the last or second-to-last bar is duplicated. If I reload the chart it displays properly. It has tripped me up on occasion because running strategies do process the duplicate bars and generate faulty signals (if I don't detect/correct the problem first).

2) Using the Optimizer in the Portfolio Backtester or Multicharts itself with the PowerLanguage Editor on in background causes the PLE to freeze and crash.

As a user of the beta, I felt I should pass these things on.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Re: Duplicate Bars and PLE crash to report

Postby Marina Pashkova » 14 Aug 2008

With the new beta I noticed two issues to bring to the developers attention:

1) When I load a chart ( ESignal Provider) often the last or second-to-last bar is duplicated. If I reload the chart it displays properly. It has tripped me up on occasion because running strategies do process the duplicate bars and generate faulty signals (if I don't detect/correct the problem first).


What are the symbols and resolutions? We would need that info to study the problem on our end.

2) Using the Optimizer in the Portfolio Backtester or Multicharts itself with the PowerLanguage Editor on in background causes the PLE to freeze and crash.


What are you doing in PLEditor when crashes occur? Compiling studies? Do you still have logs with crashes?

The logs with crashes are in: your drive:\Documents and Settings\user\Local Settings\Application Data\TS Support\MultiCharts\4.0.1440.201 - Backup

Thank you.


Return to “MultiCharts”