[Bug Report] Indicators get delayed for second charts

Questions about MultiCharts and user contributed studies.
2haerim
Posts: 502
Joined: 01 Sep 2006
Been thanked: 2 times

[Bug Report] Indicators get delayed for second charts

Postby 2haerim » 21 Jan 2009

MC build 1737.201 seems to have a bug for second charts with data1 and data2 and indicators. 1 Minute and 1 tick chart works ok, but 10-tick or 10-second chart shows delay in updating indicators.

See the attached screen shots for both 1 second chart and 1 minute chart.
Attachments
IndicatorLagProblem.zip
(303.43 KiB) Downloaded 30 times
Last edited by 2haerim on 26 Jan 2009, edited 1 time in total.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 21 Jan 2009

Hi HaeRim,

Could you please attach a workspace that is based on one of the standard data providers in MultiCharts? Also, we will need a screenshot that demonstrates the problem.

Or if you are willing to demonstrate the problem right on your computer, we could connect to your PC remotely.

Regards.

2haerim
Posts: 502
Joined: 01 Sep 2006
Been thanked: 2 times

Postby 2haerim » 21 Jan 2009

I think it can be easily repeated by GS feed if you do the same and use the indicator and workspace I provided. Simply replace the datafeed and symbol as your own choice.

multi-tick and multi-second charts only show the problem but 1-tick or 1-min chart do not have such problems.

It is so painful to repeat the test so many times and write a detail report about the bug to make you realize it with the minimal effort.

At this moment, kind of exhausted and don't have time/energy to repeat the same experiments with another feed again.

Sorry.

2haerim
Posts: 502
Joined: 01 Sep 2006
Been thanked: 2 times

Postby 2haerim » 21 Jan 2009

ok here we go again for the bug evidence.

See the attached screenshots taken before and after the indicator lag.

The indicator stops plotting until the data2 tick is cominng in for the next bar.
Attachments
bef.png
bef.png (112.2 KiB) Viewed 260 times
aft.png
aft.png (112.51 KiB) Viewed 262 times

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 23 Jan 2009

Dear HaeRim,

Thank you for all the information. The thing is that, due to the irregular nature of ticks, there are a number of problems plotting such charts. Indicators not being updating properly is a consequence of of those problems. Those issues will not be resolved in the nearest future.

However, if the problem is reproduceable on time-based charts only (charts should not contain any tick-based resolutions), please let me know. We'll run tests, find out what is causing the problem, and try to fix it.

No more testing is required from you.

P.S. We really appreciate your effort and co-operation.

Best regards.

2haerim
Posts: 502
Joined: 01 Sep 2006
Been thanked: 2 times

Postby 2haerim » 24 Jan 2009

10 second chart also has the same bug.

I think 10 second chart naturally belongs to time-based chart, doesn't it?

Just try 10 second chart with 2 data series for different symbols and apply any simple indicator like MA. You will soon see the indicator is not updating realtime.


And in case of non-time based chart, MC can provide an option to use the previous last vale to update the indicator or to wait the new tick arrival.

mojotrader
Posts: 87
Joined: 07 Dec 2006

Postby mojotrader » 24 Jan 2009

I believe this problem is related to the one I reported in the link below. Your example though is more apparent. When prices come in quickly, I’ve seen the chart shift left 10-20 spaces before bars are even printed.

http://forum.tssupport.com/viewtopic.php?t=5816&highlight=

2haerim
Posts: 502
Joined: 01 Sep 2006
Been thanked: 2 times

Postby 2haerim » 24 Jan 2009

Hi mojotrader,

That is exactly the same I experienced with 10 tick chart and 10 second chart for 2 Data series. In my case the indicator was not updating until the next tick from Data2 arrived while the Data1 chart kept moving forward.

You even seem to have experienced it with 1 Data series.

It is definitely a serious bug which needs priority attention.

MC provides superb tick and second charting features.

Unfortunately my experience shows such features have several bugs to lose all its superiority over other platforms.

http://forum.tssupport.com/viewtopic.php?p=23192#23192

http://forum.tssupport.com/viewtopic.php?p=23291#23291


I think TSS should pay more attention to tick and second chart.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 27 Jan 2009

I believe this problem is related to the one I reported in the link below. Your example though is more apparent. When prices come in quickly, I’ve seen the chart shift left 10-20 spaces before bars are even printed.

http://forum.tssupport.com/viewtopic.php?t=5816&highlight=


Mojo,

Do you have any hidden series in your chart?

mojotrader
Posts: 87
Joined: 07 Dec 2006

Postby mojotrader » 27 Jan 2009

I believe this problem is related to the one I reported in the link below. Your example though is more apparent. When prices come in quickly, I’ve seen the chart shift left 10-20 spaces before bars are even printed.

http://forum.tssupport.com/viewtopic.php?t=5816&highlight=


Mojo,

Do you have any hidden series in your chart?


No, just one symbol.

User avatar
Marina Pashkova
Posts: 2758
Joined: 27 Jul 2007

Postby Marina Pashkova » 27 Jan 2009

Hi mojo,

In this case, it looks like we need to invite you to come to LiveChat so that we could connect to your PC if you don't mind.

Thank you.


Return to “MultiCharts”