Auto-Reconnect with IB-suggestion

Questions about MultiCharts and user contributed studies.
SUPER
Posts: 633
Joined: 03 Mar 2007
Has thanked: 105 times
Been thanked: 81 times

Auto-Reconnect with IB-suggestion

Postby SUPER » 16 Apr 2009

Hi Andrew,

Would it be possible to add some additional feature to MC so that when IB resets TWS (daily), MC's system in Automation mode do not have to be re-connected/reset. At present systems get switched off from automation mode and users have to reset them manually.

It would be very useful for 24 hr market products.

Regards
Super

User avatar
TJ
Posts: 7382
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 996 times
Been thanked: 2113 times

Postby TJ » 16 Apr 2009

+1 vote.




p.s. come to think of it, I think there is already a place to set the timeout. I have not ran my strategy 24/5, so I have not tried it.

Guest

Postby Guest » 17 Apr 2009

+1 vote.

:D

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 20 Apr 2009

Guys we’ve released the "Disable auto trading after" feature months ago. Take a look at Format Strategy->Auto Trading->Select Broker Plug-in->Settings-> IB Settings.

The max value is 86400=24 hours.

SUPER
Posts: 633
Joined: 03 Mar 2007
Has thanked: 105 times
Been thanked: 81 times

Postby SUPER » 20 Apr 2009

Guys we’ve released the "Disable auto trading after" feature months ago. Take a look at Format Strategy->Auto Trading->Select Broker Plug-in->Settings-> IB Settings.

The max value is 86400=24 hours.
Andrew,

Thanks.

I will try out your max value and report my findings, I had 6000 setting and it did not work.

Regards
Super

SUPER
Posts: 633
Joined: 03 Mar 2007
Has thanked: 105 times
Been thanked: 81 times

Postby SUPER » 21 Apr 2009

Andrew,

Good news, your max value suggestion seems to have done the trick. My system remained connected throughout 24 hr session.

Many thanks.

Regards
Super

User avatar
Andrew Kirillov
Posts: 1589
Joined: 28 Jul 2005
Has thanked: 2 times
Been thanked: 31 times
Contact:

Postby Andrew Kirillov » 21 Apr 2009

I'm sure it worked before! It does what you want it to do!
If you set 6000 in the past and come to your PC at the morning it is understandable why the auto-trading was turned off.


Return to “MultiCharts”