New study subchart bug

Questions about MultiCharts and user contributed studies.
bowlesj3
Posts: 2028
Joined: 21 Jul 2007
Has thanked: 174 times
Been thanked: 405 times

New study subchart bug

Postby bowlesj3 » 24 Oct 2009

Here is an interesting bug for those who are using a study on subchart #2. I am wondering if anyone else is having the problem and what release you are using.

To test to see if you have the bug:

Code: Select all

1/ Open up the format studies window
    (it should say "Format Objects" at the top
     and your should have the "Studies" tab selected).
2/ select your study which is set to subchart #2.
3/ click the format button,
4/ then on the new window click the properties tab,
5/ click Subchart #1 then immediately click Subchart #2 then click okay
6/ If you have the bug your study will be showing subchart #1 in the "format Objects" window rather than subchart #2.

Stay on the "Format Objects" window and your study should still be selected.

7/ click the format button,
8/ the properties tab should already be selected.
9/ click Subchart #2 then immediately click Subchart #1 then click okay
10/ If you have the bug your study will be showing subchart #2 in the "format Objects" window rather than subchart #1.

So what is happening is MC is not choosing the one you select last but rather it is toggling the study back and forth between subcharts #1 and #2 each time you make a change to that subchart and leave that form.


bowlesj3
Posts: 2028
Joined: 21 Jul 2007
Has thanked: 174 times
Been thanked: 405 times

Postby bowlesj3 » 25 Oct 2009

I guess I should mention that this is a problem if one wants to send key storkes to control this function since there is no way for the sending program to know if the toggle is already correct or not. In my case it was a problem because a study was constantly reverting back to subchart #1 when toggled off then on. I wanted to force it to be always on subchart #2.


Return to “MultiCharts”