MC6.0 beta1 slow to backfill

Questions about MultiCharts and user contributed studies.
bowlesj3
Posts: 2148
Joined: 21 Jul 2007
Has thanked: 210 times
Been thanked: 424 times

MC6.0 beta1 slow to backfill

Postby bowlesj3 » 21 Dec 2009

Hi,

I just did my first live feed start of MC6.0 beta1. It backfilled slow on the two 1 minute bar charts and the 10 second bar chart. The daily bars also backfilled okay. However the 5m10,15,30 and 60 minute bars just sat with a message saying "backfilling" even though the last bar (on all thos charts) was appearing on the chart.

I normally shut it down for a while, do some offsite work then come back to restart it. I will see what happens the 2nd time. However it sure looks like a problem.

John.

User avatar
pivot
Posts: 29
Joined: 07 Dec 2009
Been thanked: 2 times

Postby pivot » 21 Dec 2009

I too find it slow to a point were sometimes its unworkable when requesting intra-day data. Daily data seems to fine but intra-day is a real problem for most larger requests.

Why isn't there a function to backup data, I am a new user so I may not have found the backup and save data function yet if so could someone point it out to this newbie.

PP

:)

User avatar
TJ
Posts: 7458
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 999 times
Been thanked: 2137 times

Re: MC6.0 beta1 slow to backfill

Postby TJ » 21 Dec 2009

Hi,

I just did my first live feed start of MC6.0 beta1. It backfilled slow on the two 1 minute bar charts and the 10 second bar chart. The daily bars also backfilled okay. However the 5m10,15,30 and 60 minute bars just sat with a message saying "backfilling" even though the last bar (on all thos charts) was appearing on the chart.

I normally shut it down for a while, do some offsite work then come back to restart it. I will see what happens the 2nd time. However it sure looks like a problem.

John.

Newer MultiCharts vresions (forgotten since which version) will give you the latest bars on the chart while backfilling missing data.

This is an improvement based on people's feedback... so that people don't have to idly wait for all the data before they can have a chart to look at.

bowlesj3
Posts: 2148
Joined: 21 Jul 2007
Has thanked: 210 times
Been thanked: 424 times

Postby bowlesj3 » 21 Dec 2009

Hi guys,

I just did my second morning startup. This time it worked much better. All charts are okay now. I will get back to reading your posts a little more carefully a bit later.

Thanks,
John

brodnicki steven
Posts: 407
Joined: 01 Jan 2008
Been thanked: 3 times

Postby brodnicki steven » 21 Dec 2009

I also notice the slow backfill of data. I thought it was because I'm rebuilding my database (after corruption) but I've been downloading data all weekend on only 40 symbols, it is collecting historical data, just at a much slower rate than 5.5. and it's not finished yet.
I hope Andrew looks into this.

User avatar
TJ
Posts: 7458
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 999 times
Been thanked: 2137 times

Postby TJ » 21 Dec 2009

I too find it slow to a point were sometimes its unworkable when requesting intra-day data. Daily data seems to fine but intra-day is a real problem for most larger requests.

Why isn't there a function to backup data, I am a new user so I may not have found the backup and save data function yet if so could someone point it out to this newbie.

PP

:)

Data are saved automatically on exit.

brodnicki steven
Posts: 407
Joined: 01 Jan 2008
Been thanked: 3 times

Postby brodnicki steven » 21 Dec 2009

I too find it slow to a point were sometimes its unworkable when requesting intra-day data. Daily data seems to fine but intra-day is a real problem for most larger requests.

Why isn't there a function to backup data, I am a new user so I may not have found the backup and save data function yet if so could someone point it out to this newbie.

PP

:)

Data are saved automatically on exit.
** That works IF you wait for the Quotemanager to collect it. I had a system(MC) crash(rare) and MC locked up. I had to reboot and the data wouldn't not backfill after that. I tried all week to fix it. (deleted the bad symbols , data, cache and re-entered the symbols but that didn't work either, so I gave up, deleted the database and installed MC6 and started to collect it again)

bowlesj3
Posts: 2148
Joined: 21 Jul 2007
Has thanked: 210 times
Been thanked: 424 times

Postby bowlesj3 » 21 Dec 2009

The problem I had with the first time startup was a bit strange. It had all the bars for the charts 5,10,15,30,60 in place. It was as if it had a final completion step it needed to do which it got stuck on. It was stuck such that it could not run the studies (bands and RSI). It sat there for at least 3 to 5 minutes then I took it down. The second startup as I said in the post above had no such problem. I would say it got the backfill done that time within 30 seconds (a guess). Pretty good the second time through.

HI pivot,

You can thank TJ for this URL that takes you to the info on how to backup the latest MC. I copied it into my outlook for a regular reminder. I have yet to look closely at it. I guess now that I am up to speed with MC I need to read it.
http://www.tssupport.com/support/base/? ... le&id=2028

John.

bowlesj3
Posts: 2148
Joined: 21 Jul 2007
Has thanked: 210 times
Been thanked: 424 times

Postby bowlesj3 » 21 Dec 2009

but I've been downloading data all weekend on only 40 symbols, it is collecting historical data, just at a much slower rate than 5.5. and it's not finished yet.
Gee, I had my problem with only the e-mini ES and only the data missing from Friday night closing. I guess that is why I seldom have had a problem with backfill (on MC2.1.999.999 that is). I have never had the type of problem I described above before. It is an MC6.0 thing I figure. Hopefully it is a 1 time fluck.

In my case I transfer band values from the higher bar sizes into my 1 minute bars as text in columns so I can see their relationship to current price all in one glance. If they have not backfilled I can not see this data in the 1 minute bars.

brodnicki steven
Posts: 407
Joined: 01 Jan 2008
Been thanked: 3 times

Postby brodnicki steven » 21 Dec 2009

I finally have the backfill finished. At shut down tonight I'm going to save an extra copy of the database.
Luckily IB runs their history servers on weekends now.
*I spent a day or so over the weekend with Windows7 64 bit on a new drive and installed MC. It might be my imagination but MC seemed to run a little smoother and quicker on Win7. I'm not sure if I'll switch to Win7 or not, since a couple of older critical apps, won't run on Win7. (neural net stuff, with no current version available)
I'm still looking for a workaround, as I'd like to switch to Win7. (using XP now)


Return to “MultiCharts”