MC 6.0 beta 2 Walk Forward bug

Questions about MultiCharts and user contributed studies.
ctrlbrk
Posts: 79
Joined: 18 Feb 2010
Location: Dallas, TX
Contact:

MC 6.0 beta 2 Walk Forward bug

Postby ctrlbrk » 12 Mar 2010

I'd like to report a bug.

On several occasions now I've had a problem with the report generated by Walk Forward. The problem is the report does not generate a taskbar tray item, and the report is not visible anywhere.

I have four monitors. I've noticed the report seems to randomly pop up on whatever monitor my cursor happens to be on at the time the report finishes. But on some occasions, like above, the report does not pop up anywhere. The walk forward optimization finishes, and then nothing. Entire time wasted. No report anywhere.

I checked alt-tab, minimized windows, everything. It is real maddening when you run a long walk forward task and have nothing to show for it.

Mike
Last edited by ctrlbrk on 12 Mar 2010, edited 1 time in total.

User avatar
Bruce DeVault
Posts: 438
Joined: 19 Jan 2010
Location: Washington DC
Been thanked: 2 times
Contact:

Re: MC 6.0 beta 2 Walk Forward bug

Postby Bruce DeVault » 12 Mar 2010

I've noticed the report seems to randomly pop up on whatever monitor my cursor happens to be on at the time the report finishes...

I believe this may be a general Windows behavior. For instance, if you use Shift-Delete to delete a file, then move the mouse around before it gets finished doing prep, the confirmation dialog will appear on whatever window your mouse is on at the time, not necessarily the one where you did the deletion.

But, if the report isn't appearing anywhere, that is a serious problem, and one that needs to be investigated.

ctrlbrk
Posts: 79
Joined: 18 Feb 2010
Location: Dallas, TX
Contact:

Postby ctrlbrk » 12 Mar 2010

Yes I know what you mean.

The new window location is controllable by the application. If you center it on the monitor where the mouse is, that is by choice (programmers). I really don't care what monitor it pops up on.

What I care about is that it isn't actually there. There is no taskbar item, nothing. It was happening several times to me again today so I ended up having to restart MC to fix it, after hours of walk forward time -poof- gone. :(

Mike


Return to “MultiCharts”