Automated Order tured off

Questions about MultiCharts and user contributed studies.
NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 34 times
Been thanked: 12 times

Automated Order tured off

Postby NiC72 » 19 Apr 2010

The problem occurs every night, if I turn on the SA or AA. If I look in the log, it shows: "The Automated Order Execution Fashion Has Been tured off due to a setting change."
At that time, the computer has not been touched. Since I use the IB Gateway should not be turned off .. Can it be ISP that switching the IP?

User avatar
Henrik
Posts: 140
Joined: 13 Apr 2010
Has thanked: 25 times
Been thanked: 11 times

Postby Henrik » 19 Apr 2010

I have the same issue with 6 beta,
support has confirmed the bug. Next beta version the bug is resolved.

Its not the ISP with switching IP, IB reboots his servers at this time (I think 6:28 AM GMT+1) and MC lost the connection to positions.

In MC 5.5 there is no issue at night with IB, only with the beta 6.

NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 34 times
Been thanked: 12 times

Postby NiC72 » 19 Apr 2010

OK, That clarifies the problem. Thanks for the info, Henrik.

Emmanuel
Posts: 287
Joined: 21 May 2009
Has thanked: 68 times
Been thanked: 19 times

Postby Emmanuel » 19 Apr 2010

Hi

This happen to me as well, the Automate switch off by itself and stop to trade

I am glade that the next version MC solve the problem

I know it is not a change of IP address, because I have a fix IP address

SUPER
Posts: 624
Joined: 03 Mar 2007
Has thanked: 99 times
Been thanked: 80 times

Postby SUPER » 20 Apr 2010

Nick72,

I used to have similar problem due to IB rebooting and by changing "disable auto trading after" to maximum limit to 86400 seconds solved problem.

Select Stratety properties > AutoTrading > Settings > Connection settings > Disable auto trading after "86400" second on the connection loss

Regards
Super

User avatar
Henrik
Posts: 140
Joined: 13 Apr 2010
Has thanked: 25 times
Been thanked: 11 times

Postby Henrik » 20 Apr 2010

Select Stratety properties > AutoTrading > Settings > Connection settings > Disable auto trading after "86400" second on the connection loss



On my PC, this solution does not work.
If I disable "auto trading after xx" than on the next day the strategy is on (green point left top), and chartticks updates, but the strategy do not trade.

NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 34 times
Been thanked: 12 times

Postby NiC72 » 20 Apr 2010

Thanks for your suggestion, Super.
Strange that you and Henrik do not get the same results ..
Are you using the MC 6 (Beta 2)?
TWS or IB Gateway?
Last edited by NiC72 on 20 Apr 2010, edited 1 time in total.

User avatar
Henrik
Posts: 140
Joined: 13 Apr 2010
Has thanked: 25 times
Been thanked: 11 times

Postby Henrik » 20 Apr 2010

MC 6 (Beta 2)?
TWS and IB Gateway (both). Next beta the issue is solved (say support).

NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 34 times
Been thanked: 12 times

Postby NiC72 » 20 Apr 2010

MultiCharts Version 6.0 Beta 2 (Build 3102)..
I'm with you, Henrik. I appreciated that you explained about the next beta in the beginning. :wink:
Actually the question was for Super. Just wondering if we all running the same versions as he seemed to get its work.

SUPER
Posts: 624
Joined: 03 Mar 2007
Has thanked: 99 times
Been thanked: 80 times

Postby SUPER » 20 Apr 2010

Nick72,

I am using MC 6 beta 2 and TWS,

Does your computer go into hibernation/power saving mode by any chance, just a thought.

Regards
Super

User avatar
TJ
Posts: 6584
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 970 times
Been thanked: 1907 times

Postby TJ » 20 Apr 2010

my internet connection always fades momentarily around midnight.
maybe the ISP resets its routers too?

you can use a network sniffer to isolate the problem,
to see whether it is the internet connect that resets,
or IB server that reboots.
or, if nothing happens on the outside,
then it must be something on the inside,
either your computer/router, or... MC.

NiC72
Posts: 92
Joined: 02 Nov 2009
Location: Sweden
Has thanked: 34 times
Been thanked: 12 times

Postby NiC72 » 20 Apr 2010

I lose the connection between 6,00-7,00 AM (GMT +1). So I am convinced that it all depends on what Henrik said earlier.

As it happened another time probably depends on the ISP. Bruce wrote another post about dual WAN router that I'm considering.

I think the problem is solved, everything seems to be consistent with Henrik explanation.


Return to “MultiCharts”