EL Compile error - causal study: (Function)

Questions about MultiCharts and user contributed studies.
tcat
Posts: 158
Joined: 02 Feb 2008
Location: Lausanne, Switzerland
Has thanked: 9 times
Been thanked: 4 times

EL Compile error - causal study: (Function)

Postby tcat » 06 Jun 2010

Hi,

I am trying to compile a signal which includes a true/false filter based on the value of the WAverage. Upon compilation, I am getting the following error:
------ Compiled with error(s): ------
Compile error
errLine 0, errColumn 0, errLineEnd 0, errColumnEnd 0
causal study: (Function)

Here is the code:

Code: Select all

inputs:    Price( Close ),
      Length( 9 ),
      Displace( 0 ) ;

variables:   var0( 0 ),
      GoLong(False),
      GoShort(False);

condition1 = Displace >= 0 or CurrentBar > AbsValue( Displace ) ;
if condition1 then
   begin
      var0 = WAverage( Price, Length ) ;
   end;

GoLong = (Close > var0);
GoShort = (Close < var0);


Help would be appreciated.

Thierry

User avatar
TJ
Posts: 6523
Joined: 29 Aug 2006
Location: Global Citizen
Has thanked: 957 times
Been thanked: 1883 times

Postby TJ » 06 Jun 2010

have you compiled your WAverage function?


your code snippet compiled with no error in my MC.

tcat
Posts: 158
Joined: 02 Feb 2008
Location: Lausanne, Switzerland
Has thanked: 9 times
Been thanked: 4 times

Postby tcat » 06 Jun 2010

Thanks for your reply.

WAverage comes by default with MC and cannot be edited. I'm using MC 6 beta 3 and get the error even after restarting PLE. All code has been compiled but this last bit signal.

I'll try re-installing the beta, and I'll contact tech support if this occurs again.

Regards,
Thierry

UPDATE: After re-installing, compilation went fine. Bizzare.

Thanks for your help TJ.

glen demarco
Posts: 35
Joined: 16 Nov 2009
Contact:

Postby glen demarco » 07 Jun 2010

A reinstallation of the Beta corrected the compiler error?

Did you uninstall first?

I also got a clean compile on the older version and the same errors on the Beta.

tcat
Posts: 158
Joined: 02 Feb 2008
Location: Lausanne, Switzerland
Has thanked: 9 times
Been thanked: 4 times

Postby tcat » 07 Jun 2010

I just selected the MC repair process and I was then able to compile.


Return to “MultiCharts”