Entry/Exit arrows not showing after getting filled

Questions about MultiCharts and user contributed studies.
ventus
Posts: 45
Joined: 14 May 2010
Location: NYC
Has thanked: 1 time
Been thanked: 6 times

Entry/Exit arrows not showing after getting filled

Postby ventus » 13 Jan 2011

Ever since I added a study to a chart window, I've been having problems with the entry and exit arrows plotting when an order is filled and even had an order duplicated once. It eventually plots once another order from a different strategy is sent, but when it finally does plot it points to the wrong bar.

On the chart:
Using 1min bars, I have a strategy that submits market orders and an attached study that writes a text file with the entry details (date, time, price, quantity, etc) when a trade occurs.

Any help is greatly appreciated.

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: Entry/Exit arrows not showing after getting filled

Postby Dave Masalov » 19 Jan 2011

Dear ventus,

Could you please be more precise? Do yo experience the issue during backtesting or in real-time, is auto trading on?

ventus
Posts: 45
Joined: 14 May 2010
Location: NYC
Has thanked: 1 time
Been thanked: 6 times

Re: Entry/Exit arrows not showing after getting filled

Postby ventus » 19 Jan 2011

This is in real-time with auto-trading turned on. It seems that fileappend is clashing with the drawing of the arrows since they seem to be trying to execute on the same tick, thus hogging up the cpu. I came up with a solution by delaying writing to a file by a few seconds after a trade has been made, but it still may be worth looking into.

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: Entry/Exit arrows not showing after getting filled

Postby Dave Masalov » 20 Jan 2011

Dear ventus,

Glad to hear that you have found a workaround. I have discussed the issue with the engineers. We will investigate it further.

ventus
Posts: 45
Joined: 14 May 2010
Location: NYC
Has thanked: 1 time
Been thanked: 6 times

Re: Entry/Exit arrows not showing after getting filled

Postby ventus » 20 Jan 2011

Appreciate it as always.


Return to “MultiCharts”