IB symbol AD-NYSE bid & Ask NOT working in ver7  [SOLVED]

Questions about MultiCharts and user contributed studies.
sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 06 Apr 2011

I just checked TWS (standalone version) and quotes ARE coming into TWS but NOT into MC version 7.. the bid and ask are for nyse advancing and declining issues and is VERY important to me..
I deleted the symbol and re-entered it, tried a new chart etc. Just shows "no data"..
Anyone else notice this ?

JackR
Posts: 34
Joined: 28 Jan 2011
Has thanked: 5 times
Been thanked: 9 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby JackR » 06 Apr 2011

sptrader wrote:I just checked TWS (standalone version) and quotes ARE coming into TWS but NOT into MC version 7.. the bid and ask are for nyse advancing and declining issues and is VERY important to me..
I deleted the symbol and re-entered it, tried a new chart etc. Just shows "no data"..
Anyone else notice this ?
What symbol are you using? Did it work in MC 6?
I look at the data in the TWS market scanner but never tried to load in MultiCharts.

Jack

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 06 Apr 2011

Jack: the symbol in IB for advancing issues is AD-NYSE "BID", Declining issues is "ASK". both use the same ad-nyse symbol.
I went back to version MC 6 and it works, so there seems to be a bug with this one symbol for some reason in version 7..

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby Stan Bokov » 07 Apr 2011

sptrader wrote:Jack: the symbol in IB for advancing issues is AD-NYSE "BID", Declining issues is "ASK". both use the same ad-nyse symbol.
I went back to version MC 6 and it works, so there seems to be a bug with this one symbol for some reason in version 7..


Please come to our Live Chat, so we can look at this issue. It may be a bug.

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 07 Apr 2011

Stan: Just enter symbol AD-NYSE and select "bid" or "Ask", neither will work in MC7.
Since I need adv and decl values for trading, I had to go back to Ver6. I don't have ver7 installed on my trading computer, so I can't go to live chat to demonstrate it. It works ok in TWS.
IB tech support verified that the API had it working, so it must be an MC7 issue. Please try it..

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby Stan Bokov » 08 Apr 2011

sptrader wrote:Stan: Just enter symbol AD-NYSE and select "bid" or "Ask", neither will work in MC7.
Since I need adv and decl values for trading, I had to go back to Ver6. I don't have ver7 installed on my trading computer, so I can't go to live chat to demonstrate it. It works ok in TWS.
IB tech support verified that the API had it working, so it must be an MC7 issue. Please try it..


Thanks, we will check it out.

tozwp
Posts: 132
Joined: 15 Apr 2011
Has thanked: 14 times
Been thanked: 6 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby tozwp » 15 Apr 2011

Any updates or has anyone been able to get advance decline data from IB into Multicharts? I too need this critical information. Thanks

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby Stan Bokov » 18 Apr 2011

We must not have the subscription for it - we are seeing nothing in TWS either. Can you come to the Live Chat and show us?
Attachments
ad-nyse.png
ad-nyse.png (48.78 KiB) Viewed 911 times

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 18 Apr 2011

AD-NYSE DOES work now in beta2. (not in beta1)
To make a chart select "ad-nyse" as the instrument and select "bid" or "ask" for advancing and declining issues.
In TWS you have to go to "scanner", then select "market statistics" from the left side, drop down list. It will show all of the nyse stats.
I have ES as data1 and ad-nyse "bid" in data2(hidden) and ad-nyse "ask" as data3 (hidden) - see attached screen shot.
(I added my own indicators to clarify the ratios)

** NOTE: On 4/19 it STOPPED working for me...back to ver6 for now.
Attachments
Adv-Decl.jpg
Adv-Decl.jpg (61.49 KiB) Viewed 922 times
Last edited by sptrader on 19 Apr 2011, edited 1 time in total.

tozwp
Posts: 132
Joined: 15 Apr 2011
Has thanked: 14 times
Been thanked: 6 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby tozwp » 18 Apr 2011

Thanks, beta2 fixed it.

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 19 Apr 2011

** It STOPPED working for me with Beta2 this morning. I had to go back to Ver6.

tekram
Posts: 96
Joined: 26 May 2009
Has thanked: 6 times
Been thanked: 18 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby tekram » 19 Apr 2011

sptrader wrote:** It STOPPED working for me with Beta2 this morning. I had to go back to Ver6.

Same here. AD-NYSE stopped on the first bar. AD-NASD continues okay. MC7beta1.

Image
Attachments
AD_NYSE_MC7b2.gif
AD_NYSE_MC7b2.gif (17.47 KiB) Viewed 1272 times

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 20 Apr 2011

tekram: This issue needs to be looked at by tech support.
Maybe you can go on live chat, so they can see it.
(I can't since I went back to ver6)

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 25 Apr 2011

Has it been fixed in beta3 ?

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby Stan Bokov » 27 Apr 2011

Bug has been confirmed - will be fixed in MC beta 4.

sptrader
Posts: 622
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 388 times
Been thanked: 229 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby sptrader » 27 Apr 2011

Stan Bokov wrote:Bug has been confirmed - will be fixed in MC beta 4.



** Thanks Stan !!! ( I can't run V7 until it's fixed)

FutureTrader
Posts: 79
Joined: 28 Mar 2013
Has thanked: 3 times
Been thanked: 4 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby FutureTrader » 11 Apr 2015

This is actually an old thread, but I wanted to use the advcaning declining data from IB.

Is it possible to get historical data for the following symbols? I tried "ask", "bid" and "trade" in the settings, but it didn't work:
AD-NYSE
VOL-NYSE
AD-NASD
VOl-NASD
AD-AMEX
AD-VOL

If it's working perhaps I'm missing the correct market data subscription, so it would be great if someone could share the correct settings with me.


I get data for the following symbols on field "trade". Historic daily and minute data.
TRIN-NYSE
TRIN-NASD
TRIN-AMEX



[04/11/2015 19:48:00] Data request for AD-NYSE NYSE IND USD 1 Day Ask [ 01/23/2015 09:30:00.000 - 03/10/2015 16:00:00.000 ] (Id= 1001034)
[04/11/2015 19:48:00] TWS error message: Id= 1001034; code= 162; description= Historical Market Data Service error message:No historical market data for AD-NYSE/IND@NYSE Ask 1d
[04/11/2015 19:48:02] Data request for AD-NYSE NYSE IND USD 1 Day Ask [ 01/23/2015 09:30:00.000 - 02/07/2015 16:00:00.000 ] (Id= 1001035)
[04/11/2015 19:48:02] TWS error message: Id= 1001035; code= 162; description= Historical Market Data Service error message:No historical market data for AD-NYSE/IND@NYSE Ask 1d

User avatar
Henry MultiСharts
Posts: 8394
Joined: 25 Aug 2011
Has thanked: 1201 times
Been thanked: 2682 times

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7

Postby Henry MultiСharts » 23 Apr 2015

FutureTrader wrote:Is it possible to get historical data for the following symbols? I tried "ask", "bid" and "trade" in the settings, but it didn't work:
AD-NYSE
VOL-NYSE
AD-NASD
VOl-NASD
AD-AMEX
AD-VOL
Hello FutureTrader,

According to the logs no historical data is provided for these instruments. You may want to double check it with your data provider directly.

FutureTrader
Posts: 79
Joined: 28 Mar 2013
Has thanked: 3 times
Been thanked: 4 times
Contact:

Re: IB symbol AD-NYSE bid & Ask NOT working in ver7  [SOLVED]

Postby FutureTrader » 24 Apr 2015

Henry MultiСharts wrote:According to the logs no historical data is provided for these instruments. You may want to double check it with your data provider directly.



According to Interactive Brokers there are no historical data available. So other traders know it reading here ...
These users thanked the author FutureTrader for the post:
Henry MultiСharts


Return to “MultiCharts”