IB Continuous Contracts stopped working, unable to add 2008

Questions about MultiCharts and user contributed studies.
tekram
Posts: 96
Joined: 26 May 2009
Has thanked: 6 times
Been thanked: 18 times

IB Continuous Contracts stopped working, unable to add 2008

Postby tekram » 16 Apr 2011

IB Continuous Contracts stopped working, unable to add 2008 contracts which are unavailable from IB TWS.

It seems like many continuous contracts using IB feeds are not working both in MC7 beta and MCDT7 beta. You get gaps in data and the charts don't load.
Attachments
2011-04-16_134247.gif
2011-04-16_134247.gif (25.49 KiB) Viewed 160 times

sptrader
Posts: 631
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 394 times
Been thanked: 235 times
Contact:

Re: IB Continuous Contracts stopped working, unable to add 2

Postby sptrader » 16 Apr 2011

I had that problem with beta1 as well. Try creating a new continuous contract- it worked for me.

tekram
Posts: 96
Joined: 26 May 2009
Has thanked: 6 times
Been thanked: 18 times

Re: IB Continuous Contracts stopped working, unable to add 2

Postby tekram » 19 Apr 2011

Thank you. It may be more complicated than that. Some of the old collected data in the expired contracts may be corrupt and that lead to the strange gaps in the data. I tried deleting some data but that didn't fix it.

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: IB Continuous Contracts stopped working, unable to add 2

Postby Stan Bokov » 21 Apr 2011

Do you have the necessary symbols in the QuoteManager? If data is corrupted, you can try reimporting data (or even just random data files) to see if the data is the issue. Let us know what you find.


Return to “MultiCharts”