No data backfill when connecting to Open E Cry

Questions about MultiCharts and user contributed studies.
User avatar
t-rader
Posts: 139
Joined: 02 Feb 2011
Location: Australia
Has thanked: 11 times
Been thanked: 27 times

No data backfill when connecting to Open E Cry

Postby t-rader » 21 Jun 2011

Hi,

In Multicharts I am trying to connect to Open E Cry using my 14 day demo account.
I've set my charts to 1 minute bars and with a data range of 30 days back from today's date. So, what I should expect to see if 30 days worth of 1 minute bars... right? The problem is that I don't. In fact I don't see ANY historical data.

I'm using MC Version 6.2 Release (Build 4338)

Here are my settings in Quote Manager (see attachment)

Can anyone help?

Regards

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: No data backfill when connecting to Open E Cry

Postby Stan Bokov » 21 Jun 2011

Dear t-rader,

These are the latest specs that we have on file from OEC - https://www.multicharts.com/market-data-feeds/.

You should be receiving SOME historical data, and it's strange if you aren't. Please go to File > Preferences > Server mode tab > and make sure you have the ONLINE radio button selected, and the "Download missing historical data" checkbox checked.

Also did not see any attachment. Are you receiving real-time data? You can also check the connection log in the bottom of the QuoteManager, to see what's happening with your connection.

Tresor
Posts: 1104
Joined: 29 Mar 2008
Has thanked: 12 times
Been thanked: 51 times

Re: No data backfill when connecting to Open E Cry

Postby Tresor » 21 Jun 2011

For sure there is no backfill in MC with OEC's forex data, which I reported about two months ago.

User avatar
t-rader
Posts: 139
Joined: 02 Feb 2011
Location: Australia
Has thanked: 11 times
Been thanked: 27 times

Re: No data backfill when connecting to Open E Cry

Postby t-rader » 21 Jun 2011

Hi Stan,

Could you please validate Tresor's comment.
I am also trading forex (eur/usd).
I will check the settings you have suggested when I get home.

Regards

Tresor
Posts: 1104
Joined: 29 Mar 2008
Has thanked: 12 times
Been thanked: 51 times

Re: No data backfill when connecting to Open E Cry

Postby Tresor » 21 Jun 2011

Oops, I reported it 6 months ago. Time flies like an arrow. Last sentence viewtopic.php?f=1&t=7997#p36880

I didn't check OEC's futures data. I only tested forex data at that time.

escamillo
Posts: 197
Joined: 25 Mar 2011
Has thanked: 22 times
Been thanked: 55 times

Re: No data backfill when connecting to Open E Cry

Postby escamillo » 21 Jun 2011

on MC7 i used open e cry on trial for a month about two months ago and was able to get back data for CME futures. did not try anything else.

User avatar
t-rader
Posts: 139
Joined: 02 Feb 2011
Location: Australia
Has thanked: 11 times
Been thanked: 27 times

Re: No data backfill when connecting to Open E Cry

Postby t-rader » 22 Jun 2011

Hi Stan,

I have an update that may either be good or.... not.
I have discovered that I CAN receive backfill data by setting the quote field to TRADE as apposed to BID or ASK.
I had originally set the quote field to BID (as I do with MB trading) and that is why I couldn't see any backfill data (same result with ASK).

This now raises a new question... what does it really mean to have the quote field set to TRADE? My live trading system requires 40 bars of backfill. Should I be using TRADE when trading live???

Regards


Return to “MultiCharts”