Multicharts error upon starting  [SOLVED]

Questions about MultiCharts and user contributed studies.
KamiCrazy

Multicharts error upon starting  [SOLVED]

Postby KamiCrazy » 28 Jun 2011

Hi,

I'm getting an error upon starting Multicharts DT.

Some background info. I am running Windows XP via VMware fusion on a macbook pro. In addition to that my macbook pro is connected to my iphone via tethering. This is my mobile trading setup.

Installation goes through fine but when I run Multicharts DT it gives me an exception and forces me to close Multicharts.

At first I thought the installation was corrupt so I tried again. Then I tried playing around with the virtual network adapter settings.

I was able to bypass the error only by disabling the network adapter in windows and then starting multicharts. Once multicharts has loaded I re-enable the network adapter and then it runs with no problems at all.

I can also bypass this error by "disconnecting" the virtual network adapter within vmware fusion so that windows thinks its ethernet cable is unplugged. Same result, multicharts loads fine and no exception happens.

From what I can surmise Multicharts must be accessing the network adapter to contact an authentication server or something. Something wrong must be happening and then it throws an exception. By disabling the network adapter it must either detect that it cannot contact this server or it is passing messages between the various multicharts exe programs via the loopback adapter instead.

I would greatly appreciate if this could be looked into as I cannot commit to purchasing the full multicharts unless my mobile trading setup is workable.

FYI this is the exception message:


<<EXCEPTION>>
Address: 0x7C812AEB ( 2088839915 )
Code: 0xE06D7363 ( -529697949 )
Continuable: 0x00000001 ( 1 )
ErrorCode: 0xE06D7363 ( -529697949 )
ExceptionType: 0x00000001 ( 1 )
Module: C:\WINDOWS\system32\kernel32.dll
Process: C:\Program Files\TS Support\MultiCharts Discretionary Trader\MultiCharts Discretionary Trader.exe
Thread ID: 0x00000CC8 ( 3272 )
Time: 28.06.2011 - 21:05:53.650


Thanks

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: Multicharts error upon starting

Postby Stan Bokov » 28 Jun 2011

Thank you for reporting. This is strange, since we saw the opposite error with MCDT - it gave an exception if it WASN'T connected to the internet, even though it doesn't need to. MCDT is free, so there is no authentication connections of any sort.

While you describe your setup in detail, some part of the virtual setup could be causing this issue. If you could come to our Live Chat, our QA staff could investigate the exception, and note why exactly it's happening. Also, please mention this thread when you come, so they have some background info.

kamicrazy

Re: Multicharts error upon starting

Postby kamicrazy » 28 Jun 2011

I've been able to isolate the problem further.

The error only appears if I use iphone tethering.

If the virtual machine is accessing the network using os x's wifi then no error upon starting multicharts.

Once I switch os x to use iphone tether rather than wifi and then launch multicharts DT I get the exception.

Note, that NAT vs network bridge has no effect, good or bad.

User avatar
Stan Bokov
Posts: 963
Joined: 18 Dec 2009
Has thanked: 367 times
Been thanked: 300 times

Re: Multicharts error upon starting

Postby Stan Bokov » 29 Jun 2011

Thanks for the update. Now, question is how to reproduce the problem on our end, and address it.


Return to “MultiCharts”