Backtesting assumptions not working for me?  [SOLVED]

Questions about MultiCharts and user contributed studies.
Rick Webber
Posts: 47
Joined: 04 Jan 2008
Has thanked: 21 times
Been thanked: 3 times

Backtesting assumptions not working for me?

Postby Rick Webber » 18 Aug 2011

Format signal/BackTesting/backtesting assumptions/Fill limit order when price goes beyond limit price by 1 points.
The result is a 8 tick Limit price is filled at 9 ticks from the EntryPrice on the chart ! !
It should be filled at 8 ticks on the chart only if price exceeded that limit by a minimum of 1 tick.
Anyone else experiencing this? Bug?

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: Backtesting assumptions not working for me?

Postby Dave Masalov » 25 Aug 2011

Rick,

Currently in the Multicharts the order is filled at current price after excessing limit price on a specified number of points (see attached screenshot). If you would like this feature to be implemented the other way please vote for this feature in our Project management system: https://www.multicharts.com/pm/viewissue ... _no=MC-149

Rick Webber
Posts: 47
Joined: 04 Jan 2008
Has thanked: 21 times
Been thanked: 3 times

Re: Backtesting assumptions not working for me?

Postby Rick Webber » 30 Aug 2011

I don't get it, makes no sense to me. Whats the point of having the feature then?

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: Backtesting assumptions not working for me?

Postby Dave Masalov » 12 Sep 2011

Rick,

This is how it is implemented at the moment. Your feature request has been forwarded to the developers. We will consider it for future implementation.
These users thanked the author Dave Masalov for the post:
Rick Webber

Jayson
Posts: 1
Joined: 08 Aug 2011

Re: Backtesting assumptions not working for me?

Postby Jayson » 02 Jan 2012

The backtesting assumption seems to work as expected when Backtesting Precision is not used.
e.g. With backtesting assumptions "Fill limit order when trade price goes beyond limit price by 1 points" and Backtesting Precision not used.
Once Backtesting Precision is used the signal shows the trade is not taken at the limit price but at limit price + 1. (i.e. not at the specific limit price).
The point of the backtesting assumption is to only allow trades if the market moves pass the limit price to ensure a fill. However with Backtesting Precision turned on you are left with an trade price (limit price + 1) that itself could be subject to a missed fill, as in some instances the market has not moved pass limit price + 1 which is the high or low of the bar.
The correct treatment is for the signal to show the trade at the limit price. This occurs on a tick chart.

User avatar
Andrew MultiCharts
Posts: 1587
Joined: 11 Oct 2011
Has thanked: 931 times
Been thanked: 557 times

Re: Backtesting assumptions not working for me?  [SOLVED]

Postby Andrew MultiCharts » 12 Sep 2014

The behavior of the feature "limit order assumption (when price goes beyond X points) for backtesting" will be improved in future version of MultiCharts. Please keep track of the following feature requests:
These users thanked the author Andrew MultiCharts for the post:
Rick Webber

Rick Webber
Posts: 47
Joined: 04 Jan 2008
Has thanked: 21 times
Been thanked: 3 times

Re: Backtesting assumptions not working for me?

Postby Rick Webber » 16 Sep 2014

Absolutely great news for many. Thanks to MAtricks for your persistence.
These users thanked the author Rick Webber for the post:
MAtricks


Return to “MultiCharts”