charts stopped updating

Questions about MultiCharts and user contributed studies.
O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

charts stopped updating

Postby O66 » 25 Aug 2011

my charts stopped updating while the dom was showing the latest prices without a problem.
is there a way to reconnect charts with datafeed?
i did a complete restart now but that takes some time...
im using mc 7 build 4510

sptrader
Posts: 629
Joined: 09 Apr 2010
Location: Colorado
Has thanked: 394 times
Been thanked: 233 times
Contact:

Re: charts stopped updating

Postby sptrader » 25 Aug 2011

If you're using IB as a datafeed, leave MC on and shutdown and re-start TWS, then it will reconnect...(I don't know about the other datafeeds)

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 25 Aug 2011

thanks. im using zenfire

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 26 Aug 2011

and again.
charts are frozen but dom and quotemanager are receiving data.

see video: http://screencast.com/t/1Amc2XC5Ukn

any ideas?

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: charts stopped updating

Postby Dave Masalov » 26 Aug 2011

O66,

Please install attached update (unzip the archive and run updater.exe, MC and QM should be closed) and send us MC logs as well as rapi.log file for investigation.

You can find log files here "%USERPROFILE%\Local Settings\Application Data\TS Support\MultiCharts\".
You should paste this line in Start --> Run and in the window that will pop up make a zip-folder. Rapi.log file can be found in the folder two levels above MultiCharts logs.

If you are able to reproduce the issue please come to our Live Chat Mon-Fri between 6:30AM and 2PM EST.

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 26 Aug 2011

Thanks Dave, But where can i find the attached update?

User avatar
rrams
Posts: 32
Joined: 10 Feb 2011
Location: Arizona
Has thanked: 2 times
Been thanked: 14 times
Contact:

Re: charts stopped updating

Postby rrams » 26 Aug 2011

Don't be offended by a simple suggestion: check that the chart instrument datasource is set to real time and not history. For some reason Multicharts will default this setting back to history when you go to format instrument instead of leaving it on the current value (real time).

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 26 Aug 2011

thanks,
but my chart stops while im using it already for a few hours.
looks like that it stops on heavy volume

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: charts stopped updating

Postby Dave Masalov » 29 Aug 2011

O66,

Please use the following link to download the update:

http://dl.dropbox.com/u/26968921/ZF_MC7 ... se_log.zip

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 30 Aug 2011

did upgrade yesterday but unfortunately charts stopped again 10 minutes ago.

gmoney
Posts: 16
Joined: 17 Jun 2011
Has thanked: 1 time
Been thanked: 3 times
Contact:

Re: charts stopped updating

Postby gmoney » 06 Sep 2011

My charts have been stopping lately too. Using MB Trading feed. On Monday the charts stopped but QuoteManager continued to receive quotes. Today both charts and QM stopped updating.

In the QM Event Log, today at 12:54:13 (my time, currently PDT) there are two messages:

"MB Trading message: Disconnected form perm server"
"MB Trading message: Connected form perm server"

However, charts and QM quit updating at that time. See screenshot from QM below:
Attachments
Disconnected from perm server.JPG
Disconnected from perm server.JPG (60.12 KiB) Viewed 426 times

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: charts stopped updating

Postby Dave Masalov » 13 Sep 2011

did upgrade yesterday but unfortunately charts stopped again 10 minutes ago.


Does the problem persist? If yes, please send us MultiCharts as well as RAPI log files after reproducing the issue and before restarting MultiCharts. You can find log files here "%USERPROFILE%\Local Settings\Application Data\TS Support\MultiCharts\". You should paste this line in Start --> Run and in the window that will pop up make a zip-folder. RAPI log files are located two levels above MultiCharts logs.

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: charts stopped updating

Postby Dave Masalov » 13 Sep 2011

My charts have been stopping lately too. Using MB Trading feed. On Monday the charts stopped but QuoteManager continued to receive quotes. Today both charts and QM stopped updating.

In the QM Event Log, today at 12:54:13 (my time, currently PDT) there are two messages:

"MB Trading message: Disconnected form perm server"
"MB Trading message: Connected form perm server"

However, charts and QM quit updating at that time. See screenshot from QM below:


gmoney,

Please send us log files after reproducing the issue but before restarting MultiCharts. You can find log files here "%USERPROFILE%\Local Settings\Application Data\TS Support\MultiCharts\". You should paste this line in Start --> Run and in the window that will pop up make a zip-folder.

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 13 Sep 2011

hi, looks like that it is solved.
i had a template which started at 0:00 and stopped at 23:59:59
once i switched to the default 24hr template charts were updating again. no idea what was wrong with template but its working now

thanks

User avatar
Dave Masalov
Posts: 1712
Joined: 16 Apr 2010
Has thanked: 51 times
Been thanked: 485 times

Re: charts stopped updating

Postby Dave Masalov » 13 Sep 2011

i had a template which started at 0:00 and stopped at 23:59:59
once i switched to the default 24hr template charts were updating again. no idea what was wrong with template but its working now


Hello O66,

Glad to hear that the problem has been solved. Was it a default or custom session template?

O66
Posts: 143
Joined: 28 Nov 2006
Location: Netherlands
Has thanked: 2 times
Been thanked: 3 times

Re: charts stopped updating

Postby O66 » 13 Sep 2011


gmoney
Posts: 16
Joined: 17 Jun 2011
Has thanked: 1 time
Been thanked: 3 times
Contact:

Re: charts stopped updating

Postby gmoney » 13 Sep 2011

If it happens again, I will send you the log files.


Return to “MultiCharts”