here we go again

Questions about MultiCharts and user contributed studies.
greenroomhoo
Posts: 62
Joined: 03 Nov 2011
Has thanked: 12 times
Been thanked: 2 times

here we go again

Postby greenroomhoo » 11 Dec 2011

worked on a strat for backtesting. went to optimize - crash - lost strat code no idea why. redid it went to optimize and get the following error - see screen shot.

12-11-2011 9-44-11 AM.png
12-11-2011 9-44-11 AM.png (142.72 KiB) Viewed 176 times


reboot - did not fix it.

thanks for wasting another eight hours of my life MC.

Assume i now need to reload the new beta? Seriously, i am not putting this program through a very rigorous workload and it just fails more than it succeeds (dont even get me started on "portfolio" backtesting.

Will these type of errors be fixed with 64bit?

SP
Posts: 444
Joined: 06 Feb 2006
Has thanked: 36 times
Been thanked: 280 times

Re: here we go again

Postby SP » 11 Dec 2011

It could be a problem with your regional settings:
viewtopic.php?f=1&t=8725&hilit=separator

User avatar
Henry MultiСharts
Posts: 8390
Joined: 25 Aug 2011
Has thanked: 1201 times
Been thanked: 2681 times

Re: here we go again

Postby Henry MultiСharts » 12 Dec 2011

greenroomhoo wrote:worked on a strat for backtesting. went to optimize - crash - lost strat code no idea why. redid it went to optimize and get the following error - see screen shot.

The attachment 12-11-2011 9-44-11 AM.png is no longer available


reboot - did not fix it.

thanks for wasting another eight hours of my life MC.

Assume i now need to reload the new beta? Seriously, i am not putting this program through a very rigorous workload and it just fails more than it succeeds (dont even get me started on "portfolio" backtesting.

Will these type of errors be fixed with 64bit?

Hello Greenroomhoo.
We adress all issues reported by our users.
Each version contains bug fixes and stability improvements.
If you have the issue-please report it to the bug tracker or live chat if you want fast solution for your issue.

Please close Multicharts and all its products (i.e. MC, Quote Manager, PL editor, ....).
Make sure that all MC processes are ended.
In the Windows Task manager check these processes:
atCenterServer.exe
Fixserver.exe
MultiCharts.exe
MessageCenter.exe
PLEditor.exe
QuoteManager.exe
StudyServer.exe
tsServer.exe
TradingServer.exe
TPserver.exe
Please end the processes if they are still running after MC close.

Import the registry key from the attachment.
Then start MultiCharts and try to do the optimization.

If you still have the crash-please install MultiCharts 7.4 beta 2 .
If the problem can be reproduced on this version- please send us the workspace, sample script and inputs for reproducing the issue, MC logs and dumps.

Here's how to find the logs:
1)You can find log files here %USERPROFILE%\Local Settings\Application
Data\TS Support\MultiCharts\
You should paste this line in Start --> Run and in the window that will pop
up make a zip-folder.
alternatively:
2) please click on the Windows Start button-> Programs -> MultiCharts ->
make a right click on Logs-> then click on Properties.
Go to the Shortcut tab and click on "Open file location".
In the appeared window please compress to Zip folder called "Logs".

Download the file and place it to the root of any drive (for ex. drive C:)
http://dl.dropbox.com/u/27918922/Dumper.exe
Please start cmd.exe
input this line
C:\Dumper.exe multicharts.exe
(here you need to input the crashed process)
the dump will be created in this folder:
c:\users\’the user you are currently logged in’
Attachments
NumberOfThreadsOnOptimization.zip
(362 Bytes) Downloaded 82 times


Return to “MultiCharts”