MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Questions about MultiCharts and user contributed studies.
Gaempi
Posts: 32
Joined: 27 Jul 2010
Location: Switzerland
Has thanked: 1 time
Been thanked: 2 times

MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Postby Gaempi » 02 Jan 2012

Hi
I'm working with TS GlobalServer and have updated MC to 7.4 from 7.0. After that the loading of my charts lasts much longer than before. Loading a 30min-chart (range: 16 years back) lasts more than 15 minutes ... yes, one chart! The loading process of the charts is mach longer then before. I don't know why.

Gaempi
Posts: 32
Joined: 27 Jul 2010
Location: Switzerland
Has thanked: 1 time
Been thanked: 2 times

Re: MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Postby Gaempi » 03 Jan 2012

Hello

Can anybody explain, why loading a workspace with 4 charts in MC 7.4 takes more than 30 minutes ... 4 times longer than in MC 7.0 ?

User avatar
Henry MultiСharts
Posts: 8450
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2706 times

Re: MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Postby Henry MultiСharts » 03 Jan 2012

Hello Gaempi.
Please go to Quote manager->Tools->Data sources->Global server->Settings.
Is the option "Save data to local database" enabled?

Gaempi
Posts: 32
Joined: 27 Jul 2010
Location: Switzerland
Has thanked: 1 time
Been thanked: 2 times

Re: MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Postby Gaempi » 04 Jan 2012

Thank you Henry!

The option "Save data to local database" was not enabled. The problem is solved.

skan
Posts: 36
Joined: 15 Jul 2010

Re: MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Postby skan » 10 Jan 2012

All right, this solves the problem after you have downloaded data, after the first time.
But Why is so slow the first time?

If I download data using TS it's very fast
Then the problem is the local MC process on my computer.
Can I tweak something?. Maybe there is a hidden variable that specifies how long MC waits between packets?

User avatar
Henry MultiСharts
Posts: 8450
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2706 times

Re: MC 7.4: Loading a 30min-chart 16 years ... 15 Minutes!

Postby Henry MultiСharts » 11 Jan 2012

skan wrote:All right, this solves the problem after you have downloaded data, after the first time.
But Why is so slow the first time?

If I download data using TS it's very fast
Then the problem is the local MC process on my computer.
Can I tweak something?. Maybe there is a hidden variable that specifies how long MC waits between packets?

In TS please go to View tab->Launch Download Scheduler->Make a right click on the request->Schedule ASAP.


Return to “MultiCharts”