Autotrading switches off after many rejections

Questions about MultiCharts and user contributed studies.
allenlowe
Posts: 37
Joined: 29 Jun 2011
Has thanked: 2 times
Been thanked: 3 times

Autotrading switches off after many rejections

Postby allenlowe » 07 Jan 2012

I didn't download the new multicharts yet. The reason is that I noticed that there is a new feature of autotrading switches off after many rejections. I am not sure I can turn off this feature or not.

The reasons is under my scripts. It is possible to have 30 rejections in a row. Although I am using interactivebrokers, I have usually more than 6 trades a day and therefore it will not be a problem for me even 30 rejections in a row. Is this new feature can be turn off or can set the parameter by myself?

Allen
These users thanked the author allenlowe for the post (total 2):
JoshMSUPER

User avatar
Henry MultiСharts
Posts: 8521
Joined: 25 Aug 2011
Has thanked: 1213 times
Been thanked: 2741 times

Re: Autotrading switches off after many rejections

Postby Henry MultiСharts » 10 Jan 2012

Hello Allen.
This feature was implemented in MultiCharts 7.4 beta 2.
Autotrading now turns off when orders reject more than N times in a row (between 10 and 20 times).
This was created to prevent flooding broker servers with orders.
If this happens, you will see an error message "Automated trading was stopped due to an excessive number of rejected orders."
To set the amount of accepted rejects you need to modify the registry key "ATRejectsLimit" at this path:
HKEY_CURRENT_USER\Software\TS Support\MultiCharts\TraderServer\
You need to set the Decimal value to this DWORD key.
If there is no such key or its value is less or equal to 0, then there is no limitation and this feature is disabled.
These users thanked the author Henry MultiСharts for the post (total 2):
allenloweJoshM

allenlowe
Posts: 37
Joined: 29 Jun 2011
Has thanked: 2 times
Been thanked: 3 times

Re: Autotrading switches off after many rejections

Postby allenlowe » 16 Jan 2012

Hi,

I just install 7.4. However, I cannot find the registry key you mentioned. Does it mean there is no autotradeoff by default? Or something wrong?

allenlowe
Posts: 37
Joined: 29 Jun 2011
Has thanked: 2 times
Been thanked: 3 times

Re: Autotrading switches off after many rejections

Postby allenlowe » 16 Jan 2012

Please ignore my previous post, I find the key after reboot.


Return to “MultiCharts”