Optimization speed is 4 times longer!

Questions about MultiCharts and user contributed studies.
User avatar
Mobiius
Posts: 60
Joined: 11 Mar 2010
Location: Victoria, BC, Canada
Has thanked: 4 times

Optimization speed is 4 times longer!

Postby Mobiius » 19 Jan 2012

Hi,

Just upgraded TS to 9.0 so that may be the issue (I have it set for minimum hardware/network usage).
But, our optimizations on our systems would take about 45 to 50 seconds. They have consistantly been thus for 1.5 years.

Now they take 4 to 5 minutes!

any help?

cheers, Lee.

User avatar
Mobiius
Posts: 60
Joined: 11 Mar 2010
Location: Victoria, BC, Canada
Has thanked: 4 times

Re: Optimization speed is 4 times longer!

Postby Mobiius » 19 Jan 2012

We tested by going back to 8.8 but it still doesnt help. it is still 4X as long as it was last week.

no other changes were made.

Optimization is only using 32% of our CPU and 2G of our 6G of ram.

we have dual 2.8 core, 6 G ram.

We do extensive testing so if we don't get any answers today I'll call in the morning as this is critical.

Cheers,lee.

User avatar
Katrin Yanenko
Posts: 55
Joined: 28 Nov 2011
Has thanked: 18 times
Been thanked: 22 times

Re: Optimization speed is 4 times longer!

Postby Katrin Yanenko » 20 Jan 2012

Hi Lee,

We have several questions for you.
Did your custom signals become4 times longer in MultiChart?

Have you changed anything on your machine? Probably you've installed some new applications, firewall.

Did you change the inputs of your signals?

Does any of your custom signals use *.dll?

What is the data range that you're analyzing?

Please send us an email to support@multicharts.com and describe in a step-by-step way how to reproduce your issue. Also we need your workspace and signals attached to the email in order we could reproduce it on our end.
Is it possible to do?


Best Regards,
Katrin Yanenko

User avatar
Mobiius
Posts: 60
Joined: 11 Mar 2010
Location: Victoria, BC, Canada
Has thanked: 4 times

Re: Optimization speed is 4 times longer!

Postby Mobiius » 20 Jan 2012

I've just sent an email to support.

I'll disable some things to try and figure it out.
Also if some helpful forum people can see the results below and run a similiar test on their computer I'd be grateful. just to prove the times are way to slow so tech support can get on this.

But here's my response anyway:

We have several questions for you.
Did your custom signals become4 times longer in MultiChart? "Yes, and all standard signals as well"

Have you changed anything on your machine? Probably you've installed some new applications, firewall. "TS 9.0 but and as explained we went back to TS 8.8 with the same results."

Did you change the inputs of your signals? "No"

Does any of your custom signals use *.dll? "No"

What is the data range that you're analyzing? "Everything. I set up test chart with the same so you can do your own tests on your side. Chart - @ES (or @ESH12) (TS feed). 100minute chart, 500 days, default session. Signals - RSI LE & SE

Run Optimization test (Exhaustive):
RSI LE - Length - Start 12 - End 39 - Step 3
RSI LE - Oversold - Start 12 - End 39 - Step 3
RSI SE - Length - Start 12 - End 39 - Step 3
RSI SE - Overbought - Start 12 - End 39 - Step 3

Number of simulations = 10,000
Time to run test = !!!!!!!!!! 8.07 MINUTES !!!!!!!!!!! (SHOULD BE 30-45 SECONDS)!!!!!!!!
Computer maximum CPU usage during test = 32% average 18%
Computer maximum Memory Usage = 2 GB

Computer=
Windows 7 - 64 bit
Intel Core i7 930 Quad Core Processor LGA1366 2.8GHZ 8MB L3 Cache
6 Gig DDR3 memory
2 TB Western Digital Raid (used as 1 TB)
"
Please send us an email to support@multicharts.com and describe in a step-by-step way how to reproduce your issue. "Anyone should be able to reproduce the above test."

Also we need your workspace and signals attached to the email in order we could reproduse it on our end." The information above is enough to do your own test."

Is it possible to do? "Done"

Thanks everyone! Lee

User avatar
Mobiius
Posts: 60
Joined: 11 Mar 2010
Location: Victoria, BC, Canada
Has thanked: 4 times

Re: Optimization speed is 4 times longer!

Postby Mobiius » 20 Jan 2012

OK...

Sorry to bother everyone. For some reason our antivirus decided to slow everything down.

I would not have guessed that one day it works for (it worked for 6 months without errors since install) and one day it decides it's going to slow everything down.

Again, I apologize I do not try and waste peoples time.

User avatar
Katrin Yanenko
Posts: 55
Joined: 28 Nov 2011
Has thanked: 18 times
Been thanked: 22 times

Re: Optimization speed is 4 times longer!

Postby Katrin Yanenko » 23 Jan 2012

Dear Lee,


We're glad to hear that everything works fine.
In case you have any questions do not hesitate to ask our support team.
It's always our pleasure to help you.

Best Regards,
Katrin Yanenko


Return to “MultiCharts”