IQ Feeds not Displaying Properly

Questions about MultiCharts and user contributed studies.
bauhinia
Posts: 31
Joined: 08 Sep 2011
Has thanked: 4 times
Been thanked: 2 times

IQ Feeds not Displaying Properly

Postby bauhinia » 09 Feb 2012

Hi All,

I am using IQ Feeds and the data doesn't seem to be feeding through properly when on the autotrading is turned on. I have attached USDJPY as an example - but all ccys pairs are doing this and as you can see the prices are gapping and not correct.

When reloading the data they display properly but it then stops the Auto trading.

Any help would be appreciated as its preventing my models from working.

Cheers
Andrew
Attachments
JPY.png
JPY.png (44.59 KiB) Viewed 165 times

User avatar
Henry MultiСharts
Posts: 8443
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2703 times

Re: IQ Feeds not Displaying Properly

Postby Henry MultiСharts » 10 Feb 2012

Hello Andrew,

Please close Multicharts and all its windows.
Check that all MC processes are ended in Task manager:
MultiCharts.exe
MessageCenter.exe
QuoteManager.exe
tsServer.exe
PLEditor.exe
StudyServer.exe
TradingServer.exe
atCenterServer.exe
TPserver.exe
Fixserver.exe

Unzip the attached archive into a new folder.
Then run the Updater.exe and click on Update.
if the update is installed correctly-the last line will say “Done”.

Please let me know if this solution helped you or not.
Attachments
MC_70.zip
(859.18 KiB) Downloaded 54 times

bauhinia
Posts: 31
Joined: 08 Sep 2011
Has thanked: 4 times
Been thanked: 2 times

Re: IQ Feeds not Displaying Properly

Postby bauhinia » 14 Feb 2012

Hi Henry,
Thanks for this.

However it did not work and bars are still not forming properly.
Could you pls advise what needs to be done to fix this.
Cheers
Andrew

User avatar
Henry MultiСharts
Posts: 8443
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2703 times

Re: IQ Feeds not Displaying Properly

Postby Henry MultiСharts » 15 Feb 2012

Please go to Quote manager->Tools->Exchanges and ECNs.
Make sure exchange settings are the same as the attached screenshot.
The time zone is UTC -5 (Eastern time).

Then make a right click on USDJPY.FXCM symbol in Quote manager-> Edit symbol:
Settings tab-> Make sure "IDEALPRO" exchange is selected
Sessions tab-> Select "Use exchange and ecn sessions"
Click Ok.

In MultiCharts make a right click on the chart->Format instrument->Settings tab->Make sure "Default" session is selected.
Then reload the chart using Ctrl+R.
Now Real time daily bars should be plotted correctly.
Please let me know if this solution helped you or not.
Attachments
IDEALPRO.PNG
IDEALPRO.PNG (20.55 KiB) Viewed 137 times

bauhinia
Posts: 31
Joined: 08 Sep 2011
Has thanked: 4 times
Been thanked: 2 times

Re: IQ Feeds not Displaying Properly

Postby bauhinia » 21 Feb 2012

Hi Henry, still is not working properly. I have noticed however that if charts are set to Local time they seem to have the data correctly displayed.

User avatar
Henry MultiСharts
Posts: 8443
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2703 times

Re: IQ Feeds not Displaying Properly

Postby Henry MultiСharts » 22 Feb 2012

Please let me know the following information:
-Is your PC time zone specified properly
-Are your PC clock correct
-Are you running MultiCharts and IQfeed software under the same user
-Are you running them as administrator
-Do you have an anti virus running
-Are both programs added to the white list of the anti virus

bauhinia
Posts: 31
Joined: 08 Sep 2011
Has thanked: 4 times
Been thanked: 2 times

Re: IQ Feeds not Displaying Properly

Postby bauhinia » 05 Mar 2012

Henry Multicharts wrote:Please let me know the following information:
-Is your PC time zone specified properly YES - Eastern Time US& Canada
-Are your PC clock correct - YES
-Are you running MultiCharts and IQfeed software under the same user - can you clarify this pls
-Are you running them as administrator - YES
-Do you have an anti virus running - NO
-Are both programs added to the white list of the anti virus N/A



Henry - comments above.
Cheers

User avatar
Henry MultiСharts
Posts: 8443
Joined: 25 Aug 2011
Has thanked: 1207 times
Been thanked: 2703 times

Re: IQ Feeds not Displaying Properly

Postby Henry MultiСharts » 06 Mar 2012

Hello Andrew,

Please come to our live chat Monday-Friday 6:30 am - 4 pm EST to demonstrate this behaviour.
We will do our best to help you.


Return to “MultiCharts”